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About this Guide
This guide explains how to upgrade webMethods and Intelligent Business Operations
products from 8.2, 9.0, 9.5, or 9.6 to 9.7.

Document Conventions
Convention

Description

Bold

Identiﬁes elements on a screen.

Narrowfont

Identiﬁes storage locations for services on webMethods
Integration Server, using the convention folder.subfolder:service .

UPPERCASE

Identiﬁes keyboard keys. Keys you must press simultaneously
are joined with a plus sign (+).

Italic

Identiﬁes variables for which you must supply values speciﬁc to
your own situation or environment. Identiﬁes new terms the ﬁrst
time they occur in the text.

Monospace
font

Identiﬁes text you must type or messages displayed by the
system.

{}

Indicates a set of choices from which you must choose one. Type
only the information inside the curly braces. Do not type the { }
symbols.

|

Separates two mutually exclusive choices in a syntax line. Type
one of these choices. Do not type the | symbol.

[]

Indicates one or more options. Type only the information inside
the square brackets. Do not type the [ ] symbols.

...

Indicates that you can type multiple options of the same type.
Type only the information. Do not type the ellipsis (...).
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Documentation Installation
You can download the product documentation using the Software AG Installer. The
documentation is downloaded to a central directory named _documentation in the main
installation directory (SoftwareAG by default).

Online Information
Software AG Documentation Website
You can ﬁnd documentation on the Software AG Documentation website at hp://
documentation.softwareag.com. The site requires Empower credentials. If you do not
have Empower credentials, you must use the TECHcommunity website.
Software AG Empower Product Support Website
You can ﬁnd product information on the Software AG Empower Product Support
website at hps://empower.softwareag.com.
To submit feature/enhancement requests, get information about product availability,
and download products and certiﬁed samples, go to Products.
To get information about ﬁxes and to read early warnings, technical papers, and
knowledge base articles, go to the Knowledge Center.
Software AG TECHcommunity
You can ﬁnd documentation and other technical information on the Software AG
TECHcommunity website at hp://techcommunity.softwareag.com. You can:
Access product documentation, if you have TECHcommunity credentials. If you do
not, you will need to register and specify "Documentation" as an area of interest.
Access articles, demos, and tutorials.
Use the online discussion forums, moderated by Software AG professionals, to
ask questions, discuss best practices, and learn how other customers are using
Software AG technology.
Link to external websites that discuss open standards and web technology.
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Upgrade Overview
This guide explains how to upgrade webMethods and Intelligent Business Operations
products from 8.2, 9.0, 9.5, or 9.6 to 9.7 using a side-by-side procedure. The tasks in the
procedure are required for all releases unless speciﬁcally noted as being required for a
certain release only.
You can only upgrade a product from its latest release. For example, if the latest release
of a product in product suite 8.2 was 8.2 SP2, you can only upgrade that product from
8.2 SP2.
If you want to upgrade to 9.7 from a release prior to 8.2, see the Supported Upgrade Paths
document.

Release Numbering
In most cases, products follow the product suite numbering. Exceptions are as follows:
9.6 upgrade: In product suite 9.7, the webMethods Broker release is still 9.6 and is the
same release that was available with product suite 9.6.
8.2 upgrade: In product suite 8.2, the OneData release was 8.4. You can upgrade from
that release.
9.6 upgrade: In product suite 9.6, the Presto release was 3.7. You can upgrade from
that release to the release in product suite 9.7, which is 3.8.
In product suite 9.7, the Terracoa release is 4.1.4. You can upgrade to that release.

Terms Used in this Chapter
For simplicity, this guide uses these terms:
For most products, the product suite releases from which you can upgrade are
referred to as 8.2, 9.0, 9.5, or 9.6. However, you can upgrade to 9.7 only from the
latest release of each 8.2, 9.0, 9.5, or 9.6 product.
The product suite release to which you can upgrade is referred to as 9.7. However,
the instructions in this guide are for upgrading to the latest release of each 9.7
product.

Guides Needed to Perform Upgrades
You will always need the guides listed below to perform this procedure.
Using the Software AG Installer (October 2014 release)
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Installing webMethods and Intelligent Business Operations Products9.7
Using the Software AG Update Manager
Depending on the products you are upgrading, you might need the 9.7 guides and other
guides listed below to perform this procedure.
webMethods BPM Task Development Help
Using Blaze Rules with BPM and CAF
CentraSite documentation
webMethods Deployer User’s Guide
webMethods Integration Server Administrator’s Guide, webMethods Service Development
Help, and webMethods Integration Server Clustering Guide
Administering webMethods Optimize and Conﬁguring BAM
Presto documentation
Geing Started with the webMethods Product Suite and Terracoa and Terracoa
BigMemory Max documentation

Requirements and Recommendations
You must upgrade products and migrate data in the order the instructions are
presented in this guide. If you do not follow the prescribed order, you will
experience unpredictable results.
Software AG strongly recommends that you upgrade in a controlled test
environment and test that environment for proper operation before upgrading your
production environment.
Software AG tests migration across machines that have the same hardware and
operating systems. Integration Server also tests migration across machines that have
diﬀerent hardware or diﬀerent operating systems. However, for other products,
migration across machines that have diﬀerent hardware or operating systems might
have unpredictable results, especially when one machine is Windows and the other
UNIX.

Upgrades Not Covered in This Guide
If you want to upgrade to 9.7 from a release prior to 8.2, see the Supported Upgrade
Paths document.
If you want to upgrade ApplinX, see the 9.7 product documentation.
If you want to upgrade Content Service Platform, contact Software AGGlobal
Consulting Services.
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If you want to upgrade MashZone or Process Performance Manager, see the 9.7
product documentation.
The procedure for upgrading Mobile Administrator explains how to upgrade an
installation on a physical machine. If you want to upgrade an installation on a virtual
machine, uninstall Mobile Administrator from the virtual machine and install the 9.7
release. For instructions, see Installing webMethods and Intelligent Business Operations
Products9.7.
If you want to upgrade Mobile Designer, you can use an automatic update option.
For instructions, see the Mobile Designer 9.7 documentation.
If you want to upgrade Presto from releases prior to 9.6, see the 9.7 product
documentation.
The procedure for upgrading Terracoa explains how to upgrade a Terracoa
Server Array that has a single server or a mirror group consisting of an active server
and a mirror server. For all other setups, see the Terracoa BigMemory Max 4.1
documentation.
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Overview
This chapter explains how to upgrade products in product suite 8.2, 9.0, 9.5, or 9.6 to 9.7
using a side-by-side procedure. For some products, you must perform additional tasks
to complete the upgrade or to migrate data. Subsequent chapters provide instructions
for those tasks.

Before You Install 9.7 Products
This section provides information to consider before installing the indicated products.

9.6 Upgrade: Before You Install webMethods Broker
In product suite 9.7, the webMethods Broker release is still 9.6 and is the same release
that was available with product suite 9.6.
If the existing webMethods Broker 9.6 from the 9.6 release is installed on its own
machine, you can continue using it with your 9.7 products.
If you want to upgrade to a machine that is running a diﬀerent operating system or
has diﬀerent hardware than the old machine, or if you want webMethods Broker to
exist with other 9.7 products in the same installation directory, install webMethods
Broker 9.6 from the 9.7 release. You can install webMethods Broker 9.6 on a machine
that is running the same or higher operating system and has the same hardware (for
example, both have AMD, or both have Intel) as the old machine.
In both cases, make sure to follow the appropriate instructions in "Create Broker Server
9.6 and Use the Old Storage" on page 50 after completing the instructions in this
chapter.
Broker Server 9.6 is compatible with webMethods Broker 9.5, 9.0, and 8.2 command-line
utilities; Broker client APIs for C, C#, Java, and JMS; and clients for JMS. Broker Server
9.5, 9.0, and 8.2 are compatible with webMethods Broker 9.6 command-line utilities,
Broker client APIs for C, C#, and Java; and the webMethods Broker user interface in My
webMethods.

Before You Install CentraSite
If you want to install the CentraSite Application Server Tier and CentraSite Registry
Repository on diﬀerent machines, or in the same directory but at diﬀerent times, you
must install the Registry Repository ﬁrst.
If you install CentraSite 9.7 on the same machine as the old CentraSite, you will not be
able later to run both products at the same time, even if they use diﬀerent ports, because
of conﬂicts for IPC and shared memory resources.
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Before You Install Integration Server
If you are going to upgrade a cluster of Integration Servers, Software AG recommends
the procedure below.

1. Install a matching set of 9.7 Integration Servers. For example, if you have a cluster of three
old Integration Servers named IS1_old, IS2_old, and IS3_old, with an external load balancer
to distribute client requests, install IS1_new, IS2_new, and IS3_new.

2. Perform the steps in "Prepare OneData " on page 23 for each Integration Server in the
cluster.

3. Shut down IS1_old.
4. Migrate IS1_old data to IS1_new and customize the IS1_new startup files using the

instructions in "Completing the Integration Server and Hosted Products Upgrade" on
page 59.

5. Shut down IS2_old and IS3_old.
6. Do the following for IS1_new:
a. Start IS1_new.
b. If IS1_old was not configured to use a Terracotta-based clustering solution, configure
IS1_new to use a Terracotta-based clustering solution. Make sure IS1_new is processing
client requests. For instructions, see webMethods Integration Server Clustering
Guide9.7.
Important: Support for Coherence was discontinued in release 9.0.
c. Update WSDLs, connect functions to database components, and set up central user
management on IS_new as described in "Completing the Integration Server and
Hosted Products Upgrade" on page 59.

7. Repeat steps 4 and 6 for IS2_new and then for IS3_new.

Before You Install My webMethods Server
For your old release, you might have identiﬁed a default My webMethods Server
installation in the global path of the installation’s host machine using the environment
variable WM_HOME. If you are going to install the new release on the same machine as
the old release, the existence of this variable could cause problems, so you must remove
the environment variable from the global path.
Do not redeﬁne the environment variable after installing My webMethods Server 9.7.
The My webMethods Server migration utility allows you to migrate speciﬁc server
instances within the old My webMethods Server installation to the new My webMethods
Server installation. You only need to install one My webMethods Server 9.7 on each
machine in the cluster.
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Install the 9.7 Products
If you are installing on the same machine as your old release, the installer often allows
you to assign ports used by an old product to the new product as well, even if the old
product is running. Assigning the same ports means you will not need to edit port
values in assets and clients when you begin using the new release.
Follow the instructions in Using the Software AG Installer (October 2014 release) and
Installing webMethods and Intelligent Business Operations Products9.7 to install your new
products, with the additional guidelines below.
1. For installation directory, specify a new Software AG installation directory.
2. On the product tree, select the 9.7 products to install. Also select Database
Conﬁguration and Update Manager.
Note: In product suite 8.2, the Blaze design tool is Blaze Advisor. In 9.0, it is a Blaze
plug-in to Software AG Designer. In 9.5 and 9.6, for compatibility reasons, the Blaze
plug-ins are delivered in a self-contained workbench that is based on Eclipse 3.6 and
is separate from Software AG Designer 9.5, 9.6, and 9.7, which are based on Eclipse
4.3.
3. For the product panels, follow the instructions in Installing webMethods and Intelligent
Business Operations Products9.7, with the additional guidelines below.
Product

Guidelines

ActiveTransfer
Server

Point the database connection at the ActiveTransfer database
component you want to use with ActiveTransfer Server 9.7.

webMethods
Broker

Choose to not create a Broker Server conﬁguration.

Integration
Server

Point the database connection at the ISInternal database
component you want to use with Integration Server 9.7.

My
webMethods
Server

Choose to not create a My webMethods Server instance.

OneData

Enter the values you noted earlier for port, repository ID, and
repository name, and database component connection. Make

Note: You will migrate old server instances later in this
procedure. You will also migrate the My webMethodsServer
database component you want to use with My webMethods
Server 9.7, then point to that database component later in this
procedure.
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Product

Guidelines
sure the database connections point to the OneData database
components you want to use with OneData 9.7.
Note: Reusing port values means that Web service clients of the
old OneData will not have to change URLs to access OneData
9.7.

Trading
Networks

Point the database connection at the TradingNetworks
database component you want to use with Trading Networks
9.7.

Universal
Messaging

Enter the name that matches the name of a server instance
in the old Universal Messaging installation and bind to that
server instance’s IP address and port. Point the data directory
to a location in the new installation (that is, do not point to
the old data directory).
Note: If you accept the default location for the data directory,
it will be migrated automatically later. If you use a diﬀerent
location, you will have to migrate it manually.

4. After installation is complete, if you installed on a Windows system, and you
installed products as Windows services, the default startup for the services is
Automatic. Set the services to Manual. If you installed on a UNIX system, and you
have scripts that automatically start daemons, disable the scripts.
5. 9.6 upgrade: Installing webMethods and Intelligent Business Operations Products9.7
explains that you can create additional Integration Server instances after installation.
However, you can also have the Integration Server migration utility create 9.7
instances for you from the old instances (see "Overview" on page 60).
Important: Do not start any 9.7 products at this point, or before migrating database
components or data. Do not start 9.7 products before the instructions in this guide tell
you to do so, or your database components could become corrupted.

Prepare the Old Environment for Upgrade
Prepare Databases
Some products, like CentraSite, Monitor, Optimize, and Trading Networks, oﬀer
features to archive or purge data from product database components. You can reduce
the amount of time needed to back up and migrate the product database components by
archiving or purging them ﬁrst.
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Apply Fixes to Products
Apply the latest ﬁxes to the old CentraSite, the old Optimize, and the old Infrastructure
Data Collector using the Software AG Update Manager. For instructions, see Using the
Software AG Update Manager. After you apply a ﬁx to a product, start the product.

8.2 Upgrade: Prepare webMethods Broker
In release 8.2 SP1 and SP2, webMethods Broker and Deployer stored Broker assets in
XML format. Starting in release 9.0, webMethods Broker and Deployer began storing
Broker assets in ADL format. You must use webMethods Broker 8.2 SP3 and Deployer
8.2 to migrate the assets from XML format to ADL format. For instructions on using
Deployer in the steps below, see webMethods Deployer User’s Guide8.2.

1. If the assets are available only in the source .xml files and do not exist in webMethods Broker
8.2 SP3, use Deployer 8.2 to deploy the assets from the source .xml files to webMethods
Broker 8.2 SP3.

2. Update the My webMethods Messaging user interface to 8.2 SP3. Go to the old_Software
AG_directory \MWS\bin directory and run this command:
mws -s server_instance update -Dcomponents.overwrite=true

3. Export the assets to ADL format as follows:
a. In My webMethods Messaging user interface 8.2 SP3, go to the Administration >
Messaging > Broker Servers > Servers page and click the Broker Server from which to
export assets.
b. Click the Brokers tab, and then click the Broker from which to export assets. If the
Broker does not appear in the list, use the search functionality to locate it.
c. On the Broker Details page, click the Export to File tab, select the assets to export, and
then click Export to File.

4. Start the Software AG Installer and install Infrastructure > Libraries > Broker and JMS

Libraries 8.2 SP3 in the installation directory that contains Deployer 8.2 and Asset Build
Environment 8.2.

5. Use Deployer 8.2 to build the assets in ADL format for repository-based deployment. For
instructions, see building assets for deployment in Administering webMethods Broker9.6
and webMethods Deployer User’s Guide9.7.

Prepare CentraSite
1. If you changed settings for CentraSite Control from their defaults, note those settings so you
can make the same changes in the new CentraSite installation.

2. 8.2 upgrade: The metamodel that defines the internal structure of ApplinX object types
changed in release 9.0 and is not compatible with the old metamodel. CentraSite 9.7 does
not support the use of object type instances that are based on the old ApplinX object types.
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CentraSite 9.7 does not allow ApplinX object types or instances from old product releases
to be imported, and there is no procedure to migrate old instances to the new metamodel. If
you want to use ApplinX object type instances from the old product release in CentraSite 9.7,
you will have to manually re-create the instances after you install CentraSite 9.7. Note the
definitions of all your ApplinX object type instances.

Prepare Software AG Designer
Export Integration Server Definitions
1. In the old Software AG Designer, go to Window > Preferences. On the Preferences
dialog box, in the left navigation bar, go to Software AG > Integration Servers.
2. Click Export and complete the dialog box. Software AG Designer will save the ﬁle
with the extension .properties.

Export CloudStreams Server Definitions and Projects
1. In the old Software AG Designer, go to the CloudStreams Development perspective.
2. To export CloudStreams Server definitions, go to Window > Preferences. On the Preferences
dialog box, in the left navigation bar, go to Software AG > CloudStreams Servers. Click
Export and complete the dialog box. Software AG Designer will save the file with the
extension .properties.

3. Open the CloudStreams Development perspective. In the CloudStreams Governance list,

right-click CloudStreamsGovernance projects to export, click Export, and complete the dialog
box.

4. Repeat the previous step to export CloudStreams Provider projects.

Export Event Bus Console Configurations
1. In the old Software AG Designer, open the File > Export wizard. In the Select panel, go
to Run/Debug > Launch Configurations and click Next.
2. In the tree, select the Event Bus Console conﬁgurations. In the Location ﬁeld, specify
the directory to which to export. Software AG Designer will save each ﬁle with the
extension .launch.

Export Preferences
If you want to migrate your preferences to Software AG Designer 9.7, you export them
from the old Software AG Designer and then import them into Software AG Designer
9.7. To export the preferences, do the following:
1. In the old Software AG Designer, open the File > Export wizard. In the Select panel, go
to General > Preferences and click Next.
2. In the To preference file ﬁeld, specify the name of the ﬁle to which to export your
preferences. Software AG Designer will save the ﬁle with the extension .epf.
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Prepare Integration Server
1. If you are using webMethods Broker, shut down the new Broker Monitor if it is running.
Restart the old Broker Monitor, and then start the old Broker Server.

2. Start the old Integration Server.
3. Suspend document retrieval for all triggers and make sure all guaranteed messages have
finished processing, as follows:
a. Open Integration Server Administrator and point to the old Integration Server.
b. Go to Packages > Management. Click View Locked Elements, click Unlock Elements,
select all elements of triggers, and then click Unlock Selected Elements.
c. 8.2 or 9.0 upgrade: Go to the Settings > Messaging > Broker/Local Trigger Management
page. In the Individual Trigger Controls area, in the Active column under Document
Retrieval, click edit all and set Retrieval State to Suspended. Refresh the page until the
Persisted Queue Counts field shows 0 for every trigger.
d. 9.5 or 9.6 upgrade: Go to the Settings > Messaging > webMethods Trigger Management
page. In the Individual Trigger Controls area, in the Active column under Document
Retrieval, click edit all and set Retrieval State to Suspended. Refresh the page until the
Current Queue Counts field shows 0 for every trigger.

4. If you are using webMethods Broker, make sure all outbound Broker messages in the client
side queue have been sent, as follows:
a. Make sure Integration Server is connected to the Broker.
b. 8.2, 9.0, or 9.5 upgrade: Go to the Settings > Resources > Store Settings page. In the
Outbound Document Store area, make sure the Current Documents in Outbound Store
field shows 0.
c. 9.6 upgrade: Go to the Settings > Messaging > webMethods Messaging Settings page.
Make sure the CSQ Count field shows 0 for the Broker connection alias.
Note: The CSQ Count ﬁeld contains the same information as the Current Documents
in Outbound Store ﬁeld on the Settings > Resources > Store Settings page. You need
only check the CSQ Count ﬁeld.

5. 9.6 upgrade: If you are using Universal Messaging, make sure all outbound Universal
Messaging messages in the client side queue have been sent, as follows:
a. Make sure Integration Server is connected to each Universal Messaging server that is
acting as a webMethods messaging provider.
b. Go to the Settings > Messaging > webMethods Messaging Settings page. Make sure the
CSQ Count field shows 0 for the Universal Messaging connection aliases.

6. Make sure all outbound JMS messages in the client side queue have been sent, as follows:
a. Make sure Integration Server is connected to the JMS providers.
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b. Go to the Settings > Messaging > JMS Settings page. In the JMS Connection Alias
Definitions area, make sure the CSQ Count field shows 0 for every JMS connection alias.

7. If you are going to upgrade business processes, and you have business process models that
use volatile transition documents and process instances of those models are in a Started state,
allow the Started processes instances to complete or suspend them before you upgrade.
Important: If you do not allow Started process instances to complete or suspend
before you upgrade, you could lose data.
Note: Started process instances of models that use guaranteed transition documents
do not have to complete or be suspended before you upgrade.

Prepare OneData
1. In the old OneData, go to the Home > Administer > Job Center page. On the Filter page,
for each job type, ﬁlter by Active or Pending Active. If a job has one of these statuses,
terminate the job or wait for it to complete.
2. In the ﬁle system, go to the old_Software AG_directory \proﬁles\ODE\conﬁguration
\tomcat\conf directory and open the context.xml ﬁle. Note the connection preﬁx
located at the beginning of the schema user name (for example, in the metadata
schema user name dev2_md, the connection preﬁx is dev2). Also note the database
connection parameters for the metadata, work area, and release area database
schemas.
3. Note the port numbers, as follows:
a. 8.4 upgrade: Go to the old_Software AG_directory \proﬁles\ODE\conﬁguration
\tomcat\conf directory and open the server.xml ﬁle. Note the HTTP and HTTPS
port numbers in the port aribute of the Default CTP HTTP Connector and
Default CTP HTTPS Connector ﬁles, respectively.
b. 9.0, 9.5, or 9.6 upgrade: Go to the old_Software AG_directory \proﬁles\ODE
\conﬁguration\com.softwareag.platform.conﬁg.propsloader director.
Open the com.softwareag.catalina.connector.hp.pid-port .properties and
com.softwareag.catalina.connector.hps.pid-port .properties ﬁles and note the
port numbers.

Prepare Optimize
1. If you want to reuse your Central Configuration System (CCS) Environment definition,
export the environment to an XML file. In My webMethods, go to the Administration
> System-Wide > Environments > Define Environments page. Select the check box next
to the environment, click Export, and provide a file name and location for the exported
environment.
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2. 8.2 upgrade: If you have Integration Servers that are clustered using Oracle Coherence, you
will reconfigure them later in this guide to use a Terracotta-based clustering solution instead.
Prepare for this change as follows:
a. If you are monitoring the clustered Integration Servers, stop monitoring them.
b. If you have KPIs for the clustered Integration Servers, go to the Applications >
Administration > Analytics > Infrastructure Components > Monitored Components page. In
the Monitored Components list, click IS Cluster. Note the KPIs listed in the Selected KPIs
box, delete the KPIs, and then click Save.
Note: KPI data that was gathered from the clustered Integration Servers will not
be available in Optimize 9.7.

3. If you want to cluster Analytic Engines in the new installation, you will need a Terracotta
Server Array. For planning information, see Geing Started with the webMethods
Product Suite and Terracoa9.7, Conﬁguring BAM9.7, and the Terracotta
BigMemory Max 4.1 documentation.

Shut Down the Old Products
Shut down your old products. For a UNIX system, use the instructions in the product
documentation for your old release. For a Windows system:
Products running
as...

Shut down from...

Services

Windows Services window. Services are listed as Software
AG product release.

Applications

Windows Start menu. Applications are listed as Software AG >
Stop Servers > product.

If you are upgrading CentraSite, and the old and new CentraSite are on the same
machine:
8.2 upgrade: Shut down all old Application Server Tiers by stopping the CentraSite
Apache and Tomcat Server services.
9.0 or 9.5 upgrade: Shut down all old Application Server Tiers by stopping the
Software AG Runtime services.
Shut down the old Registry Repository by stopping its service.
If you are upgrading EntireX, also shut down all Brokers, RPC Servers, and customer
applications that use EntireX libraries. See the instructions in the product documentation
for your old release.
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If you are upgrading Mobile Administrator, stop it by running the command /etc/
init.d/appfresh-mobile stop

If you are upgrading a cluster of My webMethods Servers, shut down all cluster nodes.
A cluster is deﬁned as multiple nodes that point to the same MywebMethodsServer
database component. Nodes can be My webMethods Server installations on diﬀerent
machines or server instances within a single My webMethods Server installation.

Migrate Database Components
Back Up the RDBMSs
Back up the RDBMSs that contain your database components using the vendor
instructions for your RDBMS.
If you are upgrading My webMethods Server, back up the My webMethods Server
installation directory at the same time you back up the MywebMethodsServer database
component. If you have problems, you will need data from the backup to restore the
database.

Upgrade the RDBMSs
Check your RDBMSs against webMethods and Intelligent Business Operations System
Requirements9.7. If the RDBMS version you are using is not supported by your 9.7
products, you must upgrade to a supported RDBMS version before you continue with
the instructions in this chapter.

Shut Down Products that Connect to Database Components
If you have not already done so, shut down all old Integration Server, My webMethods
Server, OneData, Optimize, and Presto instances that connect to database components.

Before You Migrate Trading Networks Database Components
1. Use your data editor to delete all data from the ARCHIVE_WORKTABLE table in the
TradingNetworksArchive database component.

2. If you created custom indexes for your Trading Networks database components, check
whether those custom indexes conflict with indexes that will be created when you run the
Trading Networks migration scripts in the next step. If so, drop the custom indexes. The
migration scripts are located in the 9.7_Software AG_directory \common\db\scripts
\RDBMS \tradingnetworks\migrate directory, under the directories listed below.
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Old Release

Directories

8.2

\39_40, 40_to_45, and 45_to_50

9.0

\40_to_45 and 45_to_50

9.5 or 9.6

\45_to_50

Special Considerations for Migrating Other Database Components
If you are using business processes, you have stored information about in-progress,
completed, or failed business process instances. This stored information is called
business process run-time data. If you do not want to ﬁnish running in-progress process
instances or resubmit completed or failed process instances from your old installation in
product suite 9.7, do not migrate your business process run-time data (see table below).
If you are using Optimize with a DB2 RDBMS, there are special considerations for the
URL you specify on the database component migration command. You must do the
following:
Specify the schema name in the URL using all capital leers.
Specify the options CreateDefaultPackage=true,ReplacePackage=true, and
DynamicSections=3000. These seings will aﬀect all database components in the
same schema or database.

Apply Fixes to Database Scripts
Apply the latest ﬁx to the old database scripts using the Software AG Update Manager.
The names for database script ﬁxes follow the convention DC_9.7_DBS_Fixn . For
instructions on applying ﬁxes, see Using the Software AG Update Manager.

Database Component Names
Database component names you might use in the migration command are as follows:
If you are migrating this
data...

Specify these database_component values

ActiveTransfer Server

ActiveTransfer

Business process runtime

ProcessAudit, ProcessEngine, Archive,
Staging, Reporting
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If you are migrating this
data...

Specify these database_component values

Business rules

BusinessRules

Integration Server

ISInternal, ISCoreAudit, CrossReference,
DocumentHistory, DistributedLocking

My webMethods Server

MywebMethodsServer

OneData

OneDataMetadata, OneDataReleaseArea,
OneDataWorkArea

Optimize

Analysis, ProcessTracker, ProcessAudit,
DataPurge

Trading Networks

TradingNetworks, TradingNetworksArchive

Migrate Database Components
Important: After you migrate database components to 9.7, you can no longer use them
with your old environment.
On the machine on which you installed Database Conﬁguration 9.7, open a command
window, go to the 9.7_Software AG_directory \common\db\bin directory, and migrate
database components by running the commands below. After you run each command,
check the log ﬁle dcc_yyyymmddhhmmss in the 9.7_Software AG_directory \common\db
\logs directory.
If you want to migrate all your database components, run this command:
dbConfigurator.{bat|sh} -a migrate -d {oracle|sqlserver|db2luw} -c all
-v latest -l db_server_URL -u existing_db_user -p password

If you are using an Oracle or DB2 RDBMS, and you are not using the default
tablespace, also specify the -tsdata data_tspace_name and -tsindex index_tspace_name
parameters.
Note: Since you most likely do not have all database components (because you do not
have all products in the product suite), you will see messages in the log ﬁle that say
migration failed for the database components you do not have. You can ignore these
messages.
If you do not want to migrate all your database components, run this command for
each database component you need to migrate:
dbConfigurator.{bat|sh} -a migrate -d {oracle|sqlserver|db2luw}
-c database_component_name -v latest -l db_server_URL -u existing_db_user
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-p password

Complete the Side-by-Side Upgrade
To complete the side-by-side upgrade procedure, perform the steps in the productspeciﬁc chapters that follow. For many products, the steps you perform in these chapters
include running a migration utility that automatically migrates data from the old
installation to the new installation. The section below describes the general behavior of
the migration utilities. Any exceptions to the general behavior are noted in the productspeciﬁc chapters.

Migration Utilities
Some migration utilities for some products run without prompting you for any
information. Migration utilities for other products ask you to select the data to migrate,
and oﬀer these options:
You can run a custom migration, in which you select the data to migrate. The utility
gathers your seings through a series of prompts, then migrates the selected data.
You can export your seings and use them in other upgrades.
You can run a migration with imported seings. The imported seings can come
from seings you exported from a custom migration, or from the default migration
provided with the product installation. The seings for default migrations are
described in the product-speciﬁc chapters.
Note: When you run migration utilities, you provide the full path to the old installation,
and sometimes the path to the 9.7 installation. If you supplied a symbolic link as the
installation directory when you installed the old or 9.7 product, the path you provide
to the migration utility must be the same symbolic link path you supplied during
installation.
If a migration utility fails to migrate a piece of data, the utility asks whether to continue
with the next piece of data or abort the migration. If you choose to abort, the utility exits.
The utility does not revert the 9.7 product installation. You can address the issue and
rerun the utility.
Migration utilities write detailed migration information to the command window and
to the migrationLog.txt ﬁle in the 9.7_Software AG_directory \install\logs directory.
By default, utilities write INFO, ERROR, and FATAL messages to the log. If you
want to increase the logging level for a product’s migration to DEBUG, go to the
product directory that contains the log4j.properties ﬁle (for example, the 9.7_Software
AG_directory \product \bin\migrate or \migrate\bin directory), open the ﬁle in a text
editor, set the log4j.logger.Migration property to DEBUG, MigrationFile, and save
and close the ﬁle.

Upgrading webMethods and Intelligent Business Operations Products Version 9.7

28

M

Odd Header
Upgrading Products to the New Release

Use of Zip File as Source of Data to Migrate
If your old and new installations for a product are on diﬀerent machines, migration
utilities can use a Zip ﬁle of the old product installation as the source of the data to
migrate for all products except My webMethods Server. (For My webMethods Server,
see the instructions at the end of this section.)
The instructions below use the Java Archive tool to create the Zip ﬁle. Specify the
location of the Java Archive tool in the JAVA_HOME and PATH system variables on
the machine that hosts the old product installation. The tool is located in the Software
AG_directory \jvm\jvm\bin directory.
Note: On some systems, the lower-level jvm directory name includes additional
information, such as \jvm\jvm160_32, or \jvm\jvm170, or \jvm\jvm_64.
To create the Zip ﬁle for a product, go to the product’s old machine, open a command
window, and go to the directory indicated in the table below. You might need to go to
C:\old_Software AG_directory or /opt/old_Software AG_directory , or to C:\old_Software
AG_directory\product_name or /opt/old_Software AG_directory/product_name . The table
indicates which is necessary.
Enter the command indicated in the table. If multiple commands are listed, use the same
Zip ﬁle name in each command.
Product

Go to this directory...

Run this command...

Command
Central

Software AG
directory for
old Command
Central

jar cfM Zip_file_name.zip common\conf
jar
ufM Zip_file_name.zip profiles\CCE
jar
ufM Zip_file_name.zip install
\products

EDA/NERV

Software AG
directory for old
EDA/NERV

jar cfM Zip_file_name.zip install
\products jar
ufM Zip_file_name.zip common\conf
jar
ufM Zip_file_name.zip common
\EventTypeStore
jar
ufM Zip_file_name.zip common\nerv
\bundles

Note: The common\nerv\bundles directory
will exist only if you deployed NERV
bundles in the old release.
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Product

Go to this directory...

Run this command...
If you deployed NERV bundles or the
Event Type Store to non-default locations,
add the bundles to the Zip ﬁle to preserve
the ﬁle structure shown in the commands
above.

8.2 or 9.0
upgrade:
Infrastructure

Software AG
directory for old
Software AG
Runtime

jar cfM Zip_file_name.zip common
\conf install\products profiles\CTP

Infrastructure
Data
Collector

Old
Infrastructure
Data Collector
directory

jar cfM Zip_file_name.zip common
\conf install\products profiles
\InfraDC

Integration
Server

Old Integration
Server directory

jar cfM Zip_file_name.zip *

OneData

Software AG
directory for old
OneData

jar cfM Zip_file_name.zip profiles/
ODE/bin/onedata/config/*

9.6 upgrade:
Platform
Manager

Software AG
directory for
old Platform
Manager

jar cfM Zip_file_name.zip common\conf
jar
ufM Zip_file_name.zip profiles\SPM
jar
ufM Zip_file_name.zip install
\products

Universal
Messaging

Old Universal
Messaging
directory

jar cfM Zip_file_name.zip server
lib

Note: You might see the message proﬁles
\CTP: no such ﬁle or directory. You can
ignore this message.

Copy the product’s Zip ﬁle to any directory on the 9.7 machine that hosts the product.
Use the binary ﬁle transfer mode/type when copying. If you use another mode/type, the
Zip ﬁle might become corrupted.
My webMethods Server does not support the use of a Zip ﬁle. For My webMethods
Server, do one of the following:
Map a drive on the 9.7 machine to the old machine.
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Copy the old_Software AG_directory \MWS directory and the old_Software
AG_directory \install\products directory to the 9.7 machine, and recreate the old
directory structure. For example, if the old directory structure was C:\SoftwareAG
\MWS and C:\SoftwareAG\install\products, you could create the directory
structure C:\oldMWS\MWS and C:\oldMWS\install\products on the 9.7 machine.
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Overview
Infrastructure components are automatically installed with many products. If you
cannot ﬁnd ﬁles that are referenced in the sections in this chapter, your products did
not require those infrastructure components, and those steps are not necessary for your
upgrade.
Important: The instructions in this chapter might tell you to run the Infrastructure
migration utility. The migration utility supports migration from a Windows system
to another Windows system, and from a UNIX system to another UNIX system that
is using a JVM from the same vendor. The utility does not support migration from
any operating system to a diﬀerent operating system (for example, does not support
Windows system to a UNIX system, or vice versa). For a list of systems supported by
the 9.7 release of webMethods and Intelligent Business Operations, see the webMethods
and Intelligent Business Operations System Requirements.

Before Migrating Data
Make sure all products in the old and new installations are shut down.

8.2 Upgrade: Complete the Infrastructure Upgrade
Overview
Infrastructure components are automatically installed with many products. If you
cannot ﬁnd ﬁles that are referenced in the sections in this chapter, your products did
not require those infrastructure components, and those steps are not necessary for your
upgrade.
You complete the infrastructure upgrade by:
Applying the latest ﬁxes to the 9.7 Infrastructure.
Running the Infrastructure migration utility. The utility migrates the following:
The infrastructure conﬁguration.
If present, the Software AG Runtime conﬁguration.
Port and JAAS conﬁgurations, and the user repository.
Manually migrating other conﬁgurations and customizations.
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Apply Fixes
Apply the latest ﬁxes to the 9.7 Infrastructure. The ﬁx names will look like
wMFix.OSGI.Migration. For instructions, see Using the Software AG Update Manager.

Run the Infrastructure Migration Utility
Follow the instructions in "Run the Infrastructure Migration Utility" on page 36,
except use migrate822sbs.dat instead of migrate901sbs.dat in the commands.

Manually Migrate Configurations and Customizations
Follow the instructions in "Manually Migrate Conﬁgurations and Customizations" on
page 36, except do not update ﬁles for debug, security authorization, security LDAP,
single sign-on service, and watchdog conﬁgurations.
In the copied axis2.xml ﬁle, remove or comment out the transportReceiver
element whose name aribute is http and the transportReceiver
element whose name aribute is https. Add the parameter <parameter
name="enableSoapValidation">true</parameter> above the rest of the parameters
in the ﬁle.

Update Paths in Configuration Files
Update paths in the conﬁguration ﬁle listed below to point to the 9.7 installation instead
of the old installation.
Configuration

File Name in 9.7 Software AG Directory

Journal
logger

\proﬁles\CTP\conﬁguration\logging\log_conﬁg.xml

9.0 Upgrade: Complete the Infrastructure Upgrade
Overview
Infrastructure components are automatically installed with many products. If you
cannot ﬁnd ﬁles that are referenced in the sections in this chapter, your products did
not require those infrastructure components, and those steps are not necessary for your
upgrade.
You complete the infrastructure upgrade by:
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Applying the latest ﬁxes to the 9.7 Infrastructure.
Running the Infrastructure migration utility. The utility migrates the following:
The infrastructure conﬁguration.
If present, the Software AG Runtime conﬁguration.
Port and JAAS conﬁgurations, and the user repository.
Manually migrating other conﬁgurations and customizations.
Updating paths in conﬁguration ﬁles.

Apply Fixes
Apply the latest ﬁxes to the 9.7 Infrastructure. The ﬁx names will look like
wMFix.OSGI.Migration. For instructions, see Using the Software AG Update Manager.

Run the Infrastructure Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28.
The Infrastructure migration utility runs without prompting you for any information. If
an error occurs, the utility exits.

1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \common\migrate\osgi\bin directory, and run this command:
migrate.{bat|sh} {-srcDir|-srcFile} full_path_to_{old_Software
AG_directory|Zip_file} -destDirfull_path_to_9.7_Software
AG_directory -importFile 9.7_SoftwareAG_directory\common\migrate\osgi
\bin\migrate901sbs.dat -silent
true

2. If you see a Software AG_directory \profiles\CTP directory in both the old and the 9.7
installation directories, go to the 9.7_Software AG_directory \profiles\CTP\bin\migrate
directory and run this command:
migrate.{bat|sh} {-srcDir|-srcFile} full_path_to_{old_Software
AG_directory|Zip_file} -destDirfull_path_to_9.7_Software
AG_directory -importFile 9.7_SoftwareAG_directory\profiles\CTP \bin
\migrate\migrate901sbs.dat -silent
true

Manually Migrate Configurations and Customizations
1. If you customized the old Software AG Runtime Java Service Wrapper, copy the
customizations from the old wrapper_conf or custom_wrapper.conf files to the 9.7
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custom_wrapper.conf file. The files are located in the Software AG_directory \profiles\CTP
\configuration directory.

2. Migrate the HTTP and HTTPS ports for System Management Hub. For each case below,
open the file in the indicated directory in the old installation and in the 9.7 installation. If any
values in the two files are different, copy the old value over the 9.7 value.
File Name in Old and 9.7 Software AG Directories
\proﬁles\CTP\workspace\webapps\smh\index.html
\proﬁles\CTP\workspace\webapps\smh\login.htm
\InstanceManager\smh\login.htm
Note: If the InstanceManager directory does not exist in both the old and 9.7
directory, ignore this step.

3. For each type of configuration below, copy the file from the indicated directory in the old
installation to the same directory in the 9.7 installation.
Configuration

File Name in Old and 9.7 Software AG Directories

Password
manager

\proﬁles\CTP\conﬁguration\security\passman
\defaultPassStore.dat and mpw.dat

Web
Services
Stack

\proﬁles\CTP\workspace\wsstack\repository\conf
\axis2.xml
Open the copied axis2.xml ﬁle and add the parameter

<parameter name="enableSoapValidation">true</
parameter> above the rest of the parameters in the ﬁle.

4. For each case below, open the file in the indicated directory in the old installation and in the
9.7 installation. If any values in the two files are different, copy the old value over the 9.7
value.
Configuration

File Name in Old and 9.7 Software AG Directories

Debug

\proﬁles\CTP\conﬁguration
\com.softwareag.platform.conﬁg.propsloader
\com.softwareag.platform.debug.properties

Security
authorization

same directory \com.softwareag.security.authz.pid.properties
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Configuration

File Name in Old and 9.7 Software AG Directories

Security
LDAP

same directory \com.softwareag.security.ldap.pid.properties

Single
sign-on
service

same directory \com.softwareag.sso.pid.properties

Watchdog

same directory \com.softwareag.conﬁg.watchdog.pid.properties

Password
manager

\proﬁles\CTP\conﬁguration\security\passman
\scPassMan.conﬁg.xml

Update Paths
Update paths in the ﬁles listed below to point to the 9.7 installation instead of the old
installation.
Configuration

File Name in 9.7 Software AG Directory

Journal logger

\proﬁles\CTP\conﬁguration\logging\log_conﬁg.xml

NERV

\proﬁles\CTP\conﬁguration
\com.softwareag.platform.conﬁg.propsloader
\com.softwareag.platform.eda.nerv.properties
Make sure the JMS provider references point to your 9.7 JMS
provider and the ﬁle system paths point to the 9.7 installation.
If they do not, update them.

Security
authorization

\proﬁles\CTP\conﬁguration
\com.softwareag.platform.conﬁg.propsloader
\com.softwareag.security.authz.pid.properties
If the shiro property is set to a value that is relative to
the Software AG directory (that is, the value begins with
a forward slash (/)), replace the value with the URL token
osgi.configuration.area, which points to 9.7_Software
AG_directory \proﬁles\CTP\conﬁguration directory. The
property is shown below with its default value for 9.7.
shiro=@url\:osgi.configuration.area/shiro.ini

Single sign-on
service

\common\conf\keystore.jks and platform_truststore.jks
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Configuration

File Name in 9.7 Software AG Directory
If a com.softwareag.security.idp property is set to a
value that is relative to the Software AG directory (that is, the
value begins with a forward slash (/)), replace the value with
the path token sag.install.area, which points to the root
Software AG 9.7 directory, or osgi.configuration.area,
which points to the 9.7_Software AG_directory \proﬁles\CTP
\conﬁguration directory. The properties are shown below with
their default values for 9.7.
com.softwareag.security.idp.keystore.location=@path
\:sag.install.area/common/conf/keystore.jks
com.softwareag.security.idp.truststore.location=@path
\:sag.install.area/common/conf/
platform_truststore.jks
com.softwareag.security.idp.ehcache.location=@path
\:osgi.configuration.area/ehcachesin.xml

9.5 or 9.6 Upgrade: Complete the Infrastructure Upgrade
Overview
Infrastructure components are automatically installed with many products. If you
cannot ﬁnd ﬁles that are referenced in the sections in this chapter, your products did
not require those infrastructure components, and those steps are not necessary for your
upgrade.
You complete the infrastructure upgrade by:
Migrating port conﬁgurations.
Migrating other conﬁgurations and customizations.
Updating paths in conﬁguration ﬁles.

Migrate Port Configurations
1. Migrate your HTTP port configurations as follows:
a. Go to the old_Software AG_directory \profiles\CTP\configuration
\com.softwareag.platform.config.propsloader directory. If you see a single
com.softwareag.catalina.connector.http.pid-port .properties file, open that file. If you see
multiple files with that name, open the file that specifies the port you want to designate as
the default port in 9.7.
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b. Go to the same directory in the 9.7 installation and open the
com.softwareag.catalina.connector.http.pid-port .properties file.
c. If any values in the two files are different, copy the old value over the 9.7 value.
d. Check for additional com.softwareag.catalina.connector.http.pid-port .properties files for
HTTP ports in the above-mentioned old directory. Copy all such files to the 9.7 directory
and then add these elements to each copied file:
alias=unique_identifier. This Software AG-speciﬁc aribute uniquely

identiﬁes each connector when you view its conﬁguration in the Platform
Manager. The alias for the default HTTP connector you set up above is
defaultHp. You could use that alias as a base, and add a unique suﬃx
to create the alias for each additional connector (alias=defaultHttp2,
alias=defaultHttp3, and so on).

enabled=true. This Software AG-speciﬁc aribute and value are required for

this connector to be started.

2. Repeat the previous step to migrate your HTTPS port configurations, but use
the com.softwareag.catalina.connector.https.pid-port .properties file, and add
alias=defaultHttps to the default HTTPS connector.

3. Migrate your JMX port configurations. Open the
com.softwareag.jmx.connector.pid-port .properties files in the old and 9.7 Software
AG_directory \profiles\CTP\configuration\com.softwareag.platform.config.propsloader
directories. If any values in the two files are different, copy the old value over the 9.7 value.

Migrate Other Configurations and Customizations
1. If you customized the old Software AG Runtime Java Service Wrapper, copy the
customizations from the old wrapper_conf or custom_wrapper.conf files to the 9.7
custom_wrapper.conf file. The files are located in the Software AG_directory \profiles\CTP
\configuration directory.

2. Migrate the HTTP and HTTPS ports for System Management Hub. For each case below,
open the file in the indicated directory in the old installation and in the 9.7 installation. If any
values in the two files are different, copy the old value over the 9.7 value.
File Name in Old and 9.7 Software AG Directories
\proﬁles\CTP\workspace\webapps\smh\index.html
\proﬁles\CTP\workspace\webapps\smh\login.htm
\InstanceManager\smh\login.htm
Note: If the InstanceManager directory does not exist in both the old and 9.7
directory, ignore this step.
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3. For each type of configuration below, copy the file from the indicated directory in the old
installation to the same directory in the 9.7 installation.
Configuration

File Name in Old and 9.7 Software AG Directories

JAAS

\proﬁles\CTP\conﬁguration\jaas.conﬁg

Password
manager

\proﬁles\CTP\conﬁguration\security\passman
\defaultPassStore.dat and mpw.dat

Single signon service

\common\conf\keystore.jks and platform_truststore.jks

User
repository

\common\conf\users.txt, roles.txt, and groups.txt

Web Services
Stack

\proﬁles\CTP\workspace\wsstack\repository\conf
\axis2.xml

9.5 upgrade: In the copied axis2.xml ﬁle, add the parameter <parameter
name="enableSoapValidation">true</parameter> above the rest of the
parameters in the ﬁle.

4. For each case below, open the file in the indicated directory in the old installation and in the
9.7 installation. If any values in the two files are different, copy the old value over the 9.7
value.
Configuration

File Name in Old and 9.7 Software AG Directories

Debug

\proﬁles\CTP\conﬁguration
\com.softwareag.platform.conﬁg.propsloader
\com.softwareag.platform.debug.properties

Security
authorization

same directory \com.softwareag.security.authz.pid.properties

Security
LDAP

same directory \com.softwareag.security.ldap.pid.properties

Single signon service

same directory \com.softwareag.sso.pid.properties

SSH

same directory \com.softwareag.sshd.pid.properties
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Configuration

File Name in Old and 9.7 Software AG Directories

Watchdog

same
directory \com.softwareag.conﬁg.watchdog.pid.properties

Journal
logger

\proﬁles\CTP\conﬁguration\logging\log_conﬁg.xml

Password
manager

\proﬁles\CTP\conﬁguration\security\passman
\scPassMan.conﬁg.xml

Update Paths
Update paths in the ﬁles listed below to point to the 9.7 installation instead of the old
installation.
Configuration

File Name in 9.7 Software AG Directory

HTTPS ports

\proﬁles\CTP\conﬁguration
\com.softwareag.platform.conﬁg.prop sloader
\com.softwareag.catalina.connector.hps.pid-port.properties

JMX port

same
directory \com.softwareag.jmx.connector.pidport.properties

NERV

same directory \com.softwareag.platform.eda.nerv.properties
Update JMS provider references to point to your 9.7 JMS
provider. Update ﬁle system paths to point to the 9.7
installation.
Open the same ﬁle in the old installation. If any values in
the two ﬁles other than the path values mentioned above are
diﬀerent, copy the old value over the 9.7 value.

Security
authorization

same directory \com.softwareag.security.authz.pid.properties
If the shiro property is set to a value that is relative to
the Software AG directory (that is, the value begins with
a forward slash (/)), replace the value with the URL token
osgi.configuration.area, which points to 9.7_Software
AG_directory \proﬁles\CTP\conﬁguration directory. The
property is shown below with its default value for 9.7.
shiro=@url\:osgi.configuration.area/shiro.ini
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Configuration

File Name in 9.7 Software AG Directory

JAAS

\jaas.conﬁg

Journal logger

\proﬁles\CTP\conﬁguration\logging\log_conﬁg.xml

Single sign-on
service

\common\conf\keystore.jks and platform_truststore.jks
If a com.softwareag.security.idp property is set to a
value that is relative to the Software AG directory (that is, the
value begins with a forward slash (/)), replace the value with
the path token sag.install.area, which points to the root
Software AG 9.7 directory, or osgi.configuration.area,
which points to the 9.7_Software AG_directory \proﬁles\CTP
\conﬁguration directory. The properties are shown below with
their default values for 9.7.
com.softwareag.security.idp.keystore.location=@path
\:sag.install.area/common/conf/keystore.jks
com.softwareag.security.idp.truststore.location=@path
\:sag.install.area/common/conf/
platform_truststore.jks
com.softwareag.security.idp.ehcache.location=@path
\:osgi.configuration.area/ehcachesin.xml
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Complete the EDA/NERV Upgrade
Overview
You complete the upgrade of your event driven architecture by running the EDA/NERV
migration utility. The utility migrates the following:
9.0, 9.5, or 9.6 upgrade: Software AG Designer Event Bus Console connection
conﬁgurations that use NERV.
9.0, 9.5, or 9.6 upgrade: NERV conﬁguration bundles, if you deployed any.
Event Type Store.

Run the EDA/NERV Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28. The EDA/NERV migration utility runs without prompting you for any information.
If an error occurs, the utility exits.
On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \common\migrate\EDA\bin directory and run this command:
migrate.{bat|sh}
{-srcDir|-srcFile} full_path_to_{old_Software AG_directory|Zip_file}
-destDir full_path_to_9.7_Software AG_directory
-importFile 9.7_Software AG_directory \common\migrate\EDA
\bin\migrate{822|901|951|960}sbs.dat
-silent true

Update Paths
Go to the 9.7_Software AG_directory \common\conf directory and open the
com.softwareag.eda.nerv.properties ﬁle. Verify that the JMS provider references point to
your 9.7 JMS provider and the update ﬁle system paths to point to the 9.7 installation. If
they do not, update them.

Complete the Terracotta Upgrade
The old Terracoa license key and tc-conﬁg.xml ﬁle are not compatible with the
Terracoa 4.1.4 release. Make sure you follow the instructions in Geing Started with the
webMethods Product Suite and Terracoa to install the 4.1.4 license key and tc-conﬁg.xml
ﬁle.
The procedures below explain how to complete the upgrade for a pre-4.1.4 Terracoa
Server Array that has a single server or a mirror group consisting of an active server
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and a mirror server. For all other setups, see the Terracoa BigMemory Max 4.1
documentation.
If you have a single server, shut down your old Terracoa Server Array and start the
4.1.4 Terracoa Server Array.
If you have a mirror group consisting of an active server and a mirror server, shut
down the old mirror server and then shut down the old active server. Start active
server 4.1.4 and then start mirror server 4.1.4.

Complete the Universal Messaging Upgrade
Overview
You complete the Universal Messaging upgrade by:
Running the Universal Messaging migration utility. When you install Universal
Messaging, the installer creates a default server instance named umserver. After
installing the old Universal Messaging, you might have created additional server
instances. The migration utility migrates the data for the default server. Then,
for each user-created server instance in the old installation, the utility creates a
corresponding server instance in the 9.7 installation and migrates the old instance’s
data directory and license ﬁle to the 9.7 installation.
Manually migrating custom changes in conﬁguration ﬁles.
If the old data directory, license ﬁle, or both for a server instance was not in the
default location, the migration utility will not migrate them. You will have to
manually migrate them to the 9.7 server instance.

Before Migrating Data
Make sure all old Universal Messaging server instances are shut down. If any server
instances are running in the 9.7 installation (for example, the default server instance
umserver), make sure those are shut down as well.

Run the Universal Messaging Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28. The Universal Messaging migration utility does not oﬀer a default migration.

Perform a Custom Migration
1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \UniversalMessaging\tools\migrate directory, and run the command
migrate.{bat|sh}.

2. The utility asks for the full path to one of the following:

Upgrading webMethods and Intelligent Business Operations Products Version 9.7

47

M

Even Header
Complete the EDA/NERV, Terracotta, and Messaging Upgrades

The old Universal Messaging installation (for example, C:\old_Software
AG_directory \UniversalMessaging or /opt/old_Software AG_directory /
UniversalMessaging).
The Zip ﬁle you made earlier.

3. The utility asks whether to import migration settings. Enter N.
4. The utility asks whether to migrate each old server instance. If the utility cannot determine
whether the instance was running as an application or service, it asks for that information as
well.
If the data directory or license ﬁle for an old server instance is not in the default
location (Software AG_directory \UniversalMessaging\server\server_instance \data
and Software AG_directory \UniversalMessaging\server\server_instance ,
respectively), or the utility cannot determine where the data directory or license
ﬁle is located, you will have to migrate them manually after the migration utility
ﬁnishes, as explained later in this procedure.
If a server instance already exists in the 9.7 installation, the utility does the following:
If the 9.7 instance has the same name as an old instance, the utility asks whether
to migrate the old instance over the 9.7 instance. If you enter Y, the utility
backs up the 9.7 instance to the 9.7_Software AG_directory \UniversalMessaging
\migrationbackup directory before migrating the old instance.
If the 9.7 instance has a diﬀerent name than any of the old instances, the utility
ignores the 9.7 instance.

5. The utility asks whether to export your settings. If you want to perform other migrations by
importing the settings from this session, enter Y. If not, enter N.

Migrate Using Imported Settings
Imported seings come from seings you exported from a custom migration.
These seings are stored in a ﬁle named migrate.dat in the 9.7_Software
AG_directory \UniversalMessaging\tools\migrate directory from which you ran the
custom migration. Copy the migrate.dat ﬁle to any directory on machines that host
Universal Messaging 9.7 installations to which you want to migrate data.
Migrating Using Imported Settings with Prompting

1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \UniversalMessaging\tools\migrate directory, and run the command
migrate.{bat|sh}.

2. The utility asks for the full path to the old Universal Messaging installation or to the Zip file
you made earlier.

3. The utility asks whether to import migration settings. Enter Y and, when prompted, provide
the full path to the migrate.dat file.
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Migrate Using Imported Settings without Prompting
On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \UniversalMessaging\tools\migrate directory, and run the command
below. If an error occurs, the utility exits.
migrate.{bat|sh}
{-srcDir|-srcFile} full_path_to_{old_Universal Messaging_directory|Zip_file}
-importFile full_path_to_ migrate.dat -silent true

Migrate Custom Changes, Data Directory, and License File
1. If you made any custom changes to the nserver.conf or nserverdaemon.conf file for an old
server instance, make the same changes to the same file for the corresponding 9.7 server
instance.

2. If the old data directory for a server instance was not in the default location, copy it from the
old server instance to the 9.7 server instance. The default location for the data directory is the
9.7_Software AG_directory \UniversalMessaging\server\server_instance \data directory.
Then do the following:
To run server instance
as...

Edit this file to point to the new (copied) data directory...

Application

New server instance’s nserver.conf ﬁle

Service

New server instance’s nserverdaemon.conf ﬁle

3. If the old license file for a server instance was not in the default location, copy it from the
old server instance to the 9.7 server instance. The default location for the file is the Software
AG_directory \UniversalMessaging\server\server_instance directory.

Complete the webMethods Broker Upgrade
Overview
8.2 upgrade: Migrate Broker assets from XML format to ADL format, and then follow
the instructions in "Create Broker Server 9.6 and Use the Old Storage" on page 50.
9.0 or 9.5 upgrade: Follow the instructions in "Create Broker Server 9.6 and Use the Old
Storage" on page 50.
9.6 upgrade: If you continued using your webMethods Broker 9.6 from the 9.6 release,
point your Broker clients, including Integration Server 9.7, to the old webMethods
Broker 9.6 installation. If you installed webMethods Broker 9.6 from the 9.7 release,
follow the instructions in "Create Broker Server 9.6 and Use the Old Storage" on page
50.
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If you installed webMethods Broker 9.6 on a machine that is running a diﬀerent
operating system or has diﬀerent hardware than the old machine, or on an IBM System
z machine that is running SUSE Linux Enterprise Server or Red Hat Enterprise Linux,
create new storage and then migrate Broker Server conﬁguration information from the
old storage to the new storage using the webMethods Broker export/import utilities. For
instructions, see Administering webMethods Broker9.6.

8.2 Upgrade: Migrate Broker Assets from XML Format to ADL Format
In "8.2 Upgrade: Prepare webMethods Broker " on page 20, you migrated Broker
assets from XML format to ADL format. Now use Deployer 9.7 to deploy the assets to
webMethods Broker 9.6. For instructions on using Deployer 9.7, see webMethods Deployer
User’s Guide9.7.

Create Broker Server 9.6 and Use the Old Storage
1. Back up the old data directory.
2. Go to the old_Software AG_directory \Broker\bin directory and back up the old
awbrokermon.cfg file.

3. Stop the old Broker Server, go to the old_Software AG_directory \Broker\bin directory,
and run this command:
server_config remove full_path_to_old_data_directory

When asked whether to remove the Broker Server from the Broker Monitor
conﬁguration, enter Y.

4. If you need to copy the data directory to a new location (for example, because the old and
new webMethods Broker installations are on different machines), do the following:
a. Copy the old data directory to the new location. If any storage files were located outside
the data directory (for example, .stor and .data files), also copy those files.
b. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \Broker\bin directory, and run the command below. If you also copied old
storage files, specify the qs_map_file parameter for each file.
server_config relocate full_path_to_new_data_directory
[-qs_map_file full_path_to_old_file full_path_to_new_file ]

5. Create a Broker Server 9.6. On the 9.7 machine, open a command window, go to the
9.7_Software AG_directory \Broker\bin directory, and run the command below. Broker
Server 9.6 details are automatically added to the Broker Monitor 9.6 startup configuration.
Make sure the host name and port number for Broker Server 9.6 are the same as they were for
the old Broker Server.
server_config add full_path_to_old_data_directory -k 9.6_license_file
-p old_release_port

Note: If you are migrating on multi-home machines, and the command fails due to a
port binding error, see "Migrate on Multi-Home Machines" on page 51.
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6. Make sure Broker Server 9.6 is running as follows:
System

Steps

Windows

a. Open the Windows Services window and make sure the status
of the Software AG Broker Server 9.6(port ) service is Started.
b. Right-click the service and click Properties. Make sure the Path to
Executable ﬁeld points to the awbroker ﬁle for 9.6.

UNIX

a. Run the command ps -ef | grep awbroker, which prints
all running Broker processes including the path to the
executable. Make sure the output text shows a line like this:

full_path_to_9.7_Software AG_directory/Broker/bin/
awbroker -d full_path_to_old_data_directory

b. Make sure the awbroker process is running and that it is
running from the 9.6 awbroker ﬁle.

Migrate on Multi-Home Machines
If you are migrating from and to multi-home machines (that is, machines that have
multiple network interfaces and IP addresses), the Brokerserver_config add
command will disregard the migrated Broker Server seings from the old release, ignore
speciﬁc IP bindings, and try to bind to the IP address 0.0.0.0. If the command fails due to
a port binding error, follow the steps below.

1. Go to the 9.7_Software AG_directory /Broker/bin directory, open the awbrokermon.cfg
file, and add the entries below.
server-6849.datadir=full_path_to_data_directory
server-6849.exec=Software AG_directory /Broker/bin/awbroker
server-6849.version=9.6
server-6849.port=6849

2. Go to the 9.7_Software AG_directory /Broker/data/awbrokerrelease_number /default
directory, open the awbroker.cfg file, and add the entries below.
executable=Software AG_directory /Broker/bin/awbroker
version=9.6

3. Start the Broker Monitor and use the broker_status command to make sure the Broker Server
is running and contains history statistics.
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Overview
You complete the My webMethods Server upgrade by:
Running the My webMethods Server migration utility. The utility migrates server
instances within the old installation to the new installation.
Starting My webMethods Server.
Updating host names.

Before Migrating Data
Make sure the old My webMethods Server is shut down.
If you are upgrading a cluster of My webMethods Servers, make sure all cluster nodes
are shut down before migrating data for any My webMethods Server in the cluster.
A cluster is deﬁned as multiple nodes that point to the same MywebMethodsServer
database component. Nodes can be My webMethods Server installations on diﬀerent
machines or server instances within a single My webMethods Server installation.

Run the My webMethods Server Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28. Exceptions:
The My webMethods Server migration utility does not oﬀer a default migration.
You cannot use a Zip ﬁle of the old product installation as the source of the data to
migrate.
The log4j.properties ﬁle for My webMethods Server is located in the 9.7_Software
AG_directory \MWS\bin\migrate\resources directory.

Perform a Custom Migration
1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \MWS\bin\migrate directory, and run the command migrate.{bat|sh}.
2. The utility asks for the full path to the old My webMethods Server installation (for example,
C:\old_Software AG_directory \MWS or /opt/old_Software AG_directory /MWS).
3. The utility asks whether to import migration settings. Enter N.
4. The utility asks about migrating server instances. If the installation has multiple server
instances, the utility will ask separately about each instance.
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a. The utility asks whether to migrate a server instance in the old My webMethods Server
installation. Enter Y.
b. If the server instance name already exists in the My webMethods Server 9.7 installation
directory, the utility asks whether to delete the 9.7 server instance so migration of the old
server instance can proceed. Enter Y.
c. The utility asks for the MywebMethodsServer database component to use with the
migrated server instance. If you choose to use a copy of the production database, the
utility prompts for the database URL, user name, and password.
Note: You cannot use a new database that contains no data.

5. The utility asks whether to export your settings from this session. If you want to perform
other migrations by importing the settings from this session, enter Y. If not, enter N.

6. The utility asks whether to begin migration. If you enter Y, the utility migrates the data you
selected. If migration completes successfully, the utility also does the following:
Deletes old conﬁguration ﬁles that are not used by My webMethods Server 9.7,
and deletes old properties that are not used by My webMethods Server 9.7 from
the 9.7 conﬁguration ﬁles.
If the old My webMethods Server used the embedded database, copies the
database tables from the old My webMethods Server to My webMethods Server
9.7 and converts the tables to the new format.

7. 8.2 upgrade: If you are using CAF, and you added custom Jetty settings to the 8.2 mwsweb.xml file for one or more CAF applications, the migration utility migrated those files.
However, the schema and the name of the WebAppContext class in those files changed
starting in 9.0, so you must manually migrate your custom Jetty settings.
For each CAF application, open the 8.2 mws-web.xml ﬁle and the 9.7 jey-mws.xml
ﬁle in the 8.2 and 9.7 WEB-INF directories. Copy the 8.2 custom Jey seings to
the Jey section of the 9.7 ﬁle. Then conﬁgure the copied seings using the new
schema and the name of the WebAppContext class format. The following example
shows how the Jey seing maxFormContentSize was conﬁgured in 8.2, and how it
should be conﬁgured in 9.7. The format for the rest of the custom Jey seings will
be similar.
Sample conﬁguration seing in My webMethods Server 8.2:
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE Configure PUBLIC "-//Mort Bay Consulting//DTD Configure//EN"
"http://jetty.mortbay.org/configure.dtd">
<Configure class="com.webmethods.portal.webapp.jetty6.MwsWebAppContext">
<Set name="maxFormContentSize">500000</Set>
</Configure>

Sample conﬁguration seing in My webMethods Server 9.7:
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE Configure PUBLIC "-//Jetty//Configure//EN"
"http://www.eclipse.org/jetty/configure.dtd">
<Configure class="org.eclipse.jetty.webapp.WebAppContext">
<Set name="maxFormContentSize">500000</Set>
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</Configure>

Migrate Using Imported Settings
Imported seings come from seings you exported from a custom migration. These
seings are stored in a ﬁle named migrate.dat in the 9.7_Software AG_directory \MWS
\bin\migrate directory. Copy the migrate.dat ﬁle to any directory on machines that host
My webMethods Server 9.7 installations to which you want to migrate data.

Migrate Using Imported Settings with Prompting
1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \MWS\bin\migrate directory, and run the command migrate.{bat|sh}.
2. The utility asks for the full path to the old My webMethods Server installation.
3. The utility asks whether to import migration settings. Enter Y and, when prompted, provide
the full path to the migrate.dat file.

Migrate Using Imported Settings without Prompting
On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \MWS\bin\migrate directory, and run the command below. If an error
occurs, the utility exits.
migrate.{bat|sh}
-srcDir full_path_to_old_My
webMethods Server_directory
-importFile full_path_to_ migrate.dat
-silent true

Migrate the My webMethods Server Infrastructure
Follow the steps below for each server instance.

1. Migrate your JMX port configurations. Open the
com.softwareag.jmx.connector.pidport.properties files in the old and 9.7
SoftwareAG_directory \profiles\MWS_instance_name \configuration
\com.softwareag.platform.config.propsloader directories. If any values in the two files are
different, copy the old value over the 9.7 value.

2. If you customized the old My webMethods Server Java Service Wrapper, copy the
customizations from the old wrapper_conf or custom_wrapper.conf files to the 9.7
custom_wrapper.conf file. The files are located in the SoftwareAG_directory \profiles
\MWS_instance_name \configuration directory.
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Initialize My webMethods Server
Initialize My webMethods Server 9.7 by going to the 9.7_Software AG_directory \MWS
\bin directory and running the command mws.{bat|sh} -s instance_name init.
The 9.7 components are deployed, and then My webMethods Server shuts down
automatically. Restart My webMethods Server.

Update Host Names
If the old and new My webMethods Server installations are on diﬀerent machines, verify
the host names for the new installation as follows:

1. Log on to My webMethods Server 9.7 as Administrator and go to the Administration > My
webMethods> Cluster Settings > Advanced Web and Cluster Configuration for MWS page.

2. If the host name is not correct in the Host field for each cluster node and in the MWS Front
End URL field for all nodes, update the host names.

3. Go to the Cluster Status and Control page and restart all cluster nodes.
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Overview
You complete the Integration Server upgrade by:
Running the Integration Server migration utility. The utility migrates:
Custom and user-deﬁned packages, conﬁguration ﬁles, and, starting in 9.5,
custom jar ﬁles.
If the old Integration Server hosted products (for example, Trading Networks)
and those products also exist on Integration Server 9.7, the utility migrates data
for those products.
Performing manual migration tasks for Integration Server, such as customizing
startup ﬁles and updating WSDLs.
Performing manual migration tasks for some products hosted by Integration Server.
If you are upgrading a Integration Server cluster, read "Prepare Integration Server " on
page 22 before you continue.
If you are upgrading an Integration Server that hosts Deployer, read "Complete the
Deployer Upgrade" on page 86 before you continue.

Before Migrating Data
1. Make sure Integration Server is shut down.
2. If you are going to migrate packages that you created, and you gave a package a name that
starts with Wm, go to the 9.7_Software AG_directory \IntegrationServer\bin\migrate
directory, open the packages.cnf file, and add a <value name></value> tag that identifies
that package. If you are going to migrate run-time data for business processes, also add any
run-time packages generated from Software AG Designer that you gave a name starting with
Wm.
Note: To simplify future upgrades, and as a general best practice, do not give
packages names that start with Wm.

Run the Integration Server Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28.
9.6 upgrade: If the old Integration Server installation has multiple instances, you run
the migration utility once for each instance you want to migrate. You can have the
utility migrate an old instance to a 9.7 instance you created after installation or to a new
instance the utility creates for you.
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Perform a Custom Migration
1. On the 9.7 machine, open a command window and go to the 9.7_Software
AG_directory \IntegrationServer\bin\migrate directory.
2. 8.2 upgrade: If the old and new Integration Server installations are on different operating
systems, run the appropriate command below.
When upgrading from...

Run this command...

Windows to UNIX/
Linux

export JAVA_TOOL_OPTIONS=Dfile.encoding=Cp1252

UNIX/Linux to
Windows

set JAVA_TOOL_OPTIONS=Dfile.encoding=UTF-8

3. Run the command migrate.{bat|sh}.
4. The utility asks for the full path to one of the following:
The old Integration Server installation (for example, C:\old_Software
AG_directory \IntegrationServer or /opt/old_Software AG_directory /
IntegrationServer).
The Zip ﬁle you made earlier.

5. 9.6 upgrade: If the old Integration Server installation has more than one instance, the utility
lists the instances and asks which instance to migrate from.

6. The utility asks for the name of the 9.7 instance to which to migrate. If you want to create
a 9.7 instance and migrate to it, enter an instance name that does not exist in the 9.7
installation. If you want to migrate to an instance that does exist in the 9.7 installation, enter
that instance name.
When you installed Integration Server 9.7, the Software AG Installer copied all
packages and language packs you selected during installation into a package
repository. If packages exist on the old instance, and the same packages exist in the
9.7 package repository, the utility will install those packages on the 9.7 instance. If
you are creating an instance, and language packs exist in the package repository, the
utility will install those language packs on the 9.7 instance.
Note: The migration utility can only install the ActiveTransfer Support package on
the default Integration Server 9.7 instance.

7. The utility asks whether to import migration settings. Enter N.
8. The utility asks whether to migrate custom packages. If you choose to migrate all custom
packages, the utility migrates the following:
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User-created and business process run-time packages. If the name of any of these
packages starts with Wm, it will only be migrated if you added the package to
the packages.cnf ﬁle earlier.
The WmChemPayloads, WmPapinetPayloads, WmRNPips, and
WmFINMessages packages, if present. Each of these packages contains IS
documents for its eStandards Module and the schemas for those documents.
If you are migrating Mobile Support, the packages that contain the business
document type and the download and upload services speciﬁed for the mobile
sync components conﬁgured in the mobileSyncComponents.cnf ﬁle.
If you choose to migrate selected packages only, the utility lists each of the packages
listed above and asks whether to migrate it.

9. The utility asks whether to migrate Integration Server configuration files. If you choose to
migrate selected configuration files only, the utility lists each configuration file and asks
whether to migrate it. There are about 50 configuration files. You must enter Y to all prompts
that list config\jdbc files.

10. 9.5 upgrade: The utility asks whether to migrate custom jar files. If you choose to migrate
selected custom jar files only, the utility lists each custom jar file and asks whether to migrate
it.

11. The utility asks you to specify the behavior to use for new Integration Server 9.7 properties
and Integration Server 9.7 properties that have new defaults. If you choose to select behavior,
the utility lists each property and asks whether to use new behavior or preserve existing
behavior.

12. If the Integration Server hosts other products (for example, ActiveTransfer, Mediator,
adapters, and eStandards Modules), the migration utility asks whether to migrate the data for
those products.
Note: If the Integration Server hosts Deployer, the migration utility will ask whether
to migrate Deployer data. Do not do so unless you have read "Complete the
Deployer Upgrade" on page 86 and completed all necessary pre-migration tasks.

13. The utility asks whether to migrate Trading Networks data. If you enter Y, the utility asks the
following:
a. Whether to migrate the Trading Networks configuration file. If you enter Y, the utility
copies the configuration properties from the old Trading Networks installation directory,
adds them to the new configuration properties in Trading Networks 9.7, and replaces
the properties.cnf file in the 9.7_Software AG_directory \IntegrationServer\instances
\instance_name \packages\WmTN\config directory.
Note: If you have a cluster of Trading Networks instances, you must migrate the
conﬁguration ﬁle for each instance.
b. 8.2 upgrade: Whether to migrate Trading Networks data. If you enter Y, the utility does
the following:
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Adds an onboarding IDTYPE to the IDTYPE table in the TradingNetworks
database component. Trading Networks uses the new onboarding IDTYPE
when you create partners using the Trading Networks Partner Onboarding
feature.
Imports onboarding system template data into the
TEMPLATE, TEMPLATEFIELD, TEMPLATEFIELDDEFS, and
TEMPLATEFIELDGROUPDEFS tables in the TradingNetworks database
component. The data appears in the default questionnaire templates
that accompany invitations you send to new partners using the Partner
Onboarding feature.
Note: If you have a cluster of Trading Networks instances, Trading Networks
data is shared by all instances in the cluster, so only migrate the data for one
instance.

14. The utility asks whether to export your settings. If you want to perform other migrations by
importing the settings from this session, enter Y. If not, enter N.

15. The utility asks whether to begin migration. If you enter Y, the utility migrates the data you

selected. If migration completes successfully, the utility also performs the actions in "Other
Actions Performed by the Migration Utility" on page 64.

Migrate Using Imported Settings
Imported seings can come from the following:
Seings you exported from a custom migration. These seings are stored in a ﬁle
named migrate.dat in the 9.7_Software AG_directory \IntegrationServer\bin\migrate
directory from which you ran the custom migration. Copy the migrate.dat ﬁle to
any directory on machines that host Integration Server 9.7 installations to which you
want to migrate data.
Seings in the default migrations provided with Integration Server. For each old
release, the seings are stored in a ﬁle named migraterelease sbs.dat ﬁle in the
9.7_Software AG_directory \IntegrationServer\bin\migrate directory. The seings
tell the migration utility to migrate the data listed in "Overview" on page 60.
For Integration Server properties that are new or that have new defaults, the default
migration chooses the behavior that best preserves backwards compatibility.

Migrate Using Imported Settings with Prompting
1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \IntegrationServer\bin\migrate directory, and run the command migrate.
{bat|sh}.

2. The utility asks for the full path to the old Integration Server installation or to the Zip file you
made earlier.
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3. 9.6 upgrade: If the old Integration Server installation has more than one instance, the utility
lists the instances and asks which instance to migrate from.

4. The utility asks for the name of the 9.7 instance to which to migrate. If you want to create
a 9.7 instance and migrate to it, enter an instance name that does not exist in the 9.7
installation. If you want to migrate to an instance that does exist in the 9.7 installation, enter
that instance name.
When you installed Integration Server 9.7, the Software AG Installer copied all
packages and language packs you selected during installation into a package
repository. If packages exist on the old instance, and the same packages exist in the
9.7 package repository, the utility will install those packages on the 9.7 instance. If
you are creating an instance, and language packs exist in the package repository, the
utility will install those language packs on the 9.7 instance.
Note: The migration utility can only install the ActiveTransfer Support package on
the default Integration Server 9.7 instance.

5. The utility asks whether to import migration settings. Enter Y and, when prompted, provide
the full path to the migrate.dat file or the migrate{822|901|951|960}sbs.dat file.

Migrate Using Imported Settings without Prompting
On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \IntegrationServer\bin\migrate directory, and run the command below.
The -instanceName option speciﬁes both the old instance to migrate from and the 9.7
instance to migrate to; if the 9.7 instance does not exist, the utility will create it. If an
error occurs, the utility exits.
migrate.{bat|sh}
{-srcDir|-srcFile} full_path_to_{old_Integration Server_directory|Zip_file}
-instanceName instance_name
-importFile full_path_to_ {migrate.dat|migrate{822|901|951|960}sbs.dat}
-silent true

Other Actions Performed by the Migration Utility
When migration completes successfully, the migration utility also does the following:
Deletes old conﬁguration ﬁles that are not used by Integration Server 9.7, and deletes
old properties that are not used by Integration Server 9.7 from the 9.7 conﬁguration
ﬁles.
If the old Integration Server used the embedded database, the utility copies the
database tables from the old Integration Server to Integration Server 9.7 and converts
the tables to the new format.
Adds a new property named "Validate schemas using Xerces" to existing
Web service descriptors, and sets the new property to the value the
wa.server.wsdl.validateWSDLSchemaUsingXerces parameter had in the old
Integration Server. The new property replaces the functionality provided by
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that parameter. For information about the new property, see webMethods Service
Development Help9.7.
If the old Integration Server was part of a cluster that used Coherence as its caching
software, the utility removes the clustering seings so you can reconﬁgure the
cluster to use a Terracoa-based solution. Support for Coherence was discontinued
in release 9.0. For more information, see webMethods Integration Server Clustering
Guide9.7.
8.2 upgrade: Updates the SoftwareAG-IS-Core.xml caching ﬁle to include caches
added for Integration Server 9.7.
Sets the wa.art.connection.nodeVersion property=2, which means adapter
passwords are stored unencrypted in the Integration Server passman store and the
password handle is stored in the adapter connection. In the previous release, adapter
connection passwords were encrypted and then stored in the adapter connection. If
you want to return to the previous behavior, set the wa.art.connection.nodeVersion
property=1.
If you are using Business Rules and chose to migrate rule data, the utility upgrades
Business Rule projects. You might see XML parsing messages due to a Java bug; you
can ignore these messages.

Complete the Integration Server Upgrade
Migrate the Flat File Package Properties File
If you used the Flat File package on the old Integration Server, you might have
created a properties.cnf ﬁle to control some ﬂat ﬁle behavior. Go to the old_Software
AG_directory\IntegrationServer\instances\instance_name \packages\WmFlatFile
\conﬁg directory. If the properties.cnf ﬁle is present, copy it to the same directory in the
9.7 installation.

Customize Integration Server Startup Files
The Integration Server startup scripts have been changed in release 9.7. If you
customized the old scripts, see the webMethods Integration Server Administrator’s
Guide and the Integration Server readme for instructions on how to duplicate those
customizations for 9.7.

Update WSDLs
If you have Provider Web services that have an operation with ﬁeld names starting with
xml in the input signature, output signature, header, or faults, do the following:

1. Start Integration Server 9.7.
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2. Review the migrationLog.txt file in the 9.7_Software AG_directory \install\logs directory.
If you see this error:
A property watt.server.xml.ncname.encode.backward.compatibility exists in
config/server.cnf with value as true. Make sure you make the required changes
as specified in the upgrade documentation. Not doing so could have adverse
effects as support for this property may be dropped in a future release.

Update your WSDLs as follows:
a. Open Integration Server Administrator and point to Integration Server 9.7.
b. Go to the Settings > Extended page. If you have the extended setting
watt.server.xml.ncname.encode.backward.compatibility and it is set to true, reset it to
false.
c. Regenerate the clients for all Provider Web services that have an operation with field
names starting with xml in the input signature, output signature, header, or faults.

Connect Integration Server Functions to Database Components
Connect Integration Server and the products it hosts to their database components. For
instructions, see Installing webMethods and Intelligent Business Operations Products9.7.

Update Host Names
If the old and new Integration Servers are on diﬀerent machines, update the host names
for 9.7 as follows:
1. If you want to resubmit failed business processes in the 9.7 installation, update the
host name in the ISCoreAudit database component.
2. Go to the 9.7_Software AG_directory \IntegrationServer\instances
\instance_name \conﬁg directory, open the AuditConﬁg.xml ﬁle, and update the
<server-id> element to reﬂect the Integration Server 9.7 host name.
3. Update the host name in the TARGET column in the IS_USER_TASKS database
table.
4. Update the SERVERID column in the database tables below.
IS_USER_TASKS, WMDOCUMENT, WMERROR, WMRULEDIST,
WMSECURITY, WMSESSION, WMTXIN, WMTXOUT,
WMTXOUTWMCONTROL
WMSERVICE, WMSERVICE4X, WMSERVICEACTIVITYLOG,
WMSERVICEASSOC, WMSERVICECUSTOMFLDS
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9.0, 9.5, or 9.6 Upgrade: Update the Integration ServerNERV
Configuration
1. Go to the 9.7_Software AG_directory \profiles\IS_instance_name \configuration
\com.softwareag.platform.config.propsloader directory and open the
com.softwareag.platform.eda.nerv.properties file. Update JMS provider references to point to
your 9.7 JMS provider. Update file system paths to point to the 9.7 installation.

2. Open the same file in the old installation. If any values in the two files other than the path
values mentioned above are different, copy the old value over the 9.7 value.

Complete the ActiveTransfer Upgrade
For instructions on all steps below, see Managing File Transfers with webMethods
ActiveTransfer9.7.

1. Copy keystore files and the security.cnf file from the old installation to the ActiveTransfer
9.7 installation. Update the keystore file paths.

2. Make sure that port values, host names and IP addresses, and local and remote file paths in
event file operations and the virtual file system (VFS) are correct for the ActiveTransfer 9.7
installation.

3. If you used temporary accounts and shared files with the old ActiveTransfer, you can
copy that information so you can use it with ActiveTransfer 9.7. Go to the old_Software
AG_directory \IntegrationServer\instances\instance_name directory for the Integration
Server instance that hosts ActiveTransfer and copy the TempAccounts directory to the same
location in the 9.7 installation.

Complete the CloudStreams Upgrade
You complete the CloudStreams upgrade by running the public service
pub.cloudstreams.migration:migrate, which is available in the WmCloudStreams
package. The service migrates old CloudStreams artifacts in custom packages that
depend on the WmCloudStreams package and updates them to be compatible with
CloudStreams 9.7. Artifacts include SOAP and REST connector services and connections.
Back up any custom packages that contain CloudStreams artifacts, then run the
pub.cloudstreams.migration:migrate service. The utility logs the results of
migration to the Integration Server server log.
The input signature for the service is as follows:
Parameter

Description

allPackages

Boolean string. Optional. Set to:
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Parameter

Description
true to migrate CloudStreams artifacts from all custom

packages that are dependent on WmCloudStreams.

false to migrate CloudStreams artifacts from only custom

packages speciﬁed on the packages parameter. This is the
default.
packages

Object. String array containing the names of custom packages to
migrate. You must specify at least one package name.

The output signature of the service is a parameter named Result that consists of an array
of iData records. The array contains a record for each custom package speciﬁed in the
input signature. The ﬁelds in each record are as follows:
Field

Description

packageName

String. Name of the custom package.

success

String. Value that indicates whether migration succeeded (true)
or failed (false).

message

String. Information about the migration, such as number of
CloudStreams artifacts found in the package and number of
CloudStreams artifacts that were successfully migrated.

info

Object. Optional. If the service issued info messages during the
migration, string array of the messages.

errors

Object. Optional. If the service issued errors during the
migration, string array of the errors.

Complete Adapter Upgrades
If the old Integration Server hosted adapters and you installed the same release or a later
release of those adapters on Integration Server 9.7, you migrated data for those adapters
as part of the Integration Server migration. For the adapters below, however, you must
also complete the indicated tasks.
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webMethods Adapter for JDBC
If the adapter connects to an Oracle RDBMS using an OCI driver, set these environment
variables on the Integration Server 9.7 machine:
Platform

Environment Variable Setting

Solaris

LD_LIBRARY_PATH=/ORACLE_HOME/lib

HP

SHLIB_PATH=/ORACLE_HOME/lib

AIX

LIBPATH=/ORACLE_HOME/lib

Linux

LD_LIBRARY_PATH=/ORACLE_HOME/lib

webMethods Package for Microsoft .NET
If you modiﬁed the wmSystem.exe.conﬁg ﬁle in the old installation, make the same
changes to the same ﬁle in the new installation. The ﬁle is located in the Software
AG_directory \IntegrationServer\DotNetHost directory.

webMethods PeopleSoft EnterpriseOne Adapter
If the adapter connects to an Oracle RDBMS, go to the old_Software
AG_directory \IntegrationServer\lib\jars directory and copy the Oracle JDBC driver ﬁle
to the 9.7_Software AG_directory \IntegrationServer\lib\jars\custom directory.

webMethods SAP Adapter
If the Integration Server 9.7 machine uses UNIX, set these environment variables on
the machine:
Platform

Environment Variable Setting

Linux,
Solaris

LD_LIBRARY_PATH

HP

SHLIB_PATH

AIX

LIBPATH
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Go to the old_Software AG_directory \IntegrationServer\lib directory and copy
all ﬁles whose ﬁle name contains the phrase *sapjco*.* to the 9.7_Software
AG_directory \IntegrationServer\lib\jars\custom directory.
If the Integration Server 9.7 machine uses Windows, go to the C:\WINDOWS
\system32\drivers\etc directory on the old Integration Server machine, open the
services ﬁle, and copy all entries that contain the phrase "sapgw" into the same ﬁle in
the 9.7 installation. Examples of these entries are sapgw00 3300/tcp, sapgw01 3301/
tcp, sapgw02 3302/tcp, sapgw03 3303/tcp, sapgw04 3304/tcp, and sapgw05 3305/tcp.

webMethods WebSphere MQ Adapter
If the adapter is installed on a Windows system, and the WebSphere MQ back end is
installed on a remote machine, go to the WebSphereMQ_directory \java\lib directory and
copy the mqjbndnn.dll ﬁle into a local directory that is in your path system environment
variable.

Complete eStandards Module Upgrades
If the old Integration Server hosted eStandards Modules and you installed the same
release or a later release of those modules on Integration Server 9.7, you migrated data
for those modules as part of the Integration Server migration. For the modules below,
however, you must also complete the indicated tasks.

webMethods FIX Module
If you installed the same release of FIX Module on Integration Server 9.7, go
to the old_Software AG_directory \IntegrationServer\packages and copy the
WmFIXMessages package to the 9.7_Software AG_directory \IntegrationServer\instances
\instance_name \packages directory.

webMethods SWIFT FIN Module
If you installed the same release of SWIFT FIN Module on Integration Server 9.7,
go to the old_Software AG_directory \IntegrationServer\packages and copy the
WmFINMessages package to the 9.7_Software AG_directory \IntegrationServer\instances
\instance_name \packages directory.

webMethods SWIFTNet Module
Reconﬁgure the module. For instructions, see the webMethods SWIFTNet Module
Installation and User’s Guide.
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Migrate Software AG DesignerData
Before Migrating Data
1. Open Software AG Designer 9.7 and point to a new 9.7 workspace. For example, you can
accept the default workspace97.

2. Install any third-party features you need (for example, support for Subversion). The Eclipse
release installed with Software AG Designer 9.7 is Eclipse 4.3, so make sure any features you
add are compatible with Eclipse 4.3.

3. If you are upgrading Events, go to the File > Import wizard. In the Select panel, go to Run/

Debug > Launch Configurations and click Next. In the From Directory field, go to the directory
to which you exported your Event Bus Console configurations in Export Event Bus
Console Conﬁgurations and select all files with the extension .launch. Click Finish.

4. If you exported your preferences before upgrading, do the following:
a. Go to the File > Import wizard. In the Select panel, go to General > Preferences and click
Next. In the From preference file field, specify the .epf file to which you exported your
preferences. Click Finish.
b. Go to Window > Preferences. In the preferences window, go to the Java > Installed JREs
> Execution Environments page, if multiple JREs are listed, make sure JRE 1.7 is selected
as the default, or remove JRE 1.6 from the list. Also update settings that point to old
product installations to point to 9.7 product installations instead. For example, for My
webMethods Server, update the Server > Runtime Environments settings.

Migrate Business Process and Business Rule Projects
1. Start Software AG Designer 9.7.
2. If your projects are stored in a source control system, use the import wizard for that system

(for example, Import SVN > Project from SVN). If your projects are stored in the Software AG
Designer workspace, do the following:
a. Go to the File > Import wizard.
b. In the Select panel, go to General > Existing Projects into Workspace and click Next.
c. In the Import Projects panel, do the following:
i.

Click Select Root Directory and go to the workspace that contains a type of
project you want to import, or click Select Archive File and go to the directory
that contains a type of project you want to import.

ii. In the Projects box, select the projects to import. Select Copy projects into
workspace. Click Finish.

3. Verify the following:
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All imported business process projects appear in the Solutions tab under the
Processes node.
All imported business rules projects appear in the Solutions tab under the Rules
node.

4. If you imported business rule projects, right-click each project in the Rules Explorer and then
click Upgrade Project.

Migrate Task Application Projects
1. In Software AG Designer 9.7, go to Window > Preferences > Server > Runtime Environments.
If the Installed server runtimes list does not include a My webMethods Server 9.7, add one.

2. Go to Software AG > Task Development. In the preferences window, make sure all your other
task-related Software AG Designer preferences are correct, and then click OK.

3. Go to the File > Import wizard.
a. In the Select panel, go to Software AG > Existing CAF Projects into Workspace and then
click Next.
b. In the Import Projects panel, click Select Root Directory and go to the workspace or
source control system that contains your task application projects, or click Select Archive
File and go to the directory that contains your task application projects. In the Projects
box, select the projects to import.
c. Select Copy projects into workspace and then click Finish.

4. Make sure all imported task application projects appear in the Solutions tab, under the Tasks
node.

5. If errors appear in the Problems tab, click the Navigator tab. Right-click each task application
project, click CAF Tools, and click Repair CAF Project. If errors still appear, restart
Software AG Designer.

6. Publish the migrated task application projects to My webMethods Server 9.7. For
instructions, see webMethods BPM Task Development Help9.7.

Migrate CloudStreams Server Definitions and Projects
1. Start Software AG Designer 9.7.
2. Import CloudStreams Server definitions as follows:
a. Go to the CloudStreams Development perspective, then go to Window > Preferences.
On the Preferences dialog box, in the left navigation bar, go to Software AG
> CloudStreams Servers.
b. Click Import, select the .properties file you exported, and click Open. Software AG
Designer asks whether to overwrite existing servers. Click OK, and then click OK again
to close the Preferences dialog box.

Upgrading webMethods and Intelligent Business Operations Products Version 9.7

73

M

Even Header
Completing the Designer, Business Process Run-time, and Blaze Upgrades

3. Import CloudStreams Governance projects as follows:
a. Go to the File > Import wizard. In the Select panel, go to Software AG
> CloudStreams Governance Project and then click Next.
b. In the Import CloudStreams Governance Project panel, specify the directory that contains
the projects you exported in the Select Root Directory field. In the Projects box, select the
projects to import.
c. Select Copy projects into workspace and then click Finish.
d. In the CloudStreams Development perspective, make sure all imported governance
projects appear in the CloudStreams Governance tab.

4. Repeat the previous step to import CloudStreams Provider projects.

Migrate Integration Server Definitions
1. In Software AG Designer 9.7, go to Window > Preferences. On the Preferences dialog box, in
the left navigation bar, go to Software AG > Integration Servers.

2. Click Import, select the .properties file you exported, and click Open. Software AG Designer
asks whether to overwrite existing servers. Click OK, and then click OK again to close the
Preferences dialog box.

Complete the Business Process Run-time Upgrade
Note: If you have running process instances that are based on a process model created
before you upgraded to 9.7, and you now want to regenerate that process model in
Software AG Designer 9.7, change the version number of the process model to the next
sequence number before regenerating it. If you do not do so, the process instances will
not behave as expected. When you enable the new version of the process model for
execution in My webMethods Server, you will be asked if you want to upgrade running
processes; respond No.

1. If you upgraded webMethods Broker, make sure the new Broker that will be used by the
Process Engines has the same name in 9.6 that it had in the old release. To do so, open
Integration Server Administrator and point to Integration Server 9.7. Go to the IS Settings >
Messaging > webMethods Messaging Settings page and check the Broker name.

2. If you migrated process run-time packages (see "Run the Integration Server
Migration Utility" on page 60), make sure the packages exist in the 9.7_Software
AG_directory \IntegrationServer\instances\instance_name \packages directory. The
package names are the project names or custom names you specified in Software AG
Designer.

3. Open Integration Server Administrator and point to Integration Server 9.7. Go to the Settings
> JDBC Pools page and connect the ProcessEngine and ProcessAudit functions to their
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database components. For instructions, see Installing webMethods and Intelligent
Business Operations Products9.7.

4. Make sure document retrieval for all webMethods messaging triggers is enabled
on Integration Server 9.7. For instructions, see webMethods Integration Server
Administrator’s Guide9.7.

Update Host Names
If the old and new business process product installations are on diﬀerent machines,
update the host name in the SERVERID column in the database tables below.
PRTINSTANCEITER, PRTPROCESS, PRTPROCLOCK, PRTQUEUE,
PRTSTEPLOCK, PRTSTEPSTATE, PRTSTEPSUSPENSION
PRA_ERROR
PRA_PROCESS, PRA_PROCESS_AT_REST, PRA_PROCESS_CUSTOM,
PRA_PROCESS_STEP, PRA_PROCESS_STEP_LOOP
PRA_STEP_LOGGED_FIELD, PRA_STEP_LOOP_LOGGED_FIELD,
PRA_STEP_MESSAGE, PRA_STEP_TRANSITION
WMSTG_PROCESS_CONTROL, WMSTG_PROCESS_STEP, WMRULEDIST

Complete the Blaze Rules Upgrade
Migrate Blaze rules using the instructions in Using Blaze Rules with BPM and CAF9.7.
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Overview
You complete the Optimize upgrade by:
Conﬁguring and starting the Terracoa Server Array.
Updating connections to other products.
Updating host names.
Migrating Infrastructure Data Collector data.
Deploying the Optimize environment.
Connecting to Universal Messaging 9.7, if you were using webMethods Broker as
your JMS provider in the old release and are now using Universal Messaging.

Configure and Start the Terracotta Server Array
If you are clustering Analytic Engines in release 9.7, you must conﬁgure and start the
Terracoa Server Array. For instructions, see Geing Started with the webMethods Product
Suite and Terracoa9.7, Conﬁguring BAM9.7, and the Terracoa BigMemory Max 4.1
documentation.

Update Connection to Other Products
Update Connection to Process Engine
If you are using Optimize for Process, do the following:

1. Open Integration Server Administrator and point to an Integration Server 9.7 that hosts a
Process Engine.

2. Go to the Packages > Management page and click

for the WmPRT package.

3. Click Settings in the left navigation bar and then click Edit Process Engine Settings.
4. In the JMS Server URL field, identify the JMS provider host name and port as follows:
JMS Provider

URL Format

webMethods Broker

broker://host :port /Broker_name . The default port is
6849.

Universal
Messaging

nsp://host :port . The default port is 9000.
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5. Click Submit and then reload the WmPRT package.
6. Repeat these steps for every Integration Server that hosts a Process Engine.

Update Connection to Optimize Support Package
If you are using Optimize built-in services, do the following:

1. Open Integration Server Administrator and point to the Integration Server 9.7 that hosts an
Optimize Support package.

2. Go to the Packages > Management page and click

for the WmOptimize package.

3. Identify the Analytic Engine host machine and port. The default port is 12503.
4. In the JMS Server URL field, identify the JMS provider host name and port as follows:
JMS Provider

URL Format

webMethods Broker

broker://host :port /Broker_name . The default port is
6849.

Universal
Messaging

nsp://host :port . The default port is 9000.

5. Click Submit and then reload the WmOptimize package.
6. Repeat these steps for every Integration Server that hosts an Optimize Support package.

Complete the Infrastructure Data Collector Upgrade
Overview
You complete the Infrastructure Data Collector upgrade by:
Migrating customizations to the Infrastructure Data Collector Java Service Wrapper.
8.2 Upgrade: Restarting monitoring of clustered Integration Servers.
Running the Infrastructure Data Collector migration utility. The utility migrates
asset conﬁguration ﬁles and the JAAS conﬁguration for Infrastructure Data
Collector.

8.2 Upgrade: Restarting Monitoring of Clustered Integration Servers
If you had Integration Servers that were clustered using Oracle Coherence, you
reconﬁgured them earlier to use a Terracoa-based clustering solution instead. You can
now rediscover the clustered Integration Servers you want to monitor, re-select the KPIs
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you noted in "Prepare Optimize " on page 23, and restart monitoring. For instructions,
see Administering webMethods Optimize 9.7.

Migrate Customizations to the Java Service Wrapper
If you customized the old Infrastructure Data Collector Java Service Wrapper, copy
the customizations from the old wrapper_conf or custom_wrapper.conf ﬁles to the 9.7
custom_wrapper.conf ﬁle. The ﬁles are located in the Software AG_directory \proﬁles
\InfraDC\conﬁguration directory.

Run the Infrastructure Data Collector Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28.

Before Migrating Data
1. Make sure the old Infrastructure Data Collector is shut down.
2. Go to the old_Software_AG_directory \bin\migrate\release directory and open the
migrateConfigFile.properties file. Identify each asset configuration file or directory
that contains asset configuration files to migrate using the format shown in the
migrateConfigFile.properties file.

Perform a Custom Migration
1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \infrastructuredc\bin\migrate directory and run the command migrate.
{bat|sh}.

2. The utility asks for the full path to one of the following:
The old Infrastructure Data Collector installation (for example, C:
\old_Software AG_directory \infrastructuredc or /opt/old_Software AG_directory /
infrastructuredc).
The Zip ﬁle you made earlier.

3. The utility asks whether to import migration settings. Enter N.
4. The utility asks whether to migrate SNMP asset configuration files. The migration utility

will migrate the old files you identified in the migrateConfigFile.properties file in "Before
Migrating Data" on page 80.

5. The utility asks whether to migrate the JAAS configuration for Infrastructure Data Collector.
If you enter Y, the utility asks whether to replace references to the old directory in the JAAS
configuration file with references to the 9.7 directory.

6. The utility asks whether to export your settings. If you want to perform other migrations by
importing the settings from this session, enter Y. If not, enter N.
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7. The utility asks whether to begin migration. If you enter Y, the utility migrates the data you
selected.
If you chose to migrate asset conﬁguration ﬁles, and a ﬁle that has the same name
as an old ﬁle already exists in the Infrastructure Data Collector 9.7 installation,
the utility backs up the 9.7 ﬁle to the 9.7_Software AG_directory \infrastructuredc
\migrationbackup directory before migrating the old ﬁle. The same is true for the
JAAS conﬁguration ﬁle.

Migrate Using Imported Settings
Imported seings can come from the following:
Seings you exported from a custom migration. These seings are stored in a ﬁle
named migrate.dat in the 9.7_Software AG_directory \infrastructuredc\bin\migrate
directory from which you ran the custom migration. Copy the migrate.dat ﬁle to
any directory on machines that host Infrastructure Data Collector 9.7 installations to
which you want to migrate data.
Seings in the default migrations provided with Infrastructure Data Collector. For
each old release, the seings are stored in a ﬁle named migraterelease sbs.dat ﬁle in
the 9.7_Software AG_directory \infrastructuredc\bin\migrate directory. The seings
tell the migration utility to migrate the data listed in "Complete the Infrastructure
Data Collector Upgrade" on page 79.
Migrate Using Imported Settings with Prompting

1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \infrastructuredc\bin\migrate directory, and run the command migrate.
{bat|sh}.

2. The utility asks for the full path to the old Infrastructure Data Collector installation or to the
Zip file you made earlier.

3. The utility asks whether to import migration settings. Enter Y and, when prompted, provide
the full path to the migrate.dat file or the migrate{822|901|951|960}sbs.dat file.
Migrate Using Imported Settings without Prompting
On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \infrastructuredc\bin\migrate directory, and run the command below. If
an error occurs, the utility exits.
migrate.{bat|sh}
{-srcDir|-srcFile} full_path_to_{old_Infrastructure Data
Collector_directory|Zip_file}
-importFile full_path_to_ {migrate.dat|{821|901|951|960}sbs.dat}
-silent true
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Deploy the Optimize Environment
Unless otherwise noted, see Conﬁguring BAM9.7 for detailed instructions on the
Optimize steps in the sections below.

To Not Reuse the Old Optimize CCS Environment Definition
If you do not want to reuse your old Central Conﬁguration System (CCS) Environment
deﬁnition, start My webMethods Server 9.7, open My webMethods, and conﬁgure your
Optimize 9.7 environment.
For Infrastructure Data Collector, when you deﬁne hosts, enter the same value in the
Host Name or IP Address ﬁeld of the Add/Edit Host dialog box that you had in the old
release.
Note: If the 9.7 value is not identical to the old value, you will have to stop monitoring
existing assets, rediscover them, and reselect them for monitoring after you ﬁnish
upgrading.
Skip to the step for deploying the Optimize 9.7 environment, below.

To Reuse the Old Optimize CCS Environment Definition
To reuse the old CCS environment deﬁnition that you exported to ﬁle before installing
Optimize 9.7, follow the steps below.

1. Start My webMethods Server 9.7 and open My webMethods.
2. Import the old CCS environment, as follows:
a. Go to the Applications > Administration > System-Wide > Environments > Define
Environments page.
b. Click Import Environment. On the Import Environments dialog box, click Browse, go to
the file to which you exported the old CCS environment, and click OK. When prompted,
confirm the migration.
c. When asked "Do you wish to migrate the environment to the latest version?", click Yes.
The CCS imports the old environment and migrates it to Optimize 9.7 Logical Servers.

3. Update the database pool connection settings for the database pool definition associated with
the environment you imported, as follows:
a. Go to the Applications > Administration > System-Wide > Environments > Database Pool
Configuration page.
b. In the Pool column, click the imported database pool.
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c. In the Pool Settings area, set the Minimum Connections field to 8, and the Maximum
Connections field to 60.
d. Make sure the database connection information is correct. In the Database Connection
area, click Test and make sure the message Test Passed displays at the bottom of the
page.
e. Click Save.

4. Go to the Applications > Administration > System-Wide > Environments > Define Environments
page. Under Environment Name, click the environment you imported.

5. If you are using a different JMS provider with the 9.7 release than you used with the old
release, do the following:
a. Click the Configure Servers tab. Under Configuration, open the Default Settings tree and
click JNDI Configuration.
b. In the Naming Factory Type list, click the JMS provider you are using with the 9.7 release.
If you are using webMethods Broker, complete the Broker Name field. If you are using
Universal Messaging, clear the field.
c. Click the Map Endpoints tab. In the first Incoming Connections field for the JMS
Provider, type broker if you are using webMethods Broker or nsp if you are using
Universal Messaging. In the second field, type the port number.
d. Click Save.

6. Validate the environment as follows:
a. Click each tab that shows the icon except the Validate tab. If you change any settings
on a tab, and the tab has a Save button, click Save.
b. When all tabs except the Validate tab show

, click the Validate tab.

7. Click Finish.

Deploy the Optimize 9.7 Environment
1. Start the Optimize 9.7 components you installed. These components can include the Analytic
Engine, Infrastructure Data Collector, and the Web Services Data Collector.

2. Start the JMS provider you are using with the 9.7 release.
3. Deploy your Optimize 9.7 environment. For instructions, see Conﬁguring BAM9.7.
4. In My webMethods, go to the My webMethods > System Settings > Servers page.
If you have BPMS installed, select the BPM and BAM option and identify the
upgraded Analytic Engine and the Integration Server that hosts Monitor. You can
identify the hosts using DNS name or IP address.
If you have BPMS installed, but are not using BPM (that is, you are using only
Optimize), select the BAM only option and identify the upgraded Analytic Engine.
You can identify the host using DNS name or IP address.
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Click Check Server Status and make sure the server is available (green icon). It might
take some time for the server to become available (for example, 15 minutes). Then
click Save.

Switching from webMethods Broker to Universal Messaging
If you were using webMethods Broker as your JMS provider in the old release, and are
using Universal Messaging in 9.7, do the following:

1. Start Universal Messaging and open Universal Messaging Enterprise Manager.
2. Connect to a server instance, then click it.
3. Click the Config tab. Expand Global Values and set AllowRealmAdminFullAccess to true.
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Complete the Asset Build Environment Upgrade
Go to the old_Software AG_directory \common\AssetBuildEnvironment\master_build
directory and open the build.properties ﬁle. Copy the property values to the same ﬁle in
the 9.7 installation.

Complete the Deployer Upgrade
Overview
You have two options for migrating Deployer data:
You can migrate all Deployer global (default) seings, aliases, target groups, and
projects using the Integration Server migration utility.
You can choose whether to migrate global (default) seings, and you can choose
which aliases, target groups, and projects to migrate using the Deployer migration
feature.
Each option is explained below.
For instructions on tasks you must perform in Deployer, see the webMethods Deployer
User’s Guide.

Before Migrating Data
1. Make sure you have upgraded all source and target product servers that were defined in the
old Deployer to their 9.7 releases, and have migrated all product data and assets to the 9.7
releases, as instructed in this guide.

2. Make sure you have upgraded the Integration Server 9.7 that hosts Deployer 9.7 and migrated
its data using the instructions in this guide.

3. Make sure you are a member of the Administrators ACL, or of the Internal, Developer
ACLs, and DeployerAdmin ACLs, for both the Integration Server that hosts the old Deployer
and the Integration Server that hosts Deployer 9.7. For instructions, see webMethods
Integration Server Administrator’s Guide9.7.

4. In the old Deployer, edit all connections to old source and target product servers to point to
the new 9.7 source and target product servers. You do not have to supply user names and
passwords if you do not know them.

5. If you installed Deployer 9.7 on the same machine as the old Deployer, you might want
Deployer 9.7 to use the ports that were used by the old Deployer. If so, do the following:
a. In Integration Server Administrator, point to the Integration Server that hosts the old
Deployer and go to the Security > Ports page.

Upgrading webMethods and Intelligent Business Operations Products Version 9.7

86

M

Odd Header
Completing the Asset Build Environment and Deployer Upgrades

b. Click Add Port, click webMethods/HTTP, and click Submit. Enter the port details, click
Yes for Enable, click WmRoot under the package name, and click Save Changes.
c. Click Change Primary Port, click the new port, and click Update.
d. In the Access Mode column of the new port, click Edit. In the Edit Access Mode page for
the port, click Set Access Mode to Allow by Default. Click OK on the warning pop-up. The
message Successfully changed access mode for Port Service Access
Settings appears.
e. Disable the old port by clicking Yes in the Enabled column for that port.

Migrate All Deployer Data Using the Integration Server Migration
Utility
In the previous section, you upgraded the Integration Server that hosts Deployer 9.7 and
migrated its data. Do not start the host Integration Server before you migrate Deployer
data. If you do, a ﬁle named MIGRATION_DONE is created in the WmDeployer
package, and you will not be able to migrate Deployer data. If you did start the host
Integration Server, delete this ﬁle.
Migrate Deployer data using the instructions in "Completing the Integration Server and
Hosted Products Upgrade" on page 59.

Migrate Selected Data Using the Deployer Migration Feature
Start the Old Deployer and Deployer 9.7 and Migrate Global (Default) Settings
1. Start the old Deployer and Deployer 9.7.
2. In Deployer 9.7, go to the Tools > Migrate Data page. In the Host and Port fields, identify the
old Deployer to migrate from. In the User and Password fields, provide the user name and
password to use to log onto the old Deployer.

3. Deployer 9.7 lists the aliases, target groups, or projects to migrate in the right-hand pane. In
the Page Size list, click the number of aliases or projects to list at a time.

4. In Deployer, you set defaults for all projects, such as defaults for dependency checking,
project locking, and general deployment. You also set defaults for Integration Server and
Trading Networks projects, such as defaults for suspending assets during deployment,
overwriting existing assets, and activating assets after deployment. If you want to migrate
these default settings, in Deployer 9.7, click Migrate Default Settings.

Migrate Connection Information (Server Aliases)
You can choose the aliases to migrate. However, if you want to migrate a target group,
you must either migrate all aliases in that target group, or remove the aliases you do not
want to migrate from the target group.
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1. In Deployer 9.7, click Migrate Server Aliases. In the Select Server list, click the type of server
whose aliases to migrate.

2. In the Select column, select the check boxes next to the server aliases you want to migrate. In
the Point Selected Aliases to Servers list, click 9.7.

3. Click Migrate Server Aliases. Deployer migrates the selected aliases, then disables those rows
and displays Yes in the Migrate column for the aliases.

4. Repeat the steps above for each type of server whose aliases to migrate.
5. You cannot migrate Integration Server HTTPS server aliases from Deployer. Manually
recreate these aliases in the host Integration Server.

Migrate Target Groups
1. If you did not migrate all aliases in the target groups you want to migrate, in the old
Deployer, remove those aliases from the target groups.
Important: If target groups include invalid aliases, deployment of projects that use
those target groups fails.

2. In Deployer 9.7, click Migrate Target Groups. In the Select Server list, click the type of server
whose target groups to migrate.

3. In the Simulate Migration column, click

in the row for each target group to migrate.

Deployer displays a message that indicates whether the aliases that are referenced by
the target group have been migrated. If any aliases have not been migrated, migrate
them or remove them from the indicated target group.

4. In the Select column, select the check boxes next to target groups to migrate. In the Point
Selected Aliases to Groups list, click 9.7.

5. Click Migrate Target Groups. Deployer migrates the selected target groups, then disables
those rows and displays Yes in the Migrate column for the groups.

Migrate Deployment Projects
1. Start all 9.7 source product servers referenced by Deployer projects.
Note: If a server referenced by a Deployer project is not running, or the connection
seings for a server referenced by a project are not correct, you will have to rebuild
the project later. Deployer will display messages to this eﬀect.

2. In Deployer 9.7, click Migrate Projects.
3. In the right-hand pane, in the Simulate Migration column, click

row for each project to
migrate. Deployer displays a message that indicates whether the source servers that are
referenced by the project are running. If the message indicates that any of the referenced
source servers are not running, start those servers.
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4. In the Select column, select the check boxes next to the projects to migrate, and then click

Migrate Projects. Deployer displays a new window with a dynamic migration report. You can
display the migration report for each project in the Report column in the original window.
You can display the latest migration report by clicking View Latest Migration Report.
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Overview
You complete the Command Central upgrade by:
Migrating the Command Central infrastructure.
Running the Command Central migration utility. The utility migrates the following:
Environment conﬁgurations, which include metadata about the environment,
nodes (installations), and products that Command Central is managing.
Users, roles, and groups.
9.5 or 9.6 upgrade: License tools and templates.
9.6 upgrade: JAAS conﬁguration and password manager data.

Before Migrating Data
Make sure the old Command Central is shut down.

Migrate the Command Central Infrastructure
1. Migrate HTTP port configurations as follows:
a. Go to the old_Software AG_directory \profiles\CCE\configuration
\com.softwareag.platform.config.propsloader directory. If you see a single
com.softwareag.catalina.connector.http.pid-port .properties file, open that file. If you see
multiple files with that name, open the file that specifies the port you want to designate as
the default port in 9.7.
Go to the same directory in the 9.7 installation and open the
com.softwareag.catalina.connector.hp.pid-port .properties ﬁle. If any values in
the two ﬁles are diﬀerent, copy the old value over the 9.7 value.
b. Check for additional com.softwareag.catalina.connector.http.pid-port .properties files for
HTTP ports in the above-mentioned old directory. Copy all such files to the 9.7 directory
and then add these elements to each copied file:
alias=unique_identifier. This Software AG-speciﬁc aribute uniquely

identiﬁes each connector when you view its conﬁguration in the Platform
Manager. The alias for the default HTTP connector you set up above is
defaultHp. You could use that alias as a base, and add a unique suﬃx
to create the alias for each additional connector (alias=defaultHttp2,
alias=defaultHttp3, and so on).

enabled=true. This Software AG-speciﬁc aribute and value are required for

this connector to start.
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2. Repeat the previous steps to migrate HTTPS port configurations, but use the
com.softwareag.catalina.connector.https.pid-port .properties file, and add
alias=defaultHttps to the default HTTPS connector.

3. If you customized the Command Central Java Service Wrappers, copy the customizations
from the old wrapper_conf or custom_wrapper.conf files to the 9.7 custom_wrapper.conf file.
The files are located in the Software AG_directory \profiles\CCE\configuration directory.

4. For each case below, open the file in the indicated directory in the old installation and in the
9.7 installation. If any values in the two files are different, copy the old value over the 9.7
value. In addition, update file system paths in the 9.7 files to point to the 9.7 installation.
Configuration

File Name in Old and 9.7 Software AG Directories

Debug

\proﬁles\CCE\conﬁguration
\com.softwareag.platform.conﬁg.propsloader
\com.softwareag.platform.debug.properties

JMX ports

same
directory \com.softwareag.jmx.connector.pid-port .properties

Security
authorization

same directory \com.softwareag.security.authz.pid.properties

Security
LDAP

same directory \com.softwareag.security.ldap.pid.properties

Single signon service

same directory \com.softwareag.sso.pid.properties

SSH

same directory \com.softwareag.sshd.pid.properties

Watchdog

same
directory \com.softwareag.conﬁg.watchdog.pid.properties

Journal
logger

\proﬁles\CCE\conﬁguration\logging\log_conﬁg_.xml

9.0 or 9.5
upgrade:
Password
manager

\proﬁles\CCE\conﬁguration\security\passman
\scPassMan.conﬁg.xml

5. 9.0 or 9.5 upgrade: For each type of configuration below, copy the file from the indicated
directory in the old installation to the same directory in the 9.7 installation.
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Configuration

File Name in Old and 9.7 Software AG Directories

JAAS

\proﬁles\CCE\conﬁguration\jaas.conﬁg ﬁle

Password
manager

\proﬁles\CCE\conﬁguration\security\passman\
defaultPassStore.dat and mpw.dat

6. For each case below, open the file in the indicated directory and update file system paths to
point to the 9.7 installation.
Configuration

File Name in 9.7 Software AG Directories

JAAS

\proﬁles\CCE\conﬁguration\jaas.conﬁg

Password
manager

\proﬁles\CCE\conﬁguration\security\passman\
defaultPassStore.dat and mpw.dat

Run the Command Central Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28.

Perform a Custom Migration
1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \CommandCentral\migrate\bin directory, and run the command migrate.
{bat|}.

2. The utility asks for the full path to one of the following:
The Software AG directory that contains the old Command Central installation
(for example, C:\old_Software AG_directory or /opt/old_Software AG_directory ).
The Zip ﬁle you made earlier.

3. The utility asks whether to import migration settings. Enter N.
4. The utility asks whether to migrate environment configuration data and users, roles, and
groups.

5. 9.5 or 9.6 upgrade: The utility asks whether to migrate license tools and templates.
6. 9.6 upgrade: The utility asks whether to migrate the JAAS configuration and password
manager data.
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7. The utility asks whether to export your settings. If you want to perform other migrations by
importing the settings from this session, enter Y. If not, enter N.

8. The utility asks whether to begin migration. If you enter Y, the utility migrates the data you
selected.

Migrate Using Imported Settings
Imported seings can come from the following:
Seings you exported from a custom migration. These seings are stored in a ﬁle
named migrate.dat. The ﬁle is stored in the 9.7_Software AG_directory \CCE\migrate
\bin directory from which you ran the custom migration. Copy the migrate.dat ﬁle
to any directory on machines that host Command Central 9.7 installations to which
you want to migrate data.
Seings in the default migrations provided with Command Central. For each
old release, the seings are stored in a ﬁle named migraterelease sbs.dat ﬁle in
the 9.7_Software AG_directory \CCE\migrate\bin directory. The seings tell the
migration utility to migrate the data listed in "Overview" on page 92.

Migrate Using Imported Settings with Prompting
1. On the 9.7 machine, open a command window, go to the 9.7_Software AG_directory \CCE
\migrate\bin directory, and run the command migrate.{bat|}.

2. The utility asks for the full path to the Software AG directory that contains the old Command
Central installation or to the Zip file you made earlier.

3. The utility asks whether to import migration settings. Enter Y and, when prompted, provide
the full path to the migrate.dat file or the migrate{901|951|960}sbs.dat file.

Migrate Using Imported Settings without Prompting
On the 9.7 machine, open a command window, go to the 9.7_Software AG_directory \CCE
\migrate\bin directory, and run the command below. If an error occurs, the utility exits.
migrate.{bat|}
{-srcDir|-srcFile} full_path_to_{old_Software AG_directory|Zip_file}
-importFile full_path_to_ {migrate.dat|migrate{901|951|960}sbs.dat}
-silent true

Update the Command CentralNERV Configuration
Go to the 9.7_Software AG_directory \proﬁles\CCE\conﬁguration
\com.softwareag.platform.conﬁg.propsloader directory and open the
com.softwareag.platform.eda.nerv.properties ﬁle. Update JMS provider references to
point to your 9.7 JMS provider, if they do not already. Update ﬁle system paths to point
to the 9.7 installation.
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9.0 or 9.5 Upgrade: Complete the Platform Manager Upgrade
Overview
You complete the Platform Manager upgrade by migrating the Platform Manager
infrastructure and user repository.

Before Migrating Data
Make sure the old Platform Manager is shut down.

Migrate the Platform Manager Infrastructure
1. Migrate HTTP port configurations as follows:
a. Go to the old_Software AG_directory \profiles\SPM\configuration
\com.softwareag.platform.config.propsloader directory. If you see a single
com.softwareag.catalina.connector.http.pid-port .properties file, open that file. If you see
multiple files with that name, open the file that specifies the port you want to designate as
the default port in 9.7.
Go to the same directory in the 9.7 installation and open the
com.softwareag.catalina.connector.hp.pid-port .properties ﬁle. If any values in
the two ﬁles are diﬀerent, copy the old value over the 9.7 value.
b. Check for additional com.softwareag.catalina.connector.http.pid-port .properties files for
HTTP ports in the above-mentioned old directory. Copy all such files to the 9.7 directory
and then add these elements to each copied file:
alias=unique_identifier. This Software AG-speciﬁc aribute uniquely

identiﬁes each connector when you view its conﬁguration in the Platform
Manager. The alias for the default HTTP connector you set up above is
defaultHp. You could use that alias as a base, and add a unique suﬃx
to create the alias for each additional connector (alias=defaultHttp2,
alias=defaultHttp3, and so on).

enabled=true. This Software AG-speciﬁc aribute and value are required for

this connector to start.

2. Repeat the previous step to migrate HTTPS port configurations, but use the
com.softwareag.catalina.connector.https.pid-port .properties file, and add
alias=defaultHttps to the default HTTPS connector.

3. If you customized the Platform Manager Java Service Wrapper, copy the customizations from
the old wrapper_conf or custom_wrapper.conf files to the 9.7 custom_wrapper.conf file. The
files are located in the Software AG_directory \profiles\SPM\configuration directory.
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4. For each case below, open the file in the indicated directory in the old installation and in the
9.7 installation. If any values in the two files are different, copy the old value over the 9.7
value. In addition, update file system paths in the 9.7 files to point to the 9.7 installation.
Configuration

File Name in Old and 9.7 Software AG Directories

Debug

\proﬁles\SPM\conﬁguration
\com.softwareag.platform.conﬁg.propsloadecom.softwareag.
platform.debug.properties

JMX ports

same
directory \com.softwareag.jmx.connector.pid-port .properties

Security
authorization

same directory \com.softwareag.security.authz.pid.properties

Security
LDAP

same directory \com.softwareag.security.ldap.pid.properties

Single signon service

same directory \com.softwareag.sso.pid.properties

SSH

same directory \com.softwareag.sshd.pid.properties

Watchdog

same
directory \com.softwareag.conﬁg.watchdog.pid.properties

Journal
logger

\proﬁles\SPM\conﬁguration\logging\log_conﬁg_.xml

Password
manager

\proﬁles\CCE\conﬁguration\security\passman
\scPassMan.conﬁg.xml

5. Go to the old_Software AG_directory \common\conf directory. Copy the user.txt, roles.txt,
and groups.txt files to the 9.7_Software AG_directory \profiles\SPM\configuration\security
directory.

6. For each type of configuration below, copy the file from the indicated directory in the old
installation to the same directory in the 9.7 installation. Then open the copied (9.7) files and
update file system paths to point to the 9.7 installation.
Configuration

File Name in Old and 9.7 Software AG Directories

JAAS

\proﬁles\SPM\conﬁguration\jaas.conﬁg ﬁle
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Configuration

File Name in Old and 9.7 Software AG Directories

Password
manager

\proﬁles\SPM\conﬁguration\security\passman
\defaultPassStore.dat and mpw.dat

Update the Platform ManagerNERV Configuration
Go to the 9.7_Software AG_directory \proﬁles\SPM\conﬁguration
\com.softwareag.platform.conﬁg.propsloader directory and open the
com.softwareag.platform.eda.nerv.properties ﬁle. Update JMS provider references to
point to your 9.7 JMS provider, if they do not already. Update ﬁle system paths to point
to the 9.7 installation.

9.6 Upgrade: Complete the Platform Manager Upgrade
Overview
You complete the Platform Manager upgrade by:
Migrating the Platform Manager infrastructure.
Running the Platform Manager migration utility. The utility migrates the following:
Password manager conﬁguration and data.
Users, roles, and groups.
JAAS conﬁguration.

Before Migrating Data
Make sure the old Platform Manager is shut down.

Migrate the Platform Manager Infrastructure
1. Migrate HTTP and HTTPS port configurations as described in "Migrate the Platform
Manager Infrastructure" on page 98.

2. If you customized the Platform Manager Java Service Wrapper, copy the customizations from
the old wrapper_conf or custom_wrapper.conf files to the 9.7 custom_wrapper.conf file. The
files are located in the Software AG_directory \profiles\SPM\configuration directory.

3. For each case below, open the file in the indicated directory in the old installation and in the
9.7 installation. If any values in the two files are different, copy the old value over the 9.7
value. In addition, update file system paths in the 9.7 files to point to the 9.7 installation.
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Configuration

File Name in Old and 9.7 Software AG Directories

Debug

\proﬁles\SPM\conﬁguration
\com.softwareag.platform.conﬁg.propsloadecom.softwareag.
platform.debug.properties

JMX ports

same
directory \com.softwareag.jmx.connector.pid-port .properties

Security
authorization

same directory \com.softwareag.security.authz.pid.properties

Security
LDAP

same directory \com.softwareag.security.ldap.pid.properties

Single signon service

same directory \com.softwareag.sso.pid.properties

SSH

same directory \com.softwareag.sshd.pid.properties

Watchdog

same
directory \com.softwareag.conﬁg.watchdog.pid.properties

Journal
logger

\proﬁles\SPM\conﬁguration\logging\log_conﬁg_.xml

4. For each case below, open the file in the indicated directory and update file system paths to
point to the 9.7 installation.
Configuration

File Name in 9.7 Software AG Directories

JAAS

\proﬁles\SPM\conﬁguration\jaas.conﬁg

Password
manager

\proﬁles\SPM\conﬁguration\security\passman
\defaultPassStore.dat and mpw.dat

Run the Platform Manager Migration Utility
For a general description of migration utility behavior, see "Migration Utilities" on page
28.
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Perform a Custom Migration
1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \PlatformManager\migrate\bin directory, and run the command migrate.
{bat|}.

2. The utility asks for the full path to one of the following:
The Software AG directory that contains the old Platform Manager installation
(for example, C:\old_Software AG_directory or /opt/old_Software AG_directory ).
The Zip ﬁle you made earlier.

3. The utility asks whether to import migration settings. Enter N.
4. The utility asks whether to migrate users, roles, and groups; the JAAS configuration; and
password manager data.

5. The utility asks whether to export your settings. If you want to perform other migrations by
importing the settings from this session, enter Y. If not, enter N.

6. The utility asks whether to begin migration. If you enter Y, the utility migrates the data you
selected.

Migrate Using Imported Settings
Imported seings can come from the following:
Seings you exported from a custom migration. These seings are
stored in a ﬁle named migrate.dat. The ﬁle is stored in the 9.7_Software
AG_directory \PlatformManager\migrate directory from which you ran the custom
migration. Copy the migrate.dat ﬁle to any directory on machines that host Platform
Manager 9.7 installations to which you want to migrate data.
Seings in the default migrations provided with Platform Manager. For each old
release, the seings are stored in a ﬁle named migraterelease sbs.dat ﬁle in the
9.7_Software AG_directory \PlatformManager\migrate directory. The seings tell the
migration utility to migrate the data listed in "Overview" on page 98.
Migrate Using Imported Settings with Prompting

1. On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \PlatformManager\migrate directory, and run the command migrate.
{bat|}.

2. The utility asks for the full path to the Software AG directory that contains the old Platform
Manager installation or to the Zip file you made earlier.

3. The utility asks whether to import migration settings. Enter Y and, when prompted, provide
the full path to the migrate.dat file or the migrate{901|951|960}sbs.dat file.
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Migrate Using Imported Settings Without Prompting
On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \PlatformManager\migrate directory, and run the command below. If an
error occurs, the utility exits.
migrate.{bat|}
{-srcDir|-srcFile} full_path_to_{old_Software AG_directory|Zip_file}
-importFile full_path_to_ {migrate.dat|migrate{901|951|960}sbs.dat}
-silent true

Update the Platform ManagerNERV Configuration
Go to the 9.7_Software AG_directory \proﬁles\SPM\conﬁguration
\com.softwareag.platform.conﬁg.propsloader directory and open the
com.softwareag.platform.eda.nerv.properties ﬁle. Update JMS provider references to
point to your 9.7 JMS provider, if they do not already. Update ﬁle system paths to point
to the 9.7 installation.
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Overview
You complete the CentraSite upgrade by:
Running CentraSite scripts that do the following:
Migrate conﬁguration data from the old CentraSite and assets from the old
Registry Repository to the new CentraSite installation.
Transform and migrate the LDAP conﬁguration from the old Registry Repository
to the new CentraSite JAAS conﬁguration.
If necessary, performing manual tasks to recreate seings or object types, and to
install GUI extension plug-ins.

Before Migrating Data
1. Make sure the old CentraSite and CentraSite 9.7 are shut down.
2. Export configuration data from the old CentraSite and assets from the old Registry
Repository into a Zip file. On the old machine, open a command window, go to the
old_Software AG_directory /CentraSite/utilities directory, and run this command:
sbsExport.{cmd|sh} /full_path_to_Zip_file

An example of this command is ./sbsExport.sh /tmp/sbs_cs82_data.zip

3. If the old and new CentraSite installations are on different machines, copy the Zip file to any
directory on the 9.7 machine.

Migrate the Data
1. Import configuration data and assets from the Zip file you created earlier. On the 9.7
machine, open a command window, go to the 9.7_Software AG_directory /CentraSite/
utilities directory and run this command:
sbsImport.{cmd|sh} /full_path_to_Zip_file

An example of this command is ./sbsImport.sh /tmp/sbs_cs82_data.zip

2. Start CentraSite 9.7.
3. Transform and migrate the LDAP configuration to the new JAAS configuration by running
this command:
CentraSiteCommand.{cmd|sh} generate JaasConfiguration -url CentraSite_9.7_URL
-user CentraSite_9.7_admin_user -password password

The script generates JAAS LoginModule entries that correspond to the
old LDAP conﬁguration and saves the entries in the jaas.conﬁg ﬁle in the
9.7_Software AG_directory /CentraSite/proﬁles/CTP/conﬁguration directory.
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For each LDAP domain, the script creates user and group ﬁles that map
internal (CentraSite) properties to external (LDAP) properties and saves the
ﬁles in the 9.7_Software AG_directory /CentraSite/proﬁles/CTP/conﬁguration/
com.softwareag.platform.conﬁg.propsloader directory.

4. If you use single sign-on with CentraSite, do the following:
a. Open the jaas.config file in the old and new Software AG_directory /CentraSite/profiles/
CTP/configuration directories. Copy the following from the old file to the 9.7 file:
ServletHeaderLoginModule for extracting the user ID from the incoming
HTTP header.
SimpleNameMappingLoginModule, if you are using it.
Any other entries you are using to process the extracted user ID.
The 9.7 jaas.conﬁg ﬁle should look like this:
CentraSite {
com.softwareag.security.jaas.login.internal.InternalLoginModule sufficient
...
com.softwareag.security.sin.is.ldap.lm.LDAPLoginModule sufficient
...
com.softwareag.security.jaas.login.modules.ServletHeaderLoginModule
required
...
com.softwareag.security.jaas.login.modules.SimpleNameMappingLoginModule
required
...
com.softwareag.security.sin.is.ldap.lm.LDAPLoginModule required
...
};

The initial InternalLoginModule is normally only for users in the INTERNAL
domain, and the initial LDAPLoginModule is for LDAP users that are logging
in directly and not via single sign-on. If you need only single-sign on logins, you
can remove the initial InternalLoginModule and LDAPLoginModule.
b. Set up your LDAP configuration to resolve the extracted user ID via LDAP. Modify the
generated LDAP login module to enable single sign-on-related options, such as technical
user. Apply LDAP single sign-on technical user credentials if necessary.

Complete the Upgrade
1. Change any settings in CentraSite Control that you noted in Prepare CentraSite .
2. 8.2 upgrade: If you want to use instances of ApplinX object types from CentraSite 8.2
in CentraSite 9.7, manually re-create them using the definitions you noted in Prepare
CentraSite .

3. If you installed plug-ins that are GUI extensions for CentraSite Control in the old CentraSite
installation, install them in the CentraSite 9.7 installation.
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Overview
You complete the Mobile Administrator upgrade by:
Running the Mobile Administrator updater to upgrade the Mobile Administrator
source code and migrate the Mobile Administrator database.
Verifying that all features required by your use case are conﬁgured.
Updating any build nodes you used with the old Mobile Administrator.
Updating the App Store Client.

Run the Updater and Verify Configurations
1. Go to the Software AG_directory /MobileAdministrator directory and run the updater by
running the command ./update.sh as root.

2. From the same directory, start Mobile Administrator by running the command /etc/
init.d/appfresh-mobile start.

3. In Mobile Administrator, click Settings, click Sites, and click a domain. On the domain

page, click Configuration Assistant. Make sure all the features you need are configured. If
necessary, follow the instructions to configure any features that are missing. Repeat this step
for each domain.

Update Build Nodes
1. If you used the Mac OS build node with the old Mobile Administrator, update the build node
as follows:
a. Go to the Mobile Administrator > Build Nodes page at https://Mobile Administrator_URL /
build_nodes. Download the appfresh-build-node-version .zip file, and extract the files to
any directory.
b. Launch the build node application. On the Install tab, in the Build Node field, make sure
the displayed build node version corresponds to the version of the build node you just
downloaded (that is, appfresh-build-node-version .zip).

2. If you used the Windows 8 build node with the old Mobile Administrator, update the build
node as follows:
a. Go to the Windows Control Panel and uninstall the previous build node.
b. Go to the Mobile Administrator > Build Nodes page at https://Mobile Administrator_URL /
build_nodes. Download and run the AppFreshBuildNode-version .exe file.
c. Launch the build node application. On the Build Node tab, start the build node by clicking
Start.
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Update the App Store Client
1. Go to the https://Mobile Administrator_URL /apps/appfresh-mobile-client/build page.
2. On the Build Configurations tab, start the build jobs for the App Store Client by selecting the
platforms for which to update the client and clicking Launch Selected Build Configs.

3. On the Build Jobs tab, verify that the build jobs have completed successfully. Corresponding
build nodes should appear on the https://Mobile Administrator_URL /build_nodes page.
If they do not, click on the build job to display the details that will help you diagnose the
problem.
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Overview
Run the OneData Migration Utility

Overview
You complete the OneData upgrade by:
Running the OneData migration utility. The utility migrates conﬁguration data.
Migrating customizations to the OneData Java Service Wrapper.
8.4 upgrade: Enabling new logging method.

Run the OneData Migration Utility
Make sure the old OneData is shut down.
On the 9.7 machine, open a command window, go to the 9.7_Software
AG_directory \proﬁles\ODE\bin\migrate directory, and run the command below. If an
error occurs, the utility exits.
migrate.{bat|sh}
{-srcDir|-srcFile} full_path_to_{old_Software AG_directory|Zip_file}
-silent true

Before migrating data, the utility backs up the ﬁles that contain the 9.7 conﬁguration
data in the 9.7_Software AG_directory \proﬁles\ODE\bin\onedata\conﬁg directory. The
backup ﬁles have the extension .bck.

Migrate Customizations to the Java Service Wrapper
If you customized the old OneData Java Service Wrapper, copy the customizations from
the old wrapper_conf or custom_wrapper.conf ﬁles to the 9.7 custom_wrapper.conf ﬁle.
The ﬁles are located in the Software AG_directory \proﬁles\ODE\conﬁguration directory.

8.4 Upgrade: Enable New Logging Method
In OneData 8.4, log entries for an action might have been distributed across multiple
ﬁles. Starting in OneData 9.0, to improve debugging, log entries for an action are
wrien to a single ﬁle. You must enable the new method of logging for OneData
modules. Follow the examples in the sample_log4j_conﬁg.txt ﬁle in the 9.7_Software
AG_directory \proﬁles\ODE\bin\onedata\conﬁg directory.
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Overview
Presto stores all of its data, including mashups, mashables, apps and workspaces, in
the Presto repository. To upgrade, you set up Presto 3.8 to use the Presto 3.7 repository.
If you deployed extensions to Presto 3.7 features (for example, if you used scripting in
mashups and the scripts are stored in ﬁles), you also copy the extensions to the Presto
3.8 installation.

Set Up the Presto Repository
Set Up Repository When Using the Embedded Derby Database
If you used the embedded Derby database for your Presto 3.7 repository, follow the
instructions below.

1. Presto 3.8 comes with a prepopulated Derby Presto repository in the prestorepository
directory. Go to the 9.7_Software AG_directory /Presto/apache-tomee-jaxrs/
bin and rename the prestorepository directory (for example, rename the directory
prestorepository_orig).

2. Go to the old_Software AG_directory /Presto/apache-tomee-jaxrs/bin and copy the
prestorepository and mashzonerepository directories to the 9.7_Software AG_directory /
Presto/apache-tomee-jaxrs/bin directory.

Set Up Repository When Using Any Other Database
If you used MySQL, Oracle, PostGres, or SQL Server for your Presto 3.7 repository,
follow the instructions below.

1. Go to the old_Software AG_directory /Presto/apache-tomee-jaxrs/lib directory and copy
the JDBC driver jar file for your database to the same directory in the Presto 3.8 installation.
Database

JDBC Driver Jar File

MySQL

mysql-connector-java-5.1.31.jar

Oracle

ojdbc6.jar

PostGres

postgresql-9.2.1004.jdbc4.jar

SQL Server

jtds-1.3.1.jar

2. If you used MySQL, Oracle, or SQL Server for your Presto 3.7, do the following:
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a. Go to the 9.7_Software AG_directory /Presto/apache-tomee-jaxrs/webapps/presto/WEBINF/lib directory and delete the jackbe-presto-rds-postgre-derby-3.8.jar file.
b. Go to the 9.7_Software AG_directory /Presto/prestorepository directory and copy the
jackbe-presto-rds-oracle-mysql-mssql-3.8.jar file to the 9.7_Software AG_directory /
Presto/apache-tomee-jaxrs/webapps/presto/WEB-INF/lib directory.

3. Go to the old_Software AG_directory /Presto/apache-tomee/jaxrs/conf directory and copy
the tomee.xml file to the same directory in the Presto 3.8 installation.

Update the Snapshots Repository Connection Information
If you used Snapshots in Presto 3.7 and you stored the data in a separate Snapshots
repository, follow the steps below.

1. Open the Presto 3.8 Admin Console.
2. If the JDBC driver you used with the 3.7 Snapshots repository is not the same driver you used
for the Presto 3.7 repository, go to the old_Software AG_directory /Presto/apache-tomeejaxrs/lib directory. Copy the JDBC driver jar file for the database that contains the Snapshots
repository over the same file in the same directory in the Presto 3.8 installation.
Database

JDBC Driver Jar File

Derby

derby-embedded-10.5.3.jar

MySQL

mysql-connector-java-5.1.31.jar

Oracle

ojdbc6.jar

PostGres

postgresql-9.2.1004.jdbc4.jar

SQL
Server

jtds-1.3.1.jar

3. Update the Snapshots 3.8 configuration to point to the Snapshots 3.8 repository as follows:
a. Open the JDBC Configuration menu, click Datasources, click SnapshotDatasource, and
then click Edit.
b. Edit the configuration properties as needed. For information on the properties, see the
section on adding a data source in the Presto Admnistration documentation.
c. Click Save.
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Update the Presto Configuration and Copy Extensions
Most of the Presto conﬁguration is stored in the Presto repository. This section
explains how to copy the parts of the 3.7 conﬁguration that were not maintained in the
repository, including extensions such as custom security proﬁles that you deployed
in Presto 3.7. The procedure varies depending on whether you used an external
conﬁguration directory with Presto 3.7.

Update When an External Configuration Directory Was Used
1. Update the classpath in the application server that hosts Presto 3.8 to work with the external
configuration directory and any subdirectories. For instructions, see the topic on setting up an
external configuration directory in the Presto Administration documentation.

2. Manually migrate the changes you made in the 3.7 configuration files listed below from
Presto 3.7 to the corresponding files in Presto 3.8. Because of the complexity of the
configuration, the easiest method is to use the difference tool offered by many text editors.
All ﬁles listed in the topic on conﬁguration ﬁles that must be internal in the
Presto Administration documentation.
The userRepositoryLdap.properties ﬁle, located in the external conﬁguration
directory.

Update When No External Configuration Directory Was Used
1. Copy any extensions you deployed from Presto 3.7 to the corresponding directory for Presto
3.8. See the Presto Administration documentation for a complete list of extensions you might
need to copy.

2. Manually migrate the changes you made in the 3.7 configuration files listed below from
Presto 3.7 to the corresponding files in Presto 3.8. Because of the complexity of the
configuration, the easiest method is to use the difference tool offered by many text editors.
All ﬁles listed in the section on conﬁguration ﬁles that must be internal in the
Presto Administration documentation.
The userRepositoryLdap.properties ﬁle, located in the old_Software AG_directory /
Presto/webapps/presto/WEB-INF/classes directory.

3. If you used database mashables, go to the old_Software AG_directory /Presto/apachetomee-jaxrs/presto/WEB-INF/config/db/jdbc directory. Copy the database driver jar files to
the same directory in the Presto 3.8 installation.
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Point to the 3.8 Online Help
Point Presto 3.8 at the 3.8 help documentation. For instructions, see the section on
updating help or using oﬄine help in the Presto Administration documentation, and use
the URL http://mdc.jackbe.com/prestodocs/v3.8/.

Upgrade the Integrated MashZone Server and RTBS Server
Configurations, and MashZone Feeds
Presto’s Integrated MashZone Server stores additional data. Follow the instructions
below to copy the data to the Presto 3.8 installation.

1. Go to the old_Software AG_directory /Presto/mashzone/data/resources directory and copy
the files to the same directory in the Presto 3.8 installation.

2. Go to the old_Software AG_directory /Presto/mashzone/data/jdbcdrivers directory and
copy the files to the same directory in the Presto 3.8 installation.

3. Go to the Admin Console in Presto Hub. Expand the MashZone Server section, click Server
Settings, and click the Resources tab. Review the paths to resource directories. If any paths
point to directories in the Presto 3.7 installation, copy those directories to the Presto 3.8
installation and then update the paths in MashZone Administration to point to the correct
location in the Presto 3.8 installation.

Update Mashups that Use RAQL Queries
Presto 3.8 contains signiﬁcant changes and additions to the RAQL query syntax that you
use in mashups. Some Presto 3.7 mashups that include RAQL queries will not run in
Presto 3.8, and you will need to update them. For other Presto 3.7 mashups, you might
want to take advantage of new RAQL query syntax. For complete information, see the
topic about migrating RAQL queries from 3.7 to 3.8 in the Presto documentation.
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Complete Final Upgrade Tasks for All Products
Conﬁgure your products as described in the 9.7 product documentation.
If you installed your 9.7 products on a diﬀerent machine than your old products,
make sure to update host names in your 9.7 products, in the connections between
your products, and in your database tables. This guide indicates many locations
in which to update host names, but make sure you also specify the correct host
names when you conﬁgure your 9.7 products using the instructions in the product
documentation. Also make sure any absolute paths in the 9.7 conﬁguration ﬁles
point to valid locations, or change them to be correct for the new machine. If the
machine has a diﬀerent operating system or hardware, make sure your JVM seings
are correct.
Use the Software AG Update Manager you installed with the 9.7 products to apply
the latest ﬁxes to the 9.7 products you installed. For instructions, see Using the
Software AG Update Manager.
In each release, changes are made to product behavior, services, parameters,
properties, and APIs. You might need to modify product ﬁles or assets to
accommodate these changes. For detailed information about the changes, read
the product readmes for each of the releases from your old release through the
9.7 release. For example, if you are upgrading from release 8.2, read the product
readmes for releases 8.2, 9.0, 9.5, 9.6, and 9.7. Also read the product release notes
for those releases to understand new functionality. Readmes and release notes are
available on the Software AG Documentation website.
After installation, you might have set Windows services for products to Manual, and
disabled scripts that start UNIX daemons, to avoid automatically starting both old
and new products. When your new environment is ready, after you stop running the
old products and when you want to start running the new ones, you can reset the
Windows services to Automatic, and re-enable the UNIX scripts.

Troubleshooting
If you encounter errors during the upgrade, try the troubleshooting methods below.
Look in log ﬁles.
Type of Log

Location

Installation and
uninstallation

9.7_Software AG_directory \install\logs directory
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Type of Log

Location

Product

In a logs directory in the product ﬁle structure, or in
the 9.7_Software AG_directory \proﬁles\product \logs
directory.

Data migration

9.7_Software AG_directory \install\logs directory and
product directories indicated by the upgrade procedures

Database
migration

9.7_Software AG_directory \common\db\logs directory.

Go to the Knowledge Center on the Empower Product Support Website and search
using keywords such as upgrade.
Look up error messages in the webMethods Error Message Reference.
Go to the Software AG Developer Community and join the upgrade discussion
forum.
If you cannot resolve the problem using the methods above, contact Software AG Global
Support.
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