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About These Guides

Software AG Designer enables you to create and maintain a wide number of
applications, services, tasks, and other components to implement and execute your
solutions in the webMethods product suite. When you install a Designer feature, the
online help for that feature appears in the Designer Guides node of the Eclipse Help
table of contents. Expand this node to view the available help sets.

If a feature is not installed, there will be no help set available for it. However, you can
view PDF versions of all Designer features on the Software AG Documentation website.

Document Conventions

Convention Description

Bold Identifies elements on a screen.

Narrowfont Identifies storage locations for services on webMethods
Integration Server, using the convention folder.subfolder:service .

UPPERCASE Identifies keyboard keys. Keys you must press simultaneously
are joined with a plus sign (+).

Italic Identifies variables for which you must supply values specific to
your own situation or environment. Identifies new terms the first
time they occur in the text.

Monospace
font

Identifies text you must type or messages displayed by the
system.

{ } Indicates a set of choices from which you must choose one. Type
only the information inside the curly braces. Do not type the { }
symbols.

| Separates two mutually exclusive choices in a syntax line. Type
one of these choices. Do not type the | symbol.

[ ] Indicates one or more options. Type only the information inside
the square brackets. Do not type the [ ] symbols.

http://documentation.softwareag.com/
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Convention Description

... Indicates that you can type multiple options of the same type.
Type only the information. Do not type the ellipsis (...).

Documentation Installation
You can download the product documentation using the Software AG Installer. The
documentation is downloaded to a central directory named _documentation in the main
installation directory (SoftwareAG by default).

Online Information
Software AG Documentation Website

You can find documentation on the Software AG Documentation website at hp://
documentation.softwareag.com. The site requires Empower credentials. If you do not
have Empower credentials, you must use the TECHcommunity website.

Software AG Empower Product Support Website

You can find product information on the Software AG Empower Product Support
website at hps://empower.softwareag.com.

To submit feature/enhancement requests, get information about product availability,
and download products and certified samples, go to Products.

To get information about fixes and to read early warnings, technical papers, and
knowledge base articles, go to the Knowledge Center

Software AG TECHcommunity

You can find documentation and other technical information on the Software AG
TECHcommunity website at hp://techcommunity.softwareag.com. You can:

Access product documentation, if you have TECHcommunity credentials. If you do
not, you will need to register and specify "Documentation" as an area of interest.

Access articles, demos, and tutorials.

Use the online discussion forums, moderated by Software AG professionals, to
ask questions, discuss best practices, and learn how other customers are using
Software AG technology.

Link to external websites that discuss open standards and web technology.

http://documentation.softwareag.com
http://documentation.softwareag.com
https://empower.softwareag.com
https://empower.softwareag.com/Products/default.asp
https://empower.softwareag.com/KnowledgeCenter/default.asp
http://techcommunity.softwareag.com
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Implementing a Multi-User Eclipse Configuration
The default installation of Software AG Designer is configured to support a single user.
You can modify the Eclipse installation to support a multi-user environment.

There are three different locations in the Eclipse installation that are important in the
context of deploying Eclipse in a multi-user setup:

The install area (the location where the Eclipse Platform is installed).

The configuration area (the location where Eclipse stores essential runtime metadata
and cached data in general).

The instance area (also known as the workspace).

You can choose to create a multi-user setup where each user has his own configuration,
or where all users share a common configuration.

For detailed information about implementing a multi-user setup, refer to the Eclipse
documentation at:

hp://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-
options.html

Configuring Eclipse for Non-Administrator Accounts
This information applies primarily to Software AG Designer/Eclipse installed in a
Windows environment.

Typically, Software AG Designer is installed by a system administrator, and can be
started by a user account with administrator rights. However, for security reasons, many
organizations prohibit the everyday operation of applications with an administrator-
enabled user account.

Starting Designer/Eclipse with a non-administrator account can cause problems when
the software was installed by an administrator account. The most significant issues are:

Lack of permission to write to specific directories in the Eclipse installation.

Potential for increasing the size of the user home directory. In cases where a size
limitation is placed on this directory, this may cause Designer/Eclipse to stop
running.

During installation, Designer/Eclipse creates a writable configuration directory within
the Eclipse installation, for example:

C:\SoftwareAG\Designer\eclipse\configuration

Each time Designer/Eclipse starts, it verifies that the configuration directory is writable.
If it is not writeable, by default, Designer/Eclipse creates a private configuration
folder in the user home directory. Depending on the features installed, the size of the

http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html
http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html
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configuration area varies. If the operating system enforces a limit on the size of the user
home directory, it is possible for the Designer/Eclipse configuration data to exceed that
limit, which causes Designer/Eclipse to stop running.

To avoid this situation, it is possible to start Designer/Eclipse with a command line
option that redefines the location of the user home directory. The default location for a
private configuration area is:

<user-home-dir>/.eclipse/<product-id>_<product-version>/configuration

The user home directory is determined by the user.home Java system property. The
product id and version are obtained from the product marker file .eclipseproduct under
the Eclipse install.

A non-default configuration area can be defined by seing the osgi.configuration.area
system property. This property can be set by the end user, but it is more convenient
to set it either in the launcher.ini file or in the config.ini file at the base configuration
location.

For detailed information about the Eclipse configuration directory and runtime options,
refer to the Eclipse documentation at:

hp://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/
multi_user_installs.html

hp://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/
runtime-options.html

Considerations when Starting Designer on Windows
After installing Software AG Designer in a Windows environment, you may find that
aempts to start Designer from a shortcut or from the command line result in an "access
denied" error. This situation can occur if you are logged in as a non-administrator user.

To resolve this issue, ensure that the user account has write access to the files in the
Software AG_directory installation directory.

In addition, when starting Designer from a shortcut you can right-click the shortcut and
select Run as administrator.

Changing the JRE or JDK Used by Designer
By default, Software AG Designer uses the JDK that the Software AG Installer installs as
described in the PDF publication Installing webMethods and Intelligent Business Operations
Products. You can modify the Designer configuration to use a different JRE or JDK. If you
want to switch back to the JDK installed by the Software AG Installer, it is located in the
Software AG_directory\jvm directory.

http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/multi_user_installs.html
http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/multi_user_installs.html
http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html
http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html
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Important: If you switch to a non-default JRE or JDK, apply maintenance updates from
the appropriate vendor on a regular basis, as you would for any JREs and JDKs you
install yourself.

Note: Software AG tests products only with the JDKs installed by the Software AG
Installer. If you change to a different JDK or JRE and encounter problems, Software AG
may require you to reproduce the issues with the JDK that is installed by the
Software AG Installer.

To change the Designer JRE or JDK

1. Locate the following file in your Designer installation:

Software AG_directory\Designer\eclipse\eclipse.ini

2. Open the file in a text editor.

3. Locate the -vm parameter and modify it to contain the directory path to the JRE or JDK you
want to use.

4. Save the file and restart Designer.

Monitoring and Modifying Memory Usage
As you work with Software AG Designer, background processes are constantly writing
to system memory. Some processes can consume a considerable amount of memory
while they are running. This can cause Designer to slow down or become unresponsive
if its memory requirements approach or exceed the configured maximum.

Eclipse provides a heap status monitor function, and by default, this feature is enabled
in Designer. The monitor appears in the status bar at the lower right of Designer:

The display shows the amount of memory in use and the total amount available. If the
display frequently shows values near the configured maximum, consider increasing
the maximum. For more information, see "Adjusting the Designer Memory Seings" on
page 11.

If the display has been disabled, you can re-enable it by clicking Window > Preferences,
selecting the General entry, and selecting the Show heap status option.

For more information about memory allocation in Eclipse, see the topic “Running
Eclipse” in the Workbench User Guide online help (Workbench User Guide > Tasks > Running
Eclipse).
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Adjusting the Designer Memory Settings
To adjust the Designer memory settings

1. Locate the following file in your Designer installation:

Software AG_directory\Designer\eclipse\eclipse.ini

2. Open the file in a text editor.

3. Locate the -Xmx parameter and modify it as required:

For systems with 1 GB or less of memory, set -Xmx=512m

For systems with more than 1 GB of memory, set -Xmx=1024m

Note: If you experience errors such as "OutOfMemoryError: PermGen Space" with
Oracle JVMs, it may help to increase the value of the launcher.XXMaxPermSize
option in the eclipse.ini file and/or in the Run/Debug configuration in Designer.

4. Ensure that the value for -Xms is less than the value for -Xmx.

5. Save the file and restart Designer.

Finding Installed Products, Versions, and Fixes
You can find the following information about the Software AG products installed with
Software AG Designer:

Which products are installed

The version and fix level of a product

You can also view and copy information about the Software AG features installed
including feature name, version, and ID.

For more information, see the following topics:

"Identifying Installed Products, Versions, and Fixes" on page 11

"Viewing and Copying Information About Software AG Features" on page 12

For technical details about Eclipse features, see the Features topic in the Workbench User
Guide online help (Workbench User Guide > Concepts > Features).

Identifying Installed Products, Versions, and Fixes
You use the About Software AG Designer dialog box to find information about installed
Software AG products, versions, and fixes.

In addition, the Welcome page provides a short description of each installed product
as well as links to the Eclipse perspective associated with the product and the product
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documentation. The Welcome page opens the first time you start Designer. To view the
Welcome page if it is closed, click Help > Welcome.

To find information about installed products, their versions, and applied fixes:

1. In Designer: Help > About Software AG Designer.

2. The Software AG tab displays all installed Software AG products, their versions, and the
latest fix levels, if a fix has been applied.

3. To view details about the Eclipse features and plug-ins associated with a product, click the
product icon.

Viewing and Copying Information About Software AG Features
To view and copy information about the features provided by Software AG:

1. In Designer, click either of the following:

Window > Preferences > Software AG

Help > About Software AG Designer > Software AG Preferences

The Installed Software AG Features table displays all installed features, their
versions, and IDs.

2. Select the feature or features you want to copy. Right-click the features and click Copy.

Using Designer with Software AG Runtime
You can install an instance of Software AG Runtime in your Software AG product
directory with the Software AG Installer. This provides you with a convenient and
integrated web server for testing the web projects you develop in Designer.

You can manage the Software AG Runtime instance using the Designer Servers view.
In this view, you can connect to an existing Software AG Runtime instance, check the
server status, start it, stop it, and publish your projects to it.

You can determine the version of the installed Software AG Runtime by referring to the
PDF publication webMethods and Intelligent Business Operations System Requirements for
your version of Designer. This section explains how to add the Software AG Runtime
instance and how to display it in the Designer Servers view.

Defining a Software AG Runtime Entry in the Servers View
You can define a Software AG Runtime entry in the Servers view. When you select
Software AG Runtime in the Servers view, the toolbar buons and menu commands
for starting, debugging, and stopping the server are enabled. For more information
about starting, debugging, and stopping Software AG Runtime, see the PDF publication
Working with Software AG Runtime.
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Note: With Software AG Runtime, you can deploy only web projects that contain servlets
or JSPs.

Before you begin, make sure that you have installed Software AG Runtime and
Software AG Platform Manager using the Software AG Installer.

To define a Software AG Runtime instance

1. In the Servers view, right-click and click New > Server.

2. In the Select the server type list, expand the Software AG folder, and select Software AG
Runtime.

3. Accept the default value of localhost for Server’s host name and specify a name for the
server in the Server name box.

4. Click Next.

5. Specify the Software AG_directory installation directory or type the URL for the Platform
Manager to select an installed instance of Software AG Runtime. Do one of the following:

In the Installation Directory box, type or browse to the Software AG_directory, for
example, C:\SoftwareAG.

In the Platform Manager URL box, type the URL of the Platform Manager.

6. Enter your user name and password to connect to the Platform Manager. Click List Servers.

7. In the Servers list, select one of the listed instances of Software AG Runtime.

8. Click Finish.

Adding the Software AG Runtime Environment
Using the Preferences page, you can add Software AG Runtime environment definitions.

Before you begin, make sure that you have installed Software AG Runtime and
Software AG Platform Manager. If Software AG Runtime is not installed, you will not
have it as an entry in the Servers list as described later. Use the Software AG Installer to
install the server in your Software AG installation.

To add a Software AG Runtime environment

1. In Designer, click Window > Preferences.

2. In the Preferences window, expand the Server node and select Runtime Environments.

3. Click Add.

4. In the Select the type of runtime environment list, expand the Software AG folder, select
Software AG Runtime and click Next.

5. Specify the Software AG_directory installation directory or type the URL for the Platform
Manager to select an installed instance of Software AG Runtime. Do one of the following:
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In the Installation Directory box, type or browse to the Software AG_directory, for
example, C:\SoftwareAG.

In the Platform Manager URL box, type the URL of the Platform Manager.

6. Enter your user name and password to connect to the Platform Manager. Click List Servers.

7. In the Servers list, select one of the listed instances of Software AG Runtime.

8. Click Finish.

Enabling Designer Console Output on Windows
At times, users of Software AG Designer might want to view Designer output messages
in a Windows Command Prompt session. This mechanism is disabled by default. If you
want to use a Windows Command Prompt session to monitor Designer activity and
error messages, you can implement any of the following solutions:

Modify the Designer configuration. This will enable output to a Command Prompt
session whenever you start Designer.

Start Designer from the command line with extra parameters. In this case, output is
enabled only during the current session.

Modify a Designer shortcut. This will enable output only during the session you
start from the shortcut.

For additional information about configuring the Designer startup, refer to the Eclipse
documentation at:

hp://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-
options.html

Modifying the Designer Configuration to Enable Console Output
You can modify the Designer configuration to enable output of Designer activity and
error messages to a Command Prompt session on Windows. After you modify the
Designer configuration, the Designer output will be available every time you start
Designer.

To modify the Designer configuration to enable console output

1. Locate the following file in your Designer installation:

Software AG_directory\Designer\eclipse\eclipse.ini.

2. Open the file in a text editor.

3. Locate the -vm parameter and do the following:

a. Type -consoleLog in a new line above the -vm parameter.

b. Replace javaw.exe with java.exe at the end of the -vm parameter definition.

http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html
http://help.eclipse.org/kepler/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html


M 
Odd Header

Tips for Working with Software AG Designer

Working with Software AG Designer Version 9.7 15

4. Save the file and start Designer.

Adding Parameters to the Command Line to Enable Designer
Console Output
You can add parameters when starting Designer from the command line to enable
output of Designer activity and error messages to a Command Prompt session on
Windows. In this case, output is enabled only during the current session.

To enable console output when starting Designer from a Command Prompt window

1. Open a Command Prompt window in this directory:

Software AG_directory\Designer\eclipse

2. Type the following command to start Designer with the console output enabled:

eclipse –consoleLog –vm <path to java.exe>

Modifying a Designer Shortcut to Enable Console Output
You can add parameters to a Windows shortcut to enable output of Designer activity
and error messages to a Command Prompt session on Windows when you start
Designer from the shortcut. In this case, output is enabled only during the session
started from the modified shortcut.

To modify a Designer shortcut to enable console output

1. Locate the Designer shortcut you want to modify, for example:

Start > All Programs > Software AG_directory  > Tools > Software AG Designer 9.7

2. Copy the shortcut and paste the copied shortcut onto your desktop.

3. Right-click the copied shortcut and click Properties > Shortcut.

4. In the Target field, add the following parameters to the end of the Target definition:

 –consoleLog –vm <path to java.exe>

5. Click OK to save the new Target definition.

6. Rename the copied shortcut as desired.

Configuring SSL Connections in Designer
Use the following procedure to configure a Secure Sockets Layer (SSL) connection in
Software AG Designer.

For more information about Java SSL configurations, see the JSSE Reference Guide in the
Java SE documentation.
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To configure an SSL connection

1. Locate the following file in your Designer installation:

Software AG_directory\Designer\eclipse\configuration\config.ini

2. Open the file in a text editor.

3. Add the following lines to the file:

javax.net.ssl.trustStore=truststore file path

where truststore file path  is the path to the server truststore in your file system.
For example:
javax.net.ssl.trustStore=C\:\\keystore\\localhost.jks

Note: Be sure to use the correct separators when specifying the path to the
truststore file. For example: C\:\\

javax.net.ssl.trustStoreType=truststore file type

where truststore file type  is the type of truststore file that the server supports. For
example:
javax.net.ssl.trustStoreType=JKS

4. Save the file and restart Designer.
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2   Software AG Training Resources

You might choose to benefit from Software AG training before you use Software AG
products, although training is not a prerequisite. Software AG training provides
extensive coverage of Software AG Designer functionality, with hands-on sessions and
numerous exercises delivered by experienced Software AG instructors.

For more information about available training courses and to schedule training for
your organization, visit the Software AG Training page at hp://www.softwareag.com/
corporate/service/ges/default.asp.

http://www.softwareag.com/corporate/service/ges/default.asp
http://www.softwareag.com/corporate/service/ges/default.asp
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3   Software AG  Information Resources

The _documentation directory of your Software AG installation provides an extensive
repository of product-related information. For example, if you are interested in an
overview of the webMethods product suite or business process management, you may
want to examine the PDF publication Understanding webMethods and Intelligent Business
Operations Products. Documentation for NaturalONE and Adabas is also available.

The _documentation directory is installed as a separate component in the
Software AGInstaller. If the _documentation directory is not installed on your system,
then you can install the directory by using the Installer.

You can also download documentation from the following locations:

Software AG Documentation website at hp://documentation.softwareag.com. The
site requires an Empower login. If you do not have an Empower login, you must use
the TECHcommunity website.

Software AG TECHcommunity website at hp://techcommunity.softwareag.com.
The site requires a TECHcommunity login. If you do not have a TECHcommunity
login, register and specify "Documentation" as an area of interest.

Additionally, you might find the Software AG publication, BPM Basics for Dummies,
of particular interest. This book addresses the business management and information
technology sides of BPM, and delves into the process-centric foundation upon
which BPM is built. You can download the entire book at no cost from: hp://
www.softwareag.com/Corporate/res/books/bpm_for_dummies/default.asp.

A number of other Software AG publications covering topics such as process intelligence
and Service Oriented Architecture (SOA) are available at no cost in a variety of
languages at: hp://www.softwareag.com/corporate/res/books/default.asp.

http://documentation.softwareag.com
http://techcommunity.softwareag.com
http://www.softwareag.com/Corporate/res/books/bpm_for_dummies/default.asp
http://www.softwareag.com/Corporate/res/books/bpm_for_dummies/default.asp
http://www.softwareag.com/corporate/res/books/default.asp

	Table of Contents
	About These Guides
	Document Conventions
	Documentation Installation
	Online Information

	Tips for Working with Software AG Designer
	Implementing a Multi-User Eclipse Configuration
	Configuring Eclipse for Non-Administrator Accounts
	Considerations when Starting Designer on Windows
	Changing the JRE or JDK Used by Designer
	Monitoring and Modifying Memory Usage
	Adjusting the Designer Memory Settings

	Finding Installed Products, Versions, and Fixes
	Identifying Installed Products, Versions, and Fixes
	Viewing and Copying Information About Software AG Features

	Using Designer with Software AG Runtime
	Defining a Software AG Runtime Entry in the Servers View
	Adding the Software AG Runtime Environment

	Enabling Designer Console Output on Windows
	Modifying the Designer Configuration to Enable Console Output
	Adding Parameters to the Command Line to Enable Designer Console Output
	Modifying a Designer Shortcut to Enable Console Output

	Configuring SSL Connections in Designer

	Software AG Training Resources
	Software AG  Information Resources

