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About this Guide
webMethods CloudStreams provides a scalable approach for the development and
governance of integration ﬂows between "Software as a Service" (SaaS) applications and
"on-premise" applications.
CloudStreams provides predeﬁned, conﬁgurable CloudStreams Connectors that enable
you to connect to popular SaaS cloud applications. Using the CloudStreams plug-ins
and administrative options, you conﬁgure these Connectors to govern transactions,
log payloads and monitor run-time performance. You can publish and view run-time
performance metrics and events using the Software AG MashZone dashboards provided
by CloudStreams.
Additionally, you can use the CloudStreams framework to create custom connectors to
other SaaS applications.

Document Conventions
Convention

Description

Bold

Identiﬁes elements on a screen.

Narrowfont

Identiﬁes storage locations for services on webMethods
Integration Server, using the convention folder.subfolder:service .

UPPERCASE

Identiﬁes keyboard keys. Keys you must press simultaneously
are joined with a plus sign (+).

Italic

Identiﬁes variables for which you must supply values speciﬁc to
your own situation or environment. Identiﬁes new terms the ﬁrst
time they occur in the text.

Monospace
font

Identiﬁes text you must type or messages displayed by the
system.

{}

Indicates a set of choices from which you must choose one. Type
only the information inside the curly braces. Do not type the { }
symbols.

|

Separates two mutually exclusive choices in a syntax line. Type
one of these choices. Do not type the | symbol.
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Convention

Description

[]

Indicates one or more options. Type only the information inside
the square brackets. Do not type the [ ] symbols.

...

Indicates that you can type multiple options of the same type.
Type only the information. Do not type the ellipsis (...).

Documentation Installation
You can download the product documentation using the Software AG Installer. The
documentation is downloaded to a central directory named _documentation in the main
installation directory (SoftwareAG by default).

Online Information
You can ﬁnd additional information about Software AG products at the locations listed
below.
If you want to...

Go to...

Access the latest version of product
documentation.

Software AG Documentation website

Find information about product releases
and tools that you can use to resolve
problems.

Empower Product Support website

hp://
documentation.softwareag.com

hps://empower.softwareag.com

See the Knowledge Center to:
Read technical articles and papers.
Download ﬁxes and service packs (9.0
SP1 and earlier).
Learn about critical alerts.
See the Products area to:
Download products.
Download certiﬁed samples.
Get information about product
availability.
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If you want to...

Go to...

Access older versions of product
documentation.
Submit feature/enhancement requests.
Access additional articles, demos, and
tutorials.

Software AG Developer Community for
webMethods

Obtain technical information, useful
resources, and online discussion forums,
moderated by Software AG professionals,
to help you do more with Software AG
technology.

hp://
communities.softwareag.com/

Use the online discussion forums to
exchange best practices and chat with
other experts.
Expand your knowledge about product
documentation, code samples, articles,
online seminars, and tutorials.
Link to external websites that discuss
open standards and many web
technology topics.
See how other customers are streamlining
their operations with technology from
Software AG.
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About CloudStreams
webMethods CloudStreams provides a scalable approach for the development and
governance of integration ﬂows between "Software as a Service" (SaaS) applications and
"on-premise" applications.

You use CloudStreams to:
Develop services for a CloudStreams connector.
Manage the security of service requests.
Perform user-deﬁned processing instructions (optional).
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Log transactions.
Monitor run-time performance and events.
Additionally, you can use the CloudStreams framework to create custom cloud
connectors for other SaaS applications.

The Components of CloudStreams
CloudStreams consists of the following components:
The CloudStreams server, which uses the same run-time framework as the one used by
Integration Server. CloudStreams runs as a package on top of Integration Server. A
CloudStreams server hosts the following components:

Plug-ins provided by Software AG Designer, which you use as the design-time tool for
CloudStreams:
You use the Service Development plug-in to create cloud connector services,
which perform SOAP operations or access REST resources.
You use the CloudStreams Development plug-in to create virtual services,
connector virtual services, and their policies. These services send the requests
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from the on-premise application to the native service in the SaaS application, and
vice versa.
The CloudStreams Analytics dashboard, which you use to view and analyze the run-time
performance metrics and run-time events of your CloudStreams connectors, cloud
connector services and consumers.

Outbound Architecture
In the outbound run-time scenario, an on-premise application invokes a SaaS application
through CloudStreams as follows:
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Step

Description

1

The on-premise application invokes a cloud connector service that you
deﬁned to perform the desired SOAP operation (such as querying an
account) or to access the desired REST resource.
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Step

Description

2

The cloud connector service obtains a connection from the Integration
Server connection pool.

3

The cloud connector service then invokes a connector virtual service.

4

The cloud connector service sends the request to the native service in the
SaaS application.

5

The SaaS application processes the request for the native service and sends a
response to the connector virtual service.

6

The CloudStreams server collects run-time metrics and events, and
publishes them to the CloudStreams Analytics facility, which is powered
by Software AG MashZone. You can use the CloudStreams Analytics
dashboard to monitor the metrics.

7

The connector virtual service logs the request/response transaction and its
payload.

Inbound Architecture
In the inbound run-time scenario, a SaaS application invokes an on-premise application
through CloudStreams as follows:
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Step

Description

1

A SaaS application invokes a virtual service that has been deployed to
CloudStreams. The virtual service's policy performs security checks and any
other user-deﬁned processing before sending the request to the on-premise
application.

2

The virtual service invokes a service endpoint (an Integration Server ﬂow
service or a Java service) in the on-premise application.

3

The endpoint service then invokes the on-premise application service(s).
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Step

Description

4

The on-premise application processes the request against the native service
and sends a response back to the SaaS application.

5

The CloudStreams server collects run-time metrics and events, and
publishes them to the CloudStreams Analytics facility, which is powered
by Software AG MashZone. You can use the CloudStreams Analytics
dashboard to monitor the metrics.

6

The virtual service logs the request/response transaction and its payload.

The CloudStreams Connectors
CloudStreams provides pre-conﬁgured CloudStreams connectors. A CloudStreams
connector contains SaaS provider-speciﬁc information that enables you to connect to a
particular SaaS provider. You install a CloudStreams connector on Integration Server as
an Integration Server package.
Each connector contains a CloudStreams Connector Bundle, which contains all the assets
to enable the CloudStreams runtime to connect with the provider's back-end, and to
perform operations on the back-end. One of these assets is the Cloud Connector Descriptor,
which describes:
A CloudStreams metadata handler (SOAP or REST), which creates the data model
representing the connector for a particular provider.
Meta information that enables you to create the cloud connector's connections.
The connector's SOAP operations or REST resources.

Custom Cloud Connectors
You can use the CloudStreams Development plug-in to deﬁne cloud connectors for other
SaaS applications. Then, you conﬁgure a custom connector the same way you conﬁgure
a CloudStreams connector.

Configuring a CloudStreams Connector
You conﬁgure a CloudStreams connector by creating:
A cloud connection to connect to the SaaS provider.
Cloud connector services.
Virtual services.
Connector virtual services, if the default one does not suit your needs.
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Policies that provide governance capabilities for the virtual services and connector
virtual services.
These tasks are summarized below.

Cloud Connections
A CloudStreams connector uses a cloud connection to connect to a SaaS application at run
time.
Integration Server includes a connection management service that dynamically manages
connections and connection pools based on the conﬁguration seings you specify for
the connection. A connection pool is a collection of connections with the same set of
aributes. Integration Server maintains connection pools in memory. Connection pools
improve performance by enabling cloud connector services to reuse open connections
instead of opening new connections.
You create and conﬁgure connections using Integration Server Administrator. The
procedures for doing this appear in the documentation speciﬁc to your CloudStreams
connector (for example, the webMethods CloudStreams Provider for Salesforce.com
Installation and User's Guide).

Cloud Connector Services
A cloud connector service is an Integration Server service that CloudStreams uses to
integrate an "on-premise" application with a SaaS application.
The number of cloud connector services you should create depends on the following:
For a SOAP-based provider, you should create at least one cloud connector service
for each desired operation deﬁned in the provider’s WSDL. For example, for a query
operation you might create a cloud connector service to query accounts and another
to query contacts.
For a REST-based provider, you should create at least one cloud connector service
for each desired REST resource on which the connector can operate.
When you conﬁgure a cloud connector service, you specify the following information:
The cloud connection you created.
A SOAP operation or a REST resource, which is deﬁned in the cloud connector
descriptor.
A connector virtual service, which sends service requests from CloudStreams to the
SaaS provider, handles the provider's responses, and logs the request/responses
(discussed below).
The business object associated with the operation (for SOAP-based providers).
The headers to include in the service’s input pipeline.
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The input/output signature that determines how the user interacts with the service.
Optional parameters to include in the input/output signature, such as variables to be
replaced at run time with a user’s input.
At run time, the cloud connector service constructs and maps a SOAP or REST request
from the service’s input pipeline to an appropriate message builder. When the SaaS
application provider sends a response, the cloud connector service processes and maps
the response and populates the output pipeline.
You create and conﬁgure cloud connector services using the Service Development plugin provided in Software AG Designer. The procedures for doing this appear in the
documentation speciﬁc to your CloudStreams connector (for example, the webMethods
CloudStreams Provider for Salesforce.com Installation and User's Guide).

Virtual Services and Connector Virtual Services
A virtual service is a service that runs on a CloudStreams server and acts as the
consumer-facing proxy for a native service that runs in a SaaS application or in an onpremise application. Service requests go to a virtual service for processing rather than
directly to the service provider. You should create a virtual service for each SaaS service
you want to expose to consumers.
There are two types of virtual services: virtual services and connector virtual services.
In the inbound processing scenario, when a SaaS application sends a service request,
a virtual service's policy performs security checks and any other user-deﬁned
processing before sending the request to the on-premise application.
In the outbound processing scenario, when an on-premise application sends a
service request, a special kind of virtual service is used, called a connector virtual
service. A connector virtual service handles the SaaS provider's responses and logs the
requests/responses and their payloads.
CloudStreams provides a default connector virtual service for each metadata handler
(one for the SOAP handler and one for the REST handler). You cannot modify these
default services, which are located in the WmCloudStreams package. Alternatively,
you can create additional connector virtual services with custom policies.
You create both types of virtual services using the CloudStreams Development plug-in
provided in Designer, and then deploy them to a CloudStreams server.
Both types of virtual services can have user-deﬁned policies, which provide governance
capabilities for the services; policies are discussed later in this overview.

The Processing Steps of Virtual Services
When you create a virtual service, you can conﬁgure the following processing steps:
The service's "In Sequence" step, which you conﬁgure to manipulate the request
messages. This step can include the following sub-steps:
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The "Entry Step" (provided by default), which speciﬁes the protocol (HTTP
or HTTPS) of the requests that the virtual service will accept. For REST-based
virtual services, you also specify the REST resource that the service will access
and the HTTP methods (GET, POST, PUT and DELETE) that the virtual service
should be allowed to perform on the REST resource.
The "Transform" step (optional), which performs an XSLT message transformation
on the request message before the virtual service submits it to the native service.
The "Invoke IS Service" step (optional), which preprocesses the request message
before the virtual service submits it to the native service.
The "Routing Rule" step (provided by default), which speciﬁes how the virtual
service will route the requests to the native service endpoint(s). For HTTP or
HTTPS requests, you have four routing choices:
"Straight Through" routing (to route requests directly to the native service
endpoint).
"Context-Based" routing (to route speciﬁc types of messages to speciﬁc
endpoints according to context-based routing rules).
"Content-Based" routing (to route speciﬁc types of messages to speciﬁc
endpoints based on speciﬁc values that appear in the request message).
"Load Balancing" routing (to distribute requests among multiple endpoints).
The service's "Out Sequence" step, which you conﬁgure to manipulate the response
messages. This step can include the following sub-steps:
The "Transform" step (optional), which speciﬁes how the response message from
the native service provider is to be transformed before the virtual service returns
it to the consuming application.
The "Invoke IS Service" step (optional), which preprocesses the request message
before the virtual service returns it to the consuming application.
The service's "Error Sequence" step (provided by default). CloudStreams returns
a default fault response to the consuming application, which you can customize
with context variables. This fault response is used for faults returned by the native
service provider as well as faults returned by internal CloudStreams exceptions,
such as policy violation errors, connection timeouts, etc. You can choose whether
or not to send the native service provider's service fault content, or just send the
message. In addition, you can invoke IS services to pre-process or post-process the
error messages.

The Processing Steps of Connector Virtual Services
A connector virtual service can contain similar processing steps as a virtual service.
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Policies for Virtual Services and Connector Virtual Services
Policies provide run-time governance capabilities for virtual services and connector
virtual services.

Policies for Virtual Services
You should create policies that apply to one or more virtual services. A policy is a
sequence of actions that is carried out by CloudStreams when a consumer requests a
particular service through CloudStreams. A policy for a virtual service can include the
following kinds of actions:
WS-SecurityPolicy 1.2 actions:
There are two kinds of WS-SecurityPolicy 1.2 actions:
Authentication actions, to verify that the requests for virtual services contain a
speciﬁed WS-SecurityPolicy element. You can authenticate consumers by their
WSS X.509 certiﬁcates, WSS username tokens, or WSS SAML tokens.
XML security actions, to provide conﬁdentiality (through encryption) and
integrity (through signatures) for request and response messages.
Monitoring actions:
The "Monitor Service Performance" action, which monitors a user-speciﬁed set
of run-time performance conditions for a virtual service, and sends alerts to a
speciﬁed destination when these conditions are violated
The "Monitor Service Level Agreement" action, which provides the same
functionality as "Monitor Service Performance", but this action is diﬀerent
because it enables you to monitor a virtual service's run-time performance for
particular consumers. You conﬁgure this action to deﬁne a Service Level Agreement
(SLA), which is set of conditions that deﬁnes the level of performance that a
speciﬁed consumer should expect from a service.
The "Throling Traﬃc Optimization" action, which limits the number of service
invocations allowed during a speciﬁed time interval.
Additional actions:
"Identify Consumer", which you use in conjunction with an authentication
action. Alternatively, this action can be used alone to identify consumers only by
host name or IP address.
"Require HTTP Basic Authentication", which uses HTTP Basic authentication
to verify the consumer's authentication credentials contained in the request's
Authorization header against the Integration Server's user account. This action
supports WS-SecurityPolicy 1.2.
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"Authorize User", which authorizes consumers against a list of users and/or a list
of groups registered in the Integration Server. You use this action in conjunction
with an authentication action.
"Log Invocation", which logs request/response payloads.
"Validate Schema", which validates all XML request and/or response messages
against an XML schema referenced in the WSDL.

Policies for Connector Virtual Services
Each default connector virtual service has a default policy, which logs the requests/
responses and their payloads to a database. You cannot modify the default connector
virtual services or their policies. However, you can create additional connector virtual
services with custom policies.
If you create a connector virtual service with a custom policy, you can include the
actions from the "Monitoring" and "Additional" categories (except for "Validate
Schema"); the "WS-SecurityPolicy 1.2" actions are not needed. For example, you might
want to create a custom policy that monitors run-time performance, customizes how the
service invocations are logged, or optimizes server traﬃc.

The CloudStreams Analytics Dashboard
CloudStreams can publish key performance indicator (KPI) metrics and run-time events
to the CloudStreams Analytics dashboard. The dashboard enables you to view and
analyze the KPI metrics and run-time events of your CloudStreams connectors, cloud
connector services and consumers.
The dashboard is powered by a MashApp called CloudStreams Analytics, which is
powered by Software AG MashZone. CloudStreams Analytics uses data feeds from
Software AG MashZone and uses the Integration Server's JDBC connection pool to
publish this data at regular intervals.
The dashboard displays the following analytic views:
View

Filtered by...

Cloud Connector Performance Summary
(performance and availability)

N/A; shows all
connectors.

Cloud Connector API Usage (total requests and data
volume)

Provider and time
period.

Cloud Connector Performance (performance trends)

Provider and time
period.
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View

Filtered by...

Cloud Connector Error (error trends by provider and
consumer)

Provider and time
period.

Cloud Connector Service Level Agreement (SLA)
violations and alerts, shown by consumer and
provider.

Provider and time
period.

Service (performance)

Provider, connector and
time period.

Transaction (event results of request transactions)

Provider, connector,
service,event type and
time period.

The types of run-time events that can be published are as follows:
Event Type

Description

Lifecycle

A Lifecyle event occurs each time the Integration Server is
started/shutdown/restarted or the WmCloudStreams package
is unloaded/reloaded in a running Integration Server.

Transaction

A Transaction event occurs each time a cloud connector
service is invoked (successfully or unsuccessfully).

Error

An Error event occurs each time an invocation of a cloud
connector service or an inbound virtual service results in an
error.

Policy Violation

A Policy Violation event occurs each time an invocation of a
cloud connector service violates a policy that was set for its
associated virtual service.

Monitoring

CloudStreams publishes key performance indicator (KPI)
metrics, such as the average response time, fault count and
availability of all connectors and connector services.

Getting Started with CloudStreams
The high-level steps for conﬁguring a cloud connector are as follows:
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Step
1. Using the Software AG Installer, install:
CloudStreams Server.
A CloudStreams Provider (such as the
Salesforce.com Provider).
Software AG MashZone, which is required
for using CloudStreams Analytics.

For procedures, see...
The document Installing
webMethods and Intelligent
Business Operations Products.
The documentation speciﬁc to
your CloudStreams provider
(for example, webMethods
CloudStreams Provider for
Salesforce.com Installation and
User's Guide).

2. Create a cloud connection and conﬁgure the
session management parameters, using the
Integration Server Administrator.

The documentation speciﬁc to
your CloudStreams provider

3. Create a cloud connector service for each
desired operation deﬁned in the cloud
provider's WSDL, or for each desired REST
resource, using the Software AG Designer's
Service Development plug-in.

The documentation speciﬁc to
your CloudStreams provider

4. Set the CloudStreams conﬁguration
options to specify things such as the keystore,
truststore and ports to use, the database to
use for publishing performance metrics and
events, the consumer applications that can
access CloudStreams, and more.

"CloudStreams Conﬁguration
Options" on page 29

5. Deﬁne a CloudStreamsserver target, which
speciﬁes an instance of a CloudStreams server
to which you will deploy your virtual services
and any optional custom connector virtual
services. You do this using Software AG
Designer. You can deﬁne one or more server
targets.

"Virtual Services" on page
55

6. Create a CloudStreams Governance project
in which you will create the virtual services,
connector virtual services, and their policies.
You create projects in your local ﬁle system,
using Designer's CloudStreams Development
plug-in. You can create one or more projects.

"Virtual Services" on page
55
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Step

For procedures, see...

7. In the CloudStreams Governance project,
create virtual services and connector virtual
services. You do this using Designer's
CloudStreams Development plug-in. You will:

"Virtual Services" on page
55

Create virtual services to handle the inbound
requests.
Optionally override the default connector
virtual services with custom ones to handle
outbound requests. CloudStreams provides
a default connector virtual service for
each metadata handler (which you cannot
modify), but you can create additional
connector virtual services with custom
policies, if desired.
8. In the CloudStreams Governance project,
create policies for the virtual services, using
Designer's CloudStreams Development plugin.

"Policies" on page 165

For the virtual services, you create policies
that include WS-SecurityPolicy actions (and
other actions) provided by CloudStreams.
For the connector virtual services,
CloudStreams provides a default policy that
logs all outbound transactions. You cannot
modify these policies, but you can create
additional connector virtual services with
custom policies that include the monitoring,
logging, and schema validation actions.
9. Deploy the virtual services and any custom
connector virtual services to a package in a
CloudStreams server target.

"Deploying Virtual Services
and Connector Virtual Services"
on page 197

10. Conﬁgure CloudStreams Analytics to
monitor performance metrics and run-time
events.

"CloudStreams Analytics" on
page 205

Note: If you want to create a custom cloud connector, see "Creating Custom Cloud
Connectors" on page 229.

Administering webMethods CloudStreams Version 9.6

28

M

Odd Header

2

CloudStreams Configuration Options

■ Overview .......................................................................................................................................

30

■ The Administration Options ..........................................................................................................

30

■ The Providers Options .................................................................................................................

47

■ The Streaming Options ................................................................................................................

48

Administering webMethods CloudStreams Version 9.6

29

M

Even Header

Overview
Set the CloudStreams conﬁguration options to specify things such as the keystore,
truststore and ports to use, the database to use for publishing run-time metrics and
events, the consumer applications that are allowed to access CloudStreams, and more.

The Administration Options
In Integration Server Administrator, you can set the following options under Solutions >
CloudStreams > Administration:
"Seing the General Options" on page 30.
"Seing the E-mail Options for Logging Payloads and Sending Performance
Monitoring Alerts" on page 33.
"Seing the Database Options for Publishing Performance Metrics and Events" on
page 35.
"The Virtual Services Option" on page 38.
"Seing the STS Options" on page 38.
"Seing the Service Fault Conﬁguration Options" on page 41.
"Seing the Consumers Options" on page 43.
"Seing the OAuth Tokens Options" on page 45.

Setting the General Options
Use these options to manage the inbound service requests sent by consumers to
CloudStreams. To manage the outboundrequests that CloudStreams sends to the
cloud provider, set the options for your cloud connections in your webMethods
CloudStreams cloud connector. For details, see the section Creating Cloud Connections in
the documentation for your webMethods CloudStreams cloud connector.
To set the CloudStreams > Administration > General options

1. In Integration Server Administrator, select Solutions > CloudStreams > Administration >
General.

2. Click Edit, complete the following fields and click Save.
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Option

Description

Target Name

The CloudStreams target name. This name is included
in the events that are sent to the database for metrics
reporting purposes.

Load Balancer URL
(HTTP)

The primary HTTP load balancer URL and port number to
use.
For the URL, you can specify either the IP address or
host name of the load balancer with the port number, as
follows:
hp://IP-address :portnumber
or
hp://hostname :portnumber
If speciﬁed, all virtual services hosted in CloudStreams will
use this value.

Load Balancer URL
(HTTPS)

The primary HTTPS load balancer URL and port number
to use.
For the URL, you can specify either the IP address or
host name of the load balancer with the port number, as
follows:
hps://IP-address :portnumber
or
hps://hostname :portnumber
If speciﬁed, all virtual services hosted in CloudStreams
(and exposed on HTTPS) will use this value.

IS Keystore Name

The Integration Server keystore that CloudStreams
should use. This ﬁeld lists all available Integration Server
keystores. If there are no conﬁgured Integration Server
keystores, the list will be empty. To conﬁgure Integration
Server keystores, see the section Securing Communications
with the Server in the document webMethods Integration
Server Administrator’s Guide.

Alias (signing)

The signing alias. This alias is the value that is used to sign
the outgoing response from CloudStreams to the original
consumer. It is auto-populated based on the keystore
selected from the IS Keystore Name above. This ﬁeld will list
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Option

Description
all the aliases available in the chosen keystore. If there are
no conﬁgured keystores, this ﬁeld will be empty.

IS Truststore Name

Specify the same truststore that is speciﬁed in Integration
Server (as described in the section Securing Communications
with the Server in the document webMethods Integration
Server Administrator’s Guide).
This truststore will be used in the following cases:
If you select the Secure Connection option for a
CloudStreams server as described in "Deﬁning and
Managing a CloudStreams Server Target" on page 59.
The truststore you specify in the IS Truststore Name ﬁeld
must contain the required SSL certiﬁcates.
This truststore is also used by the CloudStreams SMTP
e-mail server if you select the TLS Enabled option while
"Seing the E-mail Options for Logging Payloads and
Sending Performance Monitoring Alerts" on page 33.
The truststore you specify in the IS Truststore Name ﬁeld
must include a certiﬁcate in the e-mail server's certiﬁcate
chain or the certiﬁcate authority of the e-mail server.
This truststore is also used when making a connection to
a third-party OAuth 2.0-based service provider to refresh
the access token (as described in "Seing the OAuth
Tokens Options" on page 45).

HTTP Ports
Configuration

Select one or more HTTP ports on which CloudStreams
and the deployed virtual services will be available.
CloudStreams is always available on the primary HTTP
port. The primary HTTP port is the port speciﬁed on the
Integration Server's Security > Ports page. You can specify
additional HTTP and HTTPS ports here. To conﬁgure ports
for Integration Server, see webMethods Integration Server
Administrator’s Guide.
Important: If you specify multiple ports, the port that is
reported in the WSDL is the non-primary port with the lowest
number. There is only one port reported in the WSDL
retrieved through CloudStreams, but all the speciﬁed ports
are usable.
If you are using a webMethods Enterprise Gateway (EG)
Registration port to process requests from external clients,
the EG port will be displayed with the EG hostname preﬁxed
to the port, in order to distinguish it from the local internal
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Option

Description
server ports. The Enterprise Gateway Registration port must
be speciﬁed for CloudStreams.

HTTPS Ports
Configuration

Select one or more HTTPS ports on which CloudStreams
and the deployed virtual services will be available.

Connection Factory
Wire Logging

This option captures additional debug messages that
show the request's HTTP content that is sent over the
wire to the native provider. The messages also show the
response content that was received. This can be useful
when debugging connector service invocations, but there
are two implications you should be aware of:
The server.log will grow quickly as it captures this
verbose content, and performance will be severely
impacted. Use this option sparingly.
Since all "cleartext" HTTP content is captured (even the
content sent over SSL), be careful to avoid security issues.
In addition to all request and response message content,
the transport headers are also included, including
Authorization headers.
If you disable and then re-enable the Connection Factory
Wire Loggingoption, in certain cases it may be necessary
to disable and then re-enable any existing managed
connection pools. To do this, in the Integration Server
Administrator go to Solutions > CloudStreams > Providers,
click your cloud provider's name, click the connector
name, and click the Enabled column to disable/re-enable the
connection pool.

Setting the E-mail Options for Logging Payloads and Sending
Performance Monitoring Alerts
If you use the following policy actions to send e-mail messages, you must specify the
SMTP mail server to be used by CloudStreams:
A "Log Invocation" action that you conﬁgure to send request/response payloads as email aachments.
A Monitoring action that you conﬁgure to send monitoring alerts as e-mail messages
("Monitor Service Performance", "Monitor Service Level Agreement" or "Throling
Traﬃc Optimization").
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To set the CloudStreams > Administration > Email options

1. In Integration Server Administrator, select Solutions > CloudStreams > Administration > Email.
2. Click Edit, complete the following fields and click Save.
Option

Description

SMTP Host
Name/IP
Address

The address of the SMTP server to be used by CloudStreams
for sending e-mail alerts.

Port

The port on which the SMTP server is listening.

User

The user name of the e-mail account used to log into your
SMTP server.

Password

The password of the e-mail account used to log into your
SMTP server.

From

The e-mail address that will appear in the From ﬁeld of the
event e-mail.
If this ﬁeld is left blank, CloudStreams generates a default email address composed of the conﬁgured target name and
hostname of the Integration Server, as follows:
Target-Name@hostname

TLS Enabled

Whether to use transport-layer security (TLS). Requirements:
A keystore and a truststore must be conﬁgured in Integration
Server (see the section Securing Communications with the Server
in the document webMethods Integration Server Administrator’s
Guide).
An Integration Server keystore and truststore must be
speciﬁed in the IS Keystore Name and IS Truststore Name ﬁelds
in CloudStreams > Administration > General (see "Seing the
General Options" on page 30). The truststore speciﬁed
in IS Truststore Name must include a certiﬁcate in the e-mail
server's certiﬁcate chain or the certiﬁcate authority of the email server.

Test Recipient

To test your connection, enter in this ﬁeld an e-mail address
of the person who should receive the test e-mail, and click
Test. If the test is successful, CloudStreams sends an e-mail
to the address and displays a success message. Otherwise,
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Option

Description
CloudStreams displays an error message; reconﬁgure your email seings and try again.

Setting the Database Options for Publishing Performance Metrics
and Events
CloudStreams can publish data about key performance indicator (KPI) metrics and runtime events to the CloudStreams Analytics dashboard.
CloudStreams uses the Integration Server's JDBC connection pool to publish this data.
The JDBC connection pool is speciﬁed in Integration Server Administrator's Settings
> JDBC Pools page. You must deﬁne this connection pool for use by CloudStreams as
described below.
To set the CloudStreams > Administration > Database options

1. In Integration Server Administrator, select Solutions > CloudStreams > Administration >
Database.

2. Click Edit, complete the following fields on the Database Conﬁguration page, and click
Save.

Option

Description

Connection
Pool Alias

The Integration Server connection pool alias that is deﬁned in
the Integration Server Administrator's Settings > JDBC Pools
page, as described in "Creating a JDBC Connection Pool for
CloudStreams" on page 212.
If the Integration Server connection pool alias is not yet
deﬁned, click the link to deﬁne it.

Database
Publishing

Click Enable to enable the database speciﬁed in the Connection
Pool Alias to receive data.

Publish
Performance
Metrics

Select this option to enable CloudStreams to publish key
performance indicator (KPI) metrics to the database. For
more information, see "The Key Performance Indicator (KPI)
Metrics" on page 207.

Publish Interval
(minutes)

The interval at which CloudStreams should publish
performance metrics to the database. Default: 60 minutes. For
more information, see "The Intervals for Metric Publishing" on
page 36, below.
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Option

Description

Publish Events
(Error, Lifecycle,
Policy Violation)

Select the types of events to publish to the database:
Error: An Error event occurs each time an invocation of a
cloud connector service or an inbound virtual service results
in an error.
Lifecycle: A Lifecycle event occurs each time the
Integration Server is started/shutdown/restarted or the
WmCloudStreams package is unloaded/reloaded in a
running Integration Server.
Policy Violation: A Policy Violation event occurs each time an
invocation of a cloud connector service violates a policy that
was set for its associated virtual service.

The Intervals for Metric Publishing
CloudStreams tracks performance metrics by intervals. The interval is a period of
time you set in CloudStreams, during which metrics are collected for reporting to
CloudStreams.
There are two cases in which you specify an interval when measuring performance:
When you publish performance indicator (KPI) metrics and events to the
CloudStreams Analytics dashboard. In this case, you set the interval in Integration
Server Administrator, in Solutions > CloudStreams > Administration > Database.
When monitoring a virtual service's run-time performance with the actions "Monitor
Service Performance", "Monitor Service Level Agreement", or "Throling Traﬃc
Optimization". In this case, you set an interval in the action's "interval" parameter.
The rules of intervals are the same in both cases.
CloudStreams only tracks metrics for the current interval. At the end of the interval,
CloudStreams aggregates the metrics and reports them to CloudStreams. CloudStreams
resets its counters immediately for the next interval, even if the last interval's data has
not yet been reported to the database (so there is no gap between intervals when metrics
are not accumulated). CloudStreams does not calculate and aggregate metrics across
intervals. If CloudStreams is shut down or the service is undeployed before the current
interval expires, the performance data is discarded.
Examples of interval metric publishing
For example, suppose that the tracking interval is 10 minutes. One of the key
performance indicator (KPI) metrics is "Availability", which reports the amount of
time that a service was available during the current interval, shown as a percentage.
The green boxes in the illustration below indicate successful requests and the red ones
indicate unsuccessful requests.
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A request is considered unsuccessful when a network fault occurs or when the native
service is unavailable due to the following errors:
ConnectException
MalformedURLException
NoRouteToHostException
ProtocolException
SocketTimeoutException
UnknownHostException
UnknownServiceException
Web Service not available
The service cannot be found
In the case of a normal application-level SOAP fault, CloudStreams considers the request
to be successful. In the illustration below, in Interval 1 (0 - 10 minutes) a request failed
at the 4 minute mark, followed by a successful request at the 5 minute mark. Therefore,
CloudStreams considers the interval between 4 and 5 minutes to be service downtime
(even though this may not be accurate). So in this case, for Interval 1 the availability
is 9/10 (90%). In the case of Interval 2, only one request was sent, and it failed at the 1
minute mark. Therefore, CloudStreams considers the time between 1 minute to the end
of the interval as service downtime. So the time between the start of Interval 2 (the 10
minute mark) to the failed request is service uptime (1 minute); the availability is 1/10
(10%) for Interval 2. At the end of the interval, CloudStreams resets the KPI metrics.
The "Availability" status of a service is transferred to the beginning of the next interval.
When CloudStreams starts up, it is assumed that the services are available. If a service
is unavailable at the end of interval 1, and no activity occurs for several intervals, the
service's availability is 0 during the intervals when no activity occurred.
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The Virtual Services Option
This option displays a list of:
The default connector virtual services (WmCloudStreams.SoapVS and
WmCloudStreams.RestVS) as well as any other user-deﬁned connector virtual services
in the WmCloudStreams package.
All virtual services deﬁned in the WmCloudStreams package that are currently
deployed to a CloudStreams server target.
To view the list, select Solutions > CloudStreams > Administration > Virtual Services in
Integration Server Administrator.

Setting the STS Options
CloudStreams can act as a Security Token Service (STS) client. The following illustration
shows what happens at run time.
CloudStreams as an STS Client

Step

Description

1

The user's client sends a SOAP request with SAML authentication
information to CloudStreams. Integration Server authenticates the
incoming request.

2

CloudStreams sends a WS-Trust RST to the STS to request a SAML v2
token.
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Step

Description
CloudStreams sends the <OnBehalfOf> element that contains the
authenticated user name to the STS.

3

The SAML Issuer sends the SAML v1/v2 assertion to CloudStreams.

4

CloudStreams forwards the SOAP request (along with the SAML
assertion) to the native service.
CloudStreams also uses the IS keystore and signing alias you speciﬁed to
sign the SAML token and the request body before sending the request to
the native service.
Also, if you have conﬁgured the predeﬁned Java service
pub.cloudstreams.security.ws.AddSamlSenderVouchesTokento add a timestamp in
the outbound request, CloudStreams will sign the timestamp as well.

5

The native service sends a SOAP response to CloudStreams.

6

CloudStreams sends the response to the user's client.

Use the following procedure to enable CloudStreams to act as a Security Token Service
(STS) client.
To set the CloudStreams > Administration > STS options

1. In Integration Server Administrator, select Solutions > CloudStreams > Administration > STS.
2. You can use Integration Server’s default STS, DefaultSTS. To view its default parameters,
click its name.

3. Alternatively, you can to use a third-party STS that has been defined in the Integration
Server (as described in the Web Services Developer’s Guide, in the section Securing Web
Services Using Policies Based on WS-SecurityPolicy). To use a third-party STS, click
Add new STS configuration and complete the Add STS Configuration page as follows.

Option

Description

Name

A unique name for the STS being conﬁgured. If this
value is changed after creating an STS, the previous
STS conﬁguration will be deleted and replaced with
the new one.

Endpoint

The STS endpoint to which the WS-Trust request
will be sent by CloudStreams to obtain the SAML
token.
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Option

Description

Token Type

The type of token that CloudStreams should
request from the STS. Value can be SAML_11 or
SAML_20.
Note: Currently the default Integration Server STS
only supports issuing SAML 2.0 Sender-vouches
tokens.

WS-Trust Version

The version of WS-Trust that CloudStreams should
use to send the RST to the SAML Issuer. Value can
be VERSION_05_02 or VERSION_05_12.

Time-To-Live (TTL)

Indicates the time-to-live value in seconds that will
be speciﬁed in the RST. If not speciﬁed, the default
is 300 seconds (5 minutes).

Keystore

Select a keystore that has been conﬁgured in
Integration Server. To conﬁgure a keystore
in Integration Server, see the section Securing
Communications with the Server in the document
webMethods Integration Server Administrator’s Guide.

Sign Request?/Signing Alias

Select Sign Request? if the STS requires a signed
request, and specify the signing alias in the Signing
Alias ﬁeld.

Encrypt Request?/
Encryption Alias

Select Encrypt Request? if the STS requires an
encrypted request, and specify the encryption alias
in the Encryption Alias ﬁeld.

HTTP Basic Authorization
Username/Password

If the STS requires authentication, enter the HTTP
Basic Authentication username and password.

WS-Security Username
Token/Username, Password,
and Password Type

The WS-Security username token to send to the
STS. Also specify the username's password and
password type (None, Text or Digest).

4. If you selected Integration Server’s default STS (DefaultSTS), edit the default STS's
configuration file to specify the keystore and alias so that the STS can sign the SAML
assertion that it is issuing.
The conﬁguration ﬁle is:
IntegrationServer_directory \instances\instance_name \conﬁg\security\saml
\esb_sts.xml
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The contents of the ﬁle are shown below. Use the comments as a guide to conﬁgure
this ﬁle for your system.
<?xml version="1.0" encoding="UTF-8"?>
<!-- This configuration file is used to configure the IntegrationServer token
issuer that generates the SAML Sender Vouches token for CloudStreams outbound
requests -->
<IDataXMLCoder version="1.0">
<record javaclass="com.wm.data.ISMemDataImpl">
<!-- IssuerName - will be used as the IssuerName for each SAML token issued by
this Service; the default value is ESB_STS -->
<value name="IssuerName">ESB_STS</value>
<!-- IssuerKeystoreAlias - specify an Integration Server Keystore Alias that
contains the private keys that can be used to sign the generated SAML
Assertion -->
<value name="IssuerKeystoreAlias">STS</value>
<!-- IssuerKeyAlias - the name of the key alias within the
IssuerKeystoreAlias that points to the private key files -->
<value name="IssuerKeyAlias">sts</value>
<!-- TimeToLiveSeconds - how long in seconds the generated token should be
valid? the default is 300 seconds (i.e. 5 minutes) from the time of token
creation -->
<number name="TimeToLiveSeconds" type="java.lang.Integer">300</number>
</record>
</IDataXMLCoder>

5. Configure the desired virtual services so they can use the STS. To
do this, write an IS service that includes the predefined Java service
pub.cloudstreams.security.ws.AddSamlSenderVouchesTokenand invoke this IS service in the "In
Sequence" step of the virtual service. This service must reference an STS that is identified
in CloudStreams. For details about the AddSamlSenderVouchesTokenservice, see "Using the
Security API in IS Services" on page 89.

Setting the Service Fault Configuration Options
Note: The service fault conﬁguration options are intended only for virtual services, and
not for Connector Virtual Services. For information about error handling for Connector
Virtual Services, see "The Error Sequence Step (Connector Virtual Service, SOAP)" on
page 124 or "The Error Sequence Step (Connector Virtual Service, REST)" on page
158.
You can use these options to conﬁgure global error responses for all virtual services.
Alternatively, you can conﬁgure error responses for virtual services individually, in the
services' "Error Sequence" step, as described in "The Error Sequence Step (Connector
Virtual Service, SOAP)" on page 124 or "The Error Sequence Step (Connector Virtual
Service, REST)" on page 158.
The precedence of the error messaging instructions is as follows:
If you create an "Error Sequence" step for a virtual service, the error messaging step
takes precedence over any seings on the Service Fault Conﬁguration page.
If you do not create an "Error Sequence" step for a virtual service, the seings on the
Service Fault Conﬁguration page take precedence.
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To set the CloudStreams > Administration > Service Fault Configuration options

1. In Integration Server Administrator, select Solutions > CloudStreams > Administration >
Service Fault Configuration.

2. Click Edit, complete the following fields and click Save.
Option

Description

Default
Fault
Response

When you select this option, CloudStreams returns the following
fault response to the consuming application:
CloudStreams encountered an error:$ERROR_MESSAGE while
executing operation:$OPERATION service:$SERVICE at time:
$TIME on date:$DATE. The client ip was:$CLIENT_IP.
The current user:$USER. The consumer application:
$CONSUMER_APPLICATION".

This fault response is returned in both of the following cases:
When a fault is returned by the native service provider.
In this case, the $ERROR_MESSAGE variable in the fault response
will contain the message produced by the provider's exception
that caused the error. This is equivalent to the getMessage call
on the Java Exception. This maps to the faultString element for
SOAP 1.1 or the Reason element for SOAP 1.2 catch. For REST
service calls, the message is returned inside an </Exception>
tag. CloudStreams discards the native service provider's fault
and does not return this content to the web service caller since
it could be considered a security issue, especially if the native
provider is returning a stack trace with its response.
When a fault is returned by internal CloudStreams exceptions
(policy violation errors, cloud connection errors and cloud
connector service errors).
In this case, the $ERROR_MESSAGE variable will contain the error
message generated by CloudStreams.
The default fault response contains predeﬁned fault handler
variables ($ERROR_MESSAGE, $OPERATION, etc.), which are described
in "The Fault Handler Variables" on page 87.
You can customize the default fault response using the following
substitution variables, where CloudStreams replaces the variable
reference with the real content at run time:
The predeﬁned context variables listed in "The Predeﬁned
Context Variables" on page 100.
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Option

Description
Custom context variables that you declare using the
CloudStreams API (see "The API for Context Variables" on page
104).
Note: If you want to reference a custom context variable that you
have already deﬁned in a context-based routing rule (as opposed
to one you have declared using CloudStreams API for context
variables), then you must add the preﬁx $mx to the variable name
in order to reference the variable. For example, if you deﬁned the
variable TAXID, you would reference it as $mx:TAXID.

Send Native
Provider
Fault

When you select this option, CloudStreams sends the native
service provider's fault content, if available. CloudStreams
will send whatever content it received from the native service
provider.
If you select this option, the Default Fault Response is ignored when
a fault is returned by the native service provider. (Faults returned
by internal CloudStreams exceptions will still be handled by the
Default Fault Response option.)

Note: Unlike with SOAP speciﬁcations, there is no agreed upon format to suggest an
error condition for REST services (that is, there is no element nested in a </soap:Fault>
element nested in a </soap:Body>). CloudStreams assumes that REST services will
follow HTTP conventions and return responses with return codes in the 200-299 range
when service calls are successful. This is the only way CloudStreams can determine that
a native provider's response should be interpreted as a failure.

Setting the Consumers Options
Use this option to deﬁne the consumer applications that should be allowed to access
CloudStreams.
On this page, specify the precise values for the consumer identiﬁer(s) that you speciﬁed
for the Identify Consumer action in the policies of your virtual services.
To set the CloudStreams > Administration > Consumers options

1. In Integration Server Administrator, select Solutions > CloudStreams > Administration >
Consumers.

2. Click Add New Consumer, complete the following fields and click Save.
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Option

Description

Name

Assign a name for the consumer application.

Description

Enter a description for the consumer application.

IP Addresses

Use this ﬁeld when the Identify Consumer action is conﬁgured
to identify consumer applications by IP address. Enter one
or more IP addresses (or ranges of addresses) to identify
consumers. IPv4 and IPv6 addresses are supported.
If entering an IPv4 address, enter a 4-byte IP address. Note
that:
To specify an individual IP address, type the address in the
From ﬁeld. The Identify Consumer action will identify only
those requests that originate from the speciﬁed IP address.
To specify a range of IP addresses, type the lowest IP
address in the From ﬁeld and the highest IP address in the
To ﬁeld. For example, the values 192.168.0.0 and 192.168.0.10
indicate that requests originating from any IP address
that lies between the speciﬁed range will be identiﬁed by
CloudStreams.
If entering an IPv6 address, use the 128-bit IPv6 format. For
example: 1234:5678:9ABC:DEF0:1234:5678:9ABC:DEF0.
To specify additional IP addresses, use the plus buon to add
more rows.

Identification
Token

Use this ﬁeld when the Identify Consumer action is conﬁgured
to identify consumer applications by an identiﬁcation token.
Specify one or more of the following tokens. To specify
additional tokens, use the plus buon to add more rows.
Host Name: To identify consumers based on a speciﬁed host
name, type the host name (for example, pcmachine.ab.com)
in the Name ﬁeld. CloudStreams will identify only those
requests that originate from the speciﬁed host name.
HTTP Authorization Token : To authorize consumers based on
the user name transmied in an HTTP authorization user
token, type the user name (for example, testuser123) in
the Name ﬁeld. The application asset will identify only the
requests that contain the speciﬁed user name encoded and
passed in the HTTP user token in the HTTP Authorization
header. Authentication is handled by LDAP or another
external authentication mechanism.
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Option

Description
WS-Security Authentication Token: To authenticate consumers
based on the user name transmied in the SOAP or
XML message header (HTTP body), type the user name
(for example, userwss) in the Name ﬁeld. CloudStreams
will identify only the requests that contain the speciﬁed
user name passed in the SOAP or XML message header.
Authentication is handled by LDAP or another external
authentication mechanism.
A custom identification token (XPath): To identify consumers
based on the result of applying an XPath expression on
the SOAP or XML message or request, enter the XPath
expression in the Name ﬁeld. For example, typing //*[localname()='Envelope']/*[local-name()='Body']/*[localname()='echoInt']/*[local-name()='echoIntInput=']
[.='2']in the Name ﬁeld will identify the requests that

contain the XPath and the consumers.

User ID: For connector virtual services only. Identiﬁes
consumers based on a list of users who are registered in the
Integration Server on which CloudStreams is running.
X.509 Certificate

Use this ﬁeld when the Identify Consumer action is conﬁgured
to identify consumer applications by an X.509 v3 consumer
certiﬁcate. Specify the path of a certiﬁcate ﬁle on the server.

Setting the OAuth Tokens Options
If you will be seing the Authentication Type ﬁeld to OAuth on the Streaming Providers
page (as described in "Seing the Streaming Providers Options" on page 48), you
need to set the options here, on the OAuth Access Tokens page.
If OAuth will be used as an authentication mechanism, you must create an alias
containing connection details. For example, when a Streaming Provider is created that
will use OAuth, the provider details include an OAuth alias. When OAuth is chosen on
the Streaming Providers page, an alias must be selected from a drop-down list of OAuth
Token aliases that are currently deﬁned. At run time, the OAuth alias is used to lookup
parameters, such as Access Token, that are used to establish the connection with the
provider.
OAuth is a scheme to limit the need for user credentials when operating on behalf of a
resource owner. Instead of using the owner's credentials at run time, an Access Token is
used. Prior to run time, the owner and user engage in a "dance" with a Resource Server
and an Authorization Server to obtain an Access Token that will grant the user limited
access to resources controlled by the owner. The precise steps in the dance vary with
OAuth version, provider (Salesforce versus Twier) and OAuth grant scheme ("two-
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legged dance" versus "three-legged dance"). Given this variation and the complexity
of this process, CloudStreams assumes that the proper OAuth ﬁelds are obtained, and
stores the tokens and other properties for use at run time.
Some of the information that is stored is considered to be sensitive and is stored
securely, just as a password would be.
Currently, two OAuth versions are supported, v1.0a and v2.0. The parameters that are
stored with an alias are diﬀerent in the two versions, though there is also signiﬁcant
overlap.
To set the CloudStreams > Administration > OAuth Tokens options

1. In Integration Server Administrator, select Solutions > CloudStreams > Administration >
OAuth Tokens.

2. Click Add New Token, complete the following fields and click Save.
Option

Description

Name

A unique string to identify a collection of alias token
parameters.

Provider

Identiﬁes the OAuth provider (such as Salesforce or Twier).

OAuth Version

Select the OAuth version, v1.0a or v2.0.

OAuth Version

Issued by the provider when the consumer/client is created. In
OAuth 2.0, this is referred to as "Client ID".

Consumer ID

Issued by the provider when the consumer/client is created. In
OAuth 2.0, this is referred to as "Client Secret".

Consumer
Secret

The token used for authentication, instead of other credentials.
This token is issued by the Authorization Server. The process
for obtaining a token varies with version, vendor and OAuth
grant type.
For OAuth 2.0, CloudStreams will use the keystore and
truststore speciﬁed in the CloudStreams > Administration > General
tab when making a connection to the third-party OAuth 2.0based service provider to refresh the access token. The refresh
URL is almost always SSL-based, so the truststore speciﬁed in
CloudStreams will be used during the SSL handshake to verify
the provider certiﬁcate. If the provider requires two-way SSL
authentication, then the keystore speciﬁed in CloudStreams
will be used to provide the client certiﬁcates. For details about
the keystore and truststore speciﬁed in CloudStreams, see
"Seing the General Options" on page 30.
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Option

Description
If a truststore is not speciﬁed in the CloudStreams >
Administration > General tab, CloudStreams will use the default
truststore for the jvm (cacerts). This might be a problem if you
have deﬁned the default truststore to only contain speciﬁc
certiﬁcates, because if that alias is deﬁned, the well-known
certiﬁcates will not be included when deﬁning the trust. In this
case, make certain the truststore alias keystore includes the
certs necessary to trust the URLs deﬁned in this ﬁeld too.

Access Token

Issued with the v1.0a access token only.

Refresh Access
Token

OAuth 2.0 access tokens typically have a very short lifetime.
When an access token expires, the OAuth proﬁle does not
automatically refresh the expired access token. Select this
option if you want an expired access token to be refreshed
automatically. If you select this option, you must also specify
Refresh Token and Refresh URL.
The access token is refreshed whenever the session expires.
Session expiration is handled according to the seing of the
Session Management property in your connection. Note that if
Session Management is set to "none", then you must manually
modify the access token in the OAuth alias. (The Refresh Access
Token option will not be applicable in this case.)

Refresh Token

Issued with the OAuth v2.0 access token only. Available only if
Refresh Access Token is selected.
Refreshes an expired access token, thus extending the lifetime
between access token grants.

Refresh URL

Available only if Refresh Access Token is selected.
The URL used to refresh an access token; will vary with
provider.

Instance URL

A Salesforce-speciﬁc ﬁeld to identify the run-time host.

The Providers Options
Use these options to:
Enable/disable/delete/conﬁgure CloudStreams cloud connectors.
Create/enable/disable/delete/view/copy managed cloud connections.
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For details, see the documentation speciﬁc to your webMethods CloudStreams cloud
connector (for example, webMethods CloudStreams Provider for Salesforce.com Installation
and User's Guide).

The Streaming Options
In Integration Server Administrator, you can set the following options under Solutions >
CloudStreams > Streaming:
"Seing the Streaming Providers Options" on page 48
"Seing the Streaming Subscribers Options" on page 50

Setting the Streaming Providers Options
To set the CloudStreams > Streaming > Providers options

1. In Integration Server Administrator, select Solutions > CloudStreams > Streaming > Providers.
2. Click Add New Provider, complete the following fields and click Save.
Option

Description

Provider Name

Specify a unique name for this streaming service provider.
This is a required ﬁeld and is used by the Subscriber
conﬁguration to refer to it.

Client Type

The type of client that will be used by CloudStreams to
provide the streaming functionality. There are two types of
clients:
Comet: This is a client implementation that uses the Bayeux
HTTP protocol (using the CometD library) to communicate
with the streaming service. This client should be used if the
streaming provider explicitly indicates that they support
the Bayeux protocol for their streaming functionality. For
example, Salesforce uses this mechanism for their streaming
functionality and hence Salesforce integrations must use this
client type.
HTTP: An HTTP client type is used for HTTP-based streaming
service providers that use a long-lived HTTP connection
to send data periodically to the client connected to them.
For example, Twier uses this mechanism to send updates
made to their streaming API endpoints (Public, User and Site
streams).
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Option

Description

API Version

Optional. The version of the streaming API supported by the
provider service.

Streaming API
Endpoint

Points to the endpoint of the streaming provider. For example,
when conﬁguring a Salesforce streaming endpoint, you must
specify the URL that corresponds to the streaming API, such
as:
hps://na9-api.salesforce.com/cometd/25.0
Do not specify the actual subscription channel/topic name here
as part of the URL because that is subscriber conﬁgurationspeciﬁc.

Notify Meta
Channel Events

Optional. Indicates whether any meta-channel (connect,
disconnect, handshake, etc.) events must be notiﬁed to the
subscriber. If you choose this option, then the events are
delivered to the destination conﬁgured in the subscriber (see
"Seing the Streaming Subscribers Options" on page 50).

Enable Debug

Optional. Indicates whether any connection-related debugging
messages must be logged to the server log.

Connection
Timeout (ms)

Specify the streaming connection timeout value, in
milliseconds. If unspeciﬁed, this value defaults to a system
default (30 seconds).

Read Timeout
(ms)

Specify the read timeout value after a connection has been
established with the provider. This indicates the maximum
time before which a data packet must be read from the
endpoint before a timeout occurs.

Truststore Alias

Specify the IS truststore alias to use if the endpoint is SSLbased and the provider certiﬁcate must be validated as part of
the SSL handshake. By default, if no alias is conﬁgured, then
all server certiﬁcates are trusted during SSL handshake. The
alias must be conﬁgured in Integration Server Administrator.
To conﬁgure Integration Server truststores, see the section
Securing Communications with the Server in the document
webMethods Integration Server Administrator’s Guide.

Keystore Alias

Specify the IS keystore alias to use if the endpoint is SSL-based
and the CloudStreams certiﬁcate must be provided to the
server endpoint as part of the SSL handshake. By default, if no
alias is conﬁgured, then no client certiﬁcate is sent during SSL

Administering webMethods CloudStreams Version 9.6

49

M

Even Header

Option

Description
handshake. The alias must be conﬁgured in Integration Server
Administrator. To conﬁgure Integration Server keystores,
see the section Securing Communications with the Server in the
document webMethods Integration Server Administrator’s Guide.

Validate
Certificate

If set to true, the client will validate the provider's certiﬁcate
for the SSL handshake. Default: False.

Authentication
Type

Speciﬁes the authentication information that must be sent
to the streaming provider when a subscription to a topic
or channel is deﬁned. Choose one of the following ways to
provide the authentication information:
Basic: Basic refers to HTTP Basic Authentication. This option
can be used if the provider requires or supports HTTP Basic
authentication using a username and password.
OAuth 1.0 and OAuth 2.0: Select an OAuth alias that was
deﬁned on the OAuth Access Tokens page (see "Seing
the OAuth Tokens Options" on page 45). At run time,
CloudStreams will use the OAuth conﬁguration information
to retrieve the access token to be sent to the provider in the
HTTP request.
ESB Callback: This option can be used when the above two
means of authentication are not suﬃcient. For example,
if the provider does not support Basic authentication
or OAuth tokens, but instead requires another form of
authentication information as part of the Authorization
header, then you can provide another form of authentication
in a user-deﬁned ESB service. Specify the service name in
this ﬁeld in the following form: folder1.folder2:serviceName .
The only requirement for this ESB service is that it should
specify the value for the Authorization header in the
authorization.header pipeline variable. CloudStreams will
use the value present in this pipeline variable to send it
as part of the Authorization header value. You should not
include the header name (Authorization) in the value set in
this variable.

Setting the Streaming Subscribers Options
CloudStreams supports the following kinds of streaming client implementations:
Client implementations based on the Comet library, which works with streaming
services using the Bayeux protocol (for example, Salesforce).
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An HTTP client type, which is used for HTTP-based streaming service providers that
use a long-lived HTTP connection to send data periodically to the client connected
to them. For example, Twier uses this mechanism to send updates made to their
streaming API endpoints (Public, User and Site streams).
To set the CloudStreams > Streaming > Subscribers options

1. In Integration Server Administrator, select Solutions > CloudStreams > Streaming >
Subscribers.

2. Click Add New Subscriber, complete the following fields and click Save.
Option

Description

Enable
Subscriber

Enables or disables the subscriber conﬁguration. If the
subscriber conﬁguration is disabled, then no streaming
notiﬁcations will be received by CloudStreams until it is
enabled again.

Subscriber
Name

A name that uniquely identiﬁes a subscriber.

Provider

One of the streaming providers previously conﬁgured in
"Seing the Streaming Providers Options" on page 48.
The provider names are listed in a drop-down ﬁeld, and each
subscriber must choose the provider conﬁguration to use in
order for the streaming subscription to work.

Channel
Endpoint

The topic/channel name or the endpoint address for the
subscription request, depending on the streaming provider's
client type, as follows:
If the streaming provider's client type is Comet, specify
the topic or channel name for the subscription request.
This is usually of the form /channel_name . For example, for
Salesforce it can something like /topic/InvoiceUpdate. You
must not specify the complete subscription endpoint address
(of the form hp://server:port /...), because that information is
part of the provider conﬁguration information. The channel
endpoint must refer to the actual channel name only. This
endpoint will be appended to the provider endpoint before
the actual streaming connection is made to the provider.
If the streaming provider's client type is HTTP, specify the
endpoint address without the actual stream/channel name
included. For example, Twier's Public Stream address is:
hps://stream.twier.com/1.1/channelEndpoint
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Option

Description

Content Type

The HTTP Content-Type header value. Not required if the
Streaming Providers Client Type ﬁeld is set to Comet.

HTTP Method

The HTTP method to use for the streaming request made to
the service provider. Not required if the Streaming Providers
Client Type ﬁeld is set to Comet.

Request Body

The optional request entity or message contents to send to
the service endpoint. This is only applicable for the POST,
PUT, OPTIONS and PATCH HTTP methods; the other HTTP
methods do not require a message body. Not required if the
Streaming Providers Client Type ﬁeld is set to Comet.

HTTP Headers

Additional HTTP headers (name-value pairs) to be sent to
the service endpoint (optional). Not required if the Streaming
Providers Client Type ﬁeld is set to Comet.

Destination
Type

The type of destination to which the streaming subscription
response will be delivered when a notiﬁcation is received from
the provider:
ESB Service: An IS service that will be invoked when a
streaming notiﬁcation is received. The service name must
be of the fully qualiﬁed form folder1.folder2:serviceName .
For more information, see "Creating an ESB Service as a
Streaming Subscriber Destination" on page 52.
Journal Log: The IS journal log to which the streaming
subscription response contents will be logged when a
notiﬁcation is received from the provider.

Creating an ESB Service as a Streaming Subscriber Destination
When you select the ESB Service option for the Destination Type ﬁeld for a streaming
subscriber, you specify an IS service that will be invoked when a streaming notiﬁcation
is received. Following is guidance on how to write such an IS service.
ESB Services for the Client Type of Comet
The response is present under an IData variable in the pipeline, with a key whose
value is the same as the name of the subscriber. For example, if the subscriber is named
MySalesforceTopic, then there will be a key in the pipeline with the same name.
The IData structure is:
[subscriber_name]
message
channel.name (if present)
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channel.endpoint
data.json
comet.msg

This IData variable contains the actual subscription response contents within the message
pipeline variable, which contains the following pipeline variables:
channel.name:

arrived.

The name of the channel over which the subscription response

channel.endpoint:

The endpoint value of the channel.

data.json:

The streaming response contents in JSON format (note that this is only
applicable if the provider client type is Comet).
comet.msg:

The actual CometD message instance value. The type of the value is:
org.cometd.bayeux.Message.
ESB Services for the Client Type of HTTP
The response is present under an IData variable in the pipeline, with a key whose
value is the same as the name of the subscriber. For example, if the subscriber is named
MyTwitter, then there will be a key in the pipeline with the same name.
The IData structure is:
[subscriber_name]
message
response.data
channel.endpoint

This IData variable contains the actual subscription response contents within the message
pipeline variable, which contains the following pipeline variables:
response.data:

A String value representing the HTTP response contents.

channel.endpoint:

The value corresponds to the subscriber destination from which
the response was received.
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Overview
Following is a summary of the four high-level steps for creating virtual services:
1. "Deﬁne a CloudStreams Server Target" on page 56.
2. "Create a CloudStreams Governance Project" on page 56.
3. "Create the Virtual Services" on page 56.
4. "Create Policies for the Virtual Services" on page 58.

Define a CloudStreams Server Target
A CloudStreamsserver target speciﬁes a CloudStreams server to which you will deploy
virtual services and connector virtual services. You deﬁne CloudStreams server targets
using Software AG Designer. You can create one or more server targets.

Create a CloudStreams Governance Project
You need to create a CloudStreams Governance project in which you will create the
virtual services and their policies, plus any custom connector virtual services and
their policies. You create projects in your local ﬁle system, using the CloudStreams
Development plug-in provided by Designer. You can create one or more projects.

Create the Virtual Services
A virtual service runs on a CloudStreams server and acts as the consumer-facing proxy
for a native service that runs in a SaaS application or in an on-premise application.
Service requests sent from a service consumer go to a virtual service hosted on the
CloudStreams server for processing rather than directly to the service provider. You
should create a virtual service for each SaaS service you want to expose to consumers.
There are two types of virtual services: virtual services and connector virtual services.
In the inbound processing scenario, when a SaaS application sends a service request,
a virtual service performs security checks and other user-deﬁned processing before
sending the request to the on-premise application.
In the outbound processing scenario, when an on-premise application sends a
service request, a special kind of virtual service is used, called a connector virtual
service. A connector virtual service handles the SaaS provider's responses and logs the
request/responses and their payloads.
CloudStreams provides a default connector virtual service for each metadata handler
(one for the SOAP handler and one for the REST handler). You cannot modify these
default services, which are located in the WmCloudStreams package. Alternatively,
you can create additional connector virtual services with custom policies.
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You create both types of virtual services using the CloudStreams Development plug-in
provided in Designer, and then you deploy them to a CloudStreams server.
Both types of virtual services can have policies, which provide governance capabilities for
the services; policies are discussed later in this overview.

The Processing Steps of a Virtual Service
When you create a virtual service, you can conﬁgure the following processing steps for
the service:
The "In Sequence" step, which you conﬁgure to manipulate the request messages.
This step can include the following sub-steps:
The "Entry Step" (required), which speciﬁes the protocol (HTTP or HTTPS) of the
requests that the virtual service will accept, and for REST services it also speciﬁes
the HTTP methods that the virtual service should be allowed to perform on a
REST resource.
The "Transform" step (optional), which performs an XSLT message transformation
on the request message before the virtual service submits it to the native service.
The "Invoke IS Service" step (optional), which pre-processes the request message
before the virtual service submits it to the native service.
The "Routing Rule" step (required), which speciﬁes how the virtual service will
route the requests to the native service endpoint. There are four ways to route
HTTP or HTTPS requests:
"Straight Through" routing (to route requests directly to the native service
endpoint).
"Context-Based" routing (to route speciﬁc types of messages to speciﬁc
endpoints according to context-based routing rules).
"Content-Based" routing (to route speciﬁc types of messages to speciﬁc
endpoints based on speciﬁc values that appear in the request message).
"Load Balancing" routing (to distribute requests among multiple endpoints).
The service's "Out Sequence" step (optional), which you conﬁgure to manipulate the
response messages. This step can include the following sub-steps:
The "Transform" step (optional), which speciﬁes how the response message from
the native service provider is to be transformed before the virtual service returns
it to the consuming application.
The "Invoke IS Service" step step (optional), which pre-processes the request
message before the virtual service returns it to the consuming application.
The service's "Error Sequence" step (required). CloudStreams returns a default fault
response to the consuming application, which you can customize with context
variables. This fault response is used for faults returned by the native service
provider as well as faults returned by internal CloudStreams exceptions (policy
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violation errors, cloud connection errors and cloud connector service errors). In
addition, you can:
Choose whether or not to send the native service provider's service fault content,
or just send the response message.
Invoke IS services to pre-process or post-process the error messages.

The Processing Steps of a Connector Virtual Service
A connector virtual service can contain similar processing steps as a virtual service.

Create Policies for the Virtual Services
You should create policies that apply to one or more virtual services. A policy is a
sequence of actions that is carried out by CloudStreams when a consumer requests a
particular service through CloudStreams. You create policies using the same editor you
use to create virtual services.
A policy for a virtual service can include the following kinds of actions:
WS-SecurityPolicy 1.2 actions, which include authentication actions and XML security
actions for the inbound requests.
Monitoring actions, to monitor run-time performance conditions for virtual services,
and to optimize server traﬃc (and to send alerts when the conditions are violated).
Additional actions, to identify/authenticate consumers, to validate request/response
messages against an XML schema, and to log request/response payloads.
For complete details, see the chapter "Policies" on page 165.

Policies for Connector Virtual Services
Each default connector virtual service has a default policy, which logs all request/
response payloads to a database. You cannot modify the default connector virtual
service or its policy. Alternatively, you can create additional connector virtual services
with custom policies.
If you create a connector virtual service with a custom policy, you can only include the
actions in the "Monitoring" or "Additional" action categories; you cannot include the
"WS-SecurityPolicy 1.2" actions (except the "Require SSL" action). For example, you
might want to create a custom policy that monitors run-time performance, customizes
how the service invocations are logged, validates response messages against an XML
schema, or optimizes server traﬃc.
The procedures to perform the above tasks (except for creating policies) appear below, in
the following sections:
"Deﬁning and Managing a CloudStreams Server Target" on page 59.
"Creating a CloudStreams Governance Project" on page 60.
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"Creating a New Virtual Service (SOAP)" on page 62.
"Creating a New Connector Virtual Service (SOAP)" on page 117.
"Creating a New Virtual Service (REST)" on page 125.
"Creating a New Connector Virtual Service (REST)" on page 151.

Defining and Managing a CloudStreams Server Target
A CloudStreams server target speciﬁes a CloudStreams server to which you will deploy
virtual services and connector virtual services. You deﬁne CloudStreams server targets
using Software AG Designer. You can create one or more server targets.
To define and manage a server target

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. Select Window > Preferences > Software AG > CloudStreams Servers from the menu.
3. In the CloudStreams Servers window, click Add.
4. Complete the fields in the Add CloudStreams Server dialog box as follows and click OK.
Option

Description

Name

A name for the new target. Target names can contain
alphanumeric characters and underscores (_) and hyphens (-).

Host

The server's host name (for example, localhost).

User

Optional. The Integration Server user who is permied to
deploy assets to this target. By default, only a member of
the Integration Server's Administrator group is permied to
deploy assets to this target.

Port

The server's port number.

Password

Optional. The password of the Integration Server user who
is permied to deploy assets to this target. By default, the
password of this user is manage.

Secure
Connection

Indicates whether to open an HTTP session or an HTTPS
session on the selected server.
If you want to open an HTTPS session on the selected server
using the Secure Socket Layer (SSL), select this option.
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Option

Description
Note: If you select this option, it is critical that you also
specify the IS Truststore Name option for CloudStreams
(in Integration Server Administrator, go to Solutions >
CloudStreams > Administration > General). For details, see
"Seing the General Options" on page 30.
If you want to open an HTTP session on the selected server,
clear this check box.

5. In the CloudStreams Servers window, test the server connection by clicking the name of

the server in the list and clicking the Test button. If the connection is not active and valid,
activate the deployment endpoint and modify the user credentials as required.

6. To edit any parameter, click the Edit button, type your changes and click OK.
7. To delete the server from the list, click the Remove button.
8. To export target instances from the CloudStreams to an archive file on the file system, click
the Export button.

9. To import target instances from the archive file into the same CloudStreams or to another
instance of the server, click the Import button.

Creating a CloudStreams Governance Project
You need to create a CloudStreams Governance project in which you will create your
virtual services, connector virtual services, and their policies. You create projects in your
local ﬁle system, using the CloudStreams Development plug-in provided by Designer.
You can create one or more projects. Each project will contain the folders in which you
will create virtual services, connector virtual services, and their policies.
Note: Instead of creating a new CloudStreams Governance project, you can import
an existing one. To do this, from the Software AG Designer menu click File > Import >
Software AG > CloudStreams Governance Project and complete the dialog box that appears.
To create a CloudStreams Governance project

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

The CloudStreams Governance view on the left side of the page lists all existing
CloudStreams Governance projects.

2. Right-click an existing CloudStreams Governance project and click New > CloudStreams

Governance Project (or click File > New > CloudStreams Governance Project from the menu.
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3. In the New CloudStreams Governance Project wizard, complete the following fields and click
Finish.

Option

Description

Name

A project name that is a valid resource name on your
operating system. The name must not be null, cannot be an
empty string, and the following invalid OS resource characters
are not allowed:
\\

Use Default
Location

(double backward slashes)

/

(forward slash)

:

(colon)

*

(asterisk)

?

(question mark)

"

(double quote)

<

(Less Than symbol)

>

(Greater Than symbol)

|

(vertical bar)

This option is selected by default. The default location is the
Workspace root.
For example, if you are using C:\Workspaces
\My_Workspace.. the default location would be C:
\Workspaces\runtime-Eclipse Application, which is the
Workspace root.
If you want to specify a diﬀerent location, clear the Use Default
Location check box, click Browse and select a location.

Description

Optional. A description of the project.

The new project is added to any existing projects in the CloudStreams Governance
view, and it includes the default folders Virtual Services, Connector Virtual Services and
Policies. You can create virtual services, connector virtual services and policies as
described in the following sections.

4. To delete a project:
a. Undeploy all services in the project by right-clicking the project name and clicking
Undeploy.
b. Right-click the project name and click Delete.
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5. To export a project, right-click the project name and click Export and complete the dialog box
that appears.

Creating a New Virtual Service (SOAP)
To create a new virtual service (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, right-click the CloudStreams Governance project and
click New > Virtual Service (or expand the project, right-click the Virtual Services folder and
click New Virtual Service).

3. In the New Virtual Service wizard, complete the following fields and click Finish.
Option

Description

CloudStreams
Governance
Project

Click Browse and select a CloudStreams Governance project in
which to create the virtual service.

Name

Assign a name for the service. Unlike native services,
the names of virtual services cannot contain spaces or
special characters except _ (underscore) and - (hyphen).
Consequently, if you adopt a convention that involves using
the name of the service as part of the virtual service name,
then the names of the services themselves must not contain
characters that are invalid in virtual service names.
Note: If you want to change the service name after it has been
created, right-click the service name in the Virtual Services folder
and select Rename.

Version

(Read-only ﬁeld.) Currently not supported.

Type

Select SOAP.

WSDL

The WSDL that the virtual service uses. Select either File (and
click Browse to select a WSDL) or select URL (and enter the
URL of the WSDL).
Note: If you need to add a WSDL to the service later, use the
Attach WSDL option (see "Managing a Virtual Service (SOAP)" on
page 65.
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Option

Description

Description

Optional. A description for the virtual service. This description
appears when a user displays a list of virtual services in the
user interface.

The new virtual service is added to the CloudStreams Governance project, in the
Virtual Services folder.

The Properties of a Virtual Service (SOAP)
To view and modify the properties of a virtual service (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development. .

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name. (If the Properties view is not already open, click Window >
Show View > Other > General > Properties.)

3. The General page in the Properties view displays the following properties:
Option

Description

Name

(Read-only ﬁeld.) The service name. You can change the name
of an undeployed service by right-clicking the name in the
Virtual Services folder and clicking Rename.

Service Type

(Read-only ﬁeld.) SOAP.

Created/Last
Modified

(Read-only ﬁeld.) The service's creation/modiﬁcation
timestamps.

Target
Namespace

(Read-only ﬁeld.) This value is derived from the
targetNamespace aributes of the WSDL's deﬁnition element.

Namespaces

Click the buon next to this ﬁeld to view the virtual service's
available namespaces (such as wsdl, xsd, soap, etc.).

Version

(Read-only ﬁeld.) Currently not supported.

WSDL URL

Click this URL to display the contents of the service's abstract
WSDL. You can override the WSDL by aaching a new one;
see "Managing a Virtual Service (SOAP)" on page 65.
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Option

Description

Description

You can change the service description.

4. View additional properties in the Advanced page.
Option

Description

Name

(Read-only ﬁeld.) The service name. You can change the name
of an undeployed service by right-clicking the name in the
Virtual Services folder and clicking Rename.

Type

(Read-only ﬁeld.) SOAP.

Target
Namespace

(Read-only ﬁeld.) The value derived from the targetNamespace
aributes of the WSDL's deﬁnition element.

WSDL URL

Click this URL to display the contents of the service's abstract
WSDL. You can override the WSDL by aaching a new one;
see "Managing a Virtual Service (SOAP)" on page 65.

Namespaces

Click the buon next to this ﬁeld to view the virtual service's
available namespaces (such as wsdl, tns, xsd, soap, etc.).

Version

(Read-only ﬁeld.) Currently not supported.

Description

(Read-only ﬁeld.) The service description.

VSD

Click the buon next to this ﬁeld to view the service's "virtual
service deﬁnition" (VSD). This buon is disabled until you
deploy the virtual service to a CloudStreams server.
When you deploy the virtual service to a CloudStreams server,
CloudStreams generates an XML document called a virtual
service deﬁnition (VSD). The VSD deﬁnes the virtual service
for CloudStreams, and contains all the resources required to
deploy the virtual service to a CloudStreams server, including
the policy that applies to the service. You cannot edit the VSD.
Note: If multiple policies apply to the service, CloudStreams
combines all those policies into a single policy known as the
eﬀective policy. The eﬀective policy is a simple UNION of the
run-time actions speciﬁed in all policies that apply to a service.
To create the eﬀective policy, CloudStreams evaluates the
combined list of actions from all policies, using a set of internal
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Option

Description
rules known as Policy Conﬂict Resolution rules. For details, see
"Policy Conﬂict Resolution Rules" on page 201.

Applicable
Policies

Click the buon next to this ﬁeld to view a list of the active
policy or policies that apply to this service. Any inactive policy
that applies to the service is not listed. To change the list of
applicable policies, see "Modifying Policies" on page 170.

Endpoint

Click the buon next to this ﬁeld to view the endpoint to
which the virtual service is deployed, if applicable.

Deployed Status

(Read-only ﬁeld.) Indicates whether the service is Deployed,
Undeployed or Not Deployed (which is the initial status before
you deploy the service). To deploy or undeploy a service, see
"Deploying Virtual Services and Connector Virtual Services"
on page 197.

Resource

Not applicable to SOAP services.

Managing a Virtual Service (SOAP)
You can rename, delete, deploy or undeploy a virtual service, aach a WSDL to it, and
change the list of policies that apply to the virtual service.
To manage a SOAP virtual service

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development. .

2. In the CloudStreams Governance view, expand your CloudStreams Governance project.
3. Right-click the virtual service name and choose one of the following tasks from the context
menu:
Option

Description

Rename

Use this option to assign a new name to the service. The
service must be undeployed before you can rename it
(check the Deployed Status ﬁeld in the Advanced pageUse
of the service's Properties view).
Unlike native services, the names of virtual services cannot
contain spaces or special characters except _ (underscore)
and - (hyphen). Consequently, if you adopt a convention
that involves using the name of the service as part of
the virtual service name, then the names of the services

Administering webMethods CloudStreams Version 9.6

65

M

Even Header

Option

Description
themselves must not contain characters that are invalid in
virtual service names.

Delete

Deletes the virtual service from CloudStreams.

Attach WSDL

Use this option to aach a WSDL to an existing virtual
service. The new aached WSDL will override the old
WSDL. In the dialog box that appears, choose one of the
following options and click OK:
URL: Specify the URL of the WSDL to aach.
File: Click Browse to select a WSDL in your local ﬁle
system.
Note: If the new WSDL contains referenced XSDs or WSDL,
they will be copied if they are resolved by CloudStreams. But
if the referenced XSDs or WSDL cannot be resolved, a dialog
box will prompt you whether to import the unresolved XSDs
or WSDL.

Deploy

Deploys the virtual service to a CloudStreams server
target. For more information, see "Deploying Virtual
Services and Connector Virtual Services" on page 197.

Undeploy

Undeploys the virtual service from a CloudStreams server
target.

4. To change the list of policies that apply to the virtual service, see "Modifying Policies" on
page 170.

The "In Sequence" Step (SOAP)
You conﬁgure the service's "In Sequence" step to manipulate the request messages. This
step can include the following sub-steps:
The "Entry Step" (required), which speciﬁes the protocol (HTTP or HTTPS) and
SOAP format (1.1 or 1.2) of the requests that the virtual service will accept.
The "Transform" step (optional), which performs an XSLT message transformation
on the request message before it is submied to the native service.
The "Invoke IS Service" step (optional), which pre-processes the request message
before it is submied to the native service.

Administering webMethods CloudStreams Version 9.6

66

M

Odd Header

The "Routing Rule" step (required), which speciﬁes how the virtual service will route
the service requests to the native service endpoint. There are four ways to route
HTTP or HTTPS requests:
"Straight Through" routing (to route requests directly to the native service
endpoint).
"Context-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
according to context-based routing rules).
"Content-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
based on speciﬁc values that appear in the request message).
"Load Balancing" routing (to distribute requests among multiple endpoints).

The "Entry Step" (SOAP)
The Entry Step (required) speciﬁes the protocol (HTTP or HTTPS) and SOAP format (1.1
or 1.2) of the requests that the virtual service will accept. This step is required.
This step allows you to bridge protocols between the consuming application and the
native service. For example, suppose you have a native service that is exposed over
HTTPS and a consuming application that submits SOAP requests over HTTP. In this
situation, you can conﬁgure the virtual service's Entry Step to accept HTTP requests and
conﬁgure its Routing Rule step to route the request to the Web service using HTTPS.
To configure the "Entry Step" (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development. .

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.
The virtual service editor displays the three main processing steps: In Sequence, Out
Sequence and Error Sequence.

3. In the virtual service editor, expand In Sequence.
By default, the In Sequence step contains the sub-steps Entry Step and Routing Rule.
(You can add the optional Transform and Invoke IS Service steps, as described later.)

4. Click Entry Step and complete the following fields in the General page in the Properties view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read only.) Entry Step.
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Option

Description

Protocol

The protocol (HTTP or HTTPS) over which the virtual service
will accept requests. To specify HTTPS, select both HTTP and
SSL.

Format

The SOAP format (SOAP 1.1 or SOAP 1.2) of the requests that
the virtual service will accept.

The "Transform" Step (Inbound, SOAP)
The optional "Transform" step speciﬁes how the SOAP request message is to be
transformed before it is submied to the native service.
No message transformation is required as long as the request message structure matches
the request message structure that is required by the operation associated with the
soapAction. However, in some cases a virtual service might need to transform SOAP
messages.
For example, you might need to accommodate diﬀerences between the message content
that a consuming application is capable of submiing and the message content that
a native service expects. For example, if the consuming application submits an order
record using a slightly diﬀerent structure than the structure expected by the native
service, you can use the Transform step to transform the record submied by the
consuming application to the structure required by the Web service.
In this case, you would need to create two Transform steps:
One in the "In Sequence" step, to transform the request messages into the format
required by the native service, before CloudStreams sends the requests to the
native services. To do this, you pass the message to an XSLT transformation ﬁle.
(Additionally in this case, the transformation is required if the virtual service has a
schema validation policy that validates the requests.)
One in the "Out Sequence" step, to transform the native service's response messages
into the format required by the consumer applications, before CloudStreams returns
the responses to the consumer applications.
To add the "Transform" step (inbound, SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Right-click In Sequence and select Transform.
The Transform step is added under the Entry Step. You cannot change the order of
the steps.

4. Click Transform and complete the following fields in the General page in the Properties view.
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Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only.) Transform.

XSLT File

The XSLT ﬁle to transform the request message before it is
submied to the native service. Click Browse to select a ﬁle
from your ﬁle system and click Save.
The XSL ﬁle uploaded by the user should not contain the
XML declaration in it (xml version="1.0" encoding="UTF-8").
This is because when the virtual service is deployed to
CloudStreams, CloudStreams embeds the XSL ﬁle in the
virtual service deﬁnition (VSD), and since the VSD itself is in
XML format, there cannot be an XML declaration line in the
middle of it. This can lead to unexpected deployment issues
which can be avoided by making sure the XSL ﬁle does not
contain the declaration line.
Note: If you make changes to the XSLT ﬁle in the future, you
must re-deploy the virtual service.

5. To create an additional Transform step, right-click In Sequence and select Transform again.
6. To delete a Transform step, right-click Transform and click Delete Step.

The "Invoke IS Service" Step (Inbound, SOAP)
This optional step invokes a user-deﬁned Integration Server ﬂow service. You can
invoke an IS service in:
The "In Sequence" step, to pre-process the request message before it is submied to
the native service.
The "Out Sequence" step, to pre-process the response message from the native
service before it is returned to the consuming application.
The IS service you invoke must be running on the same Integration Server as
CloudStreams. It can call out a C++ or Java or .NET function. It can also call other IS
services to manipulate the SOAP message.
You can use the following constructs in an IS service:
Predeﬁned or custom context variables. For more information, see "Using Context
Variables in IS Services" on page 99.
The Security API provided by CloudStreams (for SOAP-based services only). For
more information, see "Using the Security API in IS Services" on page 89.
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You can create multiple "Invoke IS Service" steps.
To add the "Invoke IS Service" step (inbound, SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Right-click In Sequence and click Invoke IS Service.
The "Invoke IS Service" step is added under the Entry Step (and under a Transform
step, if one exists).

4. Click Invoke IS Service and complete the following fields in the General page in the
Properties view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only.) Invoke IS Service.

Service

The IS service to pre-process the request message before it is
submied to the native service.

5. When you define the IS service, the Pipeline In section of the flow should have the following
input variables:
proxy.name:

This is the name of the virtual service.

SOAPEnvelope:

This is of the Java type org.apache.axiom.soap.SOAPEnvelope.

MessageContext:

CloudStreams will automatically place a MessageContext
variable into the pipeline before executing the IS service call. MessageContext is of
the Java type org.apache.axis2.context.MessageContext.
Integration Server users can use the Axis2 MessageContext object to manipulate
the incoming SOAP request. The Integration Server provides built-in services
(the pub.soap.* services) to work with the MessageContext object to get/set/modify
the SOAP body, header, properties, etc. Integration Server users should use
these services to extract the information they need from the MessageContext to
build the necessary business logic. Users do not need to understand Axis2 or
Axiom (the XML object model based on StAX) to work with the SOAP request,
because if they are familiar with the Integration Server pub.soap.* services, they
can accomplish most of the tasks. For more information about these related
Integration Server services, see the webMethods Integration Server Built-In Services
Reference.
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6. To create an additional "Invoke IS Service" step, right-click In Sequence and select IS Service
from the context menu.

7. To delete an "Invoke IS Service" step, right-click Invoke IS Service and click Delete.

The "Routing Rule" Step for HTTP or HTTPS (SOAP)
The Routing Rule step is required. You can choose one of the following protocols in your
Routing Rule step for routing the requests:
"Straight Through" routing (to route requests directly to the native service endpoint).
"Context-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
according to context-based routing rules).
"Content-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
based on speciﬁc values that appear in the request message).
"Load Balancing" routing (to distribute requests among multiple endpoints).
The "Straight Through" Routing Rule Step (SOAP)
When you select the "Straight Through" routing protocol, the virtual service will route
the requests directly to the native service endpoint you specify. You may specify how to
authenticate requests (as with all routing protocols).
To configure the "Routing Rule" step for "Straight Through" routing (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Expand In Sequence.
4. Click Routing Rule and complete the following fields in the General page in the Properties
view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Straight Through.

Default To

Specify the URL of the service to which to route the request.

Administering webMethods CloudStreams Version 9.6

71

M

Even Header

Option

Description
Then, click the icon next to this ﬁeld and complete the
Conﬁgure Endpoint Properties dialog box as follows:
SOAP Optimization Method: Select one of the following options:
None: The default.
MTOM: Indicates that CloudStreams expects to receive
a request with a Message Transmission Optimization
Mechanism (MTOM) aachment, and will forward the
aachment to the native service.
SwA: Indicates that CloudStreams expects to receive a
"SOAP with Aachment" (SwA) request, and will forward
the aachment to the native service.
Note: Bridging between SwA and MTOM is not
supported. If a consumer sends an SwA request,
CloudStreams can only forward SwA to the native
provider. The same is true for MTOM, and applies to
responses received from the native provider. That is, an
SwA or MTOM response received by CloudStreams from
a native provider will be forwarded to the caller using
the same format it received.
Note: When sending SOAP requests that do not contain
a MTOM or SWA aachment to a virtual service for
a native provider endpoint that returns an MTOM or
SWA response, the request Accept header must be set
to 'multipart/related' (or the virtual service's Request
Processing Step should include an IS service callout that
sets the BUILDER_TYPE context variable to 'multipart/
related'). This is necessary so CloudStreams knows how
to parse the response properly.
Connection Timeout: The time interval (in seconds) after which
a connection aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), CloudStreams will use the
default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which a
socket read aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), the default is 30 seconds.
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
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Option

Description
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

Use credentials
from incoming
request

Default. Authenticates requests based on the credentials
speciﬁed in the HTTP header. CloudStreams passes the
Authorization header present in the original client request to
the native service.

Use specific
credentials

Authenticates requests according to the values you specify in
the User and Password ﬁelds, and optionally the Domain ﬁeld.

Invoke service
anonymously

Does not authenticate requests.

Use existing
HTTP Headers

Use the HTTP headers that are contained in the requests.

Customize
HTTP Headers

Use the HTTP headers that you specify in the Name and Value
columns on this page. If you need to specify multiple headers,
use the plus buon to add rows.

The "Context-Based" Routing Rule Step (SOAP)
If you have a native service that is hosted at two or more endpoints, you can use the
Context-Based routing protocol to route speciﬁc types of messages to speciﬁc endpoints
according to the context-based routing rules you create.
A routing rule speciﬁes where the requests should be routed, and the criteria by which
they should be routed there. For example, requests can be routed according to certain
consumers, certain dates/times, or according to requests that exceed/fall below a
speciﬁed metric (Total Count, Success Count, Fault Count, etc.). You can create one or
more rules. For example, you might use this capability to route requests from certain
high-priority consumers to endpoints on a fast machine.
To configure the "Routing Rule" step for "Context-Based" routing (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.
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2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.

3. Expand In Sequence.
4. Click Routing Rule and complete the following fields in the General page in the Properties
view.
Option

Description

Name

You can optionally change the step name. There are no naming
convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Context-Based.

Rule Name

Assign a name to the rule.
Then, click the icon next to this ﬁeld and choose one of the
following variables in the Conﬁgure Routing Rule dialog
box that appears: Time, IP Address (IPv4 or IPv6 format), Date,
Consumer, Predefined Context Variable or Custom Context Variable
(see "Using Context Variables in IS Services" on page 99).
Then specify a value and operator appropriate for your chosen
variable. If you need to specify multiple variables, use the plus
buon at the end of the row to add rows.
Note: If you select the value Custom Context Variable, you must
write an IS service to get/set the custom context variable,
and then invoke that service in an Invoke IS Service step.
CloudStreams provides an API to get/set custom context
variables. For more information, see "The API for Context
Variables" on page 104. CloudStreams automatically declares
any custom context variables you have speciﬁed; there is no
need for you to declare them.

Route To

Specify the URL of the native service to route the request to, if
the rule criteria are met.
Click the icon next to this ﬁeld and complete the Conﬁgure
Endpoint Properties dialog box as follows:
Optimization Method: Select one of the following options:
None: The default.
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Option

Description
MTOM: Indicates that CloudStreams expects to receive
a request with a Message Transmission Optimization
Mechanism (MTOM) aachment, and will forward the
aachment to the native service.
SwA: Indicates that CloudStreams expects to receive a
"SOAP with Aachment" (SwA) request, and will forward
the aachment to the native service.
Note: Bridging between SwA and MTOM is not
supported. If a consumer sends an SwA request,
CloudStreams can only forward SwA to the native
provider. The same is true for MTOM, and applies to
responses received from the native provider. That is, an
SwA or MTOM response received by CloudStreams from
a native provider will be forwarded to the caller using
the same format it received.
Note: When sending SOAP requests that do not contain
a MTOM or SWA aachment to a virtual service for
a native provider endpoint that returns an MTOM or
SWA response, the request Accept header must be set to
multipart/related (or the virtual service's "In Sequence"
step should include an IS service callout that sets the
BUILDER_TYPE context variable to multipart/related).
This is necessary so CloudStreams knows how to parse
the response properly.
Connection Timeout: The time interval (in seconds) after which
a connection aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), CloudStreams will use the
default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which a
socket read aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), the default is 30 seconds.
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
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Option

Description
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

Default To

Enter a native service endpoint to route the request to in case
all routing rules evaluate to False. Then, click the icon next
to this ﬁeld and complete the Conﬁgure Endpoint Properties
dialog box, as described for the Route To ﬁeld above.

Use credentials
from incoming
request

Default. Authenticates requests based on the credentials
speciﬁed in the HTTP header. CloudStreams passes the
Authorization header present in the original client request to
the native service.

Use specific
credentials

Authenticates requests according to the values you specify in
the User, Password and Domain ﬁelds.

Invoke service
anonymously

Does not authenticate requests.

Use existing
HTTP Headers

Use the HTTP headers that are contained in the requests.

Customize
HTTP Headers

Use the HTTP headers that you specify in the Name and Value
columns on this page. If you need to specify multiple headers,
use the plus buon to add rows.

The "Content-Based" Routing Rule Step (SOAP)
If you have a native service that is hosted at two or more endpoints, you can use the
Content-Based routing protocol to route speciﬁc types of messages to speciﬁc endpoints
based on speciﬁc values that appear in the request message.
You might use this capability, for example, to determine which operation the consuming
application has requested, and route requests for complex operations to an endpoint on
a fast machine.
The requests are routed according to the content-based routing rules you create. That
is, they are routed based on the successful evaluation of one or more XPath expressions
that are constructed utilizing the content of the request payload. For example, a routing
rule might allow requests for half of the methods of a particular service to be routed to
Service A, and the remaining methods to be routed to Service B.

Administering webMethods CloudStreams Version 9.6

76

M

Odd Header

To configure the "Routing Rule" step for "Content-Based" routing (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.

3. Expand In Sequence.
4. Click Routing Rule and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name. There are no naming
convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Content-Based.

Rule Name

Assign a name to the rule.

XPath

Create an XPath expression as follows:
a. Click the icon next to this ﬁeld to display the XPath Editor.
b. In the XPath Editor that appears, the Namespace tab displays
all predeﬁned namespaces in the WSDL. If you want to
add custom namespaces, click Add Custom Namespace/prefix,
specify a name and value for the namespace, and click OK.
To add additional rows, use the plus buon at the end of the
row to add them.
c. In the XPath Editor's Nodes tab, expand the namespace's
node, choose the method you want for the XPath expression,
and click OK.
d. In the XPath Editor's Evaluator tab, evaluate the XPath
expression by specifying an argument in the XPath Expression
ﬁeld, and clicking Evaluate.
The true/false result of the evaluation is displayed in the
Result ﬁeld.
To specify additional XPath expressions, use the plus buon at
the end of the row to add them.
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Option

Description

Route To

Specify where to route the request if the rule criteria are met.
Specify either the URL of a native service or a connection pool
name.
Click the icon next to this ﬁeld and complete the Conﬁgure
Endpoint Properties dialog box as follows:
Optimization Method: Select one of the following options:
None: The default.
MTOM: Indicates that CloudStreams expects to receive
a request with a Message Transmission Optimization
Mechanism (MTOM) aachment, and will forward the
aachment to the native service.
SwA: Indicates that CloudStreams expects to receive a
"SOAP with Aachment" (SwA) request, and will forward
the aachment to the native service.
Note: Bridging between SwA and MTOM is not
supported. If a consumer sends an SwA request,
CloudStreams can only forward SwA to the native
provider. The same is true for MTOM, and applies to
responses received from the native provider. That is, an
SwA or MTOM response received by CloudStreams from
a native provider will be forwarded to the caller using
the same format it received.
Note: When sending SOAP requests that do not contain
a MTOM or SWA aachment to a virtual service for
a native provider endpoint that returns an MTOM or
SWA response, the request Accept header must be set
to 'multipart/related' (or the virtual service's Request
Processing Step should include an IS service callout that
sets the BUILDER_TYPE context variable to 'multipart/
related'). This is necessary so CloudStreams knows how
to parse the response properly.
Connection Timeout: The time interval (in seconds) after which
a connection aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), CloudStreams will use the
default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which a
socket read aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), the default is 30 seconds.
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Option

Description
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

Default To

Enter a native service endpoint to route the request to in case
all routing rules evaluate to False. Then, click the icon next
to this ﬁeld and complete the Conﬁgure Endpoint Properties
dialog box, as described for the Route To ﬁeld above.

The "Load Balancing" Routing Rule Step (SOAP)
If you have a native service that is hosted at two or more endpoints, you can use the
Load Balancing protocol to distribute requests among the endpoints.
The requests are intelligently routed based on the "round-robin" execution strategy.
The load for a service is balanced by directing requests to two or more services in a
pool, until the optimum level is achieved. The application routes requests to services in
the pool sequentially, starting from the ﬁrst to the last service without considering the
individual performance of the services. After the requests have been forwarded to all the
services in the pool, the ﬁrst service is chosen for the next loop of forwarding.
Load-balanced endpoints also have automatic Failover capability. If a load-balanced
endpoint is unavailable (for example, if a connection is refused), then that endpoint is
marked as "down" for the number of seconds you specify in the Suspend Interval ﬁeld
(during which the endpoint will not be used for sending the request), and the next
conﬁgured endpoint is tried. If all the conﬁgured load-balanced endpoints are down,
then a SOAP fault is sent back to the client. After the suspension period expires, each
endpoint marked will be available again to send the request.
To configure the "Routing Rule" step for "Load Balancing" routing (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Expand In Sequence.
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4. Click Routing Rule and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name. There are no naming
convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Load Balancing.

Route To

Specify the URLs of two or more services in a pool to which
the requests will be routed. The application routes the
requests to services in the pool sequentially, starting from
the ﬁrst to the last service without considering the individual
performance of the services. After the requests have been
forwarded to all the services in the pool, the ﬁrst service is
chosen for the next loop of forwarding.
To specify additional URLs, use the plus buon next to the
ﬁeld to add rows.
Then, click the icon next to this ﬁeld and complete the
Conﬁgure Endpoint Properties dialog box as follows. These
properties will apply to all the endpoints.
Optimization Method: Select one of the following options:
None: The default.
MTOM: Indicates that CloudStreams expects to receive
a request with a Message Transmission Optimization
Mechanism (MTOM) aachment, and will forward the
aachment to the native service.
SwA: Indicates that CloudStreams expects to receive a
"SOAP with Aachment" (SwA) request, and will forward
the aachment to the native service.
Note: Bridging between SwA and MTOM is not
supported. If a consumer sends an SwA request,
CloudStreams can only forward SwA to the native
provider. The same is true for MTOM, and applies to
responses received from the native provider. That is, an
SwA or MTOM response received by CloudStreams from
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Option

Description
a native provider will be forwarded to the caller using
the same format it received.
Note: When sending SOAP requests that do not contain
a MTOM or SWA aachment to a virtual service for
a native provider endpoint that returns an MTOM or
SWA response, the request Accept header must be set
to 'multipart/related' (or the virtual service's Request
Processing Step should include an IS service callout that
sets the BUILDER_TYPE context variable to 'multipart/
related'). This is necessary so CloudStreams knows how
to parse the response properly.
Connection Timeout: The time interval (in seconds) after which
a connection aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), CloudStreams will use the
default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which a
socket read aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), the default is 30 seconds.
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

Suspend
Interval

A numeric timeout value (in seconds) for a failed endpoint.
Default: 30. When this timeout value expires, the system
routes the execution of the virtual service to the next
consecutive Web service endpoint speciﬁed in the Route To
ﬁeld.

Use Credentials
from Incoming
Request

Default. Authenticates requests based on the credentials
speciﬁed in the HTTP header. CloudStreams passes the
Authorization header present in the original client request to
the native service.
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Option

Description

Use Specific
Credentials

Authenticates requests according to the values you specify in
the User, Password and Domain ﬁelds.

Invoke Service
Anonymously

Does not authenticate requests.

Use Existing
HTTP Headers

Use the HTTP headers that are contained in the requests.

Customize
HTTP Headers

Use the HTTP headers that you specify in the Name and Value
columns on this page. If you need to specify multiple headers,
use the plus buon to add rows.

The "Out Sequence" Step (SOAP)
You conﬁgure the service's "Out Sequence" step (optional) to manipulate the
response messages from the native service before they are returned to the consuming
applications. This step includes the following sub-steps:
The "Transform" step (optional), which invokes an XSLT transformation ﬁle to
transform the SOAP response payloads from XML format to the format required by
the consumer.
The "Invoke IS Service" step (optional), which processes the response message from
the native service provider before it is returned to the consuming application.

The "Transform" Step (Outbound, SOAP)
Add this step if you need to invoke an XSLT transformation ﬁle to transform the native
service's response messages into the format required by the consumer applications,
before CloudStreams returns the responses to the consumer applications. For more
information about when to use the Transform step, see "The Transform Step (Inbound,
SOAP)" on page 68.
To add the "Transform" step (outbound, SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Right-click Out Sequence and click Transform.
The Transform step is added to the Out Sequence step.
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4. Click Transform and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Transform.

XSLT File

The XSLT ﬁle to transform the response message before it is
returned to the consuming application. Click Browse to select a
ﬁle from your ﬁle system and click Save.
The XSL ﬁle uploaded by the user should not contain the
XML declaration in it (xml version="1.0" encoding="UTF-8").
This is because when the virtual service is deployed to
CloudStreams, CloudStreams embeds the XSL ﬁle in the
virtual service deﬁnition (VSD), and since the VSD itself is in
XML format, there cannot be an XML declaration line in the
middle of it. This can lead to unexpected deployment issues
which can be avoided by making sure the XSL ﬁle does not
contain the declaration line.
Note: If you make changes to the XSLT ﬁle in the future, you
must re-deploy the virtual service.

5. To create an additional Transform step, right-click In Sequence and select Transform again.
6. To delete a Transform step, right-click Transform and click Delete.

The "Invoke IS Service" Step (Outbound, SOAP)
This optional step invokes a user-deﬁned Integration Server ﬂow service. You can
invoke an IS service in the service's "Out Sequence" step to pre-process the response
message from the native service before it is returned to the consuming application. For
more information about IS services, see "The Invoke IS Service Step (Inbound, SOAP)"
on page 69.
To add the "Invoke IS Service" step (outbound, SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.

3. Right-click Out Sequence and click Invoke IS Service.
The Invoke IS Service step is added to the Out Sequence step.
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4. Click Invoke IS Service and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Invoke IS Service.

Service

The IS service to pre-process the response message from
the native service before it is returned to the consuming
application.

5. When you define the IS service, the Pipeline In section of the flow should have the following
input variables:
proxy.name:

This is the name of the virtual service.

SOAPEnvelope:

This is of the Java type org.apache.axiom.soap.SOAPEnvelope.

MessageContext:

CloudStreams will automatically place a MessageContext
variable into the pipeline before executing the IS service call. MessageContext is of
the Java type org.apache.axis2.context.MessageContext.
Integration Server users can use the Axis2 MessageContext object to manipulate
the incoming SOAP request. The Integration Server provides built-in services
(the pub.soap.* services) to work with the MessageContext object to get/set/modify
the SOAP body, header, properties, etc. Integration Server users should use
these services to extract the information they need from the MessageContext to
build the necessary business logic. Users do not need to understand Axis2 or
Axiom (the xml object model based on StAX) to work with the SOAP request,
because if they are familiar with the Integration Server pub.soap.* services, they
can accomplish most of the tasks. For more information about these related
Integration Server services, see the webMethods Integration Server Built-In Services
Reference.

6. To create an additional "Invoke IS Service" step, right-click In Sequence and click IS Service
again.

7. To delete an "Invoke IS Service" step, right-click Invoke IS Service and click Delete.

The "Error Sequence" Step (SOAP)
CloudStreams returns a default fault response to the consuming application, which you
can customize with context variables. This fault response is used for faults returned
by the native service provider as well as faults returned by internal CloudStreams
exceptions (policy violation errors, cloud connection errors and cloud connector service
errors). In addition, you can:
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Choose whether or not to send the native service provider's service fault content, or
just send the response message.
Invoke IS services to pre-process or post-process the error messages.
You use this step to conﬁgure error messaging for each virtual service individually. If
you want to conﬁgure global error responses for all virtual services, set the Service Fault
Conﬁguration options, which are located in the Integration Server Administrator (go
to Solutions > CloudStreams > Administration > Service Fault Configuration). For details, see
"Seing the Service Fault Conﬁguration Options" on page 41.
To configure the "Error Sequence" step (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.

3. Expand Error Sequence.
4. Click Error Messaging and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Error Messaging.

Error Message

Select one or both of the following options:
Custom Failure Response Message: When you select this option,
CloudStreams returns the following fault response to the
consuming application:
CloudStreams encountered an error:$ERROR_MESSAGE while
executing operation:$OPERATION service:$SERVICE at time:
$TIME on date:$DATE. The client ip was:$CLIENT_IP.
The current user:$USER. The consumer application:
$CONSUMER_APPLICATION".

This fault response is returned in both of the following cases:
When a fault is returned by the native service provider.
In this case, the $ERROR_MESSAGE variable in the fault response
will contain the message produced by the provider's
exception that caused the error. This is equivalent to the
getMessage call on the Java Exception. This maps to the
faultString element for SOAP 1.1 or the Reason element for
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Option

Description
SOAP 1.2 catch. CloudStreams discards the native service
provider's fault and does not return this content to the web
service caller since it could be considered a security issue,
especially if the native provider is returning a stack trace
with its response.
When a fault is returned by internal CloudStreams
exceptions (policy violation errors, cloud connection errors
and cloud connector service errors).
In this case, the $ERROR_MESSAGE variable will contain the error
messages generated by CloudStreams.
The default fault response contains predeﬁned fault handler
variables ($ERROR_MESSAGE, $OPERATION, etc.), which are
described in "The Fault Handler Variables" on page 87.
You can customize the default fault response using the
following substitution variables, where CloudStreams replaces
the variable reference with the real content at run time:
The predeﬁned context variables listed in "The Predeﬁned
Context Variables" on page 100.
Custom context variables that you declare using the
CloudStreams API (see "The API for Context Variables" on
page 104).
Note: If you want to reference a custom context variable that you
have already deﬁned in a context-based routing rule (as opposed
to one you have declared using CloudStreams API for context
variables), then you must add the preﬁx $mx to the variable name
in order to reference the variable. For example, if you deﬁned
the variable TAXID, you would reference it as $mx:TAXID.
Native Provider Fault: When you select this option,
CloudStreams sends the native service provider's service fault
content, if one is available. CloudStreams will send whatever
content it received from the native service provider.
If you select this option, the Custom Failure Response Message
is ignored when a fault is returned by the native service
provider. (Faults returned by internal CloudStreams
exceptions will still be handled by the Custom Failure Response
Message option.)
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Option

Description

Processing
Method

Optionally select either of the following:
Pre-Processing: Select this option if you want to invoke an IS
service to manipulate the response message before the Error
Sequence step is invoked. The IS service will have access
to the response message context (the axis2 MessageContext
instance) before it is updated with the custom error message.
For example, you might want to send emails or perform
custom alerts based on the response payload. For more
information about IS services, see "The Invoke IS Service Step
(Inbound, SOAP)" on page 69.
Post-Processing: Select this option if you want to invoke an
IS service to manipulate the service fault after the Error
Sequence step is invoked. The IS service will have access to
the entire service fault and the custom error message. You
can make further changes to the fault message structure, if
needed. For more information about IS services, see "The
Invoke IS Service Step (Inbound, SOAP)" on page 69.

The Fault Handler Variables
The following fault handler variables are used in fault response messages. You can
deﬁne fault response messages either in a virtual service's "Error Sequence" step or in the
global Service Fault Conﬁguration page in Integration Server Administrator.
Error Handler Variable

Description

$ERROR_MESSAGE

When a fault is returned by the native service provider,
this variable will contain the message produced by
the provider's exception that caused the error. This is
equivalent to the getMessage call on the Java Exception.
This maps to the faultString element for SOAP 1.1
or the Reason element for SOAP 1.2 catch. For REST
service calls, the message is returned inside an </
Exception> tag. If the response is XML, the message
is returned inside <Exception>'custom message'</
Exception>. If the response is JSON, it will be returned
inside {"Exception":"Invalid response"}.
When a fault is returned by internal CloudStreams
exceptions (policy violation errors, cloud connection
errors and cloud connector service errors), this
variable will contain the error messages generated by
CloudStreams.
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Error Handler Variable

Description

$OPERATION

The operation that was invoked when this error
occurred.

$SERVICE

The service that was invoked when this error occurred.
Note: Deprecated, but still a valid alias. Alternatively, use
$SERVICE_NAME (see "The Predeﬁned Context Variables"
on page 100).

$TIME

The time (as determined on the Container side) at
which the error occurred.

$DATE

The date (as determined on the Container side) at
which the error occurred.

$CLIENT_IP

The IP address of the client invoking the service. This
might be available for only certain invoking protocols,
such as HTTP(S).
Note: Deprecated, but still a valid alias. Alternatively, use
$INBOUND_IP (see "The Predeﬁned Context Variables" on
page 100).

$USER

The currently authenticated user. The user will be
present only if the Transport/SOAP Message have user
credentials.

$CONSUMER_APPLICATION

The currently identiﬁed consumer application. If
the service's policy does not contain the "Identify
Consumer" action, $CONSUMER_APPLICATION will return
"null".

IS Service Constructs
As previously mentioned, an IS (Integration Server) service is a user-deﬁned Integration
Server ﬂow service that you can invoke in the "In Sequence" and "Out Sequence" steps of
virtual services (both SOAP-based and REST-based).
You can use the following constructs in an IS service:
The Security API provided by CloudStreams (for SOAP-based services only). For
more information, see "Using the Security API in IS Services" on page 89.
Predeﬁned or custom context variables. For more information, see "Using Context
Variables in IS Services" on page 99.
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Using the Security API in IS Services
Note: This API can only be used for SOAP-based virtual services.
CloudStreams provides Java services that you can use to support WS-Security
functionality in an IS service that you invoke in the "In Sequence" step. These following
services are included:
"pub.cloudstreams.security.ws.AddUserNameToken" on page 89
"pub.cloudstreams.security.ws.AddX509Token" on page 92
"pub.cloudstreams.security.ws.AddSamlSenderVouchesToken" on page 93
"pub.cloudstreams.security.ws.AddTimestamp" on page 95
"pub.cloudstreams.security.ws.AddWSAddressingHeaders" on page 96
pub.cloudstreams.security.ws.AddUserNameToken
Adds the WS-Username Token 1.0 and 1.1 to the request. This service includes the
following input parameters:
Parameter

Data
Type

Description

Default Value

username

String

Required. Java Type:
String. The value that
will be added as the
Username element in
the token.

""

MessageContext

Object

Required. Java Type:

org.apache.
axis2.context.
MessageContext

org.apache.axis2.
context.
MessageContext.

CloudStreams
will place a

instance

MessageContext

parameter into the
pipeline before
executing the IS
service call.
password

String
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Parameter

Data
Type

Description

Default Value

below) is speciﬁed as
either TEXT or DIGEST.
passwordType

String

Java Type: String.
Speciﬁes how the
password will be
added in the token.
Valid values:

NONE

NONE:

The password
is not added.
TEXT:

The password
is added in plain
text.
DIGEST:

The
password is added
in digested form
(as speciﬁed in
the UsernameToken
proﬁle).
addNonce

Boolean

Java Type: Boolean.
Speciﬁes whether the
Nonce element will be
added to the token.

False

addCreated

Boolean

Java Type: Boolean.
Speciﬁes whether
the Created element
will be added to the
token.

False

salt

byte[]

Java Type: byte[].
The value for the /

null

wsse11:UsernameToken/
wsse:Salt element.

Its value is a 128 bit
number serialized as
xs:base64Binary.
iteration

int
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Parameter

Data
Type

Description

Default Value

operation is repeated
when deriving the
key. It is expressed as
a xs:unsignedInteger
value. If it is not
present, a value of
1000 is used for the
iteration count.
useMac

Boolean

Java Type: Boolean.
Indicates whether the
derived key will be
used as a Message
Authentication
Code (MAC) or as
a symmetric key for
encryption.

False

useBasicAuthCredentials

Boolean

Java Type: Boolean.
If this parameter
is set to True,
CloudStreams
will try to use the
username and
password from the
Authorization HTTP
header. In this case
the username and
password ﬁelds need
not be speciﬁed.

False

actor

String

Java Type: String.
Indicates the value
of the SOAP actor
aribute if a new
security header is
being added to the
SOAP request. If the
request already has a
security header with
the actor speciﬁed in
it, then this value will
not overwrite it.

""
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Parameter

Data
Type

Description

Default Value

mustUnderstand

Boolean

Java Type. Boolean.
Speciﬁes whether
the security header
will have the

False

mustUnderstand

aribute set to 0 or
1 (false / true). If
the security header
already has this
aribute set, then
this value will not
overwrite it.
pub.cloudstreams.security.ws.AddX509Token
Adds an X.509 certiﬁcate (or certiﬁcate chain) as a BinarySecurityToken (BST) element in
the outbound SOAP request. This service includes the following input parameters:
Parameter

Data
Type

Description

Default Value

MessageContext

Object

Required. Java Type:

org.apache.
axis2.context.
MessageContext

org.apache.axis2.context.
MessageContext.

CloudStreams will place a
MessageContext parameter
into the pipeline before
executing the IS service
call.

instance

keystoreFile

String

Required. Java Type:
String. The absolute
path to a keystore ﬁle
on the system where
CloudStreams is running.

""

keystorePassword

String

Java Type: String.
Required. The password
for the keystore.

""

keystoreType

String

Java Type: String. The type
of keystore represented by

JKS
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Parameter

Data
Type

Description

Default Value

the ﬁle (can be JKS, JCEKS
or PKCS12).
keyAlias

String

Java Type: String.
Required. The key alias
whose X509 certiﬁcate
will be sent in the SOAP
request as a BST.

""

useCertificatePath

Boolean

Java Type: Boolean. If set
to True, CloudStreams will
use the entire certiﬁcate
chain represented by the
key alias instead of just a
single certiﬁcate.

False

actor

String

Java Type: String. Indicates
the value of the SOAP
actor aribute if a new
security header is being
added to the SOAP
request. If the request
already has a security
header with this aribute
speciﬁed in it, then this
value will not overwrite it.

""

mustUnderstand

Boolean

Java Type: Boolean.
Speciﬁes whether the
security header will
have the mustUnderstand
aribute set to 0 or 1
(false / true). If the security
header already has this
aribute set, then this
value will not overwrite it.

False

pub.cloudstreams.security.ws.AddSamlSenderVouchesToken
This service enables a Security Token Service (STS) client to send a WS-Trust request to
a conﬁgured STS to obtain a SAML v1/v2 assertion. For the details about conﬁguring
CloudStreams to act as an STS client, see "Seing the STS Options" on page 38.

Administering webMethods CloudStreams Version 9.6

93

M

Even Header

This service adds the obtained SAML assertion to the original request that is sent by the
client to the native service, and includes the following parameters.
Parameter

Data
Type

Description

Default Value

ConfigName

String

Required. Java Type: String.
References a previously
conﬁgured STS conﬁguration
name.

""

MessageContext

Object

Required. Java Type:

org.apache.
axis2.context.
MessageContext

org.apache.axis2.context.
MessageContext.

CloudStreams will place a
MessageContext parameter
into the pipeline before
executing the IS service call.

instance

addTimeStamp

Boolean

Java Type: Boolean. Adds
a Timestamp element (with
the duration speciﬁed in
timeToLive) to the WSSecurity header of the
request, and includes it in the
signature. (The other items
that are signed are the body
and SAML assertion.)

False

timeToLive

Integer

Java Type: Integer. If
addTimeStamp is true, then
timeToLive speciﬁes the
duration (in seconds) for
which the request is valid.

300

actor

String

Java Type: String. Indicates
the value of the SOAP actor
aribute if a new security
header is being added to the
SOAP request. If the request
already has a security header
with this aribute speciﬁed
in it, then this value will not
overwrite it.

""
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Parameter

Data
Type

Description

Default Value

mustUnderstand

Boolean

Java Type: Boolean. Speciﬁes
whether the security header
will have the mustUnderstand
aribute set to 0 or 1 (false /
true). If the security header
already has this aribute
set, then this value will not
overwrite it.

False

pub.cloudstreams.security.ws.AddTimestamp
Adds a timestamp to the outbound SOAP request WS-Security header. This service
includes the following input parameters:
Parameter

Data
Type

Description

Default Value

timeToLive

Integer

Java Type: Integer.
Speciﬁes the duration
(in seconds) for which
the request is valid.

300

signTimestamp

Boolean

Java Type: Boolean.
Indicates whether the
generated timestamp
must be signed
by CloudStreams
using the conﬁgured
keystore and signing
alias.

False

seconds
(5 minutes)

Note: For signTimestamp
to work, you must
ensure that a valid IS
keystore and signing
alias are conﬁgured
in CloudStreams. For
details, see "Seing the
General Options" on
page 30.
useMilliSecondPrecision

Boolean

Administering webMethods CloudStreams Version 9.6

Java Type: Boolean.
Indicates whether the
generated timestamp

True

95

M

Even Header

Parameter

Data
Type

Description

Default Value

must have millisecond
precision.
MessageContext

Object

Required. Java Type:
org.apache.axis2.
context.MessageContext.

CloudStreams will
place a MessageContext
parameter into the
pipeline before
executing the IS
service call.

org.apache.
axis2.context.
MessageContext

instance

actor

String

Java Type: String.
Indicates the value
of the SOAP actor
aribute if a new
security header is
being added to the
SOAP request. If the
request already has a
security header with
this aribute speciﬁed
in it, then this value
will not overwrite it.

""

mustUnderstand

Boolean

Java Type: Boolean.
Speciﬁes whether
the security header
will have the

False

mustUnderstand

aribute set to 0 or
1 (false / true). If
the security header
already has this
aribute set, then
this value will not
overwrite it.
pub.cloudstreams.security.ws.AddWSAddressingHeaders
Adds WS-Addressing headers to a SOAP request sent by the client before CloudStreams
forwards the request to the native service. This service includes the following input
parameters:
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Parameter

Data
Type

Description

Default Value

isVersionSubmission

Boolean

Java Type: Boolean. The
WS-Addressing version
that should be used.

False

If true, the WSAddressing submission
namespace hp://
schemas.xmlsoap.org/
ws/2004/08/addressing
will be used.
If false, the Final
speciﬁcation
namespace hp://
www.w3.org/2005/08/
addressing will be used.
To

String

Java Type: String. This
value corresponds to
the /wsa:To addressing
header. You must specify
a value that corresponds
to the destination of the
request message. If this
value is not speciﬁed,
then depending on the
isVersionSubmission

parameter value, one of
the following anonymous
EPR values will be sent:
If isVersionSubmission
is set to true, the
anonymous EPR
value is: hp://
schemas.xmlsoap.org/
ws/2004/08/addressing/
role/anonymous.
If isVersionSubmission
is set to false, the
anonymous EPR
value is: hp://
www.w3.org/2005/08/
addressing/anonymous.
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Parameter

Data
Type

Description

Default Value

From

String

Java Type: String. This
value corresponds to the
/wsa:From addressing
header and refers to the
source of the message.

""

Action

String

Java Type: String. This
value corresponds to the
/wsa:Action addressing
header. By default, this
property has the same
value as the operation on
the virtual service being
invoked (which will
usually correspond to the
same operation on the
native service). But you
can specify a diﬀerent
value corresponding to
the native service being
called.

URI identifying
input operation
corresponding
to a WSDL
port type being
called on the
virtual service.

MessageContext

Object

Required. Java Type:

org.apache.
axis2.context.
MessageContext

org.apache.axis2.
context.MessageContext.

CloudStreams will
place a MessageContext
parameter into the
pipeline before executing
the IS service call.
actor

String

Java Type: String.
Indicates the value of the
SOAP actor aribute if
a new security header is
being added to the SOAP
request. If the request
already has a security
header with this aribute
speciﬁed in it, then this
value will not overwrite
it.
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Parameter

Data
Type

Description

Default Value

mustUnderstand

Boolean

Java Type: Boolean.
Speciﬁes whether the
security header will
have the mustUnderstand
aribute set to 0 or
1 (false / true). If the
security header already
has this aribute set,
then this value will not
overwrite it.

False

Example of using AddWSAddressingHeaders:
The sample service shown below is conﬁgured by providing the MessageContext
parameter.

Using Context Variables in IS Services
CloudStreams provides predeﬁned context variables, and you can declare your own
custom context variables. You can use both predeﬁned and custom context variables
when you conﬁgure various processing steps of a virtual service. Speciﬁcally, you can
use them in:
An IS service that you create and invoke in the "In Sequence" and "Out Sequence"
steps.
In a routing rule that you create in a "Routing Rule" step of the type "Context-Based".
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This section discusses:
"The Predeﬁned Context Variables" on page 100.
Custom context variables (see "The API for Context Variables" on page 104).
The Predefined Context Variables
You can use the predeﬁned context variables listed below. Any context variable state
deﬁned during the inbound request processing steps will still be available during the
outbound response processing steps.
Note: To set, get or remove the predeﬁned context variables, use the API for context
variables provided by CloudStreams (see "The API for Context Variables" on page
104).
Note: You do not need to declare the predeﬁned context variables. If you aempt to
declare an existing predeﬁned context variable, an error will occur.
Context
Variable
Display Name

Context Variable Name

Description

Average
Response

AVG_SUCCESS_TIME

The average amount of time it
took the service to complete all
invocations in the current interval.
Response time is measured from the
moment CloudStreams receives the
request until the moment it returns
the response to the caller.

Client IP
Address

INBOUND_IP

The IP address used to send the
request to CloudStreams.

CloudStreams
Host Name

HOSTNAME

CloudStreams host name.

CloudStreams
IP Address

SERVER_IP

CloudStreams IP address.

CloudStreams
Target Name

TARGET_NAME

CloudStreams target name.

Consumer

CONSUMER_APPLICATION

The name of the consumer
application accessing the service, if
known.
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Context
Variable
Display Name

Context Variable Name

Description

Fault Count

INTERVAL_FAULT_COUNT

The number of invocations of the
service resulting in a fault in the
current interval.

Inbound
Content Type

MESSAGE_TYPE

A Content-Type deﬁned in axis2.xml
for a message formaer. This value
must be a key in the axis2 message
formaers list, since it is used to
control message serialization. (The
valid choices are deﬁned as aributes
of <messageFormatters/> group
in Integration Server's axis2.xml
conﬁguration.)

Inbound
HTTP Method

INBOUND_HTTP_METHOD

The HTTP method used by the client
to send the request (GET, POST, PUT,
DELETE, CUSTOM).

Inbound
Protocol

INBOUND_PROTOCOL

The protocol (HTTP or HTTPS) of the
request.

Maximum
Response

SLOWEST_SUCCESS_INVOKE

The maximum amount of time
it should take for the service to
complete an invocation. Response
time is measured from the moment
CloudStreams receives the request
until the moment it returns the
response to the caller.

Minimum
Response

FASTEST_SUCCESS_INVOKE

The minimum amount of time
it should take for the service to
complete an invocation.

Outbound
HTTP Method

ROUTING_METHOD

The HTTP method to be sent to
the native service if the inbound
HTTP method is custom. Otherwise,
this value will be null. For more
information, see "Changing the HTTP
Method of a REST Virtual Service" on
page 160.
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Context
Variable
Display Name

Context Variable Name

Description

Success
Count

INTERVAL_SUCCESS_COUNT

The number of successful invocations
of the service in the current interval.

Total Count

INTERVAL_TOTAL_COUNT

The total number of invocations
(successful or unsuccessful) of the
service in the current interval.

Virtual
Service Name

SERVICE_NAME

Virtual service name.

(not
displayed)

BUILDER_TYPE

A Content Type deﬁned in axis2.xml
for a message builder. This value
must be a key in the axis2 message
builders list, since it is used to
control building of native service
response messages. (The valid
choices are deﬁned as aributes
of <messageBuilders/> group in
Integration Server's axis2.xml
conﬁguration.)

(not
displayed)

INBOUND_REQUEST_URI

A partial reference to a virtual
service (for HTTP/HTTPS only).
The protocol, host and port are not
part of the value. For example, if the
following virtual service is invoked:
http://user:5555/ws/TC1

then the expected value of this
variable would be /ws/TC1.
For a REST or XML service, the URL
might also include query string
parameters. For example, if the
following virtual service is invoked:
http://user:5555/ws/cars?vin=1234

then the expected value of this
variable would be /ws/cars?vin1234.
This is useful to know because by
the time you are able to access the
request inside of CloudStreams, the
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Context
Variable
Display Name

Context Variable Name

Description

REST request would contain a toplevel element that looks like this:
<vin>1234</vin>

So it is not obvious from an XSLT
expression or an IS service callout
what part of a REST request
came in as a query parameter.
Therefore, using this variable along
with INBOUND_HTTP_METHOD and
INBOUND_PROTOCOL, you can determine
the exact entry point URI that was
used when a CloudStreams virtual
service was invoked.
(not
displayed)

NATIVE_PROVIDER_ERROR

The "reason" returned by the native
service provider in the case where it
produced a SOAP fault. This variable
will not contain CloudStreams-hosted
errors such as policy violation errors;
it will only contain the "reason" text
wrapped in a SOAP fault.

(not
displayed)

OPERATION

The service operation selected to
execute a request.

(not
displayed)

PROTOCOL_HEADERS

Contains a map of key-value
pairs in the request, where the
values are typed as strings.
To get/set this variable, use
pub.cloudstreams.ctxvar:getContextVariable
(see "The API for Context Variables"
on page 104).

(not
displayed)

SOAP_HEADERS

(For use in IS services only.)
Contains an array of the SOAP
header elements in the request.
To get/set this variable, use
pub.cloudstreams.ctxvar:getContextVariable
(see "The API for Context Variables"
on page 104).
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Context
Variable
Display Name

Context Variable Name

Description

(not
displayed)

USER

The value deﬁned for the Integration
Server session executing the request
message. If the request is not
authenticated, it will use a default
unprivileged account. Otherwise, it
will set the Integration Server session
to the user credentials used for
transport security. In the case where
a consumer is sending a request with
both transport credentials (HTTP
Basic authentication) and message
credentials (WSS Username or X.509
token), the message credentials
take precedence over the transport
credentials.

The API for Context Variables
CloudStreams provides an API that you can use to:
Set, get, declare and remove custom context variables.
Set and get the predeﬁned context variables. (It is not necessary (or even legal) to
declare or remove the predeﬁned context variables.)
CloudStreams provides the following Java services (described below):
pub.cloudstreams.ctxvar:getContextVariable
pub.cloudstreams.ctxvar:setContextVariable
pub.cloudstreams.ctxvar:declareContextVariable
pub.cloudstreams.ctxvar:removeContextVariable
The following sample ﬂow services are described in this section as well:
Sample Flow Service: Geing a Context Variable Value
Sample Flow Service: Seing a Context Variable Value
pub.cloudstreams.ctxvar:getContextVariable
Use this Java service to retrieve a context variable's value and assign it to a pipeline
variable. All parameter names are case-sensitive.
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Parameter

Pipeline
Type

Data
Type

Description

MessageContext

in

Object
ref

This object is inserted into the pipeline
by CloudStreams.

varName

in

String

Context variable name (predeﬁned or
custom). Examples: PROTOCOL_HEADERS,
SOAP_HEADERS, mx:CUSTOM_VAR

serValue

out

Object
ref

java.io.Serializable

string).

value. (Usually a

Notes on Getting and Setting the PROTOCOL_HEADERS and SOAP_HEADERS Variables
All context variable values are typed as either "string" or "int" except for the predeﬁned
context variables PROTOCOL_HEADERS and SOAP_HEADERS, which are of the type "IData". You
can set/get values for PROTOCOL_HEADERS and SOAP_HEADERS in one of two ways:
1. Set/get the entire structure.
To set the entire structure, you must:
Set the varName parameter in pub.cloudstreams.ctxvar:setContextVariable to
PROTOCOL_HEADERS or SOAP_HEADERS.
Use the method RuntimeFacade.setContextVariableValue().
To get the entire structure, you must:
Set the varName parameter in pub.cloudstreams.ctxvar:getContextVariable to
PROTOCOL_HEADERS or SOAP_HEADERS.
Use the method RuntimeFacade.getContextVariableValue().
If varName is set to PROTOCOL_HEADERS, you will get/set the entire IData structure
containing all of the transport headers. The key is the transport header name
(for example, Content-Type) and the value is a String. The IData object for
PROTOCOL_HEADERS will contain a set of string values where each IData string key
matches the header name in the transport headers map. The set of possible keys
includes the HTTP v1.1 set of headers as well as any custom key-value pairs you
might have deﬁned.
If varName is set to SOAP_HEADERS, you will get/set the entire IData structure
containing all of the SOAP headers in the SOAP envelope. The key is the array
position starting with "0", and the value is an Axiom OMElement containing that SOAP
header block.
Alternatively, you can set the varName parameter to address a speciﬁc element in the
array. For example, seing it to PROTOCOL_HEADERS[Content-Type] would apply to the
Content-Type transport header. Similarly, seing it to SOAP_HEADERS[0] would return
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a String representation of the ﬁrst SOAP header block (as opposed to an Axiom
OMElement).
2. Set/get a nested value.
Set a nested value in one of the following ways:
Set the varName parameter in pub.cloudstreams.ctxvar:setContextVariable to
PROTOCOL_HEADERS[arrayElement ], where arrayElement refers to a speciﬁc element.
For example, PROTOCOL_HEADERS[Content-Type] or SOAP_HEADERS[0] (to indicate
the ﬁrst array element in the set).
Alternatively, use the method RuntimeFacade.setContextVariableValue(). You would
use this method only if you are writing a Java service and you want to access it
through the Java source code.
Get a nested value in one of the following ways:
Set the varName parameter in pub.cloudstreams.ctxvar:getContextVariable to
PROTOCOL_HEADERS[arrayElement ], where arrayElement refers to a speciﬁc element.
For example, PROTOCOL_HEADERS[Content-Type] or SOAP_HEADERS[0] (to indicate
the ﬁrst array element in the set).
Alternatively, use the method RuntimeFacade.getContextVariableValue(). You would
use this method only if you are writing a Java service and you want to access it
through the Java source code.
You can set/get a nested value inside PROTOCOL_HEADERS and SOAP_HEADERS via an
additional keyName. In this case, the object reference will not be an IData object.
For PROTOCOL_HEADERS, the keyName must match the transport header name in
a case-sensitive manner (for example, PROTOCOL_HEADERS[Content-Type] or
PROTOCOL_HEADERS[Authorization]). In this case, the Serializable value will be a
string.
For SOAP_HEADERS, the keyName must match the 0-based array element. If a request
has a SOAP security header element (</wsse:Security>), then it would be
addressed as SOAP_HEADERS[0]. In this case, the element will be in its string
format.
pub.cloudstreams.ctxvar:setContextVariable
Use this Java service to set a value on a context variable. The pipeline variable
containing the context variable value should be an object reference that implements
java.io.Serializable. All parameter names are case-sensitive.
Parameter

Pipeline
Type

Data
Type

Description

MessageContext

in

Object
ref

This object is inserted into the pipeline
by CloudStreams.
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Parameter

Pipeline
Type

Data
Type

Description

varName

in

String

Context variable name (predeﬁned or
custom). Examples: PROTOCOL_HEADERS,
SOAP_HEADERS, mx:CUSTOM_VAR

serValue

in

Object
ref

Java.io.serializable

string.)

value. (Usually a

pub.cloudstreams.ctxvar:declareContextVariable
Use this Java service to declare a custom context variable. All custom-deﬁned context
variables must be declared in a custom namespace that is identiﬁed by using the preﬁx
mx (for example, mx:CUSTOM_VARIABLE). All parameter names are case-sensitive.
Note: It is not legal to use this service to declare the predeﬁned context variables; you can
only declare custom variables.
Parameter

Pipeline
Type

Data
Type

Description

ctxVr

in

Object
ref

The document type deﬁning the
context variable object. Use the ctxVar
Document Type provided in the Java
service pub.cloudstreams.ctxvar:ctxVar
and map it to this input variable. Deﬁne
the name of the context variable (for
example, mx:CUSTOM_VARIABLE),
the schema_type (string or int), and
isReadOnly (true or false).

ctxVar

out

Object
ref

The set Context variable document type.

varNameQ

out

Object
ref

javax.xml.namespace.QName value. The
QName of the variable.

Note the following:
After declaring the context variable, you can use the setContext variable to set a
value on the context variable.
You do not need to declare the following kinds of context variables:
The predeﬁned variables provided by CloudStreams. If you aempt to declare an
existing predeﬁned context variable, an error will occur.
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Any custom context variable that you deﬁne in a routing rule that you create in a
"Context-Based" Routing Rule step.
Any custom context variables that you explicitly declare in source code using the
API will have a declaration scope of SESSION.
Any custom context variable's state that is deﬁned during the inbound request
processing steps will still be available during the outbound response processing
steps.
All context variable values are typed as either "string" or "int" (excluding the
SOAP_HEADERS and PROTOCOL_HEADERS variables, which are of the type "IData").
Valid names should be upper case (by convention) and must be a valid Java
Identiﬁer. In general, use alpha-numerics, $ or _ symbols to construct these context
names. Names with punctuation, whitespace or other characters will be considered
invalid and will fail deployment.
All custom context variables must be declared in a custom namespace that is
identiﬁed by using an mx preﬁx (for example, mx:CUSTOM_VARIABLE).
To reference a custom context variable in a ﬂat string, you need to prepend a $
symbol to the context variable name to indicate that variable's value should be
referenced. Think of this usage as being similar to the "&" address operation for C
variables.
An expression that references a custom context variable might look like this:
$mx:TAXID=1234

or $mx:ORDER_SYSTEM_NAME="Pluto"

Notice that the values of the data type int are not enclosed in quotation marks, while
the values of the data type string are. The quotation marks are only needed if a
context variable expression (as opposed to a reference) is deﬁned.
Referencing an undeﬁned context variable does not result in an error.
Once a variable has been declared it cannot be declared again.
pub.cloudstreams.ctxvar:removeContextVariable
Use this Java service to remove a custom context variable from a request/response
session. All parameter names are case-sensitive.
Note: It is not legal to use this service to remove any predeﬁned context variables; you
can only remove custom variables.
Note: Aempting to remove a non-existent context variable will not result in an error.
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Parameter

Pipeline
Type

Data
Type

Description

MessageContext

in

Object
ref

This object is inserted into the pipeline
by CloudStreams.

varName

in

String

Custom context variable name. Example:
mx:CUSTOM_VAR.

Sample Flow Service: Getting a Context Variable Value
This ﬂow service gets the value of a custom context variable from a request. The
service declares a context variable using the name deﬁned in the pipeline variable
customName (that is, mx:COMP_TEST). It is hard-coded to store the predeﬁned context
variable SERVICE_NAME in this custom context variable name.
Step 1: Setting varName and customName

In this ﬂow service, the following pipeline variables that are hard-coded as follows:
varName

is set to the predeﬁned context variable SERVICE_NAME.

is set to mx:COMP_TEST, and SERVICE_NAME is stored in customName in the
"Pipeline Out".
customName
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Step 2: Calling the pub.cloudstreams.ctxvar:getContextVariable service

The call to pub.cloudstreams.ctxvar:getContextVariable looks up the context variable
value for the "Pipeline In" variable varName and sets the Serializable value in the
"Pipeline Out" variable serValue.
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Step 3: Calling the pub.cloudstreams.ctxvar:declareContextVariable service

The call to pub.cloudstreams.ctxvar:declareContextVariable takes the serialized value
we looked up for varName and assigns it to a newly declared custom context variable
named ctxVar.
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Step 4: Calling the pub.cloudstreams.ctxvar:setContextVariable service

The call to pub.cloudstreams.ctxvar:setContextVariable sets the context variable value
back into MessageContext so it will be available for the rest of the service invocation
steps.
Sample Flow Service: Setting a Context Variable Value
This ﬂow service sets the value of a custom context variable to be used in a response.
This ﬂow service declares a pipeline variable named customName, which is set to the
value mx:COMP_TEST.
This ﬂow service will retrieve the context variable for customName and create an element
for its context variable value in the response message return to the consumer.
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Step 1: Declaring customName

We deﬁne the customName variable to be mx:COMP_TEST so we can use this variable to
lookup the custom variable name that was seeded in the previous example.
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Step 2: Setting customName to mx:COMP_TEST

Clicking on the customName pipeline variable will display the name.
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Step 3: Displaying the value of customName

The call to pub.cloudstreams.ctxvar:getContextVariable retrieves the value of the
custom context variable from the context variable map.
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Step 4: Calling pub.cloudstreams.ctxvar:getContextVariable

This is just a sample Java service that takes the context variable and creates a top-level
element in the response message using the same name and value.
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Step 5: Sample service using the context variable

Creating a New Connector Virtual Service (SOAP)
A connector virtual service will:
Handle the provider's response.
Log the requests/responses.
CloudStreams provides a default connector virtual service for each metadata handler:
The service WmCloudStreams.SoapVS (for the SOAP handler).
The service WmCloudStreams.RestVS (for the REST handler).
The default services are located in the sample CloudStreams Governance project in the
WmCloudStreams package. You cannot modify them.
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Each default connector virtual service has a default policy (named Logging Policy),
which logs all requests/responses and their payloads to a database. You cannot modify
the default policy. Alternatively, you can create additional connector virtual services
with custom policies.
If you create a connector virtual service with a custom policy, you can only include the
actions in the "Monitoring" or "Additional" action categories; you cannot include the
"WS-SecurityPolicy 1.2" actions. For example, you might want to create a custom policy
that monitors run-time performance, customizes how the service invocations are logged,
validates response messages against an XML schema, or optimizes server traﬃc. For
complete details, see the chapter "Policies" on page 165.
To create a new connector virtual service (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, right-click the CloudStreams Governance project and
click New > Connector Virtual Service (or expand the project, right-click the Connector Virtual
Services folder and click New Connector Virtual Service).

3. Complete the following fields in the New Connector Virtual Service wizard and click Finish.
Option

Description

CloudStreams
Governance
Project

Click Browse and select a CloudStreams Governance project in
which to create the connector virtual service.

Name

Assign a name for the service. Unlike native services,
the names of virtual services cannot contain spaces or
special characters except _ (underscore) and - (hyphen).
Consequently, if you adopt a convention that involves using
the name of the service as part of the virtual service name,
then the names of the services themselves must not contain
characters that are invalid in virtual service names.
Note: If you want to change the service name after it has been
created, right-click the service name in the Virtual Services folder
and select Rename.

Version

(Read-only ﬁeld.) Currently not supported.

Type

Select SOAP.

Description

Optional. A description for the service. This description
appears when a user displays a list of services in the user
interface.
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The new connector virtual service is added to the CloudStreams Governance project,
in the Connector Virtual Services folder.

The Properties of a Connector Virtual Service (SOAP)
To view the properties of a connector virtual service (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name. (If the Properties view is not already open, click Window >
Show View > Other > General > Properties.)

3. The General page in the Properties view displays the following properties:
Option

Description

Name

(Read-only ﬁeld.) The service name. You can change the
service name at any time by right-clicking the name in the
Connector Virtual Services folder and clicking Rename.

Service Type

(Read-only ﬁeld.) SOAP.

Created/Last
Modified

(Read-only ﬁeld.) The service's creation/modiﬁcation
timestamps.

Target
Namespace

(Read-only ﬁeld.) The value derived from the targetNamespace
aributes of the WSDL's deﬁnition element.

Namespaces

Click the buon next to this ﬁeld to view the service's available
namespaces (such as wsdl, xsd, soap, etc.).

Version

(Read-only ﬁeld.) Currently not supported.

WSDL URL

(Read-only ﬁeld.) The URL of the service's WSDL.

Description

You can change the service description.

4. View additional properties in the Advanced page.
Option

Description

Name

(Read-only ﬁeld.) The service name.

Administering webMethods CloudStreams Version 9.6

119

M

Even Header

Option

Description

Type

(Read-only ﬁeld.) The type of the service (SOAP).

Target
Namespace

(Read-only ﬁeld.) The value derived from the targetNamespace
aributes of the WSDL's deﬁnition element.

WSDL URL

Click this URL to display the contents of the service's abstract
WSDL. This is an internal WSDL used by CloudStreams
primarily to manage deployment of connector virtual services
to a CloudStreams target. The native provider's WSDL that
was deﬁned for the connector is what is used when the
connector service is conﬁgured.

Namespaces

Click the buon next to this ﬁeld to view the service's available
namespaces (such as wsdl, xsd, soap, etc.).

Version

(Read-only ﬁeld.)

Description

(Read-only ﬁeld.) The service description.

VSD

Click the buon next to this ﬁeld to view the service's "virtual
service deﬁnition" (VSD). This buon is disabled until you
deploy the connector virtual service to a CloudStreams server.
When you deploy the connector virtual service to a
CloudStreams server, CloudStreams generates an XML
document called a virtual service deﬁnition (VSD). The VSD
deﬁnes the connector virtual service for CloudStreams, and
contains all the resources required to deploy the connector
virtual service to a CloudStreams server, including the policy
that applies to the service. You cannot edit the VSD.
Note: If multiple policies apply to the service, CloudStreams
combines all those policies into a single policy known as the
eﬀective policy. The eﬀective policy is a simple UNION of the
run-time actions speciﬁed in all policies that apply to a service.
To create the eﬀective policy, CloudStreams evaluates the
combined list of actions from all policies, using a set of internal
rules known as Policy Conﬂict Resolution rules. For details, see
"Policy Conﬂict Resolution Rules" on page 201.

Applicable
Policies

Click the buon next to this ﬁeld to view a list of the active
policies that apply to this service. Any inactive policy that
applies to the service is not listed. To change the list of
applicable policies, see "Modifying Policies" on page 170.
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Option

Description

Endpoint

(Read-only ﬁeld). The endpoint is resolved when the
connector service is conﬁgured and the user selects an enabled
managed connection pool.

Deployed Status

(Read-only ﬁeld.) Indicates whether the service is Deployed,
Undeployed or Not Deployed (which is the initial status before
you deploy the service). To deploy or undeploy a service, see
"Deploying Virtual Services and Connector Virtual Services"
on page 197.

Resource

Not applicable to SOAP services.

Managing a Connector Virtual Service (SOAP)
You can rename, delete, deploy or undeploy a connector virtual service, and change the
list of policies that apply to the it.
To manage a connector virtual service (SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project.
3. Right-click the connector virtual service name and choose any of the following tasks from the
context menu:
Option

Description

Rename

Use this option to assign a new name to the service. The
service must be undeployed before you can rename it (check
the Deployed Status ﬁeld in the Advanced page of the service's
Properties view).
Unlike native services, the names of connector virtual
services cannot contain spaces or special characters except
_ (underscore) and - (hyphen). Consequently, if you adopt
a convention that involves using the name of the service as
part of the connector virtual service name, then the names of
the services themselves must not contain characters that are
invalid in connector virtual service names.

Delete

Deletes the connector virtual service from CloudStreams.
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Option

Description

Deploy

Deploys the connector virtual service to a CloudStreams server
target. For more information, see "Deploying Virtual Services
and Connector Virtual Services" on page 197.

Undeploy

Undeploys the connector virtual service from a CloudStreams
server target.

4. To change the list of policies that apply to the connector virtual service, see "Modifying
Policies" on page 170.

The "In Sequence" Step (Connector Virtual Service, SOAP)
The "In Sequence" step can contain the following sub-steps:
The "Entry Step" (required), which speciﬁes the protocol of the requests that the
connector virtual service will accept.
The "Routing Rule" step (required), which speciﬁes how the connector virtual service
will route the service requests to the native service endpoint.
The "Invoke IS Service" step (optional), which pre-processes the request message
before it is submied to the native service.

The "Entry Step" (Connector Virtual Service, SOAP)
This step speciﬁes the protocol of the requests that the connector virtual service will
accept. You cannot modify this step, except for it name.
To edit the "Entry Step" (connector virtual service, SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the connector virtual service name.
The virtual service editor displays the three main processing steps: In Sequence, Out
Sequence and Error Sequence.

3. Expand In Sequence.
By default, the In Sequence step contains the sub-steps Entry Step and Routing Rule.
(You can add the optional Invoke IS Service step, as described later.)

4. Click Entry Step and complete the fields in the General page in the Properties view as
follows.

Administering webMethods CloudStreams Version 9.6

122

M

Odd Header

Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Entry Step.

Protocol

(Read-only ﬁeld.) The protocol of the requests that the
connector virtual service will accept. The value Local means
that the service can only be called from Cloud Connector
Services.

The "Routing Rule" Step (Connector Virtual Service, SOAP)
This step speciﬁes how the connector virtual service will route the requests to the native
service endpoint. You cannot modify this step, except for its name.
To edit the "Routing Rule" step (connector virtual service, SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the connector virtual service name.

3. Expand In Sequence.
4. Click Routing Rule and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

Read-only ﬁeld.) Protocol. You cannot change the protocol over
which the connector virtual service will accept requests.

Routing Rule

(Read-only ﬁeld.) The value Connection Pool means that
the requests are sent to the provider via the CloudStreams
connection pool. For more information about connection
pools, see the documentation speciﬁc to your webMethods
CloudStreams cloud provider (for example, webMethods
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Option

Description
CloudStreams Provider for Salesforce.com Installation and User's
Guide).

The "Invoke IS Service" Step (Inbound, Connector Virtual Service, SOAP)
This optional step invokes a user-deﬁned Integration Server ﬂow service. An IS service is
a user-deﬁned Integration Server ﬂow service that you can invoke in:
The "In Sequence" step, to pre-process the request messages before CloudStreams
submits the requests to the native service.
The "Out Sequence" step, to pre-process the response messages from the native
service before CloudStreams returns the responses to the consuming application.
You create an "Invoke IS Service" step for a connector virtual service the same way you
create one for a virtual service. For details, see "The Invoke IS Service Step (Inbound,
SOAP)" on page 69, or "The Invoke IS Service Step (Outbound, SOAP)" on page
83.

The "Out Sequence" Step (Connector Virtual Service, SOAP)
You conﬁgure the service's "Out Sequence" step (optional) to manipulate the response
messages from the native service before CloudStreams returns the responses to the
consuming applications. This step can include the "Invoke IS Service" step (optional),
which pre-processes the response message from the native service provider before it
is returned to the consuming application. See "The Invoke IS Service Step (Inbound,
Connector Virtual Service, SOAP)" on page 124.

The "Error Sequence" Step (Connector Virtual Service, SOAP)
The default connector virtual services are conﬁgured to return the native service
provider's service fault, if one is available. CloudStreams will send whatever content it
received from the native service provider. You can optionally invoke IS services to preprocess or post-process the error messages.
To configure the "Error Sequence" step (connector virtual service, SOAP)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the connector virtual service name.

3. In the virtual service editor, expand Error Sequence.
4. Click the Error Messaging sub-step and complete the following fields in the General page in
the Properties view.
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Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Error Messaging.

Processing
Method

Optionally select either of the following:
Pre-Processing: Select this option if you want to invoke an IS
service to manipulate the response message before the Error
Sequence step is invoked. The IS service will have access
to the response message context (the axis2 MessageContext
instance) before it is updated with the custom error message.
For example, you might want to send emails or perform
custom alerts based on the response payload. For more
information about IS services, see "The Invoke IS Service Step
(Inbound, SOAP)" on page 69.
Post-Processing: Select this option if you want to invoke an
IS service to manipulate the service fault after the Error
Sequence step is invoked. The IS service will have access to
the entire service fault and the custom error message. You
can make further changes to the fault message structure, if
needed. For more information about IS services, see "The
Invoke IS Service Step (Inbound, SOAP)" on page 69.

Creating a New Virtual Service (REST)
To create a new virtual service (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, right-click the CloudStreams Governance project and
click New > Virtual Service (or expand the project, right-click the Virtual Services folder and
click New Virtual Service).

3. In the New Virtual Service wizard, complete the following fields.
Option

Description

CloudStreams
Governance
Project

Click Browse and select a CloudStreams Governance project in
which to create the service.
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Option

Description

Name

Assign a name for the service. Unlike native services,
the names of virtual services cannot contain spaces or
special characters except _ (underscore) and - (hyphen).
Consequently, if you adopt a convention that involves using
the name of the service as part of the virtual service name,
then the names of the services themselves must not contain
characters that are invalid in virtual service names.
Note: If you want to change the service name after it has been
created, right-click the service name in the Virtual Services folder
and select Rename.

Version

(Read-only ﬁeld.) Currently not supported.

Service Type

Select REST.

Description

Optional. A description for the service. This description
appears when a user displays a list of services in the user
interface.

4. Click Finish.
The new virtual service is added to the CloudStreams Governance project, in the
Virtual Services folder.

5. Click the new virtual service name in the CloudStreams Governance project.
The Properties view is displayed at the boom of the editor.

6. On the Advanced page in the Properties view, click the Resource button.
7. In the REST Resources dialog box that appears, add a REST resource that the service will
access by completing the following fields.
Option

Description

Resource

Specify the name of the REST resource that the service will
access.
Note: To add a REST resource to the service after the service
has been created, right-click the service name and click Attach
Resource.

HTTP Methods

(Read-only ﬁeld.) The HTTP methods that the virtual service
should be allowed to perform on the REST resource (GET,
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Option

Description
POST, PUT, DELETE). You specify the HTTP methods when you
conﬁgure the virtual service's Entry Step.

Content Type

(Read-only ﬁeld.) Application/xml or Application/json.

Query String

Specify the search string as required. Any text typed in is not
case sensitive.
This ﬁeld is used only for documentation purposes at this
time. It is not included in the service's "virtual service
deﬁnition" (VSD) that is deployed to CloudStreams, so this
value has no impact at runtime.

Import from

Import the schemas that the virtual service will use. Choose
one of the following options. (To select multiple schemas, click
the plus buon to add a row.)
URL: Specify the URL of a schema and click the Add buon.
Optionally choose the following option:
URL authentication: If you have speciﬁed a URL, and
the site you want to access via the URL requires
user authentication, select this option. This opens an
Authentication sub-dialog in which you can enter a user
name and password for authentication at the URL site.
File: Click Browse to select a schema in your local ﬁle system.

8. Click OK.

The Properties of a Virtual Service (REST)
To view or modify the properties of a virtual service (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name. (If the Properties view is not already open, click Window >
Show View > Other > General > Properties.)

3. The General page in the Properties view displays the following properties:
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Option

Description

Name

(Read-only ﬁeld.) The service name. You can change the
service name at any time by right-clicking the name in the
Virtual Services folder and clicking Rename.

Service Type

(Read-only ﬁeld.) REST.

Created/Last
Modified

(Read-only ﬁeld.) The service's creation/modiﬁcation
timestamps.

Target
Namespace

(Read-only ﬁeld.) The value is derived from the
targetNamespace aributes of the WSDL's deﬁnition element.

Namespaces

Specify other namespaces (such as wsdl, xsd, etc.).

Version

(Read-only ﬁeld.) Currently not supported.

WSDL URL

(Read-only ﬁeld.) The URL of the REST resource's abstract
WSDL.

Description

You can change the service description.

4. View additional properties on the Advanced page.
Option

Description

Name

(Read-only ﬁeld.) The service name.

Type

(Read-only ﬁeld.) REST.

Target
Namespace

(Read-only ﬁeld.) The value is derived from the
targetNamespace aributes of the WSDL's deﬁnition element.

WSDL URL

Click this URL to display the contents of the REST resource's
abstract WSDL.

Namespaces

Specify other namespaces (such as wsdl, xsd, etc.).

Version

(Read-only ﬁeld.) Currently not supported.

Description

(Read-only ﬁeld.) The service description.
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Option

Description

VSD

Click the buon next to this ﬁeld to view the service's "virtual
service deﬁnition" (VSD). This buon is disabled until you
deploy the virtual service to a CloudStreams server.
When you deploy the virtual service to a CloudStreams server,
CloudStreams generates an XML document called a virtual
service deﬁnition (VSD). The VSD deﬁnes the virtual service
for CloudStreams, and contains all the resources required to
deploy the virtual service to a CloudStreams server, including
the policy that applies to the service. You cannot edit the VSD.
Note: If multiple policies apply to the service, CloudStreams
combines all those policies into a single policy known as the
eﬀective policy. The eﬀective policy is a simple UNION of the
run-time actions speciﬁed in all policies that apply to a service.
To create the eﬀective policy, CloudStreams evaluates the
combined list of actions from all policies, using a set of internal
rules known as Policy Conﬂict Resolution rules. For details, see
"Policy Conﬂict Resolution Rules" on page 201.

Applicable
Policies

Click the buon next to this ﬁeld to view a list of the active
policies that apply to this service. Any inactive policy that
applies to the service is not listed.

Endpoint

Click the buon next to this ﬁeld to view the endpoint to
which the virtual service is deployed, if applicable.

Deployed Status

(Read-only ﬁeld.) Indicates whether the service is Deployed,
Undeployed or Not Deployed (which is the initial status before
you deploy the service). To deploy or undeploy a service, see
"Deploying Virtual Services and Connector Virtual Services"
on page 197.

Resource

Click the buon next to this ﬁeld to view the REST resource
that the service will access. For details, see "Creating a New
Virtual Service (REST)" on page 125.
Note: To add a REST resource to the service, right-click the
service name and click Attach Resource.

Managing a Virtual Service (REST)
You can rename, delete, deploy or undeploy a virtual service, and aach a REST
resource to it.
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To manage a virtual service (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project.
3. Right-click the virtual service name and choose one of the following tasks from the context
menu:
Option

Description

Rename

Use this option to assign a new name to the service. The
service must be undeployed before you can rename it (check
the Deployed Status ﬁeld in the Advanced page of the service's
Properties view).
Unlike native services, the names of virtual services cannot
contain spaces or special characters except _ (underscore)
and - (hyphen). Consequently, if you adopt a convention that
involves using the name of the service as part of the virtual
service name, then the names of the services themselves must
not contain characters that are invalid in virtual service names.

Delete

Deletes the virtual service from CloudStreams.

Attach
Resource

Use this option to aach a REST resource to an existing virtual
service. The new resource will override the old one.

Deploy

Deploys the virtual service to a CloudStreams server target.
For more information, see "Deploying Virtual Services and
Connector Virtual Services" on page 197.

Undeploy

Undeploys the virtual service from a CloudStreams server
target.

4. To change the list of policies that apply to the virtual service, see "Modifying Policies" on
page 170.

The "In Sequence" Step (REST)
You conﬁgure the service's "In Sequence" step to manipulate the request messages. This
step can include the following sub-steps:
The "Entry Step" (required), which speciﬁes the protocol (HTTP or HTTPS) of the
requests that the virtual service will accept, and the HTTP methods that the virtual
service should be allowed to perform on the REST resource.
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The "Transform" step (optional), which performs an XSLT message transformation
on the request message before it is submied to the native service.
The "Invoke IS Service" step (optional), which pre-processes the request message
before it is submied to the native service.
The "Routing Rule" step (required), which speciﬁes how the virtual service will route
the requests to the native service endpoint(s). There are four ways to route HTTP or
HTTPS requests:
"Straight Through" routing (to route requests directly to the native service
endpoint).
"Context-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
according to context-based routing rules).
"Content-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
based on speciﬁc values that appear in the request message).
"Load Balancing" routing (to distribute requests among multiple endpoints).

The "Entry Step" (REST)
The Entry Step (required) speciﬁes the protocol (HTTP or HTTPS) over which the virtual
service will accept requests, and the HTTP methods (GET, POST, PUT, DELETE) that the
virtual service should be allowed to perform on a REST resource.
This step allows you to bridge protocols between the consuming application and the
native service. For example, suppose you have a native service that is exposed over
HTTPS and a consuming application that submits SOAP requests over HTTP. In this
situation, you can conﬁgure the virtual service's Entry Step to accept HTTP requests and
conﬁgure its Routing Rule step to route the request to the Web service using HTTPS.
To configure the "Entry Step" (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.
The virtual service editor displays the three main processing steps: In Sequence, Out
Sequence and Error Sequence.

3. In the virtual service editor, expand In Sequence.
By default, the In Sequence step contains the sub-steps Entry Step and Routing Rule.
(You can add the optional Transform and Invoke IS Service steps, as described later.)

4. Click Entry Step and complete the following fields in the General page in the Properties view.
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Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Entry Step.

HTTP Methods

The HTTP methods that the virtual service should be allowed
to perform on the REST resource (GET, POST, PUT, DELETE).
It is important to specify all the HTTP methods that are
supported for the virtual service. For example, if the virtual
service is deployed to CloudStreams and only the GET
method was selected in the virtual service deﬁnition, then
CloudStreamswill only permit GET invocations. A POST
request will be rejected with a return of statusCode 405 even
if the native service happens to support POSTs. It is also
important for the native service to return the correct ContentType header with its responses.
At run time, CloudStreams determines the type of a
request message based on the message's HTTP method
and its Content-Type. See "HTTP Method/Content-Type
Combinations" on page 159.

Protocol

The protocol (HTTP or HTTPS) over which the virtual service
will accept requests. To specify HTTPS, select both HTTP and
SSL. CloudStreams supports HTTP v1.1 only.

The "Transform" Step (Inbound, REST)
The optional "Transform" step speciﬁes how the request message is to be transformed
before it is submied to the native service.
As long as a consumer sends a REST request with the proper Content-Type (see "HTTP
Method/Content-Type Combinations" on page 159) and as long as the HTTP method
and endpoint URI are in the expected form, then CloudStreams can determine the
correct service and operation; in this case, no message transformation is required.
However, in some cases a virtual REST service might need to transform XML messages.
For example, you might need to accommodate diﬀerences between the message content
that a consuming application is capable of submiing and the message content that
a native service expects. For example, if the consuming application submits an order
record using a slightly diﬀerent structure than the structure expected by the native
service, you can use the Transform step to transform the record submied by the
consuming application to the structure required by the Web service.
In this case, you would need to create two Transform steps:
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One in the "In Sequence" step, to transform the request messages into the format
required by the native service, before CloudStreams sends the requests to the
native services. To do this, you pass the message to an XSLT transformation ﬁle.
(Additionally in this case, the transformation is required if the virtual service has a
schema validation policy that validates the requests.)
One in the "Out Sequence" step, to transform the native service's response messages
into the format required by the consumer applications, before CloudStreams returns
the responses to the consumer applications.
To add the "Transform" step (inbound, REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Right-click In Sequence and select Transform.
The Transform step is added under the Entry Step. You cannot change the order of
the steps.

4. Click Transform and complete the following fields in the General page in the Properties view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only.) Transform.

XSLT File

The XSLT ﬁle to transform the request message before it is
submied to the native service. Click Browse to select a ﬁle
from your ﬁle system and click Save.
The XSL ﬁle uploaded by the user should not contain the
XML declaration in it (xml version="1.0" encoding="UTF-8").
This is because when the virtual service is deployed to
CloudStreams, CloudStreams embeds the XSL ﬁle in the
virtual service deﬁnition (VSD), and since the VSD itself is in
XML format, there cannot be an XML declaration line in the
middle of it. This can lead to unexpected deployment issues
which can be avoided by making sure the XSL ﬁle does not
contain the declaration line.
Note: If you make changes to the XSLT ﬁle in the future, you
must re-deploy the virtual service.

5. To create an additional Transform step, right-click In Sequence and select Transform again.
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6. To delete a Transform step, right-click Transform and click Delete Step.

The "Invoke IS Service" Step (Inbound, REST)
This optional step invokes a user-deﬁned Integration Server ﬂow service. You can
invoke an IS service in:
The "In Sequence" step, to pre-process the request message before it is submied to
the native service.
The "Out Sequence" step, to pre-process the response message from the native
service before it is returned to the consuming application.
The IS service you invoke must be running on the same Integration Server as
CloudStreams. It can call out a C++ or Java or .NET function. It can also call other IS
services to manipulate the SOAP message.
You can use predeﬁned or custom context variables in an IS service. For more
information, see "Using Context Variables in IS Services" on page 99.
You can create multiple "Invoke IS Service" steps.
To add the "Invoke IS Service" step (inbound, REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Right-click In Sequence and click Invoke IS Service.
The "Invoke IS Service" step is added under the Entry Step (and under a Transform
step, if one exists). You cannot change the order of the steps.

4. Click Invoke IS Service and complete the following fields in the General page in the
Properties view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only.) Invoke IS Service.

Service

Specify the IS service to pre-process the request message
before it is submied to the native service.

5. When you define the IS service, the Pipeline In section of the flow should have the following
input variables:
proxy.name:

This is the name of the virtual service.
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SOAPEnvelope:

This is of the Java type org.apache.axiom.soap.SOAPEnvelope.

MessageContext:

CloudStreams will automatically place a MessageContext
variable into the pipeline before executing the IS service call. MessageContext is of
the Java type org.apache.axis2.context.MessageContext.
Integration Server users can use the Axis2 MessageContext object to manipulate
the incoming SOAP request. The Integration Server provides built-in services
(the pub.soap.* services) to work with the MessageContext object to get/set/modify
the SOAP body, header, properties, etc. Integration Server users should use
these services to extract the information they need from the MessageContext to
build the necessary business logic. Users do not need to understand Axis2 or
Axiom (the xml object model based on StAX) to work with the SOAP request,
because if they are familiar with the Integration Server pub.soap.* services, they
can accomplish most of the tasks. For more information about these related
Integration Server services, see the webMethods Integration Server Built-In Services
Reference.

6. To create an additional "Invoke IS Service" step, right-click In Sequence and select Invoke IS
Service again.

7. To delete an "Invoke IS Service" step, right-click Invoke IS Service and click Delete.

The "Routing Rule" Step (REST)
The Routing Rule step is required. You can choose one of the following protocols in your
Routing Rule step for routing the requests:
"Straight Through" routing (to route requests directly to the native service endpoint).
"Context-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
according to context-based routing rules).
"Content-Based" routing (to route speciﬁc types of messages to speciﬁc endpoints
based on speciﬁc values that appear in the request message).
"Load Balancing" routing (to distribute requests among multiple endpoints).
The "Straight Through" Routing Rule Step (REST)
When you select the "Straight Through" routing protocol, the virtual service will route
the requests directly to the native service endpoint you specify. You may specify how to
authenticate requests (as with all routing protocols).
To configure the "Routing Rule" step for "Straight Through" routing (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Expand In Sequence.
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4. Click Routing Rule and complete the following fields in the General page in the Properties
view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Straight Through.

Default To

The URL of the service to which to route the request.
Click the icon next to this ﬁeld and complete the Conﬁgure
Endpoint Properties dialog box as follows:
HTTP Properties
Connection Timeout: The time interval (in seconds) after
which a connection aempt will timeout. If a value is not
speciﬁed (or if the value 0 is speciﬁed), CloudStreams will
use the default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which
a socket read aempt will timeout. If a value is not
speciﬁed (or if the value 0 is speciﬁed), the default is 30
seconds.
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

HTTP Method

The HTTP method to pass to the native service.
Typically you want to pass each request to the native service
with the same HTTP method that is contained in the request.

Administering webMethods CloudStreams Version 9.6

136

M

Odd Header

Option

Description
For example, if a request contains a GET method, you allow
the GET method to be passed to the native service. In this
case, select the value CUSTOM, which is a context variable that
contains the HTTP method that is contained in the request.
However, in other cases you might want to change the HTTP
method of a request to a diﬀerent HTTP method. In this case,
you can specify the diﬀerent method explicitly (by selecting
the GET, POST, PUT or DELETE value), or you can specify the
diﬀerent method dynamically on a per-request basis. If you
want to specify the method dynamically, select the CUSTOM
option and then write an IS service to set the value of the
context variable. For more information, see "Changing the
HTTP Method of a REST Virtual Service" on page 160.

Use credentials
from incoming
request

This is the default HTTP Authentication option. Authenticates
requests based on the credentials speciﬁed in the HTTP
header. CloudStreams passes the Authorization header
present in the original client request to the native service.

Use specific
credentials

Authenticates requests according to the values you specify in
the User and Password ﬁelds, and optionally the Domain ﬁeld.

Invoke service
anonymously

Does not authenticate requests.

Use existing
HTTP Headers

Use the HTTP headers that are contained in the requests.

Customize
HTTP Headers

Use the HTTP headers that you specify in the Name and Value
columns on this page. If you need to specify multiple headers,
use the plus buon to add rows.

The "Context-Based" Routing Rule Step (REST)
If you have a native service that is hosted at two or more endpoints, you can use the
Context-Based protocol to route speciﬁc types of messages to speciﬁc endpoints.
The requests are routed according to the context-based routing rules you create. A
routing rule speciﬁes where the requests should be routed, and the criteria by which
they should be routed there. For example, requests can be routed according to certain
consumers, certain dates/times, or according to requests that exceed/fall below a
speciﬁed metric (Total Count, Success Count, Fault Count, etc.). You can create one or
more rules. For example, you might use this capability to route requests from certain
high-priority consumers to endpoints on a fast machine.
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To configure the "Routing Rule" step for "Context-Based" routing (REST)
Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.
In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.
Expand In Sequence.
Click Routing Rule and complete the following fields in the General page in the Properties
view.
Option

Description

Name

You can optionally change the step name. There are no naming
convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Context-Based.

Rule Name

Assign a name for the rule.
Then, click the icon next to this ﬁeld and choose one of the
following variables in the Conﬁgure Routing Rule dialog
box that appears: Time, IP Address (IPv4 or IPv6 format), Date,
Consumer, Predefined Context Variable or Custom Context Variable
(see "Using Context Variables in IS Services" on page 99).
Then specify a value and operator appropriate for your chosen
variable. If you need to specify multiple variables, use the plus
buon at the end of the row to add rows.
Note: If you select the value Custom Context Variable, you must
write an IS service to get/set the custom context variable,
and then invoke that service in an Invoke IS Service step.
CloudStreams provides an API to get/set custom context
variables. For more information, see "The API for Context
Variables" on page 104. CloudStreams automatically declares
any custom context variables you have speciﬁed; there is no
need for you to declare them.

Route To

Specify the URL of the native service to route the request to, if
the rule criteria are met.

Administering webMethods CloudStreams Version 9.6

138

M

Odd Header

Option

Description
Then, click the icon next to this ﬁeld and complete the
Conﬁgure Endpoint Properties dialog box as follows:
HTTP Properties
Connection Timeout: The time interval (in seconds) after
which a connection aempt will timeout. If a value is not
speciﬁed (or if the value 0 is speciﬁed), CloudStreams will
use the default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which
a socket read aempt will timeout. If a value is not
speciﬁed (or if the value 0 is speciﬁed), the default is 30
seconds.
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

HTTP Method

The HTTP method to pass to the rule.

Default To

Enter a native service endpoint to route the request to in case
all routing rules evaluate to False. Then, click the icon next
to this ﬁeld and complete the Conﬁgure Endpoint Properties
dialog box, as described for the Route To ﬁeld above.

HTTP Method

The HTTP method to pass to the native service.
Typically you want to pass each request to the native service
with the same HTTP method that is contained in the request.
For example, if a request contains a GET method, you allow
the GET method to be passed to the native service. In this
case, select the value CUSTOM, which is a context variable that
contains the HTTP method that is contained in the request.
However, in other cases you might want to change the HTTP
method of a request to a diﬀerent HTTP method. In this case,
you can specify the diﬀerent method explicitly (by selecting
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Option

Description
the GET, POST, PUT or DELETE value), or you can specify the
diﬀerent method dynamically on a per-request basis. If you
want to specify the method dynamically, select the CUSTOM
option and then write an IS service to set the value of the
context variable. For more information, see "Changing the
HTTP Method of a REST Virtual Service" on page 160.

Use credentials
from incoming
request

Default. Authenticates requests based on the credentials
speciﬁed in the HTTP header. CloudStreams passes the
Authorization header present in the original client request to
the native service.

Use specific
credentials

Authenticates requests according to the values you specify in
the User, Password and Domain ﬁelds.

Invoke service
anonymously

Does not authenticate requests.

Use existing
HTTP Headers

Use the HTTP headers that are contained in the requests.

Customize
HTTP Headers

Use the HTTP headers that you specify in the Name and Value
columns on this page. If you need to specify multiple headers,
use the plus buon to add rows.

The "Content-Based" Routing Step (REST)
If you have a native service that is hosted at two or more endpoints, you can use the
Content-Based routing protocol to route speciﬁc types of messages to speciﬁc endpoints
based on speciﬁc values that appear in the request message.
You might use this capability, for example, to determine which operation the consuming
application has requested, and route requests for complex operations to an endpoint on
a fast machine.
The requests are routed according to the content-based routing rules you create. That
is, they are routed based on the successful evaluation of one or more XPath expressions
that are constructed utilizing the content of the request payload. For example, a routing
rule might allow requests for half of the methods of a particular service to be routed to
Service A, and the remaining methods to be routed to Service B.
To configure the "Routing Rule" step for "Content-Based" routing (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.
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2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.

3. Expand In Sequence.
4. Click Routing Rule and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name. There are no naming
convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Content-Based.

Rule Name

Assign a name to the rule.

XPath

Create an XPath expression as follows:
a. Click the icon next to this ﬁeld to display the XPath Editor.
b. In the XPath Editor that appears, view the Namespace tab,
which displays all predeﬁned namespaces. If you want to
add custom namespaces, click Add Custom Namespace/prefix,
specify a name and value for the namespace, and click OK.
To add additional rows, use the plus buon at the end of the
row to add them.
c. In the XPath Editor's Nodes tab, expand the namespace's
node, choose the method you want for the XPath expression,
and click OK.
d. In the XPath Editor's Evaluator tab, evaluate the XPath
expression by specifying an argument in the XPath Expression
ﬁeld, and clicking Evaluate.
The true/false result of the evaluation is displayed in the
Result ﬁeld.
To specify additional XPath expressions, use the plus buon at
the end of the row to add them.
Note: Currently, you cannot deﬁne namespaces URIs. So the
XPath expressions should not include a namespace preﬁx.
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Description

Route To

Specify where to route the request if the rule criteria are met.
Specify either the URL of a native service or a connection pool
name.
Then, click the icon next to this ﬁeld and complete the
Conﬁgure Endpoint Properties dialog box as follows:
Connection Timeout: The time interval (in seconds) after which
a connection aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), CloudStreams will use the
default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which a
socket read aempt will timeout. If a value is not speciﬁed
(or if the value 0 is speciﬁed), the default is 30 seconds.
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

HTTP Method

The HTTP method to pass to the rule.

Default To

Enter a native service endpoint to route the request to in case
all routing rules evaluate to False. Then, click the icon next
to this ﬁeld and complete the Conﬁgure Endpoint Properties
dialog box, as described for the Route To ﬁeld above.

HTTP Method

The HTTP method to pass to the native service.
Typically you want to pass each request to the native service
with the same HTTP method that is contained in the request.
For example, if a request contains a GET method, you allow
the GET method to be passed to the native service. In this
case, select the value CUSTOM, which is a context variable that
contains the HTTP method that is contained in the request.
However, in other cases you might want to change the HTTP
method of a request to a diﬀerent HTTP method. In this case,
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Description
you can specify the diﬀerent method explicitly (by selecting
the GET, POST, PUT or DELETE value), or you can specify the
diﬀerent method dynamically on a per-request basis. If you
want to specify the method dynamically, select the CUSTOM
option and then write an IS service to set the value of the
context variable. For more information, see "Changing the
HTTP Method of a REST Virtual Service" on page 160.

Use credentials
from incoming
request

Default. Authenticates requests based on the credentials
speciﬁed in the HTTP header. CloudStreams passes the
Authorization header present in the original client request to
the native service.

Use specific
credentials

Authenticates requests according to the values you specify in
the User, Password and Domain ﬁelds.

Invoke service
anonymously

Does not authenticate requests.

Use existing
HTTP Headers

Use the HTTP headers that are contained in the requests.

Customize
HTTP Headers

Use the HTTP headers that you specify in the Name and Value
columns on this page. If you need to specify multiple headers,
use the plus buon to add rows.

The "Load Balancing" Routing Rule Step (REST)
If you have a Web service that is hosted at two or more endpoints, you can use the Load
Balancing option to distribute requests among the endpoints.
The requests are intelligently routed based on the "round-robin" execution strategy. The
load for a service is balanced by directing requests to two or more services in a pool,
until the optimum level is achieved. The application routes requests to services in the
pool sequentially, starting from the ﬁrst to the last service, without considering the
individual performance of the services. After the requests have been forwarded to all the
services in the pool, the ﬁrst service is chosen for the next loop of forwarding.
Load-balanced endpoints also have automatic Failover capability. If a load-balanced
endpoint is unavailable (for example, if a connection is refused), then that endpoint is
marked as "down" for the number of seconds you specify in the Suspend Interval ﬁeld
(during which the endpoint will not be used for sending the request), and the next
conﬁgured endpoint is tried. If all the conﬁgured load-balanced endpoints are down,
then a SOAP fault is sent back to the client. After the suspension period expires, each
endpoint marked will be available again to send the request.
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To configure the "Routing Rule" step for "Load Balancing" routing (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.

3. Expand In Sequence.
4. Click Routing Rule and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) HTTP.

Routing Type

Select Load Balancing.

Route To

The URLs of two or more services in a pool to which the
requests will be routed. The application routes the requests to
services in the pool sequentially, starting from the ﬁrst to the
last service without considering the individual performance of
the services. After the requests have been forwarded to all the
services in the pool, the ﬁrst service is chosen for the next loop
of forwarding.
To specify additional services, use the plus buon next to the
ﬁeld to add rows.
Then, click the icon next to this ﬁeld and complete the
Conﬁgure Endpoint Properties dialog box as follows. These
properties will apply to all the endpoints.
HTTP Properties
Connection Timeout: The time interval (in seconds) after
which a connection aempt will timeout. If a value is not
speciﬁed (or if the value 0 is speciﬁed), CloudStreams will
use the default value speciﬁed in Integration Server.
Read Timeout: The time interval (in seconds) after which
a socket read aempt will timeout. If a value is not
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speciﬁed (or if the value 0 is speciﬁed), the default is 30
seconds.
SSL Options: Optional. To enable SSL client authentication
for the endpoint, you must specify values for both the Client
Certificate Alias ﬁeld and the IS Keystore Alias ﬁeld. If you
specify a value for only one of these ﬁelds, a deployment
error will occur. You may leave both ﬁelds blank.
Client Certificate Alias: The client's private key to be used
for performing SSL client authentication.
IS Keystore Alias: The keystore alias of the instance of
Integration Server on which CloudStreams is running.
This value (along with the value of Client Certificate Alias)
will be used for performing SSL client authentication.

Suspend
Interval

A numeric timeout value (in seconds) for a failed endpoint.
Default: 30. When this timeout value expires, the system
routes the execution of the virtual service to the next
consecutive Web service endpoint speciﬁed in the Route To
ﬁeld.

HTTP Method

The HTTP method to pass to the native service.
Typically you want to pass each request to the native service
with the same HTTP method that is contained in the request.
For example, if a request contains a GET method, you allow
the GET method to be passed to the native service. In this
case, select the value CUSTOM, which is a context variable that
contains the HTTP method that is contained in the request.
However, in other cases you might want to change the HTTP
method of a request to a diﬀerent HTTP method. In this case,
you can specify the diﬀerent method explicitly (by selecting
the GET, POST, PUT or DELETE value), or you can specify the
diﬀerent method dynamically on a per-request basis. If you
want to specify the method dynamically, select the CUSTOM
option and then write an IS service to set the value of the
context variable. For more information, see "Changing the
HTTP Method of a REST Virtual Service" on page 160.

Use Credentials
from Incoming
Request

This is the default HTTP Authentication option. Authenticates
requests based on the credentials speciﬁed in the HTTP
header. CloudStreams passes the Authorization header
present in the original client request to the native service.
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Description

Use Specific
Credentials

Authenticates requests according to the values you specify in
the User, Password and Domain ﬁelds.

Invoke Service
Anonymously

Does not authenticate requests.

Use Existing
HTTP Headers

Use the HTTP headers that are contained in the requests.

Customize
HTTP Headers

Use the HTTP headers that you specify in the Name and Value
columns on the tab. If you need to specify multiple headers,
use the plus buon to add rows.

The "Out Sequence" Step (REST)
You conﬁgure the service's "Out Sequence" step (optional) to manipulate the
response messages from the native service before they are returned to the consuming
applications. This step can include:
The "Transform" step (optional), which invokes an XSLT transformation ﬁle to
transform the SOAP response payloads from XML format to the format required by
the consumer.
The "Invoke IS Service" step (optional), which processes the response message from
the native service provider before it is returned to the consuming application.

The "Transform" Step (Outbound, REST)
Add this step if you need to invoke an XSLT transformation ﬁle to transform the native
service's response messages into the format required by the consumer applications,
before CloudStreams returns the responses to the consumer applications. For more
information about when to use the Transform step, see "The Transform Step (Inbound,
REST)" on page 132.
To add the "Transform" step (outbound, REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the virtual service name.

3. In the virtual service editor, expand Out Sequence.
4. To add the Transform step, right-click Out Sequence and select Transform.
The Transform step is added under the Out Sequence step.
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5. Click Transform and complete the following fields in the General page in the Properties view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

XSLT File

The XSLT ﬁle to transform the response message before it is
returned to the consuming application. Click Browse to select a
ﬁle from your ﬁle system and click Save.
The XSL ﬁle uploaded by the user should not contain the
XML declaration in it (xml version="1.0" encoding="UTF-8").
This is because when the virtual service is deployed to
CloudStreams, CloudStreams embeds the XSL ﬁle in the
virtual service deﬁnition (VSD), and since the VSD itself is in
XML format, there cannot be an XML declaration line in the
middle of it. This can lead to unexpected deployment issues
which can be avoided by making sure the XSL ﬁle does not
contain the declaration line.
Note: If you make changes to the XSLT ﬁle in the future, you
must re-deploy the virtual service.

6. To create an additional "Transform" step, right-click In Sequence and select Transform from
the context menu.

7. To delete a "Transform" step, right-click Transform and click Delete.

The "Invoke IS Service" Step (Outbound, REST)
This optional step invokes a user-deﬁned Integration Server ﬂow service. You can
invoke an IS service in the service's "Out Sequence" step to pre-process the response
message from the native service before it is returned to the consuming application. For
more information about IS services, see "The Invoke IS Service Step (Inbound, REST)" on
page 134.
To add the "Invoke IS Service" step (outbound, REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Right-click Out Sequence and click Invoke IS Service.
The Invoke IS Service step is added to the Out Sequence step.

4. In the Properties view, complete the following fields.
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Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Invoke IS Service.

Service

Specify the IS Service to pre-process the response message
before it is returned to the consuming application.

5. When you define the IS service, the Pipeline In section of the flow should have the following
input variables:
proxy.name:

This is the name of the virtual service.

SOAPEnvelope:

This is of the Java type org.apache.axiom.soap.SOAPEnvelope.

MessageContext:

CloudStreams will automatically place a MessageContext
variable into the pipeline before executing the IS service call. MessageContext is of
the Java type org.apache.axis2.context.MessageContext.
Integration Server users can use the Axis2 MessageContext object to manipulate
the incoming SOAP request. The Integration Server provides built-in services
(the pub.soap.* services) to work with the MessageContext object to get/set/modify
the SOAP body, header, properties, etc. Integration Server users should use
these services to extract the information they need from the MessageContext to
build the necessary business logic. Users do not need to understand Axis2 or
Axiom (the xml object model based on StAX) to work with the SOAP request,
because if they are familiar with the Integration Server pub.soap.* services, they
can accomplish most of the tasks. For more information about these related
Integration Server services, see the webMethods Integration Server Built-In Services
Reference.

6. To create an additional Invoke IS Service step, right-click In Sequence and click IS Service
again.

7. To delete an Invoke IS Service step, right-click Invoke IS Service and click Delete.

The "Error Sequence" Step (REST)
CloudStreams returns a default fault response to the consuming application, which you
can customize with context variables. This fault response is used for faults returned
by the native service provider as well as faults returned by internal CloudStreams
exceptions, such as policy violation errors, connection timeouts, etc. In addition, you
can:
Choose whether or not to send the native service provider's service fault content, or
just send the response message.
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Invoke IS services to pre-process or post-process the error messages.
You use this step to conﬁgure error messaging for each virtual service individually. If
you want to conﬁgure global error responses for all virtual services, set the Service Fault
Conﬁguration options, which are located in the Integration Server Administrator (go
to Solutions > CloudStreams > Administration > Service Fault Configuration). For details, see
"Seing the Service Fault Conﬁguration Options" on page 41.
To configure the "Error Sequence" step (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name.

3. Expand Error Sequence.
4. Click Error Messaging and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Error Messaging.

Error Message

Select one or both of the following options:
Custom Failure Response Message: When you select this option,
CloudStreams returns the following fault response to the
consuming application:
CloudStreams encountered an error:$ERROR_MESSAGE while
executing operation:$OPERATION service:$SERVICE at time:
$TIME on date:$DATE. The client ip was:$CLIENT_IP.
The current user:$USER. The consumer application:
$CONSUMER_APPLICATION".

This fault response is returned in both of the following cases:
When a fault is returned by the native service provider.
In this case, the $ERROR_MESSAGE variable in the fault response
will contain the message produced by the provider's
exception that caused the error. This is equivalent to the
getMessage call on the Java Exception. For REST service
calls, the message is returned inside an </Exception> tag.
If the response is XML, the message is returned inside
<Exception>'custom message'</Exception>. If the response
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Option

Description
is JSON, it will be returned inside {"Exception":"Invalid
response"}. CloudStreams discards the native service
provider's fault and does not return this content to the web
service caller since it could be considered a security issue,
especially if the native provider is returning a stack trace
with its response.
When a fault is returned by internal CloudStreams
exceptions (policy violation errors, cloud connection errors
and cloud connector service errors).
In this case, the $ERROR_MESSAGE variable will contain errors
generated by CloudStreams.
The default fault response contains predeﬁned fault handler
variables ($ERROR_MESSAGE, $OPERATION, etc.), which are
described in "The Fault Handler Variables" on page 87.
You can customize the default fault response using the
following substitution variables, where CloudStreams replaces
the variable reference with the real content at run time:
The predeﬁned context variables listed in "The Predeﬁned
Context Variables" on page 100.
Custom context variables that you declare using the
CloudStreams API (see "The API for Context Variables" on
page 104).
Note: If you want to reference a custom context variable that you
have already deﬁned in a context-based routing rule (as opposed
to one you have declared using CloudStreams API for context
variables), then you must add the preﬁx $mx to the variable name
in order to reference the variable. For example, if you deﬁned
the variable TAXID, you would reference it as $mx:TAXID.
Native Provider Fault: When you select this option,
CloudStreams sends the native service provider's service fault
content, if one is available. CloudStreams will send whatever
content it received from the native service provider.
If you select this option, the Custom Failure Response Message
is ignored when a fault is returned by the native service
provider. (Faults returned by internal CloudStreams
exceptions will still be handled by the Custom Failure Response
Message option.)
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Option

Description

Processing
Method

Optionally select either of the following:
Pre-Processing: Select this option if you want to invoke an IS
service to manipulate the response message before the Error
Sequence step is invoked. The IS service will have access
to the response message context (the axis2 MessageContext
instance) before it is updated with the custom error message.
For example, you might want to send emails or perform
custom alerts based on the response payload. For more
information about IS services, see "The Invoke IS Service Step
(Inbound, REST)" on page 134.
Post-Processing: Select this option if you want to invoke an
IS service to manipulate the service fault after the Error
Sequence step is invoked. The IS service will have access to
the entire service fault and the custom error message. You
can make further changes to the fault message structure, if
needed. For more information about IS services, see "The
Invoke IS Service Step (Inbound, REST)" on page 134.

Creating a New Connector Virtual Service (REST)
A connector virtual service will:
Handle the provider's response.
Log the requests/responses.
CloudStreams provides a default connector virtual service for each metadata
handler: the service WmCloudStreams.RestVS (for the REST handler) and the service
WmCloudStreams.SoapVS (for the SOAP handler). The default services are located in
the sample CloudStreams Governance project in the WmCloudStreams package. You
cannot modify these default services.
Each default connector virtual service has a default policy (named Logging Policy),
which logs all request/response payloads to a database. You cannot modify the default
policy. Alternatively, you can create additional connector virtual services with custom
policies. If you create a connector virtual service with a custom policy, you can only
include the actions in the "Monitoring" or "Additional" action categories; you cannot
include the "WS-SecurityPolicy 1.2" actions. For example, you might want to create
a custom policy that monitors run-time performance, customizes how the service
invocations are logged, validates response messages against an XML schema, or
optimizes server traﬃc. For complete details, see the chapter "Policies" on page 165.
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To create a new connector virtual service (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, right-click the CloudStreams Governance project and
click New > Connector Virtual Service (or expand the project, right-click the Connector Virtual
Services folder and click New Connector Virtual Service).

3. In the New Connector Virtual Service wizard, complete the following fields and click Finish.
Option

Description

CloudStreams
Governance
Project

Click Browse and select a CloudStreams Governance project in
which to create the connector virtual service.

Name

Assign a name for the service. Unlike native services,
the names of virtual services cannot contain spaces or
special characters except _ (underscore) and - (hyphen).
Consequently, if you adopt a convention that involves using
the name of the service as part of the virtual service name,
then the names of the services themselves must not contain
characters that are invalid in virtual service names.
Note: If you want to change the service name after it has been
created, right-click the service name in the Connector Virtual
Services folder and select Rename.

Version

(Read-only ﬁeld.) Currently not supported.

Service Type

(Read-only ﬁeld.) REST.

Description

Optional. A description for the service. This description
appears when a user displays a list of services in the user
interface.

The new connector virtual service is added to the CloudStreams Governance project,
in the Connector Virtual Services folder.

The Properties of a Connector Virtual Service (REST)
To view the properties of a connector virtual service (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.
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2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the virtual service name. (If the Properties view is not already open, click Window >
Show View > Other > General > Properties.)

3. The General page in the Properties view displays the following properties:
Option

Description

Name

(Read-only ﬁeld.) The service name. You can change the
service name at any time by right-clicking the name in the
Virtual Services folder and clicking Rename.

Service Type

(Read-only ﬁeld.) REST.

Created/Last
Modified

(Read-only ﬁeld.) The service's creation/modiﬁcation
timestamps.

Target
Namespace

(Read-only ﬁeld.) The value is derived from the
targetNamespace aributes of the WSDL's deﬁnition element.

Namespaces

Click the buon next to this ﬁeld to view the service's available
namespaces (such as wsdl, xsd, etc.).

Version

(Read-only ﬁeld.) Currently not supported.

WSDL URL

(Read-only ﬁeld.) The URL of the service's WSDL.

Description

You can change the service description.

4. View additional properties in the Advanced page.
Option

Description

Name

(Read-only ﬁeld.) The service name.

Type

(Read-only ﬁeld.) The type of the service (REST).

Target
Namespace

(Read-only ﬁeld.) The value derived from the targetNamespace
aributes of the WSDL's deﬁnition element.

WSDL URL

Click this URL to display the contents of the service's abstract
WSDL.
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Option

Description

Namespaces

Click the buon next to this ﬁeld to view the service's available
namespaces (such as wsdl, xsd, etc.).

Version

(Read-only ﬁeld.) Currently not supported.

Description

(Read-only ﬁeld.) The service description.

VSD

Click the buon next to this ﬁeld to view the service's "virtual
service deﬁnition" (VSD). This buon is disabled until you
deploy the connector virtual service to a CloudStreams server.
When you deploy the connector virtual service to a
CloudStreams server, CloudStreams generates an XML
document called a virtual service deﬁnition (VSD). The VSD
deﬁnes the connector virtual service for CloudStreams, and
contains all the resources required to deploy the connector
virtual service to a CloudStreams server, including the policy
that applies to the service. You cannot edit the VSD.
Note: If multiple policies apply to the service, CloudStreams
combines all those policies into a single policy known as the
eﬀective policy. The eﬀective policy is a simple UNION of the
run-time actions speciﬁed in all policies that apply to a service.
To create the eﬀective policy, CloudStreams evaluates the
combined list of actions from all policies, using a set of internal
rules known as Policy Conﬂict Resolution rules. For details, see
"Policy Conﬂict Resolution Rules" on page 201.

Applicable
Policies

Click the buon next to this ﬁeld to view a list of the active
policies that apply to this service. Any inactive policy that
applies to the service is not listed.

Endpoint

(Read-only ﬁeld). The endpoint is resolved when the
connector service is conﬁgured and the user selects an enabled
managed connection pool.

Deployed Status

(Read-only ﬁeld.) Indicates whether the service is Deployed,
Undeployed or Not Deployed (which is the initial status before
you deploy the service). To deploy or undeploy a service, see
"Deploying Virtual Services and Connector Virtual Services"
on page 197.

Resource

Click the buon next to this ﬁeld to view the REST resources
that the service will access.

Administering webMethods CloudStreams Version 9.6

154

M

Odd Header

Managing a Connector Virtual Service (REST)
You can rename, delete, deploy or undeploy a connector virtual service, and change the
list of policies that apply to it.
To manage a connector virtual service (REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project.
3. Right-click the connector virtual service name and choose any of the following tasks from the
context menu:
Option

Description

Rename

Use this option to assign a new name to the service. The
service must be undeployed before you can rename it (check
the Deployed Status ﬁeld in the Advanced page of the service's
Properties view).
Unlike native services, the names of connector virtual
services cannot contain spaces or special characters except
_ (underscore) and - (hyphen). Consequently, if you adopt
a convention that involves using the name of the service as
part of the connector virtual service name, then the names of
the services themselves must not contain characters that are
invalid in connector virtual service names.

Delete

Deletes the connector virtual service from CloudStreams.

Deploy

Deploys the connector virtual service to a CloudStreams server
target. For more information, see "Deploying Virtual Services
and Connector Virtual Services" on page 197.

Undeploy

Undeploys the connector virtual service from a CloudStreams
server target.

4. To change the list of policies that apply to the connector virtual service, see "Modifying
Policies" on page 170.

The "In Sequence" Step (Connector Virtual Service, REST)
The "In Sequence" step can contain the following sub-steps:
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The "Entry Step" (required), which speciﬁes the protocol of the requests that the
connector virtual service will accept, and the HTTP methods that the connector
virtual service should be allowed to perform on a REST resource.
The "Routing Rule" step (required), which speciﬁes how the connector virtual service
will route the service requests to the native service endpoint.
The "Invoke IS Service" step (optional), which pre-processes the request message
before it is submied to the native service.

The "Entry Step" (Connector Virtual Service, REST)
This step speciﬁes the protocol of the requests that the connector virtual service will
accept, and the HTTP methods that the virtual services are allowed to perform on the
REST resources.
To edit the "Entry Step" (connector virtual service, REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the connector virtual service name.
The virtual service editor displays the three main processing steps: In Sequence, Out
Sequence and Error Sequence.

3. Expand In Sequence.
By default, the In Sequence step contains the sub-steps Entry Step and Routing Rule.
(You can add the optional Invoke IS Service step, as described later.)

4. Click Entry Step and complete the following fields in the General page in the Properties view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Entry Step.

Protocol

(Read-only ﬁeld.) The protocol of the requests that the
connector virtual service will accept. The value Local means
that the service can only be called from Cloud Connector
Services.

HTTP Method

The HTTP methods that the virtual services should be allowed
to perform on the REST resources (GET, POST, PUT, DELETE).
It is important to specify all the HTTP methods that are
supported for the virtual services. For example, if a virtual
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Option

Description
service is deployed to CloudStreams and only the GET method
was selected here, then CloudStreams will only permit GET
invocations. A POST request will be rejected with a return of
statusCode 405 even if the native service happens to support
POSTs. It is also important for the native service to return the
correct Content-Type header with its responses.
At run time, CloudStreams determines the type of a request
message based on the message's HTTP method and its
Content-Type. For a list of valid HTTP method/ContentType combinations, see "HTTP Method/Content-Type
Combinations" on page 159.

The "Routing Rule" Step (Connector Virtual Service, REST)
This step speciﬁes how the connector virtual service will route the requests to the native
service endpoint. You cannot modify this step, except for its name.
To edit the "Routing Rule" step (connector virtual service, REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
double-click the connector virtual service name.

3. In the virtual service editor, expand In Sequence.
4. Click Routing Rule and complete the following fields in the General page in the Properties
view.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.

Type

(Read-only ﬁeld.) Routing Rule.

Protocol

(Read-only ﬁeld.) Protocol. You cannot change the protocol
over which the connector virtual service will accept requests.

Routing Rule

(Read-only ﬁeld.) The value Connection Pool means that
the requests are sent to the provider via the CloudStreams
connection pool. For more information about connection
pools, see the documentation speciﬁc to your CloudStreams
connector (for example, webMethods CloudStreams Provider for
Salesforce.com Installation and User's Guide).
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The "Invoke IS Service" Step (Inbound, Connector Virtual Service, REST)
This optional step invokes a user-deﬁned Integration Server ﬂow service. An IS service is
a user-deﬁned Integration Server ﬂow service that you can invoke in:
The "In Sequence" step, to pre-process the request messages before CloudStreams
submits the requests to the native service.
The "Out Sequence" step, to pre-process the response messages from the native
service before CloudStreams returns the responses to the consuming application.
You create an "Invoke IS Service" step for a connector virtual service the same way you
create one for a virtual service. For details, see "The Invoke IS Service Step (Inbound,
REST)" on page 134, or "The Invoke IS Service Step (Outbound, REST)" on page
147.

The "Out Sequence" Step (Connector Virtual Service, REST)
You conﬁgure the service's "Out Sequence" step (optional) to manipulate the response
messages from the native service before CloudStreams returns the responses to the
consuming applications. This step can include the "Invoke IS Service" step (optional),
which processes the response message from the native service provider before it is
returned to the consuming application. See "The Invoke IS Service Step (Inbound,
Connector Virtual Service, REST)" on page 158.

The "Error Sequence" Step (Connector Virtual Service, REST)
The default connector virtual services are conﬁgured to return the native service
provider's service fault, if one is available. CloudStreams will send whatever content it
received from the native service provider. You can optionally invoke IS services to preprocess or post-process the error messages.
To configure the "Error Sequence" step (connector virtual service, REST)

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, expand your CloudStreams Governance project and
click the connector virtual service name.

3. Expand Error Sequence.
4. Click Error Messaging and complete the fields in the General page in the Properties view as
follows.
Option

Description

Name

You can optionally change the step name to any other name.
There are no naming convention restrictions.
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Option

Description

Type

(Read-only ﬁeld.) Error Messaging.

Processing
Method

Optionally select either of the following:
Pre-Processing: Select this option if you want to invoke an IS
service to manipulate the response message before the Error
Sequence step is invoked. The IS service will have access
to the response message context (the axis2 MessageContext
instance) before it is updated with the custom error message.
For example, you might want to send emails or perform
custom alerts based on the response payload. For more
information about IS services, see "The Invoke IS Service Step
(Inbound, SOAP)" on page 69.
Post-Processing: Select this option if you want to invoke an
IS service to manipulate the service fault after the Error
Sequence step is invoked. The IS service will have access to
the entire service fault and the custom error message. You
can make further changes to the fault message structure, if
needed. For more information about IS services, see "The
Invoke IS Service Step (Inbound, SOAP)" on page 69.

Important Considerations for REST Virtual Services
Keep the following topics in mind when you conﬁgure REST virtual services:
"HTTP Method/Content-Type Combinations" on page 159
"Changing the HTTP Method of a REST Virtual Service" on page 160

HTTP Method/Content-Type Combinations
When you conﬁgure a REST virtual service it is important to specify all the HTTP
methods that are supported for the service. For example, if the REST virtual service is
deployed to CloudStreams and only the GET method was selected in the REST virtual
service deﬁnition, then CloudStreams will only permit GET invocations. A POST request
will be rejected with a return of statusCode 405 even if the native service happens to
support POSTs.
At run time, CloudStreams determines the type of a request message based on the
message's HTTP method and its Content-Type. (The absence of the soapAction header
will indicate to CloudStreams that the message is an XML message.)
The valid HTTP method/Content-Type combinations are as follows:
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This
method...

Can be included in a message of this type...

POST

application/xml
application/json
application-x-www-form-urlencoded
multipart/form-data

PUT

application/xml
application/json
application-x-www-form-urlencoded
multipart/form-data

GET

application-x-www-form-urlencoded

DELETE

application-x-www-form-urlencoded

Note that:
If CloudStreams receives a request sent with an HTTP method that is not speciﬁed in
the REST virtual service deﬁnition, it will return a 405 error.
If CloudStreams receives a request sent with a wrong Content-Type, it will return
a 415 error. In addition, if the wrong Content-Type is used with a GET or DELETE,
then the query parameters contained in the message (if any) will not be processed.

Changing the HTTP Method of a REST Virtual Service
When conﬁguring the routing step of a REST virtual service, you specify whether to
route the requests to the native service with the same HTTP method that is contained
in the requests (GET, POST, PUT, DELETE), or whether to route the requests with a
diﬀerent HTTP method. This applies only to virtual services, not to connector virtual
services.
Typically you want to pass each request to the native service with the same HTTP
method that is contained in the request. For example, if a request contains a GET
method, you allow the GET method to be passed to the native service. However, there
might be rare cases in which you want to change the HTTP method of a request to a
diﬀerent HTTP method. For example, you might want to:
Expose an XML service as a REST service.
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In this case, the service you create would be a Virtual XML service that exposes
the HTTP methods GET, POST, PUT and DELETE, but the routing method would
always be POST.
Expose a REST service whose virtual REST service only exposes the POST method
To change the HTTP method of a REST request, in the REST virtual service's "Routing
Rule" step, set the value of the HTTP Method ﬁeld either statically (by explicitly seing the
value to GET, POST, PUT or DELETE) or dynamically (by seing the value to CUSTOM).
In order to use the CUSTOM option to set the ﬁeld dynamically, you must write a IS
service that sets a value of GET, POST, PUT or DELETE for a predeﬁned context variable
named ROUTING_METHOD. You need to invoke this service in the virtual service's
"In Sequence" step. For details, see "Changing HTTP Methods in Requests Dynamically
Using a Context Variable" on page 163.
Note: Use this feature carefully, since changing HTTP methods to certain other HTTP
methods could result in unintended results or errors. For example, changing an inbound
GET request to a DELETE request would be a serious mistake if the deletion was not
intended and the native REST service actually deleted a resource when invoked with a
DELETE method. Additionally, an incoming POST or PUT request cannot be translated
into a GET or DELETE if the request has nested elements. For more information, see
"Implications of Changing HTTP Methods" on page 161.

Implications of Changing HTTP Methods
Note the following.
When changing
from...

To...

GET

POST

Note that...
The Content-Type of the changed request is sent as
application/xml or application/json, and the charset
is UTF-8.
Depending on the structure of the native service,
be aware that the native service might not be
expecting the same payload structure that is being
sent. In this case, you would need to transform
the request message into the format required by
the native service before CloudStreams sends
the requests to the native service. For more
information, see "Sample XSLT Transformation for
GET-to-POST or GET-to-PUT" on page 164.

GET

PUT

Identical to GET-to-POST, except that CloudStreams
changes the request's HTTP method from GET to
PUT.
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When changing
from...

To...

Note that...

GET

DELETE

No comment.

POST

GET

CloudStreams will translate the POSTed request
elements into query string parameters, in a root
element. An incoming POST or PUT request cannot
be translated into a GET or DELETE if the request
has nested elements. For example:
(this is correct)
<person>
<lastName>Smith</lastName>
</person>
(this is incorrect)
<person>
<name>
<last>Smith</last>
</name>
</person>

If you want to send additional parameters as
part of the request URL, you can transform this
payload. To do this, you can use an XSLT ﬁle or
a webMethods IS service call to add parameters
before the request is sent to the native service.
For more information, see "The In Sequence Step
(REST)" on page 130.
POST

DELETE

Identical to POST-to-GET, except that CloudStreams
changes the request's HTTP method from POST to
DELETE.

POST

PUT

The Content-Type of the changed request is sent as
application/xml or application/json, and the charset
is UTF-8.

PUT

GET

Identical to POST-to-GET, except that CloudStreams
changes the request's HTTP method from PUT to
GET.

PUT

POST

The Content-Type of the changed request is sent as
application/xml or application/json, and the charset
is UTF-8.

PUT

DELETE

Identical to POST-to-DELETE, except that
CloudStreams changes the request's HTTP method
from PUT to DELETE.
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When changing
from...

To...

Note that...

DELETE

GET

No comment.

DELETE

POST

Identical to GET-to-POST, except that CloudStreams
changes the request's HTTP method from DELETE
to POST.

DELETE

PUT

Identical to GET-to-PUT, except that CloudStreams
changes the request's HTTP method from DELETE
to PUT.

GET, POST,
PUT or
DELETE

CUSTOM

See "Changing HTTP Methods in Requests
Dynamically Using a Context Variable" on page
163.

GET or
DELETE

POST
or PUT

Note that the query parameters will be picked oﬀ
the URL and stored as top-level elements when
the message is sent to the native service. The query
parameters are ignored on the endpoint URL and
lost when we POST to the native provider (that is,
do not change the protocol method).

Changing HTTP Methods in Requests Dynamically Using a Context Variable
Alternatively, instead of changing an HTTP method explicitly (statically) to PUT, POST,
GET or DELETE, you can change the HTTP method to the value of a predeﬁned context
variable (ROUTING_METHOD) that dynamically resolves to a diﬀerent HTTP method
(PUT, POST, GET or DELETE, as appropriate).
To change the HTTP method dynamically, you create an IS service and invoke it in
the virtual service's "In Sequence" step. This IS service should reference the predeﬁned
context variable ROUTING_METHOD (see "The Predeﬁned Context Variables" on page
100). To set the value of ROUTING_METHOD, use the setContextVariableValue method,
which is deﬁned in the following class:
com/softwareag/cloudstreams/api/RuntimeFacade.java
For example:
public static final void updateHttpMethod(IData pipeline)
throws ServiceException {
String mcKey = "Message Context";
Object obj = IDataUtil.get(pipeline.getCursor(), mcKey);
if (obj!=null && obj instanceof
org.apache.axis2.context.MessageContext) {
MessageContext msgCtx = (MessageContext) obj;
QName varName =
new QName(ContextVariableType.ROUTING_METHOD.getName());
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RuntimeFacade.setContextVariableValue(varName, "PUT", msgCtx );
}
}

Sample XSLT Transformation for GET-to-POST or GET-to-PUT
As stated in the above table, depending on the structure of the native service, the native
service might not be expecting the same payload structure that is being sent. In this case,
you would need to transform the request message into the format required by the native
service before CloudStreams sends the requests to the native service. To do this, you
invoke an XSLT ﬁle during the "In Sequence" step.
Assume that:
The native service name is "authors:.
The REST virtual service for "authors: is named "vs-authors: and is made available
in CloudStreams at this endpoint: hp://localhost:5555/ws/vs-authors/Invoke. The
targetNamespace of the REST virtual service is "http://example.com/authors".
Following is a sample XSLT transformation ﬁle for the GET-to-POST or GET-to-PUT
scenario.
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns:ns="http://example.com/authors"
version="1.0">
<xsl:output method="xml" omit-xml-declaration="no" standalone="yes"
indent="yes"/>
<xsl:strip-space elements="*"/>
<xsl:template match="node()|@*">
<xsl:copy>
<xsl:apply-templates select="node()|@*"/>
</xsl:copy>
</xsl:template>
<xsl:template match="//ns:invoke/node()">
<xsl:element name="{local-name(.)}">
<xsl:value-of select="."/>
</xsl:element>
</xsl:template>
<xsl:template match="//ns:invoke">
<xsl:element name="authors">
<xsl:apply-templates/>
</xsl:element>
</xsl:template>
</xsl:stylesheet>
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Overview of Policies
A policy adds run-time governance capabilities to a virtual service or a Connector
Virtual Service. A policy is a sequence of actions that are carried out by CloudStreams
when a consumer requests a particular service through CloudStreams.
The actions in a policy perform activities such as identifying/authenticating consumers,
validating digital signatures and capturing performance measurements. An action is a
single task that is included in a policy and is evaluated by CloudStreams at run time.
Actions have one or more parameters, which you conﬁgure when you insert the actions
into a policy. For example, an action that identiﬁes consumers speciﬁes one or more
identiﬁers to identify the consumers who are trying to access the services.
CloudStreams provides built-in action templates. A built-in action template is a
deﬁnition of an action that can be used in a policy. An action template speciﬁes the set of
parameters associated with a particular policy action. You can use these action templates
to create actions for policies.
When you create a policy, you:
1. Specify the service(s) to which the policy should apply. A policy can apply to one
or more virtual services or one or more Connector Virtual Services, but not to both
types of services.
2. Add the desired actions to the policy, and conﬁgure their parameters.
3. Activate the policy when you are ready to put it into eﬀect. When you deploy the
virtual services or Connector Virtual Services to which the policy is applied, the
policy will also be deployed.
Following is a summary of the kinds of actions you can include in policies for virtual
services and Connector Virtual Services. Detailed descriptions of the actions appear
later, in "The Policy Actions" on page 171.

Policies for Virtual Services
You should create a policy for each virtual service. You can apply a single policy to one
or more virtual services. A policy for a virtual service can include the following kinds of
actions:

WS-SecurityPolicy 1.2 Actions
There are two kinds of WS-SecurityPolicy 1.2 actions:
Authentication actions, to verify that the requests for virtual services contain
a speciﬁed WS-SecurityPolicy element. CloudStreams provides the following
authentication actions:
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Require SAML Token: Requires that a WSS Security Assertion Markup Language
(SAML) assertion token be present in the SOAP message header to validate
service consumers.
Require WSS Username Token: Requires that a WSS username token and password
be present in the SOAP message header to validate service consumers.
Require X.509 Token: Requires that a WSS X.509 token be present in the SOAP
message header to validate service consumers.
XML security actions, to provide conﬁdentiality (through encryption) and integrity
(through signatures) for request and response messages. CloudStreams provides the
following XML security actions:
Require Signing: Requires that a request's XML element (which is represented by
an XPath expression) be signed.
Require Encryption: Requires that a request's XML element (which is represented
by an XPath expression) be encrypted.
Require SSL: Requires that requests be sent via SSL client certiﬁcates, and can be
used with both SOAP and REST services.
Include Timestamps: Requires that timestamps be included in the request header.
CloudStreams checks the timestamp value against the current time to ensure
that the request is not an old message. This serves to protect your system against
aempts at message tampering, such as replay aacks.

Monitoring Actions
CloudStreams provides the following run-time monitoring actions:
Monitor Service Performance: This action monitors a user-speciﬁed set of run-time
performance conditions for a virtual service, and sends alerts to a speciﬁed
destination when these performance conditions are violated.
Monitor Service Level Agreement: This action provides the same functionality as
"Monitor Service Performance", but this action is diﬀerent because it enables you
to monitor a virtual service's run-time performance for particular consumers. You
can conﬁgure this action to deﬁne a Service Level Agreement (SLA), which is set of
conditions that deﬁnes the level of performance that a speciﬁed consumer should
expect from a service.
Throttling Traffic Optimization: This action limits the number of service invocations
allowed during a speciﬁed time interval, and sends alerts to a speciﬁed destination
when the performance conditions are violated. You can use this action to avoid
overloading the back-end services and their infrastructure, to limit speciﬁc
consumers in terms of resource usage, etc.
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Additional Actions
CloudStreams provides additional actions that you can use in conjunction with the
actions above.
Identify Consumer: You use this action in conjunction with an authentication action
("Require WSS Username Token", "Require X.509 Token", or "Require HTTP Basic
Authentication"). Alternatively, this action can be used alone to identify consumers
only by host name or IP address.
Require HTTP Basic Authentication: This action uses HTTP Basic authentication to verify
the consumer's authentication credentials contained in the request's Authorization
header. CloudStreams authorizes the credentials against the list of users registered in
the Integration Server on which CloudStreams is running. This action supports WSSecurityPolicy 1.2.
Authorize User: This action authorizes consumers against a list of users and/or a list of
groups registered in the Integration Server on which CloudStreams is running. You
use this action in conjunction with an authentication action ("Require WSS Username
Token", "Require SAML Token", or "Require HTTP Basic Authentication").
Log Invocation: Logs request/response information (and optionally their payloads) to a
destination you specify.
Validate Schema: Validates all XML request and/or response messages against an XML
schema referenced in the WSDL.

Policies for Connector Virtual Services
Each default Connector Virtual Service has a default policy, which logs the requests/
responses to a database. You cannot modify the default Connector Virtual Service or
its policy. However, you can create additional Connector Virtual Services with custom
policies. If you create a Connector Virtual Service with a custom policy, you can include
the actions from the "Monitoring" or "Additional" action categories (except for "Validate
Schema"); the "WS-SecurityPolicy 1.2" actions are not needed. For example, you might
want to create a custom policy that monitors run-time performance, customizes how the
service invocations are logged, or optimizes server traﬃc.
The default Connector Virtual Service policies are named Logging Policy, located in the
sample CloudStreams Governance project in the WmCloudStreams package.
The remainder of this section describes:
"Creating Policies" on page 169
"Modifying Policies" on page 170
"The Policy Actions" on page 171
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Creating Policies
To create a policy

1. Open Software AG Designer and display the CloudStreams Development perspective.
2. In the CloudStreams Governance view, expand your CloudStreams Governance project
folder, right-click the Policiesfolder and click New Policy.

3. In the New Policy wizard, complete the following fields.
Option

Description

CloudStreams
Project

Click Browse and select the CloudStreams project in which to
create the policy. Select a CloudStreams Governance project
if the policy is for a virtual service or a Connector Virtual
Service, or select a CloudStreams Provider project if the policy
is for a custom cloud connector.

Name

A name for the new policy. A policy name can contain any
character, including spaces.
Note: If you want to change the policy name after it has been
created, right-click the service name in the Policies folder and
select Rename.

Service Type

Specify whether the policy will be applied to a virtual service
or to a Connector Virtual Service.

Description

Optional. A description for the new policy. This description
appears when a user displays a list of policies in the user
interface.

4. Click Next.
5. Click the button next to the Criteriafield to apply the policy to services that meet certain
criteria. In the Criteria dialog box that appears, specify the criteria as follows:
a. In the Criteria field, specify a value (SOAP or REST) for the Service Type attribute. That
is, specify whether the policy should apply to SOAP services or REST services.
b. Click the plus button next to the Criteria field to add a new row, and choose another
criteria attribute (Name or Description) and choose an operator and value for it. For
example, specify whether the policy should apply to all SOAP services that are equal to,
or start with, or contain the prefix Abc_.
c. Repeat step 2 if desired to specify additional criteria.
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d. If you specify multiple criteria, use the Condition field to connect the criteria by the AND
or OR operator. The default operator is AND.
Notes:
If you specify no criteria, the policy will apply to all virtual services or connector
virtual services (based on your selection in the wizard).
Caution: CloudStreams checks for policy conﬂicts when you deploy a virtual
service. If the service has only one policy applied to it (that is, the policy you are
applying here), that policy will be deployed to CloudStreams, and CloudStreams
executes the policy's actions in the order in which they are speciﬁed in the policy.
However, if the service has multiple policies applied to it, a policy conﬂict might
occur. A policy conﬂict might have unintended consequences. CloudStreams will
warn you of policy conﬂicts. For more information, see "What Happens When
You Deploy a Service?" on page 200.

6. In the policy editor, click Add Action and select the first action to include in the policy.
Some actions have input parameters, which are displayed in the Action Values
section of the editor. For example, the Identify Consumer action has the parameter
Anonymous Usage Allowed.

7. Specify values for the input parameters (if any) displayed in the Action Values section.
8. Right-click the action name in the Applied Actions list. Some actions have additional

parameters you can select. For detailed descriptions of all policy action parameters, see "The
Policy Action Reference" on page 175.

9. Select another action to include in the policy, if desired.
Note: Make sure to select the actions in the order in which you want them to run
when the policy is enforced. You cannot change the order of the actions after you
add them; you can only delete them and then add a new list of actions.

10. Activate the policy when you are ready to put it into effect by right-clicking the policy name

in the Policiesfolder and clicking Active. You will not be allowed to activate the policy unless
all of its action parameters have been set. If the activation is successful, the value of the
Statusfield in the Properties view will change to Active.
When you deploy the virtual services or Connector Virtual Services to which the
policy is applied, the policy will be deployed as well.

Modifying Policies
To modify a policy

1. Open Software AG Designer and display the CloudStreams Development perspective.
2. In the CloudStreams Governance view, click the policy name in the Policiesfolder.
3. You can modify:
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a. The policy name: Right-click the policy name in the Policies folder and click Rename.
b. The policy description in the Properties view.
c. The policy's criteria (to change the services to which the policy applies): Click the
button next to the Criteria field in the Properties view (or right-click the policy name in
the Policies folder and click Criteria). The Criteria dialog box is described above, in
"Creating Policies" on page 169.
d. The policy's actions and their parameters in the Applied Actions and Action Values
sections.
e. To delete the policy, right-click the policy name in the Policies folder and click Delete.

4. Activate the changed policy when you are ready to put it into effect by right-clicking the

policy name in the Policyfolder and clicking Active. You will not be allowed to activate the
policy unless all of its action parameters have been set. If the activation is successful, the
value of the Statusfield in the Properties view will change to Active.
When you deploy the virtual services or Connector Virtual Services to which the
policy is applied, the policy will be deployed as well.

The Policy Actions
This section describes the set of policy actions that is installed with CloudStreams. The
content is organized under the following sections:
"Action Evaluation Order and Dependencies" on page 171: Lists the order in
which CloudStreams evaluates the actions, lists action dependencies, and presents
usage cases for authenticating/identifying consumers.
"The Policy Action Reference" on page 175: An alphabetic reference of the actions
and their parameters.

Action Evaluation Order and Dependencies
The following table shows:
The order in which CloudStreams evaluates the actions to determine possible policy
conﬂicts. CloudStreams resolves policy conﬂicts as described in "What Happens
When You Deploy a Service?" on page 200.
Any action dependencies (that is, whether an action must be used in conjunction
with another particular action).
Evaluation
Order

Action

Dependency

1

Require SSL

None
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Evaluation
Order

Action

Dependency

2

Require HTTP Basic
Authentication

The "Identify Consumer" action (if
the Authenticate Credentials option is
selected).

3

Require WSS Username
Token

None

4

Require X.509 Token

None

5

Require SAML Token

None

6

Require Signing

None

7

Require Encryption

None

8

Require Timestamps

The actions "Require SSL", "Require
Signing" and "Require Encryption".

9

Identify Consumer

If "Identify Consumer"'s identiﬁer ﬁeld
is set to:
HTTP Token, the action "Require HTTP
Basic Authentication" may also be
required.
WSS Header Token, the action "Require
WSS Username Token" is also
required.
Consumer Certificate, the actions
"Require X.509 Token" or "Require
Signing" are also required.

10

Authorize User

The "Require HTTP Basic
Authentication", "Require WSS
Username Token" or "Require SAML
Token" action.

11

Validate Schema

None

12

Log Invocation

None
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Evaluation
Order

Action

Dependency

13

Monitor Service
Performance

None

14

Monitor Service Level
Agreement

"Identify Consumer"

15

Throling Traﬃc
Optimization

"Identify Consumer" (if the Limit Traffic
for Applications option is selected).

Usage Cases for Identifying/Authenticating Consumers
When deciding which type of identiﬁer to use to identify a consumer application,
consider the following points:
Whatever identiﬁer you choose to identify a consumer application, it must be
unique to the application. Identiﬁers that represent user names are often not suitable
because the identiﬁed users might submit requests for multiple applications.
Identifying applications by IP address or host name is often a suitable choice,
however, it does create a dependency on the network infrastructure. If a consumer
application moves to a new machine, or its IP address changes, you must update the
identiﬁers in the application asset.
Using X.509 certiﬁcates or a custom token that is extracted from the SOAP message
itself (using an XPATH expression), is often the most trouble-free way to identify a
consumer application.
Following are some combinations of actions you can use to identify/authenticate
consumers.
Scenario 1: Identify consumers by IP address or host name
The simplest way to identify consumers is to use the Identify Consumer action and
select either the IP Address or Host Name parameter.
Scenario 2: Authenticate consumers by HTTP authentication token
Use the following actions:
Identify Consumer action, and select the HTTP Authentication Token parameter (to
identify consumers using the token derived from the HTTP header).
Require HTTP Basic Authentication action.
Authorize User action (to authorize a list of users and/or groups registered in the
Integration Server on which CloudStreams is running).
Scenario 3: Authenticate consumers by WS-Security authentication token
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Use the following actions:
Identify Consumer action, and select the WS-Security Authentication Token
parameter (to identify consumers using the token derived from the WSS
Header).
Require WSS Username Token action.
Authorize User action (to authorize a list of users and/or groups registered in the
Integration Server on which CloudStreams is running).
Scenario 4: Authenticate consumers by WSS X.509 token
Use the following actions:
Identify Consumer action, and select the Consumer Certificate parameter (to
identify consumers using the WSS X.509 token).
Require X.509 Token action.
Require SSL action.

Multiple Security Elements in Requests/Responses
SOAP allows you to send multiple security elements in the SOAP header of a request
or response. When CloudStreams receives a message with multiple security elements in
the SOAP header, it will process only the ﬁrst security element listed. It ignores all other
security elements in the request.
In order for CloudStreams to process the security element, the virtual service must be
conﬁgured with the proper policy action to handle the element (for example, "Require
WSS Username Token", "Require X.509 Token", etc.). If the proper policy actions are not
conﬁgured for the virtual service, CloudStreams will not process the security header
(even if the mustUnderstand aribute of the security element is set to 1 (true)). In this
case, CloudStreams will forward the message to the native service or the consumer
unchanged.
If the proper policy actions are conﬁgured for the virtual service, CloudStreams
processes the requests/responses as follows:
1. CloudStreams processes the ﬁrst security element found in the message.
2. CloudStreams removes the security element from the message before sending it to
the native service or the consumer.
3. If the security policy has been violated, CloudStreams sends a policy violation
event notiﬁcation (assuming that the policy is conﬁgured for policy violation event
notiﬁcations).
4. Processing is complete; CloudStreams ignores all but the ﬁrst security element.
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The Policy Action Reference
This section describes, in alphabetic order, each policy action provided by
CloudStreams:
"Authorize User" on page 175
"Identify Consumer" on page 176
"Include Timestamps" on page 177
"Log Invocation" on page 178
"Monitor Service Performance" on page 179
"Monitor Service Level Agreement (SLA)" on page 182
"Require Encryption" on page 185
"Require HTTP Basic Authentication" on page 187
"Require Signing" on page 190
"Require SSL" on page 191
"Require SAML Token" on page 188
"Require WSS Username Token" on page 192
"Require X.509 Token" on page 192
"Throling Traﬃc Optimization" on page 193
"Validate Schema" on page 196

Authorize User
Note: Dependency requirement: A policy that includes this action must also include one
of the following actions: Require HTTP Basic Authentication, Require WSS Username
Token or Require SAML Token.
This action authorizes consumers against a list of users and/or a list of groups registered
in the Integration Server on which CloudStreams is running.
Input Parameters
User

Right-click the action name and click Add User to authorize
consumers against a list of users who are registered in the
Integration Server instance on which CloudStreams is running.
You can select Add User multiple times to add multiple users.

Group

Right-click the action name and click Add Group to authorize
consumers against a list of groups who are registered in the
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Integration Server instance on which CloudStreams is running.
You can select Add Group multiple times to add multiple
groups.

Identify Consumer
Speciﬁes the kind of consumer identiﬁer (IP address, HTTP authorization token, etc.)
that CloudStreams will use to identify consumer applications. You can select only one
identiﬁer. Alternatively, you can allow anonymous users to send requests, without
restriction.
Input Parameters
Anonymous Usage
Allowed

Allows all users to send requests, without restriction.
True: Allows all users to send requests.
False: Default. Allows only the users identiﬁed by your
selected identiﬁer (below) to send requests.

IP Address

Right-click the action name and click Add IP Address to identify
consumer applications based on their originating IP addresses.

Host Name

Right-click the action name and click Add Host Name to identify
consumer applications based on a host name.

HTTP Token

Right-click the action name and click Add HTTP Token if
you want to use HTTP Basic authentication to verify the
consumer's authentication credentials contained in the
request's Authorization header. CloudStreams authorizes
the credentials against the list of users registered in the
Integration Server on which CloudStreams is running.
This type of consumer authentication is referred to as
"preemptive authentication". If you want to use "preemptive
authentication", you should also include the action "Require
HTTP Basic Authentication" in the policy.
If you choose to omit "Require HTTP Basic Authentication",
the client will be presented with a security challenge. If the
client successfully responds to the challenge, the user is
authenticated. This type of consumer authentication is referred
to as "non-preemptive authentication". For more information,
see "Require HTTP Basic Authentication" on page 187.
Note: If you select the value HTTP Token, do not include the
"Authorize Against Registered Consumers" action in the policy.
This is an invalid combination.
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WSS Header Token

Right-click the action name and click Add WSS Header Token to
validate user names and passwords that are transmied in the
SOAP message header in the WSS Username Token. If you
select this option, you should also include the action Require
WSS Username Token in the policy.

XPATH Token

Right-click the action name and click Add XPATH Token to
validate consumer applications based on an XML element
(represented by an XPATH expression you specify in the
XPATH to Identify Token ﬁeld).

Consumer
Certificate

Right-click the action name and click Add Consumer Certificate
to identify consumer applications based on information in a
WSS X.509 certiﬁcate. If you select this option, you should also
include the Require X.509 Token or the Require Signing action in
the policy.

User ID

If you are applying the Identify Consumer action to a
connector virtual service, right-click the action name and click
Add User ID. No other identiﬁer is valid if you are applying the
Identify Consumer action to a connector virtual service.
User ID identiﬁes consumer applications based on a list of
users who are registered in the Integration Server on which
CloudStreams is running. (You need to apply the Identify
Consumer action to a Connector Virtual Service if you apply
the following actions to the Connector Virtual Service:
"Monitor Service Level Agreement" or "Throling Traﬃc
Optimization" (if you select its Limit Traffic for Applications
option)).

Include Timestamps
Note: Dependency requirement: A policy that includes this action must also include all of
the following actions: Require SSL, Require Signing, and Require Encryption.
If you include this action, CloudStreams will require that timestamps be included in the
request header. This action supports WS-SecurityPolicy 1.2 and cannot be used with
REST services or connector virtual services.
CloudStreams checks the timestamp value against the current time to ensure that the
request is not an old message, which serves to protect your system against aempts at
message tampering, such as replay aacks.
CloudStreams rejects the request if either of the following things happen:
CloudStreams receives a timestamp that exceeds the time deﬁned by the timestamp
element.
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A timestamp element is not included in the request.
Input Parameters
None.

Log Invocation
Logs request/response payloads. You can log the payloads in the database and/or send
the payloads in the form of email alerts. This action also logs other information about
the request/response, including the service name, operation name, the Integration Server
user, a timestamp, the response time, and more.
Input Parameters
Log Generation
Frequency

Speciﬁes how frequently to log the payload.
Always: Log all requests and/or responses.
On Success: Log only the successful requests and/or
responses.
On Failure: Log only the failed requests and/or responses.

Log the Following
Payloads

Speciﬁes whether to log all request payloads, all response
payloads, or both.
Log Request: Log all request payloads.
Log Response: Log all response payloads.

Send Data To

Specify where to log the payloads.
Database: Default. Logs the payloads in the CloudStreams
Analytics database.
Note: Be sure to also select the Database Publishing option
in Integration Server Administrator (go to Solutions >
CloudStreams > Administration > Database), as described in
"Seing the Database Options for Publishing Performance
Metrics and Events" on page 35.
Server Log: Logs the payloads in the server log of the
Integration Server on which CloudStreams is running.
Also choose a value in the Log Level ﬁeld:
Info: Logs error-level, warning-level, and informationallevel alerts.
Warn: Logs error-level and warning-level alerts.
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Error: Logs only error-level alerts.
Note: The Integration Server Administrator's logging
level for CloudStreams should match the logging
level speciﬁed for this action (in the Integration Server
Administrator go to Settings > Logging > Server Logger).
Alert Email

Right-click the action name and click Add Alert Email to send the
payloads in an email alert to the email address you specify in
the Email ID ﬁeld. You can select Add Alert Email multiple times
to add multiple email addresses.
Note: Be sure to set the email options in Integration Server
Administrator (go to Solutions > CloudStreams > Administration >
Email), as described in "Seing the E-mail Options for Logging
Payloads and Sending Performance Monitoring Alerts" on page
33.

Monitor Service Performance
This action monitors a user-speciﬁed set of run-time performance conditions for a virtual
service, and sends alerts to a speciﬁed destination when the conditions are violated.
For the counter-based metrics (Total Request Count, Success Count, Fault Count),
CloudStreams sends an alert as soon as the performance condition is violated, without
having to wait until the end of the metrics tracking interval. CloudStreams sends only
one alert the ﬁrst time the condition is violated during the interval. (It will send another
alert the next time a condition is violated during a subsequent interval.) For information,
see "The Intervals for Metric Publishing" on page 36.
For the aggregated metrics (Average Response Time, Minimum Response Time,
Maximum Response Time), CloudStreams aggregates the response times at the end of
the interval, and then sends an alert if the performance condition is violated.
Note: By default, this action does not include metrics for failed invocations. To include
metrics for failed invocations, set the pg.PgMetricsFormatter.includeFaultsparameter
to true in IntegrationServer_directory \instances\instance_name \packages
\WmCloudStreams\conﬁg\resources\wst-conﬁg.properties. For more information, see
"Advanced Seings" on page 275.
Input Parameters
Alert Interval

The time period (in minutes) in which to monitor performance
before sending an alert if a condition is violated.

Alert Frequency

Speciﬁes how frequently to issue alerts.
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Every Time: Issue an alert every time one of the speciﬁed
conditions is violated.
Only Once: Issue an alert only the ﬁrst time one of the
speciﬁed conditions is violated.
Alert Message

A text message to include in the alert.

Send Data To

Specify where to log the alerts.
Database: Default. Logs the alerts in the CloudStreams
Analytics database.
Note: Be sure to also select the Database Publishing option
in Integration Server Administrator (go to Solutions >
CloudStreams > Administration > Database), as described in
"Seing the Database Options for Publishing Performance
Metrics and Events" on page 35.
Server Log: Logs the alerts in the server log of the Integration
Server on which CloudStreams is running.
Also choose a value in the Log Level ﬁeld:
Info: Logs error-level, warning-level, and informationallevel alerts.
Warn: Logs error-level and warning-level alerts.
Error: Logs only error-level alerts.
Note: The Integration Server Administrator's logging
level for CloudStreams should match the logging
level speciﬁed for this action (in the Integration Server
Administrator go to Settings > Logging > Server Logger).

Metrics Collection
Level

The run-time performance metrics for a virtual service
(which is invoked only in the inbound run-time scenario),
are collected at the service level. That is, the metrics for all
invocations of a single virtual services are aggregated together
during your speciﬁed metrics publishing interval and then
published.
In contrast, the metrics for a connector virtual service (which
is invoked only in the outbound run-time scenario) can be
collected at two diﬀerent levels of metric collection:
Cloud Connector Service: Remember that a single connector
virtual service can be used by multiple cloud connector
services. Select this option if you want to collect the metrics
for the connector virtual service broken down by each
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separate cloud connector service that uses it. For example, if
a connector virtual services is used by three cloud connector
services, then this option will collect the metrics of that
service separately, broken down by each of the three cloud
connector services that use it.
Connector Virtual Service(default): Select this option if you
want to aggregate all the metrics for a single connector
virtual service, even if it is used by multiple cloud connector
services. For example, if a connector virtual service is used by
three cloud connector services, then this option will collect
the combined metrics for the connector virtual service by all
three of the cloud connector services that use it.
Action
Configuration

Right-click the action name and click Add Action Configuration
to specify a condition to monitor. To do this, select a condition
Name (the metric to monitor), an Operator, and a Value for the
condition. You can select Add Action Configuration multiple
times to add multiple conditions. Multiple conditions are
connected by the AND operator.
Name: The metric to monitor, which can be:
Availability: Indicates whether the service was available to the
speciﬁed consumers in the current interval. A value of 100
indicates that the service was always available. If invocations
fail due to policy violations, this parameter could still be
as high as 100. That is, SOAP faults returned by the native
provider or faults due to CloudStreams policy enforcements
do not impact Availability. Only errors that CloudStreams
interprets as a provider service being down will impact
Availability.
Average Response: The average amount of time it took the
service to complete all invocations in the current interval.
Response time is measured from the moment CloudStreams
receives the request until the moment it returns the response
to the caller.
Fault Count: The number of faults returned in the current
interval.
Maximum Response : The maximum amount of time to
respond to a request in the current interval.
Minimum Response: The minimum amount of time to respond
to a request in the current interval.
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Successful Request Count: The number of successful requests
in the current interval.
Total Request Count: The total number of requests (successful
and unsuccessful) in the current interval.
Alert Email

Right-click the action name and click Add Alert Email if you
want to send the monitoring alerts to an email address you
specify in the Email ID ﬁeld. You can select Add Alert Email
multiple times to add multiple email addresses.
Note: Be sure to also set the email options in Integration Server
Administrator (go to Solutions > CloudStreams > Administration >
Email), as described in "Seing the E-mail Options for Logging
Payloads and Sending Performance Monitoring Alerts" on page
33.

Monitor Service Level Agreement (SLA)
Note: Dependency requirement: A policy that includes this action must also include the
Identify Consumer action.
This action is similar to the Monitor Service Performance action. Both actions can
monitor the same set of run-time performance conditions for a virtual service, and
then send alerts when the performance conditions are violated. This action is diﬀerent
because it enables you to monitor run-time performance for one or more speciﬁed
consumers.
You can conﬁgure this action to deﬁne a Service Level Agreement (SLA), which is set of
conditions that deﬁnes the level of performance that a consumer should expect from a
service. You can use this action to identify whether a service's threshold rules are met
or exceeded. For example, you might deﬁne an agreement with a particular consumer
that sends an alert to the consumer if responses are not sent within a certain maximum
response time. You can conﬁgure SLAs for each virtual service/consumer application
combination.
For the counter-based metrics (Total Request Count, Success Count, Fault Count),
CloudStreams sends an alert as soon as the performance condition is violated, without
having to wait until the end of the metrics tracking interval. You can choose whether to
send an alert only once during the interval, or every time the violation occurs during
the interval. (CloudStreams will send another alert the next time a condition is violated
during a subsequent interval.) For information about intervals, see The Intervals for
Metric Publishing.
For the aggregated metrics (Average Response Time, Minimum Response Time,
Maximum Response Time), CloudStreams aggregates the response times at the end of
the interval, and then sends an alert if the performance condition is violated.
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Note: By default, this action does not include metrics for failed
invocations. You can include metrics for failed invocations by seing
the pg.PgMetricsFormatter.includeFaultsparameter to true in
IntegrationServer_directory \instances\instance_name \packages\WmCloudStreams
\conﬁg\resources\wst-conﬁg.properties. For more information, see "Advanced
Seings" on page 275.
Input Parameters
Alert Interval

The time period (in minutes) in which to monitor performance
before sending an alert if a condition is violated.

Alert Frequency

Speciﬁes how frequently to issue alerts.
Every Time: Issue an alert every time one of the speciﬁed
conditions is violated.
Only Once: Issue an alert only the ﬁrst time one of the
speciﬁed conditions is violated.

Alert Message

A text message to include in the alert.

Send Data To

Specify where to log the alerts.
Database: Default. Logs the alerts in the CloudStreams
Analytics database.
Note: Be sure to also select the Database Publishing option
in Integration Server Administrator (go to Solutions >
CloudStreams > Administration > Database), as described in
"Seing the Database Options for Publishing Performance
Metrics and Events" on page 35.
Server Log: Logs the alerts in the server log of the Integration
Server on which CloudStreams is running.
Also choose a value in the Log Level ﬁeld:
Info: Logs error-level, warning-level, and informationallevel alerts.
Warn: Logs error-level and warning-level alerts.
Error: Logs only error-level alerts.
Note: The Integration Server Administrator's logging
level for CloudStreams should match the logging
level speciﬁed for this action (in the Integration Server
Administrator go to Settings > Logging > Server Logger).
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Metrics Collection
Level

The run-time performance metrics for a virtual service
(which is invoked only in the inbound run-time scenario),
are collected at the service level. That is, the metrics for all
invocations of a single virtual services are aggregated together
during your speciﬁed metrics publishing interval and then
published.
In contrast, the metrics for a connector virtual service (which
is invoked only in the outbound run-time scenario) can be
collected at two diﬀerent levels of metric collection:
Cloud Connector Service: Remember that a single connector
virtual service can be used by multiple cloud connector
services. Select this option if you want to collect the metrics
for the connector virtual service broken down by each
separate cloud connector service that uses it. For example, if
a connector virtual services is used by three cloud connector
services, then this option will collect the metrics of that
service separately, broken down by each of the three cloud
connector services that use it.
Connector Virtual Service(default): Select this option if you
want to aggregate all the metrics for a single connector
virtual service, even if it is used by multiple cloud connector
services. For example, if a connector virtual service is used by
three cloud connector services, then this option will collect
the combined metrics for the connector virtual service by all
three of the cloud connector services that use it.

Action
Configuration

Right-click the action name and click Add Action Configuration
to specify a condition to monitor. To do this, select a condition
Name (the metric to monitor), an Operator, and a Value for the
condition. You can select Add Action Configuration multiple
times to add multiple conditions. Multiple conditions are
connected by the AND operator.
Name: The metric to monitor, which can be:
Availability: Indicates whether the service was available to the
speciﬁed consumers in the current interval. A value of 100
indicates that the service was always available. If invocations
fail due to policy violations, this parameter could still be
as high as 100. That is, SOAP faults returned by the native
provider or faults due to CloudStreams policy enforcements
do not impact Availability. Only errors that CloudStreams
interprets as a provider service being down will impact
Availability.
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Average Response: The average amount of time it took the
service to complete all invocations in the current interval.
Response time is measured from the moment CloudStreams
receives the request until the moment it returns the response
to the caller.
Fault Count: The number of faults returned during the current
interval.
Maximum Response : The maximum amount of time to
respond to a request in the current interval.
Minimum Response: The minimum amount of time to respond
to a request in the current interval.
Successful Request Count: The number of successful requests
in the current interval.
Total Request Count: The total number of requests (successful
and unsuccessful) in the current interval.
Alert for
Applications

Right-click the action name and click Add Alert for Applications
to specify the consumer application to which this Service Level
Agreement will apply. You can select Add Alert for Applications
multiple times to add multiple consumer applications.

Add Alert Email

Right-click the action name and click Add Alert Email if you
want to send the monitoring alerts to an email address you
specify in the Email ID ﬁeld. You can select Add Alert Email
multiple times to add multiple email addresses.
Note: Be sure to also set the email options in Integration Server
Administrator (go to Solutions > CloudStreams > Administration >
Email), as described in "Seing the E-mail Options for Logging
Payloads and Sending Performance Monitoring Alerts" on page
33.

Require Encryption
This action requires that an XML element (which is represented by an XPath expression)
be encrypted. This action supports WS-SecurityPolicy 1.2 and cannot be used with REST
services or connector virtual services.
Prerequisites:
1. Conﬁgure Integration Server: Set up keystores and truststores in Integration Server
(see the section Securing Communications with the Server in the document webMethods
Integration Server Administrator’s Guide).
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2. Conﬁgure CloudStreams: In the Integration Server Administrator, navigate to
Solutions > CloudStreams > Administration > General and complete the IS Keystore Name, IS
Truststore Name and Alias (signing) ﬁelds, as described in "Seing the General Options"
on page 30).
When this policy action is set for the virtual service, CloudStreams provides decryption
of incoming requests and encryption of outgoing responses. CloudStreams can encrypt
and decrypt only individual elements in the SOAP message body that are deﬁned by the
XPath expressions conﬁgured for the policy action. CloudStreams requires that requests
contain the encrypted elements that match those in the XPath expression. You must
encrypt the entire element, not just the data between the element tags. CloudStreams
rejects requests if the element name is not encrypted.
Note: Do not encrypt the entire SOAP body because a SOAP request without an element
will appear to CloudStreams to be malformed.
CloudStreams aempts to encrypt the response elements that match the XPath
expressions with those deﬁned for the policy. If the response does not have any elements
that match the XPath expression, CloudStreams will not encrypt the response before
sending. If the XPath expression resolves a portion of the response message, but
CloudStreams cannot locate a certiﬁcate to encrypt the response, then CloudStreams
sends a SOAP fault exception to the consumer and a Policy Violation event notiﬁcation
to CloudStreams.
How CloudStreams Encrypts Responses:
The Require Encryption action encrypts the response back to the client by dynamically
seing a public key alias at run time. CloudStreams determines the public key alias as
follows:
1. If CloudStreams can access the X.509 certiﬁcate of the client (based on the incoming
request signature), it will use useReqSigCertas the public key alias.
OR
2. If the Identify Consumer action is present in the policy (and it successfully identiﬁes
a consumer application), then CloudStreams will look for a public key alias with that
consumer name in the IS Keystore Name property. The IS Keystore Name property
is speciﬁed in the Integration Server Administrator, under Solutions > CloudStreams >
Administration > General. This property should be set to an Integration Server keystore
that CloudStreams will use.
For an Identify Consumer action that allows for anonymous usage, CloudStreams
does not require a consumer name in order to send encrypted responses. In this case,
CloudStreams can use one of the following to encrypt the response in the following
order, depending on what is present in the security element:
A signing certiﬁcate.
Consumer name.
WSS username, SAML token or X.509 certiﬁcate.
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HTTP authorized user.
OR
3. If CloudStreams can determine the current IS user from the request (that is, if an
Integration Server WS-Stack determined that Subject is present), then the ﬁrst
principal in that subject is used.
OR
4. If the above steps all fail, then CloudStreams will use either the WS-Security
username token or the HTTP Basic-Auth user name value. There should be a public
key entry with the same name as the identiﬁed username.
Input Parameters
Element Required to
be Encrypted

An XPath expression that represents the XML element that is
required to be encrypted.

Namespace Prefix

Optional. Right-click the action name and click Add Namespace
Prefix if you want to specify the namespace preﬁx of the
element required to be encrypted. Enter the namespace preﬁx
in the following format:
xmlns:preﬁx-name
For example:
xmlns:soapenv
For more information, see the XML Namespaces speciﬁcations
at hp://www.w3.org/TR/REC-xml-names/#ns-decl.
See below for an example XPath element generated in the
policy.

Example Generated XPath Element
The generated XPath element in the policy should look similar to this:
<sp:SignedElements xmlns:sp="http://docs.oasis-open.org/ws-sx/ws-securitypolicy/200702">
<sp:XPath xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">//soapenv:Body</sp:XPath>
</sp:SignedElements>

Require HTTP Basic Authentication
This action uses HTTP Basic authentication to verify the consumer's authentication
credentials contained in the request's Authorization header. CloudStreams authorizes
the credentials against the list of users registered in the Integration Server on which
CloudStreams is running. This action supports WS-SecurityPolicy 1.2.
If the user/password value in the Authorization header cannot be authenticated as
a valid Integration Server user (or if the Authorization header is not present in the
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request), a 500 SOAP fault is returned, and the client is presented with a security
challenge. If the client successfully responds to the challenge, the user is authenticated.
If the client does not successfully respond to the challenge, a 401 "WWW-Authenticate:
Basic" response is returned, and the invocation is not routed to the policy engine. As
a result, no events are recorded for that invocation, and its key performance indicator
(KPI) data are not included in the performance metrics.
If you choose to omit the Require HTTP Basic Authentication action (regardless of
whether an Authorization header is present in the request or not), then:
CloudStreams forwards the request to the native service, without aempting to
authenticate the request.
The native service returns a 401 "WWW-Authenticate: Basic" response, which
CloudStreams will forward to the client; the client is presented with a security
challenge. If the client successfully responds to the challenge, the user is
authenticated.
In the case where a consumer is sending a request with both transport credentials
(HTTP Basic authentication) and message credentials (WSS Username or X.509
token), the message credentials take precedence over the transport credentials when
Integration Server is determining which credentials it should use for the session. For
more information, see "Require WSS Username Token" on page 192 and "Require
X.509 Token" on page 192. In addition, you must ensure that the consumer that
connects to the virtual service has an Integration Server user account.
Input Parameters
Authenticate
Credentials

Authorizes consumers against the list of users registered in
the Integration Server on which CloudStreams is running.
If you select this option, you must also include the Identify
Consumer action in the policy.

Require SAML Token
Requires that a WSS Security Assertion Markup Language (SAML) assertion token
be present in the SOAP message header to validate service consumers. CloudStreams
supports SAML 1.1 and 2.0 tokens. This action supports WS-SecurityPolicy 1.2 and
cannot be used with REST services or connector virtual services.
Note: When a Require SAML Token action is generated, CloudStreams also implicitly
selects the timestamp and signing assertions. You should not add the Include
Timestamps and Require Signing policy actions to a virtual service if the Require SAML
Token action is already applied.
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Input Parameters
SAML Version

String. Speciﬁes the version of the WSS SAML Token to use (1.1
or 2.0).

Run-Time Behavior
When a service consumer sends a request that includes a SAML token to a virtual
service, CloudStreams validates the SAML token to ensure it is valid. If the token is
valid, Integration Server uses its included JAAS login modules to process the SAML
assertion and map the client public key in the assertion to a valid Integration Server
user.
If the service consumer invokes the virtual service without a SAML assertion in the
request, then CloudStreams sends the following SOAP fault to the service consumer to
indicate that the request does not match the security policy being enforced: SAML Token
missing in request.
Prerequisites
In order to use a SAML token, CloudStreams requires that you:
Determine which Security Token Services (STS) to trust. The STS generates the
SAML tokens that clients will submit. The client can use any STS provider that
generates SAML 1.1 or 2.0 tokens. The generated SAML token must:
Contain the certiﬁcate of the user/client (service consumer) in the assertion if
Integration Server is to use Holder-of-Key (HOK) type SAML assertions.
Be signed by the STS.
Identify the trusted STS to Integration Server. For more information, see "Seing the
STS Options" on page 38.
Provide a truststore alias that points to a truststore containing the issuer's certiﬁcate.
For information about providing a truststore alias, see the section Securing
Communications with the Server in the document webMethods Integration Server
Administrator’s Guide.
If Integration Server is to process Holder-of-Key (HOK) type SAML assertions,
which contain the client's public key, you must map the client's public key to an
Integration Server user. For more information about conﬁguring and mapping
client certiﬁcates, see the section Authenticating Clients in the document webMethods
Integration Server Administrator’s Guide.
To Identify a Trusted STS to Integration Server
To identify a trusted STS to Integration Server

1. Open the Integration Server Administrator if it is not already open.
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2. In the Navigation panel, select Security > SAML.
3. Click Add SAML Token Issuer, set the following parameters and click Save Changes:
Option

Description

Issuer Name

Name of a SAML token issuer from which Integration Server
should accept and process SAML assertions. Integration
Server will reject SAML assertions from issuers not conﬁgured
on this screen and will log a message to the Server log similar
to the following: 2010-06-09 23:35:38 EDT [ISS.0012.0025E
This value must match the value of the Issuer ﬁeld in the
SAML assertion.

Truststore Alias

Text identiﬁer for the truststore, which contains the public
keys of the SAML token issuer.

Certificate Alias

Text identiﬁer for the certiﬁcate associated with the truststore
alias.

Clock Skew

Clock diﬀerence between your Integration Server and the
SAML token issuer.

Require Signing
Note: Dependency requirement: A policy that includes this action must also include the
Identify Consumer action.
This action requires that a request's XML element (represented by an XPath expression)
be signed. This action supports WS-SecurityPolicy 1.2 and cannot be used with REST
services or connector virtual services.
Prerequisites:
1. Conﬁgure Integration Server: Set up keystores and truststores in Integration Server
(see the section Securing Communications with the Server in the document webMethods
Integration Server Administrator’s Guide).
2. Conﬁgure CloudStreams: In the Integration Server Administrator, navigate to
Solutions > CloudStreams > Administration > General and complete the IS Keystore Name, IS
Truststore Name and Alias (signing) ﬁelds, as described in "Seing the General Options"
on page 30). CloudStreams uses the signing alias speciﬁed in the Alias (signing) ﬁeld
to sign the response.
When this policy action is set for the virtual service, CloudStreams validates that
the requests are properly signed, and provides signing for responses. CloudStreams
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provides support both for signing an entire SOAP message body or individual elements
of the SOAP message body.
CloudStreams uses a digital signature element in the security header to verify that all
elements matching the XPath expression were signed. If the request contains elements
that were not signed or no signature is present, then CloudStreams rejects the request.
Note: You must map the public certiﬁcate of the key used to the sign the request to an
Integration Server user. If the certiﬁcate is not mapped, CloudStreams returns a SOAP
fault to the caller.
Input Parameters
Element Required to
be Signed

An XPath expression that represents the XML element that is
required to be signed.

Namespace Prefix

Optional. Right-click the action name and click Add Namespace
Prefix if you want to specify the namespace preﬁx of the
element required to be signed. Enter the namespace preﬁx in
the following format:
xmlns:preﬁx-name
For example:
xmlns:soapenv
For more information, see the XML Namespaces speciﬁcations
at hp://www.w3.org/TR/REC-xml-names/#ns-decl.
See below for an example XPath element generated in the
policy.

Example Generated XPath Element
The generated XPath element in the policy should look similar to this:
<sp:SignedElements xmlns:sp="http://docs.oasis-open.org/ws-sx/wssecuritypolicy/200702">
<sp:XPath
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">//soapenv:Body</sp:XPath>
</sp:SignedElements>

Require SSL
This action ensures that requests are sent to the server using the HTTPS protocol (SSL).
This action supports WS-SecurityPolicy 1.2 but can be used with both SOAP and REST
services.
In addition, seing the Client Certificate Required parameter to True allows CloudStreams
to verify the client sending the request.
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Ensure that you specify an HTTPS port, as described in "Seing the General Options" on
page 30.
Input Parameters
Client Certificate
Required

Speciﬁes whether client certiﬁcates are required for the
purposes of:
Verifying the signature of signed SOAP requests or
decrypting encrypted SOAP requests.
Signing SOAP responses or encrypting SOAP responses.
Values:
True: Requires client certiﬁcates. If a valid client certiﬁcate is
not presented, CloudStreams rejects the message. Ensure that
the Integration Server HTTPS port is conﬁgured to request or
require a client certiﬁcate.
False: Default. Does not require client certiﬁcates.

Require WSS Username Token
Note: Dependency requirement: A policy that includes this action must also include the
Identify Consumer action.
Requires that a WSS username token and password be present in the SOAP message
header to validate service consumers. This action supports WS-SecurityPolicy 1.2 and
cannot be used with REST services or connector virtual services.
CloudStreams rejects requests that do not include the username token and password of
an Integration Server user. CloudStreams only supports clear text passwords with this
kind of authentication.
In the case where a consumer is sending a request with both transport credentials (HTTP
basic authentication) and message credentials (WSS username or X.509 token), the
message credentials take precedence over the transport credentials when Integration
Server is determining which credentials it should use for the session. For more
information, see "Require HTTP Basic Authentication" on page 187.
Input Parameters
None.

Require X.509 Token
Note: Dependency requirement: A policy that includes this action must also include the
Identify Consumer action.
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Requires that a WSS X.509 token be present in the SOAP message header to validate
service consumers. This action supports WS-SecurityPolicy 1.2 and cannot be used with
REST services or connector virtual services.
In the case where a consumer is sending a request with both transport credentials (HTTP
basic authentication) and message credentials (X.509 token or WSS username), the
message credentials take precedence over the transport credentials when Integration
Server is determining which credentials it should use for the session. For more
information, see "Require HTTP Basic Authentication" on page 187. In addition,
you must ensure that the service consumer that connects to the virtual service has an
Integration Server user account.
Input Parameters
None.

Throttling Traffic Optimization
Note: Dependency requirement: A policy that includes this action must also include the
Identify Consumer action if the Limit Traffic for Applications option is selected.
This action limits the number of service invocations allowed during a speciﬁed time
interval, and sends alerts to a speciﬁed destination when the performance conditions are
violated.
Reasons for limiting the service invocation traﬃc include:
To avoid overloading the back-end services and their infrastructure.
To limit speciﬁc consumers in terms of resource usage (that is, you can use
the Monitor Service Level Agreement action in addition to Throling Traﬃc
Optimization).
To shield vulnerable servers, services, and even speciﬁc operations.
For service consumption metering (for example, billable pay-per-use services).
Input Parameters
Soft Limit

Number. Optional. Speciﬁes the maximum number of
invocations allowed per Interval before issuing an alert.
Reaching the soft limit will not aﬀect further processing of
requests (until the Hard Limit is reached).
The limit is reached when the total number of invocations
coming from all the consumer applications (speciﬁed in the
Limit Traffic for Applications ﬁeld) reaches the limit.

Hard Limit

Number. Required. Speciﬁes the maximum number of
invocations allowed per Interval before stopping the processing
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of further requests and issuing an alert. Typically, this limit
should be higher than the soft limit.
The limit is reached when the total number of invocations
coming from all the consumer applications (speciﬁed in the
Limit Traffic for Applications ﬁeld) reaches the limit.
Alert Interval

Number. Speciﬁes the amount of time for the soft limit and hard
limit to be reached.

Alert Frequency

Number. Speciﬁes how frequently to issue alerts.
Every Time: Issue an alert every time one of the speciﬁed
conditions is violated.
Only Once: Issue an alert only the ﬁrst time one of the
speciﬁed conditions is violated.

Alert Message for
Soft Limit

Optional. Specify a text message to include in the soft limit
alert.

Alert Message for
Hard Limit

Optional. Specify a text message to include in the hard limit
alert.

Send Data To

Specify where to log the alerts.
Database: Default. Logs the alerts in the CloudStreams
Analytics database.
Note: Be sure to also select the Database Publishing option
in Integration Server Administrator (go to Solutions >
CloudStreams > Administration > Database), as described in
"Seing the Database Options for Publishing Performance
Metrics and Events" on page 35.
Server Log: Logs the alerts in the server log of the Integration
Server on which CloudStreams is running.
Also choose a value in the Log Level ﬁeld:
Info: Logs error-level, warning-level, and informationallevel alerts.
Warn: Logs error-level and warning-level alerts.
Error: Logs only error-level alerts.
Note: The Integration Server Administrator's logging
level for CloudStreams should match the logging
level speciﬁed for this action (in the Integration Server
Administrator go to Settings > Logging > Server Logger).
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Metrics Collection
Level

The run-time performance metrics for a virtual service
(which is invoked only in the inbound run-time scenario),
are collected at the service level. That is, the metrics for all
invocations of a single virtual services are aggregated together
during your speciﬁed metrics publishing interval and then
published.
In contrast, the metrics for a connector virtual service (which
is invoked only in the outbound run-time scenario) can be
collected at two diﬀerent levels of metric collection:
Cloud Connector Service: Remember that a single connector
virtual service can be used by multiple cloud connector
services. Select this option if you want to collect the metrics
for the connector virtual service broken down by each
separate cloud connector service that uses it. For example, if
a connector virtual services is used by three cloud connector
services, then this option will collect the metrics of that
service separately, broken down by each of the three cloud
connector services that use it.
Connector Virtual Service(default): Select this option if you
want to aggregate all the metrics for a single connector
virtual service, even if it is used by multiple cloud connector
services. For example, if a connector virtual service is used by
three cloud connector services, then this option will collect
the combined metrics for the connector virtual service by all
three of the cloud connector services that use it.

Limit Traffic for
Application

Right-click the action name and click Add Limit Traffic for
Application if you want to specify the consumer application
that this action applies to. You can select Add Limit Traffic
for Application multiple times to add multiple consumer
applications.

Alert Email

Right-click the action name and click Add Alert Email if you
want to send the monitoring alerts to an email address you
specify in the Email ID ﬁeld. You can select Add Alert Email
multiple times to add multiple email addresses.
Note: Be sure to also set the email options in Integration Server
Administrator (go to Solutions > CloudStreams > Administration >
Email), as described in "Seing the E-mail Options for Logging
Payloads and Sending Performance Monitoring Alerts" on page
33.
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Validate Schema
This action validates all XML request and/or response messages against an XML schema
referenced in the WSDL. This action cannot be used for connector virtual services.
CloudStreams can enforce this policy action for messages sent between services. When
this policy is set for a virtual service, CloudStreams validates XML request messages,
response messages, or both, against the XML schema referenced in the WSDL. Be sure to
provide a schema.
Input Parameters
Validate SOAP
Message(s)

Validates the request and/or response messages.

Note: Be aware that CloudStreams does not remove wsu:Id aributes that may have
been added to a request by a consumer as a result of security operations against request
elements (signatures and encryptions). In this case, to avoid schema validation failures
you would have to add a Transform sub-step to the virtual service's In Sequence step so
that the requests are passed to an XSLT transformation ﬁle that removes the wsu:Ids.
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Overview of Deployment
You can deploy virtual services and Connector Virtual Services in two ways:
Deploy all virtual services, and any custom Connector Virtual Services, that are
contained in a particular CloudStreams Governance project.
OR
Deploy a single virtual service or custom Connector Virtual Service. Generally, this is
useful for testing purposes.
Note: CloudStreams automatically deploys the default Connector Virtual Services,
WmCloudStreams.SoapVS and WmCloudStreams.RestVS; there is no need for you to
deploy them.
When you execute the deployment operation, CloudStreams will immediately deploy
the service(s) and the following items to the CloudStreams server target(s) that you
specify:
The policies of each service, as well as any other artifacts that you associated with the
services when you created them.
The VSD (virtual service deﬁnition) of each virtual service or Connector Virtual
Service.
When you deploy a virtual service or Connector Virtual Service, CloudStreams
generates an XML document called a virtual service deﬁnition (VSD). The VSD deﬁnes
the virtual service or Connector Virtual Service for CloudStreams, and contains all
the resources required to deploy the service to a CloudStreams server, including the
policy that applies to the service. You cannot edit the VSD, but you can view it in the
Advanced page in the Properties view of each service.

Before You Deploy Virtual Services or Connector Virtual
Services
You should:
Ensure that all policies of the services are Active; the value of the Status ﬁeld in the
Properties view of each policy should be Active. If it is not, right-click the policy
name in the CloudStreams Governance view and click Active. You will not be
allowed to activate a policy unless all of its action parameters have been set.
Ensure that at least one CloudStreams server target has already have been deﬁned,
as described in "Deﬁning and Managing a CloudStreams Server Target" on page 59.
Ensure that each target's speciﬁed deployment URL is active and the user credentials
of Integration Server are valid.
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Ensure that you specify an HTTP or HTTPS port, as described in "Seing the General
Options" on page 30.
Test the server connection by going to the Software AG Designer menu, selecting
Window > Preferences > Software AG > CloudStreams Servers, and clicking the Test buon.
If the connection is not active and valid, activate the deployment endpoint and
modify the user credentials as required.

Deploying All Services in a CloudStreams Governance
Project
When you deploy a CloudStreams Governance project, all virtual services in the project
are deployed at once. If any custom Connector Virtual Services are deﬁned in the project,
they are deployed too.
When you deploy a project, Integration Server automatically creates a package to
support the project. The package name is the same as your project name. This package
includes startup/shutdown services to manage the registration of the virtual service
deﬁnitions (VSDs) when Integration Server restarts.
To deploy all services within a project

1. Open Software AG Designer and display the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Governance view, right-click the CloudStreams Governance
project you want to deploy, and click Deploy.

3. In the Deploy dialog box, choose one or more CloudStreams server targets to which to
deploy the services and click OK.

Note: If only one CloudStreams server target is available to select, this dialog box will
not appear.
The services are immediately deployed to the following location:
IntegrationServer_directory \instances\instance_name \packages
\<PackageName><ProjectName \conﬁg\proxies\VirtualService
If CloudStreams encounters a problem deploying or redeploying a service, it
displays a failure message in the deployment log at the boom of the page. In this
case, the CloudStreams administrator should take corrective action and redeploy the
service. For more information, see "What Happens When You Deploy a Service?" on
page 200.
If one of the virtual services fails deployment, you do not need to redeploy the entire
project; just correct the problem with the failed virtual service and then redeploy it
separately.
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Deploying a Single Service
To deploy a single virtual service or Connector Virtual Service

1. Open Software AG Designer and display the CloudStreams Development perspective.
2. Right-click the service name and click Deploy in the context menu.
3. In the Deploy dialog box, choose one or more CloudStreams server targets to which to
deploy the service and click OK.

Note: If only one CloudStreams server target is available to select, this dialog box will
not appear.
The service is immediately deployed to the following location:
IntegrationServer_directory \instances\instance_name \packages
\<PackageName><ProjectName \conﬁg\proxies\VirtualService
If CloudStreams encounters a problem deploying or redeploying a service, it
displays a failure message in the deployment log at the boom of the page. In this
case, the CloudStreams administrator should take corrective action and redeploy the
service. For more information, see "What Happens When You Deploy a Service?" on
page 200.

Undeploying Services
To undeploy a virtual service or Connector Virtual Service

1. Open Software AG Designer and display the CloudStreams Development perspective.
2. In the CloudStreams Governance view, expand the CloudStreams Governance project
that contains the services you want to undeploy.

3. Right-click either the project name (to undeploy all services) or the service name and click
Undeploy in the context menu.

CloudStreams immediately undeploys the service(s).

What Happens When You Deploy a Service?
When you deploy virtual services or Connector Virtual Services to CloudStreams
targets, keep the following points in mind.
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Policy Validation
When you deploy a service, CloudStreams automatically validates the service's policy
(or policies) to ensure that all action dependencies are properly met. CloudStreams will
warn you of any violation, and you will need to correct the violations before deploying
the service. For more information about dependencies, see "The Policy Actions" on page
171.

Policy Conflict Resolution Rules
When the combined list of actions is evaluated, policy conﬂicts can arise due to multiple
authentication or authorization actions. Conﬂicts between these actions are resolved as
follows.
Action Type

Resolution

Authentication actions:

One occurrence of each authentication
action that appears in the list is chosen.

Require HTTP Basic Authentication
Require WSS Username Token
Require X.509 Token
Require SAML Token
Authorization actions:
Authorize User

All occurrences of authorization
actions are chosen.

The Policy Conﬂict Resolution rules evaluate the actions from all policies in the
following order. The rules choose the actions for the eﬀective policy as follows:
Order

Action

Result Chosen for Effective Policy

1

Require SSL

One occurrence of the action is chosen
if one of the actions has its Client
Certificate Required parameter set to
Yes.

2

Require HTTP Basic
Authentication

One occurrence of the action is chosen.

3

Require WSS Username
Token

One occurrence of the action is chosen.
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Order

Action

Result Chosen for Effective Policy

4

Require WSS X.509 Token

One occurrence of the action is chosen.

5

Require WSS SAML Token

One occurrence of the action is chosen.

6

Require Signing

One occurrence of the action is chosen.

7

Require Encryption

One occurrence of the action is chosen.

8

Require Timestamps

One occurrence of the action is chosen.

9

Identify Consumer

One occurrence of the action is chosen.
CloudStreams evaluates the consumer
identiﬁers in all the actions and selects the
action with the highest-priority consumer
identiﬁer, as follows: 1.) IP address 2.)
Host name 3.) HTTP Authentication
token 4.) WS-Security token 5.) Custom
identiﬁcation token 6.) Consumer
certiﬁcate 7.) User ID.

10

Authorize User

All occurrences of the action are chosen.

11

Validate Schema

If at least one occurrence of the action
is conﬁgured to validate requests, and
at least one occurrence of the action is
conﬁgured to validate responses, then
an action is constructed to validate both
requests and responses.

12

Log Invocations

All occurrences of the action are chosen.

13

Monitor Service
Performance

All occurrences of the action are chosen.

14

Monitor Service Level
Agreement

All occurrences of the action are chosen.

15

Throling Traﬃc
Optimization

All occurrences of the action are chosen.
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What if You Need to Modify Deployed Services?
If you need to modify a virtual service that is already deployed, you must redeploy it
after you modify it. CloudStreams does not monitor for updates to deployed assets.
If you make changes to a virtual service's processing steps, for example, you must
manually redeploy the virtual service to put those changes into eﬀect.
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Overview
CloudStreams can publish key performance indicator (KPI) metrics and run-time events
to the CloudStreams Analytics dashboard. The dashboard enables you to view and
analyze the KPI metrics and run-time events of your CloudStreams connectors, cloud
connector services and consumers.
The dashboard is powered by a MashApp called CloudStreams Analytics, which is
powered by Software AG MashZone. CloudStreams Analytics uses data feeds from
Software AG MashZone and uses the Integration Server's JDBC connection pool to
publish this data at regular intervals.
Note: The datafeed of Software AG MashZone fetches data from an HTTP server.
However, CloudStreams uses a WmTomcat server located inside Integration Server
to retrieve metrics and events from the database and to send it back to Software AG
MashZone. Currently, CloudStreams cannot fetch data from an HTTPS server. Thus,
only the metrics and events generated by the outbound services are displayed in the
CloudStreams Analytics dashboard. The metrics and events generated by inbound
virtual services are not displayed in the CloudStreams Analytics dashboard, but this
data is captured and is available in your destination database (which you conﬁgure in
your JDBC connection pool, as described later in this chapter).
The dashboard displays the following analytic views:
View

Can be filtered by...

Connector performance and availability.

Provider and time
period.

API usage of connectors (total requests and data
volume).

Provider and time
period.

Error trends by consumer and provider.

Provider and time
period.

Service Level Agreement (SLA) violations and alerts,
shown by consumer and provider.

Provider and time
period.

Cloud connector service performance and availability.

Service and time period.

The results of service request transactions.

CloudStreams server
target, event type and
time period.
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The types of KPI metrics and run-time events in the views are listed below.

The Run-Time Events
The types of run-time events that can be published are as follows:
Event Type

Description

Lifecycle

A Lifecyle event occurs each time a CloudStreams connector
is started or shut down.

Transaction

A Transaction event occurs each time a cloud connector
service is invoked (successfully or unsuccessfully).

Error

An Error event occurs each time an invocation of a cloud
connector service results in an error.

Policy Violation

A Policy Violation event occurs each time an invocation of a
cloud connector service violates a policy that was set for its
associated virtual service.

Monitoring

CloudStreams publishes key performance indicator (KPI)
metrics, such as the average response time, fault count, and
availability of all connectors and connector services.

The Key Performance Indicator (KPI) Metrics
The types of KPI metrics that can be published are as follows:
Metric

Description

Availability

Indicates whether the connector or service was available
to the speciﬁed consumers in the current interval. For
information about intervals, see "Seing the Database
Options for Publishing Performance Metrics and Events" on
page 35.
A value of 100 indicates that the connector or service was
always available. If invocations fail due to policy violations,
this parameter could still be as high as 100.

Average Response
Time

The average amount of time it took the connector or cloud
connector service to complete all invocations in the current
interval. Response time is measured from the moment
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Metric

Description
CloudStreams receives the request until the moment it
returns the response to the caller.

Fault Count

The number of failed invocations made by a connector, cloud
connector service, or consumer in the current interval.

Success Count

The number of successful service invocations made by a
connector, cloud connector service, or consumer in the
current interval.

Total Request
Count

The total number of requests made by a connector, cloud
connector service, or consumer in the current interval.

To enable CloudStreams to publish KPI metrics and events to the CloudStreams
Analytics dashboard, you must set the options in "Seing the Database Options for
Publishing Performance Metrics and Events" on page 35.
Note: The metrics do not include metrics for failed invocations unless
you set the pg.PgMetricsFormatter.includeFaults parameter to true in
IntegrationServer_directory \instances\instance_name \packages\WmCloudStreams
\conﬁg\resources\wst-conﬁg.properties. For more information, see "Advanced
Seings" on page 275.

Installation and Configuration Tasks
Before you can use CloudStreams Analytics, you must perform the following tasks:
1. "Installing MashZone and Starting the MashZone Server" on page 209
2. "Copying the Required Resource Files for CloudStreams Analytics" on page 209
3. "Creating the Schema and Tables Required by CloudStreams Analytics" on page
210
4. "Creating a JDBC Connection Pool for CloudStreams" on page 212
5. "Conﬁguring the Data Feed" on page 216
6. "Importing the CloudStreams Analytics MashApp" on page 216
7. "Creating New Users for CloudStreams Analytics" on page 217
8. "Seing the Publishing Options for Performance Metrics and Events" on page 217
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Installing MashZone and Starting the MashZone Server
To install MashZone and start the server

1. Install Software AG MashZone from the Software AG Installer, as described in the document
Installing webMethods and Intelligent Business Operations Products.
On the Conﬁgure page of the wizard, accept the default ports and then specify the
desired system conﬁguration (Small, Medium or Large).

2. In your browser, connect to hp://localhost:4080/mashzone/login.jsp and log in using the
user name system and the password manager.

3. Click Open central user management.
4. Click the Licenses tab under Central User Management.
5. Enter the license by uploading the MashZone license ZIP archive MashZone_license.zip (to
do this, click the icon in the upper right corner of the screen).

6. Click the User Management tab under Central User Management.
7. Under the Users tab, click on the user system.
8. Click the Privilege tab and then click License privileges.
9. Click the Granted check box for MashZone User and MashZone Viewer.

Copying the Required Resource Files for CloudStreams Analytics
To copy the required resource files

1. Copy the file SAG_HOME \CloudStreamsAnalytics\mashapp\CloudStreams
Analytics.mzp into MASHZONE_HOME \server\bin\work\work_mashzone_s
\mashzone_data\importexport folder.

where MASHZONE_HOME is the base directory that you speciﬁed when you
installed MashZone (for example, C:\SoftwareAG\ppmmashzone).

2. Copy the contents of the folder SAG_HOME \CloudStreamsAnalytics\mashapp
\assets\colorschemes into the MASHZONE_HOME server\bin\work
\work_mashzone_s\mashzone_data\assets\colorschemes folder.

3. Copy the contents of the folder SAG_HOME \CloudStreamsAnalytics\mashapp
\resources into the MSAHZONE_HOME \server\bin\work\work_mashzone_s
\mashzone_data\resources folder.
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Creating the Schema and Tables Required by CloudStreams
Analytics
To create the schema and tables

1. Start the Database Component Configurator GUI as follows:
System

Action

Windows

On the Start menu, go to Program > Software AG > Tools > Database
Component Configurator.

UNIX

Go to Software AG_directory and run the command
dbConfigurator.sh.

2. In the Action area, in the Type list, click create.
The create action type creates the database components you select in the Action area,
and lets you create a database user and storage.

3. Click Component, and in the text box next to Component, select CloudStreamsEvents.
4. In the Version field, select Latest.
The conﬁgurator will create the latest version of the database component.

5. In the Connection area, in the RDBMS field, select the RDBMS in which to create the
database component.
A URL speciﬁc to the selected database appears in the URL ﬁeld.

6. Modify the URL to point to the database where the CloudStreams events should be collected.
Sample URL formats for the DataDirect Connect JDBC 5.0 driver are displayed.
Below is additional information for completing this ﬁeld.
For Oracle, if you are going to create storage and the Data Purge database
component, you must specify the sysLoginRole connection option on the URL
(for example: ;sysLoginRole=sysdba).
For DB2, if you are going to create database components in a schema other
than the default schema for the speciﬁed database user, you must specify these
connection options in the URL, where AlternateID is the name of the default
schema used to qualify unqualiﬁed database objects in dynamically prepared
SQL statements:
;AlternateId=schema ;”InitializationString=(SET CURRENT
PATH=current_path,schema )”
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For information about options supported by the DataDirect Connect JDBC 5.0
driver used by webMethods products, see DataDirect Connect for JDBC User's
Guide and Reference 5.0 in the Software AG_directory /_documentation directory.

7. In the User ID and Password fields, your entries depend on the task you are going to perform
as follows:
If you are...

Specify...

Creating a database user
and storage in Oracle or
SQL Server

The database user and password to create.
Note: For SQL Server, the user will be created and
a default schema named dbo will be assigned to
that user.
Note: For Oracle, do not use the SYSTEM user to
create the database components in the SYSTEM
schema.

Creating a database user
and storage in DB2 for
LUW

The OS user to which to grant permissions, and
the password for that user.

8. Select the Create Tablespaces check box. (To create tablespaces, you must have Admin
privileges for the database.)
Note: This check box is labeled Create Database and Database User for SQL Server, and
Create Tablespaces and Grant Permissions to OS User for DB2.
Note: For DB2 on Linux systems, tablespaces are created for each DB2 database. If
you are creating webMethods database components in more than one DB2 database,
either the tablespace directory or the tablespace names must be unique for each DB2
database.

9. In the Admin ID field, identify the database user or operating system user that has database
administrator credentials to create the database user and storage. Supply the password for the
user in the Admin Password field.

10. The next field and your entry depend on your RDBMS.
RDBMS

Field and Entry

Oracle or DB2
for LUW

In the Tablespace Directory ﬁeld, identify the directory in
which to create the tablespaces. For Oracle, use this ﬁeld
only if the DB_CREATE_FILE_DEST parameter is not set
for your Oracle instance.
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RDBMS

Field and Entry

SQL Server

In the Database ﬁeld, specify the database to create.

11. The default tablespace names are as follows:
RDBMS

Data Storage

Index Storage

BLOB Storage

Oracle

WEBMDATA

WEBMINDX

WEBMDATA

SQL

Primary

Primary

Primary

DB2 for LUW

WEBMDATA

WEBINDX

WEBMDATA

DB2 for iSeries

Default

Default

Default

12. For Oracle or DB2 for LUW, you can select the Use Custom Tablespace Names check box
and specify custom tablespace names in the fields. You must have Admin privileges to do
this.
For Oracle, the custom tablespace names will replace the defaults WEBMDATA
and WEBMINDX.
For DB2 for LUW, the custom tablespace names will replace the defaults
WEBMDATA, WEBMINDX, and WEBMBLOB. You can also specify a custom
name to use for the buﬀer pool for webMethods products (WEBMBUFF by
default).
Note: webMethods products support all tablespace conﬁgurations deployed by users.

13. Click Execute.
The execution information is displayed on the Results tab and is wrien to the log ﬁle
dcc_yyyymmddHHMMss in the Software AG_directory \common\db\logs directory. If
the execution is successful, all required tables are available.
If you intend to run the conﬁgurator more than once, you can set the current ﬁeld
values as the defaults for subsequent runs by clicking Save Settings as Default. You can
also export ﬁeld values to .xml ﬁles by clicking Export, then later import the values
from a ﬁle by clicking Import Conﬁguration. In each case, the values for the two
Password ﬁelds are not saved.

Creating a JDBC Connection Pool for CloudStreams
To create a JDBC connection pool for CloudStreams

1. Start Integration Server and open Integration Server Administrator.
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2. Go to the Settings > JDBC Pools page.
3. On the Settings > JDBC Pools page, click Create a new Pool Alias Definition and complete the
fields to point to the tables you created in "Creating the Schema and Tables Required by
CloudStreams Analytics" on page 210, as follows.
Field

Entry

Alias Name

Specify a name for the connection pool.

Alias Description

Description for the pool.

Associated Driver
Alias

Database driver to use.

Database URL

URL for the database server. Sample URL formats for the
DataDirect Connect JDBC 5.0 driver are displayed.
Use the DataDirect Connect connection option
MaxPooledStatements=35 on the database URL. This
connection option improves performance by caching
prepared statements.
For DB2, if Integration Server will connect to a schema
other than the default schema for the speciﬁed database
user, you must specify these connection options in the
URL:
;AlternateId=schema ;”InitializationString=(SET
CURRENT
PATH=current_path,schema )”;MaxPooledStatements=35

speciﬁes the name of the default schema
that is used to qualify unqualiﬁed database objects in
dynamically prepared SQL statement.
AlternateId

User ID

Database user for Integration Server to use to
communicate with the database.

Password

Password for the database user.

Minimum
Connections

Minimum number of connections the pool must keep open
at all times.
If you use this pool alias for more than one function, each
pool instance keeps the speciﬁed number of connections
open. For example, if you specify keeping at least 3
connections open, and the IS Core Audit Log and the
Document History database components both use this
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Field

Entry
pool, the pool keeps a total of 6 connections open: 3 for the
IS Core Audit Log pool instance and 3 for the Document
History pool instance.
If your logging volume has sudden spikes, you can
improve performance by making sure the connections
needed to handle the increased volume open quickly. You
can minimize connection startup time during spikes by
seing this value higher, so that more connections remain
open at all times.

Maximum
Connections

Maximum number of connections the pool must keep open
at all times.
Calculate this value as part of the total possible number
of connections that could be opened simultaneously by
all functions and applications that write to the database.
Make sure the total number does not exceed the database's
connection limit. If one of the applications opens more
connections than the database allows, the database will
reject subsequent requests for connections from any
application.

Idle Timeout

Period of time, in milliseconds, the pool can keep an
unused connection open. After the speciﬁed period of
time, the pool closes unused connections that are not
needed to satisfy the Minimum connections value.
Note: You should also consider seing connection timeouts
as described in "SQL Statement Execution and Connection
Timeouts" on page 215.

4. Click Save Settings.
5. Click Return to JDBC Pool Definitions.
6. In the Functional Alias Definitions table, locate the functional name CloudStreams.
7. Click Edit under the Edit Association column.
8. In the JDBC Functional Alias field under Associated Pool Alias, select the connection pool
alias you created.

9. Make sure Integration Server can connect to the database by clicking Test Connection.
10. Click Save Settings.
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SQL Statement Execution and Connection Timeouts
The CloudStreams event-sending component relies on the JDBC pools connection
properties for conﬁguring the DataDirect driver properties.
It is expected that any DataDirect driver seings will be conﬁgured via property seings
in the connection URL. Minimally, it is recommended that timeouts be conﬁgured for
connections and SQL statement execution since by default the DataDirect driver uses "0"
for its default seings (which implies that no timeouts are used).
Following is a sample connection URL with the property seings QueryTimeout and
LoginTimeout:
jdbc:wm:oracle://<server> :<1521|
port> ;serviceName=<value> ;QueryTimeout=<seconds> ;LoginTimeout=<seconds>
Note the following:
The LoginTimeout property controls connection timeouts.
If LoginTimeout is not speciﬁed, the connection pool will use the value of the global
Integration Server property watt.server.jdbc.loginTimeout to aempt to connect to
the database.
The watt.server.jdbc.loginTimeout property is located in
IntegrationServer_directory \instances\instance_name \conﬁg\server.cnf. This
property sets the maximum time, in seconds, that the JDBC driver on Integration
Server is to wait for a response while aempting to connect to a database. If
Integration Server does not receive a response in the alloed time, it terminates the
request, logs the error and moves on. The default value is 60 seconds.
Note: The DataDirect property LoginTimeout takes precedence over the global
Integration Server property watt.server.jdbc.loginTimeout, which means you can
override the global property on a case-by-case basis.
The QueryTimeout property controls timeouts for queries and for inserting events.
Although the name QueryTimeout suggests its scope is limited to queries, it actually
applies to all SQL statements, including INSERTs.
If The QueryTimeout property is not speciﬁed, there is no timeout for SQL statements
executing on connections in this pool. So it is recommended that you specify a
QueryTimeout value for this pool.
If you experience timeouts while inserting events, you should consider increasing
the QueryTimeout property (and/or reducing the CloudStreams property
pg.jdbc.batchSize, which is described below).
The CloudStreams property pg.jdbc.batchSize controls the size of the events batch.
CloudStreams uses the optimized JDBC batch API to send its events to the relational
database using prepared statements. The CloudStreams property pg.jdbc.batchSize
controls how many events the sender can insert into a given batch (25 events
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by default). So, a batch of events is sent to the database every time the value of
pg.jdbc.batchSize is reached. Increasing the batch size can improve database
performance, but will also increase the statement execution time.
The pg.jdbc.batchSize property is located in:
IntegrationServer_directory \instances\instance_name \packages\WmCloudStreams
\conﬁg\resources\wst-conﬁg.properties
Additionally, if more than 3 seconds elapse since the last batch was sent, any
received events will be sent to the database, even if the batch threshold has not been
reached. This ensures there is not a substantial delay between the time an event is
created and when it is inserted into the table.

Configuring the Data Feed
To configure the data feed

1. Open the file conﬁg.xml located in the MASHZONE_HOME \server\bin\work
\work_mashzone_s\mashzone_data\resources folder.

2. Set the host and port to point to the Integration Server's host and port.
The default host and port is localhost and 5555, respectively.

Importing the CloudStreams Analytics MashApp
To import the CloudStreams Analytics MashApp

1. Login to MashZone using your credentials. If you selected the default MashZone
administrator credentials during installation, the default credentials are:
User name: system
Password: manager

2. Go to Administration > Licensing and add the License Key.
3. Go to Administration > Import/Export/Delete and click the Import button.
4. In the Select File dialog box, select CloudStreams Analytics.mzp and click OK.
5. Go to the MashZone Home page, where you should see the MashApp named CloudStreams
Analytics.

6. Verify the imported MashApp as follows:
a. Login to MashZone using your credentials. If you selected the default MashZone
administrator credentials during installation, the default credentials are: User name is
system and Password is manager.
b. Click the MashApps tab and select the CloudStreams Analytics MashApp.
c. Double-click CloudStreams Analytics to open the MashApp.
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d. You should see the Cloud Connector Performance Summary tab.

Creating New Users for CloudStreams Analytics
To enable users to access CloudStreams Analytics, you must create those users in
MashZone.
You can create users using the following procedure, or you can import users and user
groups from your LDAP system to MashZone and update the data of already imported
LDAP users. For details about importing users from your LDAP system, see the chapter
"Import LDAP Users and User Groups" chapter in the Software AG MashZone Online
Help.
Note: Prerequisite: You must have MashZone Administrator privileges.
To create a new user in MashZone

1. Login to MashZone using your credentials. If you selected the default MashZone
administrator credentials during installation, the default credentials are:
User name: system
Password: manager

2. Click the User Management Tab > User tab.
3. Create a new user.
4. The new user can login to CloudStreams Analytics using the login and password entered
here.

Setting the Publishing Options for Performance Metrics and Events
CloudStreams uses the Integration Server's JDBC connection pool to publish the
performance metrics and events. To enable CloudStreams to publish performance
metrics and events to the CloudStreams Analytics dashboard, you must set the options
described in "Seing the Database Options for Publishing Performance Metrics and
Events" on page 35.

Using the CloudStreams Analytics Dashboard
After you have completed the "Installation and Conﬁguration Tasks" on page 208,
login to the dashboard as follows.
To login to the dashboard

1. Login to MashZone using your credentials. If you selected the default MashZone
administrator credentials during installation, the default credentials are:
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User name: system
Password: manager

2. Click the MashApps tab and select the CloudStreams Analytics MashApp.
3. Double-click CloudStreams Analytics to open the MashApp.
4. The MashApp's first view, called Cloud Connector Performance Summary, is
displayed.
The dashboard provides the following views:
"Cloud Connector Performance Summary View" on page 218
"Cloud Connector API Usage View" on page 219
"Cloud Connector Performance View" on page 220
"Cloud Connector Error View" on page 222
"Cloud Connector Service Level Agreement (SLA) View" on page 223
"Service View" on page 224
"Transaction View" on page 226

Cloud Connector Performance Summary View
This view provides a summary of all CloudStreams connectors' performance and
availability. It lists all connectors and their availability, performance and status.
To use the Cloud Connector Performance Summary view

1. Open the CloudStreams Analytics MashApp, as described in "Using the CloudStreams
Analytics Dashboard" on page 217.

By default, the Cloud Connector Performance Summary view is the ﬁrst view
displayed in the dashboard.

2. This view displays the following information about all CloudStreams connectors installed in
CloudStreams:
Field

Description

Status

There are two possible statuses:
Error: The reason for the error appears in the Performance and
Availability Summary column.
OK: The connector is operating normally.

Cloud Connector

The cloud connector's name, for example Salesforce.
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Field

Description

Performance
and Availability
Summary

The reason for the connector's status. One reason for Error
status would be Availability of less than 80%.

Performance

The average response time (in milliseconds) that it took the
connector to complete all invocations in the current interval.
Response time is measured from the moment CloudStreams
receives the request until the moment it returns the response
to the caller. For information about intervals, see "Seing the
Database Options for Publishing Performance Metrics and
Events" on page 35.

Availability

The percentage of time that the connector was available during
the current interval. A value of 100 indicates that the connector
was always available. Availability of less than 80% results in
Error status.

Cloud Connector API Usage View
This view shows the API usage of one or all connectors, ﬁltered by cloud provider and
time period.
To use the Cloud Connector API Usage view

1. Open the CloudStreams Analytics MashApp, as described in "Using the CloudStreams
Analytics Dashboard" on page 217.

2. Click the Usage tab in the dashboard.
3. Filter the metrics you want to view as follows:
Filter

Description

Cloud
Provider

Choose one cloud provider or choose All.

Period

The time period for which to view API usage:
Last 90 Days: The previous 90 days, including today.
Last 30 Days: The previous 30 days, including today.
Last 7 Days: The previous 7 days, including today.
Last 1 Day: The previous 24 hours.
Last 1 Hour: The previous hour.
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4. This view displays the following information:
Field

Description

Cloud Providers by Number
of Requests

Shows each provider's percentage of the total number
of requests received during the speciﬁed time period.

Cloud Providers by Data
Volume

Shows each provider's percentage of the request/
response payload size sent and received during the
time period.

Top 5 - Cloud Connector
Services by Number of
Requests

Shows the ﬁve cloud connector services that received
the most requests during the speciﬁed period. Point to
a bar to view the exact number.

Top 5 - Cloud Connector
Services by Data Volume

Shows the ﬁve cloud connector services that received/
sent the largest amount of request/response payload
data (in Kilobytes). Point to a bar to view the exact
number.

Top 5 - Consumers by
Number of Requests

Shows the ﬁve consumers that sent the most requests.
Point to a bar to view the exact number.

Top 5 - Consumers by Data
Volume

Shows the ﬁve consumers that sent the largest amount
of request/response payloads (in Kilobytes). Point to a
bar to view the exact number.

Cloud Connector Performance View
This view shows the following metrics, ﬁltered by cloud provider and time period:
Performance (average response time) of cloud connector services. Performance is
shown by provider, consumer and individual cloud connector services.
Average response time is the average amount of time (in milliseconds) it took the
cloud connector service to complete all invocations in the current interval. Response
time is measured from the moment CloudStreams receives the request until the
moment just before it returns the response to the caller. By default, the average
response time does not include metrics for failed invocations. For information about
intervals, see "Seing the Database Options for Publishing Performance Metrics and
Events" on page 35.
Availability of cloud connector services. Availability is shown by consumer and
individual connector services.
Availability indicates the percentage of time that the cloud connector service
was available during the current interval. A value of 100 indicates that the
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cloud connector service was always available. Only the time when the service is
unavailable counts against this metric. If invocations fail due to policy violations, this
parameter could still be as high as 100. For information about intervals, see "Seing
the Database Options for Publishing Performance Metrics and Events" on page 35.
To use the Cloud Connector Performance view

1. Open the CloudStreams Analytics MashApp, as described in "Using the CloudStreams
Analytics Dashboard" on page 217.

2. Click the Performance tab in the dashboard.
3. Filter the metrics you want to view as follows:
Filter

Description

Cloud
Provider

Choose one cloud provider or choose All.

Period

The time period for which to view performance:
Last 90 Days: The previous 90 days, including today.
Last 30 Days: The previous 30 days, including today.
Last 7 Days: The previous 7 days, including today.
Last 1 Day: The previous 24 hours.
Last 1 Hour: The previous hour.

4. This view displays the following information:
Field

Description

Cloud Provider Performance Trends

Shows the average response time for each
provider.

Cloud Consumer Performance
Trends

Shows the average response time for each
consumer.

Top 5 - Cloud Connector Services by
Average Response Time

Shows the average response time of the ﬁve
fastest cloud connector services.

Slowest 5 - Cloud Connector
Services by Average Response Time

Shows the average response time of the ﬁve
slowest cloud connector services.

Top 5 - Cloud Connector Services by
Availability

Shows the three cloud connector services with
the highest availability.
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Field

Description

Lowest 5 - Cloud Connector Services
by Availability

Shows the three cloud connector services with
the lowest availability.

Cloud Connector Error View
This view shows service request error trends.
To use the Cloud Connector Error view

1. Open the CloudStreams Analytics MashApp, as described in "Using the CloudStreams
Analytics Dashboard" on page 217.

2. Click the Error tab in the dashboard.
3. Filter the metrics you want to view as follows:
Filter

Description

Cloud
Provider

Choose one cloud provider or choose All.

Period

The time period for which to view performance:
Last 90 Days: The previous 90 days, including today.
Last 30 Days: The previous 30 days, including today.
Last 7 Days: The previous 7 days, including today.
Last 1 Day: The previous 24 hours.
Last 1 Hour: The previous hour.

4. This view displays the following information:
Field

Description

Cloud Provider Error Trends

Shows the number of service request errors returned
by each provider.

Consumer Error Trends

Shows the number of service request errors
encountered by each consumer.

Top 5 - Services by Fault
Count

Shows the ﬁve cloud connector services that returned
the highest number of faults.
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Field

Description
The fault count indicates the number of failed requests
for the service for the current interval. For information
about intervals, see "Seing the Database Options for
Publishing Performance Metrics and Events" on page
35.

Lowest 5 - Services by Fault
Count

Shows the ﬁve cloud connector services that returned
the fewest number of faults.

Cloud Connector "Service Level Agreement" (SLA) View
This view shows the violations and alerts that were generated by the "Monitor Service
Level Agreement" action, ﬁltered by cloud provider and time period. (You can include
the "Monitor Service Level Agreement" action in the policies for virtual services and
Connector Virtual Services; for details, see "Monitor Service Level Agreement (SLA)" on
page 182.)
To use the Cloud Connector "Service Level Agreement" (SLA) view

1. Open the CloudStreams Analytics MashApp, as described in "Using the CloudStreams
Analytics Dashboard" on page 217.

2. Click the SLA (Service Level Agreement) tab in the dashboard.
3. Filter the metrics you want to view as follows:
Filter

Description

Cloud
Provider

Choose one cloud provider or choose All.

Period

The time period for which to view performance:
Last 90 Days: The previous 90 days, including today.
Last 30 Days: The previous 30 days, including today.
Last 7 Days: The previous 7 days, including today.
Last 1 Day: The previous 24 hours.
Last 1 Hour: The previous hour.

4. This view displays the following information:
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Field

Description

SLA Violation Trends

Shows the number of Service Level Agreement
(SLA) violations received by each cloud
provider.

SLA Violations by Cloud Provider

Shows the total number of SLA violations
received by each cloud provider.

SLA Violations by Consumer

Shows the total number of SLA violations sent
by each consumer.

Top 5 - Services by SLA Violation

Shows the ﬁve cloud connector services that
received the most SLA violations.

Top 5 - Services by Monitoring Alerts

Shows the ﬁve cloud connector services that
received the most monitoring alerts generated
by the SLA violations. (Remember that alerts
may or may not be sent every time a violation
occurs; this is controlled by the Alert Frequency
parameter of the "Monitor Service Level
Agreement" action.)

Monitoring Alerts by Event Source

Shows the number of monitoring alerts
generated by the various run-time events.

SLA Violations by Event Source

Shows the number of SLA violations generated
by the various run-time events.

Service View
This view shows the run-time performance of cloud connector services. It can be ﬁltered
by provider, connector and date range.
To use the Service View

1. Open the CloudStreams Analytics MashApp, as described in "Using the CloudStreams
Analytics Dashboard" on page 217.

2. Click the Service View tab in the dashboard.
3. Filter the metrics you want to view as follows:
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Filter

Description

Cloud
Provider

Choose one cloud provider or choose All.

Cloud
Connector

Choose one cloud connector or choose All.

Date Range

Choose one of the following values or click Timeframe and choose the
start and end dates from the calendars.
Last 90 Days: The previous 90 days, including today.
Last 30 Days: The previous 30 days, including today.
Last 7 Days: The previous 7 days, including today.
Last 1 Day: The previous 24 hours.
Last 1 Hour: The previous hour.

4. This view displays the following information:
Field

Description

Provider Name

The cloud provider name.

Connector Name

The connector name.

Service Name

The cloud connector service name.

Total Requests

Total number of requests for the service, sorted in descending
order (by the services requested the most).

Fault Count

Number of faults that the service returned.

Success Count

Number of successful requests for the service.

Average Response
Time

Average response time for the service.

Total Bytes of Data

Total size of all request/response payloads.
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Transaction View
This view shows the event results of all request transactions for cloud connector
services. It can be ﬁltered by provider, connector, service, event type and date range.
To use the Transaction View

1. Open the CloudStreams Analytics MashApp, as described in "Using the CloudStreams
Analytics Dashboard" on page 217.

2. Click the Transaction View tab in the dashboard.
3. Filter the metrics you want to view as follows:
Filter

Description

Cloud
Provider

Choose a cloud provider or choose All.

Cloud
Connector

Choose a cloud connector or choose All.

Service
Name

Choose a service or choose All.

Event Type

Choose any of the following event types or choose All:
Error: An Error event occurs each time a cloud connector service
invocation results in an error.
Policy Violation: A Policy Violation event occurs each time a cloud
connector service invocation violates a policy that was set for its
associated virtual service.
Transaction: A Transaction event occurs each time a cloud connector
service is invoked (successfully or unsuccessfully).
Monitoring: CloudStreams publishes key performance indicator
(KPI) metrics, such as the average response time, fault count, and
availability of all connectors and connector services.
Note: To enable CloudStreams to publish these events, you must set
the options described in "Seing the Database Options for Publishing
Performance Metrics and Events" on page 35.

Date Range

Choose one of the following values or click Timeframe and choose the
start and end dates from the calendars.
Last 90 Days: The previous 90 days, including today.
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Filter

Description
Last 30 Days: The previous 30 days, including today.
Last 7 Days: The previous 7 days, including today.
Last 1 Day: The previous 24 hours.
Last 1 Hour: The previous hour.

4. This view displays the following information:
Field

Description

Provider
Name

The cloud provider name.

Connector
Name

The connector name.

Service
Name

The cloud connector service that was requested.

Event Type

The event type that resulted (Error, Policy Violation, Transaction or
Monitoring).

Session ID

The SOAP invocation session ID that generated the event.

Target
Name

The CloudStreams server target that generated the event.

Event
Create
Timestamp

The event timestamps, sorted in descending order (the most recent
timestamps ﬁrst).

Error/Alert
Source

The source of errors and alerts generated by Error, Policy Violation
and Monitoring events.

Error/Alert
Description

Descriptions of the errors and alerts generated by Error, Policy
Violation and Monitoring events.

Lifecycle
Status

The status generated by a Lifecycle event.
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Overview of Creating Custom Cloud Connectors
Although CloudStreams provides predeﬁned CloudStreams connectors for some SaaS
applications (for example, Salesforce.com), you might want to create custom cloud
connectors for other SaaS applications, which you can deploy to CloudStreams. You
use the CloudStreams Development plug-in to create and conﬁgure custom cloud
connectors.
The three high-level steps to create a custom cloud connector are:
1. Create a CloudStreams Provider project in which you will deﬁne the cloud
connector.
2. Create the custom cloud connector by specifying:
The SaaS provider's WSDL (for SOAP connectors) or XSD (for REST connectors).
A metadata handler provided by CloudStreams, which provides the appropriate
SOAP or REST data model for the SaaS provider.
The necessary cloud connector services, as follows:
For a SOAP-based SaaS provider, you should create at least one cloud
connector service for each operation deﬁned in the provider’s WSDL. For
example, for a query operation, you might create a cloud connector service to
query accounts and another to query contacts.
For a REST-based SaaS provider, you should create at least one cloud
connector service for each REST resource on which the connector can operate.
One or more run-time connections to the SaaS application.
3. Finally, you need to develop the governance functionality for the custom cloud
connector, the same way you develop governance for a predeﬁned CloudStreams
connector. That is, you will:
a. Use the CloudStreams Development plug-in to conﬁgure:
Virtual services and connector virtual services (as described in "Virtual
Services" on page 55).
Policies that provide governance capabilities for the virtual services and
connector virtual services (as described in "Policies" on page 165).
The CloudStreams Analytics dashboard (as described in CloudStreams
Analytics).
b. Use the Integration Server Administrator to set the CloudStreams conﬁguration
options (as described in "CloudStreams Conﬁguration Options" on page 29).
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Creating and Managing CloudStreams Provider Projects
You must create a CloudStreams Provider project in which you will deﬁne the cloud
connector. You can perform several management tasks for Provider projects, such as
exporting them to (and importing them from) your local ﬁle system, deleting them, and
more.

Creating CloudStreams Provider Projects
To create a CloudStreams Provider project

1. In Software AG Designer, open the CloudStreams Development perspective by clicking
Window > Open Perspective > CloudStreams Development.

2. Click the CloudStreams Connectors view on the left side of the page.
3. Click File > New > CloudStreams Provider Project from the menu.
4. In the New CloudStreams Provider Project wizard, assign a name to the project and click
Finish.

Field

Description

Project Name

A name that is a valid resource name on your operating system.
The name must not be null and cannot be an empty string.
Reserved words and characters that are used in Java or C/C++
(such as for, while, and if).
Digits as their ﬁrst character.
Spaces.
Control characters and special characters like periods (.),
including:
Characters outside of the basic ASCII character set, such as
multi-byte characters.

Managing CloudStreams Provider Projects
To manage a CloudStreams Provider project

1. In Software AG Designer, open the CloudStreams Development perspective by clicking
Window > Open Perspective > CloudStreams Development.

2. Click the CloudStreams Connectors view on the left side of the page.
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3. Right-click the CloudStreams Provider project and select a menu item such as:
Export: Exports the Provider project to your local ﬁle system. Complete the
wizard to indicate the export destination and click Finish. A project with
deployed artifacts should be undeployed before being exported.
Import: Imports the Provider project from your local ﬁle system. Complete the
wizard to indicate the import destination and click Finish.
Delete: Deletes the Provider project from the CloudStreams Development
perspective.

Creating Custom SOAP or REST Cloud Connectors
The CloudStreams Development plug-in provides a wizard and editors you use to create
and conﬁgure a cloud connector.
To create a custom cloud connector

1. Ensure that you have defined a CloudStreams server target to which you will deploy
the cloud connector. For the procedure to do this, see "Deﬁning and Managing a
CloudStreams Server Target" on page 59.

2. Ensure that you have created a CloudStreams Provider project in which you will define

the cloud connector, as described in "Creating and Managing CloudStreams Provider
Projects" on page 231.

3. Right-click the Connectors folder and select New Cloud Connector (or right-click the

CloudStreams Provider project you just created and select New Cloud Connector). Complete
the fields in the New Cloud Connector wizard as follows.
Parameter

Description

Project

Click Browse and select the CloudStreams Provider project you
just created.

Name

Assign a name for the cloud connector. The name must start
with an alpha character and may contain numerals and the
following special characters:
- (hyphen)
_ (underscore)
' (apostrophe)
, (comma)
" (double quotes)
. (period)
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Parameter

Description
& (ampersand)
() (parentheses)
! (exclamation)

Version

Assign a version identiﬁer for the cloud connector. The
version identiﬁer is a required aribute that you should
increment when a connector is modiﬁed to indicate that the
cloud connector has been updated. This is a "public" version
identiﬁer that Designer shows to developers when it displays
the list of connectors. The name may contain numerals and the
following special characters:
- (hyphen)
_ (underscore)
. (period)

ID

Assign a unique identiﬁer for the connector. This value must
start with an alpha character and may contain numerals and
the following special characters:
- (hyphen)
_ (underscore)
. (period)

Group

Optional. You can specify that the connector should belong
to a particular group. A group is a logical grouping of a
collection of connectors.
For example, if you have multiple connectors for the same
provider, you might want to group them together for
convenience. Suppose you have two connectors for the
Amazon provider: one connector that is provided by Software
AG (e.g., the webMethods CloudStreams Amazon EC2
Connector), and another connector for the Amazon provider
that was custom-built. You might want to group them together
into a group called AmazonProvider.
To specify a group for the connector, type a group name in
this ﬁeld or select an existing group name from the drop-down
list. The name must start with an alpha character and may
contain numerals and the following special characters:
- (hyphen)
_ (underscore)
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Parameter

Description
' (apostrophe)
, (comma)
" (double quotes)
. (period)
& (ampersand)
() (parentheses)
! (exclamation)
If you specify a group, the connector will be added to the
<group_name> folder (under CloudStreams > Providers).
If you do not specify a group, the connector will be added to
your CloudStreams Provider project.
Note: The group will be visible in the Integration Server
Administrator's Connector List (under Solutions > CloudStreams >
Providers) if at least one connector is in the deployed state.

Metadata
Handler

CloudStreams provides two kinds of metadata handlers,
which provide the appropriate SOAP data model for the SaaS
provider. Click Browse and select a metadata handler.
For a SOAP-based SaaS provider, select the SOAP metadata
handler WsdlConnectorMetadataHandler.
For a REST-based SaaS provider, select the REST metadata
handler RestConnectorMetadataHandler.

Description

Optional. Type a description of the cloud connector.

4. Click Next and create a cloud connector service based on the provider's WSDL or XSD that
you specify as follows.
Note: Optionally, instead of clicking Next you can click Finish. If you choose to
click Finish, you can create the cloud connector service later, using the Services
Conﬁguration page as described in "Conﬁguring Cloud Connector Services (SOAP)"
on page 242.
Parameter

Description

WSDL (SOAP
only)

Specify the SaaS provider's WSDL that CloudStreams will use
to generate the document types by selecting either:
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Parameter

Description
File. Specify the WSDL ﬁle name, or click Browse and select
the WSDL from your local ﬁle system.
URL. Specify the URL of the WSDL.

XSD (REST
only)

Specify the SaaS provider's XSD that CloudStreams will use to
generate the document types by selecting either:
Namespace. Specify the XSD's namespace (for example

myConnector_v1.doctypes). Alternatively, click Browse
and select a doctype that has already been generated in

Integration Server.

XSD. Specify the URL of the XSD in the text ﬁeld, or click
Browse and select an XSD.
Connector
Package

Assign a name for the connector package, which will be
deployed to the CloudStreams target server.
The name must be a valid resource name on your operating
system. The name must not be null and cannot be an empty
string. The name cannot contain:
Reserved words and characters that are used in Java or C/C++
(such as for, while, and if).
Digits as their ﬁrst character.
Spaces.
Control characters and special characters like periods (.),
including:
Characters outside of the basic ASCII character set, such as
multi-byte characters.
CloudStreams will generate the document types from the
provider's WSDL or XSD. However, if the Namespace option
is chosen in the XSD ﬁeld, then doctypes will not be generated.
CloudStreams automatically generates a name for the
namespace that will contain the provider's document types.
The name's form is: packageName .connector_ID .doctypes.
When additional services are added, CloudStreams adds the
document types to this namespace.

Description

Optional. Type a description of the cloud connector service.

5. Click Finish.
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The new cloud connector is added to your CloudStreams Provider project.
In addition, if you completed page two of the wizard, CloudStreams creates a service
for the cloud connector, based on the WSDL or XSD you speciﬁed in the wizard.

6. Next, perform the steps in "Conﬁguring Custom SOAP Cloud Connectors" on page
236 or "Conﬁguring Custom REST Cloud Connectors" on page 248.

Configuring Custom SOAP Cloud Connectors
After you create a cloud connector as described above, you need to conﬁgure it as
follows.
"Creating Run-Time Connections (SOAP)" on page 236.
"Conﬁguring Cloud Connector Services (SOAP)" on page 242.

Creating Run-Time Connections (SOAP)
You need to create one or more run-time connections to the SaaS provider.
To create a run-time connection (SOAP)

1. Start Software AG Designer and open the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Connectors view, expand your CloudStreams Provider project and click
the cloud connector you just created (as described in "Creating Custom SOAP or REST
Cloud Connectors" on page 232).

The Overview page is displayed, showing the general information you deﬁned in the
New Cloud Connector wizard.

3. Click the Connections link in the Plug-In Content section of the page (or click the
Connections tab at the bottom of the page).

The Connections Conﬁguration page is displayed.

4. Create a run-time connection by right-clicking the Connections node, selecting Add

Connection and assigning a name and optional description to the connection. The name
cannot contain special characters.
CloudStreams creates the connection in the Connections node, and by default it will
contain a Groups node.

5. Add one or more groups that should be allowed to access the connection.
The Groups node contains a default group called Group1. Click Group1 and complete
the ﬁelds in the Conﬁguration section of the page as follows.
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Field

Description

Name

The default group name is Group1. You may rename this
group.
Connection group names cannot have spaces or use special
characters reserved by Integration Server or Designer. For
more information about the use of special characters, see the
Designer Service Development online help.

Group Type

Only one instance of each group type shown below may be
selected for a provider connector's connection conﬁguration.
oauth: Indicates that the group is deﬁned with the
authentication type of OAuth.
protocol: Indicates that the group is deﬁned with the HTTP
transport protocol that the connection will use.
connection: Indicates that the group is deﬁned with the login
endpoint to initiate communication with the SaaS provider.
requestHeaders: Indicates that the group is deﬁned with the
names of the HTTP request headers to include when sending
the login request.
credentials: Indicates that the group is deﬁned with a user
account on the SaaS provider that the connection will use to
connect to the SaaS provider.
aws_v2: Indicates that the user will use Signature Version 2 to
sign Amazon Web Services Query API requests.
aws_s3: Indicates that the group is deﬁned for the Amazon
S3 authentication scheme and it uses the AWSAccessKeyId
and the AWSSecretAccessKey of the client to authenticate the
requests.
aws_v4: Indicates that the user will use Signature Version 4 to
sign Amazon Web Services Query API requests.
custom: A user-deﬁned group.

Description

Optional. Type a description for the connection group.

Fields

Based on the group type you selected above, CloudStreams
displays the applicable ﬁelds for which you should specify
values. Required ﬁelds are marked with an asterisk. Refer to
the table below.

Administering webMethods CloudStreams Version 9.6

237

M

Even Header

Based on the group type you selected above, CloudStreams displays the applicable
ﬁelds for which you should specify values, as follows:
If the group type is...

The available fields are...

oauth

oauthAliasKey: The alias of a conﬁgured OAuth token.

protocol

elementCharSet: The encoding to use for the HTTP request
line, headers, etc.
contentCharSet: The encoding to use for the request message.
httpVersion: The HTTP version (HTTP/0.9, HTTP/1.0 or
HTTP/1.1. The default value for the connection factory is
HTTP/1.1.
userAgent: The value to the connection conﬁguration will
send for the User-Agent request header.
useExpectContinue: If true, use the Expect/Continue HTTP/1.1
handshake and send the Expect request header.
waitForContinue: The number of milliseconds that the
connection factory's client connection should wait for a "100
Continue" response from the server.
useStrictTransferEncoding: If true, the connection factory
connection raise an exception if the "Transfer-Encoding"
header is invalid.
useChunking: If true, use HTTP/1.1 chunking, using a chunk
size that matches the socket buﬀer size.
flowServerRedirects: If true, follow server redirects.
serverRedirectMax: Maximum number of times to follow a
server redirect.

connection

providerURL: The native provider endpoint target for the
connection conﬁguration. The default conﬁguration ﬁeld
provided with the connection factory is cn.providerURL.
minPoolConnections: The minimum number of socket
connections to reserve for a connection conﬁguration alias.
maxPoolConnections: The maximum number of socket
connections to reserve for a connection conﬁguration alias.
connectTimeout: The number of milliseconds a connection
aempt will wait before giving up. (0 will wait indeﬁnitely.)
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If the group type is...

The available fields are...
readTimeout: The number of milliseconds in which the the
client must read a response message from the server. (0 will
wait indeﬁnitely.)
useStaleChecking: If true, the connection factory performs
additional processing to test the socket to see if it is still
functional each time it is used.
retryCount: How many times should the connection factory
aempt to execute a failed invocation.
retryOnResponseFailure: If true, the retry mechanism will
be used for failed responses even if the request was sent
successfully.
useTcpNoDelay: If true, do not use Nagles algorithm as a
socket optimization technique.
linger: Determines how quickly a socket should close.
bufferSize: The size of the read and write socket buﬀers, in
bytes.
reuseAddr: If true, the socket will be reused even if it is in
TIME_WAIT due to a previous socket closure.
sessionToken: Session token for a stateful session.
webproxyAlias: The alias to a web proxy server conﬁguration
in Integration Server.
truststoreAlias: Alias for the Integration Server trust store
conﬁguration.
hostnameVerifier: Fully qualiﬁed class name that implements
the Apache HC org.apache.http.conn.ssl.X509HostnameVerifier
interface; helps guard against "man-in-the-middle"
aacks. Also set the IS property watt.security.cert.
wmChainVerifier.trustByDefault to false and ensure
the outbound connector's connection conﬁguration
property Hostname verifier is set to its default value,
org.apache.hp.conn.ssl.StrictHostnameVeriﬁer.

requestHeaders

names: An array of request header names to include for this
connection conﬁguration. The value should be a commadelimited list of header names; for example ContentType,SOAPAction.
values: An array of request header values to include for
this connection conﬁguration. The value should be comma-

Administering webMethods CloudStreams Version 9.6

239

M

Even Header

If the group type is...

The available fields are...
delimited list of values in the same order as the header
names; for example, text/xml,login.

credentials

username: The username credentials for the current
connection conﬁguration.
password: The password credentials for the current
connection conﬁguration
preemptiveAuth: If true, basic auth credentials will be included
when a request is sent. (It will not wait for a 401 response
challenge.)
authorizationType: The string identifying the authentication
protocol scheme to use for the connection conﬁguration.
domainName: The domain/security realm for the current
connection conﬁguration.
keystoreAlias: Alias for the Integration Server key store
conﬁguration.
clientKeyAlias: Alias to reference a key inside a key store ﬁle.

custom

User-deﬁned ﬁelds of a custom group.

6. Add additional connection groups, if desired, by right-clicking the Connections folder and
selecting Add Group.

7. If your provider requires a Login Sequence, configure it as follows:
a. Right-click the Login Sequence node and select Add Operation.
b. Right-click the login operation under the Login Sequence node and select Add Mapping.
c. In the Configuration section of the page assign a name to the sequence (for example
XYZSoapService:login), select the Login operation and optionally enter a description.
A Mapping node is added under the login operation.
d. Now the Configuration section of the page shows the document types that were generated
for the login service WSDL for the request and response messages. Define the mappings
by inserting values into the request message or extracting values from the response
message as needed. For the Salesforce.com connector, for example, the username and
password values are inserted into the request message by selecting the configured values
that are defined in the managed connection page. Then, the session token and a server
URL are extracted from the response message to be inserted into special connection
factory fields. These fields are used when invoking any of the Simple or Complex
operations.
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e. Right-click a request message field you want to map (for example, HDR1:username) and
select Set configuration.
f.

In the Set Configuration dialog that appears, complete the following fields.
Field

Description

Name

Assign a name to the mapping.

Type

Select the data source type:
Cookie: HTTP cookies. For example, the
Salesforce.com connector inserts the session token
from a valid login in the SOAP header of the business
operations to be executed. Other providers do the
same thing; however, the token is managed via
cookies instead of the SOAP header.
Header: Request or response HTTP transport headers
for the support connection factory implementation.
IData: IData is a variable name that is associated with
the connection instance when the service is invoked.
It is a subset of those conﬁguration ﬁelds from the
selected groups. Not all ﬁelds are eligible for use as a
mapping step since their values may not be changed
or have any useful meaning in this context.
Literal: A constant value.
Parameter: Primarily used for REST handlers.
Service: The Service type applies to the source,
not to the target. Select Service if you want
the source to call a given service to perform
certain tasks and to map the output of the
service to a target. The service must adhere to
wm.cloudstreams.service.common.lookup.specs:mapServiceSpec.
If an error occurs related to service validation
or execution, CloudStreams throws a Mapping
Exception.
XPATH: Enables you to deﬁne an XPath expression.

Value

If you selected the Service type, the Value
ﬁeld's drop-down list will display all
services that conform to the speciﬁcation
wm.cloudstreams.service.common.lookup.specs:mapServiceSpec.
When you choose a service, the Formaer Service
Arguments Conﬁguration dialog appears, where you
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Field

Description
can add/delete/reset the input details speciﬁed in the
service and specify arguments.
If you selected a diﬀerent type, choose the appropriate
value from the drop-down list (for example, the
connection user name key ﬁeld cr.username).

g. Click OK.
A green check mark is shown next to the request message ﬁeld you just mapped.

8. Configure a Logout Sequence step in a similar manner.
9. Next, configure your cloud connector services, as described below.

Configuring Cloud Connector Services (SOAP)
In this task, you will conﬁgure the cloud connector service you just created in the New
Cloud Connector wizard. You will:
Conﬁgure the operations for the cloud connector service and map their signatures.
Select any abstract objects that will be needed by the service's Complex type
operations (if any).
To configure a cloud connector service (SOAP)

1. Start Software AG Designer and open the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Connectors view, expand your CloudStreams Provider project and click
the cloud connector you just created (as described in "Creating Custom SOAP or REST
Cloud Connectors" on page 232).

The Overview page is displayed, showing the general information you deﬁned in the
New Cloud Connector wizard.

3. Click the Services link in the Plug-in Content section of the page (or click the Services tab at
the bottom of the page).
If you already created a cloud connector service on page 2 of the New Cloud
Connector wizard, the Services Conﬁguration page will show your new service
and the default nodes Abstract Objects and Operations.
If you did not create a cloud connector service in the New Cloud Connector
wizard, create it now by right-clicking the Services node, selecting Add Service
and specifying the SaaS provider's WSDL that CloudStreams will use to generate
the document types. For a description of the Document Type Package ﬁeld, see
"Creating Custom SOAP or REST Cloud Connectors" on page 232.

4. Add any abstract objects that will be needed by the service's Complex type operations.
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CloudStreams supports the abstract object types businessObject and schemaObject.
For a businessObject, perform the following steps:
a. Click the Abstract Objects node.
b. In the Configuration section of the page, in the Type field select businessObject.
c. In the Document Type field, select the document name of the abstract object from the
drop-down list.
d. Next to the Service table, click the Add icon.
The Add Lookup Service dialog appears, displaying the list of lookup services
that implement the boSpec and boListSpec lookup types.
e. In the Add Lookup Service dialog, select the lookup services that you implemented for
the abstract object and click OK.
The selected services will be shown in the Service table.
For a schemaObject, perform the following steps:
a. Click the Abstract Objects node.
b. In the Configuration section of the page, in the Type field select schemaObject.
c. In the Document Type field, select the document name of the abstract object from the
drop-down list.
d. Next to the Service table, click the Add icon.
The Add Lookup Service dialog appears, displaying the list of lookup services
that implement the soListSpec lookup type.
e. In the Add Lookup Service dialog, select the lookup service that you implemented for the
abstract object and click OK.
The selected service will be shown in the Service table.

5. Click the Operations node and select the operation type for each operation in the
Configuration section of the page as follows:
Field

Description

Name

(Read-only ﬁeld.) The operation name.

Type

Select the type of the operation:
SIMPLE: This is any operation that has all the information
needed to build the messages for a connector's operation
based solely on the WSDL. A simple operation neither
requires dynamic signature updating nor uses an abstract
type deﬁnition.
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Field

Description
COMPLEX: This is any operation that requires additional
eﬀorts to capture the metadata needed to build messages
and to invoke a provider's service because the WSDL by
itself does not suﬃce. Not every provider will have Complex
operations.
METADATA: Metadata operations are special operations
provided by the provider which are used by the connector
to capture the additional information that is needed for a
complex operation. Not every provider will have Metadata
operations.
LOGIN/LOGOUT: The Login and Logout operations are those
that are invoked when a managed connection pool is enabled
(login) or disabled (logout). Some providers require login/
logout methods to be invoked in order to set up a session for
the user to use when invoking any of the business operations.
Other providers do not require them.

Description

Optional. Enter a description for the operation.

Alternatively, you can select the types for the operations individually, by clicking an
operation and then selecting its type.

6. Add the operation's input parameters as follows.
You can add predeﬁned parameters (if the operation has any) and you can add
additional ones as well.
a. Right-click the operation and select Add Parameters.
The Conﬁguration section of the page will display the operation's predeﬁned
parameters (if any).
b. If the operation has any predeﬁned parameters, select the check box next to each
one you want to add. Mandatory parameters are selected by default and you
cannot un-select them.
c. Complete the following ﬁelds in the Conﬁguration section.
Field

Description

Name

The parameter's name. (For predeﬁned parameters, this is
Read-only.)

Parameter Type

The parameter's type which determines how the
parameter should be used, e.g., URI_CONTEXT,
QUERYSTRING_PARAM or CFG_PARAM. (For predeﬁned
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Field

Description
parameters, this is Read-only.) For a list of the supported
parameter types, see "Parameter Types" on page 262.

Default Value

You can provide a default value for any parameter by typing
a value in the Default Value ﬁeld. If the variable is null in the
input pipeline, this default value will be used at run time.
The value given at run time always takes precedence over the
default value. However, if the existing default value is of type
"ﬁxed default", the overwrite will fail.
Note: Parameters have various data validation constraints that
apply to them. These constraints are indicated by an icon next
to each parameter. For information about these constraints, see
"Viewing the Constraints Applied to Variables" on page 267.

Description

Optional description of the parameter.

Required

Speciﬁes whether the parameter is required.

d. If you want to add additional parameters, click the Add buon and complete the
ﬁelds in the Conﬁguration section (described above).
e. Click OK.

7. Specify the input/output mapping for an operation as follows:
a. Right-click the operation and select Add Mapping.
b. In the Configuration section of the page, right-click a parameter you want to map, select
Set Configuration and complete the following fields.
Field

Description

Name

Assign a name to the mapping.

Type

Select the data source type:
Cookie: HTTP cookies. For example, the
Salesforce.com connector inserts the session token
from a valid login in the SOAP header of the business
operations to be executed. Other providers do the
same thing; however, the token is managed via
cookies instead of the SOAP header.
Header: Request or response HTTP transport headers
for the support connection factory implementation.
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Field

Description
IData: IData is a variable name that is associated with
the connection instance when the service is invoked.
It is a subset of those conﬁguration ﬁelds from the
selected groups. Not all ﬁelds are eligible for use as a
mapping step since their values may not be changed
or have any useful meaning in this context.
Literal: A constant value.
Parameter: Primarily used for REST handlers.
Service: The Service type applies to the source,
not to the target. Select Service if you want
the source to call a given service to perform
certain tasks and to map the output of the
service to a target. The service must adhere to
wm.cloudstreams.service.common.lookup.specs:mapServiceSpec.
If an error occurs related to service validation
or execution, CloudStreams throws a Mapping
Exception.
XPath: Enables you to deﬁne an XPath expression.

Value

If you selected the Service type, the Value
ﬁeld's drop-down list will display all
services that conform to the speciﬁcation
wm.cloudstreams.service.common.lookup.specs:mapServiceSpec.
When you choose a service, the Formaer Service
Arguments Conﬁguration dialog appears, where you
can add/delete/reset the input details speciﬁed in the
service and specify arguments.
If you selected a diﬀerent type, choose the appropriate
connection group ﬁeld from the drop-down list. The
list of ﬁelds displayed in the drop-down list depends
on the type of the connection group you conﬁgure in
the Connection Conﬁguration page (as described in
"Creating Run-Time Connections (SOAP)" on page
236).

8. Define global mappings, if required by your provider.
Global mappings are mapping statements that must be executed for all Simple and
Complex type operations (if required by your provider). These global mapping steps
are used by the provider to inject the session token into the SOAP header before
invoking the service. Some providers might have conﬁguration values that could be
included for every operation. Other providers have conﬁguration content in their
SOAP header.
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To specify global mapping, right-click the service name, select Global Mapping and
complete the ﬁelds in the Conﬁguration section of the page as follows:
Field

Description

Name

Assign a name for the global mapping.

Parameter Type

Select the parameter's type which determines how
the parameter should be used, e.g., URI_CONTEXT,
QUERYSTRING_PARAM or CFG_PARAM. For a list of the
supported parameter types, see "Parameter Types" on page
262.

Required

Specify whether this is a required mapping.

Fixed

A Fixed mapping means its values cannot be changed at run
time.

Mapping Key Type

Select the source mapping type:
Cookie
Header
IData
Literal
Parameter
Service
XPath
For descriptions, see the previous step.

Mapping Key

Enter the source mapping key. For example, if your source
mapping type is IData, you might enter the key cr.username.

Mapping Value Type

Select the target mapping type, which can be:
Cookie
Header
IData
Literal
Parameter
Service
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Field

Description
XPath

Mapping Value Key

Enter the target mapping key. For example, if your target
mapping type is XPath, you might enter the key tns:login/
tns:us.

Document Name

The document type generated for that SOAP operation.

9. You can add/delete additional services in the Services page, as long as the connector is not
deployed.

10. View the Manifest tab, which shows read-only fields containing attributes whose values were
captured from your custom cloud connector definition.

Configuring Custom REST Cloud Connectors
After you create a cloud connector as described above, you need to conﬁgure it as
follows.
"Creating Run-Time Connections (REST)" on page 248.
"Conﬁguring Cloud Connector Services (REST)" on page 255.

Creating Run-Time Connections (REST)
You need to create one or more run-time connections to the SaaS provider.
To create a run-time connection (REST)

1. Start Software AG Designer and open the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Connectors view, expand your CloudStreams Provider project and click
the cloud connector you just created (as described in "Creating Custom SOAP or REST
Cloud Connectors" on page 232).

The Overview page is displayed, showing the general information you deﬁned in the
New Cloud Connector wizard.

3. Click the Connections link in the Plug-In Content section of the page (or click the
Connections tab).

The Connections Conﬁguration page is displayed.

4. Create a run-time connection by right-clicking the Connections node, selecting Add

Connection and assigning a name and optional description to the connection. The name
cannot contain special characters.
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CloudStreams creates the connection in the Connections node, and by default the
connection will contain a Groups node.

5. Add one or more groups that should be allowed to access the connection.
The Groups node contains a default group called Group1. Click Group1 and complete
the ﬁelds in the Conﬁguration section of the page as follows.
Field

Description

Name

The default group name is Group1. You may rename this
group.
Connection group names cannot have spaces or use special
characters reserved by Integration Server or Designer. For
more information about the use of special characters, see the
Designer Service Development online help.

Group Type

Only one instance of each group type shown below may be
selected for a provider connector's connection conﬁguration.
oauth: Indicates that the group is deﬁned with the
authentication type of OAuth.
protocol: Indicates that the group is deﬁned with the HTTP
transport protocol that the connection will use.
connection: Indicates that the group is deﬁned with the login
endpoint to initiate communication with the SaaS provider.
requestHeaders: Indicates that the group is deﬁned with the
names of the HTTP request headers to include when sending
the login request.
credentials: Indicates that the group is deﬁned with a user
account on the SaaS provider that the connection will use to
connect to the SaaS provider.
aws_v2: Indicates that the user will use Signature Version 2 to
sign Amazon Web Services Query API requests.
aws_s3: Indicates that the group is deﬁned for the Amazon
S3 authentication scheme and it uses the AWSAccessKeyId
and the AWSSecretAccessKey of the client to authenticate the
requests.
aws_v4: Indicates that the user will use Signature Version 4 to
sign Amazon Web Services Query API requests.
custom: A user-deﬁned group.

Description

Optional. Type a description for the connection group.
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Field

Description

Fields

Based on the group type you selected above, CloudStreams
displays the applicable ﬁelds for which you should specify
values. Required ﬁelds are marked with an asterisk. Refer to
the table below.

Based on the group type you selected above, CloudStreams displays the applicable
ﬁelds for which you should specify values, as follows:
If the group type is...

The available fields are...

oauth

oauthAliasKey: The alias of an OAuth token that was conﬁgured
in Integration Server Administrator. For details, see
webMethods Integration Server Administrator’s Guide.

protocol

elementCharSet: The encoding to use for the HTTP request
line, headers, etc.
contentCharSet: The encoding to use for the request message.
httpVersion: The HTTP version (HTTP/0.9, HTTP/1.0 or
HTTP/1.1. The default value for the connection factory is
HTTP/1.1.
userAgent: The value to the connection conﬁguration will
send for the User-Agent request header.
useExpectContinue: If true, use the Expect/Continue HTTP/1.1
handshake and send the Expect request header.
waitForContinue: The number of milliseconds that the
connection factory's client connection should wait for a "100
Continue" response from the server.
useStrictTransferEncoding: If true, the connection factory
connection raise an exception if the "Transfer-Encoding"
header is invalid.
useChunking: If true, use HTTP/1.1 chunking, using a chunk
size that matches the socket buﬀer size.
flowServerRedirects: If true, follow server redirects.
serverRedirectMax: Maximum number of times to follow a
server redirect.

connection

providerURL: The native provider endpoint target for the
connection conﬁguration. The default conﬁguration ﬁeld
provided with the connection factory is cn.providerURL.
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If the group type is...

The available fields are...
minPoolConnections: The minimum number of socket
connections to reserve for a connection conﬁguration alias.
maxPoolConnections: The maximum number of socket
connections to reserve for a connection conﬁguration alias.
connectTimeout: The number of milliseconds a connection
aempt will wait before giving up. (0 will wait indeﬁnitely.)
readTimeout: The number of milliseconds in which the the
client must read a response message from the server. (0 will
wait indeﬁnitely.)
useStaleChecking: If true, the connection factory performs
additional processing to test the socket to see if it is still
functional each time it is used.
retryCount: How many times should the connection factory
aempt to execute a failed invocation.
retryOnResponseFailure: If true, the retry mechanism will
be used for failed responses even if the request was sent
successfully.
useTcpNoDelay: If true, do not use Nagles algorithm as a
socket optimization technique.
linger: Determines how quickly a socket should close.
bufferSize: The size of the read and write socket buﬀers, in
bytes.
reuseAddr: If true, the socket will be reused even if it is in
TIME_WAIT due to a previous socket closure.
sessionToken: Session token for a stateful session.
webproxyAlias: The alias to a web proxy server conﬁguration
in Integration Server.
truststoreAlias: Alias for the Integration Server trust store
conﬁguration.
hostnameVerifier: Fully qualiﬁed class name that implements
the Apache HC org.apache.http.conn.ssl.X509HostnameVerifier
interface; helps guard against "man-in-the-middle"
aacks. Also set the IS property watt.security.cert.
wmChainVerifier.trustByDefault to false and ensure
the outbound connector's connection conﬁguration
property Hostname verifier is set to its default value,
org.apache.hp.conn.ssl.StrictHostnameVeriﬁer.
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If the group type is...
requestHeaders

The available fields are...
names: An array of request header names to include for this
connection conﬁguration. The value should be a commadelimited list of header names; for example ContentType,SOAPAction.
values: An array of request header values to include for
this connection conﬁguration. The value should be commadelimited list of values in the same order as the header
names; for example, text/xml,login.

credentials

username: The username credentials for the current
connection conﬁguration.
password: The password credentials for the current
connection conﬁguration
preemptiveAuth: If true, basic auth credentials will be included
when a request is sent. (It will not wait for a 401 response
challenge.)
authorizationType: The string identifying the authentication
protocol scheme to use for the connection conﬁguration.
domainName: The domain/security realm for the current
connection conﬁguration.
keystoreAlias: Alias for the Integration Server key store
conﬁguration.
clientKeyAlias: Alias to reference a key inside a key store ﬁle.

aws_v2

Signing Algorithm: Explicitly specify the signing algorithm (e.g.
HMAC-SHA1 Signatures) used to sign the message.
Access Key: This is a username. It is an alphanumeric text
string that uniquely identiﬁes the user who owns the
account. No two accounts can have the same AWS Access
Key.
Secret Key: This key plays the role of a password. It is called
secret because it is assumed to be known only by the owner.
When you type the secret key, it is displayed as asterisk or
dots.
Region: An area-speciﬁc value.

aws_s3

Access Key: This is a username. It is an alphanumeric text
string that uniquely identiﬁes the user who owns the
account. No two accounts can have the same AWS Access
Key.
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If the group type is...

The available fields are...
Secret Key: This key plays the role of a password. It is called
secret because it is assumed to be known only by the owner.
When you type the secret key, it is displayed as asterisk or
dots.
Region: An area-speciﬁc value.

aws_v4

Access Key: This is a username. It is an alphanumeric text
string that uniquely identiﬁes the user who owns the
account. No two accounts can have the same AWS Access
Key.
Secret Key: This key plays the role of a password. It is called
secret because it is assumed to be known only by the owner.
When you type the secret key, it is displayed as asterisk or
dots.
Region: An area-speciﬁc value.

custom

User-deﬁned ﬁelds of a custom group.

You can create additional connection groups by right-clicking the Connections node
and selecting Add Group.

6. If your provider requires a Login Sequence, configure one as follows:
a. Right-click the Login Sequence node, select Add Resource, select the Type Login, and
click Next.
b. Configure a Login resource by completing the fields as follows.
Field

Description

Name

Specify a name for the Login resource.

Document
Reference

Click Browse and select a Document Reference.

Content Type

Specify the Content-Type of the Document Reference.

c. Click Next.
d. Create a Request for the Login resource by completing the fields as follows.
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Field

Description

Name

Specify a name for the Request.

Document
Reference

Click Browse and select a Document Reference, for example
myConnector_v1.customDoctypes:docTypeRef_LoginInput.

Content Type

Specify the Content-Type of the Document Reference, for
example, application/xml.

e. Click Next.
f.

Create one or more Responses for the Login resource by completing the fields as follows.
Field

Description

Name

Specify a name for the Response.

Document
Reference

Click Browse and select a Document Reference, for example
myConnector_v1.customDoctypes:docTypeRef_LoginOutput.

Code

Specify a code for the Response, such as 201 or 400. Response
codes should be comma separated.

Content Type

Specify the Content-Type of the Document Reference for
example, application/xml.

g. Click Next.
h. Create one or more parameters for the Login resource by completing the fields as
follows.
Field

Description

Name

Specify a name for the parameter.

Active

Speciﬁes whether the parameter is active.
If the Active option is disabled, CloudStreamswill not include
the parameter in the input/output signature at runtime.

Parameter Type

Select the parameter's type which determines how
the parameter should be used, e.g., URI_CONTEXT,
QUERYSTRING_PARAM or CFG_PARAM. For a list of the
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Field

Description
supported parameter types, see "Parameter Types" on page
262.

Default Value

Specify a default value for the parameter.
In pipeline, and input/output validation, the data validation
applies constraints to its variables. Designer displays small
symbols next to a variable icon to indicate validation
constraints. For more information about icons for constrained
variables, see "Viewing the Constraints Applied to Variables"
on page 267.

Description

Optional description of the parameter.

i.

Click Finish.

j.

Define the input/output mappings for the Login Sequence by right-clicking the Login
Sequence name, selecting Add Mapping, and completing the fields as follows.
Field

Description

Parameter Type

Select IN or OUT.

Mapping
ﬁelds

For example, for input ﬁelds, you might enter the display
names Username and Password, and the values cr.username (the
connection user name key ﬁeld) and cr.password, respectively.
And for output ﬁelds, you might enter the following display
names and values:
Server URL

(with value cx.serverUrl).

Provider URL

(with value cn.providerUrl).

Session Token
Fault String

(with value cn.sessionToken).

(with value cx.faultString).

7. Configure a Logout Sequence in a similar manner.
8. Next, configure your cloud connector services, as described below.

Configuring Cloud Connector Services (REST)
In this task, you will conﬁgure the cloud connector service you just created in the New
Cloud Connector wizard. You need to create at least one cloud connector service for each
REST resource on which the connector can operate.
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To configure a cloud connector service (REST)

1. Start Software AG Designer and open the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.

2. In the CloudStreams Connectors view, expand your CloudStreams Provider project and click
the cloud connector you just created (as described in "Creating Custom SOAP or REST
Cloud Connectors" on page 232).

The Overview page is displayed, showing the general information you deﬁned in the
wizard.

3. Click the Services link in the Plug-In Content section of the page (or click the Services tab at
the bottom of the page).
If you already deﬁned a cloud connector service on page 2 of the New Cloud
Connector wizard, the Services Conﬁguration page will show your new service
and the default node Resources.
If you did not deﬁne a cloud connector service on the New Cloud Connector
wizard, deﬁne it now by right-clicking the Services node, selecting Add Service
and specifying the SaaS provider's XSD that CloudStreams will use to generate
the document types. For a description of the Document Type Package ﬁeld, see
"Creating Custom SOAP or REST Cloud Connectors" on page 232.

4. Define any necessary global mappings to be used by all the REST resources in the service. To
do this, right-click the service, select Add Global Mapping and complete the fields as follows.
Field

Description

Mapping Name

Assign a name for the global mapping.

Parameter Type

Select the parameter's type which determines how
the parameter should be used, e.g., URI_CONTEXT,
QUERYSTRING_PARAM or CFG_PARAM. For a list of the
supported parameter types, see "Parameter Types" on page
262.

Required

Specify whether this is a required mapping.

Fixed

A Fixed mapping means its values cannot be changed at run
time.

Mapping Key Type

Select the data source type:
Cookie: HTTP cookies. For example, the Salesforce.com
connector inserts the session token from a valid login in
the SOAP header of the business operations to be executed.
Other providers do the same thing; however, the token is
managed via cookies instead of the SOAP header.
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Field

Description
Header: Request or response HTTP transport headers for the
support connection factory implementation.
IData: IData is a variable name that is associated with the
connection instance when the service is invoked. It is a subset
of those conﬁguration ﬁelds from the selected groups. Not
all ﬁelds are eligible for use as a mapping step since their
values may not be changed or have any useful meaning in
this context.
Literal: A constant value.
Parameter: Primarily used for REST handlers.
Service: The Service type applies to the source, not to
the target. Select Service if you want the source to call
a given service to perform certain tasks and to map the
output of the service to a target. The service must adhere to
wm.cloudstreams.service.common.lookup.specs:mapServiceSpec.
If an error occurs related to service validation or execution,
CloudStreams throws a Mapping Exception.
XPath: Enables you to deﬁne an XPath expression.

Mapping Key

Enter the source mapping key. For example, if your source
mapping type is IData, you might enter the source mapping
key cn.sessionToken.

Mapping Value Type

Select the target mapping type:
Cookie
Header
IData
Literal
Parameter
Service
XPath

Mapping Value Key

Enter the target mapping key. For example, if your target
mapping type is Header, you might enter the target mapping
key X-SFDC-Session.

Document Name

The document type, based on the XSD.
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5. Add a REST resource by right-clicking the Resources node, selecting Add REST Resource
and completing the following fields in the wizard.
Field

Description

Name

Assign a name for the resource.

Method

Select an available HTTP method (GET, PUT, POST, DELETE).

Path

Specify the path to the resource.

Description

Optional description for the resource.

6. Click Next.
7. Add a Request to a REST resource by completing the fields as follows.
Field

Description

Request Name

Specify the request name, for example tns:jobInfo.

Incoming
Parsing Type

The Content-Type of the request, for example, application/octet
+idataoref.

Outgoing
Serialization
Type

The Content-Type for the response, for example, application/
xml.

Document
Reference Type

Click Browse and select a document reference. For example,
myConnector_v1.doctypes:docTypeRef_tns_JobInfo.

8. Click Next.
9. Add one or more Responses to a REST resource by completing the fields as follows.
Field

Description

Response Name

Specify the request name, for example tns:jobInfo.

Response Codes

Specify one or more codes for the response, such as 201 or 400.
Response codes should be comma separated.

Incoming Parsing
Type

For example, application/xml.
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Field

Description

Outgoing
Serialization Type

For example, application/octet+idataoref.

Document
Reference Type

Click Browse and select a document reference. For example,
myConnector_v1.doctypes:docTypeRef_tns_JobInfo or
myConnector_v1.doctypes:docTypeRef_tns_Error.

10. Click Next.
11. Select the predefined input parameters for the REST resource as desired. Note that:
Mandatory parameters are selected by default and you cannot un-select them.
You can provide a default value for any parameter by typing a value in the
Default Value ﬁeld. If the variable is null in the input pipeline, this default value
will be used at run time. The value given at run time always takes precedence
over the default value. However, if the existing default value is of type "ﬁxed
default", the overwrite will fail.
Parameters have various data validation constraints that apply to them. These
constraints are indicated by an icon next to each parameter. For information
about these constraints, see "Viewing the Constraints Applied to Variables" on
page 267.

12. Optionally create additional input parameters for the REST resource by clicking the Add
button and completing the following fields.
Field

Description

Name

Specify a parameter name.

Document
Reference

For QUERYSTRING_PARAM type parameters only.

Formatter
Service

For QUERYSTRING_PARAM type parameters only.

If the parameter is a complex parameter involving indices
where an IS document type is required, specify the fully
qualiﬁed name of the IS document type.

If you have used a parameter formaer to format input data
into a custom format, specify your custom formaer service
here, and then provide the input in the form of "key:value"
pairs for the arguments speciﬁed in the service.
For details about parameter formaers, see "Parameter
Formaers for REST Connector Services" on page 264.
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Field

Description

Parameter Type

Select the parameter's type, which determines how
the parameter should be used, e.g., URI_CONTEXT,
QUERYSTRING_PARAM or CFG_PARAM. For more
information about the supported parameter types, see
"Parameter Types" on page 262.

Default Value

Specify a default value for the parameter. If the variable is null
in the input pipeline, this default value will be used at run
time. The value given at run time always takes precedence
over the default value. However, if the existing default value is
of type "ﬁxed default", the overwrite will fail.
Note: Parameters have various data validation constraints that
apply to them. These constraints are indicated by an icon next
to each parameter. For information about these constraints, see
"Viewing the Constraints Applied to Variables" on page 267.

Description

Optional description of the parameter.

Required

Speciﬁes whether the parameter is required.

13. Click Finish.
14. Define the local mappings for the REST resource by right-clicking the resource name,
selecting Add Mapping and completing the fields as follows.
Field

Description

Name

Assign a name for the local mapping. This mapping will be
used only by this particular resource.

Parameter Type

Select the parameter's type which determines how
the parameter should be used, e.g., URI_CONTEXT,
QUERYSTRING_PARAM or CFG_PARAM. For a list of the
supported parameter types, see "Parameter Types" on page
262.

Required

Specify whether this is a required mapping.

Fixed

A Fixed mapping means its values cannot be changed at run
time.

Mapping Key
Type

Select the data source type:
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Field

Description
Cookie: HTTP cookies. For example, the Salesforce.com
connector inserts the session token from a valid login in
the SOAP header of the business operations to be executed.
Other providers do the same thing; however, the token is
managed via cookies instead of the SOAP header.
Header: Request or response HTTP transport headers for the
support connection factory implementation.
IData: IData is a variable name that is associated with the
connection instance when the service is invoked. It is a subset
of those conﬁguration ﬁelds from the selected groups. Not
all ﬁelds are eligible for use as a mapping step since their
values may not be changed or have any useful meaning in
this context.
Literal: A constant value.
Parameter: Primarily used for REST handlers.
Service: The Service type applies to the source, not to
the target. Select Service if you want the source to call
a given service to perform certain tasks and to map the
output of the service to a target. The service must adhere to
wm.cloudstreams.service.common.lookup.specs:mapServiceSpec.
If an error occurs related to service validation or execution,
CloudStreams throws a Mapping Exception.
XPath: Enables you to deﬁne an XPath expression.

Mapping Key

Enter the source mapping key. For example, if your source
mapping type is Literal, you might enter the key application/
xml.

Mapping Value
Type

Select the target mapping type:
Cookie
Header
IData
Literal
Parameter
Service
XPath
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Field

Description

Mapping Value
Key

Enter the target mapping key. For example, if your target
mapping type is Header, you might enter the key ContentType.

Document
Name

The document type, based on the XSD.

15. View the Manifest node, which shows read-only fields containing attributes whose values
were captured from your cloud connector definition.

Understanding REST Parameters
CloudStreams REST connector services allow you to set parameters which become part
of the outgoing request.
REST services rely on HTTP methods (GET, POST, PUT, DELETE) to make requests to a
SaaS provider. Thus the parameters are closely tied to these HTTP methods, as they are
sent as part of these HTTP method requests.
The parameters are typically part of the HTTP URI which may be of the following
format:
[scheme:][//authority][path][?query]

Parameter Types
CloudStreams supports the following parameter types:
Type

URI Scope

"URI_CONTEXT" on page 262

path

"QUERYSTRING_PARAM" on page 263

query

"CFG_PARAM" on page 263

authority, path

URI_CONTEXT
URI_CONTEXT parameters are passed as the path component of a REST resource URI,
and the parameter names correspond to the URI path variable names speciﬁed in the {}
annotation. For example, a sample request might look like this:
services/async/25.0/job/{jobId}

In the above sample request, the URI path variable name jobId is speciﬁed as a
parameter to the job resource. The annotation {} is set to the variable name jobId. At
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service run-time, the variable is substituted with it's runtime value to form the dynamic
path.
A sample resource deﬁnition with URI_CONTEXT parameter:
<resource name="Job" method="POST" path="services/async/25.0/job/{jobId}">
<parameters>
<parameter name="jobId" isRequired="true" style="URI_CONTEXT"/>
</parameters>
</resource>

QUERYSTRING_PARAM
QUERYSTRING_PARAM parameters are passed as the query component of a REST
resource invocation request.
The following example demonstrates a typical HTTP GET request with parameters that
form a query string of the resource URI.
GET /status?key1=value1&key2=value2 HTTP/1.1
Host: www.softwareag.com
Content-Length: 0

Notice that the parameters are added to the path after a "?", and speciﬁed as ampersand
( & ) separated list of key-value pairs, with the corresponding Content-Length set
accordingly. The key & values passed as parameters are URL encoded by CloudStreams.
A sample resource deﬁnition with QUERYSTRING_PARAM parameter:
<resource name="GetStatus" method="GET" path="/status">
<parameters>
<parameter name="key1" isRequired="true" style="QUERYSTRING_PARAM"/>
<parameter name="key2" isRequired="false" style="QUERYSTRING_PARAM"/>
</parameters>
</resource>

CFG_PARAM
CFG_PARAM parameters signify an internal contract between the connector tier and the
connecter-speciﬁc authentication scheme along with the virtual runtime layer.
The allowed set of parameter name, which can be speciﬁed as CFG_PARAM depends on
the authentication scheme used for the connector deﬁnition.
Example
is a parameter, which is used by the Amazon Authentication Scheme
version 3, for specifying the dynamic host based on the parameter value.
aws.bucketName

While executing a resource with such parameter, the service endpoint is preﬁxed with
the appropriate bucket name.
<resource name="GetBucket" method="GET" path="/">
<parameters>
<parameter name="aws.bucketName" isRequired="true" style="CFG_PARAM"/>
</parameters>
</resource>
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Parameter Data Types
CloudStreams currently supports the data types String and Record.
String
String data type represents a simple parameter which is an individual string keyvalue parameter. This is the most commonly used data type and the default type, if not
speciﬁed explicitly.
Record
Record data type handles complex parameters involving a collection of related keyvalue pairs. These parameters can have indices's for one or more parameter entry. Such
parameters can ideally be represented with an IS document type, and conﬁgured as a
"Record" data type.
Example
Consider a complex parameter structure as follows:
+ Filter[]
- Name
+ Value[]

This needs to be represented as a query string like:
Filter.1.Name=instance-type&Filter.1.Value.1=m1.small&Filter.1.Value.2=t1.micro

Such a parameter can be deﬁned by creating an IS document type, and referring it as a
"Record" data type parameter within the resource deﬁnition.
CloudStreams provides the capability to represent and transform such complex
parameters into the desired format using its predeﬁned formaer implementation. The
resource's parameter deﬁnition can be enhanced to refer to a formaer, as follows:
<parameter name=”Filter” dataType=”Record”
documentRef=”documents.paramType:FilterList”
style=”QUERYSTRING_PARAM”>
<formatter service=”wm.cloudstreams.service.util.formatters:paramFormatter”
type=”paramFormatter”/>
</parameter>

At runtime, the resource PATH would look like:
GET /?Filter.1.Name=instance-type&Filter.1.Value.1=m1.small&Filter.1.Value.2=t1.micro

For more details on formaers and customizing the formaer behavior, see "Parameter
Formaers for REST Connector Services" on page 264.

Parameter Formatters for REST Connector Services
CloudStreams provides a parameter formaer which enables you to format input data
into a custom format as desired.
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Alternatively, in cases where the default parameter formaer is not suﬃcient to achieve
the desired parameter behavior, you can write a custom implementation for the
parameter formaer.
The input will typically be data present in a complex structure (e.g., an IS document
type).
The output will be data organized in a desired output format (e.g., a URL query string).
The format in which the output data is generated depends on the implementation of the
formaer.
Typically, you will use the QUERYSTRING_PARAM parameter type to format the input
data into a desired output format (e.g., a URL query string).
In order to form the query string, you can write a custom
formaer service by implementing the bundled IS speciﬁcation
wm.cloudstreams.service.common.lookup.specs:formaerSpec.
At run time CloudStreams will give control to the formaer service to format the data
appropriately and to return the formaed string data. Then, CloudStreams will encode
the data during a post-processing step, and the ﬁnal query string will be formed.
For details, see:
"Using the Default Parameter Formaer" on page 265.
"Implementing a Custom Parameter Formaer" on page 267.
Using the Default Parameter Formatter
For convenience, CloudStreams provides a default formaer implementation which
handles the most common formaer usage:
wm.cloudstreams.service.util.formaers:paramFormaer
This formaer allows you to specify a complex IS document type, and to implement
the desired output. The input will typically be data in a complex structure (e.g., an IS
document type). The output will be a data organized in a desired output format (e.g.,
a URL query string). The format in which the output data is generated depends on the
implementation of the formaer. Typically, the formaer is used in conjunction with the
QUERYSTRING_PARAM parameter type.
Example of using the default parameter formatter
Consider a SaaS back-end expecting the following parameter:
BlockDeviceMapping.n.DeviceName
BlockDeviceMapping.n.VirtualName
BlockDeviceMapping.n.Ebs.NoDevice
BlockDeviceMapping.n.Ebs.VolumeSize

where n represents a number.

1. Create IS document types for the above parameter definition.
The IS document structure would look like this:
BlockDeviceMapping[]
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+ DeviceName
+ VirtualName
+ Ebs
+ NoDevice
+ VolumeSize

2. Set the dataType of the parameter to Record.
3. Set the document reference (documentRef) to the newly created IS document type in step 1.
4. Specify a formatter element within the parameter element, along with the service name
(service attribute) and type (type attribute).
5. In case the implementation contains supported arguments, specify any customization by
adding the appropriate argument name and value.
The parameter deﬁnition for a resource using the above, within the Connector
Descriptor, would look like this:
<parameter name="BlockDeviceMapping" dataType="Record"
documentRef="document.paramType:BlockDeviceList" style="QUERYSTRING_PARAM">
<formatter service = "wm.cloudstreams.service.util.formatters:paramFormatter"
type = "paramFormatter">
<arg name="startIndex" value="1" />
<arg name="format" value="." />
</formatter>
</parameter>

Note: The default value for the type aribute, within the scope of a parameter
deﬁnition is "paramFormaer". This type refers to the bundled IS Speciﬁcation:
wm.cloudstreams.service.common.lookup.specs:formatterSpec

The generated representation of the above parameter would look like this:
BlockDeviceMapping.1.DeviceName=/dev/sdj&;BlockDeviceMapping
.1.Ebs.NoDevice=true&;BlockDeviceMapping
.2.DeviceName=/dev/sdh&;BlockDeviceMapping
.2.Ebs.VolumeSize=300&;BlockDeviceMapping
.3.DeviceName=/dev/sdc&;BlockDeviceMapping
.3.VirtualName=ephemeral1

The default formaer can be conﬁgured with the following supported arguments:
Argument

Default Value

Description

startIndex

0

Determines the index values of the
keys e.g. should the n present in
BlockDeviceMapping.n.DeviceName start with
0 or 1 or some number of your choice.

format

. (period)

Speciﬁes how the document
entries be separated. For example,
BlockDeviceMapping.3.DeviceName is
separated by a period (.).
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Implementing a Custom Parameter Formatter
In cases where the default parameter formaer is not suﬃcient to achieve the desired
parameter behavior, you can write a custom implementation for the parameter
formaer.
Implement a custom formaer as follows:
1. Write an IS service implementation, adhering to the bundled IS speciﬁcation
wm.cloudstreams.service.common.lookup.specs:formaerSpec.
2. The fully-qualiﬁed service namespace should be referred with the formaer service
aribute, under the parameter deﬁnition. Ensure that the formaer type aribute is
set to "paramFormaer".
3. Optionally, any service arguments can be speciﬁed within the formaer element
deﬁnition.
Example
Consider a custom service implementation:
my.custom.formatter:sample

The parameter deﬁnition for a resource using the above, within the Connector
Descriptor, would look like this:
<parameter name="SampleParam" dataType="Record"
documentRef="my.custom.document:sample" style="QUERYSTRING_PARAM">
<formatter service = "my.custom.formatter:sample" type = "paramFormatter">
<arg name="separator" value=";" />
</formatter>
</parameter>

Viewing the Constraints Applied to Variables
Designer displays small symbols next to a variable icon to indicate the constraints
applied to the variable as follows.
Variable

Constraint Status

Variable Properties

Required ﬁeld.

The Required property is set to True.

Optional ﬁeld.

The Required property is set to False.

Required ﬁeld
with content
type constraint.

The Content type property speciﬁes an IS
schema or XML schema.
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Variable

Constraint Status

Variable Properties

Optional ﬁeld
with content
type constraint.

The Required property is set to False, and the
Content type property speciﬁes an IS schema
or XML schema.

Required ﬁeld
with default
value.

The Fixed property is set to False, and the
defaultValue property speciﬁes a default
value.
The variable has a default value, but you can
override this default value with any other
valid values while executing the service or
mapping the variables.

Required ﬁeld
with ﬁxed value.

The Fixed property is set to True, and the
defaultValue property speciﬁes a null value.
The variable has a null value assigned to
it by default and you cannot override this
value. You cannot map this variable to another
variable or assign any input values to this
variable during service execution.

Required ﬁeld
with ﬁxed
default value.

The Fixed property is set to True, and the
defaultValue property speciﬁes a default
value.
The variable has a default value and you
cannot override this value. You cannot map
this variable to another variable or assign any
input values to this variable during service
execution.

Deploying Custom Cloud Connectors
Note: If you have not speciﬁed the provider's WSDL or XSD, then you will not be
allowed to deploy the connector. You should have speciﬁed the provider's WSDL or
XSD either in the New Cloud Connector wizard, or when you created a cloud connector
service in the Services Conﬁguration page (see "Conﬁguring Cloud Connector Services
(SOAP)" on page 242).
To deploy a custom cloud connector

1. Start Software AG Designer and open the CloudStreams Development perspective by
clicking Window > Open Perspective > CloudStreams Development.
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2. In the CloudStreams Connectors view, expand your CloudStreams Provider project, rightclick the cloud connector and select Deploy.

If the deployment is successful, a message is displayed. These messages are not
persisted, so the next time Software AG Designer is started, the prior messages will
not be shown.

3. Next, you must enable the deployed cloud connector as described in "Managing Custom
Cloud Connectors" on page 269.

Managing Custom Cloud Connectors
After you deploy a custom cloud connector, you must enable it as described below. In
addition, you can:
View its conﬁgured connection pool instance(s).
View other details about the connector.
Conﬁgure the properties of the connector as desired.
Delete the connector.
To manage a custom cloud connector

1. In the Integration Server Administrator, click Solutions > CloudStreams > Providers >
your_provider_name.

The list of custom cloud connector(s) that have been deﬁned for that provider will
appear in the Connector List.

2. You can do the following in the Connector List:
Column

Description

Connector
Name

Click the connector name to display the connector's conﬁgured
connection pool instance(s). To create a new connection pool
instance, click Configure New Connection and complete the ﬁelds
on the Conﬁgure Connection page.

View

Click the icon to display details about the connector.

Enabled

Click No or Yes to enable/disable the connector.

Delete

Click the icon to delete the connector. You must disable the
connector before you can delete it.

Configure

Click the icon to display the Connector Conﬁguration page,
which displays the connector properties you can conﬁgure.
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Column

Description
You must disable the connector before you can edit the
properties.

Managing the Custom Cloud Connector Packages
When you deploy a custom cloud connector, two packages are deployed: One package
for the cloud connector you created and one for the provider, which CloudStreams
automacally creates. When the connector is distributed, only the provider package is
shipped. You can manage both packages as described below.
To manage the custom cloud connector packages

1. In the Integration Server Administrator, click Packages > Management.
2. Here, you can enable/disable the packages, reload them, archive them and delete them.
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Summary of Elements in this Folder
The following elements are available in this folder:
Element

Description

pub.cloudstreams.admin.connection:disableConnection

Disables a
connection node.

pub.cloudstreams.admin.connection:enableConnection

Enables an existing
connection node.

pub.cloudstreams.admin.connection:getConnectionStatistics

Returns current
usage statistics for
a connection node.

pub.cloudstreams.admin.connection:queryConnectionState

Returns the current
connection state
(enabled/disabled)
and error status for
a connection node.

pub.cloudstreams.admin.connection:disableConnection
Disables a connection node.
Input Parameters
connectionAlias

String Name of the connection node you want to disable.

Output Parameters
status

String Indicates whether the connection is disabled successfully.
Values are:
true

- The connection is disabled.

false

statusMessage

- Disabling the connection failed.

String The status message of the error.
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pub.cloudstreams.admin.connection:enableConnection
Enables an existing connection node.
Input Parameters
connectionAlias

String Name of the connection node you want to enable.

Output Parameters
status

String Indicates whether the connection is enabled successfully.
Values are:
true

- The connection is enabled.

false

statusMessage

- Enabling the connection failed.

String The status message of the error.

pub.cloudstreams.admin.connection:getConnectionStatistics
Returns current usage statistics for a connection node.
Input Parameters
connectionAlias

String Name of the connection node for which you want usage
statistics returned.

Output Parameters
connectionStatisticsDocument List Information for each connection node. Keys are:
totalConnections String Current number of connection instances.
busyConnections String Number of connections currently in use by
services, notiﬁcations, and listeners.
freeConnections String Total number of connections created and
available for use.
totalHits String Number of times this connection node successfully
provided connections since the last reset.
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totalMisses String Number of times this connection node
unsuccessfully provided connections since the last reset (when
the request timed out).

pub.cloudstreams.admin.connection:queryConnectionState
Returns the current connection state (enabled/disabled) and error status for a connection
node.
Input Parameters
connectionAlias

String Name of the connection node for which you want the
connection state and error status returned.

Output parameters
response

Document List Information about the connection state and error
status. Keys are:
connectionState String Current connection state (enabled/disabled).
hasError Boolean Flag indicating if any error was detected on the
connection. Values are:
true

- An error was detected.

false

- No error was detected.

lastErrorTime String Indicates the last time an error occurred.
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wst.cloudConnectorService.

Introduction
This appendix describes the parameters you can specify in the CloudStreams properties
ﬁle:
Integration Server_directory \instances\instance_name \packages\WmCloudStreams
\conﬁg\resources\wst-conﬁg.properties
You can edit this ﬁle only by using a text editor. Before you edit the ﬁle, you should
either:
Shut down the Integration Server, make your changes and then restart the server,
OR
Make your changes and then reload the WmCloudStreams package.
Note: Some parameters present in the wst-conﬁg.properties ﬁle can be edited from
the CloudStreams Administration console in Integration Server Administrator. You
do not have to restart Integration Server when you change parameters through the
CloudStreams Administration console.

pg.backupFailedProxies
pg.backupFailedProxies
Indicates whether the backup services failed. The default is false.

pg.CollectionPool.
pg.CollectionPool.minThreads
Sets the minimum number of threads used for the Policy Engine. The default is 1.
pg.CollectionPool.maxThreads
Sets the maximum number of threads used for the data collection work queue. The
default is 8.
pg.CollectionPool.forcefulShutdown
Speciﬁes whether the data collection thread pool should shut down immediately or wait
for queued tasks to complete during CloudStreams shutdown. The default is false.
pg.CollectionPool.poolName
Sets the name for the data collection thread pool. The default is CollectionPool.
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pg.CollectionWorkQueue.
pg.CollectionWorkQueue.queueCapacity
Sets the capacity available for data collection tasks stored in the memory work queue.
The default is 10000.

pg.debug.
pg.debug.eventLoggerActive
This is an internal parameter. Do not modify.

pg.delayedRefresher.
CloudStreams cannot query for updates or receive deployed services until Integration
Server is running. If Integration Server is not yet fully operational when CloudStreams
starts, a delayed refresh helper is used to wait for Integration Server. This helper will
periodically check on Integration Server's status.
pg.delayedRefresher.napMillis
Speciﬁes the amount of time (in milliseconds) the delayed refresher helper waits before
checking to see whether Integration Server is running. The default is 500.

pg.ehcache.config.
pg.ehcache.config.file
The path to the ehcache conﬁguration ﬁle. This path will be provided to Integration
Server during the ﬁrst startup, and subsequent startups will not use the local ﬁle; it will
use the one under IS/conﬁg/Caching. Do not modify.

pg.email.
pg.email.charset
Speciﬁes the character set to use for the subject line, email addresses, and message body
of the emails when sending alerts or events. The default is US-ASCII.
pg.email.debug
This is an internal parameter. Do not modify.
pg.email.from
Speciﬁes the email address used when sending events by email. The default is
targetName@IS-hostname.
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You can edit this parameter from the From ﬁeld on the CloudStreams > Administration >
Email page in Integration Server Administrator.
pg.email.resourceMimeType
Speciﬁes the MIME type that CloudStreams uses to send the request and response
payload aachments for transaction events that are sent by email. CloudStreams
supports the following values:
application/gzip
application/zip
text/xml

(.gz)

(.zip)

(.xml)

The default is application/gzip.
pg.email.SenderActive
Speciﬁes whether an email server is conﬁgured for CloudStreams. The default is false.

You can edit this parameter from the SMTP Host Name/IP Address ﬁeld on the CloudStreams
> Administration > Email page in Integration Server Administrator.
pg.email.smtpHost
Speciﬁes the host name of the email server.
You can edit this parameter from the SMTP Host Name/IP Address ﬁeld on the CloudStreams
> Administration > Email page in Integration Server Administrator.
pg.email.smtpPort
Speciﬁes the email port for the SMTP or SMTPS protocol. The default is 25.

You can edit this parameter from the Port ﬁeld on the CloudStreams > Administration > Email
page in Integration Server Administrator.
pg.email.timeOut
Speciﬁes the time out period (in milliseconds) when connecting to an e-mail server and
sending e-mails. The default is 1000.
pg.email.TLSEnabled
Speciﬁes whether to use one-way transport-layer security (TLS). If set to true, the
truststore conﬁgured for CloudStreams must include a certiﬁcate in the email server's
certiﬁcate chain. The default is false.
You can edit this parameter from the TLS Enabled check box on the CloudStreams >
Administration > Email page in Integration Server Administrator.
pg.email.userName
Speciﬁes the user name of the email account used to log into the SMTP server.
You can edit this parameter from the User ﬁeld on the CloudStreams > Administration >
Email page in Integration Server Administrator.
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pg.endpoint.
pg.endpoint.connectionTimeout
Speciﬁes the time interval (in seconds) after which an HTTP connection aempt will
timeout. Default: 30 seconds.
This is a global property that applies to the endpoints of all virtual services. If you prefer
to specify a connection timeout for the endpoints of virtual services individually, set the
HTTP Connection Timeout parameter in the virtual service's "Routing Protocols" processing
step. This parameter takes precedence over pg.endpoint.connectionTimeout.
pg.endpoint.readTimeout
Speciﬁes the time interval (in seconds) after which a socket read aempt will timeout.
Default: 30 seconds.
This is a global property that applies to all virtual services. If you prefer to specify a read
timeout for virtual services individually, set the Read Timeout parameter in the virtual
service's "Routing Protocols" processing step. This parameter takes precedence over
pg.endpoint.readTimeout.

pg.failedProxies.
pg.failedProxies.backupDir
The absolute or relative path to the config directory.

pg.http.
pg.http.ports
Speciﬁes the HTTP ports on which CloudStreams is available.
You can edit this parameter from the HTTP Ports Configuration ﬁeld on the CloudStreams >
Administration > General page in Integration Server Administrator.
pg.https.ports
Speciﬁes the HTTPS ports on which CloudStreams is available.
You can edit this parameter from the HTTPS Ports Configuration ﬁeld on the CloudStreams >
Administration > General page in Integration Server Administrator.

pg.IntervalPool.
The interval pool is used to schedule the processing of recurring tasks.
pg.IntervalPool.minThreads
Speciﬁes the minimum thread count for this interval pool. The default is 1.
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pg.IntervalPool.maxThreads
Speciﬁes the maximum thread count for this interval pool. The default is 1.
pg.IntervalPool.forcefulShutdown
Speciﬁes whether the interval thread pool should wait for queued tasks to complete
during CloudStreams shutdown. Seing this parameter to true will cause CloudStreams
to shut down immediately, without waiting for the tasks to ﬁnish. The default is false.
pg.IntervalPool.poolName
Speciﬁes the name of the interval processor pool. The default is IntervalPool.

pg.jaxbFileStore.
pg.jaxbFileStore.consumerFileStore
Speciﬁes the location of the locally persisted consumer applications that CloudStreams
receives. This ﬁle is updated periodically. The default is resources\consumers
\consumers.xml. The consumers are populated from the CloudStreams > Administration >
Consumers page.

pg.jdbc.
pg.jdbc.active
Speciﬁes whether to send events to CloudStreams JDBC tables (assuming no policies are
violated).
You can edit this parameter from the Database Publishing check box on the CloudStreams >
Administration > Database options page in Integration Server Administrator.
pg.jdbc.batchSize
Speciﬁes the maximum number of records that the JDBC sender should send in a batch.
The default is 25 records.
When the Policy Engine sends events to the database, it uses JDBC batch API for
eﬃciency purposes. This parameter determines the size of the batch before the
Datadirect driver sends records from the Integration Server JVM over to the database.

pg.keystore.
pg.keystore.keyStoreHandle
This is an internal parameter. Do not modify.
pg.keystore.trustStoreHandle
This is an internal parameter. Do not modify.
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pg.lb.
pg.lb.http.url
Specify the primary HTTP load balancer URL and port number to use in
http://hostname :portnumber format.

You can edit this parameter from the Load Balancer URL (HTTP) ﬁeld on the CloudStreams >
Administration > General page in Integration Server Administrator.
pg.lb.https.url
Specify the primary HTTPS load balancer URL and port number to use in
http://hostname :portnumber format.

You can edit this parameter from the Load Balancer URL (HTTPS) ﬁeld on the CloudStreams
> Administration > General page in Integration Server Administrator.
pg.lb.failoverOnDowntimeErrorOnly
Controls CloudStreams's behavior for load-balanced endpoints. The default is false,
which means that in a load-balanced routing scenario, if a service fault is encountered
in the response coming from endpoint 1, then CloudStreams will immediately try the
next conﬁgured endpoint. There is no distinction on the type of fault present in the
response from endpoint 1. However, if this parameter is set to true, then CloudStreams
will failover only if the service fault is a "downtime" error (that is, if it matches one of the
strings deﬁned in the ﬁle:
Integration Server_directory \instances\instance_name \packages\WmCloudStreams
\conﬁg\resources\downtime-paerns.txt

pg.passman.
pg.passman.configFile
This is an internal parameter. Do not modify.

pg.PgMenConfiguration.
pg.PgMenConfiguration.perfDataEnabled
Controls whether CloudStreams sends run-time performance data to the relational
database destination. The default is true.
Note: If this parameter is disabled, CloudStreams will not collect performance
metrics.
You can edit this parameter from the Publish Performance Metrics check box on the
CloudStreams > Administration > Database options page in Integration Server Administrator.
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pg.PgMenConfiguration.publishErrorEvents
Speciﬁes whether to publish Error events to CloudStreams. The default is false.

You can edit this parameter from the Publish Events (Error, Lifecycle, Policy Violation) check
box on the CloudStreams > Administration > Database options page in Integration Server
Administrator.
pg.PgMenConfiguration.publishLifeCycleEvents
Speciﬁes whether to publish Life Cycle events to CloudStreams. The default is false.

You can edit this parameter from the Publish Events (Error, Lifecycle, Policy Violation) check
box on the CloudStreams > Administration > Database options page in Integration Server
Administrator.
pg.PgMenConfiguration.publishPolicyViolationEvents
Speciﬁes whether to publish Policy Violation events to CloudStreams. The default is
false.

You can edit this parameter from the Publish Events (Error, Lifecycle, Policy Violation) check
box on the CloudStreams > Administration > Database options page in Integration Server
Administrator.
pg.PgMenConfiguration.reportInterval
Speciﬁes the how often (in minutes) CloudStreams publishes performance data to
CloudStreams. The default is 60 minutes.
You can edit this parameter from the Publish Interval ﬁeld on the CloudStreams >
Administration > Database options page in Integration Server Administrator.

pg.PgMenConfiguration.sieFlushInterval
Speciﬁes the number of seconds before the accumulated invoked service events are
pushed into the shared cache. The default is 2.
pg.PgMenConfiguration.tickInterval
Speciﬁes the amount of time (in seconds) between each interval processor iteration. This
must be an evenly divisible fraction of the smallest policy interval, which is one minute.
The default is 15.

pg.PgMenSharedCacheManager.
pg.PgMenSharedCacheManager.lockTimeOut
Speciﬁes the amount of time (in seconds) the shared cache waits to obtain a lock before
timing out. The default is 5 seconds.

pg.PgMetricsFormatter.
pg.PgMetricsFormatter.includeFaults
Speciﬁes whether service faults are included in the aggregated performance metrics.
If set to true, the average, minimum, and maximum response times will include failed
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requests in the calculations. The default is false. For more information, "The Key
Performance Indicator (KPI) Metrics" on page 207.

pg.policygateway.
pg.policygateway.targetName
Sets the name of the CloudStreams instance conﬁgured as a target. It is used to identify
this instance of CloudStreams. The default is your-target-name-here.
You can edit this parameter from the Target Name ﬁeld on the CloudStreams >
Administration > General page in Integration Server Administrator.
pg.policygateway.repositoryLocation
This is an internal parameter. Do not modify.
pg.policygateway.deleteTempArtifacts
Speciﬁes whether to delete artifacts that are temporarily persisted by the deployment
receiver. The default is true.

pg.proxyLoader
pg.proxyLoader.proxyLocation
This is an internal parameter. Do not modify.

pg.rampartdeploymenthandler.
pg.rampartdeploymenthandler.signingCertAlias
Speciﬁes the signing alias used to sign the outgoing response from CloudStreams to the
original request service consumer.
You can edit this parameter from the Alias (Signing) ﬁeld on the CloudStreams >
Administration > General page in Integration Server Administrator.
pg.rampartdeploymenthandler.usernameTokenUser
This is an internal parameter. Do not modify.

pg.ReportingPool.
Reporting pool options aﬀect outbound event publishing. The pool includes all events,
including performance data, JDBC and SMTP.
pg.ReportingPool.minThreads
Speciﬁes the minimum thread count for this reporting pool. Enabling more threads
means that CloudStreams can send more events to the event destination faster. The
default is 2.
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pg.ReportingPool.maxThreads
Speciﬁes the maximum thread count for this reporting pool. Enabling more threads
means that CloudStreams can send more events to the event destination faster. The
default is 4.
pg.ReportingPool.forcefulShutdown
Speciﬁes whether the reporting pool should wait for queued tasks to complete during
CloudStreams shutdown. Seing this parameter to true will cause CloudStreams to shut
down immediately, without waiting for the tasks to ﬁnish. The default is true.
pg.ReportingPool.poolName
Speciﬁes the name of the reporting pool. The default is ReportingPool.

pg.ReportingWorkQueue.
pg.ReportingWorkQueue.queueCapacity
Sets the capacity available for data collection tasks stored in the reporting work queue.
Smaller in-memory collection and reporting queues reduce memory load on Integration
Server, but can result in some messages being discarded. If you conﬁgure more memory
for Integration Server, it can support more events in the queues. The default is 5000.

pg.serviceReader.
pg.serviceReader.interval
This is an internal parameter. Do not modify.

wst.cloudConnectorService.
wst.cloudConnectorService.validation
Set this parameter to true if you want cloud connector services to be validated against
the IS document types present in the service signature. The default is true.

wst.connfactory.
wst.connfactory.wirelogEnabled
Set this parameter to true if you want to capture additional debug messages that
show the request's HTTP content that is sent over the wire to the native provider. The
messages also show the response content that was received. This can be useful when
debugging connector service invocations.
You can edit this parameter from the Connection Factory Wire Logging check box on the
CloudStreams > Administration > General page in Integration Server Administrator.
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wst.default.tenant.
wst.default.tenant.id
This is an internal parameter. Do not modify.

wst.product.
wst.product.name
This is an internal parameter. Do not modify.
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