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About this Guide

This guide contains information about publishing and retracting metadata for BPM,
CAF, and Integration Server assets to CentraSite. By publishing asset metadata to
CentraSite, you can make the assets available for reuse in other projects.

Document Conventions

Convention Description

Bold Identifies elements on a screen.

Narrowfont Identifies storage locations for services on webMethods
Integration Server, using the convention folder.subfolder:service .

UPPERCASE Identifies keyboard keys. Keys you must press simultaneously
are joined with a plus sign (+).

Italic Identifies variables for which you must supply values specific to
your own situation or environment. Identifies new terms the first
time they occur in the text.

Monospace
font

Identifies text you must type or messages displayed by the
system.

{ } Indicates a set of choices from which you must choose one. Type
only the information inside the curly braces. Do not type the { }
symbols.

| Separates two mutually exclusive choices in a syntax line. Type
one of these choices. Do not type the | symbol.

[ ] Indicates one or more options. Type only the information inside
the square brackets. Do not type the [ ] symbols.

... Indicates that you can type multiple options of the same type.
Type only the information. Do not type the ellipsis (...).



M
Even Header

webMethods BPM and CAF CentraSite Metadata Help Version 10.0 (Innovation Release) 6

Online Information
Software AG Documentation Website

You can find documentation on the Software AG Documentation website at “hp://
documentation.softwareag.com”. The site requires Empower credentials. If you do not
have Empower credentials, you must use the TECHcommunity website.

Software AG Empower Product Support Website

You can find product information on the Software AG Empower Product Support
website at “hps://empower.softwareag.com”.

To submit feature/enhancement requests, get information about product availability,
and download products, go to “Products”.

To get information about fixes and to read early warnings, technical papers, and
knowledge base articles, go to the “Knowledge Center”.

Software AG TECHcommunity

You can find documentation and other technical information on the Software AG
TECHcommunity website at “hp://techcommunity.softwareag.com”. You can:

Access product documentation, if you have TECHcommunity credentials. If you do
not, you will need to register and specify "Documentation" as an area of interest.

Access articles, code samples, demos, and tutorials.

Use the online discussion forums, moderated by Software AG professionals, to
ask questions, discuss best practices, and learn how other customers are using
Software AG technology.

Link to external websites that discuss open standards and web technology.

http://documentation.softwareag.com
http://documentation.softwareag.com
https://empower.softwareag.com
https://empower.softwareag.com/Products/default.asp
https://empower.softwareag.com/KnowledgeCenter/default.asp
http://techcommunity.softwareag.com
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About webMethodsCentraSite Metadata Help
webMethodsCentraSite metadata enables you to locate and reuse shared webMethods
and other process assets in Designer. webMethodsCentraSite Metadata Help contains
supporting documentation on the following main topics:

“About Metadata in CentraSite ” on page 8

“Working with CentraSite Metadata ” on page 9

“Publishing and Retracting Metadata for BPM and CAF Assets” on page 13

“Registry Explorer View” on page 10

For information about working with metadata in the local workspace, see webMethods
BPM and CAF Workspace Metadata Help.

About Metadata in CentraSite
Metadata is data that describes the assets in webMethods components. An asset is
any object you create and work with in a webMethods component. For example, in
Designer, assets include processes, tasks, portlets, Integration Server documents, e-
forms, Integration Server services, and Web services. CentraSite captures metadata about
each Designer asset stored in its repository.

CentraSite stores a variety of metadata about an asset. All assets have names and
(optionally) descriptions. An asset also may have values for certain properties, such
as the Process ID of a process. If an asset references other assets, like a task step that
references a service, it will have metadata about such associations.

The purpose of metadata is to provide information describing each asset, what it
contains, and what assets it references or depends on. The CentraSite registry enables
reuse of assets among users. You can publish metadata about an asset to CentraSite.
Other users will be able to see the published metadata and incorporate one or more
references to the asset into their own projects. If an asset should not be reused, you can
retract the assets from CentraSite.

For more information about using assets from CentraSite, see “Registry Explorer View”
on page 10 and “Search View” on page 34.

Metadata is accessed by using Designer's search capabilities. You can search metadata
for information about various assets. For more information, see “ CentraSite Metadata
Search” on page 29.

Designer includes two CentraSite perspectives with many advanced views and tools for
a customized CentraSite experience. You can access these from:

Window > Open Perspective >CentraSiteAsset Catalog

Window > Open Perspective >CentraSiteSearch and Browse
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For more information about working with the CentraSite perspectives, see the CentraSite
Help.

The DesignerProcess Development perspective includes the Registry Explorer view so
you can access your CentraSite assets without switching perspectives. See “Registry
Explorer View” on page 10.

Note: Local metadata that is stored on your computer is referred to as workspace
metadata. Workspace metadata is stored in a database, on your computer,
called the workspace index (see "The Workspace Index" in webMethods BPM
and CAF Workspace Metadata Help.

Working with CentraSite Metadata
Keep the following information in mind when working with CentraSite metadata.

CentraSite is a shared repository and registry. Assets are stored in the repository,
and information about those assets, or metadata, is stored in the registry. Both
the workspace index and the CentraSite registry contain metadata about assets.
The difference is that the workspace index is accessible only by you on your own
computer, while the CentraSite registry is accessible to other users. The CentraSite
registry resides on and is maintained by a server on the network.

webMethods assets are pre-installed in CentraSite. When you publish metadata to
CentraSite from the Package Navigator view or Solutions view, Designer performs
a check to ensure that CentraSite has the latest asset definitions. If it does, your
publish action is completed. If it does not, you must update your asset definitions
in CentraSite before you can publish to it. Contact your CentraSite administrator to
have the updated definitions installed.

It is possible to configure and connect to multiple CentraSite registries, but Designer
can only connect to one registry at a time. For more information about connecting to
CentraSite, see the CentraSite Help.

Each CentraSite user can belong to only one organization. By default, each member
of a CentraSite organization is assigned the roles of Asset Provider and Asset
Consumer in the Users group of that organization, allowing the publishing
and usage of assets there. Administrators can choose to revoke or change role
assignments in the Users group, so the default assignments might be different for
some organizations. Administrators can also assign permissions to individual users
and groups to view and create (publish) assets in other organizations. Designer does
not allow users to select an organization when they publish; it publishes using the
organization to which the user belongs. As such, it is important for all collaborating
Designer users working on the same project to publish to CentraSite using the same
organization. Publishing using multiple organizations could lead to access problems,
duplicates, and lost data.

When you reuse an asset from CentraSite, only a minimally required amount of
information about that asset is transferred to the workspace where you use it. As a
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result, when you query the workspace, you do not find the same metadata you find
when you query CentraSite directly.

Reference chains in CentraSite are not fully reflected in the workspace. For example,
if process A references process B, which references process C in CentraSite, when
you reuse process B in your workspace, the relationship between B and C is not
preserved. When you reuse an Integration Server (IS) service from CentraSite, you
lose the information about the relationships that Integration Server (IS) service has
with other assets. If service A calls service B, and you reuse service A, you only get
service A.

CentraSite does not currently support versioning of webMethods asset types. As
such, this functionality is disabled by default for these assets. Do not manually
enable versioning for them in CentraSite; this will lead to unavailable assets.

Before making a change to an asset, you might wish to locate any assets that refer
to it or are dependent on it. This helps ensure you are not making changes that
would adversely affect other assets. For more information, see “Related Assets” on
page 36.

Although you can configure Designer to automatically generate and store metadata
in the workspace index, you cannot automatically publish metadata to CentraSite.
You must select an asset and manually publish it. For more information, see
“Publishing and Retracting Metadata for BPM and CAF Assets” on page 13 and
“Publishing and Retracting Metadata for IS and TN Assets” on page 17.

Workspace indexing is not required for publishing to CentraSite. Local (workspace)
metadata about an asset is created automatically when you enable workspace
indexing and is stored locally in the workspace index, which is accessible only on
your computer. For more information, see webMethods BPM and CAF Workspace
Metadata Help.

Registry Explorer View
The Registry Explorer view displays the contents of the CentraSite registry to which
Designer is currently connected. To connect to a different CentraSite registry, you must
configure it in Preferences. You can connect to only one CentraSite registry at a time, but
you can configure multiple registries.

The CentraSite registry often contains a great deal of data. Designer provides a view
filter for the Registry Explorer view to make it easier to locate webMethods assets.

Note: Due to limitations in the API, the webMethods Assets filter shows some non-
reusable assets, like generated wrapper services and items that have been
referenced but not published themselves. These are not available for use in
processes. The Registry Explorer view allows you to drag them out of the
view, but Designer does not allow you to drop them into any editors.
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The Registry Explorer view is displayed by default in the Process Development
perspective. If you close the Registry Explorer view and want to reopen it, or if you want
to open it in another perspective, click Window > Show View >  Registry Explorer.

Note: If the CentraSite connection is disabled or not properly configured, the
Registry Explorer view displays a message indicating so and a link to
CentraSite preferences, where you can enable or configure the connection. For
information about configuring a connection, see the CentraSite Help.

The following table describes the actions you can perform in the Registry Explorer view.

To... Take this action in the Registry Explorer view...

Enable or disable the
webMethods Assets
filter

To enable the webMethods Assets filter, click View
Menu > Configurations >webMethodsAssets.

Designer retains your selection in your current
workspace until you change it. To disable it, select a
different filter, such as Default.

Expand an asset type The Registry Explorer view is organized by asset type.
Click  next to an asset type to view the assets under it.

Refresh the view Right-click anywhere in the view and click Refresh.
You may need to refresh if you publish metadata with
the Registry Explorer view open. Newly published
metadata will not appear in the Registry Explorer view
until you refresh it.

Refreshing the view collapses any currently expanded
asset type.

Use an asset in one of
your own projects

Drag the asset from the Registry Explorer view onto the
process editor canvas for the project.

When you use an asset from the Registry Explorer,
you are creating a reference to that asset. You are not
including the asset itself in your project; rather, you are
referencing the asset based on its metadata in CentraSite.

Note: The Reuse property for an asset determines whether
the asset can be reused in other projects or canvases.
For information about controlling the reuse of IS
assets, see the webMethods Service Development Help.

Retract metadata
about an asset

Right-click the asset and click Retract.

This removes the asset's metadata from CentraSite.
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To... Take this action in the Registry Explorer view...

Note: You cannot publish or retract process simulation
metadata.

For more information, see:

"Properties View" in webMethods BPM Process Development Help

“Process Simulation” in webMethods BPM Process Simulation Help
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Publishing Metadata for Processes and CAF Applications
You can publish multiple assets at the same time. CTRL + click the assets, right-click any
of them, and then click Publish.

To publish process or CAF application metadata to CentraSite

1. In the Solutions view, right-click an asset and click Publish.

2. In the Publish Assets dialog box, select the assets whose metadata you want to
publish.

By default, the assets you selected will be marked for publishing to CentraSite. If you
do not want metadata for an asset published, clear the check box next to the asset
name.

3. Click OK.

Notes:

If you have the Registry Explorer view open, the assets you published should appear
in it when the publish operation completes. You may have to refresh the view to see
the newly published assets. For more information, see “Registry Explorer View” on
page 10.

Published metadata may not be visible immediately in the Registry Explorer view
or appear in searches performed immediately after publishing. Depending on the
amount of metadata being published, and network and computer resources, there
may be a slight lag. Generally, if you do not see published metadata within a few
minutes, contact your CentraSite system administrator to check on the operation's
progress.

When a process is published, only the process is marked as published. The various
services, processes, documents, etc. used by the process are referenced, not published.
To search for, retract, or reuse a CentraSite asset, it must first be published. However,
note that an unpublished asset can exist in the CentraSite registry as a reference.

For example, If you publish a process (procA) and then use it in a second process
(procB) but you do not publish the second process (procB), CentraSite contains one
process (procA) with no references to it. You can retract that process (procA), because
it is published, and it will be removed from the CentraSite registry completely.
CentraSite does not keep track of whether or not an asset has been used outside of
CentraSite; CentraSite only knows what has been published.
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Retracting Metadata for Processes and CAF Applications
Metadata about an asset can be removed from CentraSite — this is referred to as
retracting metadata. When you retract metadata about an asset from CentraSite, it is no
longer available to other users for use in their own Designer projects.

Keep the following points in mind when retracting metadata for processes or CAF
applications:

Retracting metadata about an asset will not affect other users who have already
referenced the metadata in their own projects; however, the retracted metadata will
no longer be available for future referencing by other users.

Uninstalling Integration Server can cause any published Integration Server assets to
become unreferenced, or orphaned. Retract any published Integration Server assets
before uninstalling the Integration Server that contains those assets.

Problems with retracting can occur if multiple processes with multiple owners
exist in a single process project, even if the users belong to the same organization.
For example, if User1 publishes the process procA, the ownership of procA and
its parent process project (projA) are both set to (User1). User2 publishes another
process (procB) to the same process project (projA). When User1 retracts the procA,
User2 cannot retract procB because User2 is not the owner of its parent process
project (projA), whose only asset is now procB.

You can publish/retract metadata for a multiple assets by pressing the CTRL or
SHIFT keys while selecting assets in Solutions view.

To retract process or CAF application metadata from CentraSite

1. In the Solutions or Registry Explorer view, right-click an asset and click Retract.

2. In the Retract Assets dialog box, select the assets you want to retract.

By default, the assets you selected will be marked for retraction from CentraSite. If
you do not want metadata retraced for an asset, clear the check box next to the asset
name.

3. Click OK.

Designer retracts the assets.

If you have the Registry Explorer view open, the assets you retracted should no
longer appear in it. You may have to refresh the view to see this.
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Available IS and TN Assets
You can publish and retract metadata for Integration Server (IS) assets, IS administrative
assets, and Trading Networks (TN) document types to and from the CentraSite shared
registry. IS administrative assets include Adapter connections, Broker connections, and
JMS connection aliases. By publishing metadata, you make these assets available to other
CentraSite users for activities such as search, documentation, reuse, and impact analysis.

The following table lists the Integration Server and Trading Networks assets that you
can publish and retract, and how they are mapped to CentraSite assets.

Integration Server Asset CentraSite Asset

.NET service IS service

Adapter connection IS connection

Adapter notification IS type definition

Adapter service IS service

Blaze rule service IS service

Broker connection IS connection

C service IS service

Document type (IS document type
and XML document type)

IS type definition

Flat file dictionary IS type definition

Flat file schema IS type definition

Flow service IS service

Integration Server IS server

Java service IS service

JMS connection alias IS connection
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Integration Server Asset CentraSite Asset

JMS trigger IS routing rule

Package IS package

REST resource IS service interface

Schema IS type definition

Specification IS specification

TN document type TN document type

Web service connector IS service

Web service descriptor IS service interface

webMethods messaging trigger IS routing rule

XML field IS type definition

XSLT service IS service

Publishing and Retracting Metadata
You can publish and retract IS assets, IS administrative assets, and TN document types.
Designer publishes and retracts metadata using the credentials defined for a CentraSite
connection in Designer. The CentraSite URL and credentials required for a CentraSite
connection are specified in Designer preferences (Window > Preferences).

For more information about publishing and retracting metadata, see the information in
“Considerations for Publishing and Retracting Metadata” on page 19 and “Usage
Notes for IS Assets” on page 25.

Considerations for Publishing and Retracting Metadata
When you publish or retract metadata for IS assets, IS administrative assets, and TN
document types, keep the following points in mind:

You must configure the CentraSite URL and credentials in the Window > Preferences
page in Designer. Designer uses these credentials and URL to connect to CentraSite
to publish or retract metadata.
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Integration Server must be able to resolve and access the host name defined in the
CentraSite connection configuration in Designer.

When you publish or retract metadata at the Integration Server level, Designer
publishes or retracts packages as well as administrative assets. When you publish
or retract metadata at the asset level, Designer publishes or retracts metadata for the
selected asset only. The selected asset could be a single asset, such as a document
type, or a container, such as a folder or a package.

When publishing metadata for TN document types, you publish metadata for all
TN document types on the Integration Server. When retracting metadata for TN
document types, you retract metadata for all published TN document types. That is,
it is not possible to publish or retract metadata for specific TN document types.

After Designer starts a metadata operation, it executes to completion. You cannot
cancel the operation.

Only one metadata operation can run at a time.

If you select an Integration Server for publishing or retracting metadata, Designer
lists the packages and administrative assets, if any, rather than individual
publishable assets. If you select a folder or package for publishing or retracting
metadata, Designer lists all the publishable or retractable assets in that folder or
package.

If a folder or package contains assets that cannot be published or retracted, Designer
does not list those assets in the Publish Metadata and Retract Metadata dialog boxes.

If an asset cannot be published or retracted, the Publish and Retract commands
appear but are disabled in the context menu.

If CentraSite plug-ins are not installed in Designer, the Publish and Retract commands
will not appear in the context menu.

Publishing Metadata for IS Assets or TN Document Types at the
Integration Server Level
When you publish metadata by selecting the Integration Server and then selecting
Publish from the context menu, you publish metadata at the Integration Server level.
You can publish packages, IS administrative assets, and TN document types when
publishing at the Integration Server level.

Before you publish metadata for IS or TN assets, do the following:

Make sure the Reuse property for the asset is set to the appropriate value. The
Reuse property controls whether or not a published IS asset can be reused in BPM
processes or CAF projects. For more information about controlling the reuse of an IS
asset, see webMethods Service Development Help.

Note: The Reuse property applies only to the namespace elements in Integration
Server.
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Review the information related to publishing assets mentioned in “Usage Notes for
IS Assets” on page 25.

To publish metadata for IS assets or TN document types at the Integration Server level

1. In the Service Development perspective, in Package Navigator view, select the
Integration Server that contains the assets that you want to publish.

2. Right-click the selected Integration Server and select Publish.

If a CentraSite connection is not yet configured, Designer displays the Preferences
window and prompts you to configure a connection. For more information about
configuring a connection, see the CentraSite Help.

3. In the Publish Metadata dialog box, under Select the packages to publish, do the
following:

To publish metadata for packages, select the packages that you want to publish.

Note: Designer lists all the packages that can be published to CentraSite. You
can select multiple packages by pressing the CTRL or SHIFT keys.

To publish metadata for TN document types, select Trading NetworksDocument
Types.

4. If you want Integration Server to automatically publish metadata for packages on
which the selected packages depend, select the Auto-select package dependencies check
box.

5. Click Next if you want to publish administrative assets. Otherwise, click Finish.

Note: The Next buon will be disabled if there are no administrative assets to
publish.

6. Under Select the administrative assets to publish, do one of the following:

To publish all administrative assets, select the Administrative assets check box.

To publish specific administrative assets, select the check boxes next to the
administrative assets that you want to publish.

7. Click Finish.

Designer publishes the metadata and displays the progress of the operation in the
Metadata Publish Status Job dialog box. To close the Metadata Publish Status Job
dialog box, click Cancel. Clicking Cancel does not cancel the operation.

After publishing metadata, Designer displays a summary of the publish operation in
the Published Metadata dialog box on completing the publish operation. Click OK to
close the dialog box.
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Retracting Metadata for IS Assets or TN Document Types at the
Integration Server Level
When you retract metadata by selecting the Integration Server and then selecting Retract
from the context menu, you retract metadata at the Integration Server level. You can
retract metadata for packages, IS administrative assets, and TN document types when
you retract metadata at the Integration Server level.

Before you retract metadata for published assets, review the information given in
“Considerations for Publishing and Retracting Metadata” on page 19 and “Usage
Notes for IS Assets” on page 25.

To retract metadata for IS assets or TN document types at the Integration Server level

1. In the Service Development perspective, in Package Navigator view, select the
Integration Server that contains the assets that you want to retract.

2. Right-click the Integration Server and select Retract.

Note: If a configured CentraSite connection does not exist, Designer displays the
Preferences window and prompts you to configure a connection. For more
information about configuring a connection, see CentraSite Help.

If there are no metadata for packages, IS administrative assets, or TN document
types to retract from CentraSite, Designer displays a message stating that there are
no metadata to retract.

3. In the Retract Metadata dialog box, under Select the packages to retract, do the
following:

To retract metadata for packages from CentraSite, select the packages that you
want to retract.

Note: Designer displays all the published packages from the selected
Integration Server. You can select multiple packages by pressing the
CTRL or SHIFT keys.

To retract published metadata for TN document types, select Trading
NetworksDocument Types.

4. Click Next if you want to retract metadata for published administrative assets.
Otherwise, click Finish.

Note: The Next buon will be disabled if there are no published administrative
assets to retract.

5. Under Select the administrative assets to retract, do one of the following:

To retract metadata for all published administrative assets, select the
Administrative assets check box.
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To retract metadata for specific administrative assets, select the check boxes next
to the administrative assets that you want to retract.

6. Click Finish.

Designer retracts the metadata and displays the progress of the operation in the
Metadata Retract Status Job dialog box. To close the Metadata Retract Status Job
dialog box, click Cancel. Clicking Cancel does not cancel the operation.

Designer displays a summary of the retraction in the Retracted Metadata dialog box
on completing the operation. Click OK to close the dialog box.

Publishing Metadata for IS Assets or TN Document Types at the
Asset Level
When you publish metadata by selecting specific assets and then selecting Publish from
the context menu, you publish metadata at the asset level. You can publish metadata
for individual assets, such as a package, a folder, or an element to CentraSite. You
can also publish metadata for TN document types collectively by selecting Trading
NetworksDocument Types.

Note: You can only publish metadata for IS administrative assets by publishing at
the Integration Server level.

To publish metadata for IS assets or TN document types at the asset level

1. In the Service Development perspective, in Package Navigator view, do the
following:

To publish metadata for a specific asset such as a package, a folder, or an
element, select the asset.

To publish metadata for TN document types, select Trading NetworksDocument
Types.

Note: When publishing metadata for TN document types, you must publish
all available TN document types. That is, it is not possible to publish
metadata for specific TN document types.

2. Right-click and select Publish.

Note: If a CentraSite connection is not yet configured, Designer displays the
Preferences window and prompts you to configure a connection. For more
information about configuring a connection, see the CentraSite Help.

3. In the Asset Publish dialog box, select the assets that you want to publish.

By default, all the assets you selected in the Package Navigator view will be marked
for publishing to CentraSite. If you selected a package or folder in the Package
Navigator view, Designer lists all the publishable assets in the folder or package.
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To deselect any of the selected assets, clear the check box next to the asset.

To deselect all the selected assets, click Deselect All.

To select an asset, select the check box next to the asset.

To select all the assets, click Select All.

4. Click OK.

Designer publishes the metadata and displays the progress of the operation in the
Metadata Publish Status Job dialog box. To close the Metadata Publish Status Job
dialog box, click Cancel. Clicking Cancel does not cancel the operation.

After publishing metadata, Designer displays a summary of the publish operation in
the Published Metadata dialog box. Click OK to close the dialog box.

Retracting Metadata for IS Assets or TN Document Types at the
Asset Level
When you retract metadata by selecting specific assets and then selecting Retract from
the context menu, you retract metadata at the asset level. You can retract metadata
for individual assets, such as a package, a folder, or an element from CentraSite. You
can also retract metadata for TN document types collectively by selecting Trading
NetworksDocument Types.

Note: You can only retract metadata for IS administrative assets by retracting at the
Integration Server level.

To retract metadata for IS assets or TN document types at the asset level

1. In the Service Development perspective, in Package Navigator view, do the
following:

To retract metadata for a specific asset such as a package, a folder, or an element,
select the specific asset.

To retract published metadata for TN document types, select Trading
NetworksDocument Types.

Note: When retracting metadata for TN document types, you must retract
all published TN document types. That is, it is not possible to retract
metadata for specific TN document types.

2. Right-click and select Retract.

Note: If a CentraSite connection is not yet configured, Designer displays the
Preferences window and prompts you to configure a connection. For more
information about configuring a connection, see the CentraSite Help.
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If none of the assets that you selected was published to CentraSite, Designer displays
a message stating that the assets do not exist in CentraSite and cannot be retracted. If
you have selected multiple assets and at least one of the assets can be retracted from
CentraSite, this message does not appear.

3. In the Asset Retract dialog box, select the assets that you want to retract.

By default, the assets you selected in the Package Navigator view will be marked for
retraction from CentraSite. If you right-clicked a package or folder in the Package
Navigator view, Designer lists all the published assets in the folder or package
and selects them for retraction. You can deselect the assets that you do not want to
retract.

To deselect any of the selected assets, clear the check box next to the asset.

To deselect all the selected assets, click Deselect All.

To select an asset, select the check box next to the asset.

To select all the assets, click Select All.

4. Click OK.

Designer retracts the metadata and displays the progress of the operation in the
Metadata Retract Status Job dialog box. To close the Metadata Retract Status Job
dialog box, click Cancel. Clicking Cancel does not cancel the operation.

Designer displays a summary of the retraction in the Retracted Metadata dialog box
on completing the operation. Click OK to close the dialog box.

Usage Notes for IS Assets
Keep the following information in mind when publishing and retracting metadata for IS
assets:

You cannot retract a published asset that is referenced by another published asset
until the asset that established the reference is retracted. For example, suppose
that you publish a process (processA), that uses an IS service (serviceA). Then, you
publish the package (packageA) that contains serviceA. Because processA depends
on an asset in packageA, you can only retract packageA (and any of its contents)
after you retract processA. If you change processA so that it no longer references
serviceA and republish processA, you can retract packageA.

Uninstalling Integration Server can cause any published Integration Server assets to
become unreferenced, or orphaned. Retract any published Integration Server assets
before uninstalling the Integration Server that contains those assets.

If a published IS asset is in pending state in CentraSite, retracting the package that
contains the IS asset results in an orphaned asset in CentraSite. For example, suppose
that you published a package containing an IS service to CentraSite. If you change
the life cycle state of the IS service asset to “Deploy” and then retract the package
while the state change is pending, the IS service asset is not deleted when the
package is retracted. The IS service asset becomes an orphaned asset in CentraSite.
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CentraSite only establishes the “Uses” relationship between the IS Service Interface
asset created for a consumer Web service descriptor and the Service asset created
for a web service if the Service asset exists in CentraSite before you publish the
consumer Web service descriptor.

If you create the web service asset in CentraSite by importing its WSDL after
publishing the consumer Web service descriptor, republish the consumer Web
service descriptor to establish the “Uses” relationship between the IS Service
Interface asset created for the Web service descriptor and the Service asset created for
the web service.

You can use the scheduler capabilities within Integration Server to schedule
the pub.metadata.assets:publishPackages service to publish information about
Integration Server packages and administrative assets to CentraSite. The
pub.metadata.assets:publishPackages service publishes metadata to CentraSite using
Integration Server credentials. For more information about configuring CentraSite
credentials on Integration Server, see webMethods Integration Server Administrator’s
Guide. For more information about scheduling services, see webMethods Integration
Server Built-In Services Reference.

To establish the correct relationships between Web service descriptors created from
WSDL documents and the CentraSite Service asset, use the New wizard in Designer
to create the Web service descriptor and select CentraSite as the source location. If
you create a Web service descriptor from a WSDL in CentraSite through the UDDI
registry or directly from a file or URL, the “Uses” and “Implements” relationships
will not be established between the Web service descriptor and the CentraSite service
asset.

If you intend to change the compatibility mode of a Web service descriptor for which
you published metadata to CentraSite, first retract metadata for the Web service
descriptor. Next, change the compatibility mode. Finally, republish metadata for the
Web service descriptor to CentraSite.

For more information about Web service descriptors and compatibility mode, see the
webMethods Service Development Help.

Each asset in CentraSite has a “Deployed On” property that identifies each
Integration Server from which an asset with that name has been published.
However, the Integration Servers might have published different versions of the
same asset or completely different assets that happen to have the same name. In
CentraSite, it will appear as if both Integration Servers published the exact same
asset. CentraSite will maintain the asset that was most recently published.

For example, suppose that Integration Server1 publishes a service named myService.
CentraSite creates an IS service asset with the name myService and a “Deployed On”
property value of Integration Server1. Later, Integration Server2 also publishes
a service named myService but the service published by Integration Server2 is not
identical to the service published by Integration Server1. CentraSite will update
the IS service asset to represent the myService service published Integration Server2.
CentraSite also updates the “Deployed On” property value to be: Integration



M
Odd Header

Publishing and Retracting Metadata for IS and TN Assets

webMethods BPM and CAF CentraSite Metadata Help Version 10.0 (Innovation Release) 27

Server1, Integration Server2. CentraSite indicates that both Integration Servers
published an identical asset when, in fact, they did not.

When an Integration Server retracts an asset, CentraSite removes that Integration
Server from the “Deployed On” property for the CentraSite asset. If the asset is not
deployed on another Integration Server, CentraSite removes the asset. If the asset is
deployed on another Integration Server, the asset remains in CentraSite. The content
of the CentraSite asset will be the asset that was most recently published. This might
result in a CentraSite asset whose content does not represent the IS asset that was
published by the Integration Server listed in the “Deployed On” property.

To continue the above example in which Integration Server1 and then Integration
Server2 published different versions of services named myService, if Integration
Server2 retracts myService, CentraSite removes Integration Server2 from the
“Deployed On” property value. However, the content of the myService asset in
CentraSite represents the myService asset published by Integration Server2 because
Integration Server2 published the asset most recently. This results in CentraSite
indicating that the myService asset published by Integration Server2 is deployed on
Integration Server1.

Status Information for Publish and Retract Requests
During and after execution of publish and retract requests, Designer displays status
information for each package in the request and the overall request.

Status Description

complete Integration Server completed the publication or retraction
request.

error An error occurred while publishing or retracting the metadata.
Refer to the Integration Server log for more information.

retracting Integration Server is removing the assets from CentraSite. This
status applies to retraction requests only.

publishing Integration Server is sending the metadata to CentraSite. This
status applies to publication requests only.

starting Integration Server is starting the request. This is always the
initial state when a request is submied.

counting Integration Server is counting the number of assets in the
package or the number of TN document types.
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Status Description

counted Integration Server has completed counting the number of
assets in the package or the number of TN document types.
The total number is displayed in the Assets column.

extracting Integration Server is extracting the metadata for selected assets.

Summary Information for Publish and Retract Requests
Designer displays the following information about the metadata for IS assets, IS
administrative assets, or TN document types in the Published Metadata and Retracted
Metadata windows.

Column Description

Asset If a package was selected for metadata publication or retraction,
this column displays the package name.

If Trading NetworksDocument Types was selected for metadata
publication or retraction, this field displays Trading Networks
Document Types.

Status The status of the metadata operation. For more information about
status values for metadata operations, see “Status Information for
Publish and Retract Requests” on page 27.

The Published Metadata and Retracted Metadata windows display the following
summary information for the entire publication or retraction request:

Field Description

Status The overall status of the publication or retraction request.

Assets The total number of assets processed in the publication request.

This field only applies to publish requests.

Duration The time (in hh:mm:ss) Integration Server spent executing the
publication or retraction request.
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webMethods Search
To locate assets and/or asset references, Designer searches the metadata associated with
assets. You can choose to search only the workspace index, only CentraSite, or both
the workspace index and CentraSite. For more information, see “About Metadata in
CentraSite ” on page 8, as well as "Metadata in Your Workspace" in webMethods BPM and
CAF Workspace Metadata Help.

Important: When you reuse an asset from CentraSite, only a minimally required amount
of information about that asset is transferred to the workspace where you
use it. As a result, when you query the workspace, you do not find the
same metadata you find when you query CentraSite directly. Additionally,
reference chains in CentraSite are not fully reflected in the workspace.For
example, if process A references process B, which references process C in
CentraSite, when you reuse process B in your workspace, the relationship
between B and C is not preserved. When you reuse an Integration Server (IS)
service from CentraSite, you lose the information about the relationships that
Integration Server (IS) service has with other assets. If service A calls service
B, and you reuse service A, you only get service A.

Note: If you have workspace indexing disabled now or had it disabled in the past,
you might have assets in your workspace for which there is no or incomplete
metadata. In this case, the search will not properly locate these assets. For
more information, see "Enabling or Disabling Workspace Indexing" in the
PDF publication webMethods BPM and CAF Workspace Metadata Help.

The following table lists the types of searches that Designer provides for searching for
assets:

Type of Search How to Access... Description

Basic keyword
search

webMethods tab
in the Search
window

Use to locate assets or asset references
based on keywords contained in the
asset's name and/or description.

In both Basic and Advanced searches,
you can locate all assets of a particular
type by selecting the asset and specifying
no search criteria.

Advanced
search

webMethodsAdvanced
tab in the Search
window

Use to locate assets of a single type. For
example, you can search for portlets or
you can search for IS document types, but
not both portlets and IS document types
in a single search.
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Type of Search How to Access... Description

The advanced search allows you to
specify detailed search criteria to locate
specific assets. For example, you can
search for processes with names that
contain "HR", with a model version
that is equal to "2", and that references
another process with a name that
contains "approve".

In both webMethods basic and advanced
searches, you can locate all assets of a
particular type by selecting the asset and
specifying no search criteria.

Saved
searches

Saved Searches
view

Use to locate assets of a single type. For
example, you can search for portlets or
you can search for processes, but not both
portlets and processes in a single search.

Designer provides predefined saved
searches of assets used in your solutions.
You can search your workspace for all
CAF Task Types, Portlets, or Processes;
and you can search CentraSite for all
Documents, E-forms, IS Services, Rule
Services, or Web Services.

You can define and save additional
searches. When defining your own saved
search, you can specify detailed search
criteria to locate specific assets, similar
to the criteria you can specify for an
advanced search.

Performing webMethods Basic Searches
Use a basic search to locate assets or asset references based on keywords contained in
the asset's name and/or description. Designer displays the results of your search in the
Search view.

To locate assets and/or asset references, Designer searches the metadata associated with
assets. You can choose to search only the workspace index, or both the workspace index
and CentraSite. For more information, see “Registry Explorer View” on page 10 and
"The Workspace Index" in webMethods BPM and CAF Workspace Metadata Help.
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Note: If you have workspace indexing disabled now or had it disabled in the past,
you might have assets in your workspace for which there is no or incomplete
metadata. In this case, the search will not properly locate these assets. For
more information, see "Enabling or Disabling Workspace Indexing" in the
PDF publication webMethods BPM and CAF Workspace Metadata Help.

To perform a basic search for webMethods assets

1. In Designer, select Search > Search .

The webMethods tab has focus by default.

Selections from the previous search are retained.

2. In the Name or description contains field, specify a keyword that is contained in the
name or description of the assets you want to locate. The search is not case sensitive.

3. Select the type of assets that you want to locate from the Asset Type list. You can
select All to search for all types of assets and asset references, or you can select one of
the listed asset types.

4. In the Search in field, click:

Workspace to search metadata in the workspace index only.

CentraSite to search metadata in CentraSite only.

Workspace &CentraSite to search metadata in both the workspace index and
CentraSite.

5. Click Search.

Performing webMethods Advanced Searches
Use an advanced search to specify detailed search criteria to locate specific assets.
When you perform an advanced search, you can only locate assets of a single type.
For example, you can search for portlets or you can search for Integration Server (IS)
document types, but not both portlets and Integration Server (IS) document types in a
single search. Designer displays the results of your search in the Search view.

To locate assets and/or asset references, Designer searches the metadata associated with
assets. You can choose to search only the workspace index, or both the workspace index
and CentraSite. For more information, see “Working with CentraSite Metadata ” on
page 9.

Note: If you have workspace indexing disabled now or had it disabled in the
past, you might have assets in your workspace for which there is missing or
incomplete metadata. In this case, the search will not properly locate these
assets. For more information, see "Enabling or Disabling Workspace Indexing"
in the PDF publication webMethods BPM and CAF Workspace Metadata Help.
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To perform an advanced search for webMethods assets

1. In Designer, select Search > Search .

2. Click the webMethodsAdvanced tab.

Selections from the previous search are retained.

3. Select the type of asset you want to locate from the Asset Type list.

4. For each search criterion you want to use:

a. Click Add.

b. In the Add Query Condition window, click Asset Field and select an item. The
items that Designer includes in the Asset Field list depends on the Asset Type you
select.

c. Complete specifying the condition for the selected Asset Field. Note that the
search is not case sensitive.

d. Click OK.

5. In the Match condition field, select:

Any to have Designer locate assets that match any of the criteria you specified.

All to have Designer locate assets only if they match all of the criteria that you
specified.

Note: If you select References from Asset Field and All for Match condition,
Designer finds assets that contain all the specified references, but those
references do not necessarily have to be all in one place. For example,
if you have a condition to locate all processes that reference processes
with names that contain "HR" and also reference processes with a
process version that contains "2", Designer might find a process that
contains one step for a referenced process with the name "HR-Tasks"
and a process version "3" and another step for a referenced process with
the name "ApproveOrder" and a process version "2".

6. In the Search in field, select:

Workspace to search metadata in the workspace index only.

CentraSite to search metadata in CentraSite only.

Workspace &CentraSite to search metadata in both the workspace index and
CentraSite.

Note: Services and documents associated with processes are not searchable
in the workspace. However, you can show the references and
dependencies of processes to locate these assets. See “Showing Asset
References and Dependencies” on page 37.

7. To initiate the search, click Search.
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Configuring Search Preferences
You can configure standard Eclipse preferences for searching. For more information, see
the Eclipse documentation.

To configure Search preferences

1. In Designer, select Window > Preferences > General > Search.

2. Set the preferences you want for each of the following options. You can also click
Restore Defaults to reset all Search preferences to their initial installed values.

For more information about each of these options, see the Eclipse documentation.

3. Click Apply to apply your changes without closing the Preferences window.

Click OK to apply your changes and close the Preferences window.

For more information, see "Metadata in Your Workspace" in webMethods BPM and CAF
Workspace Metadata Help.

Search View
The Search view is a standard Eclipse view. Designer displays the results of a search in
the Search view.

Search results do not display referenced assets. For example, if you publish a package
that contains one service, but that service in turn calls other services in different
packages, then when you search for all services you will only see the one service in the
package you published, not all of the referenced services. To see what your one service
depends on, you can Show Dependencies, and to see what your one service refers to, you
can Show References.

When you choose to show references or dependencies in the Solutions or Registry
Explorer view, the results are shown in the Search view. See “Showing Asset References
and Dependencies” on page 37.

The table below lists the actions you can take from the Search view.

Action Description

View
dependencies of
an asset

Right-click a row in the Search view.

Select Show Dependencies >  InCentraSite or Show
Dependencies > In Workspace.

For more information, see “Showing Asset References and
Dependencies” on page 37.
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Action Description

Note: Because Designer uses metadata to determine
dependent assets, if you have set your Designer
preferences to disable workspace indexing, the
Search view might not list all dependencies. For more
information, see "Enabling or Disabling Workspace
Indexing" in the PDF publication webMethods BPM and
CAF Workspace Metadata Help.

View references
of an asset

Right-click a row in the Search view.

Select Show References > InCentraSite or Show References >
In Workspace.

For more information, see “Showing Asset References and
Dependencies” on page 37.

Note: Because Designer uses metadata to determine
referenced assets, if you have set your Designer
preferences to disable workspace indexing, the Search
view might not list all references. For more information,
see "Enabling or Disabling Workspace Indexing" in the
PDF publication webMethods BPM and CAF Workspace
Metadata Help.

Add an item in
the search results
to the process
editor's canvas

Select a row in the search results and drag it on to the
process editor's canvas.

Note: The item in the search result must be appropriate for
the type of asset on the canvas for the drag and drop to
succeed.

Note: When you use an asset from CentraSite, you are
creating a reference to that asset. You are not including
the asset itself in your project or solution; rather, you
are referencing the asset based on its metadata in
CentraSite. CentraSite assets show CentraSite in the
Store column.

 Show Next
Match

Selects the next item in the search results.

 Show Previous
Match

Selects the previous item in the search results.
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Action Description

 Remove
Selected Matches

Removes the currently selected matches from the Search
view. Select one, or CTRL + click to select multiple matches.

 Remove All
Matches

Removes all matches currently shown in the Search view.

 Run the Current
Search Again

Repeats the current search to reflect changes to results.

 Cancel Current
Search

Cancels the current search.

 Show Previous
Searches

Browse previously conducted searches and repeat a previous
search. Shows previous searches and allows you to select
one.

Select Show Previous Searches Menu to see a list of the most
recent searches. Select one to run again.

Select Show Previous Searches Menu > History to see the
history of your previous searches.

Select Show Previous Searches Menu > Clear History to remove
all previous search history information, including the one
currently displayed.

 Pin the Search
View

Pinning the Search view means that subsequent searches
display results in another Search view, leaving the pinned
view and its results unchanged.

Designer displays the Search view automatically when you execute a search. If you close
the Search view and want to reopen it, click Window > Show View > General >  Search.

Related Assets
Search results do not display referenced assets. For example, if you publish a package
that contains one service, but that service in turn calls other services in different
packages, then when you search for all services you will only see the one service in the
package you published, not all of the referenced services. To see what your one service
depends on, you can Show Dependencies, and to see what your one service refers to, you
can Show References.

For a selected asset, you can view related assets: references and dependencies.
Referenced assets are used by the selected asset. Dependent assets use, or "depend on,"
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the selected asset. For example, a process might use a number of Integration Server (IS)
services. The IS services are references of the process.

You can view the related assets of an asset by right-clicking it in the Solutions or Registry
Explorer view and then choosing Show References or Show Dependencies. The related
assets are displayed in the Search view.

You can also view the related assets of an asset returned by a search. In the Search view,
right-click the asset and choose Show References or Show Dependencies.

Related asset information is metadata that comes from either the workspace index (see
"The Workspace Index" in webMethods BPM and CAF Workspace Metadata Help). When
you choose to view related assets, you are given a choice of viewing the related asset
information from the workspace index or CentraSite. The related asset information for
the same asset might be different in the workspace index than in CentraSite. The latest
changes to the asset reflected in the workspace index may not have been published to
CentraSite, or the version in the workspace index may not have been updated with the
latest changes reflected in CentraSite.

Only directly related assets are shown in the Search view. For example, if A references B
and B references C, only B is shown as a reference of A. C is not shown because it is not
directly referenced by A.

Showing Asset References and Dependencies
When you choose to show the related assets of an asset, they are displayed in the Search
view:

 References are the assets that are used by (referred to by) the selected asset.

 Dependencies are the assets that use (depend on) the selected asset.

Note: If you have workspace indexing disabled now or had it disabled in the
past, you might have assets in your workspace for which there is no or
incomplete metadata. In this case, Designer might not show all references or
dependencies. For more information, see "Enabling or Disabling Workspace
Indexing" in the PDF publication webMethods BPM and CAF Workspace
Metadata Help.

To show the references or dependencies of an asset

1. In the Solutions or Search view, right-click the asset for which you want to view
references or dependencies.

2. Select Show References or Show References and then:

InCentraSite to show assets found in CentraSite.

In Workspace to show assets found in the workspace index.

Note: The related asset information for the same asset might be different
in the workspace index than in CentraSite. The latest changes to the
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asset reflected in the workspace index may not have been published to
CentraSite, or the version in the workspace index may not have been
updated with the latest changes reflected in CentraSite.

3. Designer displays referenced or dependent assets (based on your selection) in the
Search view.

Note: Only direct references and dependencies are shown. For example, A
references B and B references C. If you choose to view the references of A,
only B is shown. Likewise, A has dependency B and B has dependency C.
If you choose to view the dependencies of A, only B is shown.

Saved Searches View
The Saved Searches view allows you to perform searches that are already defined. These
searches can include assets in your local workspace, CentraSite, or both. When you
execute a saved search, Designer displays the results in the Search view.

Designer provides predefined saved searches of assets used in your solutions. You
can search your workspace for all CAF Task Types, Portlets, or Processes; and you can
search CentraSite for all Documents, E-forms, IS Services, Rule Services, or Web Services.

webMethods predefined saved searches are designated by the webMethodsPredefined
Saved Search icon. You cannot edit, delete, rename, or duplicate any of the predefined
saved searches.

webMethodsPredefinedSaved Search Use this saved search to locate...

 All CAF Task Types in Workspace All CAF task types in your workspace.

 All Documents inCentraSite All Integration Server (IS) or Trading
Networks (TN) document types in
CentraSite.

 All E-forms inCentraSite All e-forms in CentraSite.

The Name field displays the template
name.

 All IS Services inCentraSite All IS services in CentraSite (including
rule services).

 All Portlets in Workspace All portlets in your workspace.

 All Processes in Workspace All processes in your workspace.
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webMethodsPredefinedSaved Search Use this saved search to locate...

 All Rule Services inCentraSite All rule services in CentraSite.

 All Web Services inCentraSite All Web services in CentraSite.

In addition to the predefined saved searches that webMethods provides, you can create
additional saved searches where you define the search criteria. You can delete, rename,
and change the criteria for saved searches that you define.

To add a new saved search, you can:

Create a new saved search where you specify all the criteria.

Duplicate an existing saved search and edit the criteria if you want to add a saved
search that is similar to an existing one.

Import saved searches that were previously exported.

The Saved Searches view is shown by default in the Process Development perspective.
If you close the Saved Searches view and want to reopen it, or if you want to open it in
another perspective, click Window > Show View >  Saved Searches.

Creating Saved Searches
Use a saved search to specify detailed search criteria to locate specific assets. When you
create a saved search, you can define criteria to locate only assets of a single type. For
example, you can define a saved search for portlets or you can define a saved search
for IS document types, but you cannot define a single saved search that locates both
portlets and IS document types. You can save workspace searches, CentraSite searches,
or searches of both the workspace and CentraSite.

To create a saved search

1. In Designer, if the Saved Searches view is not visible, open it: Window > Show View >
 Saved Searches

2. In the Saved Searches view, click Add Saved Search.

3. In the Add Saved Search window, type a Search Name.

4. Select the type of asset you want the saved search to locate from the Asset Type list.

5. For each search criterion you want to use:

a. Click Add.

b. In the Add Query Condition window, click Asset Field and select an item. The
items that Designer includes in the Asset Field list depends on the Asset Type you
select.
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Note: Although Designer will allow any entry in the Provide the Aribute
Name to Search box, the aribute must exist in the Web service
taxonomy in order to return valid results.

c. Complete specifying the condition for the selected Asset Field. Note that the
search is not case sensitive.

d. Click OK.

6. In the Match condition field, select.

Any to have Designer locate assets that match any of the criteria you specified.

All to have Designer locate assets only if they match all of the criteria that you
specified.

Note: If you select References from Asset Field and All for Match condition,
Designer finds assets that contain all the specified references, but those
references do not necessarily have to be all in one place. For example,
if you have a condition to locate all processes that reference processes
with names that contain "HR" and also reference processes with a
process version that contains "2", Designer might find a process that
contains one step for a referenced process with the name "HR-Tasks"
and a process version "3" and another step for a referenced process with
the name "ApproveOrder" and a process version "2".

7. In the Search in field, select:

Workspace to search metadata in the workspace index only.

Workspace &CentraSite to search metadata in both the workspace index and
CentraSite.

8. Click Save.

Duplicating Saved Searches
If you want to create a saved search that is similar to an existing one, you can duplicate
an existing user-defined saved search and edit its search criteria.

Note: You cannot edit, rename, or duplicate webMethods predefined saved
searches.

To duplicate an existing saved search

1. In Designer, if the Saved Searches view is not visible, open it: Window > Show View >
 Saved Searches.

2. In the Saved Searches view, right-click the saved search you want to duplicate and
click Duplicate Saved Search.

3. In the Copy Saved Search window, specify a Saved Search Name.
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4. Click OK.

You can edit the duplicated saved search to update the search criteria.

Executing Saved Searches
When you execute a saved search, Designer locates assets and/or asset references that
match your search criteria and displays the search results in the Search view.

Note: If you have workspace indexing disabled now or had it disabled in the past,
you might have assets in your workspace for which there is no or incomplete
metadata. In this case, the search will not properly locate these assets. For
more information, see "Enabling or Disabling Workspace Indexing" in the
PDF publication webMethods BPM and CAF Workspace Metadata Help.

To execute a saved search

1. In Designer, if the Saved Searches view is not visible, open it: Window > Show View >
 Saved Searches.

2. In the Saved Searches view, right-click the saved search you want to execute and
click Execute Saved Search.

Tip: You can also double-click a saved search to execute it.

Renaming Saved Searches
You can rename user-defined saved searches.

Note: You cannot edit, rename, or duplicate webMethods predefined saved
searches.

To rename a saved search

1. In Designer, if the Saved Searches view is not visible, open it: Window > Show View >
 Saved Searches.

2. In the Saved Searches view, right-click the saved search you want to rename and
click Rename Saved Search.

3. In the Rename Saved Searches window, specify a New Saved Search Name.

4. Click OK.

Editing Saved Searches
You can edit the search criteria for user-defined saved searches.
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Note: You cannot edit, rename, or duplicate webMethods predefined saved
searches.

To edit a saved search

1. In Designer, if the Saved Searches view is not visible, open it: Window > Show View >
 Saved Searches.

2. In the Saved Searches view, right-click the saved search you want to edit and click
Edit Saved Search.

3. If you want to rename the Saved Search, update the name in the Search Name field.

4. If you want to change the type of assets the saved search locates, select a new asset
type from the Asset Type list.

Important: Search criteria is based on Asset Type.If you select a new Asset Type while
editing a saved search, Designer removes all existing search criteria, and
you must rebuild the search.

5. To modify an existing search criterion:

a. Select the row for the search criterion and click Edit.

b. In the Edit Query Condition window, update the search condition.

c. Click OK.

6. To delete a search criterion, select the row for the search criterion and click Remove.

7. To add a new search criterion:

a. Click Add.

b. In the Add Query Condition window, click Asset Field and select an item. The
items that Designer includes in the Asset Field list depends on the Asset Type you
selected.

Note: Although Designer allows any entry in the Provide the Aribute Name
to Search box, the aribute must exist in the Web service taxonomy to
return search results.

c. Complete specifying the condition for the selected Asset Field. Note that the
search is not case sensitive.

d. Click OK.

8. If you want to change whether Designer matches all of the search criteria or any one
search criterion, update the Match condition field. Select:

Any to have Designer locate assets that match any of the criteria you specified.

All to have Designer locate assets only if they match all of the criteria that you
specified.
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Note: If you select References from Asset Field and All for Match condition,
Designer finds assets that contain all the specified references, but those
references do not necessarily have to be all in one place. For example,
if you have a condition to locate all processes that reference processes
with names that contain "HR" and also reference processes with a
process version that contains "2", Designer might find a process that
contains one step for a referenced process with the name "HR-Tasks"
and a process version "3" and another step for a referenced process with
the name "ApproveOrder" and a process version "2".

9. In the Search in field, select:

Workspace to search metadata in the workspace index only.

Workspace &CentraSite to search metadata in both the workspace index and
CentraSite.

10. Click Save.

Exporting Saved Searches
You can export all user-defined saved searches to an XML file. You can keep the file as a
backup or use it to import the saved searches into another workspace.

To export all user-defined saved searches

1. In Designer, if the Saved Searches view is not visible, open it: Window > Show View >
 Saved Searches.

2. In the Saved Searches view, click Menu  (in the upper right corner) and click
Export Saved Searches.

3. In the Save As window, select the location where you want to store your saved
searches, specify a name for the exported XML file, and save the XML file to your file
system.

Importing Saved Searches
You can import user-defined saved searches into Designer from an XML file that has
been exported from Designer.

To import user-defined saved searches from an XML file

1. In Designer, if the Saved Searches view is not visible, open it: Window > Show View >
 Saved Searches.

2. In the Saved Searches view, click Menu  (in the upper right corner) and click
Import Saved Searches.

3. In the Open dialog box, browse to and select the XML file that contains the exported
saved searches you want to import.
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4. Click Open.
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