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Tamino X-Plorer

The Tamino X-Plorer documentation is intended for designers, builders and developers of XML
database applications who need to explore and manipulate the contents of a Tamino XML Server.

This documentation covers the following topics:

Installation and Getting Started

Introducing the Tamino X-Plorer

Installing the Tamino X-Plorer

First Steps with the Tamino X-Plorer

Using the Tamino X-Plorer

Starting and Leaving the Tamino X-Plorer

Elements of the Main Application Window

Servers and Databases

Browsing Through a Tamino Database

General Commands for Managing Different Types of Objects

Working with Schemas

Working with Instances

Setting the Tamino X-Plorer and X-Query Options

Instances in WebDAV Enabled Collection

Performing X-Queries with the Tamino X-Plorer

Invoking and Closing X-Query Windows

Elements of an X-Query Window

Working with X-Queries

Managing X-Query Results

Using the Tamino XQuery Tool

Starting and Leaving the Tamino XQuery Tool

Elements of the Tamino XQuery Window

Working with the Tamino XQuery Tool

Managing XQuery Results

Setting the Tamino XQuery Tool Options

Reference

Menu Commands in the Main Application Window

Menu Commands in an X-Query Window

Menu Commands in a Tamino XQuery Window

Predefined External Tools

vii
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I Introducing the Tamino X-Plorer
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1 Introducing the Tamino X-Plorer

The Tamino X-Plorer displays the contents of Tamino XML Server in a navigation tree, thus allowing
you to explore and manipulate its contents.
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The features of the Tamino X-Plorer are summarized below.

Explore databases

■ Connect to Tamino servers and their XML databases.
■ Navigate and browse through collections, groups of schemas and groups of instances.
■ Display the contents of documents in the standard formats XML, HTML, TXT, GIF, JPG, BMP,

TIFF and SVG.
■ Define different views for the document contents.
■ Browse through very large amounts of data using highly sophisticated fetch options, filter

mechanisms and display options.

Query a database

■ Query and display instances or fragments of instances.
■ Specify and execute queries directly.
■ Save and load queries.
■ Define different result views.

Maintain the structure and contents of a database

■ Define, update and undefine existing schemas.
■ Insert, update and delete existing instances. Multiple insertions and deletions of instances are

supported.

Display, create and edit objects in a database

■ For schemas, invoke the Tamino Schema Editor.
■ For XML instances, invoke an appropriate external tool or start an application.
■ For non-XML instances, invoke an external tool which supports the corresponding media type

(for example, Adobe Reader for PDF).
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Support for developing Tamino applications

■ Invoke useful tools for application development, for example, a tool which generates test data
for a specific doctype.

View externally maintained data

■ View administrative data such as security data or server extensions of a Tamino XML Server.
■ View WebDAV-enabled collections which contain documents controlled by a WebDAV server.
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II Installing the Tamino X-Plorer
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2 Installing the Tamino X-Plorer

■ After you have Installed the Tamino X-Plorer ......................................................................................... 10
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The Tamino X-Plorer is automatically installed if you choose the option "Complete" of the Tamino
XML Server installation. For more information, refer to the installation section of the Tamino XML
Server documentation.

After you have Installed the Tamino X-Plorer

Non-ASCII Characters

In order to enable this Java based graphical tool to display non-ASCII characters, users can edit
or create their own font.properties files to to map logical font names to physical fonts.
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III First Steps with the Tamino X-Plorer
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3 First Steps with the Tamino X-Plorer

■ Starting the Tamino X-Plorer .............................................................................................................. 14
■ Connecting to a Database ................................................................................................................. 14
■ Browsing through a Database ............................................................................................................ 14
■ Displaying Packs of Instances ............................................................................................................ 15
■ Specifying the Instance Fetch Options ................................................................................................. 15
■ Using Instance Descriptors ................................................................................................................ 15
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■ Adding Instances and Schemas to a Database ...................................................................................... 16
■ Checking the Open Location .............................................................................................................. 16
■ Modifying a Schema or Instance ......................................................................................................... 16
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This chapter is intended to get you started with the most important features of the Tamino X-
Plorer. It is recommended that you read the topics in the sequence indicated below. After reading
a section which is referenced in a topic below, you should always return to this chapter and then
proceed with the next topic.

The following topics are covered below:

Starting the Tamino X-Plorer

See Starting the Tamino X-Plorer for information on how to start the Tamino X-Plorer on the
supported platforms.

Connecting to a Database

When you start the Tamino X-Plorer for the very first time, the navigation tree on the left is empty
since you have not yet connected to a server and database.

Connect to any Tamino database which has been previously activated using the Tamino Manager.
See Connecting to a Tamino Database in the section Servers and Databases.

Browsing through a Database

When you have connected to a database, a node for it is shown in the navigation tree and you can
explore the database contents.

Expand the tree structure by clicking the plus sign in front of an object. When using the keyboard,
select the object and press RIGHT-ARROW. The object types are indicated by different icons. See
Navigation Tree in the section Elements of the Main Application Window.

Select an object to display details about it in the Content pane and in the Properties pane on the
right. SeeContent Pane andProperties Pane in the sectionElements of theMainApplicationWindow.
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Displaying Packs of Instances

In the navigation tree, not all instances are shown at the same time. They are subdivided into
several packs. When further packs are available, down-arrows are shown in the navigation tree.

Click the plus sign next to the down-arrow to display the next pack of instances. When using the
keyboard, select the down-arrow and press ENTER.

Or invoke a context menu for a group of instances. From the context menu, choose, for example,
Last to display the last pack of instances.

Specifying the Instance Fetch Options

The pack size and the maximum number of instances that can be shown in the navigation tree at
the same time depend on the instance fetch options. You can specify different values. See Specifying
the Instance Fetch Options in the section Working with Schemas.

Using Instance Descriptors

By default, the ino:docname or ino:id is shown for each XML instance in the navigation tree. To
make the instances more readily identifiable, you can create instance descriptors.

An instance descriptor defines the attributes of an instance that are to be shown in the navigation
tree (for example, a surname, city and phone number) and the sorting sequence. See Specifying
an Instance Descriptor in the section Working with Schemas.

Filtering Instances

Using a filter, you can reduce the number of instances that are shown in the navigation tree. For
example, you can define a filter that shows only the instances with a specific surname. See Filtering
Instances in the section Working with Instances.
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Adding Instances and Schemas to a Database

Instances and schemas are created outside the Tamino X-Plorer, using external tools (see below).
With the Tamino X-Plorer, you can then add them to a Tamino database. See Defining a Schema
in the section Working with Schemas and Inserting a New Instance in the section Working with In-
stances.

Checking the Open Location

The open location is the folder on your PC in which all schemas and instances that you modify
and save using external tools are temporarily stored.

To check the default open location or to define another open location, invoke the Options dialog
box and go to the File Location page. See the section Setting the Tamino X-Plorer and X-Query
Options.

Modifying a Schema or Instance

Several steps are required when modifying schemas or instances:

1. Invoke the corresponding external tool for the schema or instance directly from the Tamino X-
Plorer (either with a double-click or via a context menu using the Open With command). See
Opening a Schema or Instance in the section General Commands for Managing Different Types of
Objects.

2. Modify the schema or instance with your external tool.

3. Save the modifications to your open location and exit your external tool.

4. Update the schema or instance using the Tamino X-Plorer (i.e. overwrite the existing schema
or instance in the database with the new version that is stored in your open location). See Up-
dating a Schema or Instance in the section General Commands for Managing Different Types of
Objects.
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Searching a Tamino Database

To search a Tamino database, you have to invoke a query window in which you specify and execute
your query. The query results are shown in the query window. Two different types of query can
be performed with the Tamino X-Plorer. See the following sections for further information:

■ Performing X-Queries with the Tamino X-Plorer
■ Using the Tamino XQuery Tool
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IV Using the Tamino X-Plorer

This section explains how to work with the Tamino X-Plorer. The following topics are provided:

■ Starting and Leaving the Tamino X-Plorer
■ Elements of the Main Application Window
■ Servers and Databases
■ Browsing Through a Tamino Database
■ General Commands for Managing Different Types of Objects
■ Working with Schemas
■ Working with Instances
■ Setting the Tamino X-Plorer and X-Query Options
■ Instances in WebDAV Enabled Collection
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4 Starting and Leaving the Tamino X-Plorer

■ Starting the Tamino X-Plorer .............................................................................................................. 22
■ Using Help ..................................................................................................................................... 23
■ Leaving the Tamino X-Plorer .............................................................................................................. 23
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This chapter covers the following topics:

Note: Each Tamino X-Plorer installation uses a single set of properties. Therefore, we do
not recommend using one installation with multiple users (at least not in parallel) because
they will then share (mutually overwrite) these properties.

Starting the Tamino X-Plorer

The Tamino X-Plorer can be invoked from all supported Windows and UNIX platforms.

To start the Tamino X-Plorer on Windows

■ From the Windows Start menu choose Tamino X-Plorer in the Tamino program group.

To start the Tamino X-Plorer on UNIX platforms

■ Start the following script from the command line:

inoxplorer.sh
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Using Help

The complete Tamino X-Plorer documentation is available in HTML format.

The description below applies to both the main application window and the query windows of
the Tamino X-Plorer.

To invoke the overview page for the documentation

■ From the Help menu, choose Contents.

Or:

Press F1.

Or:

Choose the following toolbar button:

To invoke context-sensitive help for a dialog box

■ Choose the Help button in the dialog box.

Or:

Press F1.

Leaving the Tamino X-Plorer

When you leave the Tamino X-Plorer, all open connections to databases are disconnected automat-
ically. Visited databases are remembered.

To leave the Tamino X-Plorer

■ From the File menu, choose Exit.

Or:

From the Control menu, choose Close.

Or:
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Choose the corresponding standard button in the title bar.
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5 Elements of the Main Application Window
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When you start the Tamino X-Plorer, its main application window appears.

The main application window contains several panes: the navigation tree, the Content pane and
the Properties pane. To modify the size of a pane, move the mouse pointer over the border separ-
ating the panes until the pointer changes, showing two arrows pointing in opposite directions.
Then drag the border using the mouse until the panes have the desired size.

For details on keyboard access not mentioned in this documentation, consult the documentation
of the individual operating system or software product.
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The following topics are covered below:

27Tamino X-Plorer

Elements of the Main Application Window



Menu Bar

The following menus are available:

Using the commands in this menu, you can ...Menu

Create a new collection or open, update, delete and save objects. Or exit the Tamino X-Plorer.File

Switch on and off different elements of the main application window or refresh the display.View

Connect/disconnect to/from a database, or remove a database from the tree.Database

Define and undefine a schema, specify an instance descriptor or the instance fetch options.Schema

Insert instances and apply a display filter.Instance

Perform queries, invoke external tools, define additional external tools or define the options.Tools

Invoke the online documentation.Help

For reference information on each menu command, seeMenuCommands in theMain Application
Window.
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Toolbar

You can execute the most important functions using the toolbar.

The following toolbar buttons are available:

Create new collection

Open schema or instance

Update schema or instance

Delete instance or collection

Refresh database, collection, schema or instance

Connect to database

Disconnect from database

Define schema in collection

Undefine schema

Specify instance descriptor

Specify instance fetch options

Insert instance in collection

Filter instances

Invoke Tamino XQuery tool

Invoke X-Query window

Access online documentation

To switch the toolbar display on and off

■ From the View menu, choose Toolbar.

When the toolbar is displayed in the main application window, a check mark is shown next
to this menu command.
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Navigation Tree

The navigation tree on the left side of the main application window shows databases of Tamino
XML Servers to which you have previously connected. When you invoke the Tamino X-Plorer for
the first time, the list is empty. See Connecting to a Tamino Database for further information.

Note: If you have removed all previously connected databases, no database is shown at all.

You can expand or collapse the tree structure by clicking the plus or minus sign in front of an object.
When using the keyboard, select the object and press RIGHT-ARROW or LEFT-ARROW.

When you select an object, details about this object are displayed in the Content pane and in the
Properties pane, but the tree is not expanded.

A database contains collections (the largest units of information within a database). A collection
contains one group of schemas. For each schema containing a doctype, the collection contains one
group of instances of that doctype. The following example shows different doctypes of schemas
and the corresponding groups of instances.
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The object types are indicated by the following icons:

Server

Connected database

Disconnected database

TSD3 or TSD4 collection

TSD2 collection

WebDAV-enabled collection

Group of schemas

TSD3 or TSD4 schema

TSD2 schema

Doctype of XML schema

Doctype of non-XML schema

Group of XML instances

Group of non-XML instances

Group of XML instances without doctype (grouped by root element name)

Group of non-XML instances without doctype (grouped by root element name)

Group of instances with active filter

XML instance

Non-XML instance

XML instance without doctype

Non-XML instance without doctype

For information on TSD4, TSD3 and TSD2, see Collections.

Arrows for browsing the instances may appear in the tree. See Handling Very Large Amounts of
Data.

Note: Problems within the navigation tree may occur if more than one X-Plorer modifies
the same data in the database (for example, X-Plorer 1 scrolls through an instance group
which is modified or deleted by X-Plorer 2).
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Context Menus

Context menus are available for the entries in the navigation tree. For example, the following
context menu is available for a group of instances:

Additionally, two commands (Next and Last) appear when the selected node is expanded so that
instances are shown and not all instances can be shown at the same time. Depending on the pack
of instances that is currently shown (see Handling Very Large Amounts of Data), you can either
display the next or last pack or the previous or first pack.

To invoke a context menu

1 Select the object for which you want to invoke a context menu.

2 Click the right mouse button.

Or:

Press SHIFT+F10.

The context menu appears and you can now choose the required command.
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Content Pane

The Content pane at the top right of the main application window shows the content of the XML
object that is currently selected in the navigation tree.

Non-XML instances in the following formats can also be shown in the Content pane: GIF, JPG,
HTML, SVG and ASCII text.

Restrictions:

■ Objects in the HTML format
Under certain circumstances, the Content pane remains empty in HTML view (for example,
HTML pages based on frames or documents that contain external references such as images).

■ Right-to-left orientation
Documents with right-to-left orientation or mixed orientation may not be displayed in the correct
sequence.

■ SVG Includes
In case an SVG document internally refers to another content, which is not accessible in URL
form. Displaying such a document would not be possible for the SVG view.

■ SVG DTD Reference
Should an SVG document refer to a DTD or include entity declarations, such a document cannot
be added to Tamino as an XML object (as Tamino does not support DTDs). However, it is possible
to add this document as a non-XML document.

■ SVG External Links and References
If an SVG document (that has been added to Tamino as a non-XML object) has DTD or link
references to an external URL, and this URL is not accessible or is beyond proxy, the SVG content
is rendered under default environment settings. However, this may cause the SVG not to be
rendered at all, or to be rendered with an incorrect dimension (size).

Help:

■ SVG Context Help
Right-clicking on the SVG Image view opens a context help that can be referred to while working
with the content.

When information cannot be displayed in the Content pane or when no information is available,
a hint is provided. For example, for a group of instances, no content information is available. In
this case, the Content pane informs you to check the Properties pane.

Depending on the type of object, one or more views are available. When different views are
available, they can be activated using the following buttons in the top right corner of the Content
pane:
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DescriptionKeyboardButton

Tree view for XML objects. Not available for non-XML instances. Whether lines are
wrapped in tree view depends on the corresponding setting in the Options dialog
box. See Setting the Tamino X-Plorer and X-Query Options for further information.

CTRL+SHIFT+T

Plain view providing the XML code of an XML object. Or plain view providing the
HTML code of an HTML document

CTRL+SHIFT+P

Browser-like view for HTML documents with the restrictions described above.CTRL+SHIFT+H

Image view for non-XML objects (for example, GIF).CTRL+SHIFT+I

Hexadecimal view for non-XML objects of media type "text/plain".CTRL+SHIFT+X

SVG image view for Scalable Vector GraphicsCTRL+SHIFT+S
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The following example shows the tree view for an XML instance:

The following example shows the plain view for the same instance:

See Instances for further information.

To switch the Content pane display on and off

■ From the View menu, choose Content.

When the Content pane is displayed in the main application window, a check mark is shown
next to this menu command.

35Tamino X-Plorer

Elements of the Main Application Window



Properties Pane

The Properties pane at the bottom right of the main application window shows properties
(metadata) for the object that is currently selected in the navigation tree. There are two types of
information:

■ Schemas, Doctypes and Instance Nodes
For a schema, the schema type (for example, TSD4) and the media type (for example, text/xml)
are shown.

For a doctype, the doctype name is shown and whether this is a non-XML doctype or not.

For an instance (XML or non-XML), date and time of the last modification are shown as well as
the media type (for example, text/xml or image/gif).

■ Other Nodes
Other nodes are the nodes for servers, databases, collections, groups of schemas and groups of
instances. The information shown in the Properties pane depends on the type of node which is
currently selected in the navigation tree. It may include the names of the doctype, schema, col-
lection, database and server (URL and version). It may also include the state of the database
(connected or not), the type of collection (user collection or system collection) and whether the
collection is WebDAV-enabled. For a group of schemas, the schema version (for example, TSD4)
is shown. For a group of instances, information about the instance descriptor (if defined) and
the instance fetch options is shown.

Depending on the type of object, one or more views are available. When different views are
available, they can be activated using the following buttons in the top right corner of the Properties
pane:

DescriptionKeyboardButton

Tree view. Whether lines are wrapped in tree view depends on the corresponding
setting in the Options dialog box. See Setting the Tamino X-Plorer and X-Query
Options for further information.

CTRL+SHIFT+T

Plain view providing the properties of a schema, doctype or instance node as
name/value pairs in a table. Not available for other nodes.

CTRL+SHIFT+P

The following example shows the properties for an XML instance in tree view:
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The following example shows the plain view for the same instance:

To switch the Properties pane display on and off

■ From the View menu, choose Properties.

When the Properties pane is displayed in the main application window, a check mark is
shown next to this menu command.

Dialog Boxes

Most Tamino X-Plorer dialog boxes can be resized. This is indicated by the following symbol in
the lower right corner of a dialog box:

Resizing a dialog box is helpful if a string is so long that it is not fully shown.

Keyboard users should additionally note the use of the following keys:

FunctionKey

Activate the default button.ENTER

Cancel the current operation and close the dialog box.ESCAPE

Navigating in the Tamino X-Plorer

You can navigate in the Tamino X-Plorer using the standard mouse and/or keyboard techniques
for navigating through the menus and selecting items.

Keyboard users should additionally note the use of the following keys:
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FunctionKey

Activate the selected input field for editing (edit mode).F2

Open and close a drop-down list box in a dialog box.
To open and close a drop-down list box in a table, invoke edit mode (F2) first.

ALT+DOWN-ARROW and
ALT+UP-ARROW

Select the next control, or select the next item in a table.TAB

If a control uses TAB for its own purposes (for example, a table), you have to
use CTRL+TAB to leave the context of current control.

CTRL+TAB
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You can connect to several servers and Tamino databases at the same time.

This chapter provides the following information:

Connecting to a Tamino Database

You can connect to any Tamino database which has been previously activated using the Tamino
Manager.

The navigation tree shows all servers and databases to which you have previously connected. The
icon next to the database name indicates one of the following states:

A connection to the database has not yet been established.

A connection to the database has already been established.

To connect to a Tamino database

1 From the Database menu, choose Connect.

Or:

Choose the following toolbar button:

The Connect dialog box appears.

If this is the first time you are connecting to a server, the drop-down list boxes are empty and
you have to type in the required information. The next time you access this dialog box, this
information is available and can be selected from the drop-down list boxes.

Note: All information entered in the Connect dialog box is reflected in the navigation
tree. If you accidentally mistyped, for example, the name of a database and thus tried
to connect to a non-existing database, you should remove this entry from the tree. See
Removing a Server or Database from the Navigation Tree.
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Tip: The Connect dialog box appears automatically when you try to expand the node
for a database which has not yet been connected.

2 Enter the path to the required server in the following format:

http://host/tamino

where host is the name of the computer on which the Tamino Server resides. You can specify
"localhost" for your local computer, or a path such as "yourpc.ourcompany.com" for a remote
computer.

Or:

Select the required server from the corresponding drop-down list box.

3 Enter the name of the database to which you want to connect.

Or:

Select the required database from the corresponding drop-down list box.

Or:

Choose the Select button to display all databases on the specified server in an additional
dialog box. You can then choose the desired database. This feature works only with databases
that have been created starting with version 4.2.1. In all other cases, a message appears saying
that a list of databases is not available.

4 Choose the Connect button.

When a password is required for the database, a login dialog box appears.

5 Specify the user ID and password with which you are defined to Tamino security and/or the
authentication file of your web server (if authentication is active), and then choose the Login
button.

If you have to specify a domain name with your user ID, specify it in the following way:

domain-name/user-ID
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If the authentication of your web server is not active (which is the default setting) and you
have no explicit user ID/password entry in the Tamino security file, you can enter any com-
bination here. You are then assigned default access rights in Tamino.

The last user ID you entered in this text box is automatically remembered.
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Checking the Database Version

When you select a Tamino database in the navigation tree, the Properties pane shows the current
Tamino version. For example:

Disconnecting from a Database

When you disconnect from a database, an expanded node is collapsed and the icon in front of the
database name indicates that this database is not connected.

Note: When you leave the Tamino X-Plorer, all open connections to databases are discon-
nected automatically.

To disconnect from a database

1 In the navigation tree, select the database to be disconnected.

2 From the Database menu, choose Disconnect.

Or:

Choose the following toolbar button:
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Removing a Server or Database from the Navigation Tree

All servers and databases that you have previously accessed are automatically remembered. They
are shown in the navigation tree each time you start the Tamino X-Plorer. When you do not need
access to a specific server or database any longer, you can remove its entry from the tree.

Removed servers and databases are no longer available from the drop-down list boxes of the
Connect dialog box.

To remove a server or database from the navigation tree

1 In the navigation tree, select the server or database to be removed.

2 From the Database menu, choose Remove from Tree.

A dialog box appears asking whether you really want to remove the selected object.

3 To remove the object, choose the Yes button.
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This chapter provides general information on handling the objects in the navigation tree:

For detailed information, see Working with Schemas and Working with Instances.
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Collections

A collection is the largest unit of information within a database.

When you select a collection in the navigation tree, the Properties pane shows information about
this collection. For example:

A collection may be defined as required, optional or prohibited (schemaUsage property). See also
Creating a New Collection.

Whether system collections are shown in the navigation tree depends on the corresponding setting
in the Options dialog box. See Setting the Tamino X-Plorer and X-Query Options for further in-
formation.

Different types of collection are available:

■ WebDAV-enabled Collections
■ The Collection ino:etc

One collection may contain only schemas of a specific version: either XSD, TSD, TSD2 or TSD3.

49Tamino X-Plorer

Browsing Through a Tamino Database



WebDAV-enabled Collections

In the navigation tree, WebDAV-enabled collections are indicated by the following icon:

You can view the contents of a WebDAV-enabled collection. The WebDAV path for an instance
is shown in the Properties pane. This path is not always identical to the path in the navigation
tree.

You can specify that the WebDAV names of the instances are shown in the navigation tree. See
Specifying an Instance Descriptor for further information.
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The Collection ino:etc

The collection ino:etc is always shown in the navigation tree. It is not affected by theHide system
collections setting in the Options dialog box (see Setting the Tamino X-Plorer and X-Query Op-
tions).

Instances for which a doctype has not been defined in Tamino can be stored in the collection
ino:etc or in any other collection for which schema usage is optional or prohibited.

XML instances are grouped according to their root element. When a new XML instance without
a doctype is inserted in the database, one of the following occurs (this applies also for collections
for which schema usage is optional or prohibited):

■ If a group with the same name as the root element does not yet exist, the group is created and
the instance is shown in this group.

■ If a group with the same name as the root element has already been created, the instance is
shown in this group.

Non-XML instances without a doctype do not have a root element. They are always inserted in
the group ino:nonXML which is part of ino:etc.

See Inserting a New Instance for further information.
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Schemas and Doctypes

All schemas of a collection are available in a group of schemas. In the navigation tree, groups of
schemas are indicated by the following icon:

When you select a group of schemas in the navigation tree, theProperties pane shows information
about this group. For example:

Schemas

A schema specifies rules for how XML document elements, attributes, and other data are defined
and logically related in an XML-compliant document.

When you select a schema in the navigation tree, the Content pane shows the XML code for the
entire schema. The Properties pane shows the schema type (for example, TSD4) and the media
type (for example, text/xml).
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Doctypes

A doctype describes a particular type of object. Tamino can store instances of doctypes and can
retrieve information from them. The icon in the navigation tree indicates whether a doctype applies
to an XML schema ( ) or to a non-XML schema ( ).

A TSD4 schema can have more than one doctype. TSD4 schemas may also be sub-schemas without
a doctype; these sub-schemas can be imported into other schemas.

When you select the doctype for a schema in the navigation tree, only the XML code for the doctype
is shown in the Content pane. In the case of a non-XML schema, only information such as the
following is shown:

<?xml version="1.0" encoding="UTF-8"?>
<tsd:nonXML name="jpg-file"/>
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Instances

For each doctype of a schema, the corresponding instances stored in Tamino are shown. In the
navigation tree, the instances are shown in different groups of instances where each group has
the same name as the corresponding doctype. The icon in the navigation tree indicates whether
the group contains XML instances ( ) or non-XML instances ( ).

Selecting such a group displays the properties of the selection in the Properties pane. This can
basically be used to determine the selection's meta properties like root-element name, fetch option,
etc. However, it is also possible to see the total number of records available under this group in
the recordCount property.

Note: Similar icons are shown for groups of instances without doctype and for groups of
instances with an active filter.

The following defaults apply for the different types of instances:

■ XML Instances
The ino:id is shown in the navigation tree.

Caution: The ino:id may change when the Tamino Data Loader is used to unload and
load data.
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■ Non-XML Instances
The ino:docname is shown in the navigation tree (for example, "myimage.jpg").

■ Instances in a WebDAV-enabled Collection
The WebDAV name is shown in the navigation tree. See also WebDAV-enabled Collections.

To make the instances more readily identifiable, you can create instance descriptors for all XML
instances of a specific doctype. An instance descriptor defines the attributes of an instance that
are to be shown in the navigation tree (for example, the e-mail address of a user) and the sorting
sequence. See Specifying an Instance Descriptor for detailed information.

When an instance does not have an ino:id or ino:docname and when an instance descriptor has
not been defined, a number preceded by a hash (#) character is shown in the navigation tree. This
number indicates the current position of this instance within the group of instances.
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When you select a group of instances in the navigation tree, the Properties pane shows information
about this group, including the current instance descriptor, filter (if defined) and instance fetch
options.
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XML Instances

In the navigation tree, XML instances are indicated by the following icon:

Note: A similar icon ( ) is shown for XML instances without doctype.

When you select an XML instance in the navigation tree, the Content pane shows the contents of
this instance.

The Properties pane shows the date and time of the last modification and the media type (for ex-
ample, text/xml).

Note: If XML instances with a mapping to externally stored data do not provide an ino:id,
the Tamino X-Plorer does not display these documents in the navigation tree. Hint: Use the
XQuery tool to query and view these documents.
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Non-XML Instances

In the navigation tree, non-XML instances are indicated by the following icon:

Note: A similar icon ( ) is shown for non-XML instances without doctype.

When you select, for example, a non-XML instance in the JPG format, the Content pane shows an
image.

The Properties pane shows the date and time of the last modification and the media type (for ex-
ample, image/gif).

For a list of all non-XML formats that can be displayed with the Tamino X-Plorer, see the description
of the main application window's Content pane.
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Handling Very Large Amounts of Data

In the navigation tree, not all data is shown at the same time. The instances are subdivided into
several packs.

The following symbols can be shown within a group of instances:

Click the plus sign next to this symbol to fetch and display the next pack. When using the keyboard,
select this symbol and press ENTER.

Click the plus sign next to this symbol to fetch and display the previous pack. When using the keyboard,
select this symbol and press ENTER.

A symbol is not shown when the number of available instances is smaller than the defined pack,
or when the beginning or end of the instance list has been reached.

The instance fetch options limit the number of instances that can be shown in the navigation tree
at the same time. See Specifying the Instance Fetch Options for detailed information.

Memory Settings for the Java Virtual Machine (VM)

For normal use, the following tested and optimized default settings for the JAVA_PARAMS are
sufficient:

-Xms64m (lower limit: 64 MB)
-Xmx256m (upper limit: 256 MB)

If the VM runs out of memory, you have to increase these settings in the file inoxplorer.cmd (for
Windows) or inoxplorer.sh (for UNIX).

Depending on the tasks, memory usage of the Tamino X-Plorer may be high, in particular when
using fetch options with a large number of documents to be retrieved and/or kept, or when access-
ing/using several different databases and collections in parallel. See Database Cursoring below for
further information.

Database Cursoring

In general, the Tamino X-Plorer retrieves its data (especially the instances in the navigation tree)
using database cursoring. The data belonging to a retrieved cursor is displayed pack by pack
(using the navigation controls as described above) to fill the navigation tree with this data. Under
certain circumstances, these cursors need to be retrieved again. This leads to a refresh of the dis-
played data in the navigation tree, possibly showing different data afterwards.
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In the navigation tree, new cursors will be retrieved when:

■ using the refresh function,
■ adding/changing the instance descriptor,
■ adding/changing the filter expression,
■ changing the fetch options for instances.

In a query window, new cursors will be retrieved when changing the fetch options for X-Query
results or XQuery results.

For optimum usage, performance and response time, it is recommended that you use the pack
sizes indicated in the tables below.

■ Navigation tree in the main application window (instance fetch options):

Recommended MaximumDefault

5005Number of instances per pack

200015Maximum number of kept instances

■ Query window (result fetch options for X-Query and XQuery):

Recommended MaximumDefault

Depends on the size of the documents to be retrieved. This
number should be a good deal smaller than the recommended
maximum for the navigation tree (see above).

5Number of instances per pack

5Maximum number of kept instances

Generally spoken, the larger the pack size, the longer the response time and the bigger the memory
usage. For large packs, or if you encounter high response times and big memory usage, consider
smaller pack sizes or use the filter functionality to reduce the amount of data to be retrieved or
displayed.

If the pack sizes are too large, runtime exceptions may occur (normally OutOfMemory exceptions).

Tamino X-Plorer60

Browsing Through a Tamino Database



Refreshing the Display

You can refresh the visual representation of databases, collections, schemas and instances in the
navigation tree. This is useful, for example, when a schema has been renamed or when instances
have been created or deleted by other users.

For a schema, the name is refreshed. For an instance, the current representation according to the
specified instance descriptor is refreshed.

Caution: Refreshing a database can be time-consuming.

To refresh the display

1 In the navigation tree, select the desired object.

2 From the View menu, choose Refresh.

Or:

Press F5.

Or:

Choose the following toolbar button:
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The File menu contains general commands for managing different object types. These commands
are described in this chapter.

See Working with Schemas and Working with Instances for further information.
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Creating a New Collection

We can add new collections to a database. A collection may contain groups of schemas and in-
stances.

To create a new collection

1 In the navigation tree, select the database to which we want to add the collection.

2 From the File menu, choose New Collection.

Or:

Choose the following toolbar button:

Or:

Open the context menu and choose New Collection.

The Create New Collection dialog box appears.

If the tab Schema Usage is not selected, select it now before proceeding.

3 Specify a name for the new collection.

The name must comply with the Tamino naming conventions (e.g. blanks are not allowed in
a name).
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4 Specify one of the following option buttons:

Required
Default. Schema usage is required. Instances can only be stored in this collection when a
schema has been defined.

Note: Collections which have been created with an older version of Tamino are
automatically defined as required.

Prohibited
Schema usage is prohibited. A schema is not required for storing instances.

Optional
Schema usage is optional. A schema can be defined, but this is not required. Instances can
also be stored when a schema has not been defined (for example, ino:etc is a collection
for which schema usage is optional).

5 Select the Namespaces tab.

Set the custom namespaces, if required. Note that the tsd namespace definition is predefined
and you cannot delete it.

1. To add a namespace, choose the Add button.

2. To remove a namespace, choose the Delete button.

6 If we choose the Miscellaneous tab, the following options are displayed:

■ If we want auto version control to be enabled, check the Supports auto version control
field.

■ We can also specify the end-of-line handling character:

1. Preserve
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2. Transform

7 Choose the Create button.

The collection is now created and is visible in the navigation pane.
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Modifying Properties of an Existing Collection

It is possible to modify the properties of an existing collection.

To modify the properties of an existing collection

1 Select a collection in the navigation tree and open the context menu. From the context menu,
choose Modify Collection Properties. This opens a dialog in which you can specify the col-
lection's properties.

2 Choose the Schema Usage tab and specify one of the following option buttons:

DescriptionOption

Instances can only be stored in this collection if a schema has been definedRequired

Schema usage is optional. A schema can be defined, but this is not required. Instances can
also be stored if a schema has not been defined (for example, ino:etc is a collection for
which schema usage is optional) .

Optional

Schema usage is prohibited. A schema is not required for storing instances.

Note: The following schema usage modifications are permitted for a collection: Required
- Optional and Prohibited - Optional

Prohibited

3 Choose the Namespaces tab and modify the custom namespaces, if required. Note that the
tsd namespace definition is displayed by default and that it is not possible to delete it.

To add a namespace, choose the Add button ( ).

To remove a namespace, choose the Delete button ( ).

4 Choose the Miscellaneous tab.

If we want to modify the auto version control property of the collection, choose the Supports
auto version control check box.

The End of line handling parameter can have one of the following values:

■ Preserve (default)
■ Transform

If you select the value "Transform" for the End of line handling parameter, the Tamino X-
Plorer adds this value to the corresponding instance in ino:collection/tsd:collection:
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<tsd:collection
ino:docname="PretestTelefon01"
name="PretestTelefon01"
xmlns:tsd="http://namespaces.softwareag.com/tamino/TaminoSchemaDefinition">

<tsd:property name="end-of-line-handling" value="transform" />
</tsd:collection>

5 Choose the Modify button to store the modified the collection properties.
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Opening a Schema or Instance

Using external tools, schemas and instances can be opened directly from the Tamino X-Plorer. We
can then view or modify the schema or instance using the features of that external tool. The external
tools have to be defined in the Customize dialog box. See Customizing the Tools for further in-
formation.

When we double-click a schema or instance in the navigation tree, it is opened using the default
tool that has been defined in the Customize dialog box. This corresponds to selecting the object
and choosing Open from the File menu.

Each external tool that has not been defined as the default tool for a specific type of object is
available for selection using theOpenWith command from a context menu. We can thus use more
than one tool for opening the same type of object (for example, two different schema editors where
one of them has been defined as the default tool).

Each time a schema or instance is opened with an external tool, a file is written to the open location
which has been defined in the Options dialog box. The file name is derived from the current in-
stance descriptor. For example, when the name "Atkins" is shown for an instance in the navigation
tree, the resulting file name is "Atkins.xml". When more than one item has been defined for the
instance descriptor, all items are used in the file name (for example, "Fred, Bloggs.xml").

To open a schema or instance using the default tool

1 In the navigation tree, select the schema or instance to be opened.

2 From the File menu, choose Open.

Or:

Press CTRL+O.

Or:

Choose the following toolbar button:

Or:

Double-click the schema or instance.

The schema or instance is opened using the external tool that has been defined as the default
tool.
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To open a schema or instance using another defined external tool (not the default tool)

1 In the navigation tree, select the schema or instance to be opened.

2 Invoke the context menu and choose Open With > your external tool.

The schema or instance is opened using the chosen external tool.

Note: When the OpenWith command is not available, an alternative tool has not been
defined for the selected type of object.

Updating a Schema or Instance

When we modify a schema or instance using an external tool, our modifications are not automat-
ically stored in the database. To do so, we have to update the schema or instance.

We can update an existing schema or instance from a file in your file system (from the open location
which has been defined in theOptions dialog box), or by coping a schema from another database.

The update procedure checks whether the existing schema or instance will not only remain well-
formed but also whether it is still a valid XML document (i.e. whether it matches the schema). If
the modifications result in an invalid document, the existing schema or instance is not updated.

Note: When we update an XML instance, the attribute ino:id is no longer accepted by the
parser. It is recommended that we delete the attribute ino:id in the instance text.

To update a schema

1 In the navigation tree, select the schema to be updated.

2 From the File menu, choose Update.

Or:

Choose the following toolbar button:

The Update Schema dialog box appears.

3 Select one of the following pages:
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■ From File
This page is used to specify the name of a file containing a schema.

Either specify the path and file name in the text box or choose the Select button to select
the file from a dialog box.

■ From Database
This page is used to copy an existing schema from another database.

When we have previously connected to a server and database, we can select their names
from the corresponding drop-down list boxes. If we want to connect to a new server and
database, enter the required names in the drop-down list boxes.

When the specified database is currently not connected, a dialog box appears asking
whether we want to connect. Choose the Yes button to invoke the Connect dialog box. See
Connecting to a Tamino Database.

When a database has been specified and is connected, the names of all of its collections are
available in the Collection drop-down list box. Select the collection containing the desired
schema.

When a collection has been selected, the names of all of its schemas are available in the
Schema drop-down list box. Select the schema to be copied.

4 Choose the Update button.

The existing schema is now replaced with the schema that we have just specified.

Caution: Do not specify information on different pages. When we choose the Update
button, only the information on the currently shown page is used.
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To update an instance

1 In the navigation tree, select the instance to be updated.

2 From the File menu, choose Update.

Or:

Choose the following toolbar button:

The Update Instance dialog box appears. The title bar shows the doctype and the name of
the selected instance as displayed in the navigation tree.

This dialog box is used to specify the name of a file containing an instance.

3 Either specify the path and the file name in the text box or choose the Select button to select
the file from a dialog box.

4 Choose the Update button.

The existing instance is now replaced with the instance that we have just specified.
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Deleting a Collection or Instance

You can delete a collection or instance permanently from the database.

Caution: When you delete a collection, all instances of all doctypes in this collection will
also be deleted.

Note: If you want to undefine a schema or delete a collection, you need exclusive access to
the collection. Otherwise, these commands result in an error. The error message indicates
that the documents could not be locked. No user is allowed to access this collection while
an "undefine schema" or "delete collection" is about to be executed. This error will also occur
if you are the user who is accessing a group of instances of that collection, for example, in
an XQuery result. If this error occurs, the problem will persist until the database is discon-
nected and connected once again. Workaround: Disconnect the database, connect it once
again and then execute the command without previously accessing instances of this collec-
tion.

To delete a collection or instance

1 In the navigation tree, select the collection or instance to be deleted.

2 From the File menu, choose Delete.

Or:

Choose from the toolbar.

Or:

From the context menu of the collection or instance, choose Delete.

You are now asked whether you really want to delete the collection or instance.

3 Choose the Yes button to confirm the deletion.

Saving a Schema or Instance in Your File System

You can save a schema or instance that is stored in a database in your local file system.

A schema is saved with the extension "tsd". An XML instance is saved with the extension "xml".
A non-XML instance is saved with its original file name and extension.
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To save a schema or instance in your file system

1 In the navigation tree, select the schema or instance to be saved.

2 From the File menu, choose Save As.

The Save As dialog box appears.

3 Specify a file name and select the path in which you want to save the file.

4 Choose the Save button.
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This chapter covers the following topics:

SeeGeneral Commands forManaging Different Types of Objects for information on how to open,
update and save schemas.
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Defining a Schema

A schema is created outside the Tamino X-Plorer, using an external tool such as the Tamino Schema
Editor. After a schema has been created, you can use the file containing the schema to define the
schema in the Tamino database. You can also define a schema by copying an existing schema from
another database.

A schema is always defined in the collection that is currently selected.

For non-XML objects, you only need to define a simple doctype in a schema. For example:

<?xml version="1.0" encoding="UTF-8"?>
<tsd:nonXML name="gif-file"/>

To define a schema

1 In the navigation tree, select the collection that is to contain the schema.

2 From the Schema menu, choose Define Schema.

Or:

Choose the following toolbar button:

Or:

From the context menu, select Define Schema.

The Define Schema dialog box appears.

Using the different pages, you can define a schema in one of the following ways:

■ define a schema from a file
■ define a schema from a database

3 Select the desired page and specify all required information as described below under the
corresponding heading.

4 Choose the Define button.

Caution: Do not specify information on different pages. When you choose theDefine button,
only the information on the currently shown page is used.
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Define a Schema from a File

This page is used to specify the name of a file containing a schema.

Either specify the path and file name in the text box or choose the Select button to select the file
from a dialog box.

Defining a Schema from a Database

This page is used to copy an existing schema from another database.

When you have previously connected to a server and database, you can select their names from
the corresponding drop-down list boxes. If you want to connect to another server and database,
enter the required names in the drop-down list boxes.

When the specified database is currently not connected, a dialog box appears asking whether you
want to connect. Choose the Yes button to invoke the Connect dialog box. See Connecting to a
Tamino Database.

When a database has been specified and is connected, the names of all of its collections are available
in the Collection drop-down list box. Select the collection containing the desired schema.

When a collection has been selected, the names of all of its schemas are available in the Schema
drop-down list box. Select the schema to be copied.
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Undefining a Schema

When you undefine a schema, it is deleted permanently from a collection in the database.

Caution: All instances of all doctypes belonging to this schema will also be deleted.

Note: If you want to undefine a schema or delete a collection, you need exclusive access to
the collection. Otherwise, these commands result in an error. The error message indicates
that the documents could not be locked. No user is allowed to access this collection while
an "undefine schema" or "delete collection" is about to be executed. This error will also occur
if you are the user who is accessing a group of instances of that collection, for example, in
an XQuery result. If this error occurs, the problem will persist until the database is discon-
nected and connected once again. Workaround: Disconnect the database, connect it once
again and then execute the command without previously accessing instances of this collec-
tion.

To undefine a schema

1 In the navigation tree, select the schema you want to undefine.

2 From the Schema menu, choose Undefine.

Or:

Choose the following toolbar button:

Specifying an Instance Descriptor

An instance descriptor can be defined for each doctype which defines XML instances. It defines
the information, including the sorting sequence, that is to be shown for the corresponding instances
in the navigation tree. This information may be, for example, a surname, city and phone number.

An instance descriptor consists of one or more items. Each item is an X-Query expression. See X-
QueryUser Guide andX-Query Reference Guide in the Tamino XML Server documentation for detailed
information on X-Query expressions.

For non-XML instances only the ino:docname is shown in the navigation tree. If the ino:docname
is not defined, the ino:id is shown instead.

Note: The instance descriptor applies to both the main application window and the X-Query
windows (it does not apply to the XQuery tool). The sorting sequence, however, is only
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applied in the main application window. In an X-Query window, you can specify your own
sorting sequence in the query expression (for example, with the sortby clause).

Example

The following instance descriptor has been defined:

/patient/name/firstname
/patient/name/surname
/patient/therapy/medication/type/@brand

This displays the following instances in the navigation tree:

First name and surname have been found for both instances.

A medication was only found for one instance containing the following information:

<therapy>
<medication>

<type brand="Gallopamil" form="tablet">Beta-blocker</type>
<dosage>Twice daily</dosage>

</medication>
</therapy>

When an instance does not contain a value for an item defined in the instance descriptor,
"<not_defined>" is shown in the navigation tree. In the above example, "<not_defined>" is shown
because an "other" therapy has been used instead of a "medication" therapy:

<therapy>
<other>

<description>Decompression chamber</description>
<amount>18 hrs</amount>

</other>
</therapy>

To specify an instance descriptor

1 In the navigation tree, select the desired doctype.

2 From the Schema menu, choose Instance Descriptor.

Or:
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Choose the following toolbar button:

Or:

Choose Instance Descriptor from the context menu of the instance group.

The Specify Instance Descriptor dialog box appears, which includes the following panel:

When you are modifying an existing instance descriptor, the dialog box shows the X-Query
expressions that are currently defined. The sequence of the X-Query expressions determines
the sequence in which the information for an instance is shown.

3 Edit the existing X-Query expressions or use the following buttons:

Add a new item. You can then specify an X-Query expression (case-sensitive) in a new line.

Delete the selected X-Query expression.

Move the selected X-Query expression up one position.

Move the selected X-Query expression down one position.

4 Optionally: select a cell in the Sort column and from the resulting drop-down list box, choose
either ascending ( ) or descending ( ) sorting sequence for the corresponding item.

5 Choose the OK button to save the instance descriptor.
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Specifying the Instance Fetch Options

The instance fetch options limit the number of instances that can be shown in a specific group of
instances at the same time. They are always defined for a doctype.

When you expand the node for a group of instances in the navigation tree, the first pack of instances
in this group is shown. You can define the number of instances that are to be fetched with each
pack.

Each pack that you fetch (see Handling Very Large Amounts of Data) remains visible in the nav-
igation tree until the maximum number of kept instances is reached. You can also define this
number.

Example: when the number of instances per pack is 50 and the maximum number of kept instances
is 4000, you can fetch 80 packs where each pack has 50 instances. All of these instances will be
shown in the navigation tree. However, when you fetch the 81st pack, the first pack is removed
from the tree to make room for the new pack.

The default values are defined in the Options dialog box. See Setting the Tamino X-Plorer and
X-Query Options for further information.

To specify the instance fetch options

1 In the navigation tree, select the group of instances for the desired doctype.

2 From the Schema menu, choose Instance Fetch Options.

Or:

Choose the following toolbar button:

Or:

In the context menu of the doctype, choose Instance Fetch Options.

The Specify Instance Fetch Options dialog box appears showing the values for the currently
defined fetch options.
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3 Specify the following information:

Number of instances per pack
The number of instances that are to be fetched with each pack.

Maximum number of kept instances
The maximum number of instances that can be shown in a group of instances at the same
time.

4 Optionally: if you want to reset the values that are currently defined in this dialog box to the
default values, choose the Reset to Default button.

5 Choose the OK button to save the new instance fetch options.
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This chapter covers the following topics:

SeeGeneral Commands forManaging Different Types of Objects for information on how to open,
update, delete and save instances.

See also: Specifying an Instance Descriptor and Specifying the Instance Fetch Options.
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Inserting a New Instance

An instance is created outside the Tamino X-Plorer, using an external tool. After the instance has
been created, you can use the Tamino X-Plorer to insert it in the database.

When you insert an instance, you specify the name of the file which contains the instance.

You can insert XML instances and non-XML instances in a collection.

You can also insert instances for which a doctype has not been defined. You insert these instances
in collections for which schema usage is optional (like ino:etc) or prohibited.

Note: Instances containing the attribute ino:id are no longer accepted by the parser. It is
recommended that you delete the attribute ino:id in these instances.

To insert a new instance

1 In the navigation tree, select the collection or group of instances that is to contain the instance.

Notes:

1. If a group with the same name as the root element of the instance does not yet exist, a new
group of instances is created and the instance is inserted in this new group.

2. If you want to insert an instance for which a doctype has not been defined, you must select
a collection for which schema usage is optional or prohibited.

2 From the Instance menu, choose Insert Instance.

Or:

Choose the following toolbar button:

Or:

Open the context menu on the collection or instance group and choose Insert Instance.

The following dialog box is displayed if a collection is selected while invoking the Insert In-
stance dialog box:
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Instances can be inserted from XML as well as non-XML files, using the tabs in the Insert In-
stance dialog box. Depending on the type that you have selected (XML or non-XML), the
following tabs are activated:

■ from an XML file
■ from a non-XML file

3 Select the desired tab, when the Insert Instances dialog box is invoked from the collection
level, and specify all required information as described below under the corresponding
heading.

4 Choose the Insert button.

Caution: Do not specify information on different pages. When you choose the Insert button,
only the information on the currently shown page is used.
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From XML File

This dialog box is used to insert an instance from an XML file.

To insert an instance from an XML file

1 Choose the Add New button ( ) to select the file from a Select File dialog box.

2 Select the source file, or use CTRL or SHIFT to select multiple files.

3 Choose the Select File button to add your selection to the Insert Instance dialog box.

4 You can modify the file name in the Document Name field.

5 Choose the Insert button to insert the instance(s) into the database.
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From Non-XML File

This dialog box is used to insert a non-XML instance, for example, an image file.

To insert an instance from a non-XML file

1 Choose the Add New button ( ) to select the file from a Select File dialog box.

2 Select the source file, or use CTRL or SHIFT to select multiple files.

3 Choose the Select File button to add your selection to the Insert Instance dialog box.

4 You can modify the Document Name and or the Media Type of the document to be inserted.

5 Choose the Insert button to insert the instance(s) into the database.

Note: The Delete button ( ) can be used to remove an already selected document from the
list of documents to be inserted.

Non-XML Doctype
Enter a non-XML doctype that is available in the selected collection. Or select the non-XML
doctype from the drop-down list box. The drop-down list box provides for selection all non-
XML doctypes in the selected collection.

If you want to insert a non-XML instance without a doctype in a collection for which schema
usage is optional (like ino:etc) or prohibited, you have to select the doctype ino:nonXML.

File
Enter the path to the non-XML object or choose the Select button to select the file from a dialog
box.
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Media Type
If you intend to change the media type, refer to Media Types for Non-XML Instances.

The following information applies when the media type "text" has been used (for example,
"text/plain" or "text/html"). Behind the media type - separated by a semicolon - specify the
character set that has been used when the non-XML object has been created. For example, if
you want to insert an instance containing Japanese text which has been created using the media
type "text/plain" and the character set Shift-JIS, theMedia Typefield must contain the following:

text/plain; charset=Shift-JIS

Cutting, Copying and Pasting of Instances

It is possible to cut, copy and paste instances within the X-Plorer for easier handling of instances.

To cut, copy and paste instances

1 Select the instance in the navigation pane.

2 From the context menu, choose Cut to remove or Copy to copy the selected instance.

3 Right-click on the target collection to paste the cut or copied instance.

You can insert instances from the file system into a collection, using X-Plorer's system clipboard
integration features:

■ Select and copy files from your file system.
■ In the X-Plorer window, right-click on the target collection, then choose Paste to find the selected

files to be inserted as instances. You are prompted for a confirmation if the file to be inserted is
a non-XML file.

It is also possible to paste the content of an XML instance from the X-Plorer to an external editor
using the Copy functionality of the X-Plorer and the Paste functionality of an external editor. The
instance can be edited in the external editor and pasted back into the X-Plorer as a new instance.

You can also copy the content of an XML file from an external editor and use the Paste functionality
of the X-Plorer to insert the copied content into a collection as an instance.
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Editing Instances

You can edit text documents (XML and non-XML documents) in the plain text view.

To edit a text document

1 Choose the instance in the navigation view. The contents are then displayed in the Content
pane.

2 If the plain text view is not already active in the Content pane, change to the plain text view.

3 Edit the text as required.

4 Save your changes by using one of the following methods:

In the navigation pane, choose another object. You will be prompted if you want to save the
current changes.

Or:

Choose File > Save from the main menu.

Or:

Press CTRL+S.

Renaming of Instances

You can add the ino:docname attribute to an instance. You can also modify or remove the
ino:docname attribute of an instance that has it already defined.

To rename an instance

1 Select the instance that you want to rename in the navigation pane.

Or:

Choose Rename from the context menu of the instance to be renamed.

The following dialog box is displayed, if the instance does not have an already defined
ino:docname:
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If the instance has an ino:docname, the rename functionality provides an additional feature
as shown in the following dialog box:

2 Enter the new name and choose the Rename button to rename the instance.

Or:

Select the Remove ino:docname button to remove the ino:docname attribute of the instance.

Deleting Multiple Instances

You can delete multiple instances in the X-Plorer. To do so, select the instances, while holding
down the CTRL key. Delete the instances with the Delete icon ( ), available from the toolbar.
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Filtering Instances

Using a filter, you can reduce the number of instances that are shown in the navigation tree of the
application window.

For example, you can define a filter which only shows the instances starting with a specific surname.
When "name/surname between 'B', 'C'" has been defined as the filter, only surnames beginning
with the letter B are shown.

The filter is an XQuery expression. SeeXQueryUser Guide andXQuery Reference Guide in the Tamino
XML Server documentation for detailed information on XQuery expressions.

For each group of instances (doctype) you can specify exactly one filter. When a filter is active, a
filter symbol is shown with the group node in the navigation tree. For example:

The corresponding filter expression for the group of instances is shown in the properties pane.
For example:

To filter instances

1 In the navigation tree, select the group of instances to which you want to apply the filter.

2 From the Instance menu, choose Filter.

Or:

Choose the following toolbar button:

Or:

From the context menu of the doctype, choose Filter.
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The Filter Instances dialog box appears. The current doctype is indicated in the title bar.
When a filter has already been defined, an XQuery expression is shown in the dialog box.
When a filter has not yet been defined, the dialog box is empty.

3 Specify the XQuery expression that is to be used as a filter.

It is only possible to specify the where-clause part of the valid XQuery. The where-clause ex-
pression can use the instance with the predefined instance variable name $obj. For example:

$obj/name/surname between 'B', 'C'

For comparison, this is the X-Query equivalent with square brackets:

/person[name/surname between 'B', 'C']

4 Make sure that the Active check box is selected.

If this check box is not selected, your filter is not applied. This is useful if you want to deactivate
your filter temporarily.

5 Choose the OK button to display the first pack of instances that meet your filter criteria in
the navigation tree.

Exporting Instances for Mass-Loading

You can export all instances of an instance group into the Tamino standard format for mass-
loading.

To export instances for mass-loading

1 Select the doctype that contains the instances.

2 From the context menu, choose Export Instances.

3 Select the export location and enter the output filename in the Save dialog box. This starts
the export process.
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The following dialog box is displayed, indicating the status of the export process:

Note: If the number of instances in the selected instance group is quite high, the process
will take some time.

When the export process completes, the output file that you specified will contain the concatenated
contents of all of the selected instances.

Printing Instances

You can print both XML and non-XML instances. Select the instances to be printed and choose
Print Preview from the File menu. The Print Preview page is displayed, showing the contents of
the selected instances.

Choose the Print icon ( ) from the toolbar to print the page.

You can also print an instance directly, without previewing it, by selecting the instance and
choosing Print from the File menu.
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11 Customizing the Tools

In theCustomize dialog box, which is available underTools > Customize, you can define external
tools for editing the following types of objects that are displayed in the navigation tree:

■ schemas
■ doctypes
■ XML instances
■ non-XML instances
■ no specific type

You can define an external tool as the default tool for a specific type of object. The default tool is
invoked when you double-click the corresponding type of object in the navigation tree, or by
choosing Open from the File menu.

The defined external tools are also available as menu commands in the Tools menu (provided
that the corresponding check box has been selected in the Customize dialog box, see below).

When you invoke an external tool from theToolsmenu, any schema or instance which is currently
selected in the navigation tree is ignored. It is therefore recommended that you proceed as described
in section Opening a Schema or Instance.

Important: Predefined external tools for which a path has not been specified are not shown
as commands in the Tools menu and cannot be invoked using the Open or Open With
command.

See Predefined External Tools for further information.

To customize the tools

1 From the Tools menu, choose Customize.
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The Customize dialog box appears.

When external tools have already been defined, they are shown in the upper half of the dialog
box. When the corresponding check box in the Tools menu column has been selected and a
valid path has been entered in theCommand text box, the external tool is provided as a menu
command in the Tools menu.

The information shown in the lower half of the dialog box always applies to the external tool
that is currently selected in the upper half.

If the same external tool is to apply to objects of different types, you have to add an entry for
each of these types.

The following buttons are provided:
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Add a new external tool.

Delete the selected external tool.

Move the selected external tool one position up in the menu.

Move the selected external tool one position down in the menu.

Define an icon for the selected external tool. When the corresponding check box in theToolsmenu
column is selected, the icon will be shown in theToolsmenu. For your convenience, several image
files are available in the folder "X_Plorer\icons" which is created during installation.

2 To add a new external tool, choose the following button:

A new line is now shown.

3 Enter a name for the new external tool in the new line and press ENTER.

The description below applies to both new external tools that you have just added and existing
external tools that you want to modify.

4 Select the external tool in the upper half of the dialog box.

5 When the external tool is to be provided as a menu command in the Tools menu, make sure
that the corresponding check box in the Tools menu column is selected.

6 In the Command text box, specify the path to the external tool.

Use the appropriate notation for the platform on which you are running the Tamino X-Plorer.
Under Solaris, slashes are used (instead of backslashes as used under Windows).

Or:

Choose the Select button to select the executable file for the external tool from a dialog box.

Once the path to the external tool has been selected, the corresponding icon is automatically
displayed in the icons column of the Customize dialog box.

Tip: Under Windows, you can copy the information from the Properties dialog box.
From the Start menu, selectPrograms > program folder > program name. Do not execute
the program. Instead, invoke the context menu and choose Properties. You can now
copy the string in the Target text box and paste it in the Command text box. Make sure
not to copy any quotes at the start and end of the string.

If you leave this text box empty, the external tool is not shown as a command in the Tools
menu and cannot be invoked using the Open or Open With command.

7 In theArguments text box, define the arguments with which the external tool is to be invoked.

This can be a mixture of the following:
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Context-specific arguments
The following arguments can be used to send information about the object that is currently
selected in the navigation tree to the external tool:

DescriptionArgument

Creates a (temporary) file for the selected object in your open location. This
argument is usually required for tools used to edit instances and schemas.

$FILE_PATH$

Creates an URL pointing to the selected object.

Note:

$URL$

1. If the selected object is a schema, $URL$ is equal to
$SERVER_URL$/$DATABASE$/$COLLECTION$/$SCHEMA$.

2. If the selected object is an instance and if ino:docname exists, $URL$ is
equal to
$SERVER_URL$/$DATABASE$/$COLLECTION$/$DOCTYPE$/$INSTANCE$.

3. If the selected object is an instance and if ino:docname does not exist,
$URL$ is equal to
$SERVER_URL$/$DATABASE$/$COLLECTION$/$DOCTYPE$/@ino:id.

Creates an URL pointing to the server containing the selected object.$SERVER_URL$

Creates a string with the name of the database containing the selected object.$DATABASE$

Creates a string with the name of the collection containing the selected
object.

$COLLECTION$

Creates a string with the name of the selected schema.$SCHEMA$

Creates a string with the name of the selected doctype.$DOCTYPE$

Creates a string with the name of the selected instance (ino:docname).$INSTANCE$

Your user ID for the database containing the selected object.$USER$

Your password for the database containing the selected object.$PASSWORD$

Instead of entering the above arguments in the text box, you can also select them from a
list. To do so, choose the Arguments button.

Tool-specific arguments
You have to specify all arguments that are expected by the external tool. See your external
tool documentation for information on the supported arguments.

8 In the Apply to objects of type group box, select one of the following option buttons (the
adjacent information changes depending on the option button that has been selected):
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Schema
The tool applies to schemas.

If you want to use this tool as your default tool for schemas, make sure that the Open
(double-click) schemawith tool check box is selected. When the check box is not selected,
this tool is available from a context menu via the Open With command.

Doctype
The tool applies to doctypes.

If you want to use this tool as your default tool for doctypes, make sure that the Open
(double-click) doctypewith tool check box is selected. When the check box is not selected,
this tool is available from a context menu via the Open With command.

Instance
The tool applies to XML instances.

If you want to use this tool as your default tool for XML instances, make sure that the
Open (double-click) instance with tool check box is selected. When the check box is not
selected, this tool is available from a context menu via the Open With command.
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Non-XML Instance
The tool applies to non-XML instances.

When you open a non-XML instance, the application which is associated with the media
type and extension that has been defined in this table is used.

You have to specify the required media type and the corresponding extension(s). It is also
possible to define an extension without a media type. See Media Types for Non-XML In-
stances.

Tip: Under Windows, you can copy the media type from the FolderOptions dialog
box. Invoke the Windows Explorer (not the Internet Explorer) and from the Tools
menu, choose Folder Options. In the resulting Folder Options dialog box, choose
the File Types tab. Select a registered file type and copy media type and extension
to the Customize dialog box.

When you define several tools for one type of object (for example, GIF), the first tool that
has been defined in the upper half of the Customize dialog box is used as the default tool
(i.e. when you use the Open command or double-click the non-XML instance). All other
defined tools are available from a context menu via theOpenWith command which offers
the tools in the following sequence: tools for which media type and extension have been
defined are shown first, tools with a media type only are shown next, and tools with an
extension only are shown last.

The following buttons are provided:

Add a new media type and its extension(s).

Delete the selected media type and its extension(s).

None
The tool does not apply to a specific type of object. It can only be invoked from the Tools
menu (provided that the Tools menu check box has been selected). You can define, for
example, an editor such as the Windows Notepad.
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9 Choose the OK button.

In the Tools menu, commands are now available for each tool for which you have defined a
path and for which the Tools menu check box has been selected.
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This chapter covers the following topics:

Invoking the Options Dialog Box

The settings in the Options dialog box control the behavior of certain features of the Tamino X-
Plorer.

To invoke the Options dialog box

1 From the Tools menu, choose Options.

The Options dialog box appears.

2 Select one of the following pages and set the required options as described below under the
following headings.

■ General
■ File Location
■ X-Query

3 Choose the OK button.
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General

The instance fetch defaults on this page are the default values for the command Instance Fetch
Options. See Specifying the Instance Fetch Options.

By default, different values are defined for the two instance fetch options. Each pack that you fetch
is thus shown in addition to the previous pack. It is not overwritten - until the maximum number
of kept instances is reached.

You can set the following options:

Number of instances per pack
The number of instances that are to be fetched with each pack.

Maximum number of kept instances
The maximum number of instances that can be shown in a group of instances at the same time.

Use wordwrap in tree view
Applies to the Content pane and Properties pane in the main application window. When this
check box is selected, lines are wrapped in tree view.

Hide system collections
When this check box is selected, the system collections (for example, ino:SXS-ADMINISTRATION
or ino:SXS-TRACE) are not shown in the navigation tree of the main application window. There
is one exception: the collection ino:etc, which contains user data, is always shown.

If you want to display the content of the WebDAV enabled collection ino:dav, uncheck this
check box. The content of the ino:dav collection is displayed in the Navigation Tree.

When you change this option and close the Options dialog box, the change is not applied im-
mediately as this can be time-consuming. It will be applied the next time you invoke the Tamino

109Tamino X-Plorer

Setting the Tamino X-Plorer and X-Query Options



X-Plorer. If you want to see the effects of your change immediately, you can refresh the display
for the database. See Refreshing the Display.

Tip: As changing this option can be time-consuming for large databases, it is recommen-
ded that you specify the required setting once and then keep it.
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File Location

You can set the following option on this page:

Open location
All objects that are opened with an external tool for which the argument $FILE_PATH$ has been
specified are stored in the folder that is defined as your open location.

You can define any other folder in your file system. Either specify the path to the folder in this
text box or choose the Select button to select the folder from a dialog box.

Note: All file locations for schemas, instances, queries and results are remembered. Each
time you open a file chooser dialog box, the folder that was selected when you last
opened this dialog box is shown again. A file chooser dialog box appears, for example,
when you define, update or save a schema.

Browser Location
With this option, you can choose your preferred browser to display help. Uncheck the option
Select default browser and select the preferred browser location. You can change the settings
anytime.
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X-Query

The settings on this page apply only to the Tamino X-Plorer's X-Query windows. They do not
apply to the Tamino XQuery Tool which can also be invoked from the Tamino X-Plorer.

The result fetch defaults on this page are the default values for the commandResult FetchOptions.
See Specifying the Result Fetch Options.

By default, identical values are defined for the two result fetch options. Each pack that you fetch
thus overwrites the previous pack. If the previous packs are to remain visible, specify a higher
value for the maximum number of kept instances.

You can set the following options:

Number of instances per pack
The number of instances or fragments that are to be fetched with each pack.

Maximum number of kept instances
The maximum number of instances or fragments that can be shown in a group of instances at
the same time.

Use wordwrap in tree view
Applies to the Result pane in an X-Query window. When this check box is selected, lines are
wrapped in tree view.
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The Tamino X-Plorer can display the contents of the WebDAV enabled collection ino:dav.

To display the content of the ino:dav collection

1 From the Tools menu, choose Options and uncheck the Hide system collection checkbox
under the General tab.

The ino:dav collection is displayed in the Navigation Tree.

2 Expand the ino:dav collection and select an instance to view it in the X-Plorer.

Note: Currently, displaying a folder in the ino:dav collection that has white-space character(s)
in its name is not supported. An error message is displayed if such a situation occurs.

Furthermore, the following actions are possible with instances in the ino:dav collection:

Checkout and Checkin of Instances

You can check out instances of the ino:dav collection and subsequently check them back in. In-

stances that can currently be checked out are marked with the icon. Instances that can currently
be checked in, i.e. instances that previously have been checked out, are marked with the icon.

To check out an instance of the ino:dav collection

1
Select the instance to be checked out, open the context menu and chooseCheckout ( ) from
the context menu to open a File Save dialog box.

2 Select the path where the checked out instance is to be saved and choose the Save button.

The selected instance is saved to the specified location, and the corresponding instance icon

changes to .

To check in an instance into the ino:dav collection

1 Make the desired changes to the file that previously has been checked out.

2
Select the instance, open the context menu and choose Checkin from the context menu.

The selected instance is checked in, using the file that is located at the previously checked out

location. The instance icon changes to .
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Version History

You can view the version history of the instances in the ino:dav collection. Also, you can download
a specific version of a selected instance.

To view the version history of an instance in the ino:dav collection

■ Select an instance, open the context menu and choose Version List from the context menu.

The WebDAV Version History dialog box is displayed:
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The dialog box shows the URL of the selected instance. It also displays the versions of the
instance that are available, the last date modified of the particular version, as well as any related
comment.
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To download a specific version of an instance in the ino:dav collection

1 In the WebDAV Version History dialog box, select the row containing the version of the in-
stance that is to be downloaded, and choose the Download button.

A File Save dialog box is displayed.

2 Select the path where the specified version of the instance is to be saved and choose the Save
button.

Note: Modifying and updating plain text documents in WebDAV is possible as normal in-
stances.
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V Performing X-Queries with the Tamino X-Plorer

This section explains how to work with the X-Query windows of the Tamino X-Plorer. The following
topics are provided:

■ Invoking and Closing X-Query Windows
■ Elements of an X-Query Window
■ Working with X-Queries
■ Managing X-Query Results

See also:X-QueryUser Guide andX-Query Reference Guide in the Tamino XML Server documentation.

119



120



14 Invoking and Closing X-Query Windows

■ Invoking an X-Query Window ........................................................................................................... 122
■ Closing an X-Query Window ............................................................................................................ 123

121



You can perform queries on a Tamino database. Queries are performed in a separate application
window. The main Tamino X-Plorer application window remains active so that you can work
with both windows at the same time.

This chapter covers the following topics:

Invoking an X-Query Window

Each time you invoke an X-Query window, the currently selected object in the navigation tree is
automatically provided as a query expression. This if helpful if you do not want to type this in-
formation yourself.

It is possible to invoke more than one X-Query window. Thus, you can perform several queries
and compare their results.

To invoke an X-Query window

1 In the navigation tree, select the object which you want to include in your query.

2 From the Tools menu of the main application window, choose Query > X-Query.

Or:

Choose the following toolbar button:

Or:

In the context menu, choose X-Query.

The X-Query window appears. See Elements of an X-Query Window.

You can now specify and execute the query. See Working with X-Queries.
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Closing an X-Query Window

When you close the main application window of the Tamino X-Plorer, all X-Query windows are
also closed.

To close an X-Query window

■ From the File menu of the X-Query window, choose Close.

Or:

From the Control menu of the X-Query window, choose Close.

Or:

Choose the corresponding standard button in the title bar.
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The following sample X-Query window contains all information that is required to execute a
query: server, database, collection and query expression.

The X-Query window contains several panes. To modify the size of a pane, move the mouse
pointer over the border separating the panes until the pointer changes, showing two arrows
pointing in opposite directions. Then drag the border using the mouse until the panes have the
desired size.

The following topics are covered below.
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Menu Bar

The following menus are available:

Using the commands in this menu, you can ...Menu

Create, open, execute and save your queries.File

Cut, copy and paste information.Edit

Switch on and off different elements of the X-Query window.View

Manage your results.Result

Use additional related features.Tools

Invoke online help.Help

For reference information on each menu command, seeMenu Commands in an X-QueryWindow.

Toolbar

You can execute the most important functions using the toolbar.

The following toolbar buttons are available:

Create new query

Open query

Save query

Execute query

Execute non-XML query

Cut selected text

Copy selected text

Paste previously cut or copied text

Toggle display of navigation tree

Specify result fetch options

Go to first result pack

Go to previous result pack

Go to next result pack

Go to last result pack

Access online documentation
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To switch the toolbar display on and off

■ From the View menu, choose Toolbar.

When the toolbar is displayed in the X-Query window, a check mark is shown next to this
menu command.
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Query Area

The query area consists of the text boxes in which you enter the required server, database and
collection, and a query editor in which you enter your query.

When you invoke an X-Query window, the currently selected object in the navigation tree is
automatically shown as a query expression. Server, database and collection containing the selected
object are automatically provided in the text boxes. This if helpful if you do not want to type this
information yourself. In addition, any settings used for the instance descriptors are included in
the query. For example:

You can now modify the query expression and/or execute the query. SeeWorkingwith X-Queries.

A query is specified using Tamino's X-Query language. See X-Query User Guide and X-Query Ref-
erence Guide in the Tamino XML Server documentation for detailed information.

Using the Tamino connect/select dialog, we can select the server and database. These buttons are
available along with the text areas.

Different colors are used for a query expression. Blue is used for keywords of the X-Query language
such as and, true, sortby or between. Red is used for values of datatypes such as string or boolean.

To execute the query

■ Choose File > Execute Query.

Or:

Choose from the menu bar.
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Result Pane

After you have executed a query (see Executing an X-Query), its result is shown on the Result
pane at the bottom of the X-Query window. For example:

The following topics are covered below:

■ Navigation Tree
■ Result Contents

More information is provided in the section Managing X-Query Results.

Navigation Tree

The left side of the Result pane shows a navigation tree with the query result. The number of
result packs shown depends on the defined result fetch options. See Specifying the Result Fetch
Options.

Depending on your query expression, different types of query result are provided. Each result
shows either instances or fragments:

■ Instances
Complete instances are shown when you search for a doctype, for example, when your query
expression is "/patient". When an instance descriptor has been defined for the XML instances,
it is applied.

■ Fragments
A fragment is a small part of an instance. It is shown when you specify, for example,
"//name/firstname" which shows all first names not considering their locations in the XML object
(i.e. this can be the first name of a patient or doctor). The ino:id is always shown for a fragment;
an instance descriptor is not applied. Fragments are not shown for non-XML instances.
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The following icons may appear in the navigation tree. The icon tells you which type of query
has been executed.

Shown as the result of an XML query: XML instance or non-XML instance.

Shown as the result of a non-XML query: XML instance or non-XML instance.

Shown as the result of an XML query: fragment of an XML instance.

Arrows for browsing the instances may appear in the tree:

Click the plus sign next to this symbol to fetch and display the next pack. When using the keyboard,
select this symbol and press ENTER.

Click the plus sign next to this symbol to fetch and display the previous pack. When using the keyboard,
select this symbol and press ENTER.

To switch the navigation tree display on and off

■ From the View menu, choose Navigation Tree.

Or:

Choose the following toolbar button:

When the navigation tree is displayed in the Result pane, a check mark is shown next to the
command Navigation Tree.
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Result Contents

The right side of the Result pane shows the contents of the result that is currently selected in the
navigation tree on the left.

Depending on the type of object and the type of query, one or more views are available. When
different views are available, they can be activated using the following buttons in the top right
corner of the Result pane:

DescriptionKeyboardButton

Tree view for the result of an XML query. Not available for the result of a non-XML
query. Whether lines are wrapped in tree view depends on the corresponding setting

CTRL+SHIFT+T

in the Options dialog box. See Setting the Tamino X-Plorer and X-Query Options
for further information.

Plain view providing the content of a result.CTRL+SHIFT+P

Image view for non-XML objects (for example, GIF). Not available for the result of an
XML query.

CTRL+SHIFT+I

Note: In plain view, you can copy information using the corresponding command from the
Edit menu.

The following example shows the contents of an XML instance in tree view (XML query):
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The following example shows the contents of the same instance in plain view (XML query):
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The following topics are covered below.

Specifying an X-Query

When you specify a query in the X-Query window, you must always provide server, database,
collection and query expression.

To specify an X-Query

1 In the Server text box, specify the name of the server on which you want to execute your
query.

2 In the Database text box, specify the name of a database of the above server in which you
want to execute your query.

3 In the Collection text box, specify the name of a collection in the above database in which
you want to execute your query.

4 In the query area below the above text boxes, specify the query expression using Tamino's X-
Query language. See X-Query User Guide and X-Query Reference Guide in the Tamino XML
Server documentation for detailed information.

The sorting sequence specified with the instance descriptor is not applied in the X-Query
window. In the X-Query window, you can specify your own sorting sequence in the query
expression (for example, with the sortby clause).

You can now execute the query as described below. See Executing an X-Query.

Creating a New X-Query

When you create a new query, any information in the query area is deleted.

Note: The result of the previous query is not overwritten until you execute the new query.

To create a new X-Query

1 From the File menu, choose New.

Or:

Press CTRL+N.

Or:
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Choose the following toolbar button:

A dialog box appears asking whether you want to save the currently displayed query.

2 Choose either the Yes or No button.

When you choose the Yes button and the current query has not yet been saved in a file, the
Save As dialog box appears. See Saving an X-Query below.

The query area is now empty.

3 Specify a query expression and execute the query.

Executing an X-Query

When you have specified a query and want to display the result, you have to execute the query.

You can search for both XML instances and non-XML instances. Two different types of query are
available for these two types of instances and they are executed using different commands (see
below).

Depending on the type of query different information is shown in the navigation tree:

■ XML Query
The ino:id is shown for fragments and non-XML instances. For XML instances, the ino:id
and/or instance descriptor is shown.

■ Non-XML Query
The ino:docname is shown for XML and non-XML instances. When ino:docname is not available
for an XML instance, the ino:id is shown.
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The result contents are shown in different ways, depending on the type of query:

Non-XML QueryXML Query

The XML code without ino:id is
shown in plain view.

The XML code with ino:id is shown in plain
view and tree view.

XML Instance or
Fragment

The content of a non-XML instance is
shown.

The attributes ino:id and ino:docname are
shown in plain view and tree view.

Non-XML Instance

For a list of all non-XML formats that can be displayed with the Tamino X-Plorer, see the description
of the main application window's Content pane.

When you execute a query for a database which has not yet been connected, the Connect dialog
box appears and you have to specify all required logon information. See Connecting to a Tamino
Database.

Each new query that is executed overwrites the previous result pack. If you want to save your
result pack, see Saving the Current Result Pack.

Note: The result of a query may provide both XML and non-XML instances.

To execute an XML query

■ From the File menu, choose Execute XML Query.

Or:

Or press CTRL+Q.

Or:

Choose the following toolbar button:

The result is now shown on the Result pane.

To execute a non-XML query

■ From the File menu, choose Execute Non-XML Query.

Or:

Or press CTRL+E.

Or:
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Choose the following toolbar button:

The result is now shown on the Result pane.

Note: A portion of X-Query code can be executed by selecting the portion and pressing the
Execute button or pressing Ctrl+Q.

Saving an X-Query

You can save a query in a file in your file system.

As long as a query has not yet been saved, the name "NewQuery" is shown in the title bar of the
X-Query window. When you save this query for the first time, the Save As dialog box appears in
which you have to specify the name of the file in which the query is to be saved in your file system.

To save an X-Query under a new name

1 From the File menu, choose Save As.

The Save As dialog box appears. File name and extension are automatically provided.

2 Optionally: specify another file name and extension.

3 Select the path in which you want to save the file.

4 Choose the Save button.

To save a named X-Query

■ From the File menu, choose Save.

Or:

Or press CTRL+S.

Or:

Choose the following toolbar button:

The existing query in your file system is updated.
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Opening a Saved X-Query

You can open a query which you have previously saved in your file system.

To open a saved X-Query

1 From the File menu, choose Open.

Or:

Press CTRL+O.

Or:

Choose the following toolbar button:

A dialog box appears asking whether you want to save the currently displayed query.

2 Choose either the Yes or No button.

When you choose the Yes button and the current query has not yet been saved in a file, the
Save As dialog box appears. See Saving an X- Query above.

The Open dialog box appears.

3 Select the file containing the desired query.

4 Choose the Open button.

The previously saved query is now shown in the X-Query window.

Selecting Text

In order to cut, copy or delete text, you have to select it. To do so, use the standard techniques for
the platform on which you are currently working.

You can also select all text at once (see below). In this case, the selection depends on the area which
has previously been selected in the query window.

You can select text in the following areas:

■ in the query area (including the text boxes for server, database, and collection),
■ in the result contents of the Result pane (plain view only).
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To select all text

1 Select the required area in the query window.

2 From the Edit menu, choose Select All.

Or:

Press CTRL+A.

Cutting, Copying and Pasting Text

You can cut, copy and paste any text in the query area. You can also copy from the result contents
of the Result pane (plain view only).

This feature uses the Windows clipboard which may also contain information from another ap-
plication. Thus, it is also possible to copy an entire query from or to another source.

To cut the selection and transfer it to the clipboard

■ From the Edit menu, choose Cut.

Or:

Press CTRL+X.

Or:

Choose the following toolbar button:

The selection is deleted at its original position and is copied to the clipboard.

To copy the selection to the clipboard

■ From the Edit menu, choose Copy.

Or:

Press CTRL+C.

Or:

Choose the following toolbar button:
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The selection remains at its original position and is copied to the clipboard.

To paste the content of the clipboard

1 Place the insertion point at the position at which you want to paste the cut or copied inform-
ation.

2 From the Edit menu, choose Paste.

Or:

Press CTRL+V.

Or:

Choose the following toolbar button:

The previously cut or copied text is inserted at the insertion point.

Deleting Text

You can delete any text in the query area.

To delete the selection

■ From the Edit menu, choose Clear.

Or:

Press DEL.

The selection is deleted immediately. You are not asked to confirm the deletion.
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The following topics are covered below.
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Specifying the Result Fetch Options

The result of a query is shown as different packs in the Result pane. You can specify the number
of instances that are to be shown with each pack.

The default values are defined in the Options dialog box. See Setting the Tamino X-Plorer and
X-Query Options for further information.

To specify the result fetch options

1 From the Result menu, choose Result Fetch Options.

Or:

Choose the following toolbar button:

The Specify Instance Fetch Options for Result dialog box appears.

2 Specify the following information:

Number of instances per pack
The number of instances or fragments that are to be fetched with each pack.

Maximum number of kept instances
The maximum number of instances or fragments that can be shown at the same time.

3 Optionally: if you want to reset the values that are currently defined in the dialog box to the
default values, choose the Reset to Default button.

4 Choose the OK button to use the new values.
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Browsing the Result Packs

When more instances or fragments are available than can be shown on the Result pane, you can
browse through the result packs.

You can display the next or previous pack. Or you can immediately jump to the last pack or to
the first pack.

The browse commands (see below) that are currently not available are disabled. For example,
when the entire result is provided in one pack on the Result pane, all browse commands (and the
corresponding toolbar buttons) are disabled.

To go to the first result pack

■ From the Result menu, choose First.

Or:

Choose the following toolbar button:

To go to the last result pack

■ From the Result menu, choose Last.

Or:

Choose the following toolbar button:

To go to the previous result pack

■ From the Result menu, choose Previous.

Or:

Choose the following toolbar button:

Or:
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When the navigation tree is shown, click the plus sign next to the up-arrow at the top of the
list. When using the keyboard, select the up-arrow and press ENTER.
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To go to the next result pack

■ From the Result menu, choose Next.

Or:

Choose the following toolbar button:

Or:

When the navigation tree is shown, click the plus sign next to the down-arrow at the bottom
of the list. When using the keyboard, select the down-arrow and press ENTER.

Saving the Current Result Pack

You can save the result pack that is currently shown in the navigation tree of the Result pane to
your file system.

To save the current result pack

1 From the Result menu, choose Save Displayed Result As.

The Save As dialog box appears. File name and extension are automatically provided.

2 Optionally: specify another file name and extension.

3 Select the path in which you want to save the file.

4 Choose the Save button.

Saving an Instance or Fragment

You can save the item that is currently selected in the navigation tree of the Result pane to your
file system. This can be an XML instance, a non-XML instance or a fragment.

To save an instance or fragment

1 In the navigation tree of the Result pane, select the item to be saved.

2 From the Result menu, choose Save Selected Item As.

The Save As dialog box appears. File name and extension are automatically provided.
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3 Optionally: specify another file name and extension.

4 Select the path in which you want to save the instance or fragment.

5 Choose the Save button.
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VI Using the Tamino XQuery Tool

This section explains how to specify queries with the Tamino XQuery tool. The following topics
are provided:

■ Starting and Leaving the Tamino XQuery Tool
■ Elements of the Tamino XQuery Window
■ Working with the Tamino XQuery Tool
■ Managing XQuery Results
■ Setting the Tamino XQuery Tool Options

See also: XQuery 4 User Guide and XQuery 4 Reference Guide in the Tamino XML Server document-
ation.
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This chapter covers the following topics:

Starting the Tamino XQuery Tool

The Tamino XQuery tool can be started in two different ways:

■ From the Tamino X-Plorer. The Tamino X-Plorer remains active so that you can work with both
applications at the same time.

■ In standalone mode (without the Tamino X-Plorer).

It is possible to invoke more than one XQuery window. Thus, you can perform several queries
and compare their results.

To invoke the Tamino XQuery tool from the Tamino X-Plorer

1 In the navigation tree of the Tamino X-Plorer, select the object which you want to include in
your query.

The currently selected object in the navigation tree will be provided as a query expression in
the Tamino XQuery tool. The names of the server, database and collection will be supplied
automatically. This if helpful if you do not want to type this information yourself.

2 From the Tools menu of the Tamino X-Plorer, choose Query > XQuery.

Or:

Choose the following toolbar button:

The application window of the Tamino XQuery tool appears. See Elements of the Tamino
XQuery Window.

You can now specify and execute the query. See Working with the Tamino XQuery Tool.
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To start the Tamino XQuery tool in standalone mode on Windows

■ From the Windows Start menu chooseTaminoXQuery Tool from the Tamino program group.

To start the Tamino XQuery tool in standalone mode on UNIX platforms

■ Start the following script from the command line:

inoxquery.sh

Leaving the Tamino XQuery Tool

When you close the Tamino X-Plorer, all XQuery windows that have been opened from the Tamino
X-Plorer are also closed.

To close an XQuery window

■ From the File menu, choose Close.

Or:

From the Control menu, choose Close.

Or:

Choose the corresponding standard button in the title bar.
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When you start the Tamino XQuery tool, its application window appears.

The following sample XQuery window contains all information that is required to execute a query:
server, database, collection and the query expression.

The XQuery window contains several panes. To modify the size of a pane, move the mouse
pointer over the border separating the panes until the pointer changes, showing two arrows
pointing in opposite directions. Then drag the border using the mouse until the panes have the
desired size.

For details on keyboard access not mentioned in this documentation, consult the documentation
of the individual operating system or software product.
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The following topics are covered below.
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Menu Bar

The following menus are available:

Using the commands in this menu, you can ...Menu

Create, open, execute, explain and save your queries.File

Edit the current query (for example, cut, copy and paste text).Edit

Switch on and off different elements of the XQuery window.View

Manage your results.Result

Define the options.Tools

Invoke online help.Help

For reference information on each menu command, see Menu Commands in a Tamino XQuery
Tool Window.
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Toolbar

You can execute the most important functions using the toolbar.

The following toolbar buttons are available:

Create new query

Open query

Save query

Execute query

Explain query

Open XQuery module

Save XQuery module

Toggle between module management mode and query mode.

Cut selected text

Copy selected text

Paste previously cut or copied text

Find text

Toggle display of navigation tree

Specify result fetch options

Go to first result pack

Go to previous result pack

Go to next result pack

Go to last result pack

Access online documentation

To switch the toolbar display on and off

■ From the View menu, choose Toolbar.

When the toolbar is displayed in the XQuery window, a check mark is shown next to this
menu command.
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Query Area

The query area consists of the text boxes in which you enter the required server, database and
collection, and a query editor in which you enter your query expression.

When you invoke an XQuery window from the Tamino X-Plorer, the currently selected object in
the X-Plorer's navigation tree is automatically shown as a query expression. Server, database and
collection containing the selected object are automatically provided in the text boxes. This if
helpful if you do not want to type this information yourself. For example:

You can modify the query expression and/or execute the query. See Working with the Tamino
XQuery Tool. When you invoke an XQuery window in standalone mode, you have to specify all
of this information yourself (see Specifying an XQuery).

A query expression is specified using XQuery. See XQuery 4 User Guide and XQuery 4 Reference
Guide in the Tamino XML Server documentation for detailed information.

Syntax highlighting is used. Several predefined styles with different colors and font styles are
provided. For example, a keyword style is provided which shows the keywords of the XQuery
language (such as for, in, where or return) with the color blue and with the font style bold.

Notes:

1. The W3C XQuery specification (W3C Working Draft 16 August 2002) is currently used for
syntax highlighting. SeeXQuery 1.0: AnXMLQuery Language athttp://www.w3.org/TR/2002/WD-
xquery-20020816/.

2. Syntax highlighting may fail if the expression contains non-ASCII characters. In certain cases
(for example, Kanji), the query code is highlighted in red. Workaround: Switch highlighting
off by adding the following line to the xplorer.properties file:
com.softwareag.xtools.xquery.editor.XQueryEditor.syntaxHighlighting=false

The current position of the insertion point in the query editor is shown at the bottom of the query
area (line and column). The information to the left of the position indicates whether insert mode
or overwrite mode is currently active. The mode can be toggled using the INS key.
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The XQuery code is automatically indented in the query display area if you check theAuto Indent
box. This can help to make the code easier for you to read if the code contains nested structures.
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Result Pane

The Result pane is shown at the bottom of the XQuery window.

The following topics are covered below:

■ Navigation Tree
■ Result Contents

More information is provided in the section Managing XQuery Results.

Navigation Tree

After you have executed a query (see Executing an XQuery), the left side of theResult pane shows
a tree with the query result. The number of result packs shown depends on the defined result fetch
options (see Specifying the Result Fetch Options).

Note: The navigation tree is not shown when an error message is displayed or when an ex-
planation of a query is displayed.

Depending on your query expression, different types of query result are provided. Each result
shows either instances or fragments:

■ Instances
Complete instances are shown when you search for a doctype, for example, when your query
expression is "input()/patient".

■ Fragments
A fragment is a small part of an instance. It is shown when you specify, for example, "in-
put()/name/firstname" which shows all first names not considering their locations in the XML
object (i.e. this can be the first name of a patient or doctor).

The instances or fragments receive consecutive numbers preceded by a hash (#) character.
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The following icons may appear in the navigation tree. They are shown as the result of an XQuery.

XML instance as it was stored in Tamino.

Fragment of an XML instance, or XML instance if an element constructor is used in the result.

Arrows for browsing the instances may appear in the tree:

Click the plus sign next to this symbol to fetch and display the next pack. When using the keyboard,
select this symbol and press ENTER.

Click the plus sign next to this symbol to fetch and display the previous pack. When using the keyboard,
select this symbol and press ENTER.

To switch the navigation tree display on and off

■ From the View menu, choose Navigation Tree.

Or:

Choose the following toolbar button:

When the navigation tree is displayed in the Result pane, a check mark is shown next to the
command Navigation Tree.
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Result Contents

The right side of the Result pane shows one of the following:

■ When you have chosen the Execute Query command, the contents of the result that is currently
selected in the navigation tree is shown on the right side of the Result pane. See Executing an
XQuery.

The following example shows the contents of a query in tree view:

The following example shows the same result in plain view:

■ When you have chosen the Explain Query command, an explanation of the query is shown.
The navigation tree is not shown in this case. See Explaining an XQuery.

The following example shows the explanation of a query:
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■ When an error has occurred, an error message is shown. The navigation tree is not shown in
this case.

167Tamino X-Plorer

Elements of the Tamino XQuery Window



Depending on the type of object and the type of query, one or more views are available. When
different views are available, they can be activated using the following buttons in the top right
corner of the Result pane:

DescriptionKeyboardButton

Tree view providing the content of a result, an explanation of a query, or an error
message. Whether lines are wrapped in tree view depends on the corresponding

CTRL+SHIFT+T

setting in the Options dialog box. See Setting the Tamino XQuery Tool Options for
further information.

Plain view providing the content of a result, an explanation of a query, or an error
message.

CTRL+SHIFT+P

Note: In plain view, you can copy information using the corresponding command from the
Edit menu.
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Response Pane

When you have chosen the Explain Query command (see Explaining an XQuery), the Tamino
response (ino:response) is shown in the Response pane at the bottom of the XQuery window.

In general, the success or failure of the client request is indicated in the ino:returnvalue attribute
of the ino:message element of the response document. A value of 0 indicates a successful response,
whereas a non-zero value indicates either an error or a non-standard response. For further inform-
ation on the syntax of XML responses and on the elements and attributes in Tamino response
documents, seeX-Machine Programming, sectionRequests usingX-Machine Commands in the Tamino
XML Server documentation.

Different views are available. They can be activated using the following buttons in the top right
corner of the Response pane:

DescriptionKeyboardButton

Tree view providing the response. Whether lines are wrapped in tree view depends
on the corresponding setting in theOptionsdialog box. See Setting the TaminoXQuery
Tool Options for further information.

CTRL+SHIFT+T

Plain view providing the response.CTRL+SHIFT+P

Note: In plain view, you can copy information using the corresponding command from the
Edit menu.
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History Pane

Queries for which you have previously invoked the Execute Query command (see Executing an
XQuery) or the Explain Query command (see Explaining an XQuery), are shown on the History
pane at the bottom of the XQuery window.

The following topics are covered below:

■ Query List
■ Query Contents
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Query List

The top of the History pane shows a list with queries that have been previously invoked. The
latest query is shown at the top of the list.

The maximum number of query entries and the maximum number of characters shown for each
query entry depend on the corresponding settings in the Options dialog box. See Setting the
Tamino XQuery Tool Options for further information.

When you select a query in the list, the following information about this query is shown below
the list: server, database, collection and the date and time when this query was invoked.

The following buttons are provided:

Copies the selected query to the query area so that you can modify and invoke it once more. A
dialog box appears asking whether you want to save the query which is currently displayed in the
query area. Alternative: double-click the desired query.

Apply

Deletes the selected query from the history. The query is deleted immediately. You are not asked
to confirm the deletion.

Query Contents

The bottom of the History pane shows the entire query (read-only) for the item that is currently
selected in the query list.

For information on syntax highlighting, see Query Area.
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The following topics are covered below.
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Specifying an XQuery

When you specify a query in the XQuery window, you must always provide server, database,
collection and the query itself.

Only queries that reference XML doctypes are possible. For queries on non-XML doctypes, use X-
Query. See Performing X-Queries with the Tamino X-Plorer.

To specify an XQuery

1 In the Server text box, specify the name of the server on which you want to execute your
query.

You can use the selection icon ( ) to open a dialog that lets you navigate to the required
server and database. You can also use the option Tools > Connect to Server from the main
menu to navigate to the required server and database.

2 In the Database text box, specify the name of a database of the above server in which you
want to execute your query.

3 In the Collection text box, specify the name of a collection in the above database in which
you want to execute your query.

4 In the query editor below the above text boxes, specify the query. See XQuery 4 User Guide
and XQuery 4 Reference Guide in the Tamino XML Server documentation for detailed inform-
ation.

You can specify the sorting sequence in your query, for example, with the sort by clause (the
sorting sequence specified in the Tamino X-Plorer (instance descriptor) is not applied).

You can now execute the query as described below. See Executing an XQuery.

It is also possible to retrieve information about query execution, without executing the query.
See Explaining an XQuery.
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Creating a New XQuery

When you create a new query, any information in the query area is deleted.

Note: The result of the previous query is not overwritten until you issue the Execute Query
or Explain Query command for the new query.

To create a new XQuery

1 From the File menu, choose New.

Or:

Press CTRL+N.

Or:

Choose the following toolbar button:

A dialog box appears asking whether you want to save the currently displayed query.

2 Choose either the Yes or No button.

When you choose the Yes button and the current query has not yet been saved in a file, the
Save As dialog box appears. See Saving an XQuery below.

The query area is now empty.

3 Specify a query and choose the Execute Query or Explain Query command
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Using Templates and the auto-complete Feature

You can use pre-defined XQuery templates and the auto-complete feature to complete your XQuery
statements, without much typing effort. Type in the first one or two letters of the word that you
want to insert and press CTRL+SPACE. Also notice that the query statement aligns itself automatically.
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Explaining an XQuery

When you have specified a query, you can use the Explain Query command (which corresponds
to ino:explain) to retrieve information about query execution for analysis and optimization. For
detailed information on ino:explain, see the X-Query Reference Guide in the Tamino XML Server
documentation.

The Explain Query command works in the same way as the Execute Query command. The only
difference is that the query is not executed, it is just analyzed.

When the query is sent to the Tamino server, two additional lines, {?explain?} and {?explain
preprocessor?}, are inserted at the top of the query. Therefore, all line numbers in the explanation
text of the query (in the Result pane and Response pane) are greater by two than in the query
editor.

When you request the explanation of a query for a database which has not yet been connected,
the Connect dialog box appears and you have to specify all required logon information. See Con-
necting to a Tamino Database.

To explain an XQuery

■ From the File menu, choose Explain Query.

Or:

Or press CTRL+E.

Or:

Choose the following toolbar button:

The explanation is now shown on the Result pane and on the Response pane.
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Executing an XQuery

When you have specified a query and want to display the result, you have to execute the query.

When you execute a query for a database which has not yet been connected, the Connect dialog
box appears and you have to specify all required logon information. See Connecting to a Tamino
Database.

Each new query that is executed overwrites the previous result pack. If you want to save your
result pack, see Saving the Current Result Pack.

Note: Before you execute a query, it is recommended that you retrieve information about
query execution using the Explain Query command. See Explaining an XQuery.

To execute an XQuery

■ From the File menu, choose Execute Query.

Or:

Or press CTRL+Q.

Or:

Choose the following toolbar button:

The result is now shown on the Result pane.

XQuery execution is based on a transaction. Therefore, the access to a query result is only
possible during the transaction. See the description for maximum transaction duration in the
in the Tamino XML Server documentation (to be found under Create a Database in the Tamino
Manager section). Hints:

■ Execute the query once again if the transaction has timed out.
■ Increase the number of instances per pack to get a bigger portion of the query result set.
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Cancel XQuery Execution

If you execute a query that takes a considerable amount of time, a processing dialog box is displayed,
which lets you cancel the query. You just need to choose theAbort button and the query is cancelled.
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XQuery Scratchpad

In addition to using the Explain Query and Execute Query features as described above, you can
select a section of XQuery code from the display and activate the Explain or Execute feature for
this selected code section.

To execute or explain a section of code from the text input field

1 Ensure that the text input field contains valid XQuery code.

2 Select the required section of the displayed XQuery code in the text input field, by moving
the cursor to the required first character, then dragging the cursor to the required last character.

3 From the Tools menu, select either to execute the selected query code, or to examine the
selected query code.

The results are then displayed in the Result window.

Saving an XQuery in the File System

You can save a query in a file in your file system.

As long as a query has not yet been saved, the name "NewXQuery" is shown in the title bar of the
XQuery window. When you save this query for the first time, the Save As dialog box appears in
which you have to specify the name of the file in which the query is to be saved in your file system.

To save an XQuery under a new name

1 From the File menu, choose Save As.

TheSaveAsdialog box appears. File name and extension (.xquery) are automatically provided.

2 Optionally: specify another file name. Do not change the extension.

3 Select the path in which you want to save the file.

4 Choose the Save button.

To save a named XQuery

■ From the File menu, choose Save.

Or:

Or press CTRL+S.
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Or:

Choose the following toolbar button:

The existing query in your file system is updated.
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Opening a Saved XQuery

You can open a query which you have previously saved in your file system.

To open a saved XQuery

1 From the File menu, choose Open.

Or:

Press CTRL+O.

Or:

Choose the following toolbar button:

A dialog box appears asking whether you want to save the currently displayed query.

2 Choose either the Yes or No button.

When you choose the Yes button and the current query has not yet been saved in a file, the
Save As dialog box appears. See Saving an XQuery above.

The Open dialog box appears.

3 Select the file containing the desired query.

4 Choose the Open button.

The previously saved query is now shown in the application window.
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Inserting an XQuery Expression from a File

You can insert the contents of a text file at the insertion point. This is helpful, for example, if you
have received an XQuery expression from another user.

Note: Do not use this feature to insert a saved XQuery with the extension "xquery". Use the
Open command instead (see Opening a Saved XQuery).

To insert an XQuery from a file

1 In the query area, move the insertion point to the position at which you want to insert the
contents of the file.

2 From the Edit menu, choose Insert From File.

A dialog box appears.

3 Select the desired file.

4 Choose the Open button.

The content of the selected file is now inserted at the insertion point.

XQuery Modules

You can save XQuery code as a module in a database and retrieve it at a later time.

If you wish to work with modules, you must activate the module management mode. If this mode
is not active, the menu entries and buttons for saving and retrieving modules are greyed out.

To activate module management mode

■ Choose Tools > Options from the main menu, then select the Module tab in the dialog, then
mark the checkbox for Module management mode

Or:

Choose the corresponding entry under the Tools menu

Or:

Choose the appropriate button from the toolbar.
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To save a module to the database

■ Choose File > Save as Module

Or:

Choose the appropriate button from the toolbar.

To retrieve a module from the database

■ Choose File > Open Module

Or:

Choose the appropriate button from the toolbar.

When you save a module, it is stored in the doctype ino:module in the collection ino:source of your
database.

The Tamino XQuery tool cannot be used to delete XQuery modules in a database. If you wish to
delete an XQuery module in a database, use the Tamino X-Plorer instead.

If you wish to deactivate module management mode and return to query mode, proceed as follows:

To deactivate module management mode

■ Choose again the appropriate menu entry under Tools or Tools > Options, so that the tick
mark beside the menu entry is no longer displayed.

Or:

Choose the appropriate button from the toolbar. This toggles the current setting from "module
management mode" back to "query mode".
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Selecting Text

In order to cut, copy or delete text, you have to select it. To do so, use the standard techniques for
the platform on which you are currently working.

You can also select all text at once (see below). In this case, the selection depends on the area which
has previously been selected in the query window.

You can select text in the following areas:

■ in the query area (including the text boxes for server, database, and collection),
■ in the result contents of the Result pane (plain view only).

To select all text

1 Select the required area in the query window.

2 From the Edit menu, choose Select All.

Or:

Press CTRL+A.

Cutting, Copying and Pasting Text

You can cut, copy and paste any text in the query area. You can also copy from the result contents
of theResult pane (plain view only), or from the query contents at the bottom of theHistory pane.

This feature uses the Windows clipboard which may also contain information from another ap-
plication. Thus, it is also possible to copy an entire query from or to another source.

To cut the selection and transfer it to the clipboard

■ From the Edit menu, choose Cut.

Or:

Press CTRL+X.

Or:

Choose the following toolbar button:
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The selection is deleted at its original position and is copied to the clipboard.
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To copy the selection to the clipboard

■ From the Edit menu, choose Copy.

Or:

Press CTRL+C.

Or:

Choose the following toolbar button:

The selection remains at its original position and is copied to the clipboard.

To paste the content of the clipboard

1 Place the insertion point at the position at which you want to paste the cut or copied inform-
ation.

2 From the Edit menu, choose Paste.

Or:

Press CTRL+V.

Or:

Choose the following toolbar button:

The previously cut or copied text is inserted at the insertion point.
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Finding Text Occurrences in XQuery Result and Response

You can find the occurrences of a text in the plain views of XQuery result and response panes.

To find occurrences of text

1 Activate the plain view of the result or response pane.

2 Choose the Find icon in the toolbar.

Or:

Choose Find from the Edit menu.

Or:

Press CTRL+F.
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Deleting Text

You can delete any text in the query area.

To delete the selection

■ From the Edit menu, choose Clear.

Or:

Press DEL.

The selection is deleted immediately. You are not asked to confirm the deletion.

Undoing and Redoing the Previous Change

You can undo and redo your previous changes in the query area.

To undo the previous change

■ From the Edit menu, choose Undo.

Or:

Press CTRL+Z.

To redo the previous undo action

■ From the Edit menu, choose Redo.

Or:

Press CTRL+Y.
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The following topics are covered below.
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Specifying the Result Fetch Options

The result of a query is shown as different packs in the Result pane. You can specify the number
of instances that are to be shown with each pack.

The default values are defined in the Options dialog box. See Setting the Tamino XQuery Tool
Options for further information.

To specify the result fetch options

1 From the Result menu, choose Result Fetch Options.

Or:

Choose the following toolbar button:

The Specify Instance Fetch Options for Result dialog box appears.

2 Specify the following information:

Number of instances per pack
The number of instances or fragments that are to be fetched with each pack.

Maximum number of kept instances
The maximum number of instances or fragments that can be shown at the same time.

3 Optionally: if you want to reset the values that are currently defined in the dialog box to the
default values, choose the Reset to Default button.

4 Choose the OK button to use the new values.
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Browsing the Result Packs

When more instances or fragments are available than can be shown on the Result pane, you can
browse through the result packs.

You can display the next or previous pack. Or you can immediately jump to the last pack or to
the first pack.

The browse commands (see below) that are currently not available are disabled. For example,
when the entire result is provided in one pack on the Result pane, all browse commands (and the
corresponding toolbar buttons) are disabled.

To go to the first result pack

■ From the Result menu, choose First.

Or:

Choose the following toolbar button:

To go to the last result pack

■ From the Result menu, choose Last.

Or:

Choose the following toolbar button:

To go to the previous result pack

■ From the Result menu, choose Previous.

Or:

Choose the following toolbar button:

Or:
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When the navigation tree is shown, click the plus sign next to the up-arrow at the top of the
list. When using the keyboard, select the up-arrow and press ENTER.
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To go to the next result pack

■ From the Result menu, choose Next.

Or:

Choose the following toolbar button:

Or:

When the navigation tree is shown, click the plus sign next to the down-arrow at the bottom
of the list. When using the keyboard, select the down-arrow and press ENTER.

Saving the Current Result Pack

You can save the result pack that is currently shown in the navigation tree of the Result pane to
your file system.

To save the current result pack

1 From the Result menu, choose Save Displayed Result As.

The Save As dialog box appears. File name and extension are automatically provided.

2 Optionally: specify another file name and extension.

3 Select the path in which you want to save the file.

4 Choose the Save button.

Saving an Instance or Fragment

You can save the item that is currently selected in the navigation tree of the Result pane to your
file system.

To save an instance or fragment

1 In the navigation tree of the Result pane, select the item to be saved.

2 From the Result menu, choose Save Selected Item As.

The Save As dialog box appears. File name and extension are automatically provided.

Tamino X-Plorer196

Managing XQuery Results



3 Optionally: specify another file name and extension.

4 Select the path in which you want to save the instance or fragment.

5 Choose the Save button.
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This chapter covers the following topics:

Invoking the Options Dialog Box

The settings in the Options dialog box control the behavior of certain features of the Tamino
XQuery tool.

To invoke the Options dialog box

1 From the Tools menu of the XQuery Tool, choose Options.

The Options dialog box appears.

2 Select one of the following pages and set the required options as described below under the
following headings.

■ Result
■ History
■ Module

3 Choose the OK button.
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Result

The result fetch defaults on this page are the default values for the commandResult FetchOptions.
See Specifying the Result Fetch Options.

By default, identical values are defined for the two result fetch options. Each pack that you fetch
thus overwrites the previous pack. If the previous packs are to remain visible, specify a higher
value for the maximum number of kept instances.

You can set the following options:

Number of instances per pack
The number of instances or fragments that are to be fetched with each pack.

Maximum number of kept instances
The maximum number of instances or fragments that can be shown in a group of instances at
the same time.

Use wordwrap in tree view
Applies to the Result pane. When this check box is selected, lines are wrapped in tree view.
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History

You can set the following options:

Maximum number of characters of each row used
Each query entry in the History pane shows the first n characters from each query line. These
characters are concatenated to one string; each line break is indicated by three dots. Example:

declare namespace tf ... for $q in input()/Pr ... return ... $q/Address/Zip ... ↩
sort by (Zip)

When the query has 5 lines and you specify 20 in this text box, the first 20 characters of each
query line are shown and each query entry thus shows a maximum of 100 characters. However,
if 90 has been defined in the text box Maximum number of characters in each query history
entry, each query entry in this example only shows 90 characters - 10 characters from the last
query line are not used.

Maximum number of characters in each query history entry
The maximum number of characters that can be shown for a query entry in the History pane.

Maximum number of query history entries
The maximum number of query entries to be kept in the History pane.

Module

This tab allows you to activate or deactivate the module management mode. You activate or deac-
tivate the mode by checking or unchecking the box labeled Module management mode.
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DescriptionMode setting

You can store XQuery code as a module in the database or retrieve an
XQuery module from the database.

Activated (the box is checked)

In this mode, you cannot execute the current query.

You can execute the current query but you cannot store or retrieve
XQuery modules.

Deactivated (the box is unchecked)

Note: You can also activate or deactivate the module management mode directly from the
Tools menu by selecting the menu item Module Management Mode.
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VII Reference

The following topics are provided:

■ Menu Commands in the Main Application Window
■ Menu Commands in an X-Query Window
■ Menu Commands in a Tamino XQuery Window
■ Predefined External Tools
■ Supported Character Encodings
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This chapter provides reference information on each menu command that is available from the
main application window of the Tamino X-Plorer.
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File

New Collection
Creates a new collection in the selected database. See Creating a New Collection.

Open
Opens the selected schema or instance using the default tool. SeeOpening a Schema or Instance.

Update
Updates the selected schema or instance so that your modifications are stored in the database.
See Updating a Schema or Instance.

Delete
Deletes the selected collection or instance permanently from the database. See Deleting a
Collection or Instance.

Save As
Saves the selected schema or instance (which is stored in the database) in your local file system.
See Saving a Schema or Instance in Your File System.

Save Shadow As
Saves the shadow document of the selected non-XML instance (which is stored in the database)
in your local file system.

Print Preview
Shows a print preview of the selected instance in a preview window. See Printing Instances.

Print
Prints the selected instance. See Printing Instances.

Exit
Closes the main application window of the Tamino X-Plorer. Any open query window that
has been started from the Tamino X-Plorer is automatically closed. See Leaving the Tamino
X-Plorer.
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Edit

The entries in this menu are the standard operations for working with text, namely Cut, Copy,
Paste, Select, Find, Replace.

View

Content
Toggles the display of the Content pane at the top right of the main application window. See
Content Pane.

Properties
Toggles the display of the Properties pane at the bottom right of the main application window.
See Properties Pane.

Toolbar
Toggles the display of the toolbar in the main application window. See Toolbar in the sec-
tion Elements of the Main Application Window.

Refresh
Refreshes the content of a database, collection, schema or instance in the navigation tree. See
Refreshing the Display.

Database

Connect
Connects to a specific database. See Connecting to a Tamino Database.

Disconnect
Disconnects the selected database. See Disconnecting from a Database.

Remove from Tree
Removes the selected server or database from the navigation tree. See Removing a Server or
Database from the Navigation Tree.
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Schema

Define Schema
Defines a new schema in the selected collection. See Defining a Schema.

Undefine Schema
Undefines the selected schema and thus deletes it with all of its doctypes and instances from
the collection. See Undefining a Schema.

Instance Descriptor
Defines the instance descriptor (i.e. the information that is to be shown in the navigation tree)
for a specific doctype. See Specifying an Instance Descriptor.

Instance Fetch Options
Defines the number of instances that can be shown in the navigation tree at the same time and
the number of instances that are to be fetched with each pack. See Specifying the Instance Fetch
Options.

Instance

Insert Instance
Inserts a new instance in the selected collection. See Inserting a New Instance.

Filter
Defines a filter for the currently selected group of instances. This reduces the number of in-
stances shown in the navigation tree. See Filtering Instances.
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Tools

Query > XQuery
Invokes the Tamino XQuery tool. The currently selected object in navigation tree is provided
as a query expression. See Starting the Tamino XQuery Tool.

Query > X-Query
Opens an X-Query window. The currently selected object in navigation tree is provided as a
query expression. See Invoking an X-Query Window.

Customize
Defines external tools, for example, for editing the selected schema, doctype or instance. See
Customizing the Tools.

Options
Controls the behavior of certain features of the Tamino X-Plorer. See Setting the Tamino X-
Plorer and X-Query Options.

Help

Contents
Invokes the online documentation.

About Software AG Tamino X-Plorer
Displays information about the Tamino X-Plorer in a dialog box (for example, the version
number). When you choose the System Info button in this dialog box, system information (for
example, the Java Runtime Environment version which is used by the Tamino X-Plorer) and
Tamino X-Plorer information is shown.
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This chapter provides reference information on each menu command that is available from an X-
Query window of the Tamino X-Plorer.
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File

New
Invokes an empty X-Query window. See Creating a New X-Query.

Open
Opens an existing query from the file system. See Opening a Saved X-Query.

Execute Query
Executes the current query. The document structure of an XML document is shown in the
result. See Executing an X-Query.

Execute Non-XML Query
Executes the current query. The content of a non-XML instance (for example, an image) is
shown in the result. See Executing an X-Query.

Save
Saves the current query. See Saving an X-Query.

Save As
Saves the current query under a new name. See Saving an X-Query.

Close
Closes the X-Query window. See Closing an X-Query Window.

Edit

Undo
Undo the previous operation.

Redo
Redo the previous operation.

Cut
Cuts the selected text in the query area. See Cutting, Copying and Pasting Text in the sec-
tion Working with X-Queries.

Copy
Copies the selected text in the query area or Result pane (plain view only). See Cutting,
Copying and Pasting Text in the section Working with X-Queries.

Paste
Pastes cut or copied text into the query area at the position of the insertion point. See Cutting,
Copying and Pasting Text in the section Working with X-Queries.
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Clear
Deletes the selected text in the query area. See Deleting Text in the section Working with X-
Queries.

Select All
Selects all text in the query area or Result pane (plain view only). See Selecting Text in the
section Working with X-Queries.

Find
Helps to find the portion of the content (same as X-Plorer).

View

Toolbar
Toggles the display of the toolbar in the X-Query window. See Toolbar in the section Elements
of an X-Query Window.

Navigation Tree
Toggles the display of the navigation tree in the Result pane of the X-Query window. See
Result Pane in the section Elements of an X-Query Window.
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Result

First
Goes to the first result pack on the Result pane. See Browsing the Result Packs in the sec-
tion Managing X-Query Results.

Previous
Goes to the previous result pack on the Result pane. See Browsing the Result Packs in the
section Managing X-Query Results.

Next
Goes to the next result pack on the Result pane. See Browsing the Result Packs in the sec-
tion Managing X-Query Results.

Last
Goes to the last result pack on the Result pane. See Browsing the Result Packs in the sec-
tion Managing X-Query Results.

Save Selected Item As
Saves the currently selected item in the result pack to your file system. See Saving an Instance
or Fragment in the section Managing X-Query Results.

Save Displayed Result As
Saves the current result pack as a file. See Saving the Current Result Pack in the section Man-
aging X-Query Results.

Result Fetch Options
Defines the number of instances that are shown with each result pack. See Specifying the
Result Fetch Options in the section Managing X-Query Results.
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Help

Contents
Invokes the online documentation.

About Software AG Tamino X-Plorer
Displays information about the Tamino X-Plorer in a dialog box (for example, the version
number). When you choose the System Info button in this dialog box, system information (for
example, the Java Runtime Environment version which is used by the Tamino X-Plorer) and
Tamino X-Plorer information is shown.

Tools

Connect To Server
Allows you to connect to a new server and database.
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This chapter provides reference information on each menu command that is available from the
Tamino XQuery tool.
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File

New
Invokes an empty XQuery window. See Creating a New XQuery.

Open
Opens an existing query from the file system. See Opening a Saved XQuery.

Open Module
Opens an existing module from the Tamino database.

Execute XML Query
Executes the current query. The document structure of an XML document is shown in the
result. See Executing an XQuery.

Explain Query
Retrieves information about query execution for analysis and optimization. See Explaining an
XQuery.

Save
Saves the current query. See Saving an XQuery.

Save As
Saves the current query under a new name. See Saving an XQuery.

Save as module
Saves the current module in the Tamino database.

Close
Closes the Tamino XQuery window. See Leaving the Tamino XQuery Tool.

Edit

Undo
Undoes the previous change in the query area. SeeUndoing and Redoing the Previous Change
in the section Working with the Tamino XQuery Tool.

Redo
Redoes the previous undo action. See Undoing and Redoing the Previous Change in the sec-
tion Working with the Tamino XQuery Tool.

Cut
Cuts the selected text in the query area. See Cutting, Copying and Pasting Text in the sec-
tion Working with the Tamino XQuery Tool.
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Copy
Copies the selected text in the query area, in the Result pane (plain view only), or in the query
contents of the History pane. See Cutting, Copying and Pasting Text in the section Working
with the Tamino XQuery Tool.

Paste
Pastes cut or copied text into the query area at the position of the insertion point. See Cutting,
Copying and Pasting Text in the section Working with the Tamino XQuery Tool.

Insert From File
Inserts an XQuery expression from a file. See Inserting an XQuery Expression from a File.

Clear
Deletes the selected text in the query area. See Deleting Text in the section Working with the
Tamino XQuery Tool.

Select All
Selects all text in the query area or Result pane (plain view only). See Selecting Text in the
section Working with the Tamino XQuery Tool.

Find
Finds the specified text in the Plain View of the Result Pane and the Response Pane.

View

Toolbar
Toggles the display of the toolbar in the XQuery window. See Toolbar in the section Elements
of the Tamino XQuery Window.

Navigation Tree
Toggles the display of the navigation tree in the Result pane of the XQuery window. See
Result Pane in the section Elements of the Tamino XQuery Window.

Result

First
Goes to the first result pack on the Result pane. See Browsing the Result Packs in the sec-
tion Managing XQuery Results.

Previous
Goes to the previous result pack on the Result pane. See Browsing the Result Packs in the
section Managing XQuery Results.

Next
Goes to the next result pack on the Result pane. See Browsing the Result Packs in the sec-
tion Managing XQuery Results.
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Last
Goes to the last result pack on the Result pane. See Browsing the Result Packs in the sec-
tion Managing XQuery Results.

Save Selected Item As
Saves the currently selected item in the result pack to your file system. See Saving an Instance
or Fragment in the section Managing XQuery Results.

Save Displayed Result As
Saves the current result pack as a file. See Saving the Current Result Pack in the section Man-
aging XQuery Results.

Result Fetch Options
Defines the number of instances that are shown with each result pack. See Specifying the
Result Fetch Options in the section Managing XQuery Results.

Tools

Options
Controls the behavior of certain features of the Tamino XQuery tool. See Setting the Tamino
XQuery Tool Options.

Connect To Server
Allows you to connect to a new server and database.

Module Management Mode
Toggles between query mode and module management mode.

Help

Contents
Invokes the online documentation.

About Software AG Tamino XQuery
Displays information about the Tamino XQuery tool in a dialog box (for example, the version
number). When you choose the System Info button in this dialog box, system information (for
example, the Java Runtime Environment version which is used) and product-specific inform-
ation is shown.
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After installation, several external tools are predefined in the Customize dialog box. See Custom-
izing the Tools for information on this dialog box.

This chapter covers the following topics:

Predefined Values

The tables below list the predefined external tools. The command line information is automatically
available in the Customize dialog box, if the corresponding external tool has been found on your
system. If an external tool could not be found, you have to specify the command line information
yourself. If you do not need an entry for an external tool, you can safely delete it.

The entries "My Instance Editor" and "My Schema Editor" are provided for your convenience. You
can either delete them or specify any external tool you have installed.

Image files for the icons below are available in the folder "X_Plorer\icons" which is created during
installation.

Notes:

1. Invoking an external tool with the URL of an instance (using the argument $URL$) is not possible
for some external tools. This depends on the external tool.

2. Invoking an external tool with the file path to access the copy of a document in the file system
(using the argument $FILE_PATH$) is only possible for a document that does not contain a
namespace prefix in its name (a value for the attribute ino:docname that is not equal to the
pattern xxx:yyy). If you want to use an external tool to view or edit a document with a namespace
prefix, you have to save the document in the file system with a valid name and use the Open
command of the external tool.

3. When using a file path argument containing blanks, the file path must be enclosed in double
quotes (use "$FILE_PATH$" instead of $FILE_PATH$).
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Installed Tools

Command line information is added for the following tools, if the tool is already installed:

Tamino Schema Editor

SoftwareAGTaminoSchemaEditor.gifIcon

SchemasApplies to

Path to your Tamino Schema Editor (inoschema.cmd for Windows and inoschema.sh
for UNIX)

Command line

-tamino -url $URL$ -usr $USER$ -pwd $PASSWORD$Arguments

Open (File menu) or double-clickInvoke with

If you invoke the Tamino Schema Editor with the above argument string, it is
required that you specify a user ID and a password when connecting to a database

Additional information

using the Tamino X-Plorer. If authentication is not required for your database, use
the following argument string instead (i.e. omit the arguments for user ID and
password):

-tamino -url $URL$

Tamino X-Tension Builder

SoftwareAGTaminoXTensionBuilder.gifIcon

No specific type of objectApplies to

Path to your Tamino X-Tension Builder (inosxbuilder.cmd for Windows and
inosxbuilder.sh for UNIX)

Command line

NoneArguments

Corresponding command in Tools menuInvoke with
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Installed Tools which Depend on an Internet Browser

Command line information is added for the following tools, if the tool is already installed and if
an Internet browser has been found:

Tamino Interactive Interface

SoftwareAGTaminoInteractiveInterface.gifIcon

No specific type of objectApplies to

Path to your Internet browserCommand line

Path to your Tamino Interactive Interface (xql.htm)Arguments

Corresponding command in Tools menuInvoke with

Tamino Manager

SoftwareAGTaminoManager.gifIcon

No specific type of objectApplies to

Path to your Internet browserCommand line

http://localhost:9991/smh/login.htmArguments

Corresponding command in Tools menuInvoke with

Internet Browser

InternetBrowser.gifIcon

Non-XML instances (html, gif, jpg, pdf)Applies to

Path to your Internet browserCommand line

$FILE_PATH$Arguments

Open With (context menu)Invoke with

Tamino X-Plorer228

Predefined External Tools



Tools Without Command Line Information

Command line information is not added for the following tools:

My Instance Editor

MyInstanceEditor.gifIcon

InstancesApplies to

Path to your instance editorCommand line

$FILE_PATH$Arguments

Open With (context menu)Invoke with

My Schema Editor

MySchemaEditor.gifIcon

SchemasApplies to

Path to your schema editorCommand line

$FILE_PATH$Arguments

Open With (context menu)Invoke with
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Media Types for Non-XML Instances

When defining external tools for non-XML instances in the Customize dialog box, you have to
specify media types and extensions. The following table lists frequently used items.

Extension(s)Media Type

docapplication/msword

pdfapplication/pdf

xmlapplication/xml

gifimage/gif

jpg, jpegimage/jpeg

htm, htmltext/html

txttext/plain

xmltext/xml

pdfapplication/pdf

xmlapplication/xml

gifimage/gif

jpg, jpegimage/jpeg

htm, htmltext/html

txttext/plain

xmltext/xml

aiapplication/postscript

aifaudio/x-aiff

aifcaudio/x-aiff

aiffaudio/x-aiff

asctext/plain

auaudio/basic

avivideo/x-msvideo

avxvideo/x-msvideo

bcpioapplication/x-bcpio

binapplication/octet-stream

bmpimage/x-bmp

cdfapplication/x-netcdf

classapplication/octet-stream

cpioapplication/x-cpio

cptapplication/mac-compactpro

Tamino X-Plorer230

Predefined External Tools



Extension(s)Media Type

cshapplication/x-csh

csstext/css

dcrapplication/x-director

dirapplication/x-director

dlvideo/x-dl

dllapplication/octet-stream

dmsapplication/octet-stream

dviapplication/x-dvi

dxrapplication/x-director

epsapplication/postscript

etxtext/x-setext

exeapplication/octet-stream

ezapplication/andrew-inset

flcvideo/x-fli

flivideo/x-fli

gifimage/gif

gtarapplication/x-gtar

gzapplication/x-gzip

hdfapplication/x-hdf

hqxapplication/mac-binhex40

htmtext/html

htmltext/html

icex-conference/x-cooltalk

icoimage/x-ico

iefimage/ief

igesmodel/iges

igsmodel/iges

jpeimage/jpeg

jpegimage/jpeg

jpgimage/jpeg

jsapplication/x-javascript

latexapplication/x-latex

lhaapplication/octet-stream

lzhapplication/octet-stream

m3uaudio/x-mpegurl

manapplication/x-troff-man
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Extension(s)Media Type

meapplication/x-troff-me

meshmodel/mesh

midaudio/midi

midiaudio/midi

movvideo/quicktime

movievideo/x-sgi-movie

mp2audio/mpeg

mp3audio/mpeg

mpevideo/mpeg

mpegvideo/mpeg

mpgvideo/mpeg

mpgaaudio/mpeg

msapplication/x-troff-ms

mshmodel/mesh

mvvideo/x-sgi-movie

mxuvideo/vnd.mpegurl

ncapplication/x-netcdf

odaapplication/oda

pbmimage/x-portable-bitmap

pdbchemical/x-pdb

pdfapplication/pdf

pgmimage/x-portable-graymap

pgnapplication/x-chess-pgn

pngimage/png

pnmimage/x-portable-anymap

ppmimage/x-portable-pixmap

pptapplication/vnd.ms-powerpoint

psapplication/postscript

qtvideo/quicktime

raaudio/x-realaudio

ramaudio/x-pn-realaudio

rasimage/x-cmu-raster

rgbimage/x-rgb

rmaudio/x-pn-realaudio

roffapplication/x-troff

rpmaudio/x-pn-realaudio-plugin
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Extension(s)Media Type

rtftext/rtf

rtxtext/richtext

sgmtext/sgml

sgmltext/sgml

shapplication/x-sh

sharapplication/x-shar

silomodel/mesh

sitapplication/x-stuffit

skdapplication/x-koan

skmapplication/x-koan

skpapplication/x-koan

sktapplication/x-koan

sndaudio/basic

soapplication/octet-stream

splapplication/x-futuresplash

srcapplication/x-wais-source

stcapplication/vnd.sun.xml.calc.template

stdapplication/vnd.sun.xml.draw.template

stiapplication/vnd.sun.xml.impress.template

stwapplication/vnd.sun.xml.writer.template

sv4cpioapplication/x-sv4cpio

sv4crcapplication/x-sv4crc

swfapplication/x-shockwave-flash

sxcapplication/vnd.sun.xml.calc

sxdapplication/vnd.sun.xml.draw

sxgapplication/vnd.sun.xml.writer.global

sxiapplication/vnd.sun.xml.impress

sxmapplication/vnd.sun.xml.math

sxwapplication/vnd.sun.xml.writer

tapplication/x-troff

tarapplication/x-tar

tclapplication/x-tcl

texapplication/x-tex

texiapplication/x-texinfo

texinfoapplication/x-texinfo

tgzapplication/x-gzip
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Extension(s)Media Type

tifimage/tiff

tiffimage/tiff

trapplication/x-troff

tsvtext/tab-separated-values

txttext/plain

ustarapplication/x-ustar

vcdapplication/x-cdlink

vfwvideo/x-msvideo

vrmlmodel/vrml

wavaudio/x-wav

wbmpimage/vnd.wap.wbmp

wbxmlapplication/vnd.wap.wbxml

wmltext/vnd.wap.wml

wmlcapplication/vnd.wap.wmlc

wmlstext/vnd.wap.wmlscript

wmlscapplication/vnd.wap.wmlscriptc

wpapplication/wordperfect5.1

wrlmodel/vrml

xbmimage/x-xbitmap

xlsapplication/vnd.ms-excel

xmltext/xml

xpmimage/x-xpixmap

xsltext/xml

xwdimage/x-xwindowdump

xyzchemical/x-xyz

zipapplication/zip

svgtext/xml
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27 Supported Character Encodings

The Tamino X-Plorer supports the standard character encodings and their well known aliases, as
shown in the following list. Please observe that Tamino XML Server may support other encodings
than those listed here.

Well known aliasesEncoding Name

950, cp950, csBig5, ibm-1370_VSUB_VPUA, x-big5Big5

850, csPC850Multilingual, IBM850cp850

857, csIBM857cp857

860, csIBM860, IBM860cp860

861, cp-is, csIBM861, IBM861cp861

862, cp867, cspc862latinhebrewcp862

cp863, csIBM863, IBM863cp863

csIBM864cp864

865, csIBM865, IBM865cp865

866, csIBM866cp866

868, cp-ar, csIBM868, IBM868cp868

869, cp-gr, csIBM869cp869

csEUCPkdFmtJapanese, eucjis, Extended_UNIX_Code_Packed_Format_for_Japanese,
ibm-33722_VPUA, ibm-eucJP, X-EUC-JP

EUC-JP

csEUCKR, ibm-970_VPUA, ibm-eucKR, X-EUC-KREUC-KR

ibm-1392gb18030

1383, chinese, cp1383, csGB2312, csISO58GB231280, EUC-CN, gb, gb2312-1980,
GB_2312-80, ibm-1383, ibm-1383_VPUA, ibm-eucCN, iso-ir-58, X-EUC-CN

GB2312

CP936, ibm-1386_VSUB_VPUA, MS936, zh_cn, windows-936GBK

CCSID01140, CP01140, cpibm1140, ebcdic-us-37+euroIBM01140

CCSID01141, CP01141, cpibm1141, ebcdic-de-273+euroIBM01141
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Well known aliasesEncoding Name

CCSID01142, CP01142, cpibm1142, ebcdic-dk-277+euro, ebcdic-no-277+euroIBM01142

CCSID01143, CP01143, cpibm1143, ebcdic-fi-278+euro, ebcdic-se-278+euroIBM01143

CCSID01144, CP01144, cpibm1144, ebcdic-it-280+euroIBM01144

CCSID01145, CP01145, cpibm1145, ebcdic-es-284+euroIBM01145

CCSID01146, CP01146, cpibm1146, ebcdic-gb-285+euroIBM01146

CCSID01147, CP01147, cpibm1147, ebcdic-fr-297+euroIBM01147

CCSID01148, CP01148, cpibm1148, ebcdic-international-500+euroIBM01148

CCSID01149, CP01149, cpibm1149, ebcdic-is-871+euroIBM01149

cpibm37, ebcdic-cp-us, ebcdic-cp-ca, ebcdic-cp-wt, ebcdic-cp-nl, cp37, cp037, 037IBM037

CP1026, csIBM1026, Ibm-1026_STDIBM1026

273, CP273, cpibm273, csIBM273, ebcdic-deIBM273

277, csIBM277, cpibm277, EBCDIC-CP-DK, EBCDIC-CP-NO, ebcdic-dkIBM277

278, cp278, cpibm278, csIBM278, ebcdic-cp-fi, ebcdic-cp-se, ebcdic-svIBM278

280, CP280, cpibm280, csIBM280, ebcdic-cp-itIBM280

284, CP284, cpibm284, csIBM284, ebcdic-cp-esIBM284

285, CP285, cpibm285, csIBM285, ebcdic-cp-gb, ebcdic-gbIBM285

cp290, csIBM290, EBCDIC-JP-kanaIBM290

297, cp297, cpibm297, csIBM297, ebcdic-cp-frIBM297

IBM367

420, cp420, csIBM420, ebcdic-cp-ar1IBM420

424, cp424, csIBM424, ebcdic-cp-heIBM424

500, CP500, cpibm500, csIBM500, ebcdic-cp-be, ebcdic-cp-chIBM500

IBM852

IBM855

IBM857

IBM862

IBM864

IBM869

CP870, csIBM870, ibm-870, ibm-870_STD, ebcdic-cp-roece, ebcdic-cp-yuIBM870

871, CP871, cpibm871, csIBM871, ebcdic-cp-is, ebcdic-isIBM871

CP918, csIBM918, , ebcdic-cp-ar2, ibm-918_STD, ibm-918_VPUAIBM918

ISO-2022-CN-EXT

ISO-2022-CN

csISO2022JPISO-2022-JP

csISO2022KRISO-2022-KR

iso-8859-15
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Well known aliasesEncoding Name

8859-1, cp819, csISOLatin1, IBM819, ISO_8859-1:1987, iso-ir-100, l1, latin1ISO-8859-1

8859-2, 912, cp912, csISOLatin2, ISO_8859-2:1987, iso-ir-101, l2, latin2iso-8859-2

8859-3, 913, cp913, csISOLatin3, iso-ir-109, l3, latin3iso-8859-3

8859-4, 914, cp914, csISOLatin4, ISO_8859-4:1988, iso-ir-110, l4, latin4iso-8859-4

8859-5, 915, cp915, csISOLatinCyrillic, cyrillic, ISO_8859-5:1988, iso-ir-144iso-8859-5

1089, 8859-6, arabic, asmo-708, cp1089, csISOLatinArabic, ecma-114, ISO_8859-6:1987,
iso-ir-127

iso-8859-6

813, 8859-7, cp813, csISOLatinGreek, ecma-118, elot_928, greek, greek8, ISO_8859-7:1987,
iso-ir-126

iso-8859-7

916, cp916, csISOLatinHebrew, Hebrew, 8859-8, ISO_8859-8:1988, iso-ir-138iso-8859-8

8859-9, 920, cp920,latin5, csISOLatin5, ISO_8859-8:1989, iso-ir-148, l5iso-8859-9

cp878, cskoi8r, koi8KOI8-R

943, cp943, cp932, csShiftJIS, csWindows31J, MS_Kanji, pck, sjis, windows-31j, x-sjisShift_JIS

874, cp874, cp9066, ms874, windows-874TIS-620

ANSI_X3.4-1968, ASCII, ANSI_X3.4-1986, cp367, csASCII, ISO_646.irv:1983,
ISO_646.irv:1991, ISO646-US, iso-ir-6, us

US-ASCII

cp1201, UTF16_BigEndian, x-utf-16beUTF-16BE

cp1200, UTF16_LittleEndian, x-utf-16leUTF-16LE

cp1208, cp65001UTF-8

csUnicode, ISO-10646-UCS-2, ucs-2UTF-16

cp1250windows-1250

cp1251windows-1251

cp1252windows-1252

cp1253windows-1253

cp1254windows-1254

cp1255windows-1255

cp1256windows-1256

cp1257windows-1257

cp1258windows-1258
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A
add

collection, 65
external tool, 99
schema to a database, 16
XML instance to a database, 16

auto-complete, 177

B
browse

result pack, 194

C
change

schema, 16
XML instance, 16

character encoding
Tamino X-Plorer, 235

close
X-Query, 123

collection
add, 65
create, 65
delete, 74
display information, 49
ino:etc, 51
modify properties, 68
navigate, 30
WebDAV-enabled, 50

connect
to database, 14, 42
to server, 42

context menu
invoke in Tamino X-Plorer, 32

copy
X-Query text, 141
XQuery text, 186

create
collection, 65
filter for XML instances, 15
X-Query, 129, 136
XQuery, 176

cursoring, 59
customize

external tool, 99

cut
X-Query text, 141
XQuery text, 186

D
database

browse through, 14
connect to, 14, 42
disconnect, 45
explore, 14

database version
display, 45

define
external tool, 99
filter for XML instance, 15
schema, 79

delete
collection, 74
database entry from navigation tree, 46
instance, 74
schema, 81
server entry from navigation tree, 46
X-Query text, 142
XQuery text, 190

disconnect
from database, 45
from server, 45

display
content of XML object, 33
database version, 45
doctype, 52
information about collection, 49
information about XML object, 36
non-XML instance, 58
schema, 52
XML instance, 15, 54

doctype
display information about, 53

E
execute

non-XML query, 137
X-Query, 137
XQuery, 179

explain
XQuery, 178

explore
database, 14
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external tool
customize, 99
file location, 111
installed

Internet Browser, 228
Tamino Interactive Interface, 228
Tamino Manager, 228
Tamino Schema Editor, 227
Tamino X-Tension Builder, 227

open schema, 70
predefine, 225
update schema or instance, 71

F
filter

instance, 96

H
help

for Tamino X-Plorer, 23

I
identify

XML instance, 15
insert

instance, 89
non-XML instance, 92
schema in a database, 16
XML instance, 16, 91
XQuery, 184

installation
Tamino X-Plorer, 9

instance
delete, 74
filter, 96
insert, 89
number per pack, 109
open, 70
save, 74, 148, 196
update, 71

instance descriptor
specify, 81

instance fetch option, 84
default values, 109

instance per pack
maximum number, 145
specify number, 145

invoke
context menu in Tamino X-Plorer, 32
Tamino X-Plorer, 22
X-Query, 122
XQuery Tool options, 200

J
Java Virtual Machine, 59

L
leave

Tamino X-Plorer, 23
XQuery Tool, 153

M
manage

object type, 63
X-Query result, 143

media type, 36, 93
non-XML, 230

modify
schema, 16
XML instance, 16

N
navigate

in collections, 30
in Tamino X-Plorer, 30, 38
in X-Query result pane, 130
in XQuery Tool, 164

non-XML instance
display information about, 58
insert, 92

O
object type

manage, 63
open

instance, 70
schema, 70
X-Query, 140
XQuery, 183

open location, 16
overview

Tamino X-Plorer, 3

P
pack of instance, 15, 59

limit number of instances, 84
maximum number, 109
number per pack, 109

paste
X-Query text, 141
XQuery text, 186

plain view, 36
predefine

external tool, 225

Q
query

database, 17
query history, 202

R
redo

change in XQuery text, 190
refresh

display of navigation tree, 61
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resize
dialog box, 38

result
XQuery, 164

result fetch option
specify, 145, 193
XQuery, 164

result pack
browse, 146
save, 148

S
save

instance, 74, 148, 196
result pack, 196
schema, 74
X-Query, 139
XQuery, 181

schema
add to a database, 16
define, 79
delete, 81
display information about, 52
modify, 16
open, 70
save, 74
undefine, 81
update, 71

schema type, 36
search

database, 17
select

XQuery text, 186
server

connect to, 14, 42
disconnect from, 45

show
collection, 49
content of XML object, 33
database version, 45
doctype, 52
information about XML object, 36
non-XML instance, 58
schema, 52
XML instance, 15, 54

sorting sequence, 81
specify

instance descriptor, 81
result fetch option, 145, 193
X-Query, 136
XQuery, 175

start
help for Tamino X-Plorer, 23
Tamino X-Plorer, 14, 22
XQuery Tool, 153

stop
Tamino X-Plorer, 23

system collection, 109

T
Tamino X-Plorer

menu commands, 207

start, 22
stop, 23
user interface, 25

template, 177
toolbar

Tamino X-Plorer, 29
XQuery Tool, 161

tools
Tamino X-Plorer, 29

tree view, 36

U
undefine

schema, 81
undo

change in XQuery text, 190
update

instance, 71
schema, 71

user interface
Tamino X-Plorer, 25

W
WebDAV

checkin instance, 114
checkout instance, 114
display instance, 113
version history, 115

wordwrap in tree view, 109

X
X-Query

close, 123
create, 136
execute, 137
invoke, 122
manage result, 143
menus, 127
open, 140
options, 112
query area, 129
result, 130
result content, 132
save, 139
specify, 136
toolbar, 127
window, 125

X-Query Tool
menu commands, 213

XML instance
add to a database, 16
define a filter, 15
display, 15, 36
display information about, 54
identify, 15
insert, 91
modify, 16
plain view, 36
show content, 33
tree view, 36

XQuery
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create, 176
execute, 179
explain, 178
insert, 184
open, 183
save, 181
specify, 175

XQuery Tool
history options, 202
history pane, 170
leave, 153
menu commands, 219
menus, 160
navigation tree, 164
options, 199
query area, 162
query contents, 171
query list, 171
response pane, 169
result options, 201
result pane, 164, 166
start, 153
toolbar, 161
window elements, 157
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