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Software AG Designer enables you to create and maintain a wide number of applications, services,
tasks, and other components to implement and execute your solutions in the webMethods product
suite. When you install a Designer feature, the online help for that feature appears in the Designer
Guides node of the Eclipse Help table of contents. Expand this node to view the available help
sets.
If a feature is not installed, there will be no help set available for it. However, you can view PDF
versions of all Designer features on the Software AG Documentation website.

Document Conventions
Convention

Description

Bold

Identifies elements on a screen.

Narrowfont

Identifies service names and locations in the format folder.subfolder.service, APIs,
Java classes, methods, properties.

Italic

Identifies:
Variables for which you must supply values specific to your own situation or
environment.
New terms the first time they occur in the text.
References to other documentation sources.

Monospace font

Identifies:
Text you must type in.
Messages displayed by the system.
Program code.

{}

Indicates a set of choices from which you must choose one. Type only the
information inside the curly braces. Do not type the { } symbols.

|

Separates two mutually exclusive choices in a syntax line. Type one of these
choices. Do not type the | symbol.

[]

Indicates one or more options. Type only the information inside the square
brackets. Do not type the [ ] symbols.

...

Indicates that you can type multiple options of the same type. Type only the
information. Do not type the ellipsis (...).

Online Information and Support
Software AG Documentation Website
You can find documentation on the Software AG Documentation website at http://
documentation.softwareag.com.
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Software AG Empower Product Support Website
If you do not yet have an account for Empower, send an email to empower@softwareag.com with
your name, company, and company email address and request an account.
Once you have an account, you can open Support Incidents online via the eService section of
Empower at https://empower.softwareag.com/.
You can find product information on the Software AG Empower Product Support website at
https://empower.softwareag.com.
To submit feature/enhancement requests, get information about product availability, and download
products, go to Products.
To get information about fixes and to read early warnings, technical papers, and knowledge base
articles, go to the Knowledge Center.
If you have any questions, you can find a local or toll-free number for your country in our Global
Support Contact Directory at https://empower.softwareag.com/public_directory.aspx and give us
a call.

Software AG TECHcommunity
You can find documentation and other technical information on the Software AG TECHcommunity
website at http://techcommunity.softwareag.com. You can:
Access product documentation, if you have TECHcommunity credentials. If you do not, you
will need to register and specify "Documentation" as an area of interest.
Access articles, code samples, demos, and tutorials.
Use the online discussion forums, moderated by Software AG professionals, to ask questions,
discuss best practices, and learn how other customers are using Software AG technology.
Link to external websites that discuss open standards and web technology.

Data Protection
Software AG products provide functionality with respect to processing of personal data according
to the EU General Data Protection Regulation (GDPR). Where applicable, appropriate steps are
documented in the respective administration documentation.
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The following topics provide information on how to work with various aspects of your Software
AG Designer installation:
“Managing Designer User Configuration” on page 10
“Changing the JRE or JDK Used by Designer ” on page 11
“Monitoring and Modifying Memory Usage” on page 13
“Verifying Java Byte Code” on page 14
“Java Code Cache” on page 14
“Finding Installed Products, Versions, and Fixes” on page 14
“Using Designer with Software AG Runtime ” on page 15
“Enabling Designer Console Output on Windows” on page 17
“Configuring SSL Connections in Designer ” on page 19

Managing Designer User Configuration
Software AG Designer is, by default, configured to support a single user with full read/write
permission to the Eclipse installation area.
The following three locations in the Eclipse installation are important and must be considered
when you configure Software AG Designer.
The install area, which is the location where the Eclipse Platform is installed. The default location
is Software AG_directory \Designer\eclipse.
The configuration area, which is the location where Eclipse stores essential runtime metadata
and cached data in general. The default location is Software AG_directory
\Designer\eclipse\configuration.
The instance area, which is also known as the workspace. The default location is
<user-home-dir>\workspace98.
These default locations might vary if,
The user does not have full read/write permission to the configuration area.
The Designer installation is shared by multiple users.
During installation, Designer/Eclipse creates a configuration directory within the Eclipse installation.
Each time Designer/Eclipse starts, it verifies that the configuration directory is writable. If it is not
writable, by default, Designer/Eclipse creates a private configuration folder in the user home
directory. The size of the configuration area varies depending on the features installed. The default
location for a private configuration area is:
<user-home-dir>/.eclipse/<product-id>_<product-version>_<hashcode>_<os-ws-arch>/configuration

The user home directory is determined by the user.home Java system property. The product id
and version are obtained from the product marker file .eclipseproduct under the Eclipse install.
10
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A non-default configuration area can be defined by setting the osgi.configuration.area system
property. This property can be set by the end user when starting Designer from a shortcut or, from
the command line. It is convenient to set the property either in the launcher.ini file or in the
config.ini file at the base configuration location.
In most cases, there is no need to change the default behavior. However, after installing Software
AG Designer in a Windows environment, you may find that attempts to start Designer from a
shortcut or from the command line result in an "access denied" error. In these cases, Eclipse has
failed to determine that some files in the configuration area are not writable.
To resolve these issues, use any one of the following approaches:
Define a non-default configuration area by setting the osgi.configuration.area system property.
This is the preferred approach.
If you have administrator privileges, change the access rights to the configuration area.
If you have administrator privileges, when starting Designer from a shortcut, right-click the
shortcut and select Run as administrator.
If you want the Designer installation to be shared by multiple users, ensure that none of the users
have write privileges to the shared configuration area. In this case, set the osgi.configuration.area
system property and restrict access to the configuration area.
For example, define the configuration area in the config.ini file by adding the system property as
follows, osgi.configuration.area=$user.home$/.eclipse/Designer_12345. Define the configuration
area in the shortcut or the command line, by adding the following Java option: -vmargs
-Dosgi.configuration.area=$user.home$/.eclipse/Designer_12345

Note:
When Designer/Eclipse starts, it checks the shared configuration area for changes. Migration
Wizard prompts you to reapply the changes made to the private configuration area.
For detailed information about the Eclipse configuration directory and runtime options, refer to
the Eclipse documentation at:
http://help.eclipse.org/luna/topic/org.eclipse.platform.doc.isv/reference/misc/multi_user_
installs.html
http://help.eclipse.org/luna/topic/org.eclipse.platform.doc.isv/reference/misc/runtimeoptions.html

Changing the JRE or JDK Used by Designer
By default, Software AG Designer uses the JDK that the Software AG Installer installs as described
in the PDF publication Installing Software AG Products. You can modify the Designer configuration
to use a different JRE or JDK. If you want to switch back to the JDK installed by the Software AG
Installer, it is located in the Software AG_directory \jvm directory.
Important:
If you switch to a non-default JRE or JDK, apply maintenance updates from the appropriate
vendor on a regular basis, as you would for any JREs and JDKs you install yourself.
Working with Software AG Designer 10.7
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Note:
Software AG tests products only with the JDKs installed by the Software AG Installer. If you
change to a different JDK or JRE and encounter problems, Software AG may require you to
reproduce the issues with the JDK that is installed by the Software AG Installer.
To change the Designer JRE or JDK
1. Locate the following file in your Designer installation:
Software AG_directory \Designer\eclipse\eclipse.ini
2. Open the file in a text editor.
3. Locate the -vm parameter and modify it to contain the directory path to the JRE or JDK you
want to use.
4. Save the file and restart Designer.

Configuring the Secure Storage
Eclipse uses PBEWithSHA1AndDES as the default algorithm for encrypting the information in
the secure storage. This algorithm is considered to be vulnerable.
The secure storage is located in the user's home directory and applies to all Eclipse installations.
If you have used the secure storage with Eclipse or Software AG Designer, the secure storage file
is configured to use the default algorithm.
Software AG Designer is enhanced with PBEWithSHA1AndDESede as the preselected algorithm.
However, this algorithm applies only to the new storage files created with
PBEWithSHA1AndDESede algorithm.
To enable the PBEWithSHA1AndDESede algorithm, you must delete the old secure storage file.
You can find the secure storage settings at Window >Preferences > General > Security > Secure
Storage > Contents. The Contents tab displays the location of the secure storage file. Save a copy
of the old secure storage file. Delete the old secure storage settings and restart Software AG
Designer. The secure storage file is created when the first credentials are stored.

Secure Storage Runtime Options
Changing the location of secure storage
By default, secure storage is located in your home directory. For example, on Windows the default
location of the secure storage file resolves to C:\Users\<user_name>\.eclipse\
org.eclipse.equinox.security. Software AG Designer selects this location to allow multiple
Eclipse-based applications to share the same secure storage.
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If you need to modify the location of the default secure storage, you can use the "-eclipse.keyring
<file_path>" runtime option. The <file_path> is a path to the file which is used to persist the secure
storage data.
For more information about the secure storage, see Workbench User Guide > Reference > Secure
Storage in Software AG Designer help.

Password file
The password provider mechanism can be bypassed if you specify the "-eclipse.password
<file_path>" runtime option. In this case, the contents of the file you specified as the argument
will be used as a master password. While this option is valuable in some circumstances (such as
headless applications), the protection of the password file becomes a consideration. The password
file can be protected by the operating system access rights and/or by placing it on removable
storage, such as a USB key.

Monitoring and Modifying Memory Usage
As you work with Software AG Designer, background processes are constantly writing to system
memory. Some processes can consume a considerable amount of memory while they are running.
This can cause Designer to slow down or become unresponsive if its memory requirements
approach or exceed the configured maximum.
Eclipse provides a heap status monitor function, and by default, this feature is enabled in Designer.
The monitor appears in the status bar at the lower right of Designer:

The display shows the amount of memory in use and the total amount available. If the display
frequently shows values near the configured maximum, consider increasing the maximum. For
more information, see “Adjusting the Designer Memory Settings” on page 13.
If the display has been disabled, you can re-enable it by clicking Window > Preferences, selecting
the General entry, and selecting the Show heap status option.
For more information about memory allocation in Eclipse, see the topic “Running Eclipse” in the
Workbench User Guide online help (Workbench User Guide > Tasks > Running Eclipse).

Adjusting the Designer Memory Settings
To adjust the Designer memory settings
1. Locate the following file in your Designer installation:
Software AG_directory \Designer\eclipse\eclipse.ini
2. Open the file in a text editor.
Working with Software AG Designer 10.7
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3. Locate the -Xmx parameter and modify it as required:
For systems with 1 GB or less of memory, set -Xmx=512m
For systems with more than 1 GB of memory, set -Xmx=1024m
4. Ensure that the value for -Xms is less than the value for -Xmx.
5. Save the file and restart Designer.

Verifying Java Byte Code
The Java class bytecode verification process helps you troubleshoot issues in code compiled by
external compilers. This verification process is enabled by default. You can disable the Java class
bytecode verification process in Designer by adding the parameter, -Xverify:none at the end of
the Software AG_directory\Designer\eclipse\eclipse.ini file.
Important:
Disabling Java bytecode verification might decrease the Designer launch time by up to 40%.
However, bytecode verification protects your application against malicious code, and identifies
defects in code generated by external Java and non-Java frameworks. Disabling Java class
bytecode verification process is recommended ONLY if you are using Designer in a stable,
non-production environment.

Java Code Cache
Java uses its in-memory code cache to store native code generated for compiled methods. The
default maximum size of this code cache is 240 MB, which is normally more than sufficient for
Designer. The Java Runtime Environment indicates an overflow in the code cache with the following
console message: CodeCache is full. Compiler has been disabled. A code cache overflow might
result in serious performance degradation because the Java code is not compiled to native code.
You can increase the maximum size of the cache code by adding the option,
-XX:ReservedCodeCacheSize= <newsize> at the end of the Software
AG_directory\Designer\eclipse\eclipse.ini file. For additional details, see the Java SE documentation
available on the Oracle website.

Finding Installed Products, Versions, and Fixes
You can find the following information about the Software AG products installed with Software
AG Designer:
Which products are installed
The version and fix level of a product
You can also view and copy information about the Software AG features installed including feature
name, version, and ID.
For more information, see the following topics:
14
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“Identifying Installed Products, Versions, and Fixes” on page 15
“Viewing and Copying Information About Software AG Features” on page 15
For technical details about Eclipse features, see the Features topic in the Workbench User Guide
online help (Workbench User Guide > Concepts > Features).

Identifying Installed Products, Versions, and Fixes
You use the About Software AG Designer dialog box to find information about installed
Software AG products, versions, and fixes.
In addition, the Welcome page provides a short description of each installed product as well as
links to the Eclipse perspective associated with the product and the product documentation. The
Welcome page opens the first time you start Designer. To view the Welcome page if it is closed,
click Help > Welcome.
To find information about installed products, their versions, and applied fixes:
1. In Designer: Help > About Software AG Designer.
2. The Software AG tab displays all installed Software AG products, their versions, and the latest
fix levels, if a fix has been applied.
3. To view details about the Eclipse features and plug-ins associated with a product, click the
product icon.

Viewing and Copying Information About Software AG Features
To view and copy information about the features provided by Software AG:
1. In Designer, click either of the following:
Window > Preferences > Software AG.
Help > About Software AG Designer > Software AG Preferences.
The Installed Software AG Features table displays all installed features, their versions, and
IDs.
2. Select the feature or features you want to copy. Right-click the features and click Copy.

Using Designer with Software AG Runtime
You can install an instance of Software AG Runtime in your Software AG product directory with
the Software AG Installer. This provides you with a convenient and integrated web server for
testing the web projects you develop in Designer.
Working with Software AG Designer 10.7
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You can manage the Software AG Runtime instance using Designer Servers view. In this view,
you can connect to an existing Software AG Runtime instance, check the server status, start it, stop
it, and publish your projects to it.
You can determine the version of the installed Software AG Runtime by referring to the PDF
publication System Requirements for Software AG Products for your version of Designer. This section
explains how to add the Software AG Runtime instance and how to display it in Designer Servers
view.

Defining a Software AG Runtime Entry in the Servers View
You can define a Software AG Runtime entry in the Servers view. When you select Software AG
Runtime in the Servers view, the toolbar buttons and menu commands for starting, debugging,
and stopping the server are enabled. For more information about starting, debugging, and stopping
Software AG Runtime, see the PDF publication Software AG Infrastructure Administrator's Guide.
Note:
With Software AG Runtime, you can deploy only web projects that contain servlets or JSPs.
Before you begin, make sure that you have installed Software AG Runtime and Software AG
Platform Manager using the Software AG Installer.
To define a Software AG Runtime instance
1. In the Servers view, right-click and click New > Server.
2. In the Select the server type list, expand the Software AG folder, and select Software AG
Runtime.
3. Accept the default value of localhost for Server’s host name and specify a name for the server
in the Server name box.
4. Click Next.
5. Specify the Software AG_directory installation directory or type the URL for the Platform Manager
to select an installed instance of Software AG Runtime. Do one of the following:
In the Installation Directory box, type or browse to the Software AG_directory , for example,
C:\SoftwareAG.
In the Platform Manager URL box, type the URL of the Platform Manager.
6. Enter your user name and password to connect to the Platform Manager. Click List Servers.
7. In the Servers list, select one of the listed instances of Software AG Runtime.
8. Click Finish.
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Adding the Software AG Runtime Environment
Using the Preferences page, you can add Software AG Runtime environment definitions.
Before you begin, make sure that you have installed Software AG Runtime and Software AG
Platform Manager. If Software AG Runtime is not installed, you will not have it as an entry in the
Servers list as described later. Use the Software AG Installer to install the server in your
Software AG installation.
To add a Software AG Runtime environment
1. In Designer, click Window > Preferences.
2. In the Preferences window, expand the Server node and select Runtime Environments.
3. Click Add.
4. In the Select the type of runtime environment list, expand the Software AG folder, select
Software AG Runtime and click Next.
5. Specify the Software AG_directory installation directory or type the URL for the Platform Manager
to select an installed instance of Software AG Runtime. Do one of the following:
In the Installation Directory box, type or browse to the Software AG_directory , for example,
C:\SoftwareAG.
In the Platform Manager URL box, type the URL of the Platform Manager.
6. Enter your user name and password to connect to the Platform Manager. Click List Servers.
7. In the Servers list, select one of the listed instances of Software AG Runtime.
8. Click Finish.

Enabling Designer Console Output on Windows
At times, users of Software AG Designer might want to view Designer output messages in a
Windows Command Prompt session. This mechanism is disabled by default. If you want to use
a Windows Command Prompt session to monitor Designer activity and error messages, you can
implement any of the following solutions:
Modify Designer configuration. This will enable output to a Command Prompt session
whenever you start Designer.
Start Designer from the command line with extra parameters. In this case, output is enabled
only during the current session.
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Modify Designer shortcut. This will enable output only during the session you start from the
shortcut.
For additional information about configuring the Designer startup, refer to the Eclipse
documentation at:
http://help.eclipse.org/luna/topic/org.eclipse.platform.doc.isv/reference/misc/runtime-options.html

Modifying the Designer Configuration to Enable Console Output
You can modify the Designer configuration to enable output of Designer activity and error messages
to a Command Prompt session on Windows. After you modify the Designer configuration, the
Designer output will be available every time you start Designer.
To modify the Designer configuration to enable console output
1. Locate the following file in your Designer installation:
Software AG_directory \Designer\eclipse\eclipse.ini.
2. Open the file in a text editor.
3. Locate the -vm parameter and do the following:
a. Type -consoleLog in a new line above the -vm parameter.
b. Replace javaw.exe with java.exe at the end of the -vm parameter definition.
4. Save the file and start Designer.

Adding Parameters to the Command Line to Enable Designer
Console Output
You can add parameters when starting Designer from the command line to enable output of
Designer activity and error messages to a Command Prompt session on Windows. In this case,
output is enabled only during the current session.
To enable console output when starting Designer from a Command Prompt window
1. Open a Command Prompt window in this directory:
Software AG_directory \Designer\eclipse
2. Type the following command to start Designer with the console output enabled:
eclipse –consoleLog –vm <path to java.exe>
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Modifying a Designer Shortcut to Enable Console Output
You can add parameters to a Windows shortcut to enable output of Designer activity and error
messages to a Command Prompt session on Windows when you start Designer from the shortcut.
In this case, output is enabled only during the session started from the modified shortcut.
To modify a Designer shortcut to enable console output
1. Locate the Designer shortcut you want to modify, for example:
Start > All Programs > Software AG_directory > Tools > Software AG Designer 9.8
2. Copy the shortcut and paste the copied shortcut onto your desktop.
3. Right-click the copied shortcut and click Properties > Shortcut.
4. In the Target field, add the following parameters to the end of the Target definition:
–consoleLog –vm <path to java.exe>

5. Click OK to save the new Target definition.
6. Rename the copied shortcut as desired.

Configuring SSL Connections in Designer
Use the following procedure to configure a Secure Sockets Layer (SSL) connection in Software AG
Designer.
For more information about Java SSL configurations, see the JSSE Reference Guide in the Java SE
documentation.
To configure an SSL connection
1. Locate the following file in your Designer installation:
Software AG_directory \Designer\eclipse\configuration\config.ini
2. Open the file in a text editor.
3. Add the following lines to the file:
javax.net.ssl.trustStore=truststore

file path

where truststore file path is the path to the server truststore in your file system. For example:
javax.net.ssl.trustStore=C\:\\keystore\\localhost.jks

Working with Software AG Designer 10.7

19

1 Tips for Working with Software AG Designer

Note:
Be sure to use the correct separators when specifying the path to the truststore file. For
example: C\:\\
javax.net.ssl.trustStoreType=truststore

file type

where truststore file type is the type of truststore file that the server supports. For example:
javax.net.ssl.trustStoreType=JKS

4. Save the file and restart Designer.

Enabling Automatic Updates
The automatic updates are disabled by default, as Designer might not work on the newer Eclipse
updates and also the updates are delivered through Update Manager and not through update
sites.
To enable automatic updates
1. In Designer, click Window > Preferences.
2. In the Preferences window, click Install/Update > Automatic Updates.
3. In the Automatic Updates section, select Automatically find new updates and notify me.
4. Select the appropriate options in the Update schedule, Download options, and When updates
are found sections.
5. Click Apply.
6. Click OK.

Enabling Eclipse Update Sites
The Eclipse Update sites are disabled by default, as Designer might not work on the newer Eclipse
updates.
To enable Eclipse update sites
1. In Designer, click Window > Preferences.
2. In the Preferences window, click Install/Update > Available Software Sites.
3. In the Available Software Sites panel, select all the applications from Eclipse sites.
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4. Click OK.

Enabling Error Reporting Notifications
The error reporting notifications as provided by Eclipse 4.5 are disabled by default. If you encounter
issues with Designer, see "Online Information" section or contact Software AG support.
To enable error reporting notifications
1. In Designer, click Window > Preferences.
2. In the Preferences window, click General > Error Reporting.
3. In the Error Reporting section, click Notifications.
4. In the Notifications section, select Enable notifications.
5. Click Apply.
6. Click OK.

Enabling Preference Recorder
The Preference Recorder is a new feature in Eclipse 4.5. This feature is disabled by default.
To enable Preference recorder
1. In Designer, click Window > Preferences.
2. In the Preferences window, click Oomph > Preference Recorder.
3. In the Preference Recorder, select Enabled.
4. Click Apply.
5. Click OK.
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