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This document contains information about using the Web Services Stack plug-in available within
Software AG Designer.

Document Conventions

DescriptionConvention

Identifies elements on a screen.Bold

Identifies service names and locations in the format folder.subfolder.service, APIs,
Java classes, methods, properties.

Narrowfont

Identifies:Italic

Variables for which you must supply values specific to your own situation or
environment.
New terms the first time they occur in the text.
References to other documentation sources.

Identifies:Monospace font

Text you must type in.
Messages displayed by the system.
Program code.

Indicates a set of choices from which you must choose one. Type only the
information inside the curly braces. Do not type the { } symbols.

{ }

Separates two mutually exclusive choices in a syntax line. Type one of these
choices. Do not type the | symbol.

|

Indicates one or more options. Type only the information inside the square
brackets. Do not type the [ ] symbols.

[ ]

Indicates that you can type multiple options of the same type. Type only the
information. Do not type the ellipsis (...).

...

Online Information and Support

Software AG Documentation Website

You can find documentation on the Software AG Documentation website at https://
documentation.softwareag.com.

Software AG Empower Product Support Website

If you do not yet have an account for Empower, send an email to empower@softwareag.comwith
your name, company, and company email address and request an account.
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Once you have an account, you can open Support Incidents online via the eService section of
Empower at https://empower.softwareag.com/.

You can find product information on the Software AG Empower Product Support website at
https://empower.softwareag.com.

To submit feature/enhancement requests, get information about product availability, and download
products, go to Products.

To get information about fixes and to read early warnings, technical papers, and knowledge base
articles, go to the Knowledge Center.

If you have any questions, you can find a local or toll-free number for your country in our Global
Support Contact Directory at https://empower.softwareag.com/public_directory.aspx and give us
a call.

Software AG Tech Community

You can find documentation and other technical information on the SoftwareAGTechCommunity
website at https://techcommunity.softwareag.com. You can:

Access product documentation, if you have Tech Community credentials. If you do not, you
will need to register and specify "Documentation" as an area of interest.

Access articles, code samples, demos, and tutorials.

Use the online discussion forums, moderated by Software AG professionals, to ask questions,
discuss best practices, and learn how other customers are using Software AG technology.

Link to external websites that discuss open standards and web technology.

Data Protection

SoftwareAGproducts provide functionalitywith respect to processing of personal data according
to the EU General Data Protection Regulation (GDPR). Where applicable, appropriate steps are
documented in the respective administration documentation.
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About the Web Services Stack Designer Plug-in

The Web Services Stack Designer plug-in enables you to create, configure, deploy, and publish
Web services. You can expose Web services created with pure Java classes to implement business
logic, or createWeb service packages containingmultiple Java classes essential for the completion
of a particular business case.

You create Web services out of Java classes and WSDL files contained in your Java projects in
Designer. The Java classes and WSDL files are added to Web service packages together with
supplementary source and meta-information files.

When you createWeb services, you can design thembyproviding individual configuration settings.
You can modify their behavior at run time and facilitate the correct invocation of the functionality
that they expose. You can configure theWeb services by providing advanced design settings, such
as Web service addressing, security, and transactional behavior.

The Web Services Stack Designer plug-in enables you to deploy your Web services and expose
their functionality for a broader usage. Depending on your environment, you can deploy them to
the default Web Services Stack servlet container and run them locally, or you can deploy them to
a fully functional application server and expose their functionality to other Web service clients.

You can use the Web Services Stack Designer plug-in to publish Web services to CentraSite. To
do this, you must have CentraSite Registry Repository and the CentraSite plug-in installed on
your system.

Installing the Web Services Stack Plug-in on an Independent
Eclipse Installation

By default, the Web Services Stack plug-in is installed with Software AG Designer. However, you
can also use your own independent Eclipse installation with the Web Services Stack plug-in.

As a prerequisite, you must use Software AG Installer to install the Web Services Stack plug-in.
The installed plug-in package is located in the Software AG_directory /Designer/updates directory.
You must then update your independent Eclipse installation with the respective Web Services
Stack package.

To install the Web Services Stack plug-in on an independent Eclipse installation

1. Start Eclipse.

2. Navigate to Help >Install New Software.

The Available Software screen appears.

3. For the com.softwareag.common.zip archive, complete the following steps:

a. Click Add.
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b. Click Archive.

c. Browse to the Software AG_directory /Designer/updates directory and open the archive.

d. Click OK.

e. Select the components you want to install and click Next.

4. For the eclipse.wss.<version_number>.UpdatePackage.0000.zip archive, complete the following
steps:

a. Click Add.

b. Click Archive.

c. Browse to the Software AG_directory /Designer/updates directory and open the archive.

d. Click OK.

e. Select the components you want to install and click Next.

Note:
The version number of the particular package depends on the version of the current
installation. For example, if you want to update a Web Services Stack 9.0 SP1 installation,
the version number of the update package is 901, and the file name is
eclipse.wss.901.UpdatePackage.0000.zip.

5. Follow the instructions.

Verifying the Installed Web Services Stack Application

You can verify that your Web Services Stack application is installed.

To verify the Web Services Stack installation

1. In Designer, open the Project Explorer view.

2. Right-click a Java project and select Web Services Stack > View Web Services Stack.

TheWeb Services Stack Locationswindowappears, displaying the configuration information
provided in theWindows > Preferences > Software AG > Web Services Stack > Deployment
window.

3. Select an entry from the table and click OK.

Designer opens the selected Web Services Stack configuration in an embedded web browser.
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4. Click the Validate link on the Web Services Stack web application Welcome screen to ensure
that all the required libraries are in place.
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Configuring XML View Preferences

The Web Services Stack Designer plug-in displays the content of XML documents. If you want to
customize the way the content is displayed, you can modify several visualization parameters.

To configure the Web Services Stack XML view preferences

1. In Designer: Windows > Preferences.

2. In the preferences navigation tree, select Software AG > Web Services Stack.

3. In the Web Services Stack window, set values for the following settings:

DescriptionProperty

Specifies the width of the line in symbols. The default value is
132.

Line Width

Specifies the indentation of the XML elements on the line in
symbols. The default value is 2.

Indentation size

4. Click Apply, and then OK to confirm.

Configuring Message Receivers, User Policies, and Password
Callback Handlers

To ensure the communication between applications, services and operations within your web
services use message receivers, user policies, and password callback handlers. You can use the
default ones, provided with your Software AG installation, or you can configure your custom
message receivers, user policies, and password callback handlers.

Configuring Message Receivers
Message receivers are agents that exchangemessages in accordancewith specificmessage exchange
patterns. You can configure your custom message receivers using the procedure below.

To configure Web Services Stack message receivers

1. In Designer: Windows > Preferences.

2. In the preferences navigation tree, selectSoftware AG > Web Services Stack > Configuration
Editor.

3. In the Message Receivers tab, configure the Web Services Stack message receivers.
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a. In the Message Exchange Pattern table, click Add, provide a name for the Message
Exchange Pattern, then click Add to confirm.

b. In the Message Receiver table, click Add, provide a name for the Message Receiver, then
click Add to confirm.

c. To edit or remove an item from the tables, select an entry and click the Edit or Remove
button.

The message receivers that you configure appear in the advanced policy settings of the Web
service packages. For more information about Web services packages, see Managing Web
Service Packages.

4. Click Apply, and then OK to confirm your Web Services Stack configuration settings.

Configuring User Policies
User policies are XMLfiles that contain pre-configureduser settings andpolicies, and are previously
exported to the file system. You can configure your custom user policies using the procedure
below.

To configure Web Services Stack user policies

1. In Designer: Windows > Preferences.

2. In the preferences navigation tree, selectSoftware AG > Web Services Stack > Configuration
Editor.

3. In the User Policies tab, configure the Web Services Stack user policies.

a. In the User Policies tab, click Add.

b. Open the policies XML file, then click Add and OK to confirm.

c. To edit or remove an item from the tables, select an entry and click the Edit or Remove
button.

The user policies that you configure appear in the advanced policy settings of all Web service
packages. For more information about advanced policy settings, see Configuring Advanced
Policy Settings.

4. Click Apply, and then OK to confirm.
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Configuring Password Callback Handlers
Password callback handlers provide or validate credentials for a specific identifier. You can create
your custom password callback handlers using the procedure below.

To configure Web Services Stack password callback handlers

1. In Designer: Windows > Preferences.

2. In the preferences navigation tree, selectSoftware AG > Web Services Stack > Configuration
Editor.

3. In the Callback Handlers tab, configure the Web Services Stack callback handlers.

a. In the Password Callback Handler table, click Add, provide a name for the password
callback handler, then click Add to confirm.

b. In the Policy Validator table, click Add, provide a name for the policy validator, then click
Add to confirm.

c. To edit or remove an item from the tables, select an entry and click the Edit or Remove
button.

The callback handlers that you configure appear in the advanced policy settings of the Web
service packages. For more information about Web services packages, see Configuring Web
Services Stack Preferences.

4. Click Apply, and then OK to confirm.

Configuring Deployment Locations

After you create and configure aWeb Services Stack package, you can deploy it on theWeb Services
Stack instance, which is deployed either on Software AG Runtime, or on a standard Java servlet
container. The deployed package can then be exposed to consumers. Before you deploy a Web
service package, you must define the deployment locations.

To configure the Web Services Stack deployment locations

1. In Designer: Windows > Preferences.

2. In the preferences navigation tree, select Software AG > Web Services Stack > Deployment.

3. In the Deployment window, click Add, provide values for the properties in the table below,
and click OK to confirm.
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DescriptionProperty

A name for the connection.Name

A protocol for the connection. Possible options are: http (default)
and https.

Protocol

A host name. Default value is localhost.Host

A port number for the connection. The default value is 10010.Port

Location of the deploy servlet. The default value is
/wsstack/sagdeployer.

Servlet

A user name.User

A password.Password

4. Click Apply, and then OK to confirm.

Configuring SSL Settings

You can configure your Web Services Stack Designer plug-in to use Secure Sockets Layer (SSL) to
encrypt the information exchange over a secure protocol.

To configure Web Services Stack SSL settings

1. In Designer: Windows > Preferences.

2. In the preferences navigation tree, select Software AG > Web Services Stack > SSL.

3. In the SSL window, browse to select the truststore file location, and enter a value for the
truststore password.

4. To specify a keystore file that differs from the truststore, clear the Use truststore settings for
keystore check box. Browse to select the keystore file location, and enter a value for the keystore
password.

5. Click Apply, and then OK to confirm.
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Creating Web Service Packages

You createWeb service packages out of Java classes andWSDLfiles contained in your Java projects
in Designer. A single Java project can contain multiple Web service packages which differ in
configuration and exposed functionality. Later you can deploy the created Web service package
to an application server to expose its Web services and make their functionality available to other
applications.

To create a web service package

1. In Designer, open the Project Explorer view.

2. In the Project Explorer, right-click the Java project, where you want to create a Web service
package.

3. On the context menu, select Web Services Stack > Add Web Services Package.

4. In the Web Services Packaging Wizard, specify a container and a unique name for the Web
service package, and click Next.

By default, the container is the Java project.

5. Select and open the source file which you want to expose as a Web service, and click Next.

You can select a WSDL file or a Java class file as a source file on the file system.

Note:
The source file you expose must be in the same Java project where you create the Web
service. You cannot expose external files as Web services in the current Java project.

6. Optionally, select supplementary meta-information files, and click Next.

The files you select in this step are included in the META-INF directory of the Web service
package.

7. Optionally, select supplementary source files, and click Next.

The files you select in this step are included in the root directory of the Web service package.

8. Click Finish.

Using the Web Services Stack Package Builder
TheWeb Services Stack Designer plug-in has its ownWeb Services Stack Package builder, similar
to the Java builders. The builder stores some metadata information in a hidden folder, called
.wsstack. Every time a package is deleted or any of the files within the Java project are modified,
the builder recreates the package. For example, if a Java class that is part of a package is modified
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and saved, the Java builder recreates the corresponding class file, and the Web Services Stack
Package builder recreates the package with the new class file. To deactivate the builder for the
particular project, right-click and select Properties > Builders.

If a file, which is part of a Web service package, is deleted, renamed, or moved, the Web Services
Stack Package builder asks you if you want to keep the file in the package.

If you decide to keep it, the file is copied to the corresponding temporary WSS directory, and
you can rebuild the package.

If you decide not to keep it, the file is removed from the package.

Note:
If you keep the file in the temporary directory, and then you add a new file with the same name
to the project, the build process allows you to add the new or the restored file to theWeb service
package. The old file is kept in the package and it is removed from the temporary directory.

Deleting Web Service Packages

Using the Web Services Stack Designer plug-in, you can delete Web service packages.

To delete a Web service package

1. In Designer, open the Project Explorer view.

2. In the Project Explorer, do one of the following:

Right-click the Web service package you want to delete, and select Web Services Stack
> Remove Web Services Package.

CAUTION:
Make sure you select the correct Web service package for deletion. Designer does not
ask you to confirm your choice and you cannot undo the action.

Right-click a Java project, and then select Web Services Stack > Remove Web Services
Package. Select the Web service packages you want to delete, and click OK.

Configuring Web Service Packages

Using the Web Services Stack Designer plug-in, you can configure the Web service packages, as
well as the services and the service operations within them.

The configuration settings are grouped in the Web service package editor under the following
tabs:

Archive - configures the Web service package.

Services - configures the Web services within the Web service package.

Operations - configures the Web service operations within the Web service package.
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Services.xml - displays a read-only textual view of the Web service.

Note:
You can also display a tree structure of the Web service package using the Outline view in
Designer and navigate through the different tabs by clicking the respective element in the tree.
To open the Outline view, select Window > Show View > Outline.

Adding Supplementary Source Files to Web Service Packages
You can add supplementary source files and Java classes to existing Web service packages using
the Archive tab in the Web service package editor.

To add supplementary source files to a Web service package

1. In Designer, open the Project Explorer view.

2. Double-click to open the Web service package you want to configure.

By default, the Web service package editor opens the Archive tab.

3. To add a supplementary source file to the META-INF directory:

a. In the Archive Structure area, click Add.

b. Select and open the source file you want to add as a META-INF file, and click OK.

4. To add a supplementary source file and expose it as a Web service:

a. In the Web Service Files area, click Add.

b. Select and open the source file you want to expose as a Web service, and click OK.

You can select a WSDL file or a Java class file as a source file on the file system.

Note:
The source file you expose must be in the same Java project where you create the Web
service. You cannot expose external files as Web services in the current Java project.

5. Save your changes.

Updating the Configuration of Web Services within Web Service
Packages
You can update and provide further configuration settings for Web services already included in
Web service packages using the Services tab in the Web service package editor.
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To update the configuration of Web services within a Web service package

1. In Designer, open the Project Explorer view.

2. Double-click to open the Web service package you want to configure.

3. Click the Services tab.

4. In the Service drop-down list, select the Web service you want to configure.

5. In the Description area, add a description for the Web service, and click Set to confirm.

6. In the Properties area:

Click the Add button to add a new property. Select a name, set a value, then click OK.

Select an existing property and click Edit to modify it. Set a new name and value, then
click OK.

Select an existing property and click Remove to delete it.

7. In the Message Receivers area:

Click the Add button to add a new message receiver. Select a name, set a value, then click
OK.

Select an existing message receiver and click Edit to modify it. Set a new name and value,
then click OK.

Select an existing message receiver and click Remove to delete it.

8. In the Transport area, select the transport you want to use with the Web service. You can
select between the following transport types: HTTP, HTTPS, TCP, and JMS.

If you do not select a specific transport type, all transports enabled on the respective Web
server are available for the Web service.

9. In the Modules area, enable and configure the advanced policy settings for the Web service.

For more information about configuring advanced policy settings, see Configuring Advanced
Policy Settings.

10. Save your changes.
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Configuring Web Services Operations within Web Service
Packages
You can provide additional configuration settings forWeb service operationswithin aWeb service
package.

To configure Web service operations within a Web service package

1. In Designer, open the Project Explorer view.

2. Double-click to open the Web service package you want to configure.

3. Click the Operations tab.

4. In the Service drop-down list, select the Web service you want to configure.

5. In the Operation drop-down list, select the operation you want to configure.

6. In the Message Receivers area:

Select the class name, then click Set to assign a new message receiver.

You can use your own user-defined message receivers. For more information about
user-defined message receivers, see Configuring Message Receivers, User Policies, and
Password Callback Handlers.

Click the Clear button to remove an assigned message receiver.

7. In the Parameters area:

Click the Add button to add a new parameter. Select a name, set a value, then click OK.

Select an existing parameter and click Edit to modify it. Set a new name and value, then
click OK.

Select an existing parameter and click Remove to delete it.

8. In the Modules area, enable and configure the advanced policy settings for the Web service.

For more information about configuring advanced policy settings, see Configuring Advanced
Policy Settings.

9. Save your changes.

Note:
In a POJO Web service, all public methods are exposed as operations, even if they are not
declared in the services.xml file. To exclude an operation, edit manually the services.xml file,
and add the following excerpt:
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<excludeOperations>
<operation>[operation_name]</operation>

</excludeOperations>
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Overview

The Web Services Stack tool enables you to configure Web services and Web service operations
advanced policy settings, such as: WS-Addressing, WS-ReliableMessaging, andWS-Security. You
can also save your policy configuration as a policy XML file, and reuse it later.

Enabling Web Service Addressing

To enable WS-Addressing

1. In Designer, double-click a Web service package to open it.

2. Select the Services or Operations tab, depending on which one you want to configure.

3. Select Enable WS-Addressing.

4. Save your changes.

Enabling Web Service Reliable Messaging

To enable WS-ReliableMessaging

1. In Designer, double-click a Web service package to open it.

2. Select the Services or Operations tab, depending on which one you want to configure.

3. Select Enable WS-ReliableMessaging.

4. Set the inactivity timeout period in milliseconds. The default value is 600000.

5. Save your changes.

Configuring Web Service Security

To configure WS-Security

1. In Designer, double-click a Web service package to open it.

2. Select the Services or Operations tab, depending on which one you want to configure.

3. Select Enable WS-Security
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The Security opens and the Enable WS-Addressing option, the HTTPS transport,
Transport-level Security with SSL and Username Token Assertion are automatically
enabled.

4. In the Security area, you can select one of the four Security Bindings:

No Binding - when selected, you can disable the Enable WS-Addressing option.

Transport-level Security with SSL

Message-level Security with Symmetric Binding

Message-level Security with Asymmetric Binding

Depending on the security binding you selected, continue with the relevant options below.

5. Configure the options in the Message-level Security Options area.

DescriptionOption

Enables encryption (EncryptedParts assertion) over the entire body
content.

Encrypt Body

Enables integrity protection (SignedParts assertion) over the entire
body content.

Sign Body

Enables signature over the headers and body content
(OnlySignEntireHeadersAndBody policy assertion.

Sign entire
Headers and
Body

6. Configure the options in the Token Assertions area.

DescriptionOption

Enables the UsernameToken assertion to secure the messages sent
to the client.

User Name
Token

Enables the SecureConversationToken assertion Language
(WS-SecureConversation).WS-SecureConversation providesmeans

Secure
Conversation

for creating and sharing security contexts rather than relying only
on the message authentication model.

7. Other Security Options

DescriptionOption

Enables the usage of the IncludeTimestamp policy assertion.Include
Timestamp
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DescriptionOption

Enables the usage of client certificates to encrypt the transferred
data (RequireClientCertificate policy assertion).

Use Client
Certificate

Note:
This option is only available when you configure transport-level
security with SSL.

8. In case of Message-level Security you can specify the following:

XPath expressions to encrypt (EncryptedElements or ContentEncryptedElements assertion)
and/or sign (SignedElements assertion) parts of the message.

Headers to be encrypted (EncryptedParts assertion) and/or signed (SignedParts assertion).

Configure the options in the Security Model Configuration (Apache Rampart see http://
axis.apache.org/axis2/java/rampart/rampartconfig-guide.html) area.

DescriptionOption

Specifies the user name used. For details see "Client-Side
Configuration" in the Web Services Stack documentation.

User

Callback Class providing the password used to create the
UsernameToken for the desired user.

UsernameToken
Validator Class

Callback Class providing the password to sign themessage
or to create the UsernameToken (for the details of the

Password Validator
Class

predefined callback classes see "Implementation of Password
Callback Handlers in the Web Services Stack
documentation).

Callback Class providing the password for Custom
validators (for the details of the predefined callback classes

Policy Validator
Callback Class

see "Implementations of Policy Validation Callbacks" in the
Web Services Stack documentation).

Optionally, you can add anduse your own, user-definedpassword callback classes, user-defined
policy validator callback classes that you added in the preferences settings of Designer. For
more information, see Configuring Web Services Stack Preferences.

In the Encryption and Signing areas below you can configure the corresponding keystore and
truststore.

DescriptionOption

The user name used for encryption (ENCRYPTION_USER)
or for signature (USER_CERTIFICATE_ALIAS).

Certificate Alias
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DescriptionOption

Specifies the path to keystore file for encryption or for
signature.

Keystore

Specifies the password for the keystore file.Keystore Password

Specifies the path to truststore file for encryption or for
signature.

Truststore

9. Save your changes.

For more information see the separate Web Services Stack documentation, also available under
http://documentation.softwareag.com > webMethods Product Line > Shared Components.

Saving Policy Configurations

To save your policy configuration to a file

1. In Designer, in the Policies area, click Save Policy as.

2. In the dialog that opens, specify a file name and directory on the file system.

3. Save your changes.

Designer saves your policy configuration and makes it available in the Available Policies
drop-down menu.

Note:
The policy file stored using the configuration editor appears only in the Available Policies
drop-downmenu for this package. OtherWeb service packages have no access to the policy
file. To enable other Web service packages to use the policy file, you must add it to Web
Services Stack preferences inDesigner. Formore information, see ConfiguringWeb Services
Stack Preferences.
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Overview

When you create and configure a Web service package, you can deploy it on Web Services Stack,
which runs on a servlet container.

By default, Web Services Stack runs on a Software AG Runtime instance at port 10010. After
installation, the Web Services Stack deployment location is set to localhost:10010. You can
configure an alternative deployment location using the Web Services Stack Designer plug-in. For
more information, see Configuring Web Services Stack Preferences.

Note:
We strongly recommend you use only the Software AG Runtime (CTP) with the Web Services
Stack Designer plug-in. Software AG does not officially support deployment scenarios for Web
Services Stack on other web servers. To install the Software AG Runtime with Web Services
Stack, choose Infrastructure > Shared Platform > Runtime in the Installer tree.

Deploying Web Service Packages

You can deploy Web service packages using the Web Services Stack Designer plug-in.

To deploy a Web service package

1. In Designer, open the Project Explorer view.

2. To specify the Web service package that you want to deploy, do one of the following:

Right-click the Web service package.

Right-click the Java project that contains the Web service package.

3. On the context menu, select Web Services Stack > Deploy Web Services Package.

The Software AG Web Services Stack wizard opens.

4. Provide the following information:

DescriptionField

The location to which you deploy your Web service package. The
default value is localhost-10010.

Name

The location of the Web Services Stack deploy servlet. The default
deploy servlet location is
http://<host_name>:<port_number>/wsstack/sagdeployer.

URL

The username for the required authentication credentials. The
default value is admin.

User
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DescriptionField

The password for the required authentication credentials. The
default value is manage.

Password

Formore information aboutmodifying the user name andpassword,
go to Software AG Documentation Website > Software AG
Infrastructure Administrator's Guide.

5. Complete the deployment process by doing one of the following:

If you started the wizard on a Web service package, click Finish.

If you started the wizard on a Java project, click Next, select the Web service package you
want to deploy, and click Finish.

Displaying Deployed Web Service Packages

To display the particular WSDL document, you must deploy the respective Web service package.

To display a deployed Web service package

1. In Designer, open the Project Explorer view.

2. Right-click the Web service package whose WSDL document you want to display.

3. On the context menu, select Web Services Stack > View deployed Web Service.

Designer opens theWSDLdocument of the deployedWeb service in an embeddedweb browser.

Undeploying Web Service Packages

To undeploy a Web service package

1. In Designer, open the Project Explorer view.

2. Right-click the Web service package that you want to undeploy.

3. On the context menu, select Web Services Stack > Undeploy Web Services Package.

4. Provide the following information:

DescriptionField

The location to which you deploy your Web service package. The
default value is localhost-10010.

Name
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DescriptionField

The location of the Web Services Stack deploy servlet. The default
deploy servlet location is
http://<host_name>:<port_number>/wsstack/sagdeployer.

URL

The username for the required authentication credentials. The
default value is admin.

User

The password for the required authentication credentials. The
default value is manage.

Password

Formore information aboutmodifying the user name andpassword,
go to Software AG Documentation Website > Software AG
Infrastructure Administrator's Guide.

5. Click Finish.
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Overview

Software AG Designer enables you to publish previously deployed Web service packages to
multiple CentraSite Organizations.

The following statements are valid for the publication process:

The service you publish is registered in the CentraSite Registry via the WSDL document.

The WSDL document and the Web service packages are stored in the CentraSite Repository.

The service object gets an external link to the package.

For more information about deploying services, see Deploying and Undeploying Web Service
Packages.

For more information about CentraSite, CentraSite Organizations, and the publication process,
see the CentraSite documentation on the Software AG Documentation website.

Publishing a Web Service Package

Using Software AG Designer, you can publish previously deployed Web service packages to
CentraSite Organizations. As a prerequisite, you must have the CentraSite Registry Repository
and the CentraSite Designer plug-in installed on your system.

Before you publish your Web service package to a CentraSite Organization, make sure you have
the authentication credentials needed to access that Organization.

To publish a Web service package

1. In Designer, open the Project Explorer view.

2. Right-click the Web service package that you want to publish.

3. On the context menu, select Web Services Stack > Register Web Services Package.

The Publish to CentraSite wizard opens.

4. Provide the following information:

DescriptionField Name

The host name on which you can access CentraSite. The default
value is localhost.

Host

The port number on which you can access CentraSite. The default
value is 53305.

Port

The ID of the product. The default value is CentraSite.Product ID
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DescriptionField Name

The path to the repository. The default value is WebServicesStack.Repository Path

The user name for access to a CentraSite Organization.User

The password for access to a CentraSite Organization.Password

The name for the CentraSite Organization to which you want to
publish the Web service. Select a value from the drop-down list.

Organization

The user name for access to a CentraSite Organization.User

5. Click Next.

6. Provide the following information about the deployment location of the Web service:

DescriptionField Name

The location to which you deploy your Web service package.Name

The location of the Web Services Stack deploy servlet. The default
deploy servlet location is
http://<host_name>:<port_number>/wsstack/sagdeployer.

URL

The username for the required authentication credentials. The
default value is admin.

User

The password for the required authentication credentials. The
default value is manage.

Password

Formore information aboutmodifying the user name andpassword,
go to Software AG Documentation Website > Product Families >
Software AG Suite & Cross-Product Guides > Web Services
Stack > Web Services Stack [version].

7. Click Finish.

Unpublishing a Web Service Package

You can unpublish a Web service package from CentraSite Organizations.

To unpublish a Web service package

1. In Designer, open the Project Explorer view.

2. Right-click the Web service package that you want to unpublish.
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3. On the context menu, select Web Services Stack > Unregister Web Services Package.

The Unregister from CentraSite wizard opens.

4. Provide the following information:

DescriptionField

The ID of the product. The default value is CentraSite.Product ID

The user name for access to a CentraSite Organization.User

The password for access to a CentraSite Organization.Password

5. Click Finish.
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