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This guide contains the webMethods BPM and CAF Workspace Metadata Help in PDF book format.
The information in this guide is the same information that you can view via the Software AG
Designer online help.

Document Conventions

DescriptionConvention

Identifies elements on a screen.Bold

Identifies service names and locations in the format folder.subfolder.service, APIs,
Java classes, methods, properties.

Narrowfont

Identifies:Italic

Variables for which you must supply values specific to your own situation or
environment.
New terms the first time they occur in the text.
References to other documentation sources.

Identifies:Monospace font

Text you must type in.
Messages displayed by the system.
Program code.

Indicates a set of choices from which you must choose one. Type only the
information inside the curly braces. Do not type the { } symbols.

{ }

Separates two mutually exclusive choices in a syntax line. Type one of these
choices. Do not type the | symbol.

|

Indicates one or more options. Type only the information inside the square
brackets. Do not type the [ ] symbols.

[ ]

Indicates that you can type multiple options of the same type. Type only the
information. Do not type the ellipsis (...).

...

Online Information and Support

Software AG Documentation Website

You can find documentation on the Software AG Documentation website at https://
documentation.softwareag.com.

Software AG Empower Product Support Website

If you do not yet have an account for Empower, send an email to empower@softwareag.comwith
your name, company, and company email address and request an account.
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Once you have an account, you can open Support Incidents online via the eService section of
Empower at https://empower.softwareag.com/.

You can find product information on the Software AG Empower Product Support website at
https://empower.softwareag.com.

To submit feature/enhancement requests, get information about product availability, and download
products, go to Products.

To get information about fixes and to read early warnings, technical papers, and knowledge base
articles, go to the Knowledge Center.

If you have any questions, you can find a local or toll-free number for your country in our Global
Support Contact Directory at https://empower.softwareag.com/public_directory.aspx and give us
a call.

Software AG Tech Community

You can find documentation and other technical information on the SoftwareAGTechCommunity
website at https://techcommunity.softwareag.com. You can:

Access product documentation, if you have Tech Community credentials. If you do not, you
will need to register and specify "Documentation" as an area of interest.

Access articles, code samples, demos, and tutorials.

Use the online discussion forums, moderated by Software AG professionals, to ask questions,
discuss best practices, and learn how other customers are using Software AG technology.

Link to external websites that discuss open standards and web technology.

Data Protection

SoftwareAGproducts provide functionalitywith respect to processing of personal data according
to the EU General Data Protection Regulation (GDPR). Where applicable, appropriate steps are
documented in the respective administration documentation.
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webMethods Workspace Metadata

With webMethods workspace metadata, you can locate and re-use local process assets.

This webMethods Workspace Metadata Help contains supporting documentation about the
following main topics:

“Metadata in Your Workspace” on page 10

“The Workspace Index” on page 11

“Configuring Workspace Index Preferences” on page 13

For information aboutworkingwith CentraSitemetadata for process and Integration Server assets,
seewebMethods BPMProcessDevelopmentHelp andwebMethods ServiceDevelopmentHelp, respectively.
For a general overview of CentraSite functionality, see “Metadata in CentraSite ” on page 14.

Metadata in Your Workspace

Metadata is data that describes the assets in webMethods components. An asset is any object you
create and work with in a webMethods component. For example, in Designer, assets include
processes, tasks, portlets, and so on. Each asset in Designer has metadata automatically generated
about it and saved to the workspace index — a process referred to as workspace indexing.

Note:
You candisable automaticworkspace indexing. Formore information, see “Enabling orDisabling
Workspace Indexing” on page 11.

Metadata consists of a variety of information about an asset. All assets have names and (optionally)
descriptions. An asset also may have values for certain properties, such as the Process ID of a
process. If an asset references other assets, like a task step that references a service, it will have
metadata about such associations.

The essential idea of metadata is to provide information describing each asset, what it contains,
and what assets it references or depends on.

Metadata is accessed by using Designer's search capabilities. You can search metadata for
information about various assets. For more information, see “ webMethods Workspace Metadata
Search” on page 16.

Before making a change to an asset, you might want to locate any assets that refer to it or are
dependent on it. This helps ensure you are not making changes that would adversely affect other
assets. For more information, see “Related Assets” on page 22.

Local metadata that is stored on your computer is referred to as workspace metadata. Workspace
metadata is stored in a database, on your computer, called the workspace index (see “The
Workspace Index” on page 11).

You can also share workspace metadata with other users by publishing it to CentraSite (see
“Metadata in CentraSite ” on page 14).
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Important:
When you reuse an asset from CentraSite, only a minimally required amount of information
about that asset is transferred to the workspace where you use it. As a result, when you query
the workspace, you do not find the same metadata you find when you query CentraSite.
Additionally, reference chains in CentraSite are not fully reflected in the workspace. If process
A references process B, which references process C in CentraSite, when you reuse process B in
your workspace, the relationship between B and C is not preserved. When you reuse an
Integration Server service fromCentraSite, you lose the information about the relationships that
Integration Server service haswith other assets. If service A calls service B, and you reuse service
A, you only get service A.

For information about setting CentraSite preferences, see the CentraSite Help.

The Workspace Index

The workspace index refers to the local database containing metadata about local assets in the
currentDesignerworkspace. The database resides on your computer. There is a separateworkspace
index for each Designer workspace.

Enabling or Disabling Workspace Indexing

By default, workspace indexing is enabled. Whenever you create an asset or save changes to an
asset, local metadata about it is automatically generated. You can enable or disable workspace
indexing in Designer's preferences.

Important:
If you disableworkspace indexing, noworkspacemetadata is created. Assetswithoutworkspace
metadata are not included in webMethods workspace searches.

Note:
If you enable workspace indexing after you have created or modified assets while workspace
indexing is disabled, see “Resetting theWorkspace Index” on page 13 for important information
about how the workspace index is affected.

To enable or disable workspace indexing

1. In Designer: Window > Preferences > Software AG Workspace Index.

2. In the Metadata settings, select Disable Workspace Indexing to disable workspace indexing.
Clear the check box to enable it.

3. Click OK to close the Preferences window.

4. Restart Designer.

You can continueworking inDesignerwithout restarting it. However, any change toworkspace
indexing does not take effect until you restart Designer.
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About Resetting the Workspace Index

There are situations in which you may want to regenerate workspace metadata for all projects
and their assets in a Designer workspace. This is referred to as resetting the workspace index. For
information on carrying out this procedure, see “Resetting the Workspace Index” on page 13.

Typically, there are two situations in which you may want to reset the workspace index:

To capture metadata about assets that were created or modified with workspace indexing
disabled.

You suspect the workspace index has become corrupted in some way.

These two scenarios are discussed in more detail below.

Resetting after workspace indexing was disabled:

You may need to reset the workspace index to capture metadata about assets that were created
or modified when workspace indexing was disabled. Workspace metadata is created or updated
only when a file change event occurs. Therefore, simply re-enabling workspace indexing will not
generate the missing metadata retroactively. In such cases, you should consider resetting the
workspace index to create or update the metadata for all assets.

Resetting when the workspace index is possibly corrupted:

If you suspect the workspace index has become corrupted, you may want to reset it. For example,
corruption may be indicated if you have created an asset and you are certain that workspace
indexing is enabled, but when you search for workspace metadata on that asset, nothing is found.

If this happens for a single asset, you can make a trivial change to the asset and save it; then,
reverse the change and save it again. This should trigger workspace indexing for the asset. If
workspace metadata seems to be missing for several assets, consider resetting the workspace
index.

For additional information, see webMethods BPM Process Development Help.

Overview of the resetting procedure

The process of resetting the workspace index begins with deleting the existing database files that
contain theworkspacemetadata, and then restarting Designer. Upon startup, when noworkspace
index is found, Designer automatically creates an empty workspace index.

Finally, you must close and open each project, which triggers workspace indexing for all assets
in each project.

For the complete procedure, see “Resetting the Workspace Index” on page 13.

Note:
Each workspace has its own workspace index. If you have multiple workspaces and want to
reset their workspace indexes, you must apply the reset procedure to each individual index.
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Resetting the Workspace Index

To reset a workspace index

Note:
If you are resetting the workspace index because you had previously disabled workspace
indexing, be sure to enable indexing before exiting Designer. See “Enabling or Disabling
Workspace Indexing” on page 11.

1. Exit Designer.

2. Delete the workspace index folder:

a. In a file browser or explorer, go to
<workspace>\.metadata\.plugins\com.softwareag.metadata.eclipse\.

where <workspace> is the Designer workspace in question (for example, on Windows, the
default workspace is commonly C:\Documents and Settings\<your login>\workspace).

b. Delete the index folder if it exists.

3. Start Designer and select the workspace.

4. In the Navigator view, close and re-open each project:

Each top-level item in the tree is a project. For each project, right-click and selectClose Project.
Then, right-click the project again and select Open Project.

When you re-open a project, the status bar on the lower right of the Designer window will
indicate "Extracting changed files." This meansworkspacemetadata is being generated for the
project's assets.

Note:
If there is not much workspace metadata to be extracted, this message appears so briefly
you may not see it.

To ensure all local metadata is extracted, be sure to close and re-open all projects you see in
the Navigator view.

For additional information, see webMethods BPM Process Development Help.

Configuring Workspace Index Preferences

To configure Workspace Index preferences

Note:
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For additional information about this preference, see “Enabling or Disabling Workspace
Indexing” on page 11.

1. In Designer: Window > Preferences > Software AG > Workspace Index.

2. You can configure the following Workspace Index preferences:

DescriptionPreference

Select this check box to disable workspace indexing. By
default, workspace indexing is enabled.Whenever you create

Disable Workspace Indexing

an asset or save changes to an asset, metadata about it is
automatically generated. If you disable workspace indexing,
noworkspacemetadata is created. Assetswithoutworkspace
metadata are not included in webMethods workspace
searches.

3. To apply default preferences on a page, click Restore Defaults.

4. Click Apply to save your changes and keep the Preferences window open.

Click OK to save your changes and close the Preferences window.

Click Cancel to close the Preferences window without saving your changes.

Metadata in CentraSite
CentraSite is a shared repository and registry. Assets are stored in the repository, and information
about those assets, or metadata, is stored in the registry. Both the workspace index and the
CentraSite registry contain metadata about assets. The difference is that the workspace index is
accessible only by you on your own computer, while the CentraSite registry is accessible to other
users. The CentraSite registry resides on and is maintained by a server on the network.

The main purpose of the CentraSite registry is to allow reuse of assets among users. You can
publishmetadata about an asset toCentraSite. Other userswill be able to see the publishedmetadata
and incorporate one or more references to the asset into their own projects.

For information aboutworkingwith CentraSitemetadata for process and Integration Server assets,
seewebMethods BPMProcessDevelopmentHelp andwebMethods ServiceDevelopmentHelp, respectively.

Note:
You cannot publish asset metadata to CentraSite unless the asset exists in the workspace.
However, workspace indexing is not required for publishing to CentraSite. Local (workspace)
metadata about an asset is created automatically when you enable workspace indexing. For
more information, see “The Workspace Index” on page 11.
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webMethods Workspace Metadata Search

To locate assets and/or asset references, Designer searches the metadata associated with assets.
You can choose to search only the workspace index, only CentraSite, or both the workspace index
and CentraSite. For more information, see “Metadata in Your Workspace” on page 10, as well as
webMethods BPM Process Development Help and webMethods Service Development Help.

Important:
When you re-use an asset from CentraSite, only a minimally required amount of information
about that asset is transferred to the workspace where you use it. As a result, when you query
the workspace, you do not find all the same metadata you find when you query CentraSite.
Additionally, reference chains in CentraSite are not fully reflected in the workspace. If process
A references process B, which references process C in CentraSite, when you reuse process B in
your workspace, the relationship between B and C is not preserved. When you re-use an
Integration Server (IS) service fromCentraSite, you lose the information about the relationships
that Integration Server service has with other assets. If service A calls service B, and you reuse
service A, you only get service A.

Note:
If you have workspace indexing disabled now or had it disabled in the past, you might have
assets in your workspace that havemissing or incomplete metadata. In this case, the search will
not properly locate these assets. See “Enabling or Disabling Workspace Indexing” on page 11.

The following table lists the types of searches that Designer provides for searching for assets:

DescriptionHow to AccessType of Search

Use to locate assets or asset references based on
keywords contained in the asset's name and/or

webMethods tab in the
Search window

Basic keyword search

description. In both Basic and Advanced
searches, you can locate all assets of a particular
type by selecting the asset and specifying no
search criteria.

Use to locate assets of a single type. For
example, you can search for portlets or you can

webMethods
Advanced tab in the
Search window

Advanced search

search for IS document types, but not both
portlets and IS document types in a single
search.

The advanced search allows you to specify
detailed search criteria to locate specific assets.
For example, you can search for processes with
names that contain "HR", with a model version
that is equal to "2", and that references another
process with a name that contains "approve".

In both webMethods basic and advanced
searches, you can locate all assets of a particular
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DescriptionHow to AccessType of Search

type by selecting the asset and specifying no
search criteria.

Use to locate assets of a single type. For
example, you can search for portlets or you can

Saved Searches viewSaved searches

search for processes, but not both portlets and
processes in a single search.

Designer provides predefined saved searches
of assets used in your solutions. You can search
your workspace for all CAF Task Types,
Portlets, or Processes; and you can search
CentraSite for all Documents, E-forms, IS
Services, Rule Services, or Web Services.

You can define and save additional searches.
When defining your own saved search, you can
specify detailed search criteria to locate specific
assets, similar to the criteria you can specify for
an advanced search.

Performing Basic Searches

Use a basic search to locate assets or asset references based on keywords contained in the asset's
name and/or description. Designer displays the results of your search in the Search view.

To locate assets and/or asset references, Designer searches the metadata associated with assets.
You can choose to search only the workspace index, or both the workspace index and CentraSite.
For more information, see “The Workspace Index” on page 11 as well as webMethods BPM Process
Development Help and webMethods Service Development Help.

Note:
If you have workspace indexing disabled now or had it disabled in the past, you might have
assets in your workspace that havemissing or incomplete metadata. In this case, the search will
not properly locate these assets. See “Enabling or Disabling Workspace Indexing” on page 11.

To perform a basic search for webMethods assets

1. In Designer: Search.

2. The webMethods tab has focus by default. Selections from the previous search are retained.

3. In the Name or description contains field, specify a keyword that is contained in the name
or description of the assets you want to locate. The search is not case sensitive.
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4. Select the type of assets that you want to locate from the Asset Type list. You can select All
to search for all types of assets and asset references, or you can select one of the listed asset
types.

5. In the Search in field, select:

Workspace to search metadata in the workspace index only.

CentraSite to search metadata in CentraSite only.

Workspace & CentraSite to searchmetadata in both theworkspace index and CentraSite.

6. Click Search.

Performing Advanced Searches

Use an advanced search to specify detailed search criteria to locate specific assets. When you
perform an advanced search, you can only locate assets of a single type. For example, you can
search for portlets or you can search for Integration Server document types, but not both portlets
and Integration Server document types in a single search. Designer displays the results of your
search in the Search view.

To locate assets and/or asset references, Designer searches the metadata associated with assets.
You can choose to search only the workspace index, or both the workspace index and CentraSite.
For more information, see “The Workspace Index” on page 11 and “Metadata in CentraSite ” on
page 14.

Note:
If you have workspace indexing disabled now or had it disabled in the past, you might have
assets in your workspace that havemissing or incomplete metadata. In this case, the search will
not properly locate these assets. See “Enabling or Disabling Workspace Indexing” on page 11.

To perform an advanced search for webMethods assets

1. In Designer:  Search.

2. Click the webMethods Advanced tab.

Selections from the previous search are retained.

3. Select the type of asset you want to locate from the Asset Type list.

4. For each search criterion you want to use:

a. Click Add.

b. In the Add Query Condition window, click Asset Field and select an item. The items that
Designer includes in the Asset Field list depends on the Asset Type you select.
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c. Complete specifying the condition for the selected Asset Field. Note that the search is not
case sensitive.

d. Click OK.

5. In the Match condition field, select:

Any to have Designer locate assets that match any of the criteria you specified.

All to have Designer locate assets only if they match all of the criteria that you specified.

Note:
If you selectReferences fromAsset Field andAll forMatch condition, Designer finds
assets that contain all the specified references, but those references do not necessarily
have to be all in one place. For example, if you have a condition to locate all processes
that reference processeswith names that contain "HR" and also reference processeswith
a process version that contains "2", Designer might find a process that contains one step
for a referenced processwith the name "HR-Tasks" and a process version "3" and another
step for a referenced process with the name "ApproveOrder" and a process version "2".

6. In the Search in field, select:

Workspace to search metadata in the workspace index only.

CentraSite to search metadata in CentraSite only.

Workspace & CentraSite to searchmetadata in both theworkspace index and CentraSite.

Note:
Services and documents associated with processes are not searchable in the workspace.
However, you can show the references and dependencies of processes to locate these
assets. See “Showing Asset References and Dependencies” on page 23.

7. To initiate the search, click Search.

Configuring Search Preferences

You can configure standard Eclipse preferences for searching. Formore information, see the Eclipse
documentation.

To configure Search preferences

1. In Designer: Window > Preferences > General > Search.

2. Set the preferences you want for each of the following options. You can also click Restore
Defaults to reset all Search preferences to their initial installed values.
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DescriptionSearch Preference

Use the same editor for search results to reduce the number
of open editors. Enabled by default.

Reuse editors to show matches

Bring the Search view to the front after performing a search.
Enabled by default.

Bring Search view to front after
search

Select this option if you want to see exact matches only.Ignore potential matches

Highlight potentialmatches in the Search view. If the Search
engine isn't 100% sure about thematch, it is not considered
a potential match. Enabled by default.

Emphasize potential matches

Select the foreground color for potential matches.Foreground color for potential
matches

Enter a value to limit the number of file search results.Limit table size for file search
results to:

Select the perspective that should be brought to the front
when there are new search results. Default is None.

Default perspective for the
Search view

3. For more information about each of these options, see Eclipse documentation.

4. Click Apply to apply your changes without closing the Preferences window.

Click OK to apply your changes and close the Preferences window.

Search View

The Search view is a standard Eclipse view. Designer displays the results of a search in the Search
view.

Search results do not display referenced assets. For example, if you publish a package that contains
one service, but that service in turn calls other services in different packages, thenwhen you search
for all services you will only see the one service in the package you published, not all of the
referenced services. To seewhat your one service depends on, you can clickShow Dependencies,
and to see what your one service refers to, you can click Show References.

When you choose to show references or dependencies in the Solutions or Registry Explorer view,
the results are shown in the Search view. See “Showing Asset References and Dependencies” on
page 23.

You can take the following actions from the Search view:

DescriptionAction

Right-click a row in the Search view.View dependencies of an
asset
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DescriptionAction

Select Show Dependencies >  In CentraSite or Show
Dependencies > In Workspace.

For more information, see “Showing Asset References and
Dependencies” on page 23.

Note:
Because Designer uses metadata to determine dependent assets, if
you have set your Designer preferences to disable workspace
indexing, the Search view might not list all dependencies. See
“Enabling or Disabling Workspace Indexing” on page 11.

Right-click a row in the Search view.View references of an asset

Select Show References > In CentraSite or Show References >
In Workspace.

For more information, see “Showing Asset References and
Dependencies” on page 23.

Note:
Because Designer uses metadata to determine referenced assets, if
you have set your Designer preferences to disable workspace
indexing, the Search viewmight not list all references. See “Enabling
or Disabling Workspace Indexing” on page 11.

Select a row in the search results and drag it on to the canvas.Add an item in the search
results to the process
editor's canvas Note:

The item in the search result must be appropriate for the type of
asset on the canvas for the drag and drop to succeed.

Note:
When you use an asset fromCentraSite, you are creating a reference
to that asset. You are not including the asset itself in your project
or solution; rather, you are referencing the asset based on its
metadata inCentraSite. CentraSite assets show CentraSite in the
Store column.

Selects the next item in the search results. Show Next Match

Selects the previous item in the search results. Show Previous Match

Removes the currently selected matches from the Search view. Select
one, or CTRL + click to select multiple matches.

 Remove Selected
Matches

Removes all matches currently shown in the Search view. Remove All Matches
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DescriptionAction

Repeats the current search to reflect changes to results. Run the Current Search
Again

Cancels the current search. Cancel Current Search

Browse previously conducted searches and repeat a previous search.
Shows previous searches and allows you to select one.

 Show Previous
Searches

Select Show Previous Searches Menu to see a list of the most
recent searches. Select one to run again.

Select Show Previous Searches Menu > History to see the history
of your previous searches.

Select Show Previous Searches Menu > Clear History to remove
all previous search history information, including the one currently
displayed.

Pinning the Search view means that subsequent searches display
results in another Search view, leaving the pinned view and its results
unchanged.

Pin the Search View

Designer displays the Search view automaticallywhen you execute a search. If you close the Search
view and want to reopen it, click Window > Show View > General >  Search.

For additional information, see webMethods BPM Process Development Help.

Related Assets
Search results do not display referenced assets. For example, if you publish a package that contains
one service, but that service in turn calls other services in different packages, thenwhen you search
for all services you will only see the one service in the package you published, not all of the
referenced services. To see what your one service depends on, you can Show Dependencies, and
to see what your one service refers to, you can Show References.

For a selected asset, you can view related assets: references and dependencies. Referenced assets
are used by the selected asset. Dependent assets use, or "depend on," the selected asset. For example,
a process might use a number of Integration Server (IS) services. The IS services are references of
the process.

You can view the related assets of an asset by right-clicking it in the Solutions or Registry Explorer
view and then choosing Show References or Show Dependencies. The related assets are
displayed in the Search view.

You can also view the related assets of an asset returned by a search. In the Search view, right-click
the asset and choose Show References or Show Dependencies.

22 webMethods BPM and CAF Workspace Metadata Help 10.11

2 Workspace Metadata Search



Related asset information is metadata that comes from either the workspace index or CentraSite.
When you choose to view related assets, you are given a choice of viewing the related asset
information from the workspace index or CentraSite.

The related asset information for the same asset might be different in the workspace index than
in CentraSite. The latest changes to the asset reflected in the workspace index may not have been
published to CentraSite, or the version in the workspace index may not have been updated with
the latest changes reflected in CentraSite.

Only directly related assets are shown in the Search view. For example, if A references B and B
references C, only B is shown as a reference ofA. C is not shown because it is not directly referenced
by A.

For additional information, see webMethods BPM Process Development Help.

Showing Asset References and Dependencies
When you choose to show the related assets of an asset, they are displayed in the Search view:

References are the assets that are used by (referred to by) the selected asset.

Dependencies are the assets that use (depend on) the selected asset.

Note:
If you have workspace indexing disabled now or had it disabled in the past, you might have
assets in yourworkspace that havemissing or incompletemetadata. In this case, Designermight
not show all references or dependencies. See “Enabling or Disabling Workspace Indexing” on
page 11.

To show the references or dependencies of an asset

1. In the Solutions or Search view, right-click the asset you want to work with.

2. Click Show References or Show Dependencies and then click:

In CentraSite to show referenced or dependent assets (based on your selection) found
in CentraSite.

In Workspace to show referenced or dependent assets (based on your selection) found
in the workspace index.

Note:
The related asset information for the same asset might be different in the workspace
index than in CentraSite. The latest changes to the asset reflected in theworkspace index
may not have been published to CentraSite, or the version in the workspace index may
not have been updated with the latest changes reflected in CentraSite.

3. Designer displays referenced or dependent assets (based on your selection) in the Search view.

Note:
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Only direct references and direct dependencies (based on your selection) are shown. For
example, A references B and B references C. If you choose to view the references of A, only
B is shown. Likewise, A has dependency B and B has dependency C. If you choose to view
the dependencies of A, only B is shown.

For additional information, see webMethods BPM Process Development Help and webMethods Service
Development Help.

Saved Searches View

The Saved Searches view allows you to perform searches that are already defined. These searches
can include assets in your local workspace, CentraSite, or both. When you execute a saved search,
Designer displays the results in the Search view.

Designer provides predefined saved searches of assets used in your solutions. You can search
your workspace for all CAF Task Types, Portlets, or Processes; and you can search CentraSite for
all Documents, E-forms, IS Services, Rule Services, or Web Services.

webMethods predefined saved searches are designated by the webMethods Predefined Saved
Search icon. You cannot edit, delete, rename, or duplicate any of the predefined saved searches.

Use this saved search to locate...webMethodsPredefinedSavedSearch

All CAF task types in your workspace. All CAF Task Types in Workspace

All Integration Server (IS) or Trading Networks (TN)
document types in CentraSite.

 All Documents in CentraSite

All IS/TN documents in CentraSite. All Documents in CentraSite

All e-forms in CentraSite. All E-forms in CentraSite

The Name field displays the template name.

All IS services in CentraSite (including rule services and
Web services).

 All IS Services in CentraSite

All Integration Server (IS) services in CentraSite. All IS Services in CentraSite

Note:Integration Server (IS) services include rule
services.

All portlets in your workspace. All Portlets in Workspace

All processes in your workspace. All Processes in Workspace

All rule services in CentraSite. All Rule Services in CentraSite

All Web services in CentraSite. All Web Services in CentraSite

All rule services in CentraSite. All Rule Services in CentraSite

24 webMethods BPM and CAF Workspace Metadata Help 10.11

2 Workspace Metadata Search



Use this saved search to locate...webMethodsPredefinedSavedSearch

All Web services in CentraSite. All Web Services in CentraSite

In addition to the predefined saved searches that webMethods provides, you can create additional
saved searcheswhere you define the search criteria. You can delete, rename, and change the criteria
for saved searches that you define.

To add a new saved search, you can:

Create a new saved search where you specify all the criteria.

Duplicate an existing saved search and edit the criteria if you want to add a saved search that
is similar to an existing one.

Import saved searches that were previously exported.

The Saved Searches view is shown by default in the Process Development perspective. If you close
the Saved Searches view and want to reopen it, or if you want to open it in another perspective,
click Window > Show View >  Saved Searches.

For additional information, see webMethods BPM Process Development Help.

Creating Saved Searches
Use a saved search to specify detailed search criteria to locate specific assets. When you create a
saved search, you can define criteria to locate only assets of a single type. For example, you can
define a saved search for portlets or you can define a saved search for IS document types, but you
cannot define a single saved search that locates both portlets and IS document types. You can save
workspace searches, CentraSite searches, or searches of both the workspace and CentraSite.

To create a saved search

1. In Designer, if the Saved Searches view is not visible, display it: Window > Show View > 
Saved Searches.

2. In the Saved Searches view, click Add Saved Search.

3. In the Add Saved Search window, type a Search Name.

4. Select the type of asset you want the saved search to locate from the Asset Type list.

5. For each search criterion you want to use:

a. Click Add.

b. In the Add Query Condition window, click Asset Field and select an item. The items that
Designer includes in the Asset Field list depends on the Asset Type you select.
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Note:
Although Designer will allow any entry in the Provide the Attribute Name to Search
box, the attributemust exist in theWeb service taxonomy in order to return valid results.

c. Complete specifying the condition for the selected Asset Field. Note that the search is not
case sensitive.

d. Click OK.

6. In the Match condition field, select.

Any to have Designer locate assets that match any of the criteria you specified.

All to have Designer locate assets only if they match all of the criteria that you specified.

Note:
If you selectReferences fromAsset Field andAll forMatch condition, Designer finds
assets that contain all the specified references, but those references do not necessarily
have to be all in one place. For example, if you have a condition to locate all processes
that reference processeswith names that contain "HR" and also reference processeswith
a process version that contains "2", Designer might find a process that contains one step
for a referenced processwith the name "HR-Tasks" and a process version "3" and another
step for a referenced process with the name "ApproveOrder" and a process version "2".

7. In the Search in field, click:

Workspace to search metadata in the workspace index only.

Workspace & CentraSite to searchmetadata in both theworkspace index and CentraSite.

8. Click Save.

Duplicating Saved Searches
If youwant to create a saved search that is similar to an existing one, you can duplicate an existing
user-defined saved search and edit its search criteria.

Note:
You cannot edit, rename, or duplicate webMethods predefined saved searches.

To duplicate an existing saved search

1. In Designer, if the Saved Searches view is not visible, display it: Window > Show View > 
Saved Searches.

2. In the Saved Searches view, right-click the saved search you want to duplicate and click
Duplicate Saved Search.
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3. In the Copy Saved Search window, specify a Saved Search Name.

4. Click OK.

You can edit the duplicated saved search to update the search criteria.

Executing Saved Searches
When you execute a saved search, Designer locates assets and/or asset references that match your
search criteria and displays the search results in the Search view.

Note:
If you have workspace indexing disabled now or had it disabled in the past, you might have
assets in your workspace that havemissing or incomplete metadata. In this case, the search will
not properly locate these assets. See “Configuring Workspace Index Preferences” on page 13.

To execute a saved search

1. In Designer, if the Saved Searches view is not visible, display it: Window > Show View > 
Saved Searches.

2. In the Saved Searches view, right-click the saved search youwant to execute and clickExecute
Saved Search.

Tip:
You can also double-click to execute a saved search.

Renaming Saved Searches
You can rename user-defined saved searches.

Note:
You cannot edit, rename, or duplicate webMethods predefined saved searches.

To rename a saved search

1. In Designer, if the Saved Searches view is not visible, display it: Window > Show View > 
Saved Searches.

2. In the Saved Searches view, right-click the saved search youwant to rename and clickRename
Saved Search.

3. In the Rename Saved Searches window, specify a New Saved Search Name.

4. Click OK.
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Editing Saved Searches
You can edit the search criteria for user-defined saved searches.

Note:
You cannot edit, rename, or duplicate webMethods predefined saved searches.

To edit a saved search

1. In Designer, if the Saved Searches view is not visible, display it: Window > Show View > 
Saved Searches.

2. In the Saved Searches view, right-click the saved search you want to edit and click Edit Saved
Search.

3. If you want to rename the Saved Search, update the name in the Search Name field.

4. If you want to change the type of assets the saved search locates, select a new asset type from
the Asset Type list.

Important:
Search criteria is based onAsset Type. If you select a newAsset Typewhile editing a saved
search, Designer removes all existing search criteria, and you must rebuild the search.

5. To modify an existing search criterion:

a. Select the row for the search criterion and click Edit.

b. In the Edit Query Condition window, update the search condition.

c. Click OK.

6. To delete a search criterion, select the row for the search criterion and click Remove.

7. To add a new search criterion:

a. Click Add.

b. In the Add Query Condition window, click Asset Field and select an item. The items that
Designer includes in the Asset Field list depends on the Asset Type you selected.

Note:
Although Designer will allow any entry in the Provide the Attribute Name to Search
box, the attribute must exist in the Web service taxonomy to return valid results.
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c. Complete specifying the condition for the selected Asset Field. Note that the search is not
case sensitive.

d. Click OK.

8. If you want to change whether Designer matches all of the search criteria or any one search
criterion, update the Match condition field. Select:

Any to have Designer locate assets that match any of the criteria you specified.

All to have Designer locate assets only if they match all of the criteria that you specified.

Note:
If you selectReferences fromAsset Field andAll forMatch condition, Designer finds
assets that contain all the specified references, but those references do not necessarily
have to be all in one place. For example, if you have a condition to locate all processes
that reference processeswith names that contain "HR" and also reference processeswith
a process version that contains "2", Designer might find a process that contains one step
for a referenced processwith the name "HR-Tasks" and a process version "3" and another
step for a referenced process with the name "ApproveOrder" and a process version "2".

9. In the Search in field, select:

Workspace to search metadata in the workspace index only.

Workspace & CentraSite to searchmetadata in both theworkspace index and CentraSite.

10. Click Save.

Exporting Saved Searches
You can export all user-defined saved searches to an XML file. You can keep the file as a backup
or use it to import the saved searches into another workspace.

To export all user-defined saved searches

1. In Designer, if the Saved Searches view is not visible, display it: Window > Show View > 
Saved Searches.

2. In the Saved Searches view, click Menu (in the upper right corner) and click  Export Saved
Searches.

3. In the SaveAswindow, select the locationwhere youwant to store your saved searches, specify
a name for the exported XML file, and save the XML file to your file system.
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Importing Saved Searches
You can import user-defined saved searches intoDesigner from anXMLfile that has been exported
from Designer.

To import user-defined saved searches from an XML file

1. In Designer, if the Saved Searches view is not visible, display it: Window > Show View > 
Saved Searches.

2. In the Saved Searches view, click Menu (in the upper right corner) and click Import Saved
Searches.

3. In the Open window, specify the location of the XML file that contains the exported saved
searches you want to import. After locating the XML file, click Open.
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