OnRamp for Commerce One MarketSite 3.5 SP1 | webMethods OnRamp for Commerce One MarketSite Adapter Documentation | webMethods OnRamp for CommerceOne MarketSite Adapter Installation and User’s Documentation | Troubleshooting | Cannot Send Envelopes to MarketSite
 
Cannot Send Envelopes to MarketSite
Problem
You cannot send envelopes to MarketSite. When you test sending envelopes to MarketSite using the Test Send/Receive utility, the HTML representation of your pipeline shows error messages with Java exceptions. When you send envelopes in your production environment, you receive reply envelopes containing errors such as MarketSite cannot verify your user ID or password or your TPID is unknown.
Causes
*Integration Server cannot establish a network connection to MarketSite.
*Your firewall or MarketSite's firewall is preventing the connection from being established.
*Your alias definition for MarketSite is incorrect (for example, the URL you specified as the destination for envelopes you send to MarketSite is invalid).
*At error occurred at MarketSite's end.
Resolutions
*Contact your network administrator and make sure you can establish a TCP/IP connection to MarketSite.
*Contact your network administrator and make sure your firewall allows you to open an outbound communication that reaches the MarketSite host on the specified port. Contact the MarketSite network administrator and make sure MarketSite's firewall allows you to open a connection at the specified host and port.
*Correct your alias definition for MarketSite. Check the URL you specified as the destination for envelopes you send to MarketSite; make sure you are using the correct protocol (HTTP or HTTPS) and have specified the correct host and port. Also check the rest of the URL for accuracy. Make sure you spelled the alias correctly in all relevant C1 OnRamp services.
*Open the C1 OnRamp envelope log and view the contents of the reply envelope to determine the problem.