The NaturalONE Perspective

This document covers the following topics:


Opening the NaturalONE Perspective

To use NaturalONE, open the NaturalONE perspective.

When the NaturalONE perspective is not active, you can open it as described below.

Start of instruction setTo open the NaturalONE perspective

  1. From the Window menu, choose Open Perspective > Other. The Open Perspective dialog box is displayed.

  2. Select NaturalONE and click OK.

    The NaturalONE perspective is opened. The views which are part of the NaturalONE perspective are described in the section below.

Views of the NaturalONE Perspective

The NaturalONE perspective consists of several views, including Natural-specific views and standard Eclipse views. In addition to the Eclipse views shown by default, you can also use any other Eclipse view.

The following list briefly describes the most important views of the NaturalONE perspective (these are the views which are shown by default when you open the NaturalONE perspective for the first time):

  • Project Explorer
    Displays the Natural projects defined in your workspace. Other types of projects (for example, Java projects) will also appear in this view. For more information, see Working with Natural Projects in Local Mode.

  • Natural Navigator
    When no toggle button is selected in the local toolbar of this view, the Natural Navigator view shows the same information as the standard Eclipse Project Explorer view. However, the Natural Navigator view offers enhanced support for Natural projects and allows you to switch on and off different Natural-specific options for displaying your Natural projects in the tree. For more information, see Using the Natural Navigator View.

  • Natural Server
    Uses to make a connection to a Natural server. For more information, see Accessing a Remote Development Environment.

  • Outline
    In this view, the different types of Natural editors show different information. For more information, see Using the Natural Editors.

  • Dependencies
    Shows the dependencies to other Natural objects that are referenced in the active editor window. For more information, see Using the Natural Editors.

  • Properties
    Displays the properties for a selected item. NaturalONE uses this view to display Natural-specific information.

  • Console
    When console output is enabled in the Natural preferences (different types of console output can be enabled there), NaturalONE uses this view to display, for example, information from the Natural builder or output of the internal Tomcat server. You can also open a console in which you can enter Natural system commands. For more information, see Using the Natural Command Console for Mainframes.

  • Problems
    This view displays Natural-specific problems such as compiler errors, parser errors or NATstyle violations. For more information, see Problems in Your Natural Sources and Checking Natural Code with NATstyle.

  • LastMsg
    This view displays additional information about the most recent error. You can enable or disable this functionality by setting the preference Retrieve error messages from runtime environment in the LastMsg tab of the Natural preferences.

    Any time a Natural command is issued, the potentially created error messages in the runtime environment are transferred to NaturalONE and displayed inside this view; for more information, see Using the LastMsg View.

  • Tasks
    Displays the tasks (for example, for programming steps that still need to be done) that have been added to the source code. NaturalONE uses this view to display tasks of "Natural Task" type. For more information, see Working with Tasks.

  • Details
    Displays detailed information on the children of the project, library, or folder that is currently selected in the Project Explorer or Natural Navigator view. For more information, see Using the Details View.

The following Natural-specific views are not displayed by default when you open the NaturalONE perspective:

Editor Area in the NaturalONE Perspective

One of the following Natural editors is displayed in the editor area when you open a Natural object:

  • source editor

  • map editor

  • DDM editor

For more information on the above editors, see Using the Natural Editors.

Other editors are displayed in the editor area, for example, when you open the following items:

Showing a View of the NaturalONE Perspective

If a view in the NaturalONE perspective is not currently displayed, follow these steps to display it.

Start of instruction setTo show a Natural view

  1. From the Window menu, choose Show View > Other. The Show View dialog box is displayed.

  2. Expand the Software AG NaturalONE node and select one or all of the following views:

    • Dependencies

    • Details

    • NATdoc

    • Natural Navigator

    • Natural Server

    • Profiler Sessions

    • Report Data

    • RTL Visual Order

    • Time Stamp Conflicts

    • Unlock Objects

    Notes:

    1. The above views pertain to the basic functionality of NaturalONE as described in this Using NaturalONE documentation. Views in the node that are not listed above are used by other optional components of NaturalONE. See the corresponding documentation for more information.
    2. When you expand the General node in the Show View dialog box, most of the standard Eclipse views, such as the Project Explorer or Outline view, can be selected.
  3. Click OK.

Resetting the NaturalONE Perspective

If you have closed one or more views or moved a view to a different location, you can reset the perspective to restore its default settings.

Start of instruction setTo reset the NaturalONE perspective

  1. Make sure that the NaturalONE perspective is active.

  2. From the Window menu, choose Reset Perspective. A dialog box is displayed.

  3. Click OK to confirm that you want to reset the perspective to its default settings.