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Preface
This documentation explains how to install and use the sample applications that are provided
with NaturalONE. It is organized under the following headings:
Installing the Sample
Applications

How to install the sample applications from the welcome page.

Hello World Application

The Hello World application is the preferred starting point for using
NaturalONE. This is a simple sample which demonstrates a Natural
project which implements a Hello World application by using Natural
for Ajax.

Travel Approval Application

This sample demonstrates a Natural project which implements an Ajax
application for a business travel approval system.

Natural for Ajax Demos

A collection of small Natural for Ajax samples which demonstrate how
to use the different controls and how to bind them to Natural server-side
processing.
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About this Documentation

Document Conventions
Convention

Description

Bold

Identifies elements on a screen.

Monospace font Identifies service names and locations in the format folder.subfolder.service,

APIs, Java classes, methods, properties.
Italic

Identifies:
Variables for which you must supply values specific to your own situation or
environment.
New terms the first time they occur in the text.
References to other documentation sources.

Monospace font Identifies:

Text you must type in.
Messages displayed by the system.
Program code.
{}

Indicates a set of choices from which you must choose one. Type only the information
inside the curly braces. Do not type the { } symbols.

|

Separates two mutually exclusive choices in a syntax line. Type one of these choices.
Do not type the | symbol.

[]

Indicates one or more options. Type only the information inside the square brackets.
Do not type the [ ] symbols.

...

Indicates that you can type multiple options of the same type. Type only the
information. Do not type the ellipsis (...).

Online Information and Support
Software AG Documentation Website
You can find documentation on the Software AG Documentation website at http://documentation.softwareag.com. The site requires credentials for Software AG's Product Support site Empower.
If you do not have Empower credentials, you must use the TECHcommunity website.
Software AG Empower Product Support Website
If you do not yet have an account for Empower, send an email to empower@softwareag.com with
your name, company, and company email address and request an account.
Once you have an account, you can open Support Incidents online via the eService section of
Empower at https://empower.softwareag.com/.
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About this Documentation
You can find product information on the Software AG Empower Product Support website at https://empower.softwareag.com.
To submit feature/enhancement requests, get information about product availability, and download
products, go to Products.
To get information about fixes and to read early warnings, technical papers, and knowledge base
articles, go to the Knowledge Center.
If you have any questions, you can find a local or toll-free number for your country in our Global
Support Contact Directory at https://empower.softwareag.com/public_directory.asp and give us
a call.
Software AG TECHcommunity
You can find documentation and other technical information on the Software AG TECHcommunity
website at http://techcommunity.softwareag.com. You can:
■

Access product documentation, if you have TECHcommunity credentials. If you do not, you
will need to register and specify "Documentation" as an area of interest.

■

Access articles, code samples, demos, and tutorials.

■

Use the online discussion forums, moderated by Software AG professionals, to ask questions,
discuss best practices, and learn how other customers are using Software AG technology.

■

Link to external websites that discuss open standards and web technology.

Data Protection
Software AG products provide functionality with respect to processing of personal data according
to the EU General Data Protection Regulation (GDPR). Where applicable, appropriate steps are
documented in the respective administration documentation.

Sample Applications
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Installing the Sample Applications

When you start the Software AG Designer for the very first time, you will see a so-called “Welcome”
page. From this page, you can install several sample applications for NaturalONE. If the welcome
page is not visible, you can open it as described below.
Important: Before installing a sample application, open the NaturalONE perspective and
wait until the startup of the local Tomcat server has completed. When you start NaturalONE
for the very first time, this will take some time. In the Console view, you can keep track of
the Tomcat status.
To install a sample application
1

From the Help menu of Eclipse, choose Welcome.
The welcome page appears.
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Installing the Sample Applications
2

In the NaturalONE list box, scroll down until you see the following links for the sample applications.

3

To install a sample application, click the corresponding link in the NaturalONE list box.
The sample application is copied to your workspace. The Navigator view is automatically
shown, containing the new sample application as a new project. For example:

Tip: To get more space for the views of the Natural perspective, close the welcome
page.
4

After installing a sample application, it is recommended that you rebuild the project using
the Clean command from the Project menu.
If the Build Automatically command in the Project menu is currently not active, make sure
that Start a build immediately is switched on in the Clean dialog box.
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Hello World Application

About the Sample Application
The Hello World application is the preferred starting point for using NaturalONE. This is a simple
sample which demonstrates a Natural project which implements a Hello World application by
using Natural for Ajax.

Installing the Sample Application
Install the sample application by clicking Hello World application on the welcome page. A new
project named "NaturalONE Hello World Sample Application" will then be shown in the Navigator view. See also Installing the Sample Applications.

Starting the Sample Application
You start your first Natural application by executing the program HELLO-P.NSP in the SAMPL4ONE
library.
To start the sample application
1

In the Navigator view, expand the project NaturalONE Hello World Sample Application.
Note: By default, the environment to which a Natural project pertains is shown next
to the project name. For the sample applications, the environment name is "naturalruntime". This is the local Natural runtime which enables you to execute your applications without having to use a remote development environment. The number in parentheses which is also shown next to the project name indicates the number of Natural
libraries in this project. This is part of the so-called label decoration.
The following screenshot shows the project structure.
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Hello World Application

There are two folders:
■

Natural-Libraries
Natural-Libraries contains the folder SAMP4ONE. This is the Natural library for this
sample application.
SAMP4ONE contains the folder SRC. This folder contains the Natural source files.
HELLO-A.NS8 is the Natural adapter, that is, the Natural interface to the Ajax page.
HELLO-P.NSP is the Natural program which implements this simple Hello World application.

■

User-Interface-Components
User-Interface-Components contains the folder samplecomponents which in turn contains
the folder xml.
helloworld.xml contains the Ajax page layout. This page layout is defined with the Layout
Painter, which is invoked from the context menu with Open With > Layout Painter.
For detailed information about the Natural for Ajax technology, see Natural for Ajax.

2

Select the program HELLO-P.NSP, invoke the context menu and choose Run As > Natural
Application.
The output is now shown.
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3

Enter your name in the Input Area and choose the Say Hello button.
Your name is now shown in the Output Area.
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Travel Approval Application

About the Sample Application
The Travel Support System (this is the name that you can see on the screen when executing the
application) is a small sample application for NaturalONE. As a sample application, its focus is
to show NaturalONE functionality rather than being a full-fledged travel support application.
The Travel Support System (TSS) allows you to request and approve business trips. Flights, hotels
and even more external information such as cell phone expenses or car rentals can be entered with
the trip request. For the destination, weather information can be queried. A manager can do both,
request own trips as well as approve trips that have been requested by employees. After the
manager has approved single or multiple requests, the manager can print an itinerary or receive
the itinerary as a PDF file.
The usage of the travel approval application is described below.

Prerequisites
In order to use the sample application, Adabas Version 6.1.9 or above must be installed and started.

Installing the Sample Application
Install the sample application by clicking Travel Approval application on the welcome page. A
new project named "Travel" will then be shown in the Navigator view. See also Installing the
Sample Applications.

Defining the Use of an External Web Browser
You will now make sure that the sample application is executed in an external web browser and
not in the internal web browser.
To define the use an external web browser
1

From the Window menu, choose Preferences.

2

Expand the General node and select Web Browser.
The following page appears.

12

Sample Applications

Travel Approval Application

3

Select the Use external web browser option button and choose the OK button.

Starting the Sample Application
You start the sample application by executing the program LOGIN.NSP in the TRAVEL library.
To start the sample application
1

In the Navigator view, expand the project Travel.

2

Expand the following nodes:
1. Natural-Libraries
2. TRAVEL
3. SRC
The tree should now look as follows:
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3

Scroll down until you see the program name LOGIN.NSP.

4

Select LOGIN.NSP, invoke the context menu and choose Run As > Natural Application.
The sample application is executed. Since you have specified so in the preferences, it is executed
in an external browser window.
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Travel Approval Application

Logging in as an Employee for Requesting a Business Trip
You will now log in as an employee (with limited rights) and request a business trip.
To log in as an employee
1

In the Please select a User name dialog, type "A" over the name that is currently shown in
the drop-down list box.
The drop-down list box opens, displaying the names of all employees and managers which
start with the letter "A". This information comes from the Adabas demo database.
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2

Select the name "ADKINSON DAVID".

3

Choose the Enter New Request button.
The following screen appears. Here, you will enter your travel request.
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Travel Approval Application

Entering a Travel Request with Flight and Hotel Information
You will now enter and submit your travel request. This includes the following information:
■

City and date for departure.

■

City and date for return flight.

■

Flight number.

■

Hotel name.
To enter a travel request

1

In the Reason text box, enter the reason for your travel plans. For example:

2

Under Departure information, open the drop-down list box.

3

Select Toronto,Canada.

4

Click on Pick a date which is shown to the right of the departure information.

5

In the resulting Date Input dialog, select the desired date for your flight to Toronto (for example, February 21, 2012).

6

Under Return information, open the drop-down list box.
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7

Select Beijing,China.

8

Click on Pick a date which is shown to the right of the return information.

9

In the resulting Date Input dialog, select the desired date for your return flight from Beijing
(for example, February 28, 2012).

You have now entered the basic information needed to make travel plans. Next, you will book
a flight and a hotel.
10

Under Flight Booking, open the drop-down list box.

11

Select Continental Airlines Flight: #4207.
The selected flight is shown under Travel Expenses.
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12

Under Hotel Booking, open the drop-down list box.

13

Select HILTON,150.
The selected hotel is also shown under Travel Expenses, including the costs (7 nights * 150 =
1050). The total cost has also been updated (1827).

14

Choose the Submit Request button.
The Travel Expenses area is closed, and the My Travels area shows the travel details.
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At the bottom of the screen, you can see a message informing you that the travel request has
been accepted (pending approval), and that you can now either create a new request or log
out.

Adding Additional Expenses to Your Travel Request
You will now add additional expenses from a CSV file to your travel request. This is just for
demonstration purposes and you will delete these expenses before you log out.
To add additional expenses
1

Under Other Expenses, choose the Upload .csv button.

The File Upload dialog appears.
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2

Choose the Browse button.

3

In the resulting Choose File to Upload dialog, navigate to the location of your Eclipse workspace. Here, you can find the project directory that has been created for your travel application.
The demo CSV file which comes with the travel application is located in the Expenses folder
of the project and has the name expenses_trip1.csv.

4

Select the file expenses_trip1.csv and choose the Open button.
The path to the selected file is shown in the File Upload dialog.

5

In the File Upload dialog, choose the Upload button.
The contents of the CSV file is shown under Travel Expenses.

You will now delete the two items that were added from the CSV file.
6

Select both lines (press SHIFT or CTRL to select the second line).

7

Choose the Delete rows button.

8

Log out by clicking on the Log-out link which is located at the top right of the screen.
The logon screen containing the Please select a User name dialog is shown again.
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Logging in as a Manager for Approving Travel Requests
In order to approve the travel request you have just entered, you will now log in as a manager.
To log in as a manager
1

In the Please select a User name dialog, open the drop-down list box and select the name
"ARCONADA PEDRO".
For this user, an Approve Requests button is shown which is only available to managers.

2

Choose the Approve Requests button.
The following screen appears, listing the travel requests that are waiting for approval.
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Travel Approval Application

Approving a Travel Request
After you have logged in as a manager, you can approve travel requests.
To approve a travel request
1

Under Department (MGMT) statistics, open the drop-down list box for the different types
of pie charts.

2

Select Pie Exploded Chart.
A different chart is shown, indicating the total travel budget that is available for the department,
and how much of the budget is currently requested.

3

In the table at the bottom left of the screen (below the Submit approved requests button),
double-click the row containing the employee name "DAVID ADKINSON".
A check mark is now shown in front of the row, and a message is shown at the bottom of the
screen informing you that you may submit the approved requests.
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4

Choose the Submit approved requests button.
The following dialog appears, containing the travel details for David Adkinson.

5

Click on the PDF icon (

) at the top right of the dialog.

When appropriate PDF viewing software such as Adobe Reader is installed, the PDF output
is shown and you can print it.
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Natural for Ajax Demos

About the Natural for Ajax Demos
The Natural for Ajax demos show you how to use the different controls and write the corresponding
Natural server-side processing. When you start one of the samples, a corresponding description
is shown which explains the sample and provides implementation hints.

Installing the Natural for Ajax Demos
Install the samples by clicking Natural for Ajax Demos on the welcome page. A new project named
"NaturalAjaxDemos" will then be shown in the Navigator view. See also Installing the Sample
Applications.

Starting the Natural for Ajax Demos
You can start the main program which lets you select single samples by executing the program
MENU-NJX.NSP.
You can also start single samples directly by executing the corresponding program, for example,
CALCUL-P.
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