
SYSERR Utility Window and Functions 
From the SYSERR - Error Messages window, you can invoke all SYSERR utility functions available for
creating and maintaining user-defined or Natural system messages:  

The window is divided into two sections that contain data on messages available in the current library: 

The left section with a list box displaying all messages available for the current language. 

The right section displaying the fields with the text of the current message. The current message is
the message selected (highlighted) in the list box. 

If no message exists for the specified library, both sections are empty. 

The SYSERR - Error Messages window provides menus and command buttons for executing SYSERR
utility functions. As an alternative to menus and command buttons, you can execute most of the functions
by using toolbar buttons. 
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There are context menus available for several elements in the list box and the dialog boxes provided with
the SYSERR functions. To invoke the context menu for an element, click on the element required with the
right mouse button or select the element and press SHIFT+F10. The commands available are either cut
and paste functions or correspond to the commands in the menus or to command buttons. 

Some menu items are used to switch between modes or set a status. The check mark next to a menu item
indicates which mode or status is active. 

This section covers the following topics:

List Box

Fields

Command Buttons

File Menu

Edit Menu

View Menu

Options Menu

Toolbar Buttons

Status Bar

Online Help

List Box 
The list box appears in the left section of the SYSERR - Error Messages window. It contains the short
messages of one language for one library. The short texts are preceded by the message number. The
messages are sorted by the message number in ascending order. 

If  a message file contains more than 200 messages, for performance reasons, not all messages are read in
one step. When initially opening the SYSERR - Error Messages window, up to 200 messages are read
from the message file at once, and about 30 of them are displayed in the list box. Scrolling down the list
with the vertical scroll bar, the next 200 messages are read and displayed as soon as the scroll bar reaches
the bottom of the list box. 

Choose the Read All menu option, to read all remaining messages in one step as described in Edit Menu. 

The selected (highlighted) short message is the current message. It is displayed in the right section of the 
SYSERR - Error Messages window. There, you can modify the short and long texts of the current
message. See also Fields. 
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Fields
The following fields appear in the right section of the SYSERR - Error Messages window: 

Field Explanation 

Samp. Output field that appears above the Num. field if a sample message exists for the current
language and library. 

Samp. displays the text of the sample message. 

To create and use a sample message, see Sample in Options Menu. 

Num. Displays the number of the current message. It  corresponds to the selected message in the list
box. 

To display another message or to create a new one, replace the current number by another valid
number. 

The maximum message number for a library and language is 9999. The message number 0000 is
not allowed. 

Short Modifiable field displaying the short message text of the current message number. 

The input of the short message is mandatory. A new message can only be saved if text has been
entered in the Short field. Therefore, if no text is displayed for the current message, the message
number is free and can be assigned to a new message. 

To extend the default field length, see Short Message Length 72 in Options Menu. 

To copy sample messages into the Short field, see Sample in Options Menu and Copy in 
Command Buttons. 

To copy text from the Short into the Long field, choose Short to Long. 

Long Modifiable fields displaying the long message text of the current message. 

Long consists of three input areas: 

Text Extended version of the short message text. 

Expl. Further explanation of the message. 

Action   The action to be taken to resolve a problem, if relevant. 

The input in Long is optional. 

To copy text from the Short into the Long field, choose Short to Long. 
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Command Buttons 
The following commands can be executed by using command buttons:

Command Explanation 

Copy This button is only visible if a sample message exists for the current language and
library. Copy appears under the toolbar, in the right upper section of the SYSERR -
Error Messages window. 

Copies the text of a sample message (see Sample in Options Menu) into the Short
field (see Fields) of the current message. 

Previous / Add
Previous / Update 

Toggles between Previous and Add, and Previous and Update depending on the
status of the current message: 

Previous   Scrolls from the current message to the previous message if no
modification was made. 

Add Adds a new message to the message file. 

Update Saves the current message to the message file after modification. 

Note:
You can only save a message if text was entered in the Short field (see Fields). 

Next / Reset   Toggles between Next and Reset, depending on the status of the current message: 

Next Scrolls from the current message to the next message if no modification
was made. 

Reset   Resets modifications made to the current message and displays the original
message. 

New Searches for the next free message number starting from the current message, and
opens input fields to create a message for the number found. Free means that this
message number is available and has not been assigned to another message of any
language. 

The search direction is downwards by default. However, the default direction can
change to upwards if a previous search was performed in an upward direction by
using the alternative function New Message (see Edit Menu). 

Upwards searches for the next lower message number, downwards searches for the
next higher message number from the current message. 

As an alternative to New or New Message, you can also create a new message by
replacing the number in the Num. field. 

Short to Long  Copies the text of the Short field to the first line of the Long field. 
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File Menu 
This section describes the functions available in the File menu. 

Function Explanation 

New Lib/Lang Only applies to libraries and languages for which no messages exist. 

Opens a new library and/or adds a new language. See also To switch libraries and/or 
languages. 

Open Lib/Lang Only applies to libraries and languages for which messages already exist. 

Opens another library and/or changes the language.

See also To switch libraries and/or languages. 

Open File This function does not apply for accessing data on mainframe servers. 

Selects an existing message file from a Natural Err directory (FNAT or FUSER) or
from another directory. 

See also the section Generating Message and Text Files. 

Print Invokes the print function.  

A dialog box prompts you to:

Enter the range of messages.

Mark the Long texts printout option if you want to print the long message in
addition to the short message. 

Specify layout parameters and select the output device: Printer  or Source. The
initial assignment is the default printer set by Windows. 

To display the output in the source work area, use the system command LIST. If
required, use the system command SAVE and the Natural object type text to save
the contents of the source work area. 

See also To print all Natural system messages. 

Exit Terminates the SYSERR utility. 

 To print all Natural system messages

1.  Perform the steps described in Invoking SYSERR for Natural System Messages. 

2.  From the File menu, select Print . 

 To switch libraries and/or languages 
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1.  From the File menu, select New Lib/Lang if no messages exist. 

Or:
From the File menu, select Open Lib/Lang if messages exist. 

A SYSERR - New Lib/Lang or SYSERR - Open Lib/Lang dialog box similar to the example
below appears: 

2.  From the Library  drop-down list box, select a library and a language. 

In the example above, the new language code 6 (Dutch) is selected for the library TESTLIB.
TESTLIB already contains messages but no messages for language code 6. 

3.  Choose OK  to confirm your selection. 

An empty SYSERR - Error Messages window appears for the specified library and language. 

Or:
If the Open Lib/Lang menu option was selected, a list of messages appears that exist for the
specified library and language. 

Edit Menu 
This section describes the functions available in the Edit  menu. 
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Command  Explanation 

Cut Supported clipboard functions. 

Copy 

Paste 

Undo Standard edit functions. 

Delete 

New Message Searches for the next free message number starting from the current message, and
opens input fields to create a message for the number found. Free means that this
message number is available and has not been assigned to another message of any
language. 

Upwards or Downwards specifies the search direction: Upwards searches for the next
lower message number, Downwards searches for the next higher message number
from the current message. See also the alternative New command button. 

As an alternative to New Message or the New command button, you can also create a
new message by replacing the number in the Num. field. 

Delete SelectedRemoves all messages selected (highlighted) in the list box. A dialog box prompts you
to confirm the action. 

Delete All Removes all messages displayed in the list box. A dialog box prompts you to confirm
the action. 

When all messages of a message file have been deleted, the message file is deleted too. 

Read All Reads all messages from a message file into the list box in one step. This command
applies to message files with more than 200 messages.
Otherwise, for performance reasons, only 200 messages are read by default when the 
SYSERR - Error Messages window is opened. Additional messages can be displayed
by scrolling down the list box to the end or by using the Read All menu option. 

Translate Supports the creation of messages for different languages. Applies to short messages
only. See To translate languages below.  

 To translate languages

1.  From the Edit  menu, choose Translate. 

A SYSERR - Select Languages dialog box similar to the example below appears: 
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2.  Select one language or more into which you wish to translate the current message and choose OK . 

3.  A SYSERR - Translate dialog box similar to the example below appears: 

4.  The dialog box always lists the current language of the short text (in the example above, English)
in the first position followed by the new language(s) selected in Step 1. 

The SYSERR - Translate dialog box provides the following menu options, command buttons and
fields: 

File > Exit Closes the SYSERR - Translate dialog box and returns to the SYSERR
- Error Messages window. 

Options > Select 
Languages

Invokes a dialog box from which you can select one or more languages
to be added to the current message number (unless selected earlier,
during Step 1). 

Available languages The language code(s) of the language(s) already available for the current
message number.  

Language The code and language of the current language and the new language(s)
selected. 
The current language is always listed in the first position. 

Short Text The text of the short message. 

Previous / Update Same as described for Previous / Update in Command Buttons. 

Reset / Next Same as described for Reset / Next in Command Buttons. 

Help > SYSERR Help Displays help text on SYSERR utility functions. 
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5.  Enter the translation in the Short Text field of the relevant language(s). 

6.  Choose Update. The language code(s) of the new language(s) appears under Available languages. 

View Menu 
This section describes the functions available in the View menu. 

Function Explanation 

Languages Display Provides an overview of the languages available for one message number. You
can choose among the following views: 

  

Compressed   Displays the language code(s) that exists for a short and long
message. For short messages, the language codes are listed
next to Short, for long messages next to Long. 

See also Example of Compressed. 

Extended 
Short

Displays the language code(s) that exists for a short message
next to the message number. 

Extended 
Long

Displays the language code(s) that exists for a long message
next to the message number. 

  

You can keep the SYSERR - Language Display dialog box open while
maintaining messages, and use the Reload command button any time you want
to refresh the overview list. 

  

Filter Display Applies in connection with the Set Filter function. 

If Set Filter is enabled, the Filter Display function displays the short messages
that match the filter criteria defined with the Set Filter function. 

If Filter Display is enabled, the filter criteria specified with the Set Filter function
are displayed above the list box. 

To disable the Filter Display and list all messages, again choose the Filter Display
option from the menu. 

See also Filtering Messages. 

Set Filter Defines a filter for displaying short messages and shows the filtered messages in
the list box. See also Filtering Messages. 

Set Filter must be enabled in order to use the Filter Display function. 
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Example of Compressed

In the example above, the short text (Short) for message number 14 exists in English = (1), German (2),
Spanish (4), and Italian (5). The long text (Long) for message number 14 exists in English (1). 

Filtering Messages

 To filter short messages

1.  From the View menu, choose Set Filter. 

A SYSERR - Set Filter dialog box similar to the example below appears: 
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The dialog box provides the following filtering options:

Filter values There are four fields in which you can enter the character string(s) to be used in
the filter. 

Or  / And / Not You can select one of the following Boolean operators: 

  

Or The filter selects one or more of the character strings entered in 
Filter values. This is the default setting. 

And The filter selects all of the character strings entered in Filter 
values. 

Not The filter selects none of the character strings entered in Filter 
values. 

  

The operator is ignored if you only fill one of the Filter Value fields. 

  

Find whole words If marked (default), the filter only allows searching for entire words and not
parts of words. 

Case sensitive If marked, the filter only allows searching for letters that exactly match the
lower and/or upper case specified. 

2.  Specify the criteria to be used for the filter:

In the example above, the filter selects all short messages that contain both the words buffer and 
pool. 

3.  Choose OK . 

If the search criteria entered match the character strings contained in the short messages, the matches
are displayed in the list box and the Set Filter and Filter Display functions are enabled. 

4.  To remove a filter and list all messages, choose Filter Display to disable the function. 
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If the Set Filter function is enabled, alternatively, you can execute the filter function by choosing Filter 
Display. 

Options Menu 
This section describes the functions available in the Options menu. 

Function Explanation 

Sample Invokes the SYSERR - Maintain Sample Message dialog box where you create a sample message to be
used as a master for creating new short messages or replace the text of existing short messages. 

If you enter the string 0000 anywhere in the SYSERR - Maintain Sample Message dialog box
(combined with text or not), the string 0000 is replaced by the number of the new message or the
current message when copying the message. 

You can define one sample message for each language and library. 

If you created a sample message, the Samp. field appears with the text of the sample message. 

To copy the text of the sample message into the Short field, use the Copy command button (see Edit 
Menu). Alternatively, you can enter .C in the Short field if this field is empty. 

Layout See Layout. 

Shift Short Left If enabled, automatically shifts the text of a short message to the left margin when adding a new message
or choosing Update after modification. 

Short Message
Length 72

This option does not apply to a remote environment located on a UNIX, OpenVMS or mainframe
platform. 

If enabled, the Short field (see Fields) is extended to a maximum input of 72 characters. The default
field length is 65 characters, which is the maximum input in UNIX, OpenVMS and mainframe
environments. 

Size Resizes the dialog box: 

  

Startup Resizes the dialog box to the size it had at startup. 

Full List Box Resizes the dialog box to display the short message in full length. 

  

Confirm Window Enables/disables a pop-up window to confirm: 

The new message number.

That the text of the short message is copied into the first line of the Long field if  Short to Long
was chosen. 

That the text of the sample message (if available) is copied into the Short field if Copy was chosen. 
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Function Explanation 

Import Text File   This function does not apply to a remote environment located on a mainframe platform. 

Imports a text file and converts it into a message file. Note that you always need to specify the full
path of a file. 

  

From (text file)   The name of the text file from which the
message file will be generated. 

  

To (message file)   The name of the message file into which the
text file will be generated. Default is the full
path name of the current library and message
file. 

For user-defined messages, the file name must
be NnnAPMSL.MSG. For Natural system
messages, the file name must be 
NnnLmmmm.MSG. 

  

For further information on file formats and generating message and text files, see the relevant section. 

  

Export Message File This function does not apply to a remote environment located on a mainframe platform. 

Exports a message file and converts it into a text file. Note that you always need to specify the full
path of a file. 

  

From (message file)   The name of the message file from which the text file will be generated.
Default is the full path name of the current library and message file. 

For user-defined messages, the file name must be NnnAPMSL.MSG. For
Natural system messages, the file name must be NnnLmmmm.MSG. 

To (text file)   The name of the text file that will be generated. 

  

For further information on file formats and generating message and text files, see the relevant section. 

  

Layout 

The Layout option allows specification of valid message ranges to categorize messages. Overlapping of
ranges is possible. A new message can only be added if its number is within the range specified in the
layout. 

The layout definition applies to all languages. It is stored in the English message file. 

An example layout definition is shown below:
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In the fields From and To, specify the message range. In the Description field, enter text that describes
the message category. 

To insert or delete rows, mark a row and press the INS or DEL key. If the maximum of 18 rows is
displayed, you may have to delete or overwrite another row before you can insert a new one. 

Toolbar Buttons
The toolbar buttons represent the following menu items or command buttons: 
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Toolbar Button Menu Item/Command Button Menu 

New Lib/Lang File 

Open Lib/Lang File 

Print  File 

Exit File 

Cut Edit  

Copy Edit  

Paste Edit  

Undo Edit  

New Message > Upwards Edit  

New Message > Downwards Edit  

Read All Edit  

Translate Edit  

Filter Display View 

Sample Options 

Layout Options 

Size > Startup Options 

Import Text File Options 

Export Message File Options 

Previous - 

Next - 

Update - 

Reset - 

Status Bar
The status bar on the bottom of the SYSERR - Error Messages window displays the following: 

The total number of messages that exist in the specified library for the current language, the possible
message range 1 to 9999, and the last message number used. 

This information is only displayed when initializing SYSERR, opening another library or when using
the Read All menu option described under Edit Menu. 

Natural system messages or the ID of the current library.

The code and name of the current language.
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Online Help
You can obtain online information on using the SYSERR utility.

 To view the overview of the online documentation

Choose the Help menu. 

Or:
Press F1 when no dialog box is open. 

The overview page of the SYSERR Utility documentation appears. 

 To view context-sensitive help

Choose the Help button in a dialog box. 

Or:
Press F1 in a dialog box. 

Help information specific to the task you are performing appears. 
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