§ software

webMethods EntireX

Calling REST from COBOL

Version 10.9

April 2023

WEBMETHODS



This document applies to webMethods EntireX Version 10.9 and all subsequent releases.
Specifications contained herein are subject to change and these changes will be reported in subsequent release notes or new editions.

Copyright © 1997-2023 Software AG, Darmstadt, Germany and/or Software AG USA, Inc., Reston, VA, USA, and/or its subsidiaries
and/or its affiliates and/or their licensors.

The name Software AG and all Software AG product names are either trademarks or registered trademarks of Software AG and/or
Software AG USA, Inc. and/or its subsidiaries and/or its affiliates and/or their licensors. Other company and product names mentioned
herein may be trademarks of their respective owners.

Detailed information on trademarks and patents owned by Software AG and/or its subsidiaries is located at
http://softwareag.com/licenses.

Use of this software is subject to adherence to Software AG's licensing conditions and terms. These terms are part of the product
documentation, located at http://softwareag.com/licenses/ and/or in the root installation directory of the licensed product(s).

This software may include portions of third-party products. For third-party copyright notices, license terms, additional rights or re-
strictions, please refer to "License Texts, Copyright Notices and Disclaimers of Third-Party Products". For certain specific third-party
license restrictions, please refer to section E of the Legal Notices available under "License Terms and Conditions for Use of Software AG
Products / Copyright and Trademark Notices of Software AG Products". These documents are part of the product documentation,
located at http://softwareag.com/licenses and/or in the root installation directory of the licensed product(s).

Use, reproduction, transfer, publication or disclosure is prohibited except as specifically provided for in your License Agreement with
Software AG.

Document ID: EXX-EEXXSCENARIO-REST2COB-109-20230403



Table of Contents

Calling REST from COBOL .........ccccoiiiiiiiiiiiiiiiiiicicc e v
1 About this DOCUMENTAION ....covvuiieeiiiieiiiiiieee e e e eee e e e e e e e e eeeeeeeeeeeeeaaaas 1
Document CONVENTIONS .....cceeiiiiiiiiiiiieieeeeeeeeiiiiiieeeeeeeeeeetriieaaeeeeeeeerasreaaaeeeessessrsnnaaans 2
Online Information and SUPPOTt .......c.ccieiiiiiiiiiii 2
| DN =10 B 0] {=ai u o) o PPN RUPPRRRRPNE 3
2 Calling REST from COBOL under z/OS ............cccoiiiiiiiiiiiiiiiiiiicicccc 5
3 Calling REST from COBOL under z/OS CICS .........cccciiiiiiiiiiiiiicieieceece e 7
| FalunoTe 18T uTo) o NUNURRNNNR SRS OU SO OUURUURUUPRPRRRPPPRt 8
What do I need to Install for this SCENATIO? .....ccoeeeeeeeeeeeeeeeeeeeeeeeeee e 9
Task 1: Create the Consumer REST API Descriptor, Connections and
| IR TS] (<) TS - S USROS 9
Task 2: Generate Client Interface Objects and Build Client Application ................. 16
Task 3: Execute the Call from COBOL to REST ......cccoovvviiiiiiiiiiiiiieeeeeeeeeeeeeeeeee 21
4 Calling REST from COBOL under z/OS Batch ..........cccooviiiiiiiiiiiiiiiiiecciicecee 23
| FaluneYe 1E T To) s AUURUUURUTI T U TP U PP UPUPPPPPPPPPR 24
What do I need to Install for this SCeNario? .............cveeeeeeiiiiieiiiiieeeeeeeeeeeeiceeee e, 25
Task 1: Create the Consumer REST API Descriptor, Connections and
| IR TS] (<) T =T TS UUUP OIS 25
Task 2: Generate Client Interface Objects and Build Client Application ................. 32
Task 3: Execute the Call from COBOL to REST ......coovvuiiieiiiiiieeeeeeeeeeeeee e 36
5 Calling REST from COBOL under z/OS IMS ...........cccociiiiiiiiiiiiiiiiiieeec 39
INETOAUCHON coeviiiiiiiiiiiiiiiiieeeeeeeeeeeeeeeeeeeeee ettt e eeeeeeeeeeeeeeeeeeseeeeeeeeeseesseeasssesreesesereseseaeeees 40
What do I need to Install for this SCeNario? .............cveeeeeeeieiieiiiiiieee e e, 41
Task 1: Create the Consumer REST API Descriptor, Connections and
| IR TS] (<) T o= T USSP U UPTPION 41
Task 2: Generate Client Interface Objects and Build Client Application ................. 48
Task 3: Execute the Call from COBOL to REST ......ccooovvviiiiiiiiiiiieieeeeeeeeeeeeeeeeee 52
6 Calling REST from COBOL under z/OS IDMS/DC ..o, 55
INELOAUCHON coetiviiiiiiiieeieeeeeeeeeeeeeeeee ettt ettt et e eeeeeeeeeeeeeeeeeeseeeseesaeeseesesaeeresereaeaereeees 56
What do I need to Install for this SCeNario? .............veeeeeeeiiiieiiiiieeeeeeeeeeeeiceeee e e, 57
Task 1: Create the Consumer REST API Descriptor, Connections and
| IR TS] (<) < o= TS UUTU PPN 57
Task 2: Generate Client Interface Objects and Build Client Application ................. 64
Task 3: Execute the Call from COBOL to REST .......cooovvviviviiiiiiiiiiiiieieeeeeeeeeeeeeeee 68
7 Calling REST from COBOL under BS2000 ..........c.cccooviiiiiiiiiiiii 71
| FaluneYe 10T uTo) o NUURUUURUUUO PP PP PPUPUPPPPPPPPP 72
What do I need to Install for this SCeNario? .............veeeeeeeiiieeieiiieeeeeeeeeeeeiieeee e 73
Task 1: Create the Consumer REST API Descriptor, Connections and
LISTOIIOIS .ovueiiiii ettt et ettt e ettt e e e et e e e e e s ee e e s e bt e e e saateeeeartaeeraraaaaeaas 73
Task 2: Generate Client Interface Objects and Build Client Application ................. 80
Task 3: Execute the Call from COBOL to REST .......cooovvvvviiiiiiiiiiiieieeeeeeeeeeeeeeeeeeee 84
8 Calling REST from COBOL under z/VSE CICS ...........c.ccooiiiiiiiiiiiiiicccc, 87
| FaluneYe 1E Tl To) o NUUUUUURUU TP PP UPUPPPPRPPPP 88




Calling REST from COBOL

What do I need to Install for this Scenario? ..........cccccceeiiiiiiiii 89
Task 1: Create the Consumer REST API Descriptor, Connections and
| TS (<5 U= =TS 89
Task 2: Generate Client Interface Objects and Build Client Application ................. 96
Task 3: Execute the Call from COBOL to REST ... 101
9 Calling REST from COBOL under z/VSE Batch ..........c.ccccooviiiiiiiiiiiii 103
| HaLu o Yo 18T To) o N 104
What do I need to Install for this SCENArio? .......cccceeeveeeiereiiieiiiiiiiiieiiieeeeeeeeennnnns 105
Task 1: Create the Consumer REST API Descriptor, Connections and
| TS (S5 S =T PR 105
Task 2: Generate Client Interface Objects and Build Client Application ............... 112
Task 3: Execute the Call from COBOL to REST ... 116
10 Calling REST from COBOL under IBM i .......ccccoocuiiiiiiiiiiiiiiiiiiiiiiiece, 119
| HaLa o Yo 18T To) o NN 120
What do I need to Install for this SCeNArio? .......ccceeeeveieieieiiiiiiieieieieeiieeeeeeeeennnns 121
Task 1: Create the Consumer REST API Descriptor, Connections and
| IS (<5 S =T ORPPPN 121
Task 2: Generate Client Interface Objects and Build Client Application ............... 128
Task 3: Execute the Call from COBOL to REST ...t 132

Calling REST from COBOL



Calling REST from COBOL




vi



1 About this Documentation

B DOCUMENT CONVENTIONS ...ttt e e e e e e e
= Online Information and SUPPOM ........coiiiiiiiiiii e
B DAt PrO OO ON ..o e




About this Documentation

Document Conventions
Convention Description
Bold Identifies elements on a screen.

Monospace font

Identifies service names and locations in the format folder.subfolder.service,
APIs, Java classes, methods, properties.

Italic

Identifies:

Variables for which you must supply values specific to your own situation or
environment.

New terms the first time they occur in the text.

References to other documentation sources.

Monospace font

Identifies:

Text you must type in.
Messages displayed by the system.
Program code.

Indicates a set of choices from which you must choose one. Type only the information
inside the curly braces. Do not type the { } symbols.

Separates two mutually exclusive choices in a syntax line. Type one of these choices.
Do not type the | symbol.

Indicates one or more options. Type only the information inside the square brackets.
Do not type the [ ] symbols.

Indicates that you can type multiple options of the same type. Type only the
information. Do not type the ellipsis (...).

Online Information and Support

Product Documentation

You can find the product documentation on our documentation website at https://documenta-
tion.softwareag.com.

In addition, you can also access the cloud product documentation via https://www.software-
ag.cloud. Navigate to the desired product and then, depending on your solution, go to “Developer
Center”, “User Center” or “Documentation”.

Product Training

You can find helpful product training material on our Learning Portal at https://knowledge.soft-

wareag.com.
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About this Documentation

Tech Community

You can collaborate with Software AG experts on our Tech Community website at https://tech-
community.softwareag.com. From here you can, for example:

® Browse through our vast knowledge base.

" Ask questions and find answers in our discussion forums.

Get the latest Software AG news and announcements.

Explore our communities.
® Go to our public GitHub and Docker repositories at https://github.com/softwareag and ht-
tps://hub.docker.com/publishers/softwareag and discover additional Software AG resources.

Product Support

Support for Software AG products is provided to licensed customers via our Empower Portal at
https://empower.softwareag.com. Many services on this portal require that you have an account.
If you do not yet have one, you can request it at https://empower.softwareag.com/register. Once
you have an account, you can, for example:

® Download products, updates and fixes.

® Search the Knowledge Center for technical information and tips.

" Subscribe to early warnings and critical alerts.

Open and update support incidents.

Add product feature requests.

Data Protection

Software AG products provide functionality with respect to processing of personal data according
to the EU General Data Protection Regulation (GDPR). Where applicable, appropriate steps are
documented in the respective administration documentation.
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2 Calling REST from COBOL under z/0S

Under z/OS, the Integration Server can be called from a COBOL client in different environments.

© Use IDL Extractor for Integration Server to generate Integration Server connections and
listeners from the Integration Server service to be called.

@ Generate client interface objects and build COBOL client application.
© Execute the call from the COBOL client to the Integration Server service.

Continue with the appropriate scenario:

= CICS

® Batch

= IMS

= IDMS/DC







3 Calling REST from COBOL under z/OS CICS
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Calling REST from COBOL under z/OS CICS

This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.

8 Calling REST from COBOL



Calling REST from COBOL under z/OS CICS
el EntireX EntirsX REST
Client < > < > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g R: EIT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

" You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

" Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

® For z/OS, see Installing EntireX Broker under z/OS in the z/OS Installation documentation

® On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Step 3: Install the Broker Stubs and Bind the Broker Stub Executables in the z/OS Install-
ation documentation.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction
= Creating a Consumer REST API Descriptor
= Extracting the Interface of the webMethods IS Service

Calling REST from COBOL 9



Calling REST from COBOL under z/OS CICS

= Creating Listener Objects in Integration Server
= Testing the Extraction Results (Optional)

Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= 3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1  Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create a new REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.

10 Calling REST from COBOL



Calling REST from COBOL under z/OS CICS

workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

@& Wmf o D.le.l.e. } Flat File Schema Select th

Wmi - Flow Service o

& Folder

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.

Or:

Press Ctrl-N to start the selection of the New Wizards.

Calling REST from COBOL 11



Calling REST from COBOL under z/OS CICS

3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.

12 Calling REST from COBOL



Calling REST from COBOL under z/OS CICS

Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available

Calling REST from COBOL 13



Calling REST from COBOL under z/OS CICS

IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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Calling REST from COBOL under z/OS CICS

3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).

Calling REST from COBOL 15



Calling REST from COBOL under z/OS CICS

< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

16
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Calling REST from COBOL under z/OS CICS

= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating
system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective
> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

EntireX COBOL Wrapper | Set operating system |

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

VsE
Interface Type: | CICS wit BS2000

i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:

IDL Prograrm Client name
@Pplaceﬂrder ORDERCLT!

2 From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

3  Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.

4  Setthe appropriate interface type for the generated client interface objects to your application.
The options available for CICS are Standard Linkage Calling Convention and DFHCOM-
MAREA Calling Convention. These are described below.

Calling REST from COBOL 17



Calling REST from COBOL under z/OS CICS

® Standard Linkage Calling Convention

Client Application

ch:tL 0 Ll | 0 RFC : “ Broker
P € » Interface <P Service - Stub
rogram Object 1 -
Object 2
Object n
| supplied by EntireX
generated written by customer

) callinterface

The COBOL Wrapper can be used with a call interface, even in CICS. This means you can
build a client application where the COBOL client program, every generated client interface
object, the generic RPC services module and the broker stub are linked together, similar to
the batch scenario. See Using the COBOL Wrapper for Batch (z/OS, BS2000, z/VSE and IBM i).
Using a call interface within CICS may be useful in the following situations:

* The restriction of the COMMAREA length (about 31 KB) prevents you from using the
scenario Using the COBOL Wrapper for CICS with DFHCOMMAREA Calling Convention (z/OS
and z/VSE) (see above).

® You do not require a distributed program link (CICS DPL) to your client interface object(s).
" You prefer a call interface instead of EXEC CICS LINK to your client interface objects.
* DFHCOMMAREA Calling Convention

18 Calling REST from COBOL



Calling REST from COBOL under z/OS CICS

Client Application

COBOL Generic
0 client | @ RPC e Broker

Client L
Program B > IS:;:;C,T *l > Service <« > Stub
Module
Object 2
Object n

| 5upplied by EntireX

QEF‘IE"EIEd written by customer

€@ =xEc ¢

@) call interface

In this scenario, the generic RPC services module and the broker stub are linked together
to a CICS program. The COBOL client program, every generated client interface object and
the generic RPC services module together with the broker stub are installed each as separate
individual CICS programs. Use the COBOL Wrapper with this calling convention in the
following situations:

* You want to have an EXEC CICS LINK DFHCOMMAREA interface to your client interface
object(s).

* The restriction of the COMMAREA length suits your purposes. Because the RPC commu-
nication area is also transferred in the COMMAREA, the effective length that can be used
for IDL data is shorter than the CICS COMMAREA length. Nearly 31 KB can be used for
IDL data.

® You wish to separate the generic RPC service module and the broker stub from the client
interface object(s).

" You require a program link to the client interface object(s).

Generating COBOL Code

~ To generate COBOL code

= For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:

Calling REST from COBOL 19



Calling REST from COBOL under z/OS CICS

ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f& Package Explorer &3 = O
Bk e e e R R e o o o o o e <'::.C::.‘?'| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
. oL L ORDERCLT 52 » _iﬁ JF{.E System Library [JavaSE-1.8]
# TDL Pk EDp'-,IbDDk |'= HH 4 & client
* . 2| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|= 4 = include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT s OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* 1*  Template Source = cobel include.tpl 3Revision: 1.55 §
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C 17
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJE,LHH——‘_/‘

The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
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this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.

Building the Client Application

Depending on the chosen interface type of your client interface objects (CICS with Standard
Linkage Calling Convention or CICS with DFHCOMMAREA Calling Convention under Setting
Generation Options (Properties) for the COBOL Wrapper, refer to

= Using the COBOL Wrapper for CICS with Call Interfaces (z/OS and z/VSE)
® Using the COBOL Wrapper for CICS with DFHCOMMAREA Calling Convention (z/OS and z/VSE)

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Liztener Hame & * Package Mame & ¥  Sigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5  For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 13

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true
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This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.
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COBGL EntireX EntireX REST
Client -« > « > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g R: EIT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

" You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

" Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

® For z/OS, see Installing EntireX Broker under z/OS in the z/OS Installation documentation

® On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Step 3: Install the Broker Stubs and Bind the Broker Stub Executables in the z/OS Install-
ation documentation.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction
= Creating a Consumer REST API Descriptor
= Extracting the Interface of the webMethods IS Service
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= Creating Listener Objects in Integration Server
= Testing the Extraction Results (Optional)

Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= 3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1  Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create a new REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.
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workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

@& Wmf o D.le.l.e. } Flat File Schema Select th

Wmi - Flow Service o

& Folder

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.

Or:

Press Ctrl-N to start the selection of the New Wizards.
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3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.
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Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available
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IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

32
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= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating
system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective
> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

EntireX COBOL Wrapper | Set operating system |

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

WSE
Interface Type: | CICS wit BS2000
i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:
IDL Prograrm Client name
@p FI-lECEG rder ORDERCLT

2 From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

3  Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.
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Generating COBOL Code

- To generate COBOL code

m  For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:

ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f% Package Explorer 52 = B
Bk e e e R R e o o o o o e %| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
= 1pL L5 ORDERCLT &3 > B JRE System Library [JavaSE-18]
* IDL Pi|###ssssssressss {:Dp",-rbDDk ||: EE 4 (& client
* . =| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|=* 4 (= include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT iy OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* |*  Template Source = cobol include.tpl $Revision: 1.55 %
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C W
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJC/FJ(._H__‘J_
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The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.
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Building the Client Application

Client Application
COBOL Generi
Nk Client i RO Nk Broker
> > Service > Stub
Module

Client Interface
| supplied by EntireX

Program _ Object 1

Object 2
Object n

generated written by customer

) call interface

In this scenario, the COBOL client program, every generated client interface object, generic RPC
services module and the broker stub are linked together to the client application.

See Using the COBOL Wrapper for Batch (z/OS, BS2000, z/VSE and IBM i).

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement I Enabled | :

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.
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4  This step depends on the method used to call the server (see Task 3 in the Introduction).
® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).
® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).
5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
< Broker: | localhost: 1971 @
Pocal | [ Fing ] [ Open Conversation ] [ Reset ] [ Exit ]
Messages
2 OrderItemID (M5) 45
2 OrderQuantity (M10) 13
2 OrderCustomerID (I4) 234
2 OrderItemMame (A53) tennis racquet
2 OrderUnitPrice (A20) 79.89 GBP
2 OrderTotal (A20) 1438.02 GBP
3 Mame (A29) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road
3 City (A99) Wimbledon Londaon
3 ZipCode (A20) SW19 SAE
3 CountryCode (A20) LK
2 OrderShippingDate (A256)|Your order will be shipped on Wed, Jul 27, 2016,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true
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This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.
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el EntireX EntirsX REST
Client -« > - > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g R: EIT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

" You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

" Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

® For z/OS, see Installing EntireX Broker under z/OS in the z/OS Installation documentation

® On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Step 3: Install the Broker Stubs and Bind the Broker Stub Executables in the z/OS Install-
ation documentation.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction
= Creating a Consumer REST API Descriptor
= Extracting the Interface of the webMethods IS Service
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= Creating Listener Objects in Integration Server
= Testing the Extraction Results (Optional)

Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= 3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1  Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create a new REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.
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workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

@& Wmf o D.le.l.e. } Flat File Schema Select th

Wmi - Flow Service o

& Folder

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.

Or:

Press Ctrl-N to start the selection of the New Wizards.
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3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.
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Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available
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IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

48
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= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating
system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective
> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

EntireX COBOL Wrapper | Set operating system |

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

WSE
Interface Type: | CICS wit BS2000
i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:
IDL Prograrm Client name
@p FI-lECEG rder ORDERCLT

2 From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

3  Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.
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Generating COBOL Code

- To generate COBOL code

m  For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:

ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f% Package Explorer 52 = B
Bk e e e R R e o o o o o e %| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
= 1pL L5 ORDERCLT &3 > B JRE System Library [JavaSE-18]
* IDL Pi|###ssssssressss {:Dp",-rbDDk ||: EE 4 (& client
* . =| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|=* 4 (= include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT iy OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* |*  Template Source = cobol include.tpl $Revision: 1.55 %
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C W
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJC/FJ(._H__‘J_
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The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.
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Building the Client Application

Client Application
COBOL Generi
Nk Client i RO Nk Broker
> > Service > Stub
Module

Client Interface
| supplied by EntireX

Program _ Object 1

Object 2
Object n

generated written by customer

) call interface

In this scenario, the COBOL client program, every generated client interface object, generic RPC
services module and the broker stub are linked together to the client application.

See Using the COBOL Wrapper for IMS (z/OS).

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement I Enabled | :

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.
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4  This step depends on the method used to call the server (see Task 3 in the Introduction).
® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).
® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).
5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
< Broker: | localhost: 1971 @
Pocal | [ Fing ] [ Open Conversation ] [ Reset ] [ Exit ]
Messages
2 OrderItemID (M5) 45
2 OrderQuantity (M10) 13
2 OrderCustomerID (I4) 234
2 OrderItemMame (A53) tennis racquet
2 OrderUnitPrice (A20) 79.89 GBP
2 OrderTotal (A20) 1438.02 GBP
3 Mame (A29) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road
3 City (A99) Wimbledon Londaon
3 ZipCode (A20) SW19 SAE
3 CountryCode (A20) LK
2 OrderShippingDate (A256)|Your order will be shipped on Wed, Jul 27, 2016,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true
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This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.
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el EntireX EntirsX REST
Client > < > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g R: EIT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

" You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

" Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

® For z/OS, see Installing EntireX Broker under z/OS in the z/OS Installation documentation

® On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Step 3: Install the Broker Stubs and Bind the Broker Stub Executables in the z/OS Install-
ation documentation.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction
= Creating a Consumer REST API Descriptor
= Extracting the Interface of the webMethods IS Service
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= Creating Listener Objects in Integration Server
= Testing the Extraction Results (Optional)

Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= 3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1  Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create a new REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.
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workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

Wmi o Flow Service o
= &= Folder

@& Wmf o D.le.l.e. } Flat File Schema Select th

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press Ctrl-N to start the selection of the New Wizards.
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3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.
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Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available
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IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

64

Calling REST from COBOL



Calling REST from COBOL under z/OS IDMS/DC

= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating
system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective

> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

EntireX COBOL Wrapper | Set operating system |

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

WSE
Interface Type: | CICS wit BS2000
i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:
IDL Prograrm Client name
@p FI-lECEG rder ORDERCLT

2 From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

3  Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.
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Generating COBOL Code

- To generate COBOL code

m  For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:

ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f% Package Explorer 52 = B
Bk e e e R R e o o o o o e %| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
= 1pL L5 ORDERCLT &3 > B JRE System Library [JavaSE-18]
* IDL Pi|###ssssssressss {:Dp",-rbDDk ||: EE 4 (& client
* . =| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|=* 4 (= include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT iy OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* |*  Template Source = cobol include.tpl $Revision: 1.55 %
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C W
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJC/FJ(._H__‘J_
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The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.
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Building the Client Application

Client Application
COBOL Generi
Nk Client i RO Nk Broker
> > Service > Stub
Module

Client Interface
| supplied by EntireX

Program _ Object 1

Object 2
Object n

generated written by customer

) call interface

In this scenario, the COBOL client program, every generated client interface object, generic RPC
services module and the broker stub are linked together to the client application.

See Using the COBOL Wrapper for IDMS/DC with Call Interfaces (z/OS).

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement I Enabled | :

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.
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4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).

<H-E!mkﬂr: localhost: 1971 @

Pocal | [ Fing ] [ Open Conversation ] [ Reset ] [ Exit ]
Messages

2 OrderItemID (M5) 45

2 OrderQuantity (M10) 13

2 OrderCustomerID (I4) 234

2 OrderItemMame (A53) tennis racquet

2 OrderUnitPrice (A20) 79.89 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A29) The All England Lawn Tennis Club (Championships) Limited

3 Street (A99) Church Road

3 City (A99) Wimbledon Londaon

3 ZipCode (A20) SW19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)|Your order will be shipped on Wed, Jul 27, 2016,

2 OrderConfirmation (A256) | Your order is confirmed.

2 OrderConfirmationFlag (L) |true
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This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.
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COBGL EntireX EntireX REST
Client < > « > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g ﬁT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Administering Broker Stubs in the BS2000 Administration documentation.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction

= Creating a Consumer REST API Descriptor

= Extracting the Interface of the webMethods IS Service
= Creating Listener Objects in Integration Server
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= Testing the Extraction Results (Optional)
Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= a3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1 Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create anew REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.
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workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

@& Wmf o D.le.l.e. } Flat File Schema Select th

Wmi - Flow Service o

& Folder

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.

Or:

Press Ctrl-N to start the selection of the New Wizards.
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3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.
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Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available
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IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

80
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= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating
system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective
> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

EntireX COBOL Wrapper | Set operating system |

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

WSE
Interface Type: | CICS wit BS2000
i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:
IDL Prograrm Client name
@p FI-lECEG rder ORDERCLT

2 From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

3  Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.
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Generating COBOL Code

- To generate COBOL code

m  For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:

ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f% Package Explorer 52 = B
Bk e e e R R e o o o o o e %| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
= 1pL L5 ORDERCLT &3 > B JRE System Library [JavaSE-18]
* IDL Pi|###ssssssressss {:Dp",-rbDDk ||: EE 4 (& client
* . =| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|=* 4 (= include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT iy OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* |*  Template Source = cobol include.tpl $Revision: 1.55 %
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C W
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJC/FJ(._H__‘J_
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The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.
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Building the Client Application

Client Application
COBOL Generi
Nk Client i RO Nk Broker
> > Service > Stub
Module

Client Interface
| supplied by EntireX

Program _ Object 1

Object 2
Object n

generated written by customer

) call interface

In this scenario, the COBOL client program, every generated client interface object, generic RPC
services module and the broker stub are linked together to the client application.

See Using the COBOL Wrapper for Batch (z/OS, BS2000, z/VSE and IBM i).

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement I Enabled | :

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.
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4  This step depends on the method used to call the server (see Task 3 in the Introduction).
® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).
® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).
5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
< Broker: | localhost: 1971 @
Pocal | [ Fing ] [ Open Conversation ] [ Reset ] [ Exit ]
Messages
2 OrderItemID (M5) 45
2 OrderQuantity (M10) 13
2 OrderCustomerID (I4) 234
2 OrderItemMame (A53) tennis racquet
2 OrderUnitPrice (A20) 79.89 GBP
2 OrderTotal (A20) 1438.02 GBP
3 Mame (A29) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road
3 City (A99) Wimbledon Londaon
3 ZipCode (A20) SW19 SAE
3 CountryCode (A20) LK
2 OrderShippingDate (A256)|Your order will be shipped on Wed, Jul 27, 2016,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true
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This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.
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il EntireX EntireX REST
Client -« > « > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g ﬁT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Administering Broker Stubs under z/VSE in the z/VSE Administration documentation.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction

= Creating a Consumer REST API Descriptor

= Extracting the Interface of the webMethods IS Service
= Creating Listener Objects in Integration Server
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= Testing the Extraction Results (Optional)
Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= a3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1 Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create anew REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.
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workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

@& Wmf o D.le.l.e. } Flat File Schema Select th

Wmi - Flow Service o

& Folder

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.

Or:

Press Ctrl-N to start the selection of the New Wizards.
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3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.
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Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available
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IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

96
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= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating
system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective
> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

EntireX COBOL Wrapper | Set operating system |

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

VsE
Interface Type: | CICS wit BS2000

i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:

IDL Prograrm Client name
@Pplaceﬂrder ORDERCLT!

2 From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

3  Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.

4  Setthe appropriate interface type for the generated client interface objects to your application.
The options available for CICS are Standard Linkage Calling Convention and DFHCOM-
MAREA Calling Convention. These are described below.
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® Standard Linkage Calling Convention

Client Application

ch:tL 0 Ll | 0 RFC : “ Broker
P € » Interface <P Service - Stub
rogram Object 1 -
Object 2
Object n
| supplied by EntireX
generated written by customer

) callinterface

The COBOL Wrapper can be used with a call interface, even in CICS. This means you can
build a client application where the COBOL client program, every generated client interface
object, the generic RPC services module and the broker stub are linked together, similar to
the batch scenario. See Using the COBOL Wrapper for Batch (z/OS, BS2000, z/VSE and IBM i).
Using a call interface within CICS may be useful in the following situations:

* The restriction of the COMMAREA length (about 31 KB) prevents you from using the
scenario Using the COBOL Wrapper for CICS with DFHCOMMAREA Calling Convention (z/OS
and z/VSE) (see above).

® You do not require a distributed program link (CICS DPL) to your client interface object(s).
" You prefer a call interface instead of EXEC CICS LINK to your client interface objects.
* DFHCOMMAREA Calling Convention
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Client Application

COBOL Generic
0 client | @ RPC e Broker

Client L
Program B > IS:;:;C,T *l > Service <« > Stub
Module
Object 2
Object n

| 5upplied by EntireX

QEF‘IE"EIEd written by customer

€@ =xEc ¢

@) call interface

In this scenario, the generic RPC services module and the broker stub are linked together
to a CICS program. The COBOL client program, every generated client interface object and
the generic RPC services module together with the broker stub are installed each as separate
individual CICS programs. Use the COBOL Wrapper with this calling convention in the
following situations:

* You want to have an EXEC CICS LINK DFHCOMMAREA interface to your client interface
object(s).

* The restriction of the COMMAREA length suits your purposes. Because the RPC commu-
nication area is also transferred in the COMMAREA, the effective length that can be used
for IDL data is shorter than the CICS COMMAREA length. Nearly 31 KB can be used for
IDL data.

® You wish to separate the generic RPC service module and the broker stub from the client
interface object(s).

" You require a program link to the client interface object(s).

Generating COBOL Code

~ To generate COBOL code

= For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:
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ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f& Package Explorer &3 = O
Bk e e e R R e o o o o o e <'::.C::.‘?'| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
. oL L ORDERCLT 52 » _iﬁ JF{.E System Library [JavaSE-1.8]
# TDL Pk EDp'-,IbDDk |'= HH 4 & client
* . 2| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|= 4 = include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT s OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* 1*  Template Source = cobel include.tpl 3Revision: 1.55 §
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C 17
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJE,LHH——‘_/‘

The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
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this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.

Building the Client Application

Depending on the chosen interface type of your client interface objects (CICS with Standard
Linkage Calling Convention or CICS with DFHCOMMAREA Calling Convention under Setting
Generation Options (Properties) for the COBOL Wrapper, refer to

= Using the COBOL Wrapper for CICS with Call Interfaces (z/OS and z/VSE)
® Using the COBOL Wrapper for CICS with DFHCOMMAREA Calling Convention (z/OS and z/VSE)

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Liztener Hame & * Package Mame & ¥  Sigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5  For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 13

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true
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This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.
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il EntireX EntireX REST
Client -« > « > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g ﬁT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Administering Broker Stubs under z/VSE in the z/VSE Administration documentation.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction

= Creating a Consumer REST API Descriptor

= Extracting the Interface of the webMethods IS Service
= Creating Listener Objects in Integration Server
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= Testing the Extraction Results (Optional)
Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= a3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1 Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create anew REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.
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workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

@& Wmf o D.le.l.e. } Flat File Schema Select th

Wmi - Flow Service o

& Folder

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.

Or:

Press Ctrl-N to start the selection of the New Wizards.
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3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.
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Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available
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IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

12
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= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating
system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective
> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

EntireX COBOL Wrapper | Set operating system |

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

WSE
Interface Type: | CICS wit BS2000
i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:
IDL Prograrm Client name
@p FI-lECEG rder ORDERCLT

2 From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

3  Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.
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Generating COBOL Code

- To generate COBOL code

m  For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:

ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f% Package Explorer 52 = B
Bk e e e R R e o o o o o e %| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
= 1pL L5 ORDERCLT &3 > B JRE System Library [JavaSE-18]
* IDL Pi|###ssssssressss {:Dp",-rbDDk ||: EE 4 (& client
* . =| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|=* 4 (= include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT iy OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* |*  Template Source = cobol include.tpl $Revision: 1.55 %
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C W
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJC/FJ(._H__‘J_
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The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.
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Building the Client Application

Client Application
COBOL Generi
Nk Client i RO Nk Broker
> > Service > Stub
Module

Client Interface
| supplied by EntireX

Program _ Object 1

Object 2
Object n

generated written by customer

) call interface

In this scenario, the COBOL client program, every generated client interface object, generic RPC
services module and the broker stub are linked together to the client application.

See Using the COBOL Wrapper for Batch (z/OS, BS2000, z/VSE and IBM i).

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement I Enabled | :

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.
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4  This step depends on the method used to call the server (see Task 3 in the Introduction).
® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).
® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).
5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
< Broker: | localhost: 1971 @
Pocal | [ Fing ] [ Open Conversation ] [ Reset ] [ Exit ]
Messages
2 OrderItemID (M5) 45
2 OrderQuantity (M10) 13
2 OrderCustomerID (I4) 234
2 OrderItemMame (A53) tennis racquet
2 OrderUnitPrice (A20) 79.89 GBP
2 OrderTotal (A20) 1438.02 GBP
3 Mame (A29) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road
3 City (A99) Wimbledon Londaon
3 ZipCode (A20) SW19 SAE
3 CountryCode (A20) LK
2 OrderShippingDate (A256)|Your order will be shipped on Wed, Jul 27, 2016,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Calling REST from COBOL
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This scenario uses the following tools of the Designer:

® from the Service Development perspective: New REST API Descriptor
® from the EntireX perspective: IDL Extractor for Integration Server and COBOL Wrapper

Introduction

To call the REST API from COBOL, take an existing description of a REST API @ and generate
the integration logic @ to call it from a COBOL application €, as shown below.

a REST

AFI
Runtime -
COBOL | >
Client ;
Program Design -
E Time
(1] Swagger

© Create the consumer REST API descriptor in Integration Server. See Service Development Help
in the webMethods Integration Server documentation. Then generate Integration Server con-
nections and listeners. See Using the IDL Extractor for Integration Server.

@ Generate client interface objects and build COBOL client application.

© Execute the call from the COBOL client to the REST API.

This scenario makes the following important assumptions:

For Task 1:

" You have a working Integration Server Service that you want to call from your REST API.
For Task 3:

" You can call the REST API at runtime using different methods:

® For the EntireX RPC connection method you need EntireX Broker on one of the supported
platforms: z/OS | Linux | Windows | BS2000.
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il EntireX EntireX REST
Client -« > « > >

* For the EntireX Direct RPC connection method there are no additional prerequisites.

COBOL
Client - g ﬁT
Program

What do | need to Install for this Scenario?

You have Software AG Designer installed with EntireX plugins and Service Development plugins.

® For EntireX plugins, see Designer > EntireX Designer under EntireX Installation Packages in the
General Installation documentation.

® For Service Development plugins, refer to the Integration Server documentation.

You have an Integration Server with EntireX Adapter installed. See Adapters > EntireX Adapter
under EntireX Installation Packages in the General Installation documentation.

Optionally, for RPC Connection method (Task 3), you have an EntireX Broker installed.

® For Linux and Windows, see EntireX Broker under EntireX Installation Packages in the General
Installation documentation.

On the machine where the COBOL client program is executed, you have the Broker stubs in-
stalled. See Installing EntireX under IBM 1.

Task 1: Create the Consumer REST API Descriptor, Connections and
Listeners

This section covers the following topics:

= |ntroduction

= Creating a Consumer REST API Descriptor

= Extracting the Interface of the webMethods IS Service
= Creating Listener Objects in Integration Server
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= Testing the Extraction Results (Optional)
Introduction

After you have created the consumer REST API descriptor, follow the instructions for extracting
a webMethods Integration Server (IS) service under Using the IDL Extractor for Integration Server.

This process creates the following EntireX metafiles:

® an IDL file, containing definitions of the interface between client and server; see Software AG
IDL File in the IDL Editor documentation in the IDL Editor documentation

= a3 webMethods IS Connection

® a webMethods IS Listener, depending on connection type. See Listeners in the EntireX Adapter
documentation.

Connection types are described under Creating Listener Objects in Integration Server.

Creating a Consumer REST API Descriptor

~ To create a consumer REST API Descriptor

1 Switch to the Service Development perspective. Create a package and folder in Designer
where the API descriptor is placed into.

2 Invoke the wizard to create anew REST API Descriptor in Eclipse. From the File menu, choose
New > REST API Descriptor.

Or:
Choose New from the toolbar or context menu of a view showing resources.
Or:

Press ctrl-N to start the selection of the New Wizards.
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workspacel03 - Software AG Designer

File Edit Mavigate Search Project Run Wir

. O QAo g
I+ @ RESTconsumer
= RESTconsumer

@ Defa New

O Wm! ol B3 NET Service
® wm/ Find. ®; Adapter Notification

@ wm/ oF Adapter Service Select the Source Type

® wmy & Refn & CService

& wm( ff-ﬂfjﬁ E  Document Type Create REST APl Descriptor As
@Wmt - @ FlatFile Dictionary O Provider

@& Wmf o D.le.l.e. } Flat File Schema Select th

Wmi - Flow Service o

& Folder

e = [/ RESTAPIDescriptor| @ @ @
#i REST Resource
¥+ Schema
“  Specification

3  Follow the instructions on the screen. Provide the description of the REST API (Swagger file)
and create the REST API descriptor for a Consumer.

For more information on REST API descriptors see Service Development Help in the webMethods
Integration Server documentation.

Extracting the Interface of the webMethods IS Service

First create a project in Designer. This project is the container into which all extracted and generated
EntireX artifacts are placed. Name this project COBOL placeOrder client.

~ To start the IDL Extractor for Integration Server

1  Switch to the EntireX perspective.

2 Invoke the IDL Extractor for webMethods IS, which is a New Wizard in Eclipse. From the
File menu, choose New. Select IDL Extractor for webMethods IS in the following page.

Or:
Choose New from the toolbar or context menu of a view showing resources.

Or:

Press Ctrl-N to start the selection of the New Wizards.
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3  If you are using the wizard for the first time without any predefined Integration Server con-
nections, enter the TCP/IP address of the webMethods IS to extract from. Otherwise select
the connection to the Integration Server.

4  Press Next.

~ To extract the IDL from the selected package

1 Under Source (Integration Server), select the package you want to extract from.

Extract IDL from the selected package
Select the package (source), specify the container and file name (target) and choose

the mapping.

Source (Integration Server]

Packages on Integration Server localhost:5555

@ OrderManagement &
€3 WmEntireX
3 WmFlatFile
&3 WmISExtDC il

Target (Eclipse Workspace)

Container: COBOL placeQrder client

IDL File Mame:  OrderManagement

Optimize extracted IDL for usage with: |COBOL -

Map Integration Server data type to IDL Used if no constraints available

alphanumeric with variable length

@ alphanumeric with fixed length of 256

[V]iCreate Listener Objects in Integration Server

'r:?,-:' ’ < Back ” Mest = Einish

2 For Target (Eclipse Workspace), specify project COBOL placeOrder client. Extraction results
will be placed in this container. You can keep the IDL File Name as it has been derived from
the package name by default. Since COBOL is your desired endpoint, select Optimize extracted
IDL for usage with: COBOL.
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Note: COBOL only supports fixed-length data items, whereas webMethods IS has

variable length types, often without any length restrictions (constraints). Parameters
with no specified constraints will take the default fixed length. You can specify this
default in field alphanumeric with fixed length. .

3  Alistener is required for calling webMethods IS from an RPC client, so check Create Listener
Objects in Integration Server.

4  Press Next.

Creating Listener Objects in Integration Server

~ To create Listener Objects in Integration Server

1  Select a Listener connection type used for inbound connection to the Integration Server.

® An EntireX RPC Listener connection is the standard way and is always available.

® If your interface contains only In parameters, an EntireX Reliable RPC Listener connection
is available.

= If it is enabled by the license for the webMethods Integration Server:
" an EntireX Direct RPC Listener connection is available

* if your interfaces contain only In parameters, an EntireX Direct Reliable RPC Listener
connection is available
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IDL Extractor for webMethods IS | =l g

Define Adapter Services for EntireX RPC Listener Connection

Select a package, name a folder and a connection, and complete the page.

Packages on Integration Server localhost:5555

3 FLOW Tutorial -

@ OrderManagement (N

£3) WmART M

3 WmARTExDC -
Folder Name: OrderfManagement.listeners

Connection Name:  OrderfManagementConnection

Listener Mame: CrderManagementListener

Table of IDL Programs and their related IS Services:

RPC Program Mame IS Service Name

placeCrder CrderManagement.service:placeCrder

RPC Listener Connection to EntireX

Created listener and connection

Broker ID: localhost1971
Server Address: RPC/SRV1/CALLMAT -
@ CrderManagerment
UserID: 4 = OrderManagement
4 [ documents
Password: Address
. Request
Encoding: Response
4 [= listeners
2) ’ < Back H = &) OrderManagementConnection
ﬁﬁ. OrderfanagementLlistener
4 [ service
= placeOrder

2 On this page, you set the properties for the listener objects to create; these objects will wait
for the incoming COBOL requests. Select the package and specify the folder name into which
the listener is generated. If the folder does not exist, it will be created automatically.
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3  Keep the defaults given for RPC Listener Connection to EntireX. The Broker ID is a TCP/IP
or SSL/TLS address and Server Address is an EntireX-specific namespace to locate a target
server (here: OrderManagementListener).

4 When creating a connection, a package dependency is added such that the selected package
depends on webMethods EntireX (the package WmEntireX) with the version currently used.

5  PressFinish. The listener and the connection appear in the package navigator. For the package
navigator, switch to the service development perspective by choosing Window > Perspective
> Open Perspective > Service Development.

Testing the Extraction Results (Optional)

You can test the results of the extraction and the server back end, using the EntireX IDL Tester.

> To test the extraction results

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement IEnat:-Ie-:I |:

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.

4  This step depends on the method used to call the server (see Task 3 in the Introduction).

® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).

® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).

5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
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< Broker: localhost: 1971 Server: |RPC/SRV1/CALLMAT

¢ cal |[ Fing H Open Conversation ] [ Reset H Exit ]
Messages
2 OrderltemID (M5) 45

2 OrderQuantity (M10) 18

2 OrderCustomerID (14) 234

2 OrderltemMame (A599) tennis racquet
2 OrderUnitPrice (A20) 79.39 GBP

2 OrderTotal (A20) 1438.02 GBP

3 Mame (A%9) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road

3 City (A99) Wimbledon London

3 ZipCode (A20) S\ 19 SAE

3 CountryCode (A20) LK

2 OrderShippingDate (A256)| Your order will be shipped on Wed, Jul 27, 2015,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true

Task 2: Generate Client Interface Objects and Build Client Application

This section covers the following topics:

= Setting Generation Options (Properties) for the COBOL Wrapper
= Generating COBOL Code

128
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= Building the Client Application

Setting Generation Options (Properties) for the COBOL Wrapper

~ To set generation options (properties) for the COBOL Wrapper

1 To generate suitable COBOL code for your environment, first set the correct target operating

system. Make sure the EntireX perspective is active (Window > Perspective > Open Perspective
> EntireX) and call the properties of the COBOL Wrapper.

Properties for OrderManagement.idl

| Set operating system |

EntireX COBOL Wrapper

The COBOL properties are used to generate COBOL client or server code from the
selected IDL file. The default settings are taken from the COBOL preferences,

| Target Operating System: ‘Efﬂfr T'
Client

VsE
Interface Type: | CICS wit BS2000
i5/05%

RPC Communication A
i@ Linkage Section () Bxternal Clause () Copybook

Customize automatically generated Client Mames...

Starting COBOL Level for Data Iterms in Generated Copybooks; 3
Customize COBOL Client Names Used for IDL Library OrderManagement

On this page you can adapt the names to be used for COBOL Client sources,
Adapted COBOL name

Adapt Mames used for COBOL Clients:
Client name

ORDERCLT

IDL Prograrm
@pplaceﬂrder

From the context menu of the IDL file, choose Properties > EntireX COBOL Wrapper. On the
COBOL Wrapper Properties page, set the Target Operating System

Adapt the name of the generated COBOL program: Choose Customize automatically gener-
ated Client Names. Take ORDERCLT as the COBOL program's name.
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Generating COBOL Code

- To generate COBOL code

m  For COBOL code generation, make sure the EntireX Perspective is active: Choose Window >
Perspective > Open Perspective > EntireX. From context menu of the IDL file, choose COBOL
> Generate RPC Client. This generates the COBOL client ORDERCLT in folder client and a
copybook in folder include:

ORDERCLT i3
8L L8 uote | COBOLclient |
IDENTIFICATION DIVISION.

PROGRAM-ID. ORDERCLT. f% Package Explorer 52 = B
Bk e e e R R e o o o o o e %| L =
* 4 (=} COBOL placeOrder client
*  C0OBOL RPC Client Interface Object = src
* ' i 'aSE-1.8
= 1pL L5 ORDERCLT &3 > B JRE System Library [JavaSE-18]
* IDL Pi|###ssssssressss {:Dp",-rbDDk ||: EE 4 (& client
* . =| COBSRVI
* Progril*  COBOL RPC Interface Copybook =/ ORDERCLT
*  Targe|=* 4 (= include
* 5trim*  IDL Library = OrderManagement = ERXCOMM
* Inter|*  IDL Program = placeOrder = ORDERCLT
*  RPC i+ =l

Ordert t.idl
* RPC Pil*  (opybook Name = ORDERCLT iy OrderManagement.i
* *  Target Platform = all
* In th'* Interface Type = all
* el’|*  sString Literal = QUOTE
Ed N
* |*  Template Source = cobol include.tpl $Revision: 1.55 %
* I
* | B b b b b b ke e e
* or
* 1* Template Source = cobol linkage.tpl Constraints available
* | @3 REQUEST.
* 84 ORDERITEMID PIC 9(5).
* Templi @4 ORDERQUANTITY PIC 9(1@).
* 24 ORDERCUSTOMERID PIC S9(9) BINARY.
* Do @3 RESPONSE.
* 24 ORDERITEMNAME PIC %(99).
¥ generil | @4 ORDERUNITPRICE < PIC X(20). |
* B4 ORDERTOTAL PIC X(28).
e e ok ke
24 ORDERCUSTOMERADDRESS. : :
C W
55 NAME No constraints available
ENVIRONMI @5 STREET PIC X(99).
_ B5 CITY PIC X(99).
DATA DIV. @5 ZIPCODE PIC X(2@).
85 COUNTRYCODE PIC X(28).
WORKIMN @4 ORDERSHIPPINGDATE PIC X(256).
R 24 ORDERCONFIRMATION PIC X(256).
B4 ORDERCONFIRMATIONFLAG :IJC/FJ(._H__‘J_
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The copybook is the COBOL programmer's API. It is for use in the COBOL application.

As you would expect, the length of generated COBOL parameters exactly matches the lengths
extracted. COBOL parameters always have a fixed length defined at compile time. They are not
altered at runtime to reflect actual string length as in modern programming languages. This means
that if you choose your default length (see Extracting the Interface of the webMethods IS Service)
you have to choose the maximum possible data size to ensure all data can be transmitted. However,
this may needlessly increase the message size if no constraints are set for fields of shorter data
length. Choose your defaults and contstraints carefully.
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Building the Client Application

Client Application
COBOL Generi
Nk Client i RO Nk Broker
> > Service > Stub
Module

Client Interface
| supplied by EntireX

Program _ Object 1

Object 2
Object n

generated written by customer

) call interface

In this scenario, the COBOL client program, every generated client interface object, generic RPC
services module and the broker stub are linked together to the client application.

See Using the COBOL Wrapper for Batch (z/OS, BS2000, z/VSE and IBM i).

Task 3: Execute the Call from COBOL to REST

Use the EntireX IDL Tester to execute the call.

> To execute the call

1  For EntireX RPC (see Task 3 in the Introduction) and an RPC Listner Connection, make sure
EntireX Broker is running.

2 Enable the EntireX Adapter Listener.

EntireX Adapter Listeners

Listener Hame & * Package Mame & ¥  gigie & W

OrderManagement.listeners:OrderManagementListener OrderManagement I Enabled | :

3 Activate the EntireX perspective by choosing Window > Perspective > Open Perspective >
EntireX, and from the context menu of the IDL file, choose IDL Tester.
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4  This step depends on the method used to call the server (see Task 3 in the Introduction).
® For EntireX RPC, enter the same TCP/IP address for Broker that you supplied when you
created the RPC Listener Connection to EntireX (localhost:1971).
® For Direct RPC, that is, you generated a Direct RPC Listener Connection, enter the TCP/IP
address from the Integration Server (localhost:1971).
5 For Server, enter the values you specified for the server address (RPC/SRV1/CALLNAT).
< Broker: | localhost: 1971 @
Pocal | [ Fing ] [ Open Conversation ] [ Reset ] [ Exit ]
Messages
2 OrderItemID (M5) 45
2 OrderQuantity (M10) 13
2 OrderCustomerID (I4) 234
2 OrderItemMame (A53) tennis racquet
2 OrderUnitPrice (A20) 79.89 GBP
2 OrderTotal (A20) 1438.02 GBP
3 Mame (A29) The All England Lawn Tennis Club (Championships) Limited
3 Street (A99) Church Road
3 City (A99) Wimbledon Londaon
3 ZipCode (A20) SW19 SAE
3 CountryCode (A20) LK
2 OrderShippingDate (A256)|Your order will be shipped on Wed, Jul 27, 2016,
2 OrderConfirmation (A256) | Your order is confirmed.
2 OrderConfirmationFlag (L) |true
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