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1 Version information

ARIS 10.0 SR18 10.0.18.0 17.05.2022
ARIS 10.0 SR17b 10.0.17.3 05.04.2022
ARIS 10.0 SR17 10.0.17.0 14.01.2022
ARIS 10.0 SR16 10.0.16.0 15.10.2021
ARIS 10.0 SR15 10.0.15.0 07.07.2021
ARIS 10.0 SR14 10.0.14.0 15.03.2021
ARIS 10.0 SR13 10.0.13.10 17.07.2020
ARIS 10.0 SR12 10.0.12.0 15.04.2020
ARIS 10.0 SR11 10.0.11.0 16.12.2019
ARIS 10.0 SR10 10.0.10.0 15.10.2019
ARIS 10.0 SR9b 10.0.9.1 18.09.2019
ARIS 10.0 SR9 10.0.9.0 28.06.2019
ARIS 10.0 SR8 10.0.8.0 16.04.2019
ARIS 10.0 SR7 10.0.7 20.12.2018
ARIS 10.0 SR6 10.0.6 16.10.2018
ARIS 10.0 SR5b 10.0.5.1 20.09.2018
ARIS 10.0 SR5 10.0.5 13.07.2018
ARIS 10.0 SR4b 10.04.1 14.05.2018
ARIS 10.0 SR4 10.04 17.04.2018
ARIS 10.0 SR3 10.0.3 21.12.2017
ARIS 10.0 SR2c 10.0.2.3 29.11.2017
ARIS 10.0 SR2 10.0.2.1 17.10.2017
ARIS 10.0 SR1 10.0.1 14.07.2017
ARIS 10.0 10.0.0.2 19.04.2017
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For detailed information about supported platforms see
Documents\English\2 System requirements\ARIS System Requirements.pdf

For detailed information about new features in ARIS 10.0 see
Documents\English\1 Overview\ARIS Feature Overview.pdf

For detailed information about updates to new version of ARIS 10.0 see
Documents\English\3 Installation\32 Update\322 Server\3222 Advanced (Multiple node)\ARIS Update
Cookbook.pdf

If you have an elasticsearch cluster, please follow instruction under chapter 12 “Adjust elasticsearch
cluster”.

If you update from ARIS 10.0 SR9 or older version, we recommend to re-index your data. See chapter 21
“Re-index modeling data for each tenant (optional)”.

The following manuals have been removed. The contents can be found completely in the
specified help.

ARIS Aware

(The information can be found in ARIS Connect. Log in as a viewer, designer, or administrator.
Click your user name to open the menu. Click "Help". Help opens in a separate tab. Click on
"Use dashboards".

ARIS Connect Viewer User Manual
(The information can be found in ARIS Connect. Log in with the "ARIS Connect Viewer" license.
Click on your user name to open the menu. Click "Help". Help will open in a separate tab).

ARIS Connect Designer User Manual
(The information can be found in ARIS Connect. Log in with the "ARIS Connect Designer"
license. Click your user name to open the menu. Click "Help". Help opens in a separate tab).

ARIS Connect Administrator User Manual

(The information can be found in ARIS Connect. Log in with the "ARIS Connect Administrator"
function privilege. Click your user name to open the menu. Click "Help". Help opens in a
separate tab).
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With the release of ARIS 10.0 SR16 in October 2021, the Internet Explorer 11 (IE11) Web browser will no
longer be supported.

This applies to all products that are currently released and supported as marked in the document ARIS
System Requirements (ARIS Designer - YAD, ARIS Architect - YAA, UML Designer - YUD, ARIS Connect
Viewer - YCSCC, ARIS Connect Designer - YCSDC, ARIS Process Performance Manager - YPI, ARIS Risk
& Compliance Manager - YRC).

Rationale: Internet Explorer 11 represents outdated technology. We support modern browsers like Edge,
Firefox, Chrome, and Safari. Microsoft recommends using Microsoft Edge as your default browser,
featured in Windows 10.

From the release of ARIS 10.0 SR16 in October 2021 also the following functionalities will no longer be
supported:

e Embedding of OLE objects
This affects ARIS Designer - YAD, ARIS Architect - YAA and UML Designer - YUD.

e ARIS Simulation export to MiniTab
This affects ARIS Architect - YAA with extension pack: Simulation — YAASI.

e Local Server
This affects ARIS Architect - YAA and UML Designer - YUD.

Rationale: The functionalities listed above are based on outdated technology. OLE objects, simulation
export to MiniTab, and LOCAL Server require a 32-bit JRE to interact with Windows. 32-bit JREs are nho
longer provided with Java 9 or higher.

The last release including the functionalities mentioned above is the ARIS 10.0 SR14.

According to our standard maintenance guidelines (see https://empower.softwareag.com/),
maintenance will end 3 years after ARIS 10.0 SR14 is available in April 2021. No further releases will
contain these functionalities. In case of questions, please contact your Software AG sales
representative. In case of issues please contact the ARIS product management team by email (in
English or German): ARIS-ProdMgt@softwareag.com.
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= |fyoureapply a template to a model, attributes are now placed correctly at the predefined
position. (See also "Help", topic area "Create content > Create and edit models > Model ",
page "Assign model template".)

= Satellite modeling in ARIS and ARIS Architect/Designer now filters out all object symbols
that are not allowed by the content type configuration. While the filter is not being applied
to the search in ARIS Architect/Designer, a meaningful message is issued there when a
user selects a prohibited symbol as a satellite. (See also ARIS "Help", topic area "Create
content > Create and edit models > Model", page "Use satellite modeling" and ARIS
Architect/Designer "Help", topic area "Create models > ARIS models", page "Satellite
modeling".)

= The spell check in ARIS Architect/Designer now works correctly again. (See also "ARIS >
Help ", topic area "General", page "Use the spell check".)

= The automatic layout algorithm was improved for complex cases. (See also "ARIS > Help",
topic area "Create models > ARIS models > Use objects >Extended editing”, page “Generate
model layouts automatically".)

= You are now able to set the client language for all installation scenarios of an ARIS
Designer/Architect installation.

= |nthe ARIS modeling clients, connections that go to derived object symbols are now
displayed as connections that go to the object symbols from which they were derived.
(See also "ARIS > Help", topic area "ARIS Configuration and Administration > Manage ARIS
method", page "Derive object symbols".)

= The "Character formatting" setting is now set correctly during the import of a model
template. (See also "Help", topic area "Manage ARIS > Manage model templates”, page
"Available templates".)

= The merge preview now shows the same result as the log file. (See also "ARIS > Help",
topic area "ARIS Configuration and Administration > Manage databases > Merge
databases", page "Start Merge preview".)
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Models and objects that are created in the "Published content" view using "Contribution”
are now saved in the configured database groups according to the content type
configuration. (See also "Help", topic area "Work with content > Contribute as a viewer ".)

If you attempt to open a mini fact sheet for an object that uses an object symbol not
allowed by the method filter in use, an empty fact sheet is displayed now instead of an
error page. (See also "Help", topic area "Getting started > User interface > Fact sheets >
Diagram fact sheet", page "Show mini fact sheets" and topic area "Manage ARIS >
Configure user interface > Edit modification set > Manage fact sheets > Edit fact sheet",
page "Mini fact sheets".)

When you highlight objects that belong to the default path, these objects are now
indicated by means of a solid frame instead of a dashed or dotted one. (See also "Help",
topic area "Work with content > Use models > Highlight model items", page "Highlight the
happy and/or exception path".)

It is now possible to use the special character "&" in attribute names. (See also "Help",
topic area "Manage ARIS > Manage ARIS Method > Attribute types", pages "Rename
attribute type in current language" and "Rename attribute type in all languages".)

If you select a view for a process model in the diagram fact sheet, such as "Lean", all
process models are shown in this view until you select another view. (See also "Help",
topic area "Getting started > User interface > Fact sheets > Diagram fact sheet", page
"Change view".)

When you copy items from one matrix model to another, the formatting as well as the
hierarchies are now also transferred. (See also "Help", topic area "Create content > Create
and edit models > Model > Matrix model".)

Macros that were created in order to replace the "New model" functionality (macro event
"Model is to be created with type and name (vetoable)") now work correctly in ARIS. When
you create new assignments, the assignment icon is displayed and the newly created
models can be opened in ARIS automatically.

When you copy a group, the relationships between the UML2 elements and the ARIS
objects of this group are now copied as well and are displayed on the "Reused objects”
tab.
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»= The results of semantic checks are now correctly filtered in the ARIS modeling
component. (See also "Help", topic area "Create content > Create and edit models > Check
open models", page "Run semantic check for an open model".)

=  When you are using the ARIS report script API, multi-line texts are now correctly read from
Microsoft Excel and correctly written to ARIS attributes.

= The robustness of the standard report "Export attribute values for translation" was
improved. If an attribute exceeds the maximum number of 32767 characters in Microsoft
Excel, the corresponding value is added to the output file. This enables users to check the
given attribute manually. (See also "Help", topic area "Output information > Generate
report > Available reports", page "Report: Export attribute values for translation".)

= |Improvements were made to the report "Generate job description”. (See also "Help", topic
area "Output information > Generate report > Available reports"”, page "Report: Generate
job description".)

= The "Create process manual" report now runs correctly regardless of what type of
formatted attributes is being used. (See also "Help", topic area "Output information >
Generate report > Available reports”, page "Report: Create process manual”.)

= Zookeeper/Load balancer now return the server name. As a consequence, it is no longer
required to request the server name from the client by using
"Item.Database().ServerName()" (which is a step that, in the past, did not work for
scheduled reports and ScriptRunner).

= The content of table cells is now correctly aligned in report output files.

= The ARIS report script method "Database.User(String sName, UserGroup oUserGroup)"
now correctly returns a user when a user group is added. (See also "ARIS > Help > ARIS API
> Command reference for ARIS reports and macros", topic area "API for reports > Objects >
Database", page "User(String,UserGroup):User™.)

= Customized or derived object symbols are now handled correctly in BPMN diagrams.

= When you create or edit relation properties in the content type configuration, only the
relations that can really be displayed in the selected model are offered for editing.
= Updated templates are now correctly applied to BPMN diagrams so that modified lanes are

considered appropriately when you add them to pools. (See also "Help", topic area "Create
content > Create and edit models > Model", page "Assign model template”.)
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= In ARIS, the background color set under "Available templates" is now applied correctly to
the model types.

= |n the French language version, the BPMN objects "Pool" and "Lane" were renamed to
"Piste" and "Corridor".

= The communication between ARIS Architect and ARIS Risk and Compliance is now
resumed smoothly even if changes were made to the infrastructure.

= |Improvements were made to the layout that is displayed after a rollout of EPC models.
(See also "Help", topic area "Create content > Use variants", page "Enhanced variant
management".)

= Within the rollout view, the symbol and connection names of a master are displayed in the
language that the user defines in ARIS Administration. (See also "Help", topic area "Create
content > Use variants", page "Enhanced variant management".)

= The attributes "Roll-out state" and "Last roll-out state change" are now contained in the
method filters as default attributes. (See also "Help", topic area "Manage ARIS > Manage
ARIS Server and tenants > Tenant Management tool > Manage tenants > Manage filters",
page "What are filters?".)

= Dashboards that are based on "React" technology are now correctly displayed when the
configuration of the Web socket protocol was changed.

= You can now use the percent sign (%) within the password for a feed alias.
= The sorting of dashboard columns now corresponds to the sorting of the columns in the
exported CSV file.

= Setting the selection of associated widgets now works correctly even if a data column of a
heat matrix is renamed. (See also "Help", topic area "Use dashboard and data feed editor >
Use the new dashboard and data feed editor > Configure a dashboard", page "Add widgets
to adashboard ".)

= The dashboarding runnable now starts correctly even if the content of the database table
in which the dashboard style is stored is changed.
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= Third party lib updates due to security vulnerability:

=  Spring4Shell, CVE-2022-22965 and CVE-2022-22950
- Update Spring Framework to versions 5.3.18 and 5.2.20

For detailed information: https://nvd.nist.gov/

For ARIS Download Clients, the file "log4j1" was replaced by "log4j2" for security reasons.

= When changing the logo on the home page, the logo was displayed in the wrong size. This
is now fixed.

= Even if it was configured that properties are not to be displayed initially, the Properties
buttons now work.

= Loading UML content was improved. This means that loading ARIS groups with a large
number of elements, such as subgroups and objects is now significantly faster, even if
access to UML2 content is activated.

= Changed configurations are now properly loaded. |.e., customer-specific adjustments of
change sets are properly loaded so that, e.g., a changed greeting is now properly displayed
in the portal.

= |n the portal, objects are now recognized that were not assigned the default object
symbol.

= Adding the line "<property name="isOpened" value="true"/>" in the "item.xml" file properly
displays the properties if an item is selected for viewing.

= Models added to the Landing Page (Home) are now scaled properly in size.
= The search in ARIS now works in Edit mode (contribution) for unpublished databases.

= More than 150 relationships can now be displayed for an object in the ARIS modeling
component.
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= Users can no longer edit the "AT_DOCUMENTATION" attribute if they have only the "Read"
privilege.

= The model and object attributes "Last update date" and "Last update by" are now updated
when other model/object attributes in the ARIS Repository are changed on the properties
page.

= When merging versioned content (from older versions), the current version / workspace
was merged. This is now fixed.

= After the update to SR17, problems could occur when starting the server (ADS) if Oracle
was used as the database system. This is now fixed.

= |mporting databases by means of reports now works properly.

= Errors are now longer reported after a database repair with "optimizeDB".

= After an update or migration of a previous ARIS Risk & Compliance Manager version, the
master data maintenance settings are properly considered.

= |nformation on ARIS Risk & Compliance Manager adjustments are now output via the
"About" dialog.

= Calculation tables now open in Edit mode if they were created by means of a report.

= Order of parameters in ARIS Document Storage document URLSs aligned to usage within
Professional Service report solution.
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ARIS User Management

= |n user management, the load time for licenses and function privileges was optimized
when licenses and function privileges have to be distributed to a large number of user
groups.

ARIS for process-driven SAP

= |n SAP Solution Manager, you can rename a lane of a role-based diagram, which
corresponds to a process variant in ARIS, and synchronize the renaming with ARIS. In
ARIS, use the option "Transfer process variants" when synchronizing.
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=  With ARIS 10.0 SR17, these third-party libraries were updated:
= Apache Tomcat was updated to version 8.5.73.
= Apache HTTPD was updated to version 2.4.52.
= Log4jwas updated to version 2.17.1.

= Azul JRE was updated to version 11.52.14.

= Transport Layer Security (TLS) 1.0 and 1.1 are security protocols for establishing
encryption channels over computer networks. As TLS 1.0 and 1.1 are out-of-date protocols
that do not support modern cryptographic algorithms, and they contain security
vulnerabilities that may be exploited by attackers these protocols has been stopped since
ARIS 10.0 SR17.
This is affecting SSL secured connection to SMTP servers which has been switch to TLS
1.2 with ARIS 10.0 SR17.

= If you use the connection mode for BPMN models in ARIS Architect/Designer, the
connections are now created automatically.

= |ssues that had occurred when formatting reports in the design view were fixed. If you
change the style of a section, this change is now considered correctly in the generated
report.

= The formatting of documents generated by ARIS reports was improved.

= Swagger API links are now enabled again for the storage of ARIS documents.

11
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ARIS Collaboration now supports TLS 1.2.

Dashboards are now displayed only once in the dashboards view.

The size of the "Create objects" dialog was adjusted in such a way that the dialog is now
displayed entirely even if the screen resolution is low.

When satellites are added in the "Published content” view of ARIS Connect using
Contribution, models and objects are now created in the correct groups according to the
content type configuration in use.

Now, the process steps view also displays user-defined process models.
Improvements were made to the performance of the search function in ARIS Connect.
It is now possible to configure the size of the contents displayed on the "Home" page
(start page). To this end, the XML configuration provides the size specification

"min80WithOptionalControls". Furthermore, you can specify the size by entering the
values "Home section max-width" and "Home section width" under "User interface".

First Versioning with option "Include Border Items" runs in an Internal Merge Error. This is
fixed now.

Accessing the end points of the "User" and "Group" SCIM resource types is now possible
again. Attribute-related information is returned in detail.

The ARIS Process Governance operator used for retrieving users from the user
management of ARIS Administration now supports not only the login name but also the
first name and the last name as a valid input.

ARIS now verifies correctly whether the user who is logging in has the "Variant manager"
function privilege.

12
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= Now, the statuses are displayed in the columns of a report generated in Excel format.

= The arrows of the confirmation dialog in the Arabic user interface now point into the
correct direction and are placed to the left of the text.

= Improvements were made to the layout of the Arabic user interface. Message texts, check
boxes, and buttons are now arranged correctly.

= Users that do not have issue management privileges are now able to create issues again.

= The "Cleaning server task schedule" scheduler now also deletes historic server tasks.

13
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The number of ARIS Process Governance tasks that is visible in the symbol is now also
displayed in a tooltip as follows: "My tasks (23 pending)". This number of tasks is also read
by the screen reader (JAWS).

The form fields in the modal dialog "Change request" are now linked to the visible label of
the dialog. Thus, the size of the active clickable area is increased.

The search field is now selected by pressing the Tab key because this field was included in
the tab order for accessibility. Once the search field is selected, the focus is on the inner
edit field whose content is read by the screen reader.

When a modal dialog is opened, the screen reader tells the user that a dialog is now
displayed. The title of the dialog is read as well. When a modal dialog is closed, for example,
"Propose new document(s)"”, the focus of the keyboard is set to the triggering button.
Thus, users can continue working at the position where they opened the dialog.

14
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When you edit multi-line text attributes in ARIS Architect and ARIS Designer, a scroll bar is
now displayed to enhance the editing of long text attributes. (Pivotal 5452036)

When you create an object in ARIS Connect, all reusable objects are now displayed to you.
(Pivotal 5452438)

When you generate a process model from a matrix model in ARIS Architect or ARIS
Designer, all connections that were drawn between the model objects are now displayed.
(Pivotal 5455528)

Exporting model graphics to a document now works correctly for all available image file
formats. (Pivotal 5455719)

Databases that can no longer be used because an error occurred when deleting them, for
example, are now deleted automatically. You can find databases of this kind by entering
the ARIS Server Administrator command "list all". Databases that remain in the states
"restoring”, "deleting"”, or "migrating"” are deleted after a specific time period has elapsed.
(Pivotal 5433162)"

Problems that occurred when merging UML2 content were solved. (Pivotal 5438512)

ARIS Merge: Corrections were made to an error message that occurs during the merge of
databases if a model that is assigned to an object is unavailable in the target database.
(Pivotal 5443340)

ARIS Server with Oracle DBMS: The use of bind variables in SQL statements was increased
for the process of backing up databases. (Pivotal 5450418)

The ARIS Server Administrator command "optimizedb" now reliably solves database
problems that are related to database versions. (Pivotal 5450546)

The fault tolerance was increased for the process of importing and merging lane models
that do not comply with all conventions required by ARIS Method. (Pivotal 5451319)

The time required for the versioning of models was considerably reduced.
(Pivotal 5454040)

15
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= The ARIS report script method "XlsSheet.removeRow( ( XIsRow p__row, boolean
bShiftRows)" now works correctly again. Rows are deleted from Excel tables as expected.
(Pivotal 5440530)

= |f you want to restrict the access to a report script, you can now enter a higher number of
users or user groups. The maximum number of characters that can be entered in the
corresponding field was increased from 4,000 to 12,000. (Pivotal 5440924)

= The ARIS report script method "getLockOwner()" now always returns correct results even
if the model is locked for editing or explicitly locked. (Pivotal 5447762)

= |mporting Microsoft Visio files into ARIS Architect now works correctly. (Pivotal 5447875)

= You can now run the ARIS report "Import data in Excel format" successfully even if the
retrieval of attribute values fails. In such a case, the report is no longer canceled. Instead,
errors are written to a log file. (Pivotal 5448263)

= The language support for reports that were created in the design view (WYSIWYG) in ARIS
Architect was improved. (Pivotal 5448478)

= The ARIS report script method "Model.setTemplate" now works correctly when it is called
by another report script. (Pivotal 5449378)

= The robustness of ARIS was increased in terms of model graphic generation. Errors that
had occurred occasionally during the generation of model graphics were solved.
(Pivotal 5451328)

= You can now successfully run ARIS reports even if the attributes that determine the sort
order are not specified. (Pivotal 5451604)

= The robustness of the ARIS macro interface was increased so that possible errors are
avoided. (Pivotal 5454611)

= You can now perform group transformations based on attributes. (Pivotal 5436458)

= Corrections were made to the error message that is displayed when you upload a new
version of a document using another file extension than before.

16
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Calculating the local login time used for user management charts, LDAP synchronization,
and active sessions now works correctly when the ARIS server time differs from the local
client time. (Pivotal 1450258)

Corrections were made to the example explaining how to perform an ARIS Cloud user
import. (Pivotal 5449778)

Importing Microsoft Visio files that were created using third-party programs (such as
Lucidchart) now works correctly. (Pivotal 5442983)

In the data assignment dialog for dashboards, now unique names are used for data feeds
to which the same name is assigned. For example, if you enter "database" into a data feed
hierarchy twice, the data feeds can be distinguished now because the data assignment
dialog shows the names "database_feedl" and "database_feed2". (Pivotal 5448945)

The old ARIS Alfabet interface based on reports and a SOAP web service in ARIS and
operated by the tools A2AIntegrationGui.exe and A2AIntegrationBatch.exe from an
Alfabet server is not supported in ARIS 10.0 SR16 anymore. Please make sure to switch to
the newer, actively supported interface, which is based on ARIS’ and Alfabet’s REST APIs.

For the ARIS side this interface is documented here: "ARIS > Help > Working with ARIS",
topic area "Special topics and functions > Enterprise Architecture Management > ARIS >
Alfabet Interoperability Interface > Configuration > Modify configuration”, page "Modify
configuration of Alfabet REST API v2". For the Alfabet side, please look into the file
ARISAlfabetinteroperability.pdf which is available in the Alfabet installation directory.

In ARIS Process Governance dialogs, links are now represented correctly in both the
"View" and the "Edit" mode. (Pivotal 5442292)

Restoring a tenant that is managed on an ORACLE database management system and
that contains ARIS Process Governance data no longer results in heavy utilization of the
TEMP tablespace.

17
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= Third party lib updates due to security vulnerability:
» CVE-2020-13936
= CVE-2020-13959
= CVE-2021-21409
=  CVE-2021-22696
= CVE-2021-28163
= CVE-2021-28164
= CVE-2021-28165
= CVE-2021-28657
=  CVE-2021-29425

For detailed information: https://nvd.nist.gov/

= The object type "Item definition" (APl name "OT_DMN__ITEM_ DEFINITION", type number
490)" and the connection type "has type" (APl name "CT_HAS_TYPE", type number 908)
are now available in the administration of ARIS Architect. (Pivotal 5441563)

=  Comments that start with a hash sign (#) are now processed correctly. (See also "Help",
topic area "Use ARIS Connect > Collaborate with users", page "Comment on, share, flag
posts, etc.")) (Pivotal 5439272)

= Exporting formulas to Microsoft Excel output files using ARIS report scripts now works
correctly again. (Pivotal 5444289)

= The "Database.close()" ARIS report script method now works correctly again. (See also
"ARIS > Help > ARIS Script", topic area "ARIS Script > Methods for reports and semantic
checks > Objects > Database", page "close ():void".) (Pivotal 5445246)
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* The "ExtendedOutputObject.insertDocument” ARIS report script method now works
correctly again. (See also "ARIS > Help > ARIS Script", topic area "ARIS Script > Methods for
reports and semantic checks > Objects > Output object > ExtendedOutputObject"”, page
"InsertDocument(ExtendedOutputObject,boolean,boolean):boolean".)

(Pivotal 5446707)

=  When you open a model, select an object, and open the side bar containing the
dashboards, now the GUID of the selected object is displayed correctly. (Pivotal 5437511)

= When you restore a modification set to a different server than the current one, this
modification set is now loaded correctly and also correctly references the dashboards that
were previously imported using a report. (See also "Help", topic area "Use ARIS Connect >
Use dashboards", page "Use own dashboards", page "Modification sets and dashboards".)
(Pivotal 5439897)

= |fyou select a role as the filter criterion in the "My content" area and then select the
"Activities" method filter, all available activities of the processes found are now displayed
correctly. (See also "Help", topic area "Use ARIS Connect > View content > Navigate > Use
filters", pages "Add several filters" and "Structure of My content area”.) (Pivotal 5443710)

= |fyou switch from the current profile to a different profile, the selected profile is now
loaded correctly and the views showing the database content are adapted accordingly.
(See also "Help", topic area "Use ARIS Connect > Getting started > Basic handling", page
"Switch your profile".) (Pivotal 5443754)

= Itis now possible to specify in the ARIS Server Administrator command-line tool that a
message is issued when a user attempts to use an existing identifier for an object. To do
this, "designer.check.identifier.uniqueness" is set to "true". Command: "set
designer.check.identifier.uniqueness true". (See also installation medium, "Documents >
English > 4 Administration\4.1 Basic (Single node)", manual "ARIS Server Administrator
command-line tool".) (Pivotal 5444405)

= Mini fact sheets now remain open even of a zoom level other than 100% is specified. (See
also "Help", topic area "Use ARIS Connect > Work with content > Use models > Diagram fact
sheet", page "Show mini fact sheets".) (Pivotal 5445027)

= Help text that was defined for fact sheets and the catalog in the file
"glossaryBusinessProcess.xml" is now correctly displayed as a tooltip in both the fact
sheet and the catalog. (See also "Help", topic area "Use ARIS Connect > View content > Use
the Catalog".)

= Reports are now run based on the selected login language. (See also "Help", topic area
"Use ARIS Connect > Output information", page "Generate report".)
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= The documentation of the "ADSRepository" report class of the "setPermissions" method
was improved and now describes what kind of input is valid for the parameters
"authorizationType" and "elementType". (See also "ARIS > Help > ARIS Script", topic area
"ARIS Script > Methods for reports and semantic checks > Global objects > Report
component interface > ADS > ADSRepository", page "setPermissions (ADSFolder, String[]
String, String):boolean".) (Pivotal 5435758)

= The symbol type "Item definition" (APl name "ST__DMN__ITEM_ DEFINITION", type number
1937)" and the connection type "has type" (APl name "CT_HAS_TYPE", type number 908)
are now available in the administration of ARIS Architect. (Pivotal 5441567)

= |n the user management, a problem concerning the SAML user attributes "First name",
"Last name", and "E-Mail" was fixed. These attributes are now connected correctly and the
values are rendered based on the attributes configured in the IDP. (Pivotal 5443910)

= [tis now possible to change the default symbol of a task to the symbol type "Subprocess
(collapsed)". (See also ARIS Connect, "Help", topic area "Manage ARIS Connect > Configure
ARIS Method > Object symbols", page "Change 'Default’ setting for object symbol" and
ARIS Architect, "ARIS > Help > topic area "ARIS Configuration and Administration > Manage
ARIS Method", page "Edit object types" and topic area "Working with ARIS", topic area
"Create models > ARIS models > Use objects > Extended editing”, page "Assign a default
symbol to existing objects".) (Pivotal 5441691)

= The lists "Control executions" and "Control executions (control execution owner)" now
provide the correct contents for users that have the two roles "Control auditor (object-
specific)" and "Control execution owner". (Pivotal 5441848)

= The schedule of the "Synchronize with User Management" server task now works again in
the way it was configured. (Pivotal 5442555)
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ARIS Process Governance

= Configured public holidays are now correctly considered with regard to the execution time
for human tasks. (Pivotal 5440685)

ARIS Analysis

= [tis now possible to process the connection attribute "AT__NAME" using queries. (See also
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use queries".)
(Pivotal 1446762)
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=  When you perform Oracle installations, the error "ORA-01795: maximum number of
expressions in a list is 1000" no longer occurs during merge operations. (Pivotal 5402994)

= The new setting "abs.methodology.shouldSaveDataOnClientSide" is now available. You
can use this setting to specify whether serialized method data is to be stored on the
client. The default is "True" so that the method data are stored on the client. (Pivotal
5407952)

= Corrections were made to the logging in ARIS ScriptRunner. (See also ARIS Architect,
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use reports", page
"Automatically start reports with Script Runner".) (Pivotal 5413717)

=  When you use the ARIS report script option "setSynchronizeAssignments(true)",
assignments are now correctly updated in the target database during a merge procedure.
(See also ARIS Architect, "ARIS > Help > ARIS Script", topic area "Methods for reports and
semantic checks > Global objects > Report component interfaces > Merge > MergeBase
Options", page "setSynchronizeAssignments(boolean):void".) (Pivotal 5422733)

= The HD server's report processing was made more robust so that erroneous reports no
longer block the HD server. (Pivotal 5435529)

= The connection between two objects is now drawn correctly when a user-defined
template was assigned to a model and an object symbol was changed in the model. (See
also "ARIS > Help > Working with ARIS", topic area "Edit models > Basics", page "Assign a
template to a model".) (Pivotal 1432452)

= Characters no longer appear twice when you press a key while directly editing attributes
of an object or model. (See also "ARIS > Help > Working with ARIS", topic area "Create
models > ARIS models > Use objects > Basics", page "Place object".) (Pivotal 5408819)

= When you search for values of user-defined attributes, now only the searched attributes
are displayed in an additional column of the result table. (See also "ARIS > Help > Working
with ARIS", topic area "Navigate and edit items", page "Search for database content".)
(Pivotal 5410573)

= |n BPMN diagrams, the size of lanes in pools is now correctly adapted when user-defined
model templates are used. (See also "ARIS > Help > Working with ARIS", topic area "Create
models > BPMN diagrams", page "Add multiple lanes to pool or lane".)
(Pivotal 5420714)
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The layout mechanism was changed so that connections are now placed correctly even if
connection anchor points were moved. (See also "Help", topic area "Use ARIS Connect >
Create models > ARIS Models > Use objects > Extended editing"”, page "Generate model
layouts automatically" and topic area "ARIS Configuration and Administration > Configure
the system > Good to know", page "Which ARIS administrator roles exist in ARIS
Architect?".)) (Pivotal 5421034)

Within Change Management, it is now possible for users who are no system users to
submit improvement proposals for models. (See also "ARIS > Help > Working with ARIS",
topic area "Edit models > Check and approve models > Improve models”, page "Submit
improvement proposal".) (Pivotal 5421634)

Objects whose names contain line breaks are now found for re-use. (See also "ARIS > Help
> Working with ARIS", topic area "Create models > ARIS models > Use objects > Basics",
page "Insert line break".) (Pivotal 5424499)

When you perform a search using an attribute value as the filter criterion, the value that
was entered is now handled correctly and the result that is output is correct. (See also
"ARIS > Help > Working with ARIS", topic area "Navigate and edit items", page "Search for
database content".) (Pivotal 5425873)

Texts in Hebrew are now displayed without flickering when the font type is changed to
bold or italic, for example. (Pivotal 5426222)

Changing BPMN object symbols using the "Edit symbol" button now also works for derived
object symbols. (See also "ARIS > Help > Working with ARIS", topic area "Create models >
BPMN diagrams", page "Place object" and topic area "ARIS Configuration and
Administration > Manage ARIS Method", page "Derive object symbols".) (Pivotal 5435418)

Improvements were made to the robustness and layout mechanism of Smart Modeling so
that Smart Modeling now very well supports modeling in complex models. (See also "Help",
topic area "Use ARIS Connect > Create content > Create and edit models > Model", page
"Use Smart Modeling".) (Pivotal 5436769)

Special characters within link attributes are now handled correctly in ARIS Connect. (See
also "ARIS > Help", topic area > "Create content > Create and edit models > Model >
Extended editing > Use attributes”, page "Available editing options for attributes".)
(Pivotal 5437033)

The search now always opens when you use the keyboard shortcut "Ctrl + F* or the pop-
up menu. (See also "ARIS > Help > Working with ARIS", topic area "Navigate and edit items",
page "Search for database content".) (Pivotal 5409870, 5411262)
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= When you show relationships in process models, the connection as well as an occurrence
of the related target object is created even if the model already contains an occurrence. In
contrast, when you show relationships in all other model types, the connection
occurrence is created only if an occurrence of the target object is already available in the
model. (See also "ARIS > Help > Working with ARIS", topic area "Create models > ARIS
models > Use objects > Display and navigation”, page "Show relationships".) (Pivotal
5412968, 5417493)

= When you add lanes to pools or paste lanes using Copy & Paste, templates that were
already applied are now correctly applied to the new objects. (See also "ARIS > Help >
Working with ARIS", topic area "Create models > ARIS models > Use objects > Extended
editing", page "Apply a template to one or more objects".)

= The report "CoE - Local and global maturity level" now still works correctly when you
change the default language of a database. (See also "Help", topic area "Manage ARIS
Connect > Manage databases > Manage database properties > Languages", page "Select
default language (Language page)".)

= |Improvements were made to the storage mechanism of ARIS user management so that
less memory is consumed by data that are allocated to users. (Pivotal 1406095)

= |tis now possible to specify in the XML configuration that the "Model comparison" button
is shown in the portal for selected models even if there are no differences between the
two comparison models. (See also "Help", topic area "Use ARIS Connect > Work with
content > Use models > Compare models", page "Compare model versions".) (Pivotal
1432419)

= |Improvements were made to the logging procedure. Given that the locale is not relevant to
the default symbol, the incorrect error message "Could not parse locale 'null' from symbol
filter" is no longer output. (Pivotal 5402390)

= Corrections were made to ARIS Contribute so that entries of dialogs that are using multi
select are sorted correctly. (See also "Help", topic area "Use ARIS Connect > Work with
content > Contribute as a viewer".) (Pivotal 5403375)

= |Improvements were made to the procedure of uploading configuration sets. Now, all
configuration sets are correctly uploaded to the server even if multiple users start this
procedure simultaneously. (Pivotal 5405603)

= The ARIS bar that enables users to access the portal, the catalog, etc., is now displayed to
newly created users who were assigned a license but have no access privileges. (See also
"Help", topic area "Manage ARIS Connect > Manage users", page "Create user".)
(Pivotal 5408011)
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Now, the background of the current display in ARIS Connect is no longer grayed out and
locked when

= auser with the "ARIS Connect Viewer" license was assigned the "Read" access
privilege in ARIS Architect for some groups of a database and

= the user clicks a group in ARIS Connect for which the user has no access privilege.

(See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Configure the system", page "Assign access privileges (users/user
groups)".) (Pivotal 5408348)

When you search for an item that does not exist, the error message "The requested item
cannot be found." no longer displays a bullet that provides no information. (See also
"Help", topic area "Use ARIS Connect > View content > Search content".)

(Pivotal 5408492)

When you type text into an input field very quickly, the text is now entered entirely
without being cut off. (See also "Help", topic area "Use ARIS Connect > Work with content >
Contribute as a viewer", page "Change values of items".) (Pivotal 5410346)

It is now possible to use hyphens in the names of JavaScript (js) and HTML templates
when modification sets are imported. (Pivotal 5410923)

When you specify in the XML configuration that the search in the portal is to be sorted by
item types (orderByltemtype=true), saved favorites are now displayed correctly. (See also
"Help", topic area "Use ARIS Connect > View content > Use favorites".) (Pivotal 5414278)

If a user has an ARIS Connect Viewer license and an ARIS Connect Designer license along
with an ARIS Aware license, the ARIS Connect Designer license is now used along with the
ARIS Aware license. Thus, the maximum functionality is available to the user. (See also
"Help", topic area "Manage ARIS Connect > Manage users", page "Available licenses in ARIS
Connect".) (Pivotal 5416296)

When you add a new component to a modification set and assign a name to it, the title of
the component is now displayed entirely in the "Home" area. (See also "Help", topic area
"Manage ARIS Connect > Configure the user interface > Edit modification set”, page "Edit
‘Home™"'.) (Pivotal 5416333)

The scroll bar is now displayed correctly in the "My activities" area of all configuration and
modification sets. (Pivotal 5416353)

The date format of the repository was adapted to match the date format of the other ARIS
Connect components. (Pivotal 5416407)

You can now always directly navigate to the corresponding model from the search. You
are no longer redirected to the page "Recently used models". (See also "Help", topic area
"Use ARIS Connect > Use the repository > Work in the repository”, page "Display and open a
recently used model".) (Pivotal 5416694)
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It is now possible to enter multiple lines in the "Title" and "Description” attributes. Thus,
lists of attributes such as "Image Title 1" and "Image Description 1" are displayed correctly.
(See also "Help", topic area "Use ARIS Connect > Create content > Create and edit models >
Extended editing > Use attributes”, page "Available editing options for attributes".) (Pivotal
5416746)

Corrections were made to the display of mini fact sheets in Mozilla Firefox. Mini fact
sheets are now automatically hidden when the model contents is moved. (See also "Help",
topic area "Use ARIS Connect > Work with content > Use models > Diagram fact sheet",
page "Show mini fact sheets".) (Pivotal 5418611)

The model size is now displayed correctly in the model overview even if the size of
appearance is set to less than 100% in the browser. (See also "Help", topic area "Use ARIS
Connect > Work with content > Use models > Diagram fact sheet", page "Navigate using
the Diagram fact sheet".) (Pivotal 5418765)

When you change the connection alignment, the connection now always remains linked to
the source and target objects instead of losing its connection to the target object and
connecting with the source object. (Pivotal 5421245)

Smart Modeling was extended so that it now supports the modeling of lane models in a
better way. For example, it is now possible to drop structurally relevant objects on a
connection in a lane model and thereby connect these objects with the successor and
predecessor object. (See also "Help", topic area "Use ARIS Connect > Create content >
Create and edit models > Model > Use Smart Modeling" and topic area "Glossary > S", page
"Structurally relevant objects".) (Pivotal 5421924)

The usability of ARIS Connect Designer was improved. When a bright font color is used,
the background color of the input field now switches from white to grey. This increases
the readability of the input. (Pivotal 5426287)

When you export the catalog contents to Microsoft Excel, a check is now performed to find
out whether exported links contain invalid characters. If this is the case, the links are
converted into text. (See also "Help", topic area "Use ARIS Connect > View content > Use
the catalog", page "Export catalog content to Excel".) (Pivotal 5428255)

Corrections were made to the "My documents (predefined search)" filter of the "My
favorites" area so that the filtered documents are now displayed correctly. (See also
"Help", topic area "Use ARIS Connect > View content > Navigate > Use favorites"”, page
"Filter using My Favorites".) (Pivotal 5428710)

The documentation on how to access the transformation configuration using a report was
improved. Further explanations on the various objects as well as some examples
describing the most important use cases were added. (Pivotal 5432644)
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= Corrections were made to the sorting of the catalog so that the alphabetic sorting now
remains active even if filters are used. (See also "Help", topic area "Use ARIS Connect >
View content > Use the catalog".) (Pivotal 5432682)

= Itis now possible to open a model multiple times in a row from the catalog even if a filter
was set. (See also "Help", topic area "Use ARIS Connect > View content > Use the catalog”,
page "Filter catalog items based on name, description, and responsibility".) (Pivotal
5432683)

= Corrections were made to the validation of configuration sets. Now, all user-defined
objects are found in the configuration sets during a search procedure. (See also "Help",
topic area "Manage ARIS Connect > Manage configuration sets".) (Pivotal 5433663)

= The result of an extended search is now correct even if user-defined attributes are used
for filtering. (See also ARIS Connect, "Help", topic area "Use ARIS Connect > View content >
Search content”, page "Use search context and filters".) (Pivotal 5435200)

= The message "You are logged out." can be prevented so that the login page is shown
directly after you logged out of ARIS Connect. To do this, you can specify on the global
configuration page that after a logout, the ARIS Connect login page opens.

= Users can now open models that contain connections from groups for which the user has
no access privileges. These connections appear grayed out. (See also "Help", topic area
"Manage ARIS Connect > Manage databases > "Manage database properties”, page "Access
privileges".)
= Filtering the catalog now works as expected.
= |f the language is changed, the catalog is correctly filtered by the changed date
format.

= |fyou specify that all data is to be displayed according to a defined date ("greater
than"), data for the defined date are no longer included in the result.

= |fyou set "less than" for the filtering, all other entries of the filtering are now retained.

(See also "Help", topic area "Use ARIS Connect > View content > Use the catalog”, page
"Filter catalog items based on name, description, and responsibility".)

= For a model that was changed, the timestamp of the "Last change" attribute is now
correctly output in the portal and in the model. (Pivotal 1416522, 5435179)

= You can now use the report "Output model information” also for matrix models. (See also
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use reports > ARIS reports >
Standard", page "Report: Output model information".) (Pivotal 5402080)
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= The report "Import data in Excel format" is now able to generate matrix models. (See also
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use reports > ARIS reports >
Standard", page "Report: Import data in Excel format".) (Pivotal 5402493)

=  When you use the DateChooser component in report dialogs, the date is now displayed in
the correct format DD-MM-YYYY. (See also ARIS Architect, "ARIS > Help > ARIS Script",
topic area "ARIS Script > Methods for reports and semantic checks > Global objects >
Dialog objects", page " DateChooser".) (Pivotal 5410893)

= The page numbers are now created correctly in PDF documents that are generated using
a report. (Pivotal 5412396)

= Corrections were made to the ARIS report script method "CxnDef.Delete(boolean)"” so that
this method no longer calls "doLayout()". Thus, it can no longer happen that a layout is to
be performed for a connection occurrence of a connection definition that was deleted.
(See also ARIS Architect, "ARIS > Help > ARIS Script", topic area "ARIS Script > Methods for
reports and semantic checks > Objects > CxnDef", page "Delete():boolean".)
(Pivotal 5413603)

= The parameter "binsertEmfAsPng" is now available for the ARIS report script method
"xIsSheet.insertPicture(int column, int row, byte[]". This parameter must be set to "True" if
the EMF graphic in use is a model graphic that was changed using commands of the
"Picture" object. This parameter corrects an error of an external library. The default value
of the parameter is "False".

Parameters:
= imageData
= intimageFormat
= intinsertMethod
= double widthMM
= double heightMM
* boolean binsertEmfAsPng)

As an alternative, we recommend that you create and insert the picture using the PNG
format. This resolves the issue also in previous ARIS versions (10.0.12). (See also ARIS
Architect "ARIS > Help > ARIS Script”, topic area "ARIS Script > Methods for reports and
semantic checks > Objects > Output objects > Workbook > XIsSheet", page
"insertPicture(int,int,byte[],int,int,double,double,boolean):void".) (Pivotal 5418049)
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Report generation is more robust now because it is no longer possible for a report to open
more than 50 databases at the same time. If more than 50 databases are opened, an
exception can occur, which usually indicates a script error. (See also "Help", topic area
"Use ARIS Connect > Create content > Create and edit models > Model > Extended editing",
page "Generate report".) (Pivotal 5415414)

When you call the ARIS report script method "SingleSelectElement.setSelection(-1)" for a
list box, subsequent controls are now correctly updated in ARIS Connect. (See also ARIS
Architect "ARIS > Help > ARIS Script", topic area "ARIS Script > Methods for reports and
semantic checks > Global objects > Dialog object > SingleSelectElement”, page
"setSelection():int:boolean".) (Pivotal 5418996)

The ARIS report script method "MatrixHeaderCell.getColor()" now no longer outputs a null
pointer exception when a cell has no fill color. (See also ARIS Architect "ARIS > Help > ARIS
Script", topic area "ARIS Script > Methods for reports and semantic checks > Objects >
MatrixHeaderCell", page "getColor():int".) (Pivotal 5419473)

ARIS report script: Additional line breaks are now no longer inserted after bullet points or
enumerations. (Pivotal 5419753)

ARIS report script: When you generate Microsoft Word documents with the content of the
ARIS attribute "Documentation” (AT__DOCUMENTATION), now the locale is considered
correctly. (See also ARIS Architect "ARIS > Help > Working with ARIS", topic area "Edit
models > Edit attributes > Extended editing", page "Create an external description" and
"ARIS > Help > ARIS Script", topic area "ARIS Script > Methods for reports and semantic
checks > Objects > AttrBlobDef", page "createExternalDocument():ExternalDocument”.)
(Pivotal 5423359)

For list items, now the text format of the first text that is output by the report is used. This
meets the user expectation in a better way than using the text format of the last text.
(See also ARIS Architect, "ARIS > Help > Working with ARIS", topic area "ARIS Configuration
and Administration > Specify conventions > Good to know", page "How do languages,
fonts, scripts, and Diagram fact sheet interrelate?".) (Pivotal 5423360)

The size of the model graphic that is generated using the "Export graphic as PDF"
standard report is now identical regardless of whether the graphic is exported with or
without the background color. (See also "Help", topic area "Use ARIS Connect > Create
content > Model > Extended editing > Generate report > Available reports”, page "Export
graphic as PDF".) (Pivotal 5436021)

Corrections were made to the semantic check rule types "Model attribute rules" and
"Object attribute rules" so that these rules no longer indicate an error when there is none.
(See also "ARIS > Help > Working with ARIS", topic area "Edit models > Check and approve
models > Run semantic checks > Good to know", page "What are rule types and profiles?".)
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Reports that open a drop-down list box in ARIS Connect now always offer all configured
items for selection. (See also "Help", topic area "Use ARIS Connect > Create content >
Create and edit models > Model > Extended editing > Generate report”, page "Available
reports".)

Semantic checks for models that contain objects with object definitions for which the
user has no access privileges are now performed correctly. Locked object definitions are
not evaluated. (See also "ARIS > Help > Working with ARIS", topic area "Edit models > Check
and approve models > Run semantic checks > Good to know", page "What are rule types
and profiles?".)

The report "Compare models" now compares models correctly even if models of different
versions of a database are compared.

Generating models that use a background color no longer results in an error. (See also
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use reports > ARIS reports >
Standard", page "Report: Export graphic as PDF".)

It is now possible to start documents that were downloaded from SAP Solution Manager to
ARIS by pressing "F7". (See also ARIS Architect, "ARIS > Help > Working with ARIS", topic
area "Special topics and functions > ARIS for SAP Solutions > Specific handling using SAP
Solution Manager 7.2", page "Transfer and synchronize data (SAP Solution Manager 7.2)".)
(Pivotal 5420564)

ARIS Test Designer now creates test paths correctly even if a user has only the "Read"
privilege for the Process Step Library and the Executable Library in ARIS. (See also ARIS
Architect, "ARIS > Help > Working with ARIS", topic area "Evaluate data > Test Designer".)

You can use the following ARIS default object symbols for satellite modeling in the SAP
context: "Screen", "Project documentation”, "Test documentation”, and "Class".

(See also "Help", topic area "Use ARIS Connect > Create content > Create and edit models >
Model > Extended editing > Use satellites"”, page "Create a connection to a new satellite".)

Using the report API, it is now possible to save documents that have the same name but
different metadata to ARIS document storage in parallel. (See also "Help", topic area "Use
ARIS Connect > Create content > Create and edit models > Model > Extended editing > Use
documents", page "Upload documents".) (Pivotal 5435538)
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= The ARIS Process Governance service "Write - 1 attribute to multiple elements" now fails
for the various attribute types when a model is locked by a user. (Pivotal 5435568)

=  When you perform Oracle installations, the error "ORA-01795: maximum number of
expressions in a list is 1000" no longer occurs during merge operations. (Pivotal 5402994)

* The new setting "abs.methodology.shouldSaveDataOnClientSide" is now available. You
can use this setting to specify whether serialized method data is to be stored on the
client. The default is "True" so that the method data are stored on the client. (Pivotal
5407952)

= Corrections were made to the logging in ARIS ScriptRunner. (See also ARIS Architect,
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use reports", page
"Automatically start reports with Script Runner".) (Pivotal 5413717)

= When you use the ARIS report script option "setSynchronizeAssignments(true)",
assignments are now correctly updated in the target database during a merge procedure.
(See also ARIS Architect, "ARIS > Help > ARIS Script", topic area "Methods for reports and
semantic checks > Global objects > Report component interfaces > Merge > MergeBase
Options", page "setSynchronizeAssignments(boolean):void".) (Pivotal 5422733)

= The HD server's report processing was made more robust so that erroneous reports no
longer block the HD server. (Pivotal 5435529)

=  When you import the table "BUSINESSPROCESSMODEL" from Alfabet into ARIS, now all
subordinate systems are also imported correctly. (See also ARIS Architect, "ARIS > Help >
Working with ARIS", topic area "Special topics and functions > Enterprise Architecture
Management > ARIS - Alfabet Interoperability Interface".) (Pivotal 5427952)

= The ArchiMate export setting "Connections" now works correctly so that depending on the
setting, connections are included in or excluded from the export. (See also "ARIS > Help >
Working with ARIS", topic area "Export/Import > ArchiMate® export/import”, page "Export
ArchiMate® file".) (Pivotal 1433554)
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In an |IE data model, it is now possible to create a "has relationship to" connection between
a reinterpreted relationship type and an entity type. (Pivotal 5423994)

It is now possible to run a simulation experiment on a server on which more than one
simulation runnable is available. (See also ARIS Architect, "ARIS > Help > Working with
ARIS", topic area "Special topics and functions > Simulation > Experiments", page "Start
new experiment" and topic area "ARIS Configuration and Administration > ARIS Server and
Tenant Management > ARIS Cloud Controller (ACC)", page "What runnables are available?".)
(Pivotal 5399915)

When you change SMTP settings in ARIS Administration, the placeholder password now
remains unchanged. (Pivotal 5409842)

In the user management, API calls now also work in an environment that uses multi-LDAP
configuration. (Pivotal 5419788)
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ARIS Dashboarding

Preview of the upcoming new dashboarding. The preview is accessible through the lab
symbol in the current dashboarding- and feed editor applications. Functionally, the new
dashboarding is targeted towards responsive design and include a new dashboard layout
engine as well as new visualizations, new workflows and a completely rewritten Ul. Most of
the existing dashboard can be migrated. Also, all data feeds except for a few can be
opened in the new web clients. Features which will be added for the final release include

multi-language support as well as customizations and styling capabilities.

é o Manage

MNew dashboarding is here

Check out the new dashboarding with great

performance and cool new features
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= The SQL injection vulnerability that existed in connection with the "Find groups" function
in Collaboration has been eliminated. (See also "Help", topic area "Use ARIS Connect >
Collaborate with users > Work with groups", page "Follow portal contents as a group".)

= The Elasticsearch runnable starts properly now after an ARIS version was updated to
ARIS 10.0 SR12. (Pivotal 5414298)

= The search in ARIS Architect can now be opened in general. (See also "ARIS > Help >
Working with ARIS", topic area "Navigate and edit items", page "Search for database
content".) (Pivotal 5409870, 5411262)

= |n document storage, the correct byte size of the files uploaded under Windows into a
WebDAYV folder of a WebDAYV drive is displayed. (See also "Help", topic area "Manage ARIS
Connect > Manage documents”, page "Use ARIS document storage with WebDAV" and
"Manage ARIS Connect >Configure ARIS Connect > Set up Document storage", page
"Configure WebDAV".) (Pivotal 1401786)

= The document storage plug-in now returns "false" if a user does not have the required
privileges. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Use
documents", page "What is ARIS document storage?".)

= With ARIS Release 10 SR12, the output format of the "Return timestamp" data flow
operator changed. It has been reset to the former output format. (Pivotal 5415947)

= Buttons are now properly shown or hidden on subordinate report pages. (Pivotal 5415456)
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Unauthorized users can no longer retrieve activities liked by other users. (See also "Help",
topic area "Use ARIS Connect > Collaborate with users”, page "Comment on, share, flag
posts, etc.")) (Pivotal 5406104)

The Collaboration function is now no longer available if Collaboration was deactivated in
the administration (the "Collaboration activated" check box is disabled). If Collaboration is
opened, the user is notified that this function needs to be enabled first. (See also "Help",
topic area "Manage ARIS Connect > Configure Portal > Set up Collaboration", pages
"Customize Collaboration" and "What properties are available for Collaboration?".) (Pivotal
5414381)

The Technical user is now found if a health check on the ECP runnable is performed.
(Pivotal 5415245)

The vulnerability during the execution of the ExportActivitiesServlet in Collaboration (Path
Traversal Vulnerability) has been eliminated.

The get request of the system for cross-domain identity management (SCIM) now returns
the correct start index, the SCIM group APl is updated by the put request, and the group
display name is output in the SCIM client. (Pivotal 5400346)

SAML single sign-on was extended so that it works properly and the 'RelayState' can be
queried for customer-specific identity providers (IDPs). (Pivotal 5406906)

The filter analysis logic was adopted to the new SCIM standard. This results in user data
being processed properly. (See also "Help", topic area "Manage ARIS Connect > Manage
users > Use SCIM".) (Pivotal 5413456)

If a model is shared, the "Select users" dialog box now finds users with names spelled in
Korean. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Use model",
page "Share model".) (Pivotal 5416091)

The LDAP configuration was corrected. User data is transferred to the proper tenant now
so that the user is logged in properly. (Pivotal 5416260)

If a query is performed for a query element for which the "Merge results" item has been
deactivated, the empty rows in the query result table are now removed. (Pivotal 5413689)
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Confirmations in ARIS Connect are now displayed properly via the GRC task list and the
link in the e-mail notification. A confirmation was not displayed when confirmations
existed for different objects/models in different databases and the respective other
database was used before. (Pivotal 5404109)

GRC dashboards in ARIS Risk & Compliance Manager are no longer displayed in minimized
format. (Pivotal 5409991)

It used to be impossible to assign documents to questions when using Internet Explorer 11.
This error has been fixed. (Pivotal 5410739)

The monitoring server task that checks issues for due dates now checks environment-
specific and cross-environment issues. (Pivotal 5411269)

ARIS Reporting errors have been fixed. The generation of reports now works smoothly for
customized, complex queries of ARIS Risk & Compliance Manager data. (Pivotal 5412046)

The error occurring in test cases without hierarchy assignment during the calculation of
evaluations was eliminated. (Pivotal 5413668)

ARIS accelerators for GDPR: Groups ('Role' object) that were deleted from the system fact
sheet in the Contribute mode (‘'Edit > Contribute') are also deleted in the corresponding
model.(See also "Help", topic area "Use ARIS Connect > Work in the portal > Contribute as a
viewer".)

All connections are now available in the GDPR method filter.

Documents that are assigned to controls or test definitions in ARIS Architect will be
synchronized to ARIS Risk & Compliance Manager.

The "Environment" attribute is now displayed in the Issue form if the same object is
assigned as issue-relevant via various environment.

The error that occurred during the calculation of evaluations in test cases without
hierarchy assignment has been fixed.

Lists and evaluations of audits can now be opened.

The error that prevented user-defined filters in ARIS Risk & Compliance Manager
evaluations from being saved has been fixed.

The Document and Simple links in the questionnaire are now shown as clickable.
The error preventing substitute users from opening assigned documents has been fixed.

Navigation from ARIS Risk & Compliance Manager to ARIS Connect now works even if the
HTTP port is not the standard port 80.

Characters such as',' (comma) are now properly displayed in the 'Output change log'
report.
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Catalog content is now properly grouped for export. (See also "Help", topic area "Use ARIS
Connect > Use the Catalog", page "Export catalog content to Excel".) (Pivotal 5406541)

Catalog content is exported properly now even if they contain links with spaces. (See also
"Help", topic area "Use ARIS Connect > Use the Catalog", page "Export catalog content to
Excel".) (Pivotal 5406542)

Personal favorites that were created a long time ago can now be removed. (See also
"Help", topic area "Use ARIS Connect > Work in the portal > Use favorites”, page "Remove a
personal favorite ") (Pivotal 5408012)

UML content maintained in a database language other than English (United States) is now
visible if all other database languages were deleted. Example: If you maintained UML
content in "English (United Kingdom)" rather than in "English (United States)" and delete
all other languages in the database, the UML content is properly displayed. (See also
"Help", topic area "Use ARIS Connect > Work in the portal > Views > Valuable information”,
page "When can UML content be displayed?".) (Pivotal 5410936)"

If database content is filtered in the "My content" view, the filtered content remains
displayed even if the user logs off and logs in again with a different user name. (See also
"Help", topic area "Use ARIS Connect > Work in the portal > Views > Valuable information”,
page "What is the structure of the My content area?".) (Pivotal 5410968)

The ARIS Connect Portal now displays the proper content even if the view is not refreshed
with F5. (See also "Help", topic area "Use ARIS Connect > Basics > Valuable information”,
page "Keyboard shortcuts generally available".) (Pivotal 5411075)

The "Diagram" fact sheet remains enabled after a change from it to another browser tab
and back, so that it is no longer necessary to click twice to enable its functionality. (See
also "Help", topic area "Use ARIS Connect > Work in the portal > Views > Valuable
information”, page "What is the Diagram fact sheet for?".) (Pivotal 5411479)

The extended search now properly returns the path of the model listed below. (See also
"Help", topic area "Use ARIS Connect > ", page "Search content".) (Pivotal 5411569)"

Mini fact sheets are now displayed for objects of an assigned model even if the assigned
model was accessed by jumping there from a link in a mini fact sheet of the superordinate
model. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Use models >
Diagram fact sheet", page "Show Mini fact sheets".) (Pivotal 5411803)

The "Highlight" function updates the model properly now after settings were changed.
(See also "Help", topic area "Use ARIS Connect > Work in the portal > Use models >
Highlight model items".) (Pivotal 5413061)
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The "Recently used" area in the repository properly shows all recently used models now.
(See also "Help", topic area "Use ARIS Connect > Use the repository > Work in the
repository > Model > ", page "Display and open a recently used model".) (Pivotal 5413283)

Mini fact sheets now display the text for the "Role" object symbol properly before the
object symbol. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Use
models > Diagram fact sheet", page "Show Mini fact sheets".) (Pivotal 5414076)

Assignments are now properly opened in ARIS Connect Designer. (See also "Help", topic
area "Use ARIS Connect > Use the repository > Create and edit models > Model > Extended
editing > Assign models", page "Open assigned model".) (Pivotal 5414668)

All customer-specific changes to Boolean configuration values that are configured
differently from the default configuration, e.g., enableOverlay, are now adopted. (See also
"Help", topic area "Manage ARIS Connect > Configure Portal > Manage configuration and
modification sets", page "Edit modification set".) (Pivotal 5415810)"

The "ARIS Aware" license privilege is now prioritized over the "ARIS Connect Viewer"
license privilege. If both license privileges are available, only the "ARIS Aware" license
privilege is used. (See also "Help", topic area "Manage ARIS Connect > Manage users", page
"Use case - Manage users".) (Pivotal 5416296)

The "Steps" view now properly displays process models such as the EPC (event-driven
process chain) if they contain a start object connected to a process interface. (See also
"Help", topic area "Use ARIS Connect > Work in the portal > Views > Valuable information”,
page "What is the Steps fact sheet for?".) (Pivotal 5414595; 5414696)

The ARIS Connect logo and user logos are now displayed in the proper size in all
configuration and modification sets. (See also "Help", topic area "Manage ARIS Connect >
Configure Portal > Manage configuration and modification sets".)
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= A Bootstrap security vulnerability was eliminated. Using the ".attr()" method now no longer
enables cross-site scripting (XSS) (see
https://github.com/twbs/bootstrap/issues/20184).
(Pivotal 5395569)

= Searching for group names now returns correct results again. (Pivotal 5386344)

= |n ARIS Architect, the search dialog is now displayed much faster for systems that provide
a lot of user-defined method contents. (See also "ARIS > Help > Working with ARIS", topic
area "Navigate and edit items", page "Search for database content".) (Pivotal 5389461)

= The connection selection dialog is now no longer displayed in BPMN diagrams when
objects are placed on top of each other. (Pivotal 5389668)

= A correction was made to the date selection in ARIS Architect. If you click "Today", now
the date of the current day is selected. (Pivotal 5392609)

=  When you change the content of the attribute "Documentation” (AT_DOCUMENTATION),
the attributes "Last change" and "Last editor" are now correctly updated. (Pivotal
5394029)

= When you copy text into the "Identifier" attribute, existing line breaks are automatically
removed during the save operation because this attribute is a single-line attribute.
(Pivotal 5394095)

= When you edit a filter in the Filter Wizard, all attribute type groups are provided now. (See
also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and Administration >
Specify conventions”, page "Edit filter".) (Pivotal 5394335)

= Loading the list of users in ARIS Architect was improved. If there is a large number of
users, it now no longer takes several minutes to display the user list. Even if there are
more than 90000 users, displaying the list takes only 10 seconds. (Pivotal 5397244)

= When you change the default symbol of an object definition, this change is now directly
displayed in the Explorer tree. There is no need to restart the program. (See also "ARIS >
Help > Working with ARIS", topic area "Navigate and edit items > Create and manage
objects", page "Replace object symbol for definition".) (Pivotal 5397955)
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= During the automatic layout operation, a large free space is no longer added at the top of
the model. (See also "ARIS > Help > Working with ARIS", topic area "Edit models > Extended
editing”, page "Generate model layouts automatically".) (Pivotal 5398004)

= The copy function of the method administration in ARIS Architect now works correctly
again. (See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Manage ARIS Method.) (Pivotal 5398489)

= CPU usage by the "abs" runnable was optimized. (Pivotal 5393612)

= Object occurrences are no longer incorrectly created in assigned models. (See also "ARIS >
Help > Working with ARIS", topic area "Edit models > Basic > Link models", page "Assign a
new model".) (Pivotal 5395850)

= |t now no longer happens that the list of completed tasks in ARIS Connect Administration
is empty for a specific amount of time even though tasks were completed. (Pivotal
5398464)

= When you restore the system database, incorrect states are now automatically corrected
so that method filters can be imported later at any time. (Pivotal 5399878)

= Versioning errors now no longer occur when UML2 content is deleted. (Pivotal 5400111)

= The display of swimlane models is now generated faster and more efficiently with regard
to resources. (Pivotal 5400720)

= The renaming of a main group is now correctly transferred during a merge procedure. (See
also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and Administration >
Manage Databases", page "Merge databases".) (Pivotal 5401277)

= |n modification sets, attributes containing Word documents, for example, are now no
longer handled as attributes of the "STRING" base type but as attributes of the "BLOB"
base type. Attributes of the "BLOB" base type are mapped to markup attributes so that
their content is interpreted as documents that can be displayed in ARIS Connect fact
sheets. (Pivotal 1401465)

= |nthe ARIS Connect configuration sets, the default setting for "SendSignal" is now set to
"false". (Pivotal 5377079)

= There used to be a display issue in ARIS Connect. During the editing of models, margins of
text boxes were not displayed in the same way as in the portal and in ARIS Clients. You
can solve this issue by using the "defaultServerSettings.cfg" configuration file. Open the
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configuration file ("<ARIS10.0 installation
directory>\server\bin\work\work abs_m\base\webapps\abs\config") and set the value
of "abs.graphics.fontFractionalMetrics.enabled" to "true". (Pivotal 5378256)

= In ARIS Connect, integer attributes are no longer displayed as decimal numbers in spin
boxes. (Pivotal 5381647)

= |Inthe portal, predecessors and successors in a process are now correctly displayed on the
"Steps" fact sheet. Before the fix, all processes were evaluated that were assigned to a
process interface and that were linked by connections to each event and each function.
Now, when the steps are displayed, also the connections to objects of the "Rule" type are
considered and not all of the assigned process models are used. (See also "Help", topic
area "Use ARIS Connect > Work in the portal > Views > Valuable information > ", page "What
is the Steps fact sheet for?".) (Pivotal 5382369)

=  When you log in to the portal, the portal now displays only role filters that are relevant to
the corresponding user group. (Pivotal 5384831)

= |n the language selection field in ARIS Connect, all languages are now displayed using an
uppercase letter for the first letter of a language. (See also "Help", topic area "Use ARIS
Connect > Basics > ", page "Select language".) (Pivotal 5386027)

= |n ARIS Connect, report output files are now created with the correct file name.
(Pivotal 5391360)

= |n ARIS Connect, the border lines of empty columns, rows, and lanes in models with row
and column display are now entirely displayed. (Pivotal 5394856)

*= The licence problem that was encountered after the creation of modification sets no
longer occurs. (Pivotal 5394908)

= The date format is now used in accordance with the language you have selected.
(Pivotal 5395295)

= |naversioned model in ARIS Connect, model assignments now open in the selected model
version. (Pivotal 5395490)

= |n ARIS Connect, models are now displayed correctly when you use Microsoft IE 11. (Pivotal
5395532)

= |n ARIS Connect, object names are now always displayed correctly even if you click the
corresponding object symbol multiple times. (Pivotal 5395649)

= |n ARIS Connect Designer, you can now create connection assignments for matrix models
in the same way as in ARIS Architect. (Pivotal 5396940)

= The error message that was issued when the action "Reload and validate configuration
files" was carried out is now no longer displayed. (Pivotal 5399060)
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An error was fixed due to which an unknown context was displayed when a model was no
longer available in the version that was last published. (Pivotal 5387890)

You can now delegate human tasks in ARIS Process Governance even if an assigned user
was deleted from the user management. The process instances no longer fail if a reminder
e-mail is sent to the deleted user. Instead, the process administrator is informed by e-mail
that the user is missing. (Pivotal 5397720)

An error was fixed due to which the user selection was not displayed in an ARIS Process
Governance report. (Pivotal 5398486)

Assignment and task reminder links to ARIS Process Board are now clickable in ARIS
Process Governance e-mails.

Importing date attributes using the "Import data in Excel format" report now works
correctly. (See also "ARIS > Help > Working with ARIS", topic area "Evaluate data > Use
reports > ARIS reports > ", page "Report: Import data in Excel format".) (Pivotal 5381277)

When you export matrix models as a graphic using ARIS reports, object names in matrix
models are no longer cut off if you use "SansSerif" as the font in matrix models. To ensure
this, you can use the command "set designer.matrix.font "<your preferred font>"" in "ARIS
Server Administrator". (See also "ARIS > Help > Working with ARIS", topic area "Evaluate
data > Use reports > ARIS reports > ", page "Report: Export graphic as PDF".)

(Pivotal 5389459)

For report output in PDF or HTML format, the representation and resolution of model
graphics was improved for the use of zoom factors <100% (e.g., 50%). (Pivotal 5392321)

The size of backup files of the system database was reduced. Report output files of
scheduled reports are no longer saved to the system database. Old files that still exist are
automatically deleted when a scheduled report is run or the corresponding schedule is
edited. (Pivotal 5394801)

In ARIS Script, an error was fixed that used to occur when the
"CellStyle.getTopBorderColor()" method was used in combination with an XLSX file.
(Pivotal 5397531)

In ARIS Script, running the "Attr - GetValue (boolean)" method for an empty attribute of
the "AT__Documentation” type no longer results in an error. (Pivotal 5399939)
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ARIS User Management

* Problems concerning the LDAP connection were resolved. (Pivotal 5368527)

= The command line tools of the user management were adapted so that it is now possible
to edit users and user groups that use Cyrillic letters. (Pivotal 5399801)

ARIS Analysis

= The query result is now no longer empty if user-defined attributes are used for queries for
conditions. (See also "ARIS > Help > Working with ARIS", topic area "Evaluate data > Use
queries"”, page "Add conditions".) (Pivotal 5396082)

43



RELEASE NOTES

Checking the privileges of internal APIs for opening or forwarding forms was improved.
(Pivotal 5394418)

Names that contain an underscore ('_') no longer cause error messages when dashboard
links are generated. (Pivotal 5395500)

An error was fixed so that risks that are not assigned to a process hierarchy are now
considered in the linked list of evaluations. (Pivotal 5400994)

The workflow buttons are now deactivated in forms when a violation of the segregation of
duties has occurred.

An error concerning the risk manager privileges was fixed. Risk managers are now allowed
to generate and review risk assessments when they are assigned environment-specific
and object-specific roles at the same time.

An error was fixed so that surveys can now be created on the basis of manually created
working copies of questionnaire templates.

Now the audit scope is displayed in the form directly after having been assigned. Before
the fix, the audit scope was displayed only after the form was saved.

In ARIS Risk & Compliance Manager, it is now possible to define a general sender alias for
notifications.

The Customizing Toolkit (CTK) for ARIS Risk & Compliance Manager now works correctly
when custom DSL files are used.
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= Links specified in link attributes are now correctly resolved so that the target is correctly
displayed. (See also "Help", topic area "Use ARIS Connect > Use the repository > Create and
edit models > Model > Extended editing > Use attributes > Valuable information”, page
"What editing options are available for attributes?".) (Pivotal 5386684)

= |n column/row models, you can now add only columns and rows in which you can create
connections that are allowed by the method filter in use. (See also ARIS Architect, "ARIS >
Help > Working with ARIS", topic area "Glossary > L", page "Lane model" or ARIS Connect,
"Help", topic area "Use ARIS Connect > Glossary > L", page "Lane model".)
(Pivotal 5387414)

= Now, newly created system users are provided the "Administrator: Unlock" functionality
for models and objects. (See also "ARIS > Help > Working with ARIS", topic area "Edit
models > Check and approve models > Use locks", page "Unlock models" and "Unlock
objects".) (Pivotal 5389186)

= Certain circumstances used to result in the problem that backing up the latest version or a
specific change list of an ARIS database failed. Now, you can successfully back up any
latest version of an ARIS database as well as all available change lists. (See also "ARIS >
Help > Working with ARIS", topic area "ARIS Configuration and Administration > ARIS
Server and Tenant Management > Managing tenants > Tenant Management tool > Tenant
Management > Manage tenants", page "Back up tenant".) (Pivotal 5385756)

= Corrections were made to ARIS Mobile API so that all REST API query operations now work
correctly. (Pivotal 5391291)

= ARIS for SAP Solutions - SAP Solution Manager 7.2 synchronization:
Models of the "EPC (row display)" or "EPC (column display)" type that were transferred
from ARIS to SAP Solution Manager 7.2 using the "Transfer models" option, are now
displayed correctly in SAP Solution Manager even after row or column headers are deleted
from the ARIS models. The default name of row or column headers in this kind of model
type is "Organizational elements & Application system". (See also "ARIS > Help > Working
with ARIS", topic area "Special topics and functions > ARIS for SAP Solutions > Specific
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handling using SAP Solution Manager 7.2 > Transfer and synchronize data (SAP Solution
Manager 7.2) > Transfer models to SAP® Solution Manager".) (Pivotal 5381936)

The content of the "Activities" table in the "Overview" fact sheet is now entirely displayed
when you click "Show all". (See also "Help", topic area "Use ARIS Connect > Work in the
portal > Views > Valuable information"”, page "What is the Overview fact sheet for?".)
(Pivotal 5386744)

The view configuration and validation of configuration and modification sets was
corrected in such a way that only relevant warnings are issued now when a view that was
edited is being reloaded. (See also "Help", topic area "Manage ARIS Connect > Configure
ARIS Connect" and topic area "Manage ARIS Connect > Configure ARIS Connect >
Configure Portal" page "Manage configuration and modification sets".) (Pivotal 5387569)"

Mozilla Firefox now correctly reloads HTML templates when you close and reopen the
browser using ARIS Connect. (Pivotal 5388203)

If displaying mini factsheets is disabled, mini factsheets are now no longer displayed in
customer configurations. Furthermore, models are now correctly resized in customer
configurations when "Fit to window" is clicked. (See also "Help", topic area "Use ARIS
Connect > Work in the portal > Use models > Diagram fact sheet", pages "Switch on the
mini fact sheet display" and "Use the view bar".) (Pivotal 5388529)

The layout of the "My favorites" area is now displayed correctly when additional properties
are added by the XML configuration to models saved to a list of favorites. (See also "Help",
topic area "Use ARIS Connect > Work in the portal > Use favorites".) (Pivotal 5388704)

Catalog pages are now being loaded much faster and now display the entire contents.
(See also "Help", topic area "Use ARIS Connect > Use the Catalog", page "Choose items
starting with the same letter".) (Pivotal 5388727)

You can now download the catalog contents from an Excel export to a local computer with
German set as the language in ARIS Connect. (See also "Help", topic area "Use ARIS
Connect > Use the Catalog", page "Export catalog content to Excel".) (Pivotal 5390914)

During a tenant backup, all temporary files of ARIS Process Governance are now correctly

deleted. (See also program "Tenant Management”, " Help > Tenant management", topic
area "Manage tenants", page "Back up tenant".) (Pivotal 5385103)
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= Corrections were made to the time zone on the server side. Thus, ARIS Architect and the
"Output model information" report now display the correct time in the "Last change"
attribute. (Pivotal 5386607)

»= Forreasons of security, Alfabet now uses Alfabet RESTful API v2. We strongly recommend
that you no longer use Alfabet RESTful API v1 because this version will be phased out
sometime in the future. (See also "ARIS > Help > Working with ARIS", topic area "Special
topics and functions > Enterprise Architecture Management > ARIS > Alfabet
Interoperability Interface > Configuration > Modify configuration", page "Modify
configuration of Alfabet REST API v2".)

= The description "Configure MashZone NextGen Business Analytics to display dashboards"
was updated and enhanced with a description relevant to ARIS Aware: "Configure
MashZone NextGen Business Analytics/ARIS Aware to display dashboards". Performing
the steps now leads to the expected result.

= The "Confirmations" area now opens when you select an object from an inactive database
and thus change the database to perform the confirmation.

= The "Document upload allowed" attribute is now available in the ARCM attribute
maintenance macro in ARIS Architect.

= |nformation that is available for an event when event enabling is used can now be fully
read instead of being cut off after the "&" character even if that information contains XML
entities such as "&amp".

= Users can now perform role-based tasks, such as generating objects, for as long as the
corresponding role is assigned to them for at least one environment.

= The English tooltip now describes the e-mail fallback mechanism in more detail: "Specifies
the sender e-mail address for messages triggered by scheduled server tasks. If the Server
task sender is not specified, the sender address from ARIS Administration is used instead,
provided that it is specified (Configuration > User management > SMTP > Connection).”
With the service release ARIS 10 SR 12 in April 2020, this tooltip will be up-to-date in all
other available languages.

= You can now specify one and the same user as a substitute more than once.
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In User Management, you can now reset the privileges for all existing user groups.
Furthermore, the Call Level Interface (CLI) was adapted in such a way that data that is no
longer valid can be removed. (See also manual "ARIS Document Storage Command-Line
Tool", chapter "Command line tools for ARIS document storage”, Command
"deleteAccessPrivileges".) (Pivotal 5386534)

Importing SAP default dashboards now works correctly. (See also "Help", topic area
"Manage ARIS Connect > Administrate dashboards (ARIS Aware) > Configure dashboards >
Make default dashboards available", page "Import default dashboard content".)

You can now export models of the "Spreadsheet” type using the "Read" privilege. (See also
"ARIS > Help > Working with ARIS", topic area "Create models > Spreadsheeds > Advanced
editing", page "Export spreadsheet to Microsoft Excel".) (Pivotal 5392039)
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Multiple third-party libraries were updated due to known weak points that could have
resulted in a denial of service or the execution of remote code:

= CVE-2018-19362 in jackson-databind-2.9.5 allows deserialization of untrusted data.
Refer to https://snyk.io/vuln/SNYK-JAVA-COMFASTERXMLJACKSONCORE-72882 for
more information.

= CVE-2018-11771 in commons-compress-1.16.1 allows denial of service (DoS) attacks.
Refer to https://snyk.io/vuln/SNYK-JAVA-ORGAPACHECOMMONS-32473 for more
information.

= CVE-2015-7501 in commons-collections-3.2.2 allows deserialization of untrusted data.
Refer to https://snyk.io/vuln/SNYK-JAVA-COMMONSCOLLECTIONS-30078 for more
information.

The current Service Release 10 now contains the following versions:
jackson-databind-2.9.8
commons-compress-1.18
commons-collections-4.4

(Pivotal 5379994)

When you model a dialog, spaces used in option button group labels are now no longer
replaced with underscores. (See also "ARIS > Help > Working with ARIS", topic area "Special
topics and functions > Process Governance > Model > Model dialogs > Valuable
information" > Elements pane, page "Option button group".) (Pivotal 5362426)

In the "My tasks" area, when tasks are delegated or deleted, now the correct number of
pending tasks is displayed without the need to manually refresh the page. (See also "Help",
topic area "Use ARIS Connect > Work in the portal > My tasks", page "Open My tasks".)
(Pivotal 5370241)

In the "My tasks" area, country-specific special characters used in texts such as model
names are now correctly displayed with both uppercase and lowercase letters. (See also
"Help", topic area "Use ARIS Connect > Work in the portal > My tasks", page "Open My
tasks".) (Pivotal 5374079)

The locks underlying the "Request approval” mini workflow were adjusted in such a way
that locked models using the same objects no longer cause the workflow to terminate.
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(See also "Help", topic area "Use ARIS Connect > Work in the portal > Use Mini workflows",
page "Ask for model approval”.)

=  Models whose names include line breaks are now found in a search for database content.
(See also "ARIS > Help > Working with ARIS", topic area "Navigate and edit items", page
"Search for database content".) (Pivotal 5381493)

=  When you copy lanes into a pool, the placement of pool labels now remains unchanged.
(See also "ARIS > Help > Work with ARIS", topic area "Create models > BPMN diagrams",
page "Move a lane".) (Pivotal 5364763)

= |n models of the "Value-added chain diagram" type, connections are now correctly aligned
to the grid when the insertion symbol of Smart Modeling is used. (See also "ARIS > Help >
Working with ARIS", topic area "Create models > ARIS models > Use Smart Modeling", page
"Connect objects".) (Pivotal 5371953)

= When you open a model, the given grid width is now at least 2. This ensures that you are
always able to draw connections between objects. (See also "ARIS > Help > Working with
ARIS", topic area "Create models > ARIS models", page "Set grid".) (Pivotal 5372424)

= The "Select Alfabet object" dialog now provides pagination when there is a large number
of objects so that mapping objects is more comfortable now. (See also "Help", topic area
"Use ARIS Connect > Use the repository > Create and edit models > Model > Extended
editing > ARIS and Alfabet", page "Map Alfabet objects to ARIS objects".) (Pivotal 5374649)

= Corrections were made to the preview of expanded objects of the "Subprocess" type used
in BPMN diagrams. The subprocess content is now displayed correctly. (See also "Help",
topic area "Use ARIS Connect > Use the repository > Create and edit models > Model > Use
BPMN modeling support”, page "Expand subprocess".) (Pivotal 5375518)

= |n ARIS Connect, method content is now displayed correctly when two or more variants of
the same language are used in a modification set (for example, "English (Ireland)" and
"English (United States)"). (See also "Help", topic area "Manage ARIS Connect > Manage
ARIS Connect > Configure Portal > Manage configuration and modification sets", page "Edit
modification set".) (Pivotal 5381160)

= In ARIS Architect/ARIS Designer, you can now delete the "ARIS document storage Link"
attribute by selecting it on the "Attributes” tab and pressing the "Del" key. (See also "ARIS
> Help > Working with ARIS", topic area "Edit models > Extended editing > Edit attributes >
Extended editing”, page "Specify link to a document in ARIS document storage”.) (Pivotal
5382482)

* The "Smart Modeling" functionality was improved. You can now use the combination "Shift
+ Del" to delete a connection within a process flow along with the connected object. If you
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press only "Del" instead, a connection is created between the remaining objects. This
connection is automatically selected so that you can easily delete it by pressing the "Del"
key again when necessary. (See also "Help", topic area "Use ARIS Connect > Use the
repository > Create and edit models > Model", page "Use Smart Modeling" and ARIS
Architect/Designer: "ARIS > Help" > Working with ARIS", topic area "Create models > ARIS
models", page "Use Smart Modeling".) (Pivotal 5382796)

=  When a model assignment is created for a model that is being edited by another user and
can therefore be accessed only in read-only mode, now a message is displayed indicating
that the model cannot be assigned. (See also "Help", topic area "Use ARIS Connect > Use
the repository > Create and edit models > Extended editing > Assign models”, page "Assign
a model to an object".) (Pivotal 5385113)

= Corrections were made to the ARIS session cleaner so that valid sessions are now no
longer terminated. An unwanted cancelation of long-running operations such as tenant
backups or report executions can no longer occur. (Pivotal 5380369)

= |tis now generally possible to create new tenants in a multi-node environment.
(Pivotal 1370465)

=  When you use the "setSynchronizeAssignments(true)" option, assignments are now
correctly updated in the target database during a merge procedure. (See also "ARIS > Help
> ARIS Script”, topic area "Methods for reports and semantic checks > Global objects >
Report component interfaces > Merge > MergeBase Options", page
"setSynchronizeAssignments(boolean):void".) (Pivotal 5361591)

= |f the "Database administrator" function privilege of a user is revoked in the user
management, the corresponding system user privileges for ARIS Clients, such as access
privileges and function privileges, are now automatically revoked as well. (See also "Help",
topic area "Manage ARIS Connect > Manage users > Valuable information”, page "What
function privileges can be assigned?".) (Pivotal 5362775)

*= |n the database statistics, access privileges of users and user groups are now correctly
displayed for versioned content of a database. (See also "ARIS > Help > Working with ARIS",
topic area "ARIS Configuration and Administration > Manage databases", page "Display
database statistics".) (Pivotal 5378169)

» The "SetAccessRights()" ARIS report script APl method now always returns correct
results. (See also "ARIS > Help > ARIS Script", topic area "Methods for reports and semantic
checks > Objects > User", pages "Set AccessRights(Group[],int):boolean" and "UserGroup",
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page "Set AccessRights(Group[],int):boolean".) (Pivotal 5383874)

= The "Test" button for ARIS Business Publisher links on the last page of the
Synchronization Wizard now works correctly for synchronization towards SAP Solution
Manager.
(Pivotal 5371128)

= Soft hyphens used in object names are now correctly displayed in ARIS Connect. (See also
"Help", topic area "Use ARIS Connect > Use the repository > Create and edit models > Model
> Basic modeling", page "Use optional hyphens".) (Pivotal 5363375)

= The overview page of databases now always shows correct data for databases from which
a version was published, for example, "Last version". (See also "Help", topic area "Manage
ARIS Connect > Configure Portal”, page "Publish database as a process portal".)
(Pivotal 5366564)

= |f highlighting connections is not necessarily required, you can speed up highlighting by
removing the <highlightWith> section from the highlighting configuration. As a result, only
objects are highlighted. (See also "Help", topic area "Use ARIS Connect > Work in the portal
> Use models > Highlight model items >Valuable information”, page "What is highlighting?".)
(Pivotal 5372049)

= |n the "My favorites" area, pagination now works correctly. (See also "Help", topic area "Use
ARIS Connect > Work in the portal > Use favorites"”, page "Open My favorites".) (Pivotal
5373302)

= With version ARIS 10 SR10, models of the "DTD" type or model types derived from this type
can be edited in ARIS Connect. (Pivotal 5374479)

= Now, searching for attribute values works correctly in the advanced search of ARIS
Connect. (See also "Help", topic area "Use ARIS Connect > Search content”, page "Use
search context and filters".) (Pivotal 5375787)

= |nthe search result area of the advanced search, properties of items found are now newly
sorted when a filter criterion is removed. (See also "Help", topic area "Use ARIS Connect >
Search content”, page "Use search context and filters".) (Pivotal 5379921)

= Using the "Related objects" bar of a model ("Diagram” fact sheet > "Properties" bar), you
can now open the fact sheets of all objects that are connected with another object by
clicking their name. (See also "Help", topic area "Use ARIS Connect > Work in the portal >
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Use models > Model Viewer", page "Show properties".) (Pivotal 5381069)

You can now export and import Enterprise BPMN diagrams using the "Entire method" filter
as well as other filters. (See also "ARIS > Help > Working with ARIS", topic area
"Export/Import", page "BPMN import/export".) (Pivotal 5374821)

BPMN-specific XML files now contain definitions of data input and data output objects
that are connected with a task symbol. (See also "Help", topic area "Use ARIS Connect >
Use the repository > Create and edit models > Model > Extended editing > Export", page
"Export BPMN diagram".) (Pivotal 5377237)

Improvements were made to the font fallback in reports and to font substitution warnings
so that fonts are now always readable in report output results. (See also "ARIS > Help >
Working with ARIS", topic area "ARIS Configuration and Administration > Specify
conventions > Valuable information”, page "How do fonts affect graphics and PDF output
files?")) (Pivotal 1381486)

The ARIS standard report "Output database information" now outputs access privileges
correctly for users that are associated with a user group to which neither access
privileges nor function privileges were assigned. Furthermore, the report output result is
now also correct when a user starts the report while being logged in to the database with
another filter than "Entire method". (See also "ARIS > Help > Working with ARIS", topic area
"Evaluate data > Use reports > ARIS reports > Administration”, page "Report: Output
database information™.) (Pivotal 5368727)

In ARIS Report dialogs, items that are added to or changed in a table are now sorted
correctly. (See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Create scripts > Create report > Using the design view", page "Insert data
tables into report scripts".) (Pivotal 5369165)

Improvements were made to error messages used for Visio imports. It is now easier to
identify errors in invalid Visio files. (See also "ARIS > Help > Working with ARIS", topic area
"Export/Import > Visio import”, page "Import models from Microsoft Visio".)

(Pivotal 5371723)

A correction was made to the ARIS report script API. In a report, you can now use
documents that contain multiple columns and are based on different templates. (See also
"ARIS > Help > ARIS Script", topic area "Methods for reports and semantic checks > Objects
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> ModelOptions", page "getModelGridSize():int" and "setModelGridSize(int):void".) (Pivotal
5373394)

= The orientation in reports that were created using the design view now remains
unchanged in the report output result. (See also "ARIS > Help > Working with ARIS", topic
area "ARIS Configuration and Administration > Create script > Create report > Using the
design view", page "Create report scripts in design view".) (Pivotal 5375994)

= The ARIS report script APl now supports changing the default grid size for new models:
ArisData.getModelOptions().getModelGridSize()
ArisData.getModelOptions().setModelGridSize(nGridLometric)
(Pivotal 5378150)

= Disabling buttons in ARIS Report scripts now works again in ARIS Connect.

= The time format used for the statistics export of ARIS Simulation was changed from
"dddd:hh:mm:ss" to "hh:mm:ss". (See also "ARIS > Help > Working with ARIS", topic area
"Special topics and functions > Simulation > Evaluate", page "Export statistical data".)
(Pivotal 5369879)

=  Adocument URL that is copied using the buttons "Copy current view code" and "Copy to
clipboard" is now correctly encoded so that it works properly when inserted into a Wiki
page, for example. (See also "Help", topic area "Use ARIS Connect > Work in the portal >
Use models", page "Copy view code".) (Pivotal 5385117)

* Processes running in the background are more resilient so that active sessions are now
correctly closed in the event of an unexpected outage. As a result, the number of available
licenses is now correctly managed and displayed. (See also "Help", topic area "Manage
ARIS Connect > Manage licenses", page "Display information about licenses/license file".)
(Pivotal 5366016)

= Users that were deleted are no longer displayed on the page "Privileges > Database
privileges" in the user management. (See also "Help", topic area "Manage ARIS Connect >
Manage users"”, page "Delete user".) (Pivotal 5378144)

54



RELEASE NOTES

Swimlane model headers are now displayed in ARIS Publisher in the same way as in ARIS
Architect/ARIS Designer. (Pivotal 5374091)

Sending e-mail notifications from ARIS Collaboration now works correctly when the "Use
authentication” option is enabled. (See also "Help", topic area "Manage ARIS Connect >
Configure ARIS Connect > Set up user management", page "Customize SMTP settings" and
"Set up user management > Valuable information”, page "What SMTP properties are
available?".)) (Pivotal 1386414)

In the Collaboration API, you are now allowed to use spaces and rounded brackets in
database names. (Pivotal 5367244)

The names of models of the "Spreadsheet" type are now correctly displayed in the
Versioning Wizard. (See also "ARIS > Help > Working with ARIS", topic area "Create models >
Spreadsheets > ", page "Create spreadsheet" and "ARIS > Help > Working with ARIS", topic
area "Edit models > Check and approve models > Version models", page "Version selected
models".) (Pivotal 5373007)
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13 Fixesin ARIS 10.0 SR9b

ARIS Risk & Compliance Manager

= Error fixed in data migration with MS SQL Server.

Error only occurred with an update of older ARIS 10.0 version and only if MS SQL Server is
used. Customers with a new installation of ARIS 10.0 SR9 do not need this fix (update to
SR9b).
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The creation of new tenants in multi-node environments now no longer fails if tenants
were previously deleted from the environment. (See also "ARIS > Help > Working with
ARIS", topic area "ARIS Configuration and Administration > ARIS Server and Tenant
Management" > Managing tenants".) (Pivotal 1370465)

The connection from ARIS Server Administrator and Script Runner installed under Linux to
a corresponding server is now correctly established. (See also "ARIS > Help > Working with
ARIS", topic area "Evaluate data > Use reports”, page "Automatically start reports with
Script Runner" and "ARIS Configuration and Administration > ARIS Server and Tenant
Management > ARIS Server Administrator”.) (Pivotal 5369680)

The "Select change list" dialog of the login wizard now opens even if no description is
available for the relevant change list. (See also "ARIS > Help > Working with ARIS", topic
area "Navigate and edit items", page "Open database", link "Versionable databases".)

The performance of the portal in ARIS Connect was improved so that loading and
displaying data is faster now. (Pivotal 5363161)

The navigation button ,Go up in hierarchy” is now no longer deactivated when the
navigation tree is collapsed. (See also ,Help”, topic area ,Use ARIS Connect > Work in the
portal > Views > Navigate”, page .Navigate using fact sheet buttons”.) (Pivotal 5363975)

The performance of the Model Viewer in ARIS Connect was improved so that loading and
displaying models is faster now. (Pivotal 5364572)

A correction was made to the standard configurations of ARIS Connect so that users can
now view only components for which they have the required privileges. Users are no
longer redirected to a component other than the one selected when they click a link to
access a component for which they do not have the required privileges. (Pivotal 5365249)

Highlighting is now refreshed correctly in the Model Viewer when a user with the , ARIS
Connect Viewer” and ,,Contribution” license privileges changes the value of a highlighted
attribute. (See also ,Help”, topic area ,Use ARIS Connect > Work in the portal > Contribute
as a viewer”, page ,,Change values of items” and ,Use ARIS Connect > Work in the portal >
Use models > Model Viewer”, page ,Switch highlighting on*.) (Pivotal 5366707)

Scroll bars are now no longer displayed when the content of the Home area fits entirely in
the browser window. (Pivotal 5367745)
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In Collaboration, links included in the message body of e-mail notifications are now
displayed in such a way that users can recognize them as links. Furthermore, they are now
shown with the color specified for them in ARIS Administration. (Pivotal 5367335)

Test path recording was improved in such a way that the memory consumption on ARIS
Client no longer exceeds a given threshold, especially when large images are contained in
the recorded test models. (See also: “ARIS > Help > Working with ARIS", topic area " Special
topics and functions > Test Designer ", page “Generate test paths”.) (Pivotal 5358651)

Document descriptions are now transferred to the SAP system. (See also: “"ARIS > Help >
Working with ARIS", topic area " Special topics and functions > ARIS for SAP Solutions >
Common handling (version independent) > Use SAP documentation”, page “Transfer SAP
documentation to SAP Solution Manager”.)

When connections are deleted in a model, the layout of the connections that remain in the
model is no longer updated. (Pivotal 5365870)

Corrections were made in order to improve the display of attribute values within object
symbols. Values of attributes placed in an object now no longer overlap. (Pivotal 5366753)

A JDK 1.7-related sorting algorithm was replaced so that saving models now works
correctly. (Pivotal 5368423)

Corrections were made in order to improve the display of graphics in EMF (Enhanced
Metafile) format. Graphics of this type are now displayed correctly in ARIS
Architect/Designer and in the Model Viewer of ARIS Connect. (Pivotal 5362910, 5368701)

Improvements were made to the layout algorithms used for Smart Modeling in ARIS
Architect/Designer and ARIS Connect. (See also "ARIS > Help" > Working with ARIS", topic
area "Create models > ARIS models > Use Smart Modeling" and "Help", topic area "Use ARIS
Connect > Use the repository > Create and edit models > Model", page "Use Smart
Modeling".)

Hiding and showing a large number of columns and rows was improved in such a way that
all hidden columns and rows now remain hidden when a table is saved and opened again.
They are shown again only if a user clicks "Show columns" or "Show rows". (See also "ARIS
> Help > Work with ARIS", topic area "Create models > Spreadsheets > Advanced editing",
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pages "Show hidden columns" and "Show hidden rows".)

= APG Web services are now able to correctly process input data that does not comply with
the UTF-8 format, for example, language-specific special characters. (Pivotal 5369663)

= Generating a table of contents using ARIS report script APl now no longer results in the
creation of empty chapters. Instead, the required subchapters are created. (Pivotal
5364167)

= Animprovement was made to the report-based import of user-defined models from an
Excel file. The objects are now correctly aligned in the models and do no longer overlap.
(Pivotal 5364462)

= A correction was made to the ARIS report script API so that texts and table cells are now
correctly aligned. (Pivotal 5365264)

= A correction was made to the ARIS report script API so that changes made to a text box
are now correctly identified. (Pivotal 5365722)

= Object symbols that are output using ARIS report script APl now have a normal size in the
report output. (Pivotal 5367043)

= The ARIS report "Output database information” now returns a correct result regarding the
user privileges of a user associated with a user group to which no database privileges
(neither access privileges nor function privileges) are assigned. If you select the name of
an open database, you can start the functionality using the pop-up menu or clicking
"Start" > "Database > Output database information". (See also "ARIS > Help > Working with
ARIS", topic area "ARIS Configuration and Administration > Manage databases", page
"Output database information™.) (Pivotal 5368727)

= Documents generated by a report are now correctly assigned the name that the user
specified for the report.

= The "loT device import" report now issues an appropriate error message indicating that no
server protocol was specified or that the server protocol specified is wrong.

= Report script APl method "getDocumentByld" now returns NULL if a requested document
ID is not available. (See also "ARIS > Help > ARIS Script", topic area "Methods for reports
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and semantic > Global objects > Report component interfaces > ADS > ADSRepository",
page " getDocumentByld(String : ADSDocument).) (Pivotal 5364381)

ARIS Method

= In ARIS Connect, the fact sheet "Option sets" was added to the GDPR configuration set.
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The GDPR report "Output record of processing activities" is now available in other
languages than English.

Corrections were made to the behavior of date filters. If you specify a point in time for
filtering, such as the beginning of a month or the start of a fiscal year, and then manually
enter a date, the date entered manually is now used for filtering. This date is no longer
overwritten with the point in time that was specified before.

When a user session expires, now the login dialog is displayed so that the user can log in
again.

The version displayed for an object from the "My issue-relevant objects" list is now the
one that was valid when the object was marked as issue-relevant.

The "My GRC tasks" area in the portal of ARIS Connect is now displayed only to users that

have the required privileges. (See also ARIS Risk & Compliance Manager, "Help > Work with
ARIS Risk & Compliance Manager" topic area "Manage data in ARIS Connect", page "Show

my GRC tasks".)

If you remove the assignment of a document to an issue, it is now possible for you to
assign the document to the issue again.

ARIS Risk & Compliance Manager now issues an appropriate message during startup if the
database user does not have the privileges required for checking the existing database
schema.

Environment backups now also include the current tasks assigned to users (Home > My
tasks). (See also ARIS Risk & Compliance Manager, "Help > Work with ARIS Risk &
Compliance Manager" topic area "Manage data in ARIS Connect > Use Administration"”,
page "Back up environments".)

The time for reloading data feeds used in ARIS Risk & Compliance Manager dashboards
was set to 15 seconds so that updating data is faster now.

Migrating data now works correctly even if the internal object ID of the system user
changes during database migration.

It is now possible to specify an end date that is later than 2100.

Improvements were made to the behavior of ARIS Risk & Compliance Manager in a multi-
node installation with a high load and a high access rate.

The tooltip for model shortcuts in hierarchy forms was changed to "Open model in ARIS
Connect".

User ID and GUID conflicts are now automatically resolved during user synchronization.

If the "Frequency" attribute is set to "None (only event-driven)", specifying the "Time limit
for execution in days" and "Start date" attributes is no longer mandatory. The values for
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the "Time limit for execution in days" and "Start date" attributes are queried in a dialog
during event-driven generation.
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= When a search is performed in ARIS, the name attribute of items found is now always
displayed first in the list of search results.
(See also ,ARIS > Help > Working with ARIS”, topic area ,Navigate and edit items”, page
.Search for database content”.) (Pivotal 5351572)

=  When reports containing graphics are run, temporary files are now always correctly
deleted from the 'base/temp’ directory on ARIS Business Server and High Duty Server.
(Pivotal 5353690)

= Restarting the cloud search runnable no longer results in the corruption of internal cloud
search memory structures in the RAM. This problem and subsequent errors can no longer
occur. (Pivotal 5354380, 5356658, 5351826)

= Models including user-defined attributes that were created using older versions of ARIS
(older than ARIS 7.0.2) now always successfully open in ARIS Connect Designer.
(Pivotal 5355213)

= The size of backup files for ARIS databases now no longer increases significantly when a
database contains a large number of graphic images.
(See also , ARIS > Help > Working with ARIS", topic area ,, ARIS Configuration and
Administration > Manage databases”, page ,Back up databases”.) (Pivotal 5357444)

*= Unique constraint violation errors can no longer occur during versioning.
(See also ,,ARIS > Help > Working with ARIS", topic area ,Edit models > Check and approve
models”, page . Version models”.) (Pivotal 5359719)

* The error message relating to the EPC-to-BPMN transformation was improved. It now
indicates that the transformation has failed because the method filter in use does not
contain the required BPMN object(s).

(See also "ARIS > Help > Working with ARIS", topic area "Special topics and functions >
Process Governance", page "Transform models".) (Pivotal 5352854)

= Corrections were made to the 'Start events and end events in a process' semantic check
rule. The corresponding semantic check now complies with the BPMN specification.
(See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Create scripts", page "Create semantic check".)
(Pivotal 5354391)

63



RELEASE NOTES

The sorting function used for table-based modeling was improved in such way that
sorting model items is now easier and more user-friendly.

(See also "Help", topic area "Use ARIS Connect > Use the repository > Create and edit
models > Model > Model table-based".) (Pivotal 5336873)

Diagrams that you open by clicking a link are now always correctly displayed.
(Pivotal 5349900)

When 'Fit to window' is selected in the 'Diagram’ fact sheet, now the entire space of the
window is used for displaying a graphic. Margins are no longer created.

(See also "Help", topic area "Use ARIS Connect > Work in the portal > Use models > Model
Viewer", page "Use the view bar".) (Pivotal 5351721)

When you refresh a browser, the focus now always stays on the current tab.
(Pivotal 5351848)

In ARIS Connect Designer, user-defined symbols now always have the correct size (height
and width) when being placed. (Pivotal 5354852)

If an existing object is placed within another object, this action no longer results in an
additional object being created.

(See also "Help", topic area "Use ARIS Connect > Use the repository > Create and edit
models > Extended editing > Use objects", page "Place an object in an object".) (Pivotal
5352710)

Toolbars are no longer displayed twice in the diagram view of ARIS Connect.

(See also "Help", topic area "Use ARIS Connect > Use the repository > Create and edit
models > Customize ARIS Connect Designer > Valuable information”, page "How is ARIS
Connect Designer structured?".) (Pivotal 5353118)

When a user tries to access an item component in ARIS Connect without having the
required privileges, the user is no longer directed to error page 404. (Pivotal 5354373)
Customized buttons are no longer displayed twice in ARIS Connect. (Pivotal 5355038)
Refreshing the display of report notifications now works correctly with Internet Explorer®
11. (Pivotal 5355085)

The tooltips for the 'Reports’, 'Edit tasks', and 'My content filters' buttons are now
correctly displayed when the mouse pointer is positioned over them.

(For example, see "Help", topic area "Use ARIS Connect > Basics", page "Show tasks in My
tasks".) (Pivotal 5357379)

The columns of a matrix from the 'Table' fact sheet are now correctly aligned.

(See also "Help", topic area "Use ARIS Connect > Work in the portal > Use models > Table",
page "Open the matrix of a table".) (Pivotal 5360078)
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» The 'Description’ column of the 'Overwiew' fact sheet now displays the entire text.
(See also "Help", topic area "Use ARIS Connect > Work in the portal > Views > Classic",
page "Groups", Link "Fact sheets of ARIS models".) (Pivotal 5360442)

= Document links that are used as placed model or object attributes and that reference
documents whose names use Arabic characters now work correctly. Clicking such a link
now opens the relevant document.
(See also "ARIS > Help > Working with ARIS", topic area "Create models > Place attributes".)
(Pivotal 1358189)

= Information marks indicating errors or warnings in a model are now no longer displayed
when the relevant semantic check is run again after the errors were fixed.
(See also "ARIS > Help > Working with ARIS", topic area "Edit models > Check and approve
models", page "Run semantic checks".) (Pivotal 5344373)

= Macros triggering the 'Object is to be copied (vetoable)' event now always run correctly
when a definition copy is created in a model.
(See also "ARIS > Help > Working with ARIS", topic area "Evaluate data", page "Use macros
") (Pivotal 5350135)

= The names of lanes inserted into BPMN diagrams are now aligned correctly (in the lane
headers) when a template is applied to the diagram.
(See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Specify conventions", page "Assign a template to an ARIS model type".)
(Pivotal 5350433)

= Links of user-defined link attributes that are read-only are now clickable again.
(See also "ARIS > Help > Working with ARIS", topic area "Create models > ARIS models”,
page "Insert executable links for model items".) (Pivotal 5350946)

= |n BPMN diagrams, it is now possible to draw a connection from an event subprocess to
another pool.
(See also "ARIS > Help > Work with ARIS", topic area "Create models > BPMN diagrams.)
(Pivotal 5353705)

= User-defined symbols are now displayed with the correct size (hight and width) when a
model template is applied to a model using a script.
(See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Specify conventions", page "Create template".)
(Pivotal 5353828)

= Combined values are now correctly displayed. (Pivotal 5354263)
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Links that are used as placed model attributes are now always clickable. (Pivotal 5344739)

After having selected 'Filters > Characteristics', you can now search for any value in the
list. (Pivotal 5356779)

When the report script APl is used to specify a time zone-dependent attribute, now the
correct time is used on servers that are being operated at locations in other time zones.
(Pivotal 5347960)

Reports that are run by the report script APl now correctly apply the margin settings
specified in the report script. (Pivotal 5348117)

Corrections were made to the 'Export attribute values for translation' report so that
exporting attribute values now works correctly when UML elements are not allowed by the
filter in use. (See also , ARIS > Help > Working with ARIS", topic area ,Evaluate data > Use
reports > ARIS reports > Standard”, page . Report: Export attribute values for translation”.)
(Pivotal 5350935)

During the procedure of debugging a macro that calls a report, the debugging window
now always displays the corresponding report code. (Pivotal 5351697)

ARIS report script API method ,getBpmnParent () was improved so that it now returns
NULL instead of a null pointer exception when no lane or pool is assigned to a BPMN
diagram. (See also ,ARIS > Help > ARIS Script”, topic area ,Methods for reports and
semantic checks > Global objects > Report component interfaces > Designer > BPMN 2
Support > Bpmn2ReportServices”, page ,setBpmnParent (ObjOcc,0bjOcc) : void ,..)
(Pivotal 5352346)

Corrections were made to the ,Context.getExcelReader()” ARIS report script API method
so that this method now successfully opens large Microsoft Excel files on the server.

(See also ,ARIS > Help > ARIS Script”, topic area ,Methods for reports and semantic checks
> Global objects > Context”, page .getExcelReader (byte[])".)

(Pivotal 5352498)

If 'English (United Kingdom)' is configured in addition to the alternative language 'English
(United States)' in the ARIS Connect portal, the language fallback mechanism for reports
now works correctly, which means that the appropriate language is used for displaying
report names.

(See also ,ARIS > Help > Working with ARIS", topic area ,,General > Valuable information”,
page .What are languages in ARIS?".) (Pivotal 5356780)
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Audit steps that were deactivated are no longer taken into account during audit
progression and in evaluations. (Pivotal 5349321)

Changes were made in order to improve synchronization between ARIS and ARIS Risk &
Compliance Manager. In this context, special attention was given to optimizing the
deletion of deactivated objects. (Pivotal 5354415)

Server tasks that become obsolete after the migration of a database are now canceled to
make sure that subsequent tasks are able to run. (Pivotal 5359743)

Models containing user-defined attribute types that use the 'Value' data type now
correctly open in ARIS Connect.

(See also ARIS Architect, ,ARIS > Help > Working with ARIS", topic area , ARIS Configuration
and Administration > Manage ARIS Method”, page ..Create attribute type with values”.)
(Pivotal 5350065)

When 'Value-added chain' symbols (ST_VAL_ADD_CHN_SML_1and
ST _VAL_ ADD_CHN_SML_2)are zoomed in, now the gray line at the top is no longer
removed. (Pivotal 5356996)
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= |n ARIS Connect Designer, improvements were made so that sorting a table in table-based
modeling is more user-friendly now. (See also "Help", topic area "Use ARIS Connect > Use
the repository > Create and edit models > Model > Model table-based".) (Pivotal 5336873)

= The search result is now sorted alphabetically in ARIS Connect. (See also "Help", topic area
"Basics", page "Open the search area".) (Pivotal 5338727)

= ARIS Connect now responds immediately when work is resumed (for example, by clicking
an assignment icon in a model) after an idle time of several minutes has elapsed.
(Pivotal 5338759)

= When you switch to another database on the "Home" tab in ARIS Connect, the models of
the other database are now correctly displayed. (See also "Help", topic area "Use ARIS
Connect > Work in the portal > Navigate", page "Select database".) (Pivotal 5344137)

= The model viewer in ARIS Connect now correctly displays user-defined attributes, for
example, attributes specified for the duration of an operation. (See also "Help", topic area
"Use ARIS Connect > Work in the portal > Use models > Model viewer".) (Pivotal 5344855)

= The glossary/catalog now always shows the filter options for column headers. (See also
"Help", topic area "Use ARIS Connect > Use the Catalog.) (Pivotal 5346667)

= Applying a content filter (role-based filter) now correctly filters the result of the ARIS
Connect search. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Use
the portal > Use filters.) (Pivotal 5347235)

= A scroll bar was added to the drop-down list box of the glossary/catalog so that you can
now select any entry contained in the list. (See also "Help", topic area "Use ARIS Connect >
Use the Catalog.) (Pivotal 5347260)

=  When you use SSO (Single Sign-0n), you are now correctly forwarded to the pages defined
in the SAML configuration (entries: "Single sign-on URL" and "Single logout URL"), for
example, when you log out from SSO. (See also "Help", topic area "Manage ARIS Connect >
Configure ARIS Connect > Set up user management > Customize ARIS for LDAP server
operations", page "Configure single sign-on".) (Pivotal 5347587)

= Temp files generated during a tenant backup are now deleted when the backup is
complete. (Pivotal 5347595)

= The "Steps" fact sheet now displays the full name of objects as multi-line text. (See also
"Help", topic area "Use ARIS Connect > Work in the portal > Views > Valuable information,
page "What is the Steps fact sheet for?".) (Pivotal 5347739)
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= In aRACI table, columns are now correctly aligned even if a high number of connections is
evaluated. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Views >
Valuable information, page "What is the RACI fact sheet for?".) (Pivotal 5348209)

= Now, the correct amount of data is displayed for user-defined item types in ARIS
Contribution and the corresponding items are editable. (See also "Help", topic area
"Manage ARIS Connect > Configure ARIS Connect > Configure Portal > Manage
configuration and modification sets > Valuable information”, page "What is ARIS Viewer
Contribution?".)

= Restoring databases no longer fails with the error message "The file is not a valid ADB file
(database archive)" when the network connection is slow or the database is very large.
(See also ARIS Architect "ARIS > Help > Working with ARIS", topic area "ARIS Configuration
and Administration > Manage databases", page "Restore databases".) (Pivotal 5332789)

= Database reorganization is no longer canceled when locked objects are found in the
database. When reorganization is complete, the corresponding result dialog lists all objects
that are currently locked by a user. (See also ARIS Architect "ARIS > Help > Working with
ARIS", topic area "ARIS Configuration and Administration > Manage databases", page
"Reorganize databases".) (Pivotal 5343155)

= Using graphic objects in a high number of models in an ARIS database no longer
significantly increases the size of the corresponding ADB backup file. (Pivotal 5347788)

= The report component is now always correctly initialized in ARIS Connect after ARIS
version 9.8 SR7 was migrated to ARIS version 10 SR6. (Pivotal 5349758)

= When you create a call activity in a BPMN diagram but do not have the required privileges
for accessing the task or process you selected as a reference, a corresponding message is
now displayed. (See also ARIS Architect "ARIS > Help > Work with ARIS", topic area "Create
models > BPMN diagrams", page "Place activity of the Call activity type" and ARIS Connect
"Help", topic area "Use ARIS Connect > Use the repository > Create and edit models > Model
> Use BPMN modeling support"”, page "Assign global reference to call activity".)
(Pivotal 5341751)
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= The "Policy" object is now available in the function view of a macro. (Pivotal 5328060)

= Corrections were made so that showing a subset of hidden columns in a query result now
works properly. (See also "ARIS > Help > Working with ARIS", topic area "Evaluate data >
Use queries".) (Pivotal 5344266)

= The name of the date selection dialog is now correct and no longer suggests that you can
also select a time. (Pivotal 5345641)

= When the "None" button is clicked in the date selection dialog, the selection now closes
correctly and the button is no longer renamed. (See also ARIS Architect help "ARIS > Help >
Working with ARIS", topic area "Special topics and functions > Process Governance > Model
> Model dialogs > Valuable information > Elements pane", page "Date and time".)
(Pivotal 5345644)

= Properties such as "Title" or "Description" are now correctly displayed in Japanese
documents uploaded from ARIS Process Governance. (See also "Help", topic area "Use
ARIS Connect > Use the repository > Handle documents".) (Pivotal 5346119)

= Links included in e-mails sent from Collaboration are now correctly directed to the
configured loadbalancer scheme. (See also "Help", topic area "Manage ARIS Connect >
Administrate Collaboration”, page "Customize e-mail notifications".)

= Surveys are no longer closed when the end date of the underlying survey task is reached.
They are closed on the end date of the survey itself. (Pivotal 5346365)

= Objects that are deactivated in ARIS Architect and not available in ARIS Risk & Compliance
Manager are now ignored during data synchronization.

= The report "Import user data from User Management" now imports a user only once
regardless of the number of times the report is run.

= When dashboard links are generated in ARIS Risk & Compliance Manager, ARIS GUIDs
(Globally Unique Identifiers) are now provided instead of ARIS Risk & Compliance Manager

GUIDs for objects of type "Section”, "Questionnaire template”, "Question"”, and "Answer" if
these objects were imported from ARIS.

= ARIS Risk & Compliance Manager icons are now correctly displayed in the headers of
configuration sets used in ARIS Connect.
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= When ARIS 9.8.x is updated to version 10.x by restoring a tenant in ARIS 10.x, the file
"aris2arcm-mapping.xml" is now removed from the "Evaluation/Common files" folder
("Administration” tab in ARIS Architect).

= Deleted audits steps are no longer counted in the audit progress or audit evaluation.

= The hierarchy structure in ARIS Risk & Compliance Manager is no longer corrupted when
the procedure of synchronizing ARIS and ARIS Risk & Compliance Manager includes only a
part of the hierarchy.

= Symbols are now displayed without distortion in published matrix models. (Pivotal
5349074)

= The descriptions of supported commands used by the command-line tool "y-
admintool.bat" were updated in the documentation. (Pivotal 5347526)

=  When process variants are transferred to SAP Solution Manager, all process variants are
now correctly created even if a process variant model in ARIS contains BPMN objects of
the 'Call activity' or 'Subprocess' type.

= You can now perform a tenant backup even if the repository contains files whose size
exceeds 2 GB.
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Long names now have proper line breaks in objects. (Pivotal 5322294)

When a database was published it now remains selected and visible in the portal if a new
change set is activated in ARIS Administration and a hierarchy was added. (Pivotal
5324203)

Attribute formatting, such as bold and soft hyphens are properly displayed again in ARIS
Connect. (Pivotal 5325397)

Matrix models are now displayed in their entirety even if the representation is set to
another value than 100%. (See also "Help", topic area "Use ARIS Connect > Work in the
portal > Use the portal > Use models > "Use matrix models".) (Pivotal 5334325)

Now, the "Model Viewer" shows the "Swimlane View" correctly for models of databases
that were published with the "Latest version" option. (See also "Help", topic area "Use ARIS
Connect > Work in the portal > Use the portal > Model Viewer", page "Change view" and
topic area "Use ARIS Connect > Use the repository > Manage versions", page "Version
models".) (Pivotal 5337818)

Bold and italics and text attribute indentations are now properly displayed in ARIS
Connect. (Pivotal 1336224)

Using BPMN models has been improved. If lanes containing object occurrences are
deleted in ARIS Architect using ARIS Explorer, the occurrences are placed in a superior or
automatic lane. (See also ,,ARIS > Help” > Working with ARIS", topic area ,Create models >
BPMN diagrams”.) (Pivotal 5325373)

The attribute dialog of an object type now shows only those attribute types groups that
are allowed for the item type. (See also ,ARIS > Help > Working with ARIS”, topic area , Edit
models > Extended editing > Edit attributes”.) (Pivotal 5332745)

Two new settings are available for ARIS Connect. They used to be available for ARIS
Architect only:

1. Use the entire symbol surface for placing text

2. Hide non-configured objects
You can either specify the settings across servers via ,defaultserversettings.cfg” or for a
tenant by means of the ,ARIS Server Administrator” command line tool. (Pivotal 5335732)
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Keyboard control has been improved so that the tab key can now be used for indentation
of text attributes and free-form texts. You can also use Shift+Tab to undo an indent.
(Pivotal 5335923)

The model comparison was corrected, so modifications for objects of models within a
database are now shown correctly. (See also ,ARIS > Help > Working with ARIS", topic area
.Edit models > Check and approve models > Compare models”.) (Pivotal 5336525))

The line breaks for the "German" language pack in e-mails from ARIS Process Governance
and the "Approve model" mini-workflow have been corrected. (See also ARIS Architect
help, "ARIS > Help > Working with ARIS", topic area "Special topics and functions > Process
Governance > Model > Model data flows > Valuable information”, page "What notifications
exist?" and ARIS Connect help, "Help", topic area "Use ARIS Connect > Work in the portal >
Use models", page "Ask for model approval®.)

(Pivotal 5327769)

If an operator symbol is selected in a data flow chart by means of a drop-down list, the
selected operator symbol now remains selected and can be placed again by a direct click
on the symbol in the bar. (See also "ARIS > Help > Working with ARIS", topic area "Special
topics and functions > Process Governance > Model > Model data flows > Operators", page
"What are operators?".)

(Pivotal 5335636)

The Process board "Tracking" tab is now visible also for users with an ARIS Connect
Viewer license. These users can track the tasks started.
(Pivotal 5335931)

When downloading documents using the ARIS Process Governance dialog "ADS control”,
country-specific file names are now properly handled.
(Pivotal 5337530)

If the text of the "Date and time" element is changed in Dialog editor, this change is now
applied to this dialog element only. (See also "ARIS > Help > Working with ARIS", topic area
"Special topics and functions > Process Governance > Model > Model dialogs > Valuable
information”, page "Which elements can be edited directly in the dialog?".)

(Pivotal 5338655)

Write-protected ARIS Process Governance dialog elements can no longer be selected or
changed. (See also "ARIS > Help > Working with ARIS", topic area "Special topics and
functions > Process Governance > Model > Model dialogs > Valuable information”, page
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"What does read-only mean?".)
(Pivotal 5340789)

= Write-protected dialog elements of the "Check box list" type (ARIS Process Governance)
are now properly handled in ARIS Architect/Designer and in the ARIS Connect portal: they
can no longer be selected or changed. (See also "ARIS > Help > Working with ARIS", topic
area "Special topics and functions > Process Governance > Evaluate", page "Mandatory
semantic checks macro".)
(Pivotal 5340795)

= Temporary files are now deleted after ARIS Document storage data has been backed up.
(Pivotal 5326189)

= ARIS Document storage data backup is now more robust while backing up the tenant.
(Pivotal 5333810)

= ARIS Process Governance Web services now output date values properly based on
Coordinated Universal Time (UTC).
(Pivotal 5336158)

= ARIS Document storage history events are now properly output with language-specific
characters, such as Cyrillic.
(Pivotal 5338047)

= Help and dialog texts have been improved in various languages, including German and
Russian. (See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Manage databases", page "Reorganize databases".)
(Pivotal 5334042)

= The following features are described in the English Online Help. The descriptions will be
available in the other language packs from version 10.0 SR 7.

- Connect - Server requests
- Dashboards: Map with markers, vector map, heat matrix
- GRC (non-GDPR) Dashboard for UMG

- Connect keyboard shortcuts
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It is now possible to select the XLSX file format as the output format of user-defined
reports. (Pivotal 5326611)

The HTML export executes properly now even if not all connection types are allowed by
the current method filter. (Pivotal 5330057)

The "Create process manual” report now executes properly for models in Japanese.
(Pivotal 5330802)

Descriptions are now output for all link attributes in the summary of a newly created
Publisher export profile. (See also "ARIS > Help > Working with ARIS", topic area "Publisher
> Publisher export", page "Create Publisher export profiles".)

(Pivotal 5332274)

The "Time of last semantic check" value attribute output by the "Mandatory semantic
checks" macro now considers the time zone of the client on which the macro runs.
(Pivotal 1340920)

The processing sequence and thus the sort order now remain in the generated document
remain the same when performing a semantic check multiple times. (See also ARIS
Architect, "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Create scripts > Use Script Editor > Valuable Information”, page "What is a
semantic check?" and ARIS Connect, "Help", topic area "Use ARIS Connect > Use the
repository > Check models and objects > Valuable Information”, page "What should you
know about semantic checks?".) (Pivotal 1341087)

The ARIS report output object has been corrected so that the background color is now
applied to headers even when the headers are numbered. (Pivotal 5328089)

The ARIS macro script API "Designer.getOID(00bjOcc)" method now returns the proper
value. (Pivotal 5328378)

The "BrowseArisltems" report script APl method has been corrected so that dialogs load
faster now. (Pivotal 5330524)

It is now possible to set (set) or query (get) the arrow style using a macro. The following
methods are available:

- Designer.getSourceArrow(model, occ);
- Designer.getTargetArrow(model, occ);

- Designer.setSourceArrow(model, occ, arrow type number);
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- Designer.setTargetArrow(model, occ, arrow type number);
(Pivotal 5333202)

= When ARIS is synchronized with Alfabet, object names renamed in Alfabet are now
properly updated in ARIS. (Pivotal 5336129)

= The "Model created" macro event now works properly in ARIS Connect. (Pivotal 5336586)

= |f the "inheritAccessRights" function of the ARIS Report script APl is used to withdraw
privileges, they are now no longer withdrawn from just the superior group, but also from
the sub-groups. (See also "ARIS > Help > ARIS Script”, topic area "Methods for reports and
semantic checks > Objects > Group", page "inheritAccessRights():boolean™.)
(Pivotal 5337237)

= Headers of models containing graphics in EMF format are now properly placed in
generated Microsoft Word documents. (Pivotal 5338036)

= Various methods of the "picture” report script API class have been enhanced, and errors
concerning the positioning of lines and rectangles over objects have been eliminated.
(Pivotal 5338120)

= The "Import data in Excel format" ARIS report script has been corrected, so that the
standard symbols of the objects are now properly displayed after the import. (See also
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use reports > ARIS reports >
Standard", page "Report: Import data in Excel format".) (Pivotal 5338461)

= Text generated by an OLE object by means of an ARIS report script API into an output
document is now properly displayed. (Pivotal 5338751)

= ARIS Connect now supports multi-line text attributes within tables in report dialogs.
(Pivotal 5338930)

= The "updatesystemdb” command can now be run for multiple tenants without causing
errors.

(See also "ARIS > Help > Working with ARIS", topic area "Glossary > S", page "System
database".) (Pivotal 5333258)

= |dentifiers are now properly assigned during a merge, even if the "Assign identifiers when
creating new database items" property was selected for the target database and new
items are created. (See also "ARIS > Help > Working with ARIS", topic area "ARIS
Configuration and Administration > Manage Databases", page "Enable automatic ID
assignment" and topic area "ARIS Configuration and Administration > Manage Databases >
Merge databases".) (Pivotal 5340630)
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All elements considered invalid from an ARIS Method perspective are now removed during
database reorganization. (Pivotal 5342774))

The preview of the advanced template configuration of user HTML templates is now
properly sent by e-mail. (See also "Help", topic area "Manage ARIS Connect > Configure
ARIS Connect > Set up user management > Customize user-defined notifications", page
"Customize default HTML templates for notifications".)

(Pivotal 1330109)

Several enhancements were made for fact sheets of ARIS Connect:
= The mandatory attributes have been adapted in several fact sheets.

= New fact sheets for easy creation of simple questionnaire templates with ARIS
Connect are created for the respective objects and models (questionnaire template,
section, question, etc.)

= To facilitate the creation of questionnaire templates with ARIS Connect, new fact
sheets are available for objects and models (questionnaire template, section, question,
etc.).
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= Due to an update to version ARIS 10.0 SR5 or during a restore of tenant backup certain
ARIS Document Storage data might get lost irrecoverably.

An update to SR5b will prevent future occurrence of this problem and is recommended
even if the problem does not occur yet. If a problem occurs one must restore the latest
tenant backup from previous version (before you updated to version ARIS 10.0 SR5), after
applying ARIS 10.0 SR5b.

Only customers using documents from ARIS Document Storage with multiple revisions are
affected. Customers using only MS SharePoint are not affected.

= |f the database is switched, the navigation menu and the breadcrumb path now refresh
properly. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Use the
portal > Navigate", page "Select database".) (Pivotal 5339381)

= The result is now sorted alphabetically in the "Search" field (quick search), as well as in the
search area. (See also "Help", topic area "Use ARIS Connect > Search content”, pages
"Start quick search” and "Open Search area directly".) (Pivotal 5338727)

= Now, the "Model Viewer" shows the "Swimlane View" correctly for models of databases
that were published with the "Latest version" option. (See also "Help", topic area "Use ARIS
Connect > Work in the portal > Use the portal > Model Viewer", page "Change view" and
topic area "Use ARIS Connect > Use the repository > Manage versions", page "Version
models".) (Pivotal 5337818)

= The "Model Viewer" now shows the "Swimlane View" correctly for models of the type
"BPMN process diagram (BPMN 2.0)". (See also "Help", topic area "Use ARIS Connect >
Work in the portal > Use the portal > Model Viewer", page "Change view".) (Pivotal
5335339)

= The displayed timestamp was adjusted, so corresponding attributes will now receive
correct data. (Pivotal 5331168)

= Now, it is possible to modify Configuration-Sets for own view properly. (See also "Help",
topic area "Manage ARIS Connect > Configure ARIS Connect > Configure Portal > Manage
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configuration and modification sets".) (Pivotal 5338903)

= Now, the ARIS Document Storage dialog correctly shows document names containing
local specific characters of a certain language, for example Turkish. (Pivotal 5337530)

= The ARIS Risk and Compliance Manager now sends only the specified number of e-mails
per second to the User Management Parameter
"com.aris.umc.notification.smtp.sendrate”.

= Correctly, a control execution task is now displayed only once.
(Pivotal 5318692)

= The model comparison was corrected, so modifications for objects of models within a
database are now shown correctly. (See also "ARIS > Help > Working with ARIS", topic area
"Edit models > Check and approve models > Compare models".)

(Pivotal 5336525)

= If search restriction by role is activated for ARIS Document Storage then search results
will now be linked to the correct document revision. (See also "Help", topic area "Use ARIS
Connect > Use the repository > Handle documents > Handle document versions", page
"Show version history".)

= Models are now being exported with their complete content, during ARIS publisher
exports. (Pivotal 1335415)
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= German user interface items and help texts were updated. (Pivotal 5325922)

= The 'Basic Troubleshooting Guide' and 'ARIS Download Client Configuration' documents
are now available for you to solve any problems that might occur when you are trying to
start ARIS Download Client using SSL (HTTPS). (Pivotal 5319400)

= Security vulnerabilities were eliminated that might otherwise have been exploited for
attacks on ARIS Symbol Editor or XML imports.

= To prevent third-party products from causing security vulnerability, xalan was updated to
version 2.7.2.

= The risk of potential Cross-Site Scripting (XSS) attacks on ARIS Connect was eliminated.

= Allunnecessary httpd modules were deleted from the load balancer configuration file for
security reasons. (Pivotal 5328868)

= The search in ARIS Architect was improved in such way that multi-column search results
are now easier to read. (Pivotal 5318945)

» The'OK' button in the ARIS Architect login dialog now remains active when the 'SSO" and
‘Kerberos' options were enabled. (Pivotal 5323420)

= Assigning access privileges in ARIS Architect now works fast regardless of the number of

existing users or user groups. (Pivotal 5322347)

= |n ARIS Architect, link attributes, such as 'Linkl', now work correctly regardless of whether
or not the 'Parameter’ attribute is also specified. (Pivotal 5325997)

= In ARIS Architect, now the correct model opens when you click a model in a change list.
(Pivotal 5329105)

* |n ARIS Connect Designer, now all existing object definitions that are allowed by the
method are offered to you for selection when you are creating new object occurrences in
models. (Pivotal 5329416)

= All changes made to templates in ARIS Architect are now saved correctly. (Pivotal
5331954)
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=  When performing ARIS installations on Linux operating systems, you can use 'y-setenv.sh’
scripts to specify the path to the JRE file. (Pivotal 5322055)
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It is now possible to add the 'My tasks' area to the ARIS Connect configuration.

The time for loading the start page of ARIS Cloud Enterprise was significantly reduced.
(Pivotal 5325533)

Renaming a favorite in ARIS Connect no longer results in a copy of the favorite being
created. (Pivotal 5324548)

When a customer-specific database filter is used, the 'Overview' fact sheet no longer
shows unfiltered objects. (Pivotal 1329567)

Sorting GDPR-relevant tables in ARIS Connect now works correctly. (Pivotal 5327738)

Displaying diagrams in ARIS Enterprise Cloud now always works correctly. (Pivotal
5328227)

In ARIS Connect, the performance was improved in such way that models to which a filter
containing a great number of user-defined models is applied are now displayed much
faster when opened for the first time. (Pivotal 5327912)

The 'My tasks' icon is now correctly displayed in modification sets. (Pivotal 1332924)

Clicking 'My tasks' in ARIS Connect now correctly opens the 'My tasks' area. (Pivotal
1332932)

Improvements were made to the sorting and pagination of GDPR-relevant information in
ARIS Connect Portal. (Pivotal 5327738)

Opening models that were imported as XML files from Natural Engineer into an ARIS
database no longer causes any problems. (Pivotal 5331605)

The size of user-defined symbols is now adapted again to the size of the symbols from
which they were derived. (Pivotal 5329792)

The correct model templates are now used in the swimlane view. (Pivotal 5331116)

Role filters now work correctly again when applied to favorites and search results.
(Pivotal 5331991)

In ARIS Connect, BPMN diagrams are now correctly generated in the swimlane view.
(Pivotal 5325563)

When copied objects are pasted into matrix models in ARIS Connect Designer, also the
hierarchy is now displayed correctly. (Pivotal 5329990)

The performance when working with queries and spreadsheets was significantly
improved. (Pivotal 5311809, 1317672, 5315652)
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Links contained in e-mails sent by Process Governance now reference the correct tenant.
(Pivotal 5327919)

ARIS document storage now always correctly loads the configuration from the relevant
tenant. (Pivotal 5327919)

ARIS document storage now correctly identifies the relevant tenant even if schema
names differ from the standard names 'aris__default’ and 'aris__master".
ARIS document storage now works correctly when you use the 'Folder administration'

access privilege after having updated your ARIS version. (Pivotal 5329520)

Memory utilization was improved so that restoring tenant data for ARIS document storage
now consumes less memory.

Users are now no longer logged out when they click the 'Copy to clipboard' button in order
to copy a document link (ARIS document storage). (Pivotal 5331744)

Hyperlinks exported to a Microsoft Excel file by a report are now corrected if they are not
URI-compliant. (Pivotal 5324166)

If you have changed a font format in a report and the corresponding font format is not
available on the relevant ARIS Server, the missing font format is now automatically
transferred to the '<ARIS installation directory>\fonts' directory.

The report script APl method 'User.getAccessRights(oGroup(], int)' now returns correct
values again. (Pivotal 5326738).

The ARIS report 'Output object information’ now correctly displays the background color
of a text heading even if numbering is used for this heading. (Pivotal 5328089)

A correction was made to the macro script APl method 'Designer.getOID(00bjOcc)’ used in
multiple macros so that this method now returns the value NULL only if no result was
found by the search. (Pivotal 5328378 & 5330524)

The report script method 'OutputFormattedText(String p_ sHTMLTextString)' no longer
inserts unnecessary spaces or line breaks. (Pivotal 5328237)

The 'Export attribute values for translation' report now also includes attributes specified
for UML elements.

Corrections were made to the report script method
'setLaneAttributeModellingProperties(oTemplateLaneProperties)'. (Pivotal 5329586)
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= In ARIS for Process-Driven SAP, reusing process steps from the Process Step Library now
works as required. (Pivotal 5327914)

= You can now successfully perform a tenant backup even if other operations, such as the
execution of a report or a Web service, are running at the same time.
(Pivotal 5325925)

= The error message that can occur when a user is created by means of LDAP
synchronization now has an appropriate wording. (Pivotal 5327550)

= The error that occasionally occurred during validation of user names after an export of
user data to a CSV file had been performed (ARIS Administration > User Management >
Additional functions > Export user statistics) was fixed.

=  When using the 'ARCM attribute maintenance_CBA' and 'ARCM attribute
maintenance__RBA' macros, you can now specify the ‘Automatic numbering' and
‘Description’ attributes as an answer option for questionnaire templates.

= You can now specify the value 0 or higher values for the 'Reserves’ loss attribute.

= Object-specific risk management roles are now provided with risk management impact
type data that can be used as an input to dashboards. (Pivotal 5324701)

= Synchronizing data between ARIS Architect and ARIS Risk & Compliance Manager now
works correctly even if the hierarchy of the database structure is rather complex.

= The button that you can use in ARIS Risk & Compliance Manager to show detailed
descriptions for questions now no longer becomes invisible after you have saved a
questionnaire.

= Users that have logged in to ARIS Risk & Compliance Manager are now able to edit
dashboards and data feeds after having switched to ARIS Connect using the same
session.

= The 'questionnaire__answer__data' data view was extended in the REST API (/arcm/api/).
The new 'optionset_guid’ column is used in DPIA dashboards of the GDPR accelerator.
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* In ARIS Risk & Compliance Manager, hierarchy assignment lists now include deleted

objects only if the filter specifies that deleted objects are to be displayed.
(Pivotal 1332550)

= ARIS Risk & Compliance Manager now provides you with shell scripts (*.sh) for creating a

database schema (user).

= The ARIS Risk & Compliance Manager macro '‘ARCM attribute maintenance_ RBA' was

adapted in such way that you can now use it to manage user-defined attributes.

= Enhanced questionnaires for processing activity documentation:

Recommendations of the German Bitkom association for the record of processing
activities include two different sets of subjects to document for Controller role or
Processor role. From version 10.0.5, a processing activity documentation questionnaire
template is available for each role (Controller and Processor). These questionnaire
templates have the following ARIS attribute values:

- PAD-C for controller role

- PAD-P for processor role

= Enhanced report for record of processing activities:

This feature is in relation with the enhanced questionnaires for processing activity
documentation. The Record of processing activities report of ARIS Risk & Compliance
Manager selects automatically the correct questionnaire for the organizational unit
regarding the role for each processing activity. If the organizational unit is a controller,
the report outputs the PAD-C questionnaire template. If the organizational unitis a
processor, the report outputs the PAD-P questionnaire template.

=  Enhanced dashboard for GDPR Workflow:

This feature is in relation with the enhanced questionnaires for processing activity
documentation. The GDPR Workflow dashboard of ARIS Aware also includes surveys
and guestionnaires with the new GDPR questionnaire templates. The attribute value
must now be GDPR-PAD, GDPR-PAD-C, or GDPR-PAD-P.

= Several enhancements were made for fact sheets of ARIS Connect:

On the fact sheet of a function, the respective processing activity description diagram
is shown.

On the fact sheet of a processing activity description diagram, a link to the respective
fact sheet of the function is shown.

On the fact sheet of an organizational unit, the attributes Data protection officer and
Data protection representative are available.
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= The fact sheet for the Function object type is separated into two fact sheets. One for
the Control symbol type and another for all other Function symbol types. Both fact
sheets, control and function, are adapted to GDPR requirements.

Performance improvements of ARIS queries

= With Service Release 5, ARIS queries for GDPR dashboards were enhanced in order to
improve performance for large ARIS databases.

New questionnaire for application system qualification

In some cases, no detailed data object inventories are available. In this case, an
assessment of the entire application system can also be the first step to GDPR
compliance. Also, data security aspects can serve for a better assessment of data
protection risks and measures. With Service Release 5, the application system qualification
questionnaire template allows a score-based assessment of application systems. Several
data protection and IT security questions with a risk level-based scoring method are
included. The total score of the answered questionnaire is an indicator for the risk level of
the respective application system.

New questionnaire for GDPR data protection impact assessment (DPIA)

In some cases, a data protection impact assessment (DPIA) must be executed for a
processing activity. For a better structure and execution of such DPIA workshops, the
GDPR data protection impact assessment questionnaire templates include all areas to
assess as recommended by the German Bitkom association. Several impact assessment
questions with a fulfilment-based scoring method are included. The total score of the
answered questionnaire is an indicator for the data protection impact level of the
respective processing activity. Furthermore, aspects that are not completely fulfilled can
be assigned to issues (mitigation measures) directly from the questionnaire in ARIS Risk &
Compliance Manager.

New report for GDPR data protection impact assessment (DPIA)

Whenever a data protection impact assessment was executed for a processing activity,
the GDPR data protection impact assessment report shows all relevant information
regarding the processing activity, related documentation and qualification, risk
assessments, any issues or incidents, and the results of the GDPR data protection impact
assessment questionnaire.

New dashboard for GDPR data protection impact assessment (DPIA)

Whenever a data protection impact assessment was executed for a processing activity,
the GDPR data protection impact assessment dashboard shows all relevant information
regarding the workflow of the workshop (represented in answered subjects) and the
resulting issues (mitigation measures) for a processing activity. New issues regarding
aspects that are not completely fulfilled can be created directly from the dashboard.
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= New ARIS Connect configuration delta installation files
From version 10.0.5, you can install the AC configuration for G with the new delta files
more easily in your customized AC version. For more information on how to use ARIS
Connect delta files, contact your ARIS Service team.

= Fix for GDPR extended management report: The missing Issues chapter was added to the
table of content.

= Fix for GDPR record of processing activities and GDPR data protection impact assessment
report: If a user to whom the required Survey manager role is not assigned runs these
reports in ARIS Risk & Compliance Manager, a message is how displayed.
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=  When you click 'My tasks', Process Board now opens correctly and correctly shows a user's
tasks even if "My tasks' was configured as a list entry in modification sets.
(Pivotal 5327214)

= Dashboards added to the ARIS Connect configuration are displayed in the default
language if the interface language is switched to a language in which the name of the
dashboard is not specified.

= Modification sets in ARIS Aware now correctly record changes made to the location of
dashboards.

* |n ARIS Aware, improvements were made to the assignment list display (Modification sets
> Dashboards > Edit component).

= Improvements were made to the dialog used for assigning dashboards (Modification sets >
Dashboards > Edit component).

= |tis now possible to delete dashboard assignments from modification sets (ARIS
Administration > Portal > Manage configuration sets > Edit > Components > Dashboards).
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=  When distributed ARIS environments that include ElasticSearch clusters are updated from
ARIS 10.0 SR3 to ARIS 10.0 SR4, existing data are now correctly copied to the new
structure. Thus, all required data are now always available in the new environment.
(Pivotal 5325873)

= Corrections were made to the search functionality so that the correct number of pages is
now displayed for the list of search results regardless of where you have started the
search operation or how many results are returned.
(See also "Help", topic area "Use ARIS Connect > "Search content".)
(Pivotal 1329163)

= |n ARIS Connect, the display of model assignments was changed in such way that an
assigned model is displayed only if it is allowed by the method filter in use.
(See also "Help", topic area "Use ARIS Connect > Work in the portal > Use the portal >
Output information”, page "Display the current method filter", and topic area "Use ARIS
Connect > Work in the portal > Use the portal > Model Viewer", page "Open assignment".)
(Pivotal 5321644)

= An error due to which the ARIS portal sometimes became unresponsive was fixed in the
navigation component.
(See also "Help", topic area "Use ARIS Connect > Work in the portal > Use the portal”.)
(Pivotal 5324495)

= Corrections were made to the sorting of tables so that the sorting now works properly
when a user to which the "Contribution” license is assigned is working with a table as a
viewer.
(See also "Help", topic area "Use ARIS Connect > Work in the portal > Contribute as a
viewer".) (Pivotal 5316986, 5325152)

= The "Fonts" folder containing the fonts used in reports is now no longer deleted when you
perform an update of the ABS/HDS runnable. (Pivotal 5324980)
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= When you back up ADS data from a tenant, now the operation correctly backs up the
tenant you have selected and no longer tries to access other tenants. (Pivotal 5324880)

= For ARIS Aware content to be displayed faster, the communication protocol is now being
compressed.
(See also "Help", topic area "Use ARIS Connect > Use the repository", page "Use
dashboards".) (Pivotal 5320076)

= Anerror was fixed in ARIS Aware creating the Oracle backend schema for other than the
default tenant.

= |n ARIS Process Governance, both caching and the backup mechanism were improved so
that completing a human task no longer results in process instances being blocked.
(See also "ARIS > Help > Working with ARIS", topic area "Special topics and functions >
Process Governance > Use case", page "Start governance process", and topic area "Special
topics and functions > Process Governance > Model > Valuable information > What objects
and symboils are relevant to Process Governance?", page "Human task".)
(Pivotal 5320844)

=  When German is selected as the interface language, ARIS Process Governance dialogs that
were created using ARIS 10.0 SR4 sometimes show incorrect names of controls in data
flows. This problem does not occur in dialogs that were created with older versions of
ARIS or when using an ARIS 10.0 SR4b installation.
If a dialog shows this behavior, open the affected dialog, save it, and update the data flow.
(See also "ARIS > Help > Working with ARIS", topic area "Special topics and functions >
Process Governance > Model > Model dialogs".)

= Deactivated/deleted processing activities are now correctly displayed in lists at
organization hierarchy elements.

= |Integration of GDPR enhancements into Connect configuration.
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= ARIS Synchronization now also considers empty attributes of objects and clears them in
ARCM.

* Models that include a high number of user-defined method items now open quickly.
(Pivotal 5318998)
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X-Forwarded-For headers will now be ignored by default

The X-Forwarded-For (XFF) HTTP header is a common method for identifying the originating IP address
of a client connecting to a web application (like ARIS) through an HTTP proxy or load balancer.

Without this header, the application would see the IP address of the HTTP proxy or the load balancer as
the apparent client IP address instead of the IP address of the actual client.

ARIS protection mechanism against brute force login attacks

ARIS has a security mechanism in place to prevent attackers from performing arbitrarily many login
attempts to “try out” or “guess” a user’'s password (a form of brute-force attack): if to many failed login
attempts for a certain user account coming from a certain IP address are observed, that combination of
user account and IP address is locked for any further login attempts.

Up to ARIS version 10.0.1, ARIS would accept XFF headers in a request. As a consequence, an attacker
could set this header to make ARIS believe that his requests are coming from a different then his actual
IP address. That way, the protection mechanism against brute force login attacks could be
circumvented, allowing the attacker to try out arbitrary many passwords using different “fake” IP
addresses in the XFF header.

To prevent this problem in the future, starting with ARIS 10.0.2, ARIS (the ARIS loadbalancer, in
particular) will by default discard any XFF headers received from clients. However, there are scenarios
where the use of the XFF header is legitimate, for example when ARIS is operated behind a reverse
proxy (e.g., a highly-available loadbalancer in front of the ARIS loadbalancer(s)). Here, the reverse proxy
will usually use the XFF header to allow ARIS to know the IP address of the actual client that does the
request. With XFF headers now being discard by default, ARIS will now no longer see the actual client
addresses, but instead, from the perspective of ARIS, all requests will be coming from a single IP
address (that of the reverse proxy).

While the negative effects of this change are limited, in such settings it is highly recommended to
configure the ARIS loadbalancer to accept XFF headers from the IP address of the reverse proxy.

To do this, you can should the loadbalancer configure parameter HTTPD.X-Forwarded-
For.trusted.proxy.regex, with which you can provide a regular expression (regex, see
https://httpd.apache.org/docs/2.4/glossary.htmi#regex) that will make the ARIS loadbalancer accept
XFF headers from any IP address that matches this regex. Note that any backslash characters that are
to appear in your regex need to be escaped by replacing them with four(!) backslash characters.

For example, to accept XFF headers from the IP address 10.0.0.1, you would set the HTTPD.X-
Forwarded-For.trusted.proxy.regex to “10\\\\.0\\\\.0\\\\.1". Observe the use of the quadruple
backslashes to escape the dot (“.") character that has a special meaning in regular expressions.

To get back the original behavior, you can set the HTTPD.X-Forwarded-For.trusted.proxy.regex
parameter to “.*" (a regular expression matching every IP address).
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= The loadbalancer configuration for enforcing HTTPS connections (SSL) now works as
expected. (Pivotal 1296177)

= Itis nolonger possible for users to start the consolidation of objects in a versioned
database. (See also "ARIS > Help > Working with ARIS", topic area "Navigate and edit items
> Create and manage objects", page "Consolidate objects".)
(Pivotal 5305664)

= A merge procedure no longer overwrites the name of the main group in the target
database, even if you selected the "Source overwrites target" conflict resolution option for
objects. (See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration and
Administration > Manage databases > Merge databases".)
(Pivotal 5310146)

= The wording was improved for the error message that is displayed when a user who has
permanently locked a model is trying to create an occurrence copy of a model object that
is locked by another user.
(Pivotal 5310961)

= When logging in to a database, you can now select any existing change list instead of only
the latest 999. (See also "ARIS > Help > Working with ARIS", topic area "Navigate and edit
items", page "Open database", Link "Versionable databases".)
(Pivotal 5312692)

= A correction was made to the "Edit report parameters" functionality so that it now works
correctly outside of a database context. (See also "ARIS > Help > Working with ARIS", topic
area "ARIS Configuration and Administration > Manage scripts"”, page "Specify report
parameters".) (Pivotal 5316621)

= You can now import, correctly display, and work with ARIS Aware content that you have
backed up from ARIS 10.0 GA. (See also "Help", topic area "Manage ARIS Connect >
Administrate dashboards (ARIS Aware) > Configure dashboards", page "Import
dashboards".) (Pivotal 1322963)

= The dashboard editor in ARIS Aware now uses the language you have selected in ARIS
Connect. Furthermore, some of the user interface items were given more descriptive
names. (See also "Help", topic area "Use ARIS Connect > Use the repository > Use
dashboards", page "Create a dashboard in the Repository".) (Pivotal 5306476)
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Default symbols used for object definitions can now be changed only by users having
write privileges for objects. (See also "ARIS > Help > Working with ARIS", topic area "Create
models > ARIS models > Use objects > Extended editing", page "Assign a default symbol to
existing objects".) (Pivotal 5292670)

Changes were made to the Visio import into ARIS so that relevant Visio drawing types are
now correctly identified and the corresponding VSDX files correctly imported into ARIS.
(See also "ARIS > Help > Working with ARIS", topic area "Export/Import > Visio import".)
(Pivotal 5303304)

The layout functionality was improved so that automatic creation of a model layout now
provides better results. (See also "ARIS > Help > Working with ARIS", topic area "Create
models > ARIS models > Use objects > Extended editing", page "Generate model layouts
automatically”.) (Pivotal 5308846)

Sorting the "Variants" properties page of a model now works correctly for groups. (See
also "ARIS > Help > Working with ARIS", topic area "Create models > ARIS models > Use
variants".) (Pivotal 5310697)

Now the search shows a correct result when special characters suchas +78()[]{}are
being used in combination with an asterisk (*). (See also "ARIS > Help > Working with ARIS",
topic area "Navigate and edit items", page "Search for database content".)

(Pivotal 5310837)

The RACI view now works correctly when objects of the "Function" type (object type
number 22) are defined to be either a "Task" or a "Subprocess" based on the attribute
specified for them in BPMN models. (See also "Help", topic area "Use ARIS Connect > Work
in the portal > Views > Valuable information", page "What is the RACI fact sheet for?".)
(Pivotal 5314379)

ARIS User Management

The "updateLicense" ACC command for updating licenses now supports multiple product
codes. (Pivotal 5288975)

Corrections were made to the user synchronization functionality so that only group
memberships with a direct assignment are removed now when users are being
synchronized. (Pivotal 5300477)

The names of user groups are no longer truncated on the "Associated users" page.

(Pivotal 5303244)

The delimiters | (pipe) and ~ (Tilde) are now handled correctly in multi-LDAP configurations
and are allowed to be used as an input to the user interface. (Pivotal 5308410)
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User logins to the system are now logged correctly. (Pivotal 5311719)

The standalone version of User Management now provides the English version of the ARIS
help if no help is available in the interface language you have selected.
(Pivotal 5311851)

The "Add LDAP server" dialog is now displayed in the center of a screen and provides a
horizontal scroll bar for you to easily access all relevant input fields by moving them into
the visible area. (Pivotal 5311852)

Kerberos SSO now works correctly with dashboard links so that users can directly access
ARIS Aware dashboards by clicking the corresponding links.
(Pivotal 5319866)

It is now possible to simultaneously open more than seven ARIS Connect models in
Microsoft® Internet Explorer® 11. (See also "Help", topic area "Use ARIS Connect > Use the
repository > Create and edit models > Model > Basic modeling", page "Open model for
editing".) (Pivotal 5300455)

When you print a model graphic as a PDF file in the portal, the "Select output options"
dialog is now displayed in the alternative language "English" if an unsupported language
was selected as the interface language in ARIS Connect (for example, Greek). (See also
"Help", topic area "Use ARIS Connect > Work in the portal > Use the portal > Output
information”, page "Print the graphic of the current model".)

(Pivotal 5305845)

Filtered objects of the "Control" type are no longer displayed on the process overview
page and the sidebar of the "Steps" fact sheet. (See also "Help", topic area "Use ARIS
Connect > Work in the portal > Views > Classic view > Groups > Fact sheets of ARIS models
>'Overview' and 'Steps™.) (Pivotal 5311553)

Connections and connection ends are now always displayed correctly in ARIS Connect
regardless of the browser being used. (See also "Help", topic area "Use ARIS Connect >
Work in the portal > Use the portal > Model Viewer" and topic area "Use ARIS Connect > Use
the repository > Create and edit models > Model > Basic modeling”, page "Open model for
editing".) (Pivotal 5318055)

If you are using a modification set that is based on the classic view, the corresponding
areas now open correctly when you click "Manage documents” or "Dashboards & Data
feeds" on the "Home" page. (See also "Help", topic area "Manage ARIS Connect > Configure
ARIS Connect > Configure Portal > Manage configuration and modification sets", page
"Create modification set" and topic area "Use ARIS Connect > Work in the portal > Views >
Classic view > Quick start".) (Pivotal 5318061)
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= Corrections were made to the Script Wizard to enable the highlighting of output formats.
As a result, highlighting is now correctly applied or removed when output formats are
selected or deselected using the CTRL key and the mouse. (Pivotal 5300279)

= |n ARIS Connect, you can now successfully run reports for models for which no name was
specified in the language currently selected. (See also "Help", topic area "Use ARIS
Connect > Work in the portal > Use the portal > Output information”, page "Generate report”
and topic area "Use ARIS Connect > Use the repository > Create and edit models > Model >
Extended editing”, page "Generate report”.) (Pivotal 5300672)

= Changes were made to drop-down lists in ARIS Connect. As a result, the width of drop-
down list boxes in dialogs of ARIS Connect reports now corresponds to the width of the
relevant selection box even if the list entries are shorter. If the texts in the list are longer,
the last part is replaced with three dots. (See also "Help", topic area "Use ARIS Connect >
Work in the portal > Use the portal > Output information”, page "Generate report" and topic
area "Use ARIS Connect > Use the repository > Create and edit models > Model > Extended
editing", page "Generate report".) (Pivotal 5300674)

= The report script API help was revised. Some errors were removed and missing
information was added. (See also "ARIS > Help > ARIS Script".) (Pivotal 5303090)

= Corrections were made to the sorting of tables in report dialogs so that sorting a column
no longer results in incorrect data being displayed. (Pivotal 5307810)

= Corrections were made to the ARIS object model. When running an ARIS report script, it is
now no longer possible to create an object occurrence for a versioned object definition
that is no longer available in the workspace version of a database. (Pivotal 5308192)

= Corrections were made to Script Editor so that existing (saved) breakpoints no longer
move during the process of editing a script. (See also "ARIS > Help > Working with ARIS",
topic area "ARIS Configuration and Administration > Create scripts > Use Script editor".)
(Pivotal 5310701)

= "Auser running a script in debug mode without being logged in to a database can now use
the "Debug script" dialog to log in to a database. Double-clicking the name of the required
database now correctly enables the "Next" button. (See also "ARIS > Help > Working with
ARIS", topic area "ARIS Configuration and Administration > Create scripts > Use Script
editor".) (Pivotal 5310706)

= Report script API method "getAccessRights (int nAccessRight )" of the "UserGroup" report
class now returns a result. (See also "ARIS > Help > ARIS Script", topic area "Methods for
reports and semantic checks > Objects > UserGroup", page "getAccessRights(int) :
Group[]".) (Pivotal 5313094)
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* Report script API method "enableCancellation ( boolean bEnableCancel)" now works
correctly. When this method is set to "false", it is not possible to cancel a running reportin
ARIS Connect. (Pivotal 5311862)

= Corrections were made to the Visio import:
Connections of the "activates" or "creates" type used in BPMN diagrams are no longer
modeled as message flows.
If a collapsed subprocess modeled in Visio contains objects, this subprocess is now
converted into an expanded subprocess.
Please note:
Symbols that are incorrectly specified in the mapping with regard to Visio but are allowed
by ARIS Method cannot be prevented from being placed. This may lead to subsequent
errors due to which symbols of modeled objects do not comply with their
descriptions/properties.
(See also "ARIS > Help > Working with ARIS", topic area "Export/Import > Visio import".)
(Pivotal 5311445)

= Report script API method "Scriptinfo.getimports()" now always returns a correct result by
returning the file name when a file is imported and a GUID (Globally Unique Identifier)
when a report is imported. (See also "ARIS > Help > ARIS Script", topic area "Methods for
reports and semantic checks > Global objects > Report component interfaces > Script
admin > Scriptinfo”, page "getimports() : String[]".) (Pivotal 5313718)

= The table of contents is now correctly numbered in the output of the "Create process
manual" report. (See also "ARIS > Help > Working with ARIS", topic area "Evaluate data >
Use reports > ARIS reports > Standard”, page "Report: Create process manual”.) (Pivotal
5313833)

= The report "Import data in Excel format" now also imports files containing data from ARIS
Simulation attributes, such as the "Processing time" (AT_WORK _TIME) attribute. (See also
"ARIS > Help > Working with ARIS", topic area "Evaluate data > Use reports > ARIS reports >
Standard", page "Report: Import data in Excel format".) (Pivotal 5314149)

= Spaces are now correctly displayed when Arabic characters are used in EMF graphics that
were generated by reports. As a result, Arabic words are now coherent and
comprehensible. (Pivotal 5314462)

= Report script API method "getAccessRights (int nAccessRight )" of the "UserGroup" report
class now returns a result. (See also "ARIS > Help > ARIS Script", topic area "Methods for
reports and semantic checks > Objects > UserGroup", page "getAccessRights(int) :
Group[]".) (Pivotal 5318471)
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= |tis now possible to configure how hyperlinks are to be displayed in input tables used for
ARIS Process Governance dialogs. When adding an input table to a screen diagram, you
can use the "Display links as icons" check box to specify whether a link is to be displayed
as an icon (check box enabled) or as an entire link (check box not enabled). (See also "ARIS
> Help > Working with ARIS", topic area "Special topics and functions > Process
Governance > Model > Model dialogs > Valuable information > Element pane", page "Input
table".)
(Pivotal 5315987)

= The "Symbol order" area in step 15 ("Select symbol order") of the Filter Wizard now
correctly provides the object symbols for the "BPMN collaboration diagram (BPMN 2.0)"
model type. (See also "ARIS > Help > Working with ARIS", topic area "ARIS Configuration
and Administration > Specify conventions", page "Define your own filter".)
(Pivotal 5300553)

= The "can trigger" connection is now displayed in the "Create connections" dialog for you to
decide whether you want it to be shown or hidden when the associated object overlaps
another object. (See also "ARIS > Help > Working with ARIS", topic area "Create models >
ARIS models > Use objects > Extended editing", page "Create implicit connections for
overlapping objects".)
(Pivotal 5306463)

= The use of BPMN functionality in ARIS was extended in such way that it is now possible to
use lane objects in models of the "BPMN process diagram (BPMN 2.0)" type that were
created as a "Subprocess (collapsed)” in a model of the "BPMN collaboration diagram
(BPMN 2.0)" type. (Pivotal 5312848)

= |n BPMN diagrams, it is no longer possible to create a connection between a group and
other BPMN objects. (Pivotal 5316232)

=  BPMN import was improved in such way that it is now possible to import BPMN files that
have invalid references to objects. (See also "Help", topic area "Use ARIS Connect > Use
the repository > Create and edit models > Create/Import a model”, page "Import BPMN
file".) (Pivotal 5316504)

= Tasks whose "Activity type" attribute is set to "Call activity" are now correctly exported as
a call activity as was the case in previous ARIS versions. (See also ARIS Connect: "Help",
topic area "Use ARIS Connect > Use the repository > Create and edit models > Model >
Extended editing > Export", page "Export BPMN diagram". ARIS Architect: "ARIS > Help >
Working with ARIS", topic area "Export/Import > BPMN Import/Export”, page "Export BPMN
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diagram as a BPMN file".) (Pivotal 5317471)

= The folder icon is now correctly displayed in HTML exports. (See also "ARIS > Help >
Working with ARIS", topic area "Publish > HTML export”, page "Publish models as HTML
export".) (Pivotal 5312654)

= Report script API method "MatrixContentCell.getCxns()" no longer returns only NULL
objects, but now returns the required information. (See also "ARIS > Help > ARIS Script,
topic area "Methods for reports and semantic checks > Objects > Matrix", page
"getContentCells() : MatrixContentCell[]".)
(Pivotal 5313084)

= Policies that have already been assigned to an incident are now no longer displayed for
selection.

= The option that enables you to mark an object as "issue-relevant" is now available on all
lists including assignment lists.

= Specifying input for the "Processing time (target)" field on audit step templates is now
mandatory.

= An appropriate error message is how displayed when you are trying to create a
questionnaire based on a survey task whose end date is in the past.

= When a customizing is enhanced using ARIS Cloud Controller, existing customizing are
now deleted first.

= The "system administrator" role is automatically assigned to users in ARIS Risk &
Compliance Manager (by synchronization) only if these users are assigned the 'ARCM
administrator' function privilege in ARIS Administration/User Management.

= You can now switch to another section of a questionnaire via the tree view even if you
have not answered all of a section's mandatory questions yet.

= Anissue owner can no longer delete an issue whose issue owner state is "On hold".

= You can now create an incident only if the discovery date you specify is the current day or
a date in the past.

= Displaying content from ARIS document storage in Arabic now works correctly.
(Pivotal 5300129)
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= The checking of document types was improved so that uploading documents now works
without incorrect restrictions. (See also "Help", topic area "Use ARIS Connect > Work in the
portal > My tasks > Documents", page "Upload document”.)
(Pivotal 5305508)

= |fdocuments from ARIS document storage are renamed, comments associated with these
documents are no longer removed. (See also "Help", topic area "Use ARIS Connect > Use
the repository > Handle documents", page "Rename document".)
(Pivotal 5307747)

= ARIS document storage links now correctly refer to the latest document version available.
(See also "Help", topic area "Use ARIS Connect > Use the repository > Handle documents >
Handle document versions", page "Show version history".)
(Pivotal 5312227)
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= Line breaks in a "Body" property are now correctly retained for an opaque action if you
click the area in between two buttons in a value cell. (Pivotal 1205990)

= |n multi-node environments (with at least 2 ABS runnables), temporary folders and files
automatically created in the "Download" directory of the ABS runnables during a tenant
backup are now automatically deleted. As a result, more free disk space is available.
(Pivotal 1324820)

= |ssues with garbled Japanese are fixed. Japanese texts are not garbled in Merge log and
Merge wizard shows correct Japanese names. Also problems with garbled Japanese in
attribute wizard and versioning are fixed.
(Pivotal 1206134, 1206330, 1206471, 5320665, 5322062)
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An attribute search performed in a database that was just restored now finds all relevant
attributes regardless of the length of the attribute text. (See also "ARIS > Help" > Working
with ARIS", topic area "General", page "Find".)

(Pivotal 5305021)

Robustness was improved for the import of filters and XML files on Unix-based systems
with regard to the MIME types in use.
(Pivotal 5301205)

A user to whom only the "Read" privilege is assigned can no longer change the default
symbol used for an object. (See also "ARIS > Help" > Working with ARIS", topic area "Create
models > ARIS models > Use objects > Extended editing", page "Replace object symbol".)
(Pivotal 5292670)

The Visio import now correctly identifies all template aliases so that VSDX files are
successfully imported into ARIS. (See also "ARIS > Help" > Working with ARIS", topic area
"Export/Import > Visio import”, page "Import models from Microsoft® Visio".)

(Pivotal 5303304)

The object consolidation functionality is no longer provided in a versioned database. It is
generally not possible to consolidate objects in versioned databases. (See also "ARIS >
Help" > Working with ARIS", topic area "Navigate and edit items > Create and manage
objects", page "Consolidate objects".)

(Pivotal 5305664)

The "Search" tab no longer displays technical attributes that are not relevant to users and

thus are to be invisible. (See also "ARIS > Help" > Working with ARIS", topic area "General >
New tab", page "Start search using new tab".)

ARIS User Management

In the "Associated user groups" area of a user, user group names are now displayed in
their entirety, which means that names are no longer restricted to the first 26 characters.
(See also "Help", topic area "Manage ARIS Connect > Manage users", page "Edit user".)
(Pivotal 5303244)
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= The accessibility of the User Management profile page was improved.

= User-defined symbols from derived model types are now correctly displayed in the
"Symbols" bar in ARIS Connect Designer. (Pivotal 5300363)

= |If noroles are selected for filtering, the filter output no longer displays any processes. (See
also "Help", topic area "Use ARIS Connect > Work in the portal > Valuable information > ",
page "What is the structure of the My content area?".)
(Pivotal 5303680)

*= Logging in to ARIS Connect using the Kerberos single sign-on now works correctly for
users that log out and try to log in again. (See also "Help", topic area "Manage ARIS
Connect > Configure ARIS Connect > Set up user management > Customize ARIS for LDAP
server operations”, page "Configure single sign-on".)

(Pivotal 5304415)

= |f the configuration includes a language for which no translations are available, the "Select
output options" dialog is now displayed in the alternative language "English".
(Pivotal 5305845)

= |f a user changes the layout of the "Home" area in a modification set, these changes are
now always saved correctly. (See also "Help", topic area "Manage ARIS Connect >
Configure ARIS Connect > Configure Portal > Manage configuration and modification sets",
page "Create modification set".)
(Pivotal 5306080)

= The performance of ARIS Connect was improved for the browsers "Google Chrome",
"Microsoft Internet Explorer 11", and "Microsoft Edge".

= Editing diagram names sometimes resulted in an error being displayed. This problem no
longer exists.

= Color highlighting is now enabled again for table headers used in the ARIS Connect
configuration so that table headers can now be clearly distinguished from table text. (See
also "Help", topic area "Manage ARIS Connect > Configure ARIS Connect > Configure Portal
> Manage configuration and modification sets", page "Create modification set".)

= Model names containing country-specific characters are now correctly displayed in
comments posted in Collaboration even when Microsoft SQL database systems are used.
(See also "Help", topic area "Use ARIS Connect > Collaborate with users".)
(Pivotal 5305260)

= The display of a diagram is now refreshed in the "Home" area when a user switches to
another database.
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= Page changes now work correctly in the "My content" area. The required pages are shown
as expected. (See also "Help", topic area "Use ARIS Connect > Work in the portal > Views >
Classic view", page "Home".)

= The "Output user groups with users and privileges" report is now generated correctly
when curly brackets are used in an e-mail address. (See also "ARIS > Help" > Working with
ARIS", topic area "Evaluate data > Use reports > ARIS reports > User management”, page
"Report: Output user groups with users and privileges".)
(Pivotal 5297838)

= The "Export relationship matrix" report is now generated correctly, which means that all
relevant relationships are now displayed in the Microsoft Excel export file. (See also "ARIS
> Help" > Working with ARIS", topic area "Evaluate data > Use reports > ARIS reports >
Administration”, page "Report: Export relationship matrix".)
(Pivotal 5301512)

= Corrections were made to the "Mandatory semantic checks" ARIS macro so that it can now
be run for open matrix models. (See also "ARIS > Help" > Working with ARIS", topic area
"ARIS Configuration and Administration > Create scripts > Using script editor > Valuable
information”, page "What is a macro?".)
(Pivotal 5302177)

= Documents generated by reports, macros, or semantic checks now contain mixed-
language content only if the file "atsall<language abbreviation>.js" is not available for the
selected language (for example, if the file "atsallru.js", with "ru" meaning "Russian", is
missing, a generated document may still contain some English terms, such as "page" or
"database"). (See also "ARIS > Help" > Working with ARIS", topic area "ARIS Configuration
and Administration > Create scripts > Using script editor > Valuable information", pages
"What is an ARIS report?”, "What is a macro?", and "What is a semantic check?".)
(Pivotal 5302728)

= Corrections were made to the report script APl method "setFocusedElement"” so that
applying this method to multi-line text boxes no longer results in an error. (Pivotal
5303068)

= The "ARIS Script" help now provides a complete description of the
"createFilteredDefCopy" method. (See also "ARIS > Help" > ARIS Script".)
(Pivotal 5303090)

= German special characters (umlauts) are now correctly displayed in the dashboard report
properties. (Pivotal 5301517)
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= German diacritics are now correctly displayed and processed in ARIS Aware dashboards
and in the ARIS Connect configuration. (Pivotal 5300341)

= |fauser uses adashboard URL in a browser without being logged in to ARIS Connect, this
user is now automatically redirected to the ARIS Connect start page of the tenant
specified in the dashboard URL.

= Clicking the "Back" button in the "Filter Wizard" now displays the previously selected
model types, object types, and connection types. (See also "ARIS > Help > Working with
ARIS”, topic area "ARIS Configuration and Administration > Specify conventions”, page
"Define your own filter".) (Pivotal 5300553)

= The behavior of dependent controls in ARIS Process Governance was adapted for use in
ARIS Connect. This means that dialog elements of user-defined dialogs are now no longer
displayed in ARIS Connect if the "Set as invisible" option was enabled for them. (Pivotal
5306672)

= The diagram view in the process administration now displays the corresponding diagram
after a mini workflow was run in ARIS. (See also "Help", topic area "Manage ARIS Connect
>Administrate automated processes", page "Open process administration".)

= The "Check issues" job now shows the issues to be checked only once. (Pivotal 5306195)

= The "Update survey" functionality is now described in the form help. Furthermore, a
description of the button is now displayed as a tooltip.

= Corrections were made to the display of tooltips so that tooltips no longer prevent users
from clicking specific areas of a chart.

= Control executions performed by deleted users are no longer excluded from control
execution lists.
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= Due to changes made to the persistence of ARIS document storage, it is not possible to
migrate folders whose names use special characters. Prior to backing up folders for
migration purposes, folder names must be changed to match the ARIS 10.0 naming
conventions. This information is now available in the "ARIS Data Migration Guide.pdf"
manual. (See also "Help", topic area "Manage ARIS Connect > Manage documents".)
(Pivotal 5301299)

= Corrections were made to character encoding so that data feeds can now be run correctly
and MashZone and ARIS Aware are able to process the corresponding data. (Pivotal
5301824)

= Corrections were made to the sorting of query results in the table view so that entries are
now always sorted correctly. (See also "ARIS > Help" > Working with ARIS", topic area
"Evaluate data > Use queries", page "Output table view".)
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The use of the 'optimizedb' command for a database in ARIS 10.x (including ARIS 10.0, ARIS
10.0 SR1, ARIS 10.0 SR2, ARIS 10.0 SR2b) can result in data consistency defects.

An ARIS database may become inconsistent (see 'll. Impact’) if the following ARIS
Administration commands are executed in ARIS 10.x:

- Run database optimization with the ARIS Server Administrator command 'optimizedb'.

- Restore a database with '-c checkrebuildall' and set the options "checkConsistency”,
"checkReplicaConsistency"”, and "rebuildForeignKeylndexes" to 'true’.

The 'history <dbname>' ARIS Server Administrator command can be used to identify whether
one of these two commands was executed for a specific database.

Sample entry for 'optimizedb':

[DB OPTIMIZATION] | Start: 2017-11-14 12:16:23.937 | End: 2017-11-14

12:18:13.171 | Duration: 109,234s (00:01:49.234) | Area: [-1] | Actions:
[ACCESS RIGHT, FONT, COM, CXN, TEXT, USER, OBJ, EXT CXN, MODEL] |
Options: [] | Consistency: Indices, foreign keys | ARIS: 10.0.0.1168090 /

10.0.1.1168090 | ASN: #20 | Tenant: default

Sample entry for restore using '-c checkrebuildall’:

[IMPORT V 10] | Start: 2017-11-27 13:22:22.774 | End: 2017-11-27
13:22:24.249 | Duration: 1,475s | Backup: 10.0.0.1185787 /
10.0.2.1.1185787 | DB schema: 5 | Clan: [blobHandling: OptimizeForSize,
checkConsistency: true, checkReplicaConsistency: true,
rebuildForeignKeyIndexes: true] | ARIS: 10.0.0.1195057 / 10.0.0.3.1195057

| No archive | Tenant: default

The database can be repaired in any case (Section 'lll. Fix ' explains how to address the above-
named database inconsistency issue).

Impact

Performing database optimization using the 'optimizedb' command or restoring a database by
means of '-c checkrebuildall' may have the following effects in ARIS 10.x:
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- Corruption of internal meta information. This information will be ignored by the backup
operation so that using this backup to restore the database will result in data loss.

- The save operation for models can falil.

Fix
To prevent database inconsistencies from occurring or fix the inconsistency issue once it has
occurred, it is necessary to run individual patches for ARIS 10.0, ARIS 10.0 SR1, ARIS 10.0 SR2,

or ARIS 10.0 SR2b, or to perform an update to version ARIS 10.0 SR2c (10.0.2.3).

Once the relevant patch was run or the update to ARIS 10.0 SR2c was performed, executing
the 'optimizedb' command will no longer cause any inconsistency issues.

Identifying inconsistencies in existing databases is possible only by running the
corresponding patches for ARIS 10 versions older than SR2c or performing an update to ARIS
10.0 SR2c.

A new ARIS Server Administrator command called 'checkreferences' is available, making it

possible to identify whether there are critical inconsistencies in a database. This command
checks all databases on a tenant. There is no need to lock databases prior to executing this
command.

If critical inconsistencies are found in a database as a result of executing this new command,
the 'optimizedb <dbname>' command must be executed for the given database.

If '‘checkreferences' does not identify any database inconsistencies, no actions are required.

Nevertheless, with the patched or updated version, we recommend a database optimization if
any of the above described actions like optimization or special restore have been executed by
the customer.
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= ARIS 10.0 SR2b supports now also Amazon AWS Linux.

ARIS Server

»= Under certain circumstances ARIS databases can have structural issues concerning
internal index entries. In such cases an automatically triggered maintenance mechanism
has been deleting data instead of recovering it. This issue has now been solved. (Pivotal
5302336)

= The behavior of the consolidation.log file has been adapted to other log files in ARIS
Business Server and therefore is now configurable. (Pivotal 5302094)

ARIS Report

= Resolving an issue with ARIS Report "User groups with assigned users and privileges" in
User Management, that failed if the email address of a user contained the character { or }.
(Pivotal 5297838)

= Resolving an issue with ARIS Report "Export Relationship Matrix, where the exported
Microsoft Excel file did not contain any relationships at all. (Pivotal 5301512)

= ARIS for Process Driven SAP: It is now possible to use SAP shadow symbols also in
Enterprise BPMN process diagrams and Enterprise BPMN collaboration diagrams. The
tasks with SAP shadow symbols by default and are not included in the SAP
synchronization.

ARIS User Management

= User group name in User group association view will not be cut anymore. (Pivotal
5303244)

= Fixed problem with encoding (queries & data feeds). (Pivotal 5301824)
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The “Filter Wizard" now displays previously selected model, object, and connection types
when the user clicks the "Back" button. (See also "ARIS > Help > Working with ARIS", topic
area "ARIS Configuration and Administration > Specify conventions", page "Define your
own filter".)

(Pivotal 5293670)

In the "Attributes"” dialog, now the correct values are copied when the columns are
switched. (See also "ARIS > Help > Working with ARIS", topic area "Edit models > Extended
editing > Edit attributes".)

(Pivotal 5293007)

A time zone issue was fixed due to which different times were displayed for the "Last
change" attribute in ARIS Connect Model Viewer and ARIS Architect when the server time
(e.g., London (UTC +00:00)) was different from the client time (e.g., Berlin (UTC +01:00)).
(Pivotal 5290177)

Models that contain object occurrences whose height is O are now loaded and opened
without delay. (See also "ARIS > Help > Working with ARIS", topic area "Edit models > Basic",
page "Open models".)

(Pivotal 5280868)

The size of the "Assigned models" dialog can now be changed using the mouse. (See also
"ARIS > Help > Working with ARIS", topic area "Create models > ARIS models > Use objects >
Extended editing”, page "Show assignment".)

(Pivotal 5279035)

In the ARIS Method help, the "Process step"” symbol is marked correctly as "Structurally
relevant” for the derived "Process block” model type. (See also "ARIS > Help" > ARIS
Method help™.)

(Pivotal 5294966)

User names are now output identically using lower case letters in ARIS Clients as well as in
User Management of ARIS Administration.
(Pivotal 5290299)

ARIS Connect

Text that is entirely displayed in ARIS Architect/Designer is now also entirely displayed in
Model Editor instead of being abbreviated by three dots.
(Pivotal 5297752)
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The attributes "Last user" and "Last change" are no longer updated if no model changes
were made.
(Pivotal 5294234)

Model Editor now creates assignments correctly when a model is assigned whose name
contains a line break. (See also "Help", topic area "Use ARIS Connect > Use the repository >
Create and edit models > Extended editing", page "Assign a model to an object".)

(Pivotal 5289214)

The configuration of start elements used by the "Steps" fact sheet was corrected.
(Pivotal 5289554)

Columns that were added to a matrix can now be deleted by moving the mouse pointer to
the column header and clicking the "Delete" icon behind the column name. (See also
"Help", topic area "Use ARIS Connect > Work in the portal > Use the portal > Table", page
"Remove a column of a matrix".)

(Pivotal 5284731)

In Model Viewer, double-clicking an object symbol now opens the corresponding
assignment. (See also "Help", topic area "Use ARIS Connect >Work in the portal > Use the
portal > Model Viewer", page "Open assignment".)

(Pivotal 5283974)

The text wrap functionality now works correctly for all attributes of all objects.
(Pivotal 5278786)

The error message that is displayed when logging in to a Japanese version of ARIS
Connect fails is now correctly displayed in Japanese.
(Pivotal 1296327)

ARIS Server

The performance was improved for the portal and the quick search so that content and
results are now displayed much faster. (See also "Help", topic area "Use ARIS Connect >
Search content”.)
(Pivotal 5290748)

Reports using the report script APl now provide version information much faster.
(Pivotal 5292841)

Assignments are now always displayed correctly in the archive area.

(Pivotal 5274215)

Problems that occurred when using Oracle JDBC drivers newer than version 12.1.0.1 for
the ABS runnable were solved.
(Pivotal 5293255)
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= The "Replace symbol types" report now replaces symbols correctly when the "[All
symbols]" option is selected for the current object symbols.
(Pivotal 5293222)

= Arounding error that occurred when applying the "OutputObject.SetLeftMargin()" and
"GetLeftMargin()" report script APl methods was corrected so that these methods no
longer return wrong values (for example, 12 is no longer returned for a value that is
actually 13).
(Pivotal 5294181)

= The "Database.find(..)" report script APl method now handles wildcards correctly.
(Pivotal 5293159)

= The "SingleSelectElement.getSelectedindex()" report script APl method now returns the
correct index when the index was preset.
(Pivotal 5290796)

= If two carriage returns are inserted between two tables in the design view, only two
instead of four spaces are now returned. (See also "ARIS > Help > Working with ARIS", topic
area "ARIS Configuration and Administration > Create scripts > Create report > With design
view", page "Create report scripts in design view".)
(Pivotal 5289324)

=  When the "Import data in Excel format" report is run, now an automatic layout is
subsequently performed to prevent objects from overlapping.
(Pivotal 5285382)

= Corrections were made to the "XlsSheet.setPicture(...)" report script APl method so that
results are now also output correctly when the XLSX format is used.
(Pivotal 5278180, 5294460)

= The 'Export graphic as PDF' report is now available in multiple languages.
(Pivotal 5297345)

» The ARIS Script help page for the "XlsCell.getCellValue" report script APl method now
correctly states that the return value of the cell is a string.
(Pivotal 5289950)

ARIS BPMN

= Pressing F2 now starts direct editing from a condition expression attribute placed for a
connection.
(Pivotal 5294322)
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* When a task is transformed into a call activity, the system now checks whether a valid
symbol is used for the task. If not, the action is canceled. Thus, the semantic check that is
subsequently run to validate the BPMN diagram no longer returns a symbol-related error.
(Pivotal 5278385)

= |t used to be possible to insert more than one lane into a pool when using drag and drop.
Now, only the first lane is allowed to be inserted via drag and drop. To add an additional
lane to a pool, you have to proceed as follows:

1. Place a lane in the model window.
2. Select both the newly placed lane and the pool to which you want to add the lane.
3. Activate the BPMN tab.

4. Click "Insert lane" (ARIS Connect) or "Pool and lane > Insert lane (ARIS
Architect/Designer)".
(Pivotal 5279298)

= Transforming BPMN object types sometimes resulted in connections no longer being
allowed, for example, after having transformed a function into a manual task. It is now
possible to add required connections via a corresponding filter.
(Pivotal 5276811)

= The ARIS Server setup now allows white spaces in the server installation path.
(Pivotal 5288382)

= ARIS Cloud Controller (ACC) commands now work correctly when the user password
contains an @ character.
(Pivotal 5298229)

= The expiry date is now exported correctly when usage statistics are exported to a CSV file.
The field names of the JSON export now match the column names of the CSV export.
(Pivotal 5293022)

= During LDAP user synchronization, users that were deleted from the configured LDAP
system are now also removed from User Management.
(Pivotal 5287731, 5285602)

ARIS Dashboards
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If the language is changed in the "Repository" view for dashboards, the view is
automatically refreshed and shown in the language selected (ARIS Connect > Repository >
Dashboards & Data feeds).

(Pivotal 5296180)

Dashboards are now filtered even if no dashboard description is available.
(Pivotal 5294453)

ARIS Process Governance

When you jump from an error list of a failed governance process deployment to an
incorrect object, now the relevant model opens and the incorrect object is selected (i.e.,
the selection is no longer removed).

(Pivotal 5292682)

Corrections were made to the configuration file so that queries and analyses now run
efficiently on a local server.
(Pivotal 5291444)

ARIS Publisher

If the "Release" attribute is set, it is now also displayed in Greek.
(Pivotal 5291727)

All layouts - including additional layouts stored in the Publisher layout directory - are now
available in the Export dialog and can be selected to create new Publisher exports.
(Pivotal 5291368)

Transparent flags are now processed as required so that the graphic output of ARIS
diagrams is generated correctly.
(Pivotal 5285501)

ARIS Risk & Compliance Manager

If a questionnaire is generated, the interviewee in charge receives a corresponding
notification.

The monitor job now closes migrated task items properly.

Once the import of an ARCM backup including configured dashboards is complete, the "My
dashboards" button is now immediately available in the "Home" area.
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= Object-specific control managers now can view the data available in assignment lists
("Control -> Control executions" and "Control execution tasks-> Control execution").

= |f you want to assign an existing question to a section, you can now filter the questions in
the assignment list.

= The test manager, tester, and test reviewer now can also view the data available in the
assignment list (Test case -> Surveys and test case -> Questionnaires).

= Performing a backup or restore on a tenant other than the tenant configured for ARCM
now completes without errors.

= |tis nolonger possible to enter negative values for integer parameters in the system
configuration in the "Administration" area.

= The "News" panel in the "Home" area is visible only if news is actually available. Otherwise,
this panel is hidden.

= Now, the correct module is highlighted in the module navigation when the module is
changed starting from a form, for example, when a hierarchy is opened from a risk form.
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When an incorrect system password is entered, a more descriptive message is displayed
now. (Pivotal 5271818)

Access privileges assigned to user groups are now always displayed correctly.
(Pivotal 5286786)

It is now possible to search for language-independent attributes. (Pivotal 5280968)

ARIS Server

Special characters are now used correctly in the backup archive file when a tenant backup
of the "ABS" runnable is created.

The file pg__initdb.log is now stored in the correct folder:
<instDir>\server\bin\work\work__postgres_ {s,m,I}\log

The XLS output format of scheduled reports now allows more than 6553 rows.
(Pivotal 5287402)

Evaluating functions is no longer possible in the debug mode. This is due to the fact that
functions to be evaluated must be carried out when report or macro scripts are being
debugged, which may result in subsequent errors. Such errors can now no longer occur.
(Pivotal 5277648)

The "Type" column of the "Output object information (table)" report is now displayed only
once instead of twice. (Pivotal 5277683)

If ARIS Script Runner is started using an interface language that is not available, now
"English" is automatically used as the interface language. (Pivotal 1279502)

Objects in the "Create structure chart” report are now sorted so that they no longer cause
a cancelation of the report. (Pivotal 5274243)

ARIS BPMN

Transforming BPMN object types sometimes resulted in connections no longer being
allowed, e.g., after having transformed a function into a manual task. It is now possible to
add required connections via a corresponding filter. (Pivotal 5276811)
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= Installation is now possible with all patch levels of SUSE Linux 12. (Pivotal 5287177)

= The database backup function was improved so that special characters now no longer
prevent a backup from being created.

= The "create__user.bat" batch file for importing modeled ARCM users into ARIS
Administration now includes an additional parameter for setting the loadbalancer port.

= The validation of users was removed entirely from ARIS Risk & Compliance Manager and is
now performed only in User Management.

= |f ARIS Help is not available in a specific language, the English version is displayed.

= The layout of the "Risk assessments - Qualitative (risk manager)" Risk Management
evaluation PDF report was corrected.

= |tis now possible to correctly open uploaded documents in ARIS Risk & Compliance
Manager after a migration.

= Using the "Environments" filter in the "Issue-relevant objects" list no longer results in an
empty dialog being displayed.

= |n-memory Sign-off Management locks are now migrated to the database.

= The "Test cases" and "Deficiency statistics" Sign-off Management evaluations for
generated sign-off processes now use the "Calculation” filter as required.

*= If you are accessing one and the same object more than once via different browsers or
tabs and should find that the object is locked for editing, now a message is displayed
providing a link that you can use to request write privileges for the object in the current
browser or tab.

= Risk assessments that were downloaded for offline processing are now displayed to

object-specific risk managers in the list under "Home > My offline objects".

=  The list of test cases for the "Test reviewer" role was renamed from "'Not effective' test
cases (test reviewer)" to "Test cases (test reviewer)".

= |f ARIS Risk & Compliance Manager is used in a multi-node scenario, the "CDF" runnable is
required.

= The PDF and Excel report of the audit evaluation "Evaluations > Audit Management > Audit
status (Audit steps)” no longer displays numbers, but the green check marks that are also

used in ARIS Risk & Compliance Manager.

= An audit step template can now be saved only if all mandatory fields were filled in, even if
the status of the audit is not yet set to "Released".
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= The XML import now excludes assigned functions for which symbol types are used that

ARIS Risk & Compliance Manager does not support.

ARIS Mobile API

= ARIS Mobile API now correctly returns the actual values for combo boxes instead of
returning numbers. (Pivotal 5274702)
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= Toincrease ARIS security, the TLS 1.0 protocol was deactivated in the course of
development.
As a consequence, editing the Documentation attribute is no longer possible because
this attribute is based on the WebDAV protocol. If a user now attempts to edit this
attribute, a message is displayed indicating that TLS 1.0 needs to be activated.
(Pivotal 5268771, 5269774)

= The Explorer tree no longer collapses when the Object properties dialog is closed by
clicking OK. (Pivotal 5269300)

= The user guest is no longer able to perform operations for which the user role guest has
no privileges. (Pivotal 1132963)

= When a user opens a model after Collaboration was deactivated by the Administrator, and
then switches between the document and task section, the message indicating that
Collaboration is inactive is no longer displayed repeatedly in the Collaboration widget.
(Pivotal 5259015)

= |tis now possible to identify a markup property that was added via SSC. (Pivotal 5266479)
= SCC now provides the buttons Up and Down for changing the order of properties
displayed in fact sheets. (Pivotal 5266482)

= |f no configuration is available for sorting, a new fallback configuration is automatically
generated. It provides default sorting for all item types based on the Name attribute, and
flow sorting for functions and events in process item types used for the Steps view.
(Pivotal 5261862)

* Role selection on the server now works as required. (Pivotal 5263161)

= A published database that was deleted is now no longer displayed in ARIS Connect.
(Pivotal 5260581)

= When using the roleBasedltem component, ensure that the configuration includes all
references required to identify the user role. Details are available as comments in the file
instances/roleBasedltem/roleBaseditem_ default.xml in the classic and default
configuration sets. (Pivotal 5258309)

= A correction was made due to which events are now sorted alphabetically. Based on this,
the Steps view is now displayed correctly. (Pivotal 5271558)
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ARIS Server

It was possible to create a database using a name that already existed if there was a
difference in the use of upper and lower case letters. This issue was fixed.
(Pivotal 5273034)

The setSelectedFile method of the report script APl had no effect when the report was
run in ARIS Connect. This error was fixed. (Pivotal 5267068)

Changing a connection assignment in Visio mapping no longer changes the Visio shape
name to the ARIS symbol name. (Pivotal 1133534)

If a server is constantly polled in an open report panel, this now leads to a session timeout.
(Pivotal 5262683)

Applying the drawing function to a model graphic, e.g., FrameRect of the Picture object,
no longer turns the background of the model graphic into black. (Pivotal 5263046)

The report RA(S)CI - Output organizational participations in processes is now
available in XLS format in ARIS Connect. (Pivotal 5261594)

A correction was made to the report script APl method Dialog.setDIgPicture ( String
sDlgltem, byte[] imagedata, int Type ) so that a number is no longer displayed next to an
image. (Pivotal 5254294)

Based on a correction that was made regarding the report script API, using a new Rhino
Engine no longer prevents the cancelation of reports whose execution takes place in a
subfunction of the report. (Pivotal 5254342)

Pressing ESC to close a help topic no longer opens the report script help. (Pivotal
5254791)

When the language in ARIS Connect is changed from English to another language, the
names of available reports are now displayed. (Pivotal 5254808)

A correction was made to the report/macro script API so that it is now possible to
navigate back to the code editor when debugging the macro while using the openMatrix
method with visible set to false. (Pivotal 5252643)

A correction was made to the report script APl method
<>.dialog.getDialogElement("PICTURENAME") so that this method no longer returns an
undefined result. Furthermore, methods were added that can be used to place images in
dialogs. (Pivotal 5252342)

The performance regarding the procedure of assigning and applying templates to models
via reports was improved by more than 50%. (Pivotal 5250240)
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When using the report script API to generate URIs and output Excel documents, it is now
possible to access an Excel document via the corresponding link. (Pivotal 1127878)

Based on the switch to a newer external library version, links created in a document via
ARIS Report now work correctly when PDF is used as the format. (Pivotal 5239084)

ARIS BPMN

A correction was made regarding BPMN 2.0 models so that users with read-only privileges
for an object are no longer able to modify the appearance of an object. (Pivotal 5265416)

In BPMN 2.0 models, the Symbols bar no longer shows symbols that are not allowed so
that it is no longer possible for a user to create connections or objects that are actually
not allowed by the filter in use. (Pivotal 5262503)

If a filter uses only BPMN symbols that were derived, ARIS Designer no longer shows the
name of the symbol from which a user-defined symbol was derived, but the name of the
symbol derived. (Pivotal 5271549)

It is now possible to run a BPMN export for models containing grouped ARIS objects.
(Pivotal 1132067)

Links that are displayed in the portal on the Documents tab for models and that refer to
documents in ARIS document storage, are now displayed in both the language selected
for the portal and the alternative language. (Pivotal 5257886)

The description of the ARIS Process Governance data flow design was updated in the file
'Data Flow Design.pdf'. (Pivotal 5266864)

The order of documents in the table control of ARIS Process Governance dialogs is now
alphabetical. (Pivotal 5267165)

The performance regarding variable editing was increased in such way that editing a high
number of variables is much faster now. (Pivotal 5248510)

In ARIS Process Governance, the contrast was increased for scroll bars displayed in
dialogs, especially for the use of Microsoft Internet Explorer. (Pivotal 5248988)

A correction was made to a macro so that the values returned by the ADateTextField
control are now correct. (Pivotal 5249123)
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*= In the Properties dialog, using the CTRL + Up and CTRL + Down arrow keys to move the
properties of a UML2 class up or down now works as required. (Pivotal 5269243)

= The User Management report APl method getExpirationDate() does no longer throw a
Java NullPointerException if a license does not have an expiration date. (Pivotal 5268420)

= |tis now possible to store the synchronization log file in ARIS Architect Administration if
the file extension txt is available in ARIS Connect under ARIS Administration > ARIS
document storage > Quota and restrictions > Valid file extensions. (Pivotal 1133477)

= In SAP®© Solution Manager, links to models in ARIS Connect are now deleted correctly
during data transfer from ARIS to SAP®© Solution Manager. (Pivotal 5262556)
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ARIS products are intended and developed for use by persons. Automated processes, such as
the generation of content and the import of objects/artifacts via interfaces, can lead to an
outsized amount of data, and their execution may exceed processing capacities and physical
limits. For example, processing capacities are exceeded if models and diagrams transcend the
size of the modeling area or an extremely high number of processing operations is started
simultaneously. Physical limits may be exceeded if the memory available is not sufficient for
the execution of operations or the storage of data.

Proper operation of ARIS products requires the availability of a reliable and fast network
connection. Networks with insufficient response time will reduce system performance and
may cause timeouts.

If ARIS products are used in a virtual environment, sufficient resources must be available
there in order to avoid the risk of overbooking.

The system was tested using scenarios that included 100,000 groups (folders), 100,000
users, and 1,000,000 modeling artifacts. It supports a modeling area of 25 square meters.

If projects or repositories are larger than the maximum size allowed, a powerful functionality
is available to break them down into smaller, more manageable parts.

Some restrictions may apply when working with process administration, ARIS Administration
ARIS document storage, and ARIS Process Board, and when generating executable processes.
Process Governance has been tested and approved for 1000 parallel process instances.
However, the number may vary depending on process complexity, for example, if custom
reports are integrated.

Versioning: Length of a changelist description is limited to 1000 chars.
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The information provided describes the settings and features as they were at the time of
publishing. Since documentation and software are subject to different production cycles, the
description of settings and features may differ from actual settings and features. Information
about discrepancies is provided in the Release Notes that accompany the product. Please
read the Release Notes and take the information into account when installing, setting up, and
using the product.

If you want to install technical and/or business system functions without Software AG's
consulting services, you require extensive knowledge of the system to be installed, its
intended purpose, the target systems, and their various dependencies. Due to the number of
platforms and interdependent hardware and software configurations, we can only describe
specific installations. It is not possible to document all settings and dependencies.

When you combine various technologies, please observe the manufacturers' instructions,
particularly announcements concerning releases on their Internet pages. We cannot
guarantee proper functioning and installation of approved third-party systems and do not
support them. Always follow the instructions provided in the installation manuals of the
relevant manufacturers. If you experience difficulties, please contact the relevant
manufacturer.

If you need help installing third-party systems, contact your local Software AG sales
organization. Please note that this type of manufacturer-specific or customer-specific
customization is not covered by the standard Software AG software maintenance agreement
and can be performed only on special request and agreement.

If a description refers to a specific ARIS product, the product is named. If this is not the case,
names for ARIS products are used as follows:

Name Includes

ARIS products Refers to all products to which the license
regulations of Software AG standard
software apply.

ARIS Clients Refers to all programs that access shared
databases via ARIS Server.
ARIS Download clients ARIS Download clients Refers to ARIS clients

that can be accessed using a browser.
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Software AG products provide functionality with respect to processing of personal data
according to the EU General Data Protection Regulation (GDPR). Where applicable, appropriate
steps are documented in the respective administration documentation.
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The information provided describes the settings and features as they were at the time of
publishing. Since documentation and software are subject to different production cycles, the
description of settings and features may differ from actual settings and features. Information
about discrepancies is provided in the Release Notes that accompany the product. Please
read the Release Notes and take the information into account when installing, setting up, and
using the product.

If you want to install technical and/or business system functions without using the
consulting services provided by Software AG, you require extensive knowledge of the system
to be installed, its intended purpose, the target systems, and their various dependencies. Due
to the number of platforms and interdependent hardware and software configurations, we
can describe only specific installations. It is not possible to document all settings and
dependencies.

When you combine various technologies, please observe the manufacturers' instructions,
particularly announcements concerning releases on their Internet pages. We cannot
guarantee proper functioning and installation of approved third-party systems and do not
support them. Always follow the instructions provided in the installation manuals of the
relevant manufacturers. If you experience difficulties, please contact the relevant
manufacturer.

If you need help installing third-party systems, contact your local Software AG sales
organization. Please note that this type of manufacturer-specific or customer-specific
customization is not covered by the standard Software AG software maintenance agreement
and can be performed only on special request and agreement.

If you have any questions on specific installations that you cannot perform yourself, contact
your local Software AG sales organization
(https://www.softwareag.com/corporate/company/global/offices/default.html). To get
detailed information and support, use our websites.

If you have a valid support contract, you can contact Global Support ARIS at: +800
ARISHELP. If this number is not supported by your telephone provider, please refer to our
Global Support Contact Directory.
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Find information, expert articles, issue resolution, videos, and communication with other ARIS
users. If you do not yet have an account, register at ARIS Community.

Software AG Empower Portal

You can find documentation on the Software AG Documentation website
(https://empower.softwareag.com/). The site requires credentials for Software AG's Product
Support site Empower. If you do not yet have an account for Empower, send an e-mail to
empower@softwareag.com (mailto:empower@softwareag.com) with your name, company,
and company e-mail address and request an account.

If you have no account, you can use many links on the TECHcommunity website. For any
questions, you can find a local or toll-free number for your country in our Global Support
Contact Directory and give us a call.

TECHcommunity

On the TECHcommunity website, you can find documentation and other technical
information:

= Use the online discussion forums, moderated by Software AG professionals, to ask
questions, discuss best practices, and learn how other customers are using Software AG
technology.

= Access articles, code samples, demos, and tutorials.
»= Find links to external websites that discuss open standards and web technology.

= Access product documentation, if you have TECHcommunity credentials. If you do not,
you will need to register and specify Documentation as an area of interest.

If you have an account for Empower, use the following sites to find detailed information or
get support:

= You can find product information on the Software AG Empower Product Support website.

= To get information about fixes and to read early warnings, technical papers, and
knowledge base articles, go to the Knowledge Center.

= Once you have an account, you can open Support Incidents online via the eService section

of Empower.

= To submit feature/enhancement requests, get information about product availability, and
download products, go to Products.
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Software AG Managed Learnings

Get more information and trainings to learn from your laptop computer, tablet or smartphone.
Get the knowledge you need to succeed and make each and every project a success with
expert training from Software AG.

If you do not have an account, register as a customer or as a partner.
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