Der Fehler wird während der SAP®-Synchronisation gemeldet. Beim Prüfen der Konsistenzregeln ist ein Konflikt aufgetreten.
Fehlermeldung
Der Prozessschritt <Name der SAP-Funktion> stimmt nicht mit den Konsistenzregeln überein. Der entsprechende ursprüngliche Prozessschritt fehlt im SAP-System.
Ursache
Das ursprüngliche Element, auf das in ARIS referenziert wird, ist im SAP-Branch nicht mehr vorhanden.
Wenn Elemente, die von einer Bibliothek abgeleitet sind, in SAP Solution Manager angelegt werden, wie z. B. Prozessschritte oder Schnittstellen, muss für diese ein bestehender ursprünglicher Prozessschritt oder eine ursprüngliche Schnittstelle existieren.
- Bei Geschäftsprozessschritten wird das Original in ARIS von einer Master-Varianten-Beziehung zugeordnet. Prüfen Sie, ob der Master des Geschäftsprozessschritts immer noch im SAP-Branch existiert. Markieren Sie dazu das Master-Objekt und klicken Sie in der Funktionsleiste SAP® Solutions auf
Inhalt anzeigen > Blueprint anzeigen.
- Bei Schnittstellen wird die ursprüngliche Schnittstelle in SAP vom Attribut SAP-ID bestimmt, das für das zugehörige Class-Objekt gepflegt ist. Prüfen Sie, ob eine zugehörige Schnittstelle immer noch in der Interface Library vorhanden ist.
Lösung
- Löschen Sie bei einem Geschäftsprozessschritt den Master, oder zumindest die Masterbeziehung und ordnen Sie ein bestehendes Element aus der PSL in ARIS zu.
- Bei Schnittstellen löschen Sie die Schnittstelle in ARIS.