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About this documentation
This document describes how to use the Apama Dashboard Viewer.

The Dashboard Viewer is the runtime viewer for local deployments of Apama dashboards. It
provides the ability to view and interact with dashboards that are receiving live data from an
Apama Dashboard Server. Dashboard Servers serve dashboards for applications running in Apama
correlators.

This book assumes that you have already installed Apama.

Preface

How this book is organized
The information in this book is organized as follows:

"Concepts" on page 8 introduces the concepts underlying Dashboards and their runtime
usage.

"Using the Dashboard Viewer" on page 12 describes how to use the various objects included
in a Dashboard Viewer.

"Startup Options" on page 21 provides advanced information on starting Dashboard
Viewers.

"Timezone ID Values" on page 26 lists the timezone ID values used when manually starting
the Dashboard Viewer as described in "Startup Options" on page 21.

Preface

Documentation roadmap
On Windows platforms, the specific set of documentation provided with Apama depends on
whether you choose the Developer, Server, or User installation option. On UNIX platforms, only the
Server option is available.

Apama provides documentation in three formats:
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HTML viewable in a Web browser

PDF

Eclipse Help (if you select the Apama Developer installation option)

On Windows, to access the documentation, select Start > All Programs > Software AG > Apama 5.2 >
Apama Documentation . On UNIX, display the index.html file, which is in the doc directory of your
Apama installation directory.

The following table describes the PDF documents that are available when you install the Apama
Developer option. A subset of these documents is provided with the Server and User options.

Title Contents

What’s New in Apama Describes new features and changes since the previous release.

Installing Apama Instructions for installing the Developer, Server, or User
Apama installation options.

Introduction to Apama Introduction to developing Apama applications, discussions of
Apama architecture and concepts, and pointers to sources of
information outside the documentation set.

Using Apama Studio Instructions for using Apama Studio to create and test Apama
projects; write, profile, and debug EPL programs; write JMon
programs; develop custom blocks; and store, retrieve and
playback data.

Developing Apama
Applications in Event
Modeler

Instructions for using Apama Studio’s Event Modeler editor
to develop scenarios. Includes information about using
standard functions, standard blocks, and blocks generated
from scenarios.

Developing Apama
Applications in EPL

Introduces Apama’s Event Processing Language (EPL) and
provides user guide type information for how to write EPL
programs. EPL is the native interface to the correlator. This
document also provides information for using the standard
correlator plug-ins.

Apama EPL Reference Reference information for EPL: lexical elements, syntax, types,
variables, event definitions, expressions, statements.

Developing Apama
Applications in Java

Introduces the Apama in-process API for Java, referred to
as JMon, and provides user guide type information for how
to write Java programs that run on the correlator. Reference
information in Javadoc format is also available.

Building Dashboards Describes how to create dashboards, which are the end-user
interfaces to running scenario instances and data view items.

Dashboard Property
Reference

Reference information on the properties of the visualization
objects that you can include in your dashboards.
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Title Contents

Dashboard Function
Reference

Reference information on dashboard functions, which allow
you to operate on correlator data before you attach it to
visualization objects.

Developing Adapters Describes how to create adapters, which are components that
translate events from non-Apama format to Apama format.

Developing Clients Describes how to develop C, C++, Java, or .NET clients that can
communicate with and interact with the correlator.

Writing Correlator Plug-ins Describes how to develop formatted libraries of C, C++ or Java
functions that can be called from EPL.

Deploying and Managing
Apama Applications

Describes how to:

Use the Management & Monitoring console to configure,
start, stop, and monitor the correlator and adapters across
multiple hosts.

Deploy dashboards over wide area networks, including
the internet, and provide dashboards with effective
authorization and authentication.

Improve Apama application performance by using multiple
correlators, and saving and reusing a snapshot of a
correlator’s state.

Use the Apama ADBC adapter to store and retrieve data in
JDBC, ODBC, and Apama Sim databases.

Use the Apama Web Services Client adapter to invoke Web
Services.

Use correlator-integrated messaging for JMS to reliably send
and receive JMS messages in Apama applications.

Use Universal Messaging to connect correlators.

Using the Dashboard Viewer Describes how to view and interact with dashboards that are
receiving run-time data from the correlator.

Preface

Contacting customer support
You may open Apama Support Incidents online via the eService section of Empower at http://
empower.softwareag.com. If you are new to Empower, send an email to empower@softwareag.com with
your name, company, and company email address to request an account.

If you have any questions, you can find a local or toll-free number for your country in our Global
Support Directory at https://empower.softwareag.com/public_directory.asp and give us a call.

https://empower.softwareag.com/eservice
https://empower.softwareag.com/eservice
https://empower.softwareag.com/public_directory.asp
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This guide assumes that you have already installed the Dashboard Viewer. This chapter introduces
the concepts underlying dashboards and their runtime use. "Using the Dashboard Viewer" on
page 12 describes how to use the various visualization objects that are included in dashboards.
"Startup Options" on page 21 provides advanced information on starting the Dashboard Viewer.

About Dashboards
Dashboards provide the ability to view and interact with applications running in a correlator.
Dashboards contain charts and other objects that allow you to visualize the status, performance,
and attributes of Apama applications including any scenarios and DataViews. Dashboards can also
contain control objects for creating, editing, and deleting scenario instances, as well as for sending
events to a correlator.

Dashboard displays are stored in .rtv files. A dashboard project includes .rtv, image, and audio files.
A dashboard project is deployed in a single directory with one or more subdirectories containing the
files of the project. To use a dashboard, the Dashboard Viewer must have access to all the files in the
associated dashboard-project directory.

Deployed dashboards connect to a dashboard Data Server, which in turn connects to one or more
correlators. The dashboard Data Server is the middle-tier between users and the correlator. It
provides for both scalability and security. As the scenarios or DataViews in a correlator run, and
their variables or fields change, update events are sent to dashboard Data Servers, which in turn
send the data to all connected dashboards. When a dashboard receives an update event, it updates
its display in real time to show the behavior of the application. User interactions with the dashboard,
such as creating an instance of a scenario, result in control events being sent via the Data Server to
the correlator.

The following diagram illustrates the runtime deployment of dashboards:
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Figure 1. Runtime deployment of dashboards

Concepts

Starting the Dashboard Viewer
The simplest way to start the Dashboard Viewer is from the Windows Start menu. Select All Programs
> Software AG > Apama 5.2 > Dashboard Viewer .

(This assumes that you have an Apama user installation. If you have a development installation,
select All Programs > Software AG > Apama 5.2 > Development > Dashboard Viewer .)

When you start the Viewer, the Data Server login prompt is displayed:
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Figure 2. Data Server Login prompt

By default, you can log in with any user name and password, but your user name must match
the owner of any scenario instances or DataView items that you want to view. Your dashboard
administrator might have implemented a non-default authentication and authorization scheme.

The recommended deployment for the Dashboard Viewer is through a dashboard Data Server. The
Connect directly to correlator checkbox allows you to connect directly to a correlator without the use of
a Data Server. This is not recommended for live deployments, as it is not secure and not as scalable as
connections via the Data Server.

If all attachments and commands use named Data Servers, you can check the Only using named data
server connections check box and omit specification of a default server.

The Dashboard Viewer can also be started by running dashboard_viewer.exe, located in the Apama
bin directory. This method of starting the Viewer is useful when passing start-up options on the
command line. The start-up options supported by Dashboard Viewer are detailed in "Startup
Options" on page 21.

Concepts

Scenario instance and DataView item ownership
Scenario instances and DataView items in a correlator include an attribute identifying the owner of
the instance. When a scenario instance is created through Dashboard Builder, it provides the current
user ID as the owner of the instance.

When viewing scenario instances or DataView items in Dashboard Builder, you are by default only
allowed to see and operate on those instances or items that you own; that is, by default the current
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user ID must match the owner attribute of the instance or item. Your dashboard administrator might
have implemented a non-default authorization scheme.

Concepts
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"Concepts" on page 8 introduces the important concepts underlying the Dashboard Viewer, and
describes how to start the Viewer. This chapter illustrates how to use the Dashboard Viewer.

This is the layout of the Dashboard Viewer when you first start it.

Figure 3. Dashboard Viewer when first started

By default, no dashboard is displayed. This chapter describes how to open and work with
dashboards.
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Opening and viewing dashboards
The Dashboard Viewer main window can open and display one dashboard at a time.

To open a dashboard, select File > Open from the Viewer menu and select the .rtv file you want to
open.

Using the Dashboard Viewer

Running the Statistical Arbitrage demo
The examples in this chapter use the Statistical Arbitrage demonstration dashboard, which is
included in an Apama development installation. Although it is not necessary to run the Statistical
Arbitrage demonstration, you may find it useful to do so.

If you have a development installation, you can run the Statistical Arbitrage demonstration as
follows:

1. From the Start menu, select All Programs > Software AG > Apama 5.2 > Apama Studio .

2. Click on Samples in the Apama Studio Welcome page.

3. Click on Apama Samples in the Apama Studio Samples page.

4. Select the Statistical Arbitrage sample.

5. Click the Open button.

6. Click the play button in the Launch Control Panel.

Once you have launched the Statistical Arbitrage demonstration, a Statistical Arbitrage dashboard
appears automatically (the dashboard to display was passed by Apama Studio when the
demonstration was launched):
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Figure 4. Statistical Arbitrage demonstration dashboard

Opening and viewing dashboards

Displaying additional dashboards
A dashboard project can consist of more than one dashboard. In many cases, each dashboard is
displayed one at a time, in the Dashboard Viewer main window. In other cases, separate windows
are created to display additional dashboards.

Displaying dashboards in separate windows is common for dashboards that are used to create
or edit scenario instances. For example, to see the separate dashboard used to create scenario
instances in the Statistical Arbitrage demonstration, click the Create button in the Statistical Arbitrage
dashboard. This displays a separate dashboard in a new window.
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Any dashboard can be designed to display other dashboards in separate windows. The dashboards
may even be nested; for example, the Create window in the Statistical Arbitrage sample could itself
have been designed to display additional windows. Window usage is specified when the dashboard
project is created in the Dashboard Builder.

Opening and viewing dashboards

Creating scenario instances visualized by the Statistical
Arbitrage main dashboard
The Create dashboard in the Statistical Arbitrage dashboard project is subordinate to the main
dashboard; it is intended to be accessed only from the main dashboard. Although it is possible
to open the Create dashboard directly in Dashboard Viewer main window, you should not do so.
Subordinate dashboards are typically dependent on context created by the parent dashboard and
should only be accessed as intended by the creator of the dashboard project.

Follow these steps to create scenario instances that are visualized by the Statistical Arbitrage
main dashboard:

1. Accept the defaults and click the Create button in the Create dashboard.

2. Click the Create button in the main dashboard again.
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3. Enter MSFT in the Instrument1 field and ORCL in the instrument2 field.

4. Click on a row of the Summary of All Strategies table in the main dashboard.

The data used for charting is stored in the Dashboard Viewer. As the Viewer runs, it accumulates
historical data for display in charts. If you exit and restart the Dashboard Viewer, previously
displayed historical data is not available.

Opening and viewing dashboards

The Dashboard Viewer menubar
There are four menus on the menu bar. Each has a number of nested menu options.

Table 1. Dashboard Viewer menubar

Menu > Command Description

File All operations related to opening, printing, and closing dashboards

File > Open Open a dashboard.

File > Print Print the contents of a dashboard.
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Menu > Command Description

File > Exit Exit the Dashboard Viewer.

View All operations that manipulate the dashboard view.

View > Zoom In Zoom in on a location in the dashboard. This switches the pointer to

zoom mode, as indicated by the pointer changing to a crosshair . In
this mode, you can click on an area of the dashboard to zoom in on it
and display it in greater detail. Right click to exit zoom mode.

View > Zoom Out Zoom out on a location in the dashboard. This switches the pointer to

zoom mode, as indicated by the pointer changing to a crosshair . In
this mode you can click on an area of the dashboard to zoom out on it
and display it in less detail. Right click to exit zoom mode.

View > Zoom Rect Zoom in on an area of the dashboard. This switches the pointer to

zoom mode, as indicated by the pointer changing to a crosshair . In
this mode you can click and drag to select an area of the dashboard to
zoom in on. Right click to exit zoom mode.

View > Pan Pan the dashboard to show areas not currently displayed. This
switches the pointer to pan mode, as indicated by the pointer

changing to the pan pointer . In this mode you can click and drag
the dashboard to reveal areas not displayed. Right click to exit pan
mode. It is not possible to pan if 100% of the dashboard view is visible.

View > 100% Make the entire dashboard visible.

Tools Change preferences

Tools> Pause Display Pause the automatic updating of the dashboard. When not paused
the dashboard automatically updates as data changes; when paused,
updating does not occur. When paused, clicking on the dashboard will
cause it to update.

Help > Help Contents Displays the Apama documentation for your installation.

Help > Command Line
Options

Displays a list of the Viewer options that you can supply at the
command line.

Help > About Displays information about this version of the Dashboard Viewer.

Using the Dashboard Viewer

Resizing the Dashboard Viewer
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When a dashboard is created in the Dashboard Builder, the Builder specifies a width and height
for the dashboard. You can resize Dashboard Viewer windows, but the aspect ratio of width to
height cannot be altered. If you resize a window to a different aspect ratio, the window size will
automatically be adjusted in order to maintain the aspect ratio specified in the Builder.

When you resize a Dashboard Viewer window, the objects within it are scaled in order to maintain
their size relative to the size of the window. Scaling allows dashboards to be enlarged in order to
allow greater detail to be displayed, or reduced so that the dashboard occupies a smaller area of the
screen.

When a dashboard Window is reduced in size, objects such as charts will scale all their visual
elements in order to maintain proper appearance at the new size. Other objects, such as tables and
input controls, adjust their width and height but may not scale all their visual elements, such as fonts
in table column headers.

Using the Dashboard Viewer

Working with Dashboard Objects
Many of the objects displayed in a dashboard are familiar user interface controls. Their operations
will not be covered in this guide. The following sections briefly introduce some of the objects that
may not be familiar and that are used for the visualization of complex data.

Using the Dashboard Viewer

Trend charts
Trend charts provide the ability to view the performance of one or more scenario instances or
DataViews items over time.

Figure 5. Trend chart

If enabled in the Dashboard Builder, trend charts support the ability to zoom in on an area of the
chart. To zoom in on an area of a trend chart, click on the chart and drag the pointer to draw a box
around the area to be zoomed.
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Figure 6. Zooming in a trend chart area

To zoom out of a chart, hold down the Shift key while clicking on the chart.

If enabled in the Dashboard Builder, trend charts support scrolling to view historical values outside
the scope of what fits in the trend chart window. Use the horizontal scroll bar to view older values.

The number of values stored in historical data is limited. The limit is defined in the OPTIONS.ini file
and can be overridden at startup by specifying options as detailed in "Startup Options" on page
21.

When the maximum number of values is reached, the Dashboard Viewer begins to remove the
oldest values in order to make room for the newest values. When the maximum number of values is
reached, you see the oldest values being removed from the end of the trend chart.

Working with Dashboard Objects

Stock charts
Stock charts provide the ability to view open, high, low, and close values, at a specified time interval,
for a variable of a scenario instance or field of a DataView item. Stock charts support the same
zooming, scrolling, and maximum-number-of-values behavior as trend charts.

Figure 7. Stock chart

Working with Dashboard Objects

Tables
Tables provide the ability to view variable or field values for multiple scenario instances or DataView
items. They are often used for summary displays of scenario instances or DataView items.
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Figure 8. Table

Dashboard tables support many common table operations, such as sorting, column resizing, and
column ordering. If enabled in the Builder, a table may also support drilldown to display detailed
information about a scenario instance or DataView item. To drilldown on an instance or item that is
displayed in a table, click on it.

Working with Dashboard Objects

Pie and Bar charts
Pie and Bar charts are typically used to display summary information about one or more scenario
instances.

If enabled in the Builder, a pie or bar chart may also support drilldown to display detailed
information about a scenario instance. To drill down on an instance or item that is displayed in a pie
or bar chart, click on it.

Working with Dashboard Objects
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The Dashboard Viewer supports options that can be specified on the start-up command line to
override the default values used by the Viewer. This section documents these options.

Synopsis
The executable for the Dashboard Viewer is dashboard_viewer.exe, which can be found in the bin
directory of your Apama installation. It has the following syntax:
dashboard_viewer.exe [.rtv-file-path] [options]

Startup Options

Command line options
Following are the command line options for this executable:

Table 2. Dashboard Viewer command line options

Command Description

-C | --panelConfig file Specifies the panels-initialization file to use for displaying this
dashboard. file is the full pathname of the .ini file.

-c | --correlator logical-
name:host:port:bool

Sets the correlator host and port for a specified logical correlator
name. bool is one of true and false, and specifies whether to use
the raw channel for communication. This overrides the host,
port, and raw-channel setting specified by the Dashboard builder
for the given correlator logical name—see Changing Correlator
Definitions for Deployment in the Preparing Dashboards for
Deployment chapter of the Dashboard Builder guide. You can
specify connection details for multiple correlators by using the
option multiple times in a single command. Here is an example:
-c default:localhost:15903:false –c work1:somehost:19999:true

These options set the host and port for the logical names default
and work1.

-D | --nodirect Suppress check box in login dialog that allows direct connection
to correlator.

-d | --direct Connect directly to correlator.
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-E | --purgeOnEditbool Specifies whether to purge all trend data when a scenario
instance is edited. bool is one of true and false. If this option is not
specified, all trend data is purged when an instance is edited. In
most cases this is the desired mode of operation.

-f | --logfile file Full pathname of the file in which to record logging. If this option
is not specified, the options in the log4j properties file will be
used.

-G | --trendConfigFile file Trend configuration file for controlling trend-data caching.

-h | --help Emit usage information and then exit.

-I | --xmlRedirect Redirect XML sources through Data Server.

-J | --jaasFile file Full pathname of the JAAS initialization file to be used by the
Data Server. If not specified, the Data Server uses the file JAAS.ini
in the lib directory of your Apama installation.

-j | --singleClick Single click for drill down and actions.

-k | --doubleClick Double click for drill down and actions.

-L | --xmlSource file XML data source file. If file contains static data, append :0 to the
file name. This signals Apama to read the file only once.

-m | --connectMode mode Correlator-connect mode. mode is one of always and asNeeded. If
always is specified all correlators are connected to at startup. If
asNeeded is specified, correlators are connected as needed. If this
option is not specified, the Data Server connects to correlators as
needed

When --connectMode always is specified trend data starts collecting
upon correlator connection. When --connectMode asNeeded is in
effect trend data starts collecting after you select an attachment to
the trend table in the dashboard viewer.

-N | --name name Set the component name for identification in the correlator. The
default name is Dashboard Viewer: username.

--namedServer logical-
name:host:port

Sets the host and port for a specified logical Data Server name.
This overrides the host and port specified by the dashboard
builder for the given server logical name. This option can occur
multiple times in a single command.

-n | --noSplash Do not display splash screen in startup.

--noMenus Do not display menu bar.

-O | --optionsFile file Use the specified OPTIONS.ini file at startup.
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-P | --maxPrecision n Maximum number of decimal places to use in numerical values
displayed by dashboards. Specify values between 0 and 10, or -1
to disable truncation of decimal places. A typical value for n is
2 or 4, which eliminates long floating point values (for example,
2.2584435234). Truncation is disabled by default.

-q | --sql options Configures SQL Data Source access. options has the following
form:
[retry:ms | fail:n | db:name | noinfo | nopererr | quote]

retry: Specify the interval (in milliseconds) to retry connecting to
a database after an attempt to connect fails. Default is -1, which
disables this feature.fail: Specify the number of consecutive
failed SQL queries after which to close this database connection
and attempt to reconnect. Default is -1, which disables this
feature.db: Name of SQL database. Only databases using ODBC
drivers can be added on the command linenoinfo: Query database
for available tables and columns in your database. If a Database
Repository file is found, it is used to populate drop down menus
in the Attach to SQL Data dialog.nopererr: SQL errors with the
word permission in them will not be printed to the console. This is
helpful if you have selected the Use Client Credentials option for a
database. In this case, if your login does not allow access for some
data in their display, you will not see any errors.quote: Encloses
all table and column names specified in the Attach to SQL Data
dialog in quotes when an SQL query is run. This is useful when
attaching to databases that support quoted case-sensitive table
and column names. Note: If a case-sensitive table or column name
is used in the Filter field, or you are entering an advanced query in
the SQL Query field, they must be entered in quotes, even if the -
sqlquote option is specified.

-R | --purgeOnRemove bool Specifies whether to purge all scenario or DataView data when
an instance or item is removed. bool is one of true and false. If this
option is not specified, all scenario or DataView data is purged
when an instance or item is removed.

-S | --sub variable:value Specifies a value to substitute for a given dashboard variable. This
can be used to parameterize a dashboard at startup. This option
can occur multiple times in a single command. For example:
-S $foo:hello -S $bar:can't -S $tom:"my oh my" -S $jerry:"\"yikes\""

If the value contains a space, enclose the value in double quotes.
If the value contains a double quote, you must escape it by using
a backslash character, \.

-s | --dashboardServer
host:port[:modifiable]

Specifies the Data Server host and port that will appear as the
defaults in the Data Server Login dialog. The host and port fields of
the dialog will be modifiable only if you specify modifiable. If you
do not specify modifiable, the host and port fields will be greyed
out.If you use the -s option, the Connect directly to correlator check



Command line options

Using the Dashboard Viewer   5.2.0 24

box will not appear in the Data Server Login dialog. The -s option
overrides the -d option.

-T | --maxTrend depth Maximum depth for trend data, that is, the maximum number of
events in trend tables. If this option is not specified, the maximum
trend depth is 1000. Note that the higher you set this value, the
more memory the Data Server requires, and the more time it
requires in order to display trend and stock charts.

-t | --title value Text for the title bar of the Dashboard Viewer main window.

-u | --updateRate rate Data update rate in milliseconds. This is the rate at which the
Data Server pushes new data to deployed dashboards in order
to inform them of new events received from the correlator. rate
should be no lower than 250. If the Dashboard Viewer is utilizing
too much CPU you can lower the update rate by specifying a
higher value.If this option is not specified, an update rate of 500
milliseconds is used.

-V | --version Emit program name and version number and then exit.

-v | --loglevel level Logging verbosity. level is one of FATAL, ERROR, WARN, INFO, DEBUG,
and TRACE. If this option is not specified, the options in the log4j
properties file will be used.

-w | --disconnectWarning
bool

By default, the Dashboard Viewer will display a warning dialog
when the connection to a correlator is lost. Specify false to disable
the display of this dialog.

-X | --extensionFile file Full pathname of the JAAS initialization file to be used by
the Data Server. If not specified, the Data Server uses the file
EXTENSIONS.ini in the lib directory of your Apama installation.

-x | --queryIndex 
  table-name:key-list Add an index for the specified SQL-based instance table with the

specified compound key. table-name is the name of a scenario or
DataView. key-list is a comma-separated list of varaible names
or field names. If the specified scenario or DataView exists in
multiple correlators that are connected to the dashboard server,
the index is added to each corresponding data table.Example:
--queryIndex CrossOver:Instrument,Price

You can only add one index per table, but you can specify this
option multiple times in a single command line in order to index
multiple tables.Use this option only when you connect Viewer
directly to a correlator.

-Y | --enhancedQuery
Make SQL-based instance tables available as data tables
for visualization attachments. See Attaching Dashboards to
Correlator Data in Building Dashboards.Use this option only when
you connect Viewer directly to a correlator.



Command line options

Using the Dashboard Viewer   5.2.0 25

-z | --timezone zone Default time zone for interpreting and displaying dates. zone
is either a Java timezone ID or a custom ID such as GMT-8:00. 
Unrecognized IDs are treated as GMT.  See Appendix A of the
Dashboard Viewer guide for the complete listing of permissible
values for zone.

Startup Options
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Chapter 4: Timezone ID Values

The following table lists the timezone ID values used when manually starting the Dashboard Viewer
as described in "Startup Options" on page 21.

Table 3. Timezone ID values

 December 9, 2010 9:40
amtc/GMT+12  Etc/GMT
+11  MIT  Pacific/Apia
 Pacific/Midway  Pacific/
Niue  Pacific/Pago_Pago
 Pacific/Samoa  US/Samoa
 America/Adak  America/
Atka  Etc/GMT+10  HST
 Pacific/Fakaofo  Pacific/
Honolulu  Pacific/Johnston

 PRT  SystemV/AST4
 SystemV/AST4ADT
 America/St_Johns  CNT
 Canada/Newfoundland
 AGT  America/Araguaina
 America/Belem  America/
Buenos_Aires  America/
Catamarca  America/
Cayenne  America/
Cordoba  America/Fortaleza
 America/Godthab  America/
Jujuy

 Africa/Khartoum  Africa/
Mogadishu  Africa/Nairobi
 Antarctica/Syowa  Asia/Aden
 Asia/Baghdad  Asia/Bahrain
 Asia/Kuwait  Asia/Qatar
 Asia/Riyadh  EAT  Etc/GMT-3
 Europe/Moscow  Indian/
Antananarivo  Indian/Comoro
 Indian/Mayotte

 Pacific/Rarotonga  Pacific/
Tahiti  SystemV/HST10
 US/Aleutian  US/Hawaii
 Pacific/Marquesas  AST
 America/Anchorage
 America/Juneau  America/
Nome  America/Yakutat
 Etc/GMT+9  Pacific/
Gambier  SystemV/YST9
 SystemV/YST9YDT  US/
Alaska  America/Dawson

 America/Maceio  America/
Mendoza  America/
Miquelon  America/
Montevideo  America/
Paramaribo  America/
Recife  America/Rosario
 America/Sao_Paulo
 Antarctica/Rothera  BET
 Brazil/East  Etc/GMT+3
 America/Noronha  Atlantic/
South_Georgia  Brazil/
DeNoronha  Etc/GMT+2
 America/Scoresbysund

 W-SU  Asia/Riyadh87  Asia/
Riyadh88  Asia/Riyadh89
 Mideast/Riyadh87  Mideast/
Riyadh88  Mideast/Riyadh89
 Asia/Tehran  Iran  Asia/Aqtau
 Asia/Baku  Asia/Dubai  Asia/
Muscat  Asia/Oral  Asia/Tbilisi
 Asia/Yerevan  Etc/GMT-4

 America/Ensenada
 America/Los_Angeles
 America/Tijuana
 America/Vancouver
 America/Whitehorse
 Canada/Pacific  Canada/
Yukon  Etc/GMT+8
 Mexico/BajaNorte
 PST  PST8PDT  Pacific/
Pitcairn  SystemV/PST8
 SystemV/PST8PDT  US/
Pacific  US/Pacific-New
 America/Boise  America/
Cambridge_Bay  America/
Chihuahua  America/
Dawson_Creek  America/

 Atlantic/Azores  Atlantic/
Cape_Verde  Etc/GMT+1
 Africa/Abidjan  Africa/
Accra  Africa/Bamako
 Africa/Banjul  Africa/
Bissau  Africa/Casablanca
 Africa/Conakry  Africa/
Dakar  Africa/El_Aaiun
 Africa/Freetown  Africa/
Lome  Africa/Monrovia
 Africa/Nouakchott  Africa/
Ouagadougou  Africa/
Sao_Tome  Africa/Timbuktu
 America/Danmarkshavn
 Atlantic/Canary  Atlantic/
Faeroe  Atlantic/Madeira

 Europe/Samara  Indian/Mahe
 Indian/Mauritius  Indian/
Reunion  NET  Asia/Kabul
 Asia/Aqtobe  Asia/Ashgabat
 Asia/Ashkhabad  Asia/
Bishkek  Asia/Dushanbe  Asia/
Karachi  Asia/Samarkand  Asia/
Tashkent  Asia/Yekaterinburg
 Etc/GMT-5  Indian/Kerguelen
 Indian/Maldives  PLT
 Asia/Calcutta  IST  Asia/
Katmandu  Antarctica/Mawson
 Antarctica/Vostok  Asia/
Almaty  Asia/Colombo  Asia/
Dacca  Asia/Dhaka  Asia/
Novosibirsk  Asia/Omsk  Asia/
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Denver  America/
Edmonton  America/
Hermosillo  America/
Inuvik  America/Mazatlan
 America/Phoenix
 America/Shiprock
 America/Yellowknife
 Canada/Mountain  Etc/
GMT+7  MST  MST7MDT
 Mexico/BajaSur  Navajo
 PNT  SystemV/MST7
 SystemV/MST7MDT  US/
Arizona  US/Mountain
 America/Belize  America/
Cancun  America/Chicago
 America/Costa_Rica
 America/El_Salvador
 America/Guatemala
 America/Managua
 America/Menominee
 America/Monterrey

 Atlantic/Reykjavik  Atlantic/
St_Helena  Eire  Etc/GMT
 Etc/GMT+0  Etc/GMT-0
 Etc/GMT0  Etc/Greenwich
 Etc/UCT  Etc/UTC  Etc/
Universal  Etc/Zulu  Europe/
Belfast  Europe/Dublin
 Europe/Lisbon  Europe/
London  GB  GB-Eire  GMT
 GMT0  Greenwich  Iceland
 Portugal  UCT  UTC

Qyzylorda  Asia/Thimbu  Asia/
Thimphu  BST  Etc/GMT-6
 Indian/Chagos  Asia/Rangoon
 Indian/Cocos  Antarctica/Davis
 Asia/Bangkok  Asia/Hovd
 Asia/Jakarta  Asia/Krasnoyarsk
 Asia/Phnom_Penh  Asia/
Pontianak  Asia/Saigon  Asia/
Vientiane  Etc/GMT-7

 America/Merida
 America/Mexico_City
 America/North_Dakota/
Center  America/
Rainy_River  America/
Rankin_Inlet  America/
Regina  America/
Swift_Current  America/
Tegucigalpa  America/
Winnipeg  CST  CST6CDT
 Canada/Central  Canada/
East-Saskatchewan
 Canada/Saskatchewan
 Chile/EasterIsland
 Etc/GMT+6  Mexico/
General  Pacific/Easter
 Pacific/Galapagos
 SystemV/CST6  SystemV/
CST6CDT  US/Central
 America/Bogota  America/
Cayman  America/
Detroit  America/
Eirunepe  America/
Fort_Wayne  America/
Grand_Turk  America/
Guayaquil  America/
Havana  America/
Indiana/Indianapolis
 America/Indiana/
Knox  America/Indiana/

 Universal  WET  Zulu
 Africa/Algiers  Africa/
Bangui  Africa/Brazzaville
 Africa/Ceuta  Africa/Douala
 Africa/Kinshasa  Africa/
Lagos  Africa/Libreville
 Africa/Luanda  Africa/
Malabo  Africa/Ndjamena
 Africa/Niamey  Africa/
Porto-Novo  Africa/Tunis
 Africa/Windhoek  Arctic/
Longyearbyen  Atlantic/
Jan_Mayen  CET  ECT
 Etc/GMT-1  Europe/
Amsterdam  Europe/
Andorra  Europe/Belgrade
 Europe/Berlin  Europe/
Bratislava  Europe/Brussels
 Europe/Budapest  Europe/
Copenhagen  Europe/
Gibraltar  Europe/Ljubljana
 Europe/Luxembourg
 Europe/Madrid  Europe/
Malta  Europe/Monaco
 Europe/Oslo  Europe/Paris
Europe/Prague  Europe/
Rome  Europe/San_Marino
 Europe/Sarajevo  Europe/
Skopje  Europe/Stockholm

 Indian/Christmas  VST
 Antarctica/Casey  Asia/
Brunei  Asia/Chongqing  Asia/
Chungking  Asia/Harbin  Asia/
Hong_Kong  Asia/Irkutsk  Asia/
Kashgar  Asia/Kuala_Lumpur
 Asia/Kuching  Asia/Macao
 Asia/Macau  Asia/Makassar
 Asia/Manila  Asia/Shanghai
 Asia/Singapore  Asia/Taipei
 Asia/Ujung_Pandang  Asia/
Ulaanbaatar  Asia/Ulan_Bator
 Asia/Urumqi  Australia/
Perth  Australia/West  CTT
 Etc/GMT-8  Hongkong  PRC
 Singapore  Asia/Choibalsan
 Asia/Dili  Asia/Jayapura
 Asia/Pyongyang  Asia/
Seoul  Asia/Tokyo  Asia/
Yakutsk  Etc/GMT-9  JST  Japan
 Pacific/Palau  ROK  ACT
 Australia/Adelaide  Australia/
Broken_Hill  Australia/Darwin
 Australia/North
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Marengo  America/
Indiana/Vevay  America/
Indianapolis  America/
Iqaluit  America/Jamaica
 America/Kentucky/
Louisville  America/
Kentucky/Monticello
 America/Knox_IN
 America/Lima  America/
Louisville  America/
Montreal  America/Nassau
 America/New_York
 America/Nipigon
 America/Panama

  Europe/Tirane  Europe/
Vaduz

 America/Pangnirtung
 America/Port-au-Prince
 America/Porto_Acre
 America/Rio_Branco
 America/Thunder_Bay
 Brazil/Acre  Canada/
Eastern  Cuba  EST
 EST5EDT  Etc/GMT+5
 IET  Jamaica  SystemV/
EST5  SystemV/EST5EDT
 US/East-Indiana  US/
Eastern  US/Indiana-
Starke  US/Michigan
 America/Anguilla
 America/Antigua
 America/Aruba  America/
Asuncion  America/
Barbados  America/
Boa_Vista  America/
Caracas  America/
Cuiaba  America/
Curacao  America/
Dominica  America/
Glace_Bay  America/
Goose_Bay  America/
Grenada  America/
Guadeloupe  America/
Guyana  America/
Halifax  America/
La_Paz  America/
Manaus  America/
Martinique  America/
Montserrat  America/
Port_of_Spain  America/
Porto_Velho  America/
Puerto_Rico  America/
Santiago  America/

 Europe/Vatican  Europe/
Vienna  Europe/Warsaw
 Europe/Zagreb  Europe/
Zurich  MET  Poland  ART
 Africa/Blantyre  Africa/
Bujumbura  Africa/Cairo
 Africa/Gaborone  Africa/
Harare  Africa/Johannesburg
 Africa/Kigali  Africa/
Lubumbashi  Africa/Lusaka
 Africa/Maputo  Africa/
Maseru  Africa/Mbabane
 Africa/Tripoli  Asia/Amman
 Asia/Beirut  Asia/Damascus
 Asia/Gaza  Asia/Istanbul
 Asia/Jerusalem  Asia/
Nicosia  Asia/Tel_Aviv
 CAT  EET  Egypt  Etc/
GMT-2  Europe/Athens
 Europe/Bucharest  Europe/
Chisinau  Europe/Helsinki
 Europe/Istanbul  Europe/
Kaliningrad  Europe/Kiev
 Europe/Minsk  Europe/
Nicosia  Europe/Riga
 Europe/Simferopol  Europe/
Sofia  Europe/Tallinn
 Europe/Tiraspol  Europe/
Uzhgorod

 Australia/South  Australia/
Yancowinna  AET  Antarctica/
DumontDUrville  Asia/Sakhalin
 Asia/Vladivostok  Australia/
ACT  Australia/Brisbane
 Australia/Canberra  Australia/
Hobart  Australia/Lindeman
 Australia/Melbourne
 Australia/NSW  Australia/
Queensland  Australia/Sydney
 Australia/Tasmania Australia/
Victoria  Etc/GMT-10  Pacific/
Guam  Pacific/Port_Moresby
 Pacific/Saipan  Pacific/Truk
 Pacific/Yap  Australia/LHI
 Australia/Lord_Howe  Asia/
Magadan  Etc/GMT-11  Pacific/
Efate  Pacific/Guadalcanal
 Pacific/Kosrae  Pacific/Noumea
 Pacific/Ponape  SST  Pacific/
Norfolk  Antarctica/McMurdo
 Antarctica/South_Pole  Asia/
Anadyr  Asia/Kamchatka  Etc/
GMT-12  Kwajalein  NST  NZ
 Pacific/Auckland  Pacific/
Fiji  Pacific/Funafuti  Pacific/
Kwajalein  Pacific/Majuro
 Pacific/Nauru
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Santo_Domingo America/
St_Kitts  America/St_Lucia
 America/St_Thomas
 America/St_Vincent

 America/Thule  America/
Tortola  America/Virgin
 Antarctica/Palmer
 Atlantic/Bermuda
 Atlantic/Stanley  Brazil/
West  Canada/Atlantic
 Chile/Continental  Etc/
GMT+4

 Europe/Vilnius
 Europe/Zaporozhye
 Israel  Libya  Turkey
 Africa/Addis_Ababa
 Africa/Asmera  Africa/
Dar_es_Salaam  Africa/
Djibouti  Africa/Kampala

 Pacific/Tarawa  Pacific/Wake
 Pacific/Wallis  NZ-CHAT
 Pacific/Chatham  Etc/GMT-13
 Pacific/Enderbury  Pacific/
Tongatapu  Etc/GMT-14
 Pacific/Kiritimati
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