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1 Natural Business Services Tools and Utilities

Natural Business Services Tools and Ultilities describes the tools and utilities provided by Natural
Business Services (NBS).

This documentation is intended for developers who are familiar with Natural Business Services
and want to learn how to use the tools and utilities supplied with NBS.

Natural Business Services Tools and Ultilities covers the following topics:

Broker Driver Program |Describes the Broker Driver program, which you can use to send and receive
low-level Broker calls for testing purposes.

NBS Tester Describes the NBS tester, which you can use to test the connections used to
access your business services.

NBS Server Monitor |Describes the Server Monitor application provided by Natural Business
Services (NBS). The NBS Server Monitor provides GUI access to the Business
Service Administration subsystem, where you can monitor and control active
NBS servers.







2 Broker Driver Program

You can use the Broker Driver program to send and receive low-level EntireX Broker calls for
testing purposes.

» To access the Broker Driver program:

1  Select All Programs > Software AG Natural Business Services > Broker Driver on the Start
menu.

The Broker Driver window is displayed. For example:

c Broker Driver,

Send Data:

E Communication -
ErokerID
ConversationID
Function SEND
KernelSecurity
Security_Token 00 00 00 00 00 00 DO M
ServiceDef i s
i it Receive Data;
E Compress / Encrypt
CompressLevel COMPRESS_LEYEL_O
EncryptLevel NOME
= Misc
AdapterError
AdCount o
APIType TYPE1
APTYersion YERSS ﬂ

UserID: | Last Response:

Password: | [~ EBCDIC [ Display as Hex [ Reset Corwersation ID Gol Receive

2 Define information about the Broker call in the appropriate input fields.




Broker Driver Program

For example, the Broker ID and Kernel Security settings for the call. Use the scroll bar to display
additional input fields.

) Note: For information on the Broker call settings, see the EntireX Communicator docu-

mentation.

3 Type the user ID and password for the connection you are testing.

4  Select Go!.

The Broker Driver program sends the data to the server.

5  Select Receive to display the data returned from the server.

4 Natural Business Services Tools and Utilities



3 NBS Tester
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NBS Tester

Using the NBS Tester, you can build a test suite to test the connections used to access your business
services. The NBS Tester is available on the Tools menu in the Natural Business Services Natural
plug-in or as a stand-alone utility on the Start menu.

® If you run this utility from the Natural plug-in, the current mapped connection is tested.

® If you run the utility from the Start menu, you can select which connection to test.

This section covers the following topics:

Build a New Test Suite

» To create a new test suite:

1  Select All Programs > Software AG Natural Business Services > NBS Tester on the Start
menu.

The NBS Tester window is displayed. For example:

- MBS Tester

File = Help =

Design | Log

2 Select New on the File menu.

Test Suite is displayed in the upper left corner of the window.
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NBS Tester

3  Select Test Suite.

The Design tab becomes active. For example:

 NBS Tester

File ~ Help =

Design | log |

Connection ID: | b |

Motes:

Select the connection ID in Connection ID.
Type the user ID and password for the connection.
Open the context menu for Test Suite.

Select Add Test.

NN O

The Design tab displays the specifications for a new test. For example:

Natural Business Services Tools and Ultilities 7



NBS Tester

ct MBS Tester
File~ Help ~

= Test Suite

Design | Laog

Marng: |New Test |

Cateqgary: | |

[ Always download PDA definitions befare running
Conneckion

Use parent suite's connection

| Development 1

Credentials
Use parert suite's credentials

Iterations: |1 =

Motes:

8  Type a descriptive name for the test you are creating in Name (for this example, type "Test
example").
The name is displayed in the Test Suite tree. You can optionally specify the following inform-
ation for the test:
Option Description
Category Name of the category for this test suite (for example, Development).
Always download PDA definition |If this option is selected, the PDA definition is downloaded before
before running the test is run.
Connection/Use parent suite’s If this option is selected, the test suite is part of another test suite
connection and will use the parent test suite’s connection ID. If this option is
not selected, select the connection ID to use for this test suite.
Credentials/Use parent suite’s If this option is selected, the test suite is part of another test suite
credentials and will use the parent test suite’s credentials. If this option is not
selected, type the user ID and password to use for this test suite.
Iterations Number of times to run the test.
Notes Information about the test suite.
8 Natural Business Services Tools and Utilities



NBS Tester

9  Open the context menu for the new test in the Test Suite tree.

For this example, the Test example node.

10 Select Add Actions.

The Select Actions window is displayed. For example:

Select Actions E|

D Logon

] populate data
[] Load PDA

[ call service
[] show FDA
[ verify data
[] Logoff

[ if ] l Zancel

This window lists the actions available for the test suite.

11 Select the actions you want to test.
For this example, select the following actions:

® Populate data
= Call service

Show PDA

Verify data

12 Select OK.
13 Expand the Test example node.

Natural Business Services Tools and Utilities 9



NBS Tester

For example:

+ NBS Tester

=13

File v Help ~
= Tesk Suite Design | Lag |
= ple
Populate data {Populate Data) Mame: |Test example |
Call Service {Call Service)
Cakeqory: |

Show PDA {Show PDAY
Werify Data (Verify Data)

Connection
Use parent suite's connection

[] ahways download PDA definitions before running

| Development 1

Credentials
Use parent suite's credentials

Iterations: |1 Er

Motes:

14 Select Call Service to specify which service to call.

The call service information is displayed on the Design tab. For example:

Natural Business Services Tools and Utilities
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NBS Tester

MBS Tester |-_| |E| [z|
File~ Help ~
= Test Suite Design |ng
= Test example
Populate data (Populate Data) j(oH |Ca|| Service |
Call Service (Call Service) Bomain:
Show PDa {Shaw POA) omain: | |
verify Data (Yerify Data) e ETIER | |
oiors [ ][]
Method: | |

PD& send Flags: | |

(<] (=]

15 Type the following information:

Field Input
Domain DEMO

Service name |Calculator

Method Add

] Note: Ensure the input values use the same case as indicated above.

Optionally, you can:

® Type a different call service in ID

® Type a different version number in Version (by default, 1.1.1)

16 Select Populate data to specify which data to send to the service for the test.

Natural Business Services Tools and Ultilities

11



NBS Tester

17
18

19

The Populate data information is displayed on the Design tab. For example:

- NBS Tester

File v Help ~
= Test Suite Design ||_og |
= Test example

Populate data (Populate Data) ] |P0pulate data

Call Service {Call Service)

Target action:
Show PDA (Show PDA) L |

Yerify Data (Werify Data) Fields:

Select Call Service in Target action.

Type the following two lines in Name:

INPUT-DATA . #fFIRST-NUM
INPUT-DATA.#fSECOND-NUM

Type "1" in Value for both numbers.

For example:

12
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NBS Tester

MBS Tester

B
Eile = Help =
- Test Suite Desion |Log |
= Test example
Populate data {Populate Data) I |F‘0pulate data |
Call Service (Call Service) Target action: |Ca|| Service ¥ |
Show PO (Show POA)
Werify Data (Werify Data) Fields:
Mame Index | Yalue
IMPUT-DATA, #FIRST-MUM 1
IMPUT-DA T A, #SECOMND-MUM 1
= © I

20 Select Show PDA.

This action allows you to debug the service for testing purposes. The Show PDA information

is displayed on the Design tab. For example:

MBS Tester

Eile = Help =
= Test Suite

FEX

= Test example

Populate data (Populate Data)
Call Service (Call Service)
Show PO (Show POAY

Verify Data (Verify Daka)

(¢] ]

Design ||_Dg |

Wait For the PO viewer to close
Enabled

21 Select Call Service in Source action.

Natural Business Services Tools and Ultilities
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NBS Tester

The source action must be specified. This value will be any call service in your test.

22 Select Verify Data to verify that the service is working correctly.

The Verify data information is displayed on the Design tab. For example:

o MBS Tester

File = Help -
= Test Suite Design | Log
= Test example 3
Populate data {Populate Data) D =
Call Service {Call Service) .
Show PDA (Show PDA) Source action:

Verify Data (Verify Data)

Fields

Run

23 Select Call Service in Source action.

24 Type the following in Name:

OUTPUT-DATA.#RESULT

] Note: Regex indicates a Regular Expression. You can use this field to specify a Regex
pattern to check for matches.

25 Type "2"in Value.

For example:
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NBS Tester

MBS Tester. |:| |§| E|
Eile = Help =

= Test Suite Design | Log
= Test example

Populate data (Populate Data) I Werify Data

Call Service (Call Service)

Show PO {Shaw POA) Source ackion: |Call Service -

3

iFy Data)

Fields
Mame Index Regex Walue
CQUTPUT-DATA #RESULT 2
@ | a0 ~ I

This value indicates that the expected result of the test is 2.

26 Select Run.

Because you selected Show PDA, the Natural Data Area Viewer window is displayed. For
example:

c Matural Data Area Yiewer Z E| gl

File =
=

= &

Field Marne: Index Yalue
=1 IMPUT-DATA
2 #FUMCTION (A30) Add
2 #FIRST-MUM (NS 2) 1
2 #SECOMD-MUM (NS 2) 1
2 #SUCCESS-CRITERTA (WS.0) 0
= 1 QUTPUT-DATA
2 #RESULT (MN11.2) 2
Z #TIME (T} 2118/2009 5:03:45 PM
2 #SUCCESS (L) True

This window displays the INPUT/OUTPUT data in the PDA for the service.
27 Close the window.
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NBS Tester

28 Select the Log tab to see the results of the test.

For example:

c+ MBS Tester

File = Help ~

B Test Suite Design | Log |
=" Test example

" Populate data {Populate Data) Level: Filter ~

W« Call Service (Call Service)

Started Test Suite using connection: 'Development 1' UserID:
Calling Enviromment serwvice. ..
Enviromment call succeeded -» MBS Data Installed:True Wersio
Test Started: Test example. Using ComnnectionID: 'Development
Iteration Started: Test example (1 of 1)
Populate data: Started
E Populate data: Passed Time: 0.00 (seconds)
Call Serwvice: Started
'S Call Serwvice: Passed Time: 0.53 (zeconds)
Show PDA: Started
Zhow PDA: Passed Time: 150.8E5 (seconds)
Verify Data: Started
Verify Data: Passed Time: 0.00 (seconds)
Test example passed (1 of 1)
Suite completed -¥ Test count: 1 failures: 0

| #
b4

29 Select Save on the File menu to save the test suite.
A window is displayed to type a name for the test and select a location to store the test suite.

| Note: You can repeat this procedure to create additional test suites.

Add a Test to an Existing Test Suite

After saving a test suite, you can add other tests to the suite.

» To add a test to an existing test suite:

1  Select Open on the File menu.

A selection window is displayed.

2 Select the test suite.

The selected test suite is displayed in the NBS Tester window.

16 Natural Business Services Tools and Utilities



NBS Tester

Expand the Test node to see the actions for the test. For example:

MBS Tester

File = Help =
=] Test Suite Diesign ||_Ug |
= Test example
Populate data (Populate Data) Connection ID: |Deve|opment 1 vl
Call Service (Call Sarvice)
Shaw PDA (Show PDA) User ID:

werify Data (verify Data)

Motes:

Optionally, you can use this window to:

® Change the connection ID for the new test

® Change the user ID or password

3 Open the context menu for Test Suite.

4  Select Add Test.

The new test is added to the test suite. For example:

Natural Business Services Tools and Ultilities 17



NBS Tester

c* NBS Tester

File = Help ~
= Test Suite Design | Lag

= Test example 7
Populate data (Populate Data) Marne: |New Test | —
Call Service {Call Service)
Show PDA (Shaw PDA) Category: | |
Verify Data (Verify Data) [ aways download PO definitions befare running

Zonneckion

Use parent suite's connection

E] |Devel0pment 1 v |

Credentials
Use parent suite's credentials

4

Iterations: |1

Notes: ¥

5  Enter the specifications for the new test.

For information, see Build a New Test Suite.

6  Select Save on the File menu to save the changes.

Reorder a Test in an Existing Test Suite

You can reorder the tests in an existing test suite.

» To reorder a test in an existing test suite:

1  Select Open on the File menu.

A selection window is displayed.

2 Select the test suite.

The selected test suite is displayed in the NBS Tester window.
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NBS Tester

Expand the Test node to see the actions for the test. For example:

MBS Tester

File = Help =
= Design | Log |
= Test example
Populate data (Populate Data) Connection ID: |Deve|opment 1 vl
Call Service (Call Sarvice)
Show PDA (Show PDA) User ID:
werify Data (verify Data)

Motes:

3 Select the test you want to reorder.

4  Select the up or down arrow to move the test to a new position.

In the following example, the Call Service action was moved up in the list:

Natural Business Services Tools and Ultilities 19



NBS Tester

- MBS Tester

File ~ Help ~

= Test Suite

= Test example

Call Service (Call Service)

|Ca|| Service

Populate data {Populate Data) |

Show POA (Show PDAY T

Werify Drata (verify Data) Service name: |

ersion:

Method: |
+

PDA send Flags: |

5  Select Save on the File menu to save the changes.

Delete a Test Suite

» To delete an existing test suite:

1 Open the context menu for the test suite.
2 Select Delete.

3 Select Save on the File menu to save the changes.

Delete a Test from a Test Suite

» To delete a test from an existing test suite:

1 Open the context menu for the test suite.
2 Select Delete.

3  Select Save on the File menu to save the changes.

20

Natural Business Services Tools and Utilities



NBS Tester

Access the NBS Configuration Utility

You can use the NBS Tester to access the Configuration utility.

» To access the Configuration utility:

»  Select NBS Configuration on the File menu.

The Configuration utility is displayed. For example:

 Configuration Utility (C:\Program FilesiSoftware AGMWatural Business Servicesi¥ 5. 3\ClientConfig.oanl)

Connections | visual Studia Add-In

File name: |C:'|,D0cuments and Settingsiall Usersiapplication DatalSoftware AGINatural Business Services\Configuration’DispatchClient. Config |

Connection I0 Descripkion m| Ervironment || Optional
% Production
o Development 2 SPoD conneckion to us Connection ID: |Pr0ducti0n
W MaT4z

D SecuUre server

O Education{SPod) Mews SPoD connection

- Encrypion: Mang
'\D Development 1

O Development 3 SPal connection to us Compression: Mone

Eernel security: Auto

Decimal separator:

4

Server Parameters

Broker ID:  |ETBOOL | port: | 1971

Server class: |BUSINESS |

Server Name Broker Service
Dispatcher: |DISPP.TCH | | |
CFactory: |CFACTORV | | |
s J attach: |ATTACH | | |
| | |

H

K

For information about the settings on this panel, see:

® For the Eclipse plug-in, Configure Connections

* For the Visual Studio add-in, Configure Connections
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4 NBS Server Monitor

= Access the NBS Server Monitor

m Use the NBS Server Monitor WINAOWS ..........cooiiiiiiiiiiiie et
= Arrange the NBS Server Monitor WINAOWS ...........ooiiiiiiieiiiii e

= Refresh Data .......cccoceeeiiinnnnns
= Set Security Credentials ..........

= Send Commands to the Servers

m Create Trace Files ..................
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NBS Server Monitor

The NBS Server Monitor is a GUI application that provides functionality similar to the character-
based Manage Servers function in the Business Service Administration subsystem ("SA MS" on
the command line). Use the NBS Server Monitor windows to monitor and control active Natural
Business Services servers. This application accepts the same commands as are available using the
Manage Servers function. The only restriction is that at least one instance of the Attach Manager
must be running, which prevents its use to initiate the first session of that server.

Before you can use the NBS Server Monitor, you must specify the development configuration
settings for the client. For information see Configure the Client Component.

Access the NBS Server Monitor

» To access the NBS Server Monitor:

= Select All Programs > Software AG Natural Business Services > Server Monitor on the Start
menu.

The NBS Server Monitor is displayed. For example:

. \NBS Server Monitor,

: Commands Trace Wew Tools Help

=4 BKR13003:4010
=4y ATTACH-DEY {set)
. By ATTACH-DEY
¢ B Instance #1 (Token: BF78S
-y DISPATCH-DEY
&k DISPATCH-DEY-BATCH v

< i | 3|

o= 2l |:|

Information %]

Retrieving Server List For broker: BKR 1300340 » |
Retrieving MBS Services for:BKR 130034010 Bl
Retrieve done L
M|

£ 1l ] >
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NBS Server Monitor

The NBS Server Monitor attempts to connect to all pre-defined servers and display detailed in-
formation about the servers that are currently running.

Use the NBS Server Monitor Windows

The following table describes the NBS Server Monitor windows:

Window Description

Main Displays the commands sent to the servers. Commands issued via the context menu are
also recorded in this window, which allows you to modify and re-submit the commands
to the same server. The main window also contains the output from most commands sent
to the servers.

Server Explorer |Contains a tree view of all pre-defined Broker nodes, as well as the names of all the NBS
servers and services currently running under each node.

Properties Contains detailed information about the server selected in the Server Explorer window.
Information Contains additional details about the server selected in the Server Explorer window.
Status Contains information about the status of the connection for each Broker node.

Tip: Use this window as a starting point for debugging communication problems.

Arrange the NBS Server Monitor Windows

Each of the NBS Server Monitor windows can be displayed in the following modes:

= docked
" floating
= hidden

= quto-hide

» To select the display mode:

1 Open the context menu for the window’s title bar.

2 Select one of the display modes listed on the submenu.

| Note: You can also use drag-and-drop functionality to move any window by its title bar.
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NBS Server Monitor

» To restore all windows to their original arrangement:

m  Select Reset on the View menu.

Refresh Data

Since the server information is constantly changing, you may want to refresh the data periodically.
This section describes how to refresh the data manually and how to set up the NBS Server Mon-
itor to automatically retrieve fresh data at predefined intervals.

» To manually refresh data:

s Select Refresh on the View menu.

» To set up the NBS Server Monitor to automatically refresh data:

1  Select Configuration on the Tools menu.

The Server Monitor Configuration window is displayed. For example:

=+ Server Monitor, Configuration E|

[~ Enable auto refresh

Refresh interval: El (seconds)

[v Load window layout on start

UserID:  |GUEST

Wik time: |155

[u]4 Cancel

2  Select Enable auto refresh.

The Refresh interval option is enabled.
3 Select the number of seconds before refreshing data.

4  Select OK.
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NBS Server Monitor

Set Security Credentials

» To set Broker security credentials for a remote Broker node:

1 Open the context menu for the Broker node in the Server Explorer window.
. Tip: You can also select Set Credentials on the Tools menu.
The Set Credentials window is displayed, prompting you to enter your user ID and password.
2 Select OK.

3  Select Refresh on the View menu to refresh the NBS Server Monitor window.

Send Commands to the Servers

You can send commands to any server, provided there is at least one copy of an Attach Manager
running under the corresponding Broker node.

» To send commands to a server:

1 Open the context menu for the server in the Server Explorer window.
Tip: You can also open the Commands menu.

¥

2 Select the command from the commands listed.

Create Trace Files

» To create trace files for any active server:

1 Open the context menu for the server in the Server Explorer window.

Tip: You can also select Create on the Trace menu.

2 Select Trace.
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